IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS
IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS
Version 5.4.0

Monitoring Performance from
Performance Expert Client
IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS
IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS
Version 5.4.0

Monitoring Performance from Performance Expert Client
First edition, December 2016

This edition applies to the following releases and to all subsequent releases and modifications until otherwise indicated in new editions:

- IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS, version 5, release 4, modification 0 (5655-W37)
- IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS, version 5, release 4, modification 0 (5655-W38)

This edition replaces SH12-7051-00.

US Government Users Restricted Rights – Use, duplication or disclosure restricted by GSA ADP Schedule Contract with IBM Corp.
## Contents

**About this information** ................................................................. vii
Conventions used in the OMEGAMON documentation ........................ vii
   Terminology used ........................................................................... x
   How to read syntax diagrams ........................................................... x
   Where to find information ............................................................... xii
Service updates and support information .......................................... xii
   Accessibility features ................................................................. xiii
   How to send your comments ......................................................... xiii

**What's new** ................................................................................... xv

**Part 1. Before you begin** ............................................................... 1

**Chapter 1. What does OMEGAMON XE for DB2 PE do?** ............... 3

**Chapter 2. Components and features of Performance Expert Client** ................................. 5
Online monitoring and reporting ......................................................... 5
Performance Warehouse management ............................................. 6
Buffer pool analysis ......................................................................... 6

**Chapter 3. Getting started** ........................................................... 7
Starting Performance Expert Client .................................................. 8
Working with the System Overview window ...................................... 8
Defining the DB2 systems that must be monitored .......................... 10
   Defining a DB2 subsystem ........................................................... 10
   Defining a DB2 Connect gateway .................................................. 12
   Changing the properties of a DB2 subsystem ............................... 13
   Changing the properties of a DB2 Connect gateway .................... 13
Organizing the DB2 systems ............................................................ 13
Specifying global settings .............................................................. 14
Logging on to DB2 systems .............................................................. 14
   Logging on to one DB2 subsystem or DB2 Connect gateway ....... 14
   Logging on to several DB2 subsystems ......................................... 14
Starting several monitoring functions in one or more DB2 subsystems 15
Starting a monitoring function from the DB2 Control Center ........... 15
Issuing DB2 commands .................................................................. 16
Getting help ................................................................................... 16
Logging off from DB2 systems ......................................................... 16
Deleting a DB2 system .................................................................. 17
Leaving Performance Expert Client ................................................ 17

**Part 2. Online monitoring and reporting** ....................................... 19

**Chapter 4. Monitoring threads** ..................................................... 21
Viewing all connected threads ........................................................ 21
Viewing details of a selected thread ............................................... 22
Sorting threads ............................................................................. 23
Filtering threads .......................................................................... 24
Canceling threads ......................................................................... 25
Creating and viewing SQL activity traces ....................................... 26

**Chapter 5. Resolving locking conflicts** .......................................... 29
Viewing all threads involved in a locking situation ......................... 29

© Copyright IBM Corp. 1997, 2016
Viewing the threads associated with a specific resource. ......................................................... 30

Chapter 6. Viewing DB2 Statistics ................................................................. 31
Statistics values ............................................................... 31
Processing modes ............................................................ 32
   Regular processing ......................................................... 32
   Interval processing ......................................................... 33
   Delta processing ............................................................ 33
Viewing Statistics information ......................................................... 34
Viewing the SQL statements in the dynamic SQL cache ......................................................... 35
Refreshing buffer pool Statistics ......................................................... 36

Chapter 7. Viewing system health ............................................................... 37
Getting started ............................................................... 38
Scenario 1: Viewing current system health ......................................................... 39
Scenario 2: Viewing past system health ......................................................... 41
Scenario 3: Creating a data view ......................................................... 41
Changing the properties of a data view ......................................................... 42
   Changing the method for displaying the counters ......................................................... 42
      Non-stacked bar chart ......................................................... 43
      Non-stacked line chart ......................................................... 43
      Stacked bar chart ............................................................ 44
      Stacked area chart ............................................................ 44
      Stacked-to-100% bar chart ......................................................... 45
   Specifying a global threshold ......................................................... 45
   Specifying and adjusting single thresholds ......................................................... 46
   Changing the appearance of the bars, lines, or areas in the chart. ......................................................... 47
   Changing the number of visible snapshots in the chart ......................................................... 47
Freezing the display of snapshots ......................................................... 47
Displaying data views as performance graphs in the System Overview window ......................................................... 47
Reusing data-view and data-group configurations ......................................................... 48
Gaps and sudden drops or rises in charts ......................................................... 48

Chapter 8. Monitoring activities of DB2 Connect gateways and connections of DCS applications ......................................................... 49
Viewing all DB2 Connect gateways connected to a DB2 subsystem ......................................................... 51
Viewing Statistics details on a specific DB2 Connect gateway ......................................................... 51
Viewing information about all DCS applications connected to any DB2 subsystem ......................................................... 52
Viewing information about the DCS applications related to a thread ......................................................... 52
The gateway snapshot time ......................................................... 53

Chapter 9. Viewing DB2 system parameters ......................................................... 55

Chapter 10. Working with exception processing ......................................................... 57
Starting exception processing ......................................................... 57
Processing event exceptions ......................................................... 58
   Starting and stopping event exception processing ......................................................... 59
   Viewing event exceptions ......................................................... 59
   Viewing deadlocks ......................................................... 60
   Viewing details on a deadlock ......................................................... 60
Processing periodic exceptions ......................................................... 61
   Establishing thresholds ......................................................... 61
   Starting and stopping periodic exception processing ......................................................... 62
   Viewing periodic exceptions ......................................................... 62
Working with the exception user exit ......................................................... 63

Chapter 11. Monitoring data sharing groups ......................................................... 65
Monitoring the threads of a data sharing group ......................................................... 65
Viewing Statistics on a data sharing group ......................................................... 66
<table>
<thead>
<tr>
<th>Chapter 21. Defining and running queries</th>
<th>109</th>
</tr>
</thead>
<tbody>
<tr>
<td>Managing query groups</td>
<td>109</td>
</tr>
<tr>
<td>Creating a query group</td>
<td>109</td>
</tr>
<tr>
<td>Changing a query group</td>
<td>110</td>
</tr>
<tr>
<td>Copying a query group</td>
<td>110</td>
</tr>
<tr>
<td>Managing queries</td>
<td>110</td>
</tr>
<tr>
<td>Creating a query</td>
<td>111</td>
</tr>
<tr>
<td>Changing a query</td>
<td>111</td>
</tr>
<tr>
<td>Copying or moving a query to another query group</td>
<td>111</td>
</tr>
<tr>
<td>Running a query</td>
<td>112</td>
</tr>
<tr>
<td>Specifying filter criteria</td>
<td>112</td>
</tr>
<tr>
<td>Resolving variables</td>
<td>113</td>
</tr>
<tr>
<td>Viewing the query results</td>
<td>113</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 22. Overview of the Performance Warehouse database</th>
<th>117</th>
</tr>
</thead>
<tbody>
<tr>
<td>The Performance Warehouse data tables</td>
<td>117</td>
</tr>
<tr>
<td>The LOADLOG table</td>
<td>119</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 23. Troubleshooting</th>
<th>121</th>
</tr>
</thead>
<tbody>
<tr>
<td>Creating a diagnostic report</td>
<td>121</td>
</tr>
<tr>
<td>Responding to dialog boxes</td>
<td>122</td>
</tr>
<tr>
<td>Troubleshooting for Performance Expert Client</td>
<td>122</td>
</tr>
<tr>
<td>Troubleshooting for Performance Warehouse</td>
<td>122</td>
</tr>
<tr>
<td>Solving code-page problems when accessing Performance Warehouse</td>
<td>122</td>
</tr>
<tr>
<td>Restarting the OMEGAMON Collector</td>
<td>123</td>
</tr>
<tr>
<td>Running a CONVERT step with an incorrect data set</td>
<td>123</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Chapter 24. Accessibility features in Performance Expert Client</th>
<th>125</th>
</tr>
</thead>
<tbody>
<tr>
<td>Operating all features by using the keyboard</td>
<td>125</td>
</tr>
<tr>
<td>Changing the system settings for colors, fonts, and accessibility options</td>
<td>127</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Part 5. Appendixes</th>
<th>129</th>
</tr>
</thead>
<tbody>
<tr>
<td>Notices</td>
<td>131</td>
</tr>
<tr>
<td>Trademarks</td>
<td>133</td>
</tr>
<tr>
<td>Terms and conditions for product documentation</td>
<td>133</td>
</tr>
<tr>
<td>Bibliography</td>
<td>135</td>
</tr>
<tr>
<td>Index</td>
<td>137</td>
</tr>
</tbody>
</table>
About this information

This information describes how to monitor and tune IBM® Database 2 products and create reports and traces using Performance Expert Client, which is one of the graphical interfaces of the following products:

- IBM Tivoli® OMEGAMON® XE for DB2® Performance Expert on z/OS®
- IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS

This information helps DB2 users perform the following tasks:

- Determine total DB2 performance and efficiency
- Analyze and improve SQL statements
- Tune DB2 systems and DB2 threads
- Identify the cause of performance problems

This information describes the individual tasks that you can perform with Performance Expert Client. For detailed information about the individual windows and the fields, buttons, and icons in the windows, refer to the Online Help. See “Getting help” on page 16 for information on how to request help.

The technical changes for this edition are summarized under “What's new” on page xv. Specific changes since the previous edition of this information are indicated by a vertical bar (|) to the left of a change. Editorial changes that have no technical significance are not noted.

Always check the IBM DB2 and IMS™ Tools Library web page and the Tivoli library page for the most current version of this information:

- Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS (PDFs and Techdocs on DB2 Tools Product Page)
- Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS (PDFs and Techdocs on DB2 Tools Product Page)

Who should read this information

This information is intended for those persons responsible for monitoring and tuning IBM Database 2 products and assumes a working knowledge of z/OS and OS/390®.

Conventions used in the OMEGAMON documentation

This information uses several conventions for special terms and actions, and operating system-dependent commands and paths.

Panels and figures

The panels and figures in this document are representations. Actual product panels might differ.
Symbols

The following symbols might appear in command syntax:

<table>
<thead>
<tr>
<th>Symbol</th>
<th>Usage</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>The or symbol is used to denote a choice. You can use the argument on the left or the argument on the right. For example: YES</td>
</tr>
<tr>
<td>In this example, you can specify YES or NO.</td>
<td></td>
</tr>
<tr>
<td>()</td>
<td>Denotes optional arguments. Arguments that are not enclosed in square brackets are required. For example: APPLDEST DEST (ALTDEST)</td>
</tr>
<tr>
<td>In this example, DEST is a required argument and ALTDEST is optional.</td>
<td></td>
</tr>
<tr>
<td>{}</td>
<td>Some documents use braces to denote mandatory arguments, or to group arguments for clarity. For example: COMPARE {workload} - REPORT={(SUMMARY</td>
</tr>
<tr>
<td>In this example, the workload variable is mandatory. The REPORT keyword must be specified with a value of SUMMARY or HISTOGRAM.</td>
<td></td>
</tr>
<tr>
<td>_</td>
<td>Default values are underscored. For example: COPY infile outfile - [COMPRESS={(YES</td>
</tr>
<tr>
<td>In this example, the COMPRESS keyword is optional. If specified, the only valid values are YES or NO. If omitted, the default is YES.</td>
<td></td>
</tr>
</tbody>
</table>

Notation conventions

The following conventions are used when referring to high-level qualifiers:

\textit{hilev} \quad A high-level qualifier. The high-level qualifier is the first prefix or set of prefixes in the data set name. Site-specific high-level qualifiers are shown in italics.

For example:

\begin{itemize}
  \item \textit{thilev} refers to the high-level qualifier for your target data set.
  \item \textit{rhilev} refers to the high-level qualifier for your runtime data set.
    
    For members in target libraries, the high-level qualifier is \textit{thilev} rather than \textit{rhilev}.
  \item \textit{shilev} refers to the SMP/E library high-level qualifier.
\end{itemize}

Typeface conventions

This information uses the following typeface conventions:

\textbf{Bold} \quad Interface controls (check boxes, push buttons, radio buttons, spin buttons, fields, folders, icons, list boxes, items inside list boxes, multicollected lists, containers, menu choices, menu names, tabs, property sheets), labels (such as \textit{Note:})
Keywords and parameters in text

*Italic*
- Words defined in text
- Emphasis of words (for example: Use the word *that* to introduce a restrictive clause.)
- New terms in text (except in a definition list)

*Monospaced*
- Examples and code examples
- File names, programming keywords, and other elements that are difficult to distinguish from surrounding text
- Message text and prompts addressed to the user
- Text that the user must type
- Values for arguments or command options

Significant elements

**Recommendation**
Provides guidance when more than one option is available.

**Related reading**
Refers you to other publications that contain relevant information.

**Requirement**
Identifies a condition that must be met to ensure that the product is functional.

**Restriction**
Identifies a restriction or limitation with this product or an associated procedure.

"Terminology used” on page x
IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS can be considered as a functional subset of IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS. Therefore the abbreviation OMEGAMON XE for DB2 PE or DB2 PE is used for both products. If a distinction is required, OMEGAMON XE for DB2 PM or DB2 PM is used explicitly.

“How to read syntax diagrams” on page x
The rules in this section apply to the syntax diagrams that are used in this publication.

“Where to find information” on page xii
You can access the documentation in several ways.

“Service updates and support information” on page xii
You can access support information for IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS and IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS on the Support home website, or you can use the IBM Support Assistant.

“Accessibility features” on page xiii
Accessibility features help people with a physical disability, such as restricted mobility or limited vision, or with other special needs, to use software products successfully. This Knowledge Center is developed to comply with the accessibility requirements of software products according to Section 508 of the Rehabilitation Act of the United States.

“How to send your comments” on page xiii
Your feedback is important in helping to provide the most accurate and high-quality information.
Terminology used

IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS can be considered as a functional subset of IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS. Therefore the abbreviation OMEGAMON XE for DB2 PE or DB2 PE is used for both products. If a distinction is required, OMEGAMON XE for DB2 PM or DB2 PM is used explicitly.

The following table shows the products that are described in this publication and the short names with which they are referred to throughout this publication:

Table 1. Product names and their short names

<table>
<thead>
<tr>
<th>Product name</th>
<th>Short name</th>
</tr>
</thead>
<tbody>
<tr>
<td>IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS</td>
<td>OMEGAMON XE for DB2 PE or DB2 PE</td>
</tr>
<tr>
<td>IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS</td>
<td>OMEGAMON XE for DB2 PM or DB2 PM</td>
</tr>
<tr>
<td>Buffer Pool Analyzer for z/OS or a particular subsystem</td>
<td>Buffer Pool Analyzer</td>
</tr>
<tr>
<td>IBM DB2 database for z/OS</td>
<td>DB2</td>
</tr>
</tbody>
</table>

• Performance Expert Client and Workstation Online Monitor designate the client component of DB2 PE.
  Prior to Version 5.4.0 the client component of DB2 PE also designated the end-user interface of Performance Expert for Multiplatforms, Performance Expert for Workgroups, and DB2 PE.

• OMEGAMON Collector designates the server component of DB2 PE.

How to read syntax diagrams

The rules in this section apply to the syntax diagrams that are used in this publication.

Arrow symbols

Read the syntax diagrams from left to right, from top to bottom, following the path of the line.

►►—— Two right arrows followed by a line indicate the beginning of a statement.

——► One right arrow at the end of a line indicates that the statement syntax is continued on the next line.

►—— One right arrow followed by a line indicates that a statement is continued from the previous line.

——►◄ A line followed by a right arrow and a left error indicates the end of a statement.

Conventions

• SQL commands appear in uppercase.
• Variables appear in italics (for example, column-name). They represent user-defined parameters or suboptions.
• When entering commands, separate parameters and keywords by at least one blank if there is no intervening punctuation.
• Enter punctuation marks (slashes, commas, periods, parentheses, quotation marks, equal signs) and numbers exactly as given.
• Footnotes are shown by a number in parentheses, for example, (1).

**Required items**
Required items appear on the horizontal line (the main path).

►►REQUIRED-ITEM

**Optional items**
Optional items appear below the main path.

►►REQUIRED-ITEM optional-item

If an optional item appears above the main path, that item has no effect on the execution of the statement and is used only for readability.

►►REQUIRED-ITEM optional-item

**Multiple required or optional items**
If you can choose from two or more items, they appear vertically in a stack. If you must choose one of the items, one item of the stack appears on the stack main path.

►►REQUIRED-ITEM

required-choice1

required-choice2

If choosing one of the items is optional, the entire stack appears below the main path.

►►required-choice1

required-choice2

**Repeatable items**
An arrow returning to the left above the main line indicates that an item can be repeated.

►►REQUIRED-ITEM repeatable-item

If the repeat arrow contains a comma, you must separate repeated items with a comma.

►►REQUIRED-ITEM repeatable-item

If the repeat arrow contains a number in parenthesis, the number represents the maximum number of times that the item can be repeated.
A repeat arrow above a stack indicates that you can specify more than one of the choices in the stack.

**Default keywords**

IBM-supplied default keywords appear above the main path, and the remaining choices are shown below the main path. In the parameter list following the syntax diagram, the default choices are underlined.

**Where to find information**

You can access the documentation in several ways.

The documentation for this product is provided in PDF and in HTML format at the following websites:
- [Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS](#)
- [Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS](#)

**Ordering publications**

You can order many IBM publications such as product manuals or IBM Redbooks® online at the [IBM Publications Center](#) website.

You can also order by telephone by calling one of the following numbers:
- In the United States: 800-879-2755
- In Canada: 800-426-4968

In other countries, contact your software account representative to order Tivoli publications.

**Accessing terminology online**

The [IBM Terminology](#) website consolidates the terminology from IBM product libraries in one convenient location.

**Service updates and support information**

You can access support information for IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS and IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS on the Support home website, or you can use the IBM Support Assistant.

**Support home**

On the [Support home](#) website, you can find service updates and support information including software fix packs, PTFs, Frequently Asked Questions (FAQs), technical notes, troubleshooting information, and downloads.
Accessibility features

Accessibility features help people with a physical disability, such as restricted mobility or limited vision, or with other special needs, to use software products successfully. This Knowledge Center is developed to comply with the accessibility requirements of software products according to Section 508 of the Rehabilitation Act of the United States.

The accessibility features in this Knowledge Center enable users to do the following tasks:

- Use assistive technologies, such as screen-reader software and digital speech synthesizer, to hear what is displayed on the screen. In this Knowledge Center, all information is provided in HTML format. Consult the product documentation of the assistive technology for details on using assistive technologies with HTML-based information.
- Operate specific or equivalent features using only the keyboard.
- Magnify what is displayed on the screen.

In addition, all images are provided with alternative text so that users with vision impairments can understand the contents of the images.

Navigating the interface by using the keyboard

Standard shortcut and accelerator keys are used by the product and are documented by the operating system. Refer to the documentation provided by your operating system for more information.

Magnifying what is displayed on the screen

You can enlarge information in the product windows using facilities provided by the operating systems on which the product is run. For example, in a Microsoft Windows environment, you can lower the resolution of the screen to enlarge the font sizes of the text on the screen. Refer to the documentation provided by your operating system for more information.

How to send your comments

Your feedback is important in helping to provide the most accurate and high-quality information.

If you have any comments about this information or any other documentation, you can complete and submit the [Reader Comment Form]
What's new

This topic summarizes the significant improvements or enhancements for the product and refers you to the relevant topics for more information.

SH12-7069-00 — December 2016

This edition replaces IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS; IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS: Monitoring Performance from Performance Expert Client, SH12-7051-00.

• Clarifications and corrections have been applied to the information where required.
Part 1. Before you begin

This section provides the information you need before you start working with OMEGAMON XE for DB2 PE.

It gives you an overview of OMEGAMON XE for DB2 PE and describes the main components and features of Performance Expert Client, which is one of the graphical interfaces of OMEGAMON XE for DB2 PE.

Chapter 1, “What does OMEGAMON XE for DB2 PE do?,” on page 3
OMEGAMON XE for DB2 PE is a host-based performance analysis and tuning tool for z/OS environments. Its main objective is to simplify DB2 performance management.

Chapter 2, “Components and features of Performance Expert Client,” on page 5
This topic introduces the main components and features of Performance Expert Client, which is one of the graphical interfaces of OMEGAMON XE for DB2 PE.

Chapter 3, “Getting started,” on page 7
This section describes the tasks you need to perform before you can start working with OMEGAMON XE for DB2 PE.
Chapter 1. What does OMEGAMON XE for DB2 PE do?

OMEGAMON XE for DB2 PE is a host-based performance analysis and tuning tool for z/OS environments. Its main objective is to simplify DB2 performance management.

OMEGAMON XE for DB2 PE lets you monitor threads, system Statistics, and system parameters by using a single tool. It integrates performance monitoring, reporting, buffer pool analysis, and a Performance Warehouse function. It also provides a single overview system that monitors all DB2 subsystems and DB2 Connect gateways in a consistent way.

OMEGAMON XE for DB2 PE offers the following advantages:

- Performance analysis and tuning of DB2 and DB2 applications.
- Expert analysis, a real-time online monitor, and a wide range of reports for analyzing and optimizing DB2 applications and SQL statements.
- Performance Warehouse feature for storing performance data and analysis functions, and for collecting report data.
- Definitions and usage of analysis functions, such as rules of thumb and queries, to identify performance bottlenecks.
- A starter set of smart features that provide recommendations for system tuning to gain optimum throughput.
- An explain feature.
- A Reporting function that presents detailed information about DB2 events involving CPU times, buffer pool usage, locking, I/O activity, and more.
- A buffer pool analysis function that collects data and provides reports on related event activity to get information about current buffer pool behavior and to simulate anticipated future behavior. It can provide these reports in the form of tables, pie charts, and diagrams.
- Exception reports for common performance problems to help identify and quantify excessive CPU and elapsed time on a plan and package basis.
- Monitoring connections of remote applications using Performance Expert Agent for DB2 Connect Monitoring.

The stand-alone product OMEGAMON XE for DB2 PM provides a subset of the functions that are provided when you install OMEGAMON XE for DB2 PE. For a detailed description of the different capabilities, refer to the following Web site:

- [Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS (PDFs and Techdocs on DB2 Tools Product Page)]
- [Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS (PDFs and Techdocs on DB2 Tools Product Page)]

The main components of OMEGAMON XE for DB2 PE are:

- Performance Expert Client which is one of the graphical interfaces of OMEGAMON XE for DB2 PE
- OMEGAMON Collector
- Performance Expert Agent for DB2 Connect Monitoring
Related reading: For information about the OMEGAMON Collector and Performance Expert Agent for DB2 Connect Monitoring, refer to Configuration and Customization.
Chapter 2. Components and features of Performance Expert Client

This topic introduces the main components and features of Performance Expert Client, which is one of the graphical interfaces of OMEGAMON XE for DB2 PE.

With Performance Expert Client you can monitor and analyze the performance of an application online and handle exception notifications. The Performance Warehouse provides a process-oriented view of the performance analysis tasks. It helps you manage and analyze buffer pools more efficiently by providing specific recommendations to adjust buffer pool sizes and threshold values.

“Online monitoring and reporting”
Performance Expert Client enables online monitoring and reporting, including exception notification handling.

“Performance Warehouse management” on page 6
Performance Warehouse provides a process-oriented view of the performance analysis tasks.

“Buffer pool analysis” on page 6
Buffer pool analysis helps you manage buffer pools more efficiently by providing specific recommendations to adjust buffer pool sizes and threshold values.

Online monitoring and reporting
Performance Expert Client enables online monitoring and reporting, including exception notification handling.

You can use the online monitoring and reporting component to:
• Determine the total DB2 system performance and efficiency.
• Measure the performance of an application.
• Review the resources used by an application.
• Evaluate an application’s impact on other applications and the DB2 system.
• Identify the cause of performance problems by checking certain thread-activity and Statistics fields for exceptions and listing the occurrence of specific events.
• Determine the tuning requirements for DB2.
• View performance data graphically.
• Analyze and improve SQL statements by using Explain products. For more information refer to Chapter 13, “Using Explain products to analyze and improve SQL statements,” on page 69.
• Monitor DB2 Connect™ gateways, including system-related information.

This component is similar to the host-based (ISPF) Online Monitor. It has some advantages over the host-based Online Monitor, such as:
• The graphics improve the representation of the relationship between counters and the trends and evolution of counters.
• You can monitor several DB2 systems at the same time.
• When DB2 performance is not satisfactory, you receive tuning recommendations.
Performance Warehouse management

Performance Warehouse provides a process-oriented view of the performance analysis tasks.

It allows you to automate tasks that previously required user interaction, such as loading DB2 data into the Performance Warehouse database or generating reports.

Using the Performance Warehouse window, you can define, schedule, and run processes that automate the following tasks:
- Generating DB2 performance data
- Loading this data into the Performance Warehouse database
- Creating reports on the data in the Performance Warehouse database
- Collecting report data

You can then use rules of thumb and queries to analyze and evaluate the data in the Performance Warehouse database.

Samples of processes, rules of thumb, and queries are provided to help you get started.

Buffer pool analysis

Buffer pool analysis helps you manage buffer pools more efficiently by providing specific recommendations to adjust buffer pool sizes and threshold values.

If you are interested in background information about current buffer pool behavior, you can get in-depth statistical data, comprehensive reports, and easy-to-read graphic information for all buffer pools and their objects.

Buffer pool analysis helps you tune DB2 buffer pools and get the most out of your system resources. It lets you optimize memory usage by specifically recommending which buffer pools to change and by how much.

It allows you to:
- Save central processing unit (CPU) cycles
- Improve response times and elapsed times
- Simulate buffer pool behavior

Related reading: This information does not cover buffer pool analysis. For information about how to use this component, see Buffer Pool Analyzer User’s Guide.
Chapter 3. Getting started

This section describes the tasks you need to perform before you can start working with OMEGAMON XE for DB2 PE.

Before you start working with OMEGAMON XE for DB2 PE, ensure that you have the correct authorization and DB2 privileges to perform monitoring tasks.

Related reading: To find out what authorization and DB2 privileges you need, see Configuration and Customization.

Before you start working with OMEGAMON XE for DB2 PE, ensure that all DB2 traces are running. If you do not get any monitoring data, check if one or more DB2 traces are switched off.

“Starting Performance Expert Client” on page 8
You can start Performance Expert Client directly or from the DB2 Control Center.

“Working with the System Overview window” on page 8
The System Overview window shows the main performance information about the DB2 systems that you monitor and to which you are logged on. From this window, you can access all monitoring functions that are supported by Performance Expert.

“Defining the DB2 systems that must be monitored” on page 10
To monitor a DB2 subsystem or DB2 Connect gateway, you must enable Performance Expert Client to access the performance data of this DB2 system which is described in the following sections.

“Organizing the DB2 systems” on page 13
When you specify or import a new DB2 subsystem or DB2 Connect gateway for monitoring from Performance Expert Client, this DB2 system is added to the corresponding folder of the System Overview window. Within these folders, the DB2 systems are listed in alphabetical order. You can structure and sort the DB2 systems according to your needs using the My Shortcuts folder.

“Specifying global settings” on page 14
Click Monitor > Configuration to specify preferences for global settings that are used throughout OMEGAMON XE for DB2 PE, such as your Web browser of choice, diagnostics settings, and accessibility settings. The Configuration window is displayed.

“Logging on to DB2 systems” on page 14
To monitor a DB2 system, you must log on to the OMEGAMON Collector that collects the performance data for this DB2 system.

“Starting several monitoring functions in one or more DB2 subsystems” on page 15
You can start several monitoring functions in one or more DB2 subsystems to which you are logged on.

“Starting a monitoring function from the DB2 Control Center” on page 15
When you are working with DB2 you might want to start a specific performance-monitoring function from DB2. You can do this using the DB2 Control Center.
“Issuing DB2 commands” on page 16
You can issue any DB2 command for which you have authority from Performance Expert Client, except **START DB2**. This command can be issued only from an MVS terminal.

“Getting help” on page 16
You can display help for all elements in a window or wizard and for the windows and wizards themselves.

“Logging off from DB2 systems” on page 16
To log off from a DB2 subsystem or DB2 Connect gateway you must log off from the OMEGAMON Collector that collects the performance data for this DB2 system.

“Deleting a DB2 system” on page 17
If you do not want to monitor a DB2 subsystem or DB2 Connect gateway from Performance Expert Client anymore, you can delete it.

“Leaving Performance Expert Client” on page 17
To leave Performance Expert Client, click **Monitor > Exit**.

---

**Starting Performance Expert Client**

You can start Performance Expert Client directly or from the DB2 Control Center.

If you installed a firewall on your workstation, ensure that Performance Expert Client has correct access permissions. Otherwise, Performance Expert Client does not work correctly.

You can start Performance Expert Client directly in one of the following ways:

- Double-click the **IBM DB2 Performance Expert for zOS** icon on your desktop.
- Click **Start > All Programs > IBM DB2 Performance Expert for zOS > IBM DB2 Performance Expert for zOS**.

To start Performance Expert Client from the DB2 Control Center, click the **toolbar button.**

If you want to start Performance Expert Client more than once on a workstation and on the same operating system, Performance Expert Client must run under different user IDs. For example, if you want to start Performance Expert Client three times in such an environment, Performance Expert Client must run under three different user IDs or on different workstations.

After you start Performance Expert Client, the System Overview window is displayed, which is the main window.

---

**Working with the System Overview window**

The System Overview window shows the main performance information about the DB2 systems that you monitor and to which you are logged on. From this window, you can access all monitoring functions that are supported by Performance Expert.

You can view performance information for all DB2 systems or for a specific DB2 system. If a member is in DSG, you can view the information for each member. **Figure 1 on page 9** shows the KPIs page of the System Overview window after you logged on to a DB2 subsystem.
The folders pane on the left lets you select the information level. The contents pane on the right shows the performance information for the selected information level. The performance information is shown on the following tabbed pages:

- The KPIs page shows the counters that are key performance indicators (KPIs) for the selected information level. Many of these counters have cumulative values, where the delta between the values of the last two snapshots is calculated.

When you move the cursor over a KPI, hover help is displayed, which contains a short description of the KPI. Double-clicking a KPI takes you to the pane or page of the Statistics Details or System Parameters window that contains this counter. The counter is then highlighted in green.

- The Data Views page shows the performance graphs for the selected information level. Performance graphs show Statistics information in graphical format. You create these performance graphs as data views in the System Health window and make them available in the System Overview window. When you click and move the cursor over a data view, the values for the counters that are represented by the data view are shown.

To open the pane or page of the Statistics Details that contains the counters in the data view, right-click the data view and then select **Show in Statistics Details**. To open the **System Health** window, in which you created the data view, right-click the data view and then select **Show in System Health**.

- The Exceptions page shows the last 10 periodic exceptions and the last 10 event exceptions for the selected information level.

To view more details on an event exception or a periodic exception, do one of the following:

---

**Figure 1. System Overview window**

The folders pane on the left lets you select the information level. The contents pane on the right shows the performance information for the selected information level. The performance information is shown on the following tabbed pages:

- The KPIs page shows the counters that are key performance indicators (KPIs) for the selected information level. Many of these counters have cumulative values, where the delta between the values of the last two snapshots is calculated.

When you move the cursor over a KPI, hover help is displayed, which contains a short description of the KPI. Double-clicking a KPI takes you to the pane or page of the Statistics Details or System Parameters window that contains this counter. The counter is then highlighted in green.

- The Data Views page shows the performance graphs for the selected information level. Performance graphs show Statistics information in graphical format. You create these performance graphs as data views in the System Health window and make them available in the System Overview window. When you click and move the cursor over a data view, the values for the counters that are represented by the data view are shown.

To open the pane or page of the Statistics Details that contains the counters in the data view, right-click the data view and then select **Show in Statistics Details**. To open the **System Health** window, in which you created the data view, right-click the data view and then select **Show in System Health**.

- The Exceptions page shows the last 10 periodic exceptions and the last 10 event exceptions for the selected information level.

To view more details on an event exception or a periodic exception, do one of the following:
– Click the exception. The exception details are shown at the bottom of the page.
– Double-click the exception. The appropriate Details window opens.
– Delete link removes the entry from the table.
– New exceptions are shown in red. Exceptions that you have double-clicked to display details are shown in grey.

The toolbar buttons at the top of the window take you directly to the monitoring functions.

Specific icons and colors indicate whether the value of a counter falls below or above a warning or problem threshold. Event exceptions are also indicated by an icon. You are only informed of a warning or problem if the warning or problem threshold is active and if you activated the threshold set that contains this warning or problem threshold. For more information, refer to “Processing periodic exceptions” on page 61.

The data in the System Overview window is refreshed at the rate that you specify for a DB2 system.

Defining the DB2 systems that must be monitored

To monitor a DB2 subsystem or DB2 Connect gateway, you must enable Performance Expert Client to access the performance data of this DB2 system which is described in the following sections.

Note: “Changing the properties of a DB2 subsystem” on page 13 and “Changing the properties of a DB2 Connect gateway” on page 13 show how to change the properties of a DB2 system.

“Defining a DB2 subsystem”
Each OMEGAMON Collector monitors the DB2 subsystem on which it is installed. The OMEGAMON Collector collects the performance data of the subsystem and stores it in its DB2PM database.

“Defining a DB2 Connect gateway” on page 12
If an OMEGAMON Collector is registered for a Performance Expert Agent for DB2 Connect Monitoring, it receives information about the DB2 Connect server that is installed on the same system as Performance Expert Agent for DB2 Connect Monitoring. The DB2 Connect server serves as DB2 Connect gateway. The information is stored in the DB2PM database of the OMEGAMON Collector.

“Changing the properties of a DB2 subsystem” on page 13
This topic describes how to change the properties of a DB2 subsystem.

“Changing the properties of a DB2 Connect gateway” on page 13
This topic describes how to change the properties of a DB2 Connect gateway.

Defining a DB2 subsystem
Each OMEGAMON Collector monitors the DB2 subsystem on which it is installed. The OMEGAMON Collector collects the performance data of the subsystem and stores it in its DB2PM database.

To monitor a DB2 subsystem from Performance Expert Client, you must establish a connection between Performance Expert Client and the OMEGAMON Collector installed on the DB2 subsystem so that Performance Expert Client can access the performance data of this subsystem. You do this by defining the DB2 subsystem:
The New DB2 System wizard is displayed.
2. On the Object page, click DB2 on z/OS, OS/390 systems, and then click Next.
3. On the Data Collector page, specify the connection to the DB2 subsystem on which OMEGAMON Collector is installed:

   **Host**  The MVS host name.

   **Port**  Specify the port number to which the Performance Expert Client can connect when communicating with the OMEGAMON Collector. The port number specifies the TCP/IP port on which the server listens for incoming sessions of Performance Expert Client for the specified DB2 subsystem.

   If you do not know this information, contact your database administrator (DBA).
4. Click Next.
5. On the DB2 Subsystem page, do one of the following:
   - Click Retrieve to use the DB2 subsystem information defined on the host. 
     The Logon window is displayed.
   - In the **User ID** field, type your MVS host user ID. In the **Password** field, type your password. Then click OK.

   The DB2 Subsystem page of the New DB2 System window is displayed. For the **Name** field, OMEGAMON XE for DB2 PE supplies the same value as for the **Database alias** field. Ensure that the name is unique throughout Performance Expert Client.

   - Type the values for the following fields:

     **Name**  Type a name for the DB2 subsystem that is unique throughout all DB2 subsystems. If you clicked Retrieve, this field shows the same value as the Database alias field. Ensure that this value is unique throughout Performance Expert Client.

     **Database alias**  Type the alias of the DB2 subsystem location. If you clicked Retrieve, this field shows the alias of the DB2 subsystem location as defined on the host. The specified alias will appear in the folders pane of the System Overview window.

     **MVS system**  The name of the MVS system.

     **Data Sharing Group**  If the DB2 subsystem is a member of a data sharing group, type the group name here.

     **Data Sharing Member**  If the DB2 subsystem is a member of a data sharing group, type the member name here.

     **Description**  Use this field for a description of the DB2 subsystem. This field is optional.

     **Local DB alias**  If you want to use Query Workload Tuner, type the local database alias of the DB2 subsystem.
6. Click Next.
7. On the Performance Warehouse page, you can associate a Performance Warehouse system with the DB2 subsystem you are defining. You must specify a Performance Warehouse system if you want to create SQL activity traces.

In the Database alias field, type the alias of the Performance Warehouse database that is maintained by the OMEGAMON Collector that monitors this DB2 subsystem. This is the database alias that you specified when cataloging the DB2PM database of the OMEGAMON Collector by using the Configuration Assistant of DB2.

Related reading: For further information about cataloging the DB2PM database, see Configuration and Customization.

8. Click Finish.

The DB2 subsystem is shown in the System Overview window under the z/OS folder.

Defining a DB2 Connect gateway

If an OMEGAMON Collector is registered for a Performance Expert Agent for DB2 Connect Monitoring, it receives information about the DB2 Connect server that is installed on the same system as Performance Expert Agent for DB2 Connect Monitoring. The DB2 Connect server serves as DB2 Connect gateway. The information is stored in the DB2PM database of the OMEGAMON Collector.

To monitor a DB2 Connect gateway from Performance Expert Client, you must establish a connection between Performance Expert Client and the OMEGAMON Collector collecting the information about the activities of a DB2 Connect server that serves as DB2 Connect gateway. You do this by defining the DB2 Connect gateway:


   The New DB2 System wizard is displayed.

2. On the Object page, click DB2 Connect/Gateways and then click Next.

3. On the DB2 Connect/Gateways page, do the following:
   a. From the DB2 system alias list, select the DB2 subsystem monitored by the OMEGAMON Collector that receives data from one or more Performance Expert Agents for DB2 Connect Monitoring.
   b. Click Retrieve to retrieve the names of all DB2 Connect gateways with Performance Expert Agents for DB2 Connect Monitoring that send data to the selected OMEGAMON Collector.

   The Logon window is displayed.
   c. In the User ID field, type your user ID. In the Password field, type your password. Then click OK.

   The DB2 Connect/Gateways page of the New DB2 System window is displayed. The DB2 Connect gateway name consists of the following parts: the IP address, the workstation name, and the name of the DB2 subsystem containing Performance Expert Agent for DB2 Connect Monitoring. The fields under Gateway Information are shown.
   d. Select a DB2 Connect gateway name.

   This name is also displayed in the Gateway alias field.
   e. Optionally you can specify another name in the Gateway alias field that is unique throughout Performance Expert Client. This name is shown in the folders pane of the System Overview window.
   f. Optionally you can specify a description for the selected DB2 Connect gateway.
4. Click **Finish** to return to the System Overview window.

    The name of the DB2 Connect gateway is displayed in the System Overview
    window under the **DB2 Connect/Gateways** folder.

### Changing the properties of a DB2 subsystem

This topic describes how to change the properties of a DB2 subsystem.

To change the properties of a DB2 subsystem:

1. Log off from the OMEGAMON Collector that monitors this DB2 subsystem. Refer to "Logging off from DB2 systems" on page 16 for more information.
2. Click **Selected > Properties**.

    The DB2 System Properties window is displayed.

    You can define your changes on the various pages.

### Changing the properties of a DB2 Connect gateway

This topic describes how to change the properties of a DB2 Connect gateway.

To change the properties of a DB2 Connect gateway:

1. Log off from the OMEGAMON Collector that receives information from this DB2 Connect gateway. Refer to "Logging off from DB2 systems" on page 16 for more information.
2. Click **Selected > Properties**.

    The DB2 System Properties window is displayed.

On the DB2 Connect/Gateways page, you can change the **Gateway alias** and **Description** fields.

### Organizing the DB2 systems

When you specify or import a new DB2 subsystem or DB2 Connect gateway for monitoring from Performance Expert Client, this DB2 system is added to the corresponding folder of the System Overview window. Within these folders, the DB2 systems are listed in alphabetical order. You can structure and sort the DB2 systems according to your needs using the **My Shortcuts** folder.

You can copy one DB2 system and paste it as a shortcut to the **My Shortcuts** folder. In this folder, you can create a hierarchical structure of subfolders and copy the shortcuts to one or more subfolders.

You can change a DB2 system or shortcut in one of the following ways:

- **Rename a DB2 system and thus all of its shortcuts.** To do this, you must use the DB2 System Properties window (see "Changing the properties of a DB2 subsystem" and "Changing the properties of a DB2 Connect gateway").
- **Delete a DB2 system and thus all of its shortcuts:** click the DB2 system that you want to delete in the **All Subsystems**, **All Data Sharing Group**, or **DB2 Connect Gateways** folder and then click **Selected > Delete**.
- **Remove a shortcut from a folder:** click the shortcut in the appropriate folder and then click **Selected > Delete** to delete only this shortcut.
Specifying global settings

Click Monitor > Configuration to specify preferences for global settings that are used throughout OMEGAMON XE for DB2 PE, such as your Web browser of choice, diagnostics settings, and accessibility settings. The Configuration window is displayed.

- On the Preferences page, you can:
  - Specify the location of your Web browser.
  - Permanently save your logon passwords for all DB2 systems.
  - Reactivate the display of message DGOK3638 (Monitor switches are not set) if you suppressed this message.
- On the Diagnostics page, you can specify e-mail settings for sending diagnostics reports to IBM support.
- On the Accessibility page, you can specify high-contrast settings for your screen.

Logging on to DB2 systems

To monitor a DB2 system, you must log on to the OMEGAMON Collector that collects the performance data for this DB2 system.

If you use the same password for several OMEGAMON Collectors, you can log on to them at once. During such a multiple logon, you can start monitoring functions.

"Logging on to one DB2 subsystem or DB2 Connect gateway"

You log on to one DB2 subsystem or DB2 Connect gateway by logging on to the OMEGAMON Collector that collects the performance data for this DB2 system.

"Logging on to several DB2 subsystems"

You log on to several DB2 subsystems at once by logging on to the OMEGAMON Collectors that collect the performance data for these DB2 subsystems and that are accessible with the same password.

Logging on to one DB2 subsystem or DB2 Connect gateway

You log on to one DB2 subsystem or DB2 Connect gateway by logging on to the OMEGAMON Collector that collects the performance data for this DB2 system.

To log on to one DB2 subsystem or DB2 Connect gateway:

1. In the System Overview window, click the DB2 system and then click Selected > Logon.
   The Logon window is displayed.
2. In the User ID field, type your MVS host user ID.
3. In the Password field, type your password.
4. You can type your TSO group ID in the Group ID field. This is optional.
5. Click OK.

Logging on to several DB2 subsystems

You log on to several DB2 subsystems at once by logging on to the OMEGAMON Collectors that collect the performance data for these DB2 subsystems and that are accessible with the same password.

To log on to several DB2 subsystems at once:

1. In the System Overview window, click Monitor > Multiple Logon.
The Multiple Logon window is displayed.

2. Select the DB2 subsystems to which you want to log on. You can access the OMEGAMON Collector of these DB2 subsystems with the same password. You can also select the monitoring functions that you want to start.

3. Click OK. The Logon window is displayed.

4. Fill in the fields as described under "Logging on to one DB2 subsystem or DB2 Connect gateway" on page 14 and click OK.

The Log window is opened telling you whether your logon requests were successful. If you selected one or more monitoring functions, the appropriate windows are also opened.

---

**Starting several monitoring functions in one or more DB2 subsystems**

You can start several monitoring functions in one or more DB2 subsystems to which you are logged on.

To start several monitoring functions in one or more DB2 subsystems:

1. In the System Overview window, click Monitor > Multiple Launch. The Multiple Launch window is displayed.

2. Select the DB2 subsystems and the monitoring functions that you want to start and click OK.

The Log window is opened telling you whether your launch requests were successful. In addition, the appropriate monitoring windows are displayed.

---

**Starting a monitoring function from the DB2 Control Center**

When you are working with DB2 you might want to start a specific performance-monitoring function from DB2. You can do this using the DB2 Control Center.

The DB2 system for which you want to view the performance data must have already been defined for monitoring from Performance Expert Client (see "Defining the DB2 systems that must be monitored" on page 10). However, Performance Expert Client need not be open when you select the monitoring function from the Control Center.

To start a monitoring function from the Control Center, do the following:

1. In the folders pane, expand the system folder and right-click the DB2 subsystem for which you want to view performance data. If you are not connected to the selected DB2 subsystem, you are prompted to log on. You can also select DB2 Performance Expert to open a submenu containing the monitoring functions available for this DB2 subsystem.

2. Select the monitoring function you want to work with.

3. If the DB2 subsystem location alias of a DB2 subsystem is not found, a window is opened where you can select the OMEGAMON Collector monitoring this DB2 subsystem.

If OMEGAMON Collector is not already open, it is started. You can then view the requested performance data for the selected DB2 subsystem in a window.
Issuing DB2 commands

You can issue any DB2 command for which you have authority from Performance Expert Client, except –START DB2. This command can be issued only from an MVS terminal.

To issue a DB2 command:
1. You can select one of the following ways:
   • In the System Overview window, select the DB2 subsystem in the folders pane and then click the DB2 Commands toolbar button.
   • You can also use the menu bar or pop-up menu: click the DB2 subsystem in the folders pane, then click Selected > Monitor > DB2 Commands on the menu bar or Monitor > DB2 Commands on the pop-up menu.

If you are not connected to the selected DB2 subsystem, you are prompted to log on.

The DB2 Commands window is displayed.
2. In the Command input field, type your command or click the arrow to select a previously issued command from the list.
3. Click Send to send the command to your DB2 subsystem.

The command is added to the Command input list. The DB2 response is displayed in the DB2 response is box.

To remove the DB2 response, right-click the DB2 response is box and then click Clear.

Getting help

You can display help for all elements in a window or wizard and for the windows and wizards themselves.

To get help on:

• A window or wizard, click the Help button or toolbar button or Help > General Help.
• A pane of a window, click the name of the pane in the folders pane and then press F1.
• A tabbed page of a window, click the tab and then press F1.
• A toolbar button, move your mouse pointer over this button.
• A field in a window or wizard, click in the field and then press F1 or display help for the window or wizard (general help) and click Field help. Field help also covers the buttons displayed between and next to the fields.
• A command button at the bottom of a window or wizard, move the input focus to this button and press F1 or display help for the window or wizard (general help) and click Button help.
• A table in a window or pane, click in the table and then press F1.

Logging off from DB2 systems

To log off from a DB2 subsystem or DB2 Connect gateway you must log off from the OMEGAMON Collector that collects the performance data for this DB2 system.
In the System Overview window, click the DB2 system and then click Selected > Logoff. If one or more monitoring activities are still running on your DB2 system, you are asked whether you want to continue or stop them.

The exceptions that occurred for the DB2 system from which you logged off are removed from the 100 Most Recent Exceptions pane of the System Overview window even if exception processing continues running. After your next logon, the exceptions that were collected during your previous logon and logoff are shown again.

Deleting a DB2 system

If you do not want to monitor a DB2 subsystem or DB2 Connect gateway from Performance Expert Client anymore, you can delete it.

To delete a DB2 system:
1. If you are still logged on to the OMEGAMON Collector that collects the performance data of the DB2 system that you want to delete, you must log off. See “Logging off from DB2 systems” on page 16 for more information.
2. In the System Overview window, click the DB2 system that you want to delete and then click Selected > Delete.
   A message appears asking you whether you also want to delete the DB2 catalog entries for this DB2 system. If you decide to leave the catalog entries and a Performance Warehouse system is associated with this DB2 system, you can continue working with this Performance Warehouse.
3. Make your selection, then click Yes.

The DB2 system and all its shortcuts are removed from the folders pane of the System Overview window.

Leaving Performance Expert Client

To leave Performance Expert Client, click Monitor > Exit.

A message or a window appears:
• If you have already logged off from all DB2 systems or stopped all monitoring activities on the systems to which you are still logged on, a message is displayed asking you whether you want to leave Performance Expert Client. Monitoring activities that you did not stop when logging off from a DB2 system continue running.
• If you are still logged on to DB2 systems on which monitoring activities are running, a window is displayed asking you whether you want to stop or continue all activities.
Part 2. Online monitoring and reporting

These topics describe how to monitor the performance of DB2 subsystems and DB2 Connect gateways and how to create reports and traces.

Chapter 4, “Monitoring threads,” on page 21
You can view the current and recent activity of all active threads connected to a DB2 subsystem. You can get an overview of all connected threads and detailed information about a specific thread. You can also view the SQL activity of a single thread and create traces on this activity.

Chapter 5, “Resolving locking conflicts,” on page 29
When several threads try to access the same data at the same time, DB2 uses locks to control these concurrent attempts. A lock associates a DB2 resource with an application process in a way that affects how threads can access this resource.

Chapter 6, “Viewing DB2 Statistics,” on page 31
You can view important Statistics and ratios of a DB2 subsystem in various levels of detail and processing modes.

Chapter 7, “Viewing system health,” on page 37
Statistics information for a DB2 subsystem can be viewed as numerical values and percentages on various Statistics Details windows or as snapshots in graphical format.

Chapter 8, “Monitoring activities of DB2 Connect gateways and connections of DCS applications,” on page 49
You can monitor the activities of DB2 Connect servers (DB2 subsystem) that serve as DB2 Connect gateways. You can also monitor the connections of Database Connection Services (DCS) applications within the Distributed Relational Database Architecture® (DRDA®) of DB2. You can use the information that you obtain through these monitoring activities to evaluate the health of a DB2 Connect gateway and to make changes necessary to tune the system.

Chapter 9, “Viewing DB2 system parameters,” on page 55
You can view the system parameter values that you specified when configuring a DB2 subsystem.

Chapter 10, “Working with exception processing,” on page 57
Exception processing is an efficient way to monitor DB2 subsystems for performance problems. When exception processing is active, you are informed when certain events occur, or when specific counters reach levels that might produce problems.

Chapter 11, “Monitoring data sharing groups,” on page 65
If you are working with a member of a data sharing group, you might want to view, from time to time, the monitoring information collected for another member in the data sharing group. Or you might want to compare the data collected for all members in the group. Most of the monitoring functions allow you to switch among the individual members and between a member and the group. You find a Show Data for list in the toolbar.

Chapter 12, “Viewing history data,” on page 67
You can view history data for threads, locking conflicts, Statistics, and system parameters. This data is stored as snapshots.
Chapter 13, “Using Explain products to analyze and improve SQL statements,” on page 69
This topic explains how to use Explain products to analyze and improve SQL statements.

Chapter 14, “Exporting snapshot data for saving and printing,” on page 71
You can export snapshot data to HTML format. You can then print the data or save it as an HTML file.

Chapter 15, “Working with windows displaying snapshots,” on page 73
This section provides you with the information that applies to all windows displaying snapshots.
Chapter 4. Monitoring threads

You can view the current and recent activity of all active threads connected to a DB2 subsystem. You can get an overview of all connected threads and detailed information about a specific thread. You can also view the SQL activity of a single thread and create traces on this activity.

This section describes how to get the overview and the detailed information, customize the displayed windows, and create SQL activity traces.

“Viewing all connected threads”
You can display all active threads connected to a DB2 subsystem or a member of a data sharing group.

“Viewing details of a selected thread” on page 22
You can get more details of a thread by double-clicking it in the Thread Summary window to open the Thread Details window.

“Sorting threads” on page 23
You can sort threads by a specific performance counter (simple sort) or by using several performance counters (hierarchical sort).

“Filtering threads” on page 24
You can filter threads so that only those meeting your specifications are displayed. This minimizes network traffic and can decrease response times considerably. For example, if you suspect that threads with a certain CPU Class 1 are causing problems, you can specify your filter to display only threads within CPU Class 1. You can define a different filter for each DB2 subsystem.

“Canceling threads” on page 25
If you have the appropriate DB2 authority, you can cancel threads.

“Creating and viewing SQL activity traces” on page 26
If you have MONITOR1 and MONITOR2 privileges, you can create traces on the DB2 system-wide SQL activity that takes place during the processing of a DB2 application. You can create such traces only if you are not viewing history data.

Viewing all connected threads

You can display all active threads connected to a DB2 subsystem or a member of a data sharing group.

To do this, you can choose one of the following ways:

• In the System Overview window, select the DB2 subsystem or member of the data sharing group in the folders pane and then click the Thread Summary toolbar button ( ).

• You can also use the menu bar or pop-up menu: click the DB2 subsystem or member of the data sharing group in the folders pane, then click Selected > Monitor > Thread Summary on the menu bar or Monitor > Thread Summary on the pop-up menu.

If you are not connected to the selected DB2 subsystem, you are prompted to log on.
The Thread Summary window is displayed. It contains the key performance counters for all connected threads. If a thread has children, the number shown in the Parallel Threads column includes the parent thread.

To refresh the thread activity data, in the toolbar, select Automatic in the Refresh field. By default, values are updated every six seconds. To change the interval, click in the time field next to the Refresh field and overtype the value according to your requirements.

**Related information:**
- If the Thread Summary window lists too many threads, you can filter them. For more information refer to [Filtering threads](#) on page 24.
- You can sort the threads in the window. For more information, see [Sorting threads](#) on page 23.
- The Thread Summary window shows the key performance counters in a table. One or more columns might be hidden. For information about how to view hidden counters, to hide counters that you are not interested in, or to change the order of the columns, refer to [Customizing table columns](#) on page 73.
- If you are monitoring a member of a data sharing group, refer to Chapter 11, “Monitoring data sharing groups,” on page 65 for more information.
- If you are working in different time zones, refer to “Working in different time zones” on page 74 for more information.

### Viewing details of a selected thread

You can get more details of a thread by double-clicking it in the Thread Summary window to open the Thread Details window.

The Overview pane of the Thread Details window shows the main counters of the selected thread. The folders pane lists additional counter categories. You can get more details on a counter category by clicking it in the folders pane.

If a thread has children, the children are listed on the Parallel Threads pane. You can get more details on a child by double-clicking it.

The folders pane of the Thread Details window lists the counter categories. The contents pane shows the counters for the selected counter category. You can get more details on a counter category by clicking it in the folders pane.

Some DB2 counters are also shown as percentages in bar charts, stacked to 100%. Each bar in the chart represents a snapshot and reflects several counters. The percentages of these counters are shown proportionately and accumulated to add up to 100%. Click the bar chart to see which counters are represented. You can increase or decrease the number of snapshots that are shown in a bar chart by using the plus (+) and minus (-) signs next to the x-axis of the chart.

For one or more DB2 counters in the Thread Details window an icon appears next to the counter affected if:
- You run periodic exception processing
- You specified a warning threshold, problem threshold, or both
- A counter value falls below or above a threshold

When you move your mouse pointer over such a counter, you see the timestamp of the exception. The icon disappears after the counter value falls below or above...
the threshold or after periodic exception processing is stopped and you refresh the
data in the window. No icon is shown for counters listed in a table.

On the SQL Statement pane, you see the text of the SQL statement that was
recently performed by the thread. You can view the access plan for this statement
in graphical format by clicking Explain. Refer to Chapter 13, “Using Explain
products to analyze and improve SQL statements,” on page 69 for more
information. If the statement text is much longer than the space provided and,
therefore, difficult to read, you can view it in another window. Click View
Statement in New Window.

Related information:
• The Thread Details window shows part of its performance information in tables.
  In contents panes containing a table:
  – You can filter the entries listed. For more information refer to “Filtering
threads” on page 24.
  – One or more columns might be hidden. For information about how to view
    hidden counters, to hide counters that you are not interested in, or to change
    the order of the columns, refer to “Customizing table columns” on page 73.
  – You can choose to view details on a table entry in another window or on a
    notebook page. For more information, refer to “Viewing details on a table
    entry in a contents pane” on page 74.
• Performance counter values that are too long are truncated. For information
  about how to view the entire value, refer to “Viewing long performance counter
  values” on page 74.
• If you are working in different time zones, refer to “Working in different time
 zones” on page 74 for more information.

Sorting threads

You can sort threads by a specific performance counter (simple sort) or by using
several performance counters (hierarchical sort).

In windows that list threads, the entries are sorted by a performance counter
(simple sort). By default, this is the leftmost column in the window. To change the
order, click the name of another column.

In the Thread Summary window, you can create a specific sort hierarchy. You can
select up to five performance counters as sort criteria; the first one selected has the
highest sort criterion. You can sort the rows in ascending or descending order. You
can also view them in a different order for each DB2 subsystem.

To sort the threads:
1. Click View > Sort.
   The Sort window is displayed.
2. In the Available columns box, click the column name to be the highest sort
criterion and then click Add ( ).
   The selected column name is removed from the Available columns box and
displayed in the Sort columns box.
   You can continue selecting additional sort criteria until you have reached the
   limit of five column names. Your selection is always hierarchical. This means,
   the column name you select first is the highest sort criterion, the one you select
   second is the second highest criterion, and so on. For example, if you select
Plan as the highest sort key and there are several threads with the same Plan, you might want to sort these threads by another column name, such as Elapsed Class 2, and would thus select Elapsed Class 2 as second sort key.

3. Within a sort criterion, the threads are, by default, sorted in ascending order. In the Sort columns box, click the column name for which you want to specify descending order and then click Descending to sort the threads in descending order.

4. You can use the Move Up and Move Down buttons to change the hierarchy of the sort criteria.

5. At any time during or after your selection, you can remove a sort criterion from your selection. In the Sort columns box, click the column name to be removed and then click Remove ( ). The selected column name is removed from the Sort columns box and displayed in the Available columns box at its previous position.

6. When you have finished specifying your sort criteria, click OK.

The Thread Summary window is displayed. The rows are sorted according to your specifications. The Sort ( ) icon is displayed in the right-hand corner of the status bar to show that your sort criteria are active. The current sort criteria remain valid for this DB2 subsystem until you change them again or disable them.

If you want to keep your sort criteria but temporarily disable them to view the default order, right-click the Sort ( ) icon and then click Disable. The Sort ( ) icon is dimmed and the threads are displayed in the default order.

To reactivate your sort criteria, right-click the dimmed Sort ( ) icon and then click Enable. The threads are sorted according to your specifications again.

Filtering threads

You can filter threads so that only those meeting your specifications are displayed. This minimizes network traffic and can decrease response times considerably. For example, if you suspect that threads with a certain CPU Class 1 are causing problems, you can specify your filter to display only threads within CPU Class 1. You can define a different filter for each DB2 subsystem.

You start filtering on the Thread Summary window. If you have large amounts of data, you can also set filter criteria in the System Overview window.

To filter threads:

1. Click View > Filter/Qualify.
   
   The Filter/Qualify window is displayed.

2. On the Identifier Type/Status page, under Column name, click the column name for which you want to specify one or more values.

3. Type a value in the Value field. You can use a wildcard character (*) in the value. For example, if you want to cover all values that start with PM, you would specify PM*. Characters following the wildcard are ignored.

4. Click Add ( ).
   
   The selected column name is displayed in the Filter table, with its value and the include ( ) symbol.
The include symbol means that all threads having the specified value for the selected column name are included in the list of threads.

5. At any time during or after your selection, you can change your criterion:
   - You can change the include symbol to an exclude (_exclude_ ) symbol for any previous specification in order to exclude threads having the specified value:
     Click the column name and then click Exclude under Qualifier criteria.
   - To narrow the filter, you can select the same column name several times to specify more values. For example, you might want all threads starting with PM but exclude those starting with PMD. Up to 10 values are allowed for the same column name.

6. You can continue specifying additional filter criteria. All criteria and values that you specify are evaluated in the sequence in which you specify them and are combined. This means, the more criteria you specify the narrower the filter and the fewer the threads that are displayed.

7. At any time during or after your selection, you can remove filter criteria from the table.
   In the Filter table, click the criterion to be removed and then Remove (_Remove_ ). If you remove all criteria of a column name, this column name is removed from the Filter table.

8. Click the Additional Qualification tab to specify the thread status and type.
   On the Additional Qualification page:
   - By default, all check boxes are selected, except for the Exclude threads with no work in process check box.
   - If the In DB2 check box is selected, all items in the list are automatically selected. You can deselect the ones that you do not need.
   - If the In check box is selected, the field next to this check box and the check box of Exclude threads with no work in process can be selected. By default, Application is selected and the check box of Exclude threads with no work in process is not selected.

9. Click OK.
   The Thread Summary window is displayed, which is refreshed according to your specifications. The Filter/Qualify (.Filter.Qualify_ ) icon is displayed in the right-hand corner of the status bar to show that your filter is active. The current filter remains valid until you change it again or disable it.

If you want to keep your filter but temporarily view the threads unfiltered,
right-click the Filter (.Filter_ ) icon and then click Disable. The Filter (.Filter_ ) icon is dimmed and the data is displayed in the default order.

To make your filter active again, right-click the dimmed Filter (.Filter_ ) icon and then click Enable.

The window is refreshed according to your specifications.

**Canceling threads**

If you have the appropriate DB2 authority, you can cancel threads.

You can do this from the Thread Summary or the Thread Details window:
1. Do one of the following:
• In the Thread Summary window, click the thread you want to cancel and then click Selected > Cancel Thread.
• In the Thread Details window, click Thread Details > Cancel Thread.

2. Click Yes to confirm the cancelation.

Creating and viewing SQL activity traces

If you have MONITOR1 and MONITOR2 privileges, you can create traces on the DB2 system-wide SQL activity that takes place during the processing of a DB2 application. You can create such traces only if you are not viewing history data.

The trace results are displayed in a Web browser window. To ensure the correct display, use Netscape Communicator 7.0 or later, or Microsoft Internet Explorer 5.50 or later.

A trace can only be created if:
• The Performance Warehouse server is running.
• A Performance Warehouse system has been associated with the monitored DB2 subsystem. Verify that the Performance Warehouse page of the DB2 System Properties window contains the alias of the Performance Warehouse database maintained by the OMEGAMON Collector that is monitoring the DB2 subsystem. This alias is equal to the database alias that you specified when cataloging the DB2PM database by using the Configuration Assistant of DB2. For information about how to display the DB2 System Properties window, refer to “Defining a DB2 subsystem” on page 10.

To create a trace, start in the Thread Summary or Thread Details window. When you select a thread, all threads with the same LUWID as the selected one, are included in the trace.

1. Do one of the following:
• In the Thread Summary window, select the thread for which you want to create the trace and then click Selected > SQL Activity Tracing.
• In the Thread Details window, click Thread Details > SQL Activity Tracing. The SQL Activity Report Generation window is displayed.

Here, you can specify the criteria for the data collection to stop and the SQL activity events you want to see in the trace report.

2. In the Elapsed time and Number of records collected fields, you can leave the default specifications or specify both or only one of the criteria.

If you specify both criteria, data collection stops as soon as the first criterion is met. For example, if you specify an elapsed time of five minutes (00:05:00) and a number of records of 5 and this number is reached after a minute, the trace stops and disregards the remaining four minutes.

3. Optionally, select the SQL statements with a negative return code and the workload blocks that are shown in trace report.

4. Click OK.

If the message Data set not cataloged is displayed, set the OMEGAMON Collector startup parameter USERAUTHORIZATION to YES.

Related reading: For more information about how to set this parameter, refer to Configuration and Customization.

The collection of the performance data and the generation of the SQL activity trace are started and the SQL Activity Tracing window is displayed.
When the trace report is complete and the data sets are downloaded, the results are shown in a Web browser window.

The SQL activity trace results are downloaded as temporary files and are deleted when you leave OMEGAMON XE for DB2 PE. To save these files, use the save functions provided by your Web browser.
Chapter 5. Resolving locking conflicts

When several threads try to access the same data at the same time, DB2 uses locks to control these concurrent attempts. A lock associates a DB2 resource with an application process in a way that affects how threads can access this resource.

You can view the threads involved in a locking situation where at least one thread is suspended. You can view the threads of a single DB2 subsystem or an entire data sharing group.

This section describes how to display the threads independently of the associated resource and to view only the threads associated with a specific resource.

Related information:
- Some windows show the key performance counters in a table. One or more columns might be hidden. For information about how to view hidden counters, to hide counters that you are not interested in, or to change the order of the columns, refer to "Customizing table columns" on page 73.
- Viewing all threads involved in a locking situation
- Viewing the threads associated with a specific resource

Viewing all threads involved in a locking situation

This topic describes how to view all threads for an entire DB2 subsystem or data sharing group.

To view all threads for an entire DB2 subsystem or data sharing group you can do one of the following:
- In the System Overview window, select the DB2 subsystem in the folders pane and then click the Threads in Lock Conflicts toolbar button ( ).
- You can also use the menu bar or pop-up menu: click the DB2 subsystem in the folders pane, then click Selected > Monitor > Threads in Lock Conflicts on the menu bar or Monitor > Threads in Lock Conflicts on the pop-up menu.

If you are not connected to the selected DB2 subsystem, you are prompted to log on.

The Threads in Lock Conflicts window shows all threads that are involved in a locking situation, independent of the resource with which they are associated. They are grouped by the thread that holds the lock (Holder) and the threads that wait for the resource to be freed (Waiter).

This window shows all threads involved in a locking situation, independent of the resource that they are associated with. They are grouped by the thread holding the lock (Holder) and the threads waiting for the resource to be freed (Waiter).

To view more details on a thread, double-click the thread, or click the thread and then click Selected > Thread Details.
Related information:
- If you are monitoring a member of a data sharing group, refer to "Chapter 11, "Monitoring data sharing groups," on page 65 for more information.

Viewing the threads associated with a specific resource

This topic describes how to view the threads associated with a specific resource.

To view the threads associated with a specific resource:
1. Open the Locking Conflicts window is in one of the following ways:
   - In the System Overview window, select the DB2 subsystem in the folders pane and then click the **Locking Conflicts** toolbar button ( ).
   - You can also use the menu bar or pop-up menu: click the DB2 subsystem in the folders pane, then click **Selected > Monitor > Locking Conflicts** on the menu bar or **Monitor > Locking Conflicts** on the pop-up menu.
   This window lists all resources involved in a locking situation.
2. In the Locking Conflicts window, double-click the resource, or click the resource for which you want to view the associated threads and then click **Selected > Threads in Lock Conflicts**.
   The Threads in Lock Conflicts window for the selected resource type is displayed.
   This window contains detailed information about the selected resource and a list of the associated threads. The resource information changes with the selected resource. The threads are grouped by the thread holding the lock (Holder) and the threads waiting for the resource to be freed (Waiter).
3. To view more details on a thread, double-click the thread, or click the thread and then click **Selected > Thread Details**.
Chapter 6. Viewing DB2 Statistics

You can view important Statistics and ratios of a DB2 subsystem in various levels of detail and processing modes.

This section explains some Statistics terms and the processing modes. It also describes how to get the Statistics information and how to refresh buffer pool Statistics.

“Statistics values”
Most of the DB2 Statistics values accumulate while DB2 is active. When DB2 is started, accumulation begins and continues until DB2 is stopped. There are, however, certain fields that are not cumulative.

“Processing modes” on page 32
You can display the Statistics values in different modes: regular, interval, and delta.

“Viewing Statistics information” on page 34
This topic describes how to view Statistics information for a DB2 subsystem.

“Viewing the SQL statements in the dynamic SQL cache” on page 35
This topic describes how to view the SQL statements in the dynamic SQL cache.

“Refreshing buffer pool Statistics” on page 36
The contents of a window or contents pane is normally refreshed when an automatic refresh occurs or when you click View > Refresh.

Statistics values

Most of the DB2 Statistics values accumulate while DB2 is active. When DB2 is started, accumulation begins and continues until DB2 is stopped. There are, however, certain fields that are not cumulative.

Some are reported as snapshot values (gauge values in a workgroup environment), and some are reported as high-water mark values. A snapshot value is a current value. It is updated each time the Statistics values are displayed. A high-water mark is the highest value reached since startup. It is updated each time the Statistics values are displayed.
The values in fields other than snapshot or high-water mark fields are accumulated or delta values. They are calculated by the Statistics display and derived differently for each of the Statistics processing modes.

**Processing modes**

You can display the Statistics values in different modes: regular, interval, and delta.

*Interval* and *delta* modes determine the time period over which delta values are accumulated.

In all modes, Statistics values are updated each time a refresh occurs.

"Regular processing"

Regular processing is the default processing mode whenever you open a Statistics window.

"Interval processing" on page 33

The interval mode allows you to isolate DB2 Statistics activity beginning at a specific time.

"Delta processing" on page 33

Delta processing allows you to isolate DB2 Statistics activity between two snapshot refreshes.

**Regular processing**

Regular processing is the default processing mode whenever you open a Statistics window.

Figure 3 on page 33 shows that the values displayed are accumulated from the start of DB2.

---

*Figure 2. Snapshots and high-water marks*

The values in fields other than snapshot or high-water mark fields are accumulated or delta values. They are calculated by the Statistics display and derived differently for each of the Statistics processing modes.
No calculations are performed on the Statistics values in this mode.

**Interval processing**

The interval mode allows you to isolate DB2 Statistics activity beginning at a specific time.

*Figure 4* shows the interval processing mode.

In this mode, all Statistics windows show the delta values accumulated since the start of interval processing. *Figure 4* shows the interval processing mode. In this case, accumulation is set to zero and all future snapshots are accumulated from this point. When you stop interval processing, all following snapshots are shown in regular mode again, that is, as accumulated since the start of DB2.

**Delta processing**

Delta processing allows you to isolate DB2 Statistics activity between two snapshot refreshes.

*Figure 4* shows delta processing. It can help you discover a problem when running exception processing.

In this mode, all Statistics windows show the delta between the values of two consecutive snapshots. This means, accumulation starts at zero after each snapshot. When you stop delta processing, all following snapshots are shown in regular mode again, that is, as accumulated since the start of DB2.
Viewing Statistics information

This topic describes how to view Statistics information for a DB2 subsystem.

To view Statistics information for a DB2 subsystem:

- In the System Overview window, select the DB2 subsystem in the folders pane
  and then click the Statistics Details toolbar button ( ).
- You can also use the menu bar or pop-up menu: click the DB2 subsystem in the folders pane, then click Selected > Monitor > Statistics Details on the menu bar or Monitor > Statistics Details on the pop-up menu.

If you are not connected to the selected DB2 subsystem, you are prompted to log on.

The Statistics Details window is displayed.

The folders pane of the Statistics Details window lists the counter categories. The contents pane shows the counters for the selected counter category. You can get more details on a counter category by clicking it in the folders pane.

Some DB2 counters are also shown as percentages in bar charts, stacked to 100%. Each bar in the chart represents a snapshot and reflects several counters. The percentages of these counters are shown proportionately and accumulated to add up to 100%. Click the bar chart to see which counters are represented. You can increase or decrease the number of snapshots that are shown in a bar chart by using the plus (+) and minus (-) signs next to the x-axis of the chart.

An icon appears next to the counter affected if:

- You run periodic exception processing.
- You specified a warning threshold, problem threshold, or both for one or more DB2 counters in the Statistics Details window.
- A counter value falls below or above a threshold.

When you move your mouse pointer over such a counter, you see the timestamp of the exception. The icon disappears after the counter value falls below or above the threshold or after periodic exception processing is stopped and you refresh the data in the window. No icon is shown for counters listed in a table.

On the SQL Statement pane, you see the text of the SQL statement that was recently performed by the thread. You can view the access plan for this statement in graphical format by clicking Explain. Refer to Chapter 13, “Using Explain products to analyze and improve SQL statements,” on page 69 for more information. If the statement text is much longer than the space provided and, therefore, difficult to read, you can view it in another window. Click View Statement in New Window.

Related information:

- The Statistics Details window shows part of its performance information in tables. In contents panes containing a table:
  - One or more columns might be hidden. For information about how to view hidden counters, to hide counters that you are not interested in, or to change the order of the columns, refer to “Customizing table columns” on page 73.
You can choose to view details on a table entry in another window or on a notebook page. For more information, refer to “Viewing details on a table entry in a contents pane” on page 74.

- Performance counter values that are too long are truncated. For information about how to view the entire value, refer to “Viewing long performance counter values” on page 74.
- If you are monitoring a member of a data sharing group, refer to Chapter 11, “Monitoring data sharing groups,” on page 65 for more information.
- If the OMEGAMON Collector and Performance Expert Client are in different time zones, refer to “Working in different time zones” on page 74 for more information.

---

**Viewing the SQL statements in the dynamic SQL cache**

This topic describes how to view the SQL statements in the dynamic SQL cache.

You can view detailed information about the SQL statements in the dynamic SQL cache as follows:

1. In the folders pane of the Statistics Details window, click **Dynamic SQL Statements** and then click **SQL Statements**.
   
   The SQL Statements pane is displayed without any entries.

2. To display the SQL statements that are in the cache:
   
   a. Click the **Filter** toolbar button to check the filter values and set the appropriate values for your subsystem. For more information about defining filter criteria, see step 5.
   
   b. Select the **Receive Statement Cache information** check box.

   The list is refreshed whenever you click **View > Refresh** or when an automatic refresh occurs.

3. The SQL statements in the cache might be shown with the value 0 for all counters because no trace data has been collected yet. To get all values for the counters, click the **Start** toolbar button to start the collection of the specified counter values.

   After the next refresh, the counter values of all SQL statements displayed reflect the values collected since the trace started.

   Trace data collection continues until you click the **Stop** toolbar button. Because tracing can increase the overhead, stop tracing when you have finished working with the SQL statements. You can only stop the traces that you started.

4. To view the text of an SQL statement, double-click the statement.

   The SQL Statements text page opens, where text stands for the first couple of characters of the statement text.

   **Note:** If the text is much longer than the space provided and therefore difficult to read, click **View Statement in New Window** to view the text in another window.

   This page contains the text and the counters of the SQL statement. If you have an Explain product installed and the statement contains a SELECT, UPDATE, INSERT, DELETE, or VALUES clause, you can click **Explain** to view the access path. For more information about Explain products, refer to Chapter 13, “Using Explain products to analyze and improve SQL statements,” on page 69.

5. To reduce the list of SQL statements:
   
   a. Return to the SQL Statements pane of the Statistics Details window.
b. Click the Filter \( \text{Filter} \) toolbar button. The Dynamic Statement Cache Filter Criteria window is displayed.

c. Choose your filter method:
   - If you want to list only those SQL statements where a specific counter exceeds a certain value:
     Click Statements with value higher than, specify a value, and then select one of the counters listed under Fields.
   - If you want to display the SQL statements sorted by the values of a counter in descending order:
     Click Statements with highest value and then select one of the counters listed under Fields.
     This option is useful, for example, if there are more SQL statements in the cache than can be displayed (up to 1 MB). For example, if there are 5 MB of SQL statements in the cache and you are mainly interested in those with high Getpage counter values, ensure that these SQL statements are displayed by using this option.

d. Click OK to return to the SQL Statements pane.
   The list of SQL statements is changed according to your filter criteria. The filter remains valid until you change it.

Restriction: If you are viewing history data, you cannot define a filter. For more information about history data, refer to Chapter 12, “Viewing history data,” on page 67.

6. To change the order of the table columns shown or hide the table columns that you are not interested in, click the Customize Columns \( \text{Customize Columns} \) toolbar button. The Customize Columns window is displayed.
   For further information about how to customize columns, see “Customizing table columns” on page 73.

---

**Refreshing buffer pool Statistics**

The contents of a window or contents pane is normally refreshed when an automatic refresh occurs or when you click View > Refresh.

This does not apply, however, to buffer pool Statistics at dataset level.

Buffer pool Statistics at dataset level are received using IFCID 199. If I/O activity has taken place (at least one I/O per second), DB2 updates the list of buffer pool data sets every five minutes or according to the time interval set in the Online data set Statistics time interval (minutes) parameter in the Tracing Parameters (DSNTIPN) pane of the System Parameters window.

To view the update:
1. On the Data Sets pane of the Buffer Management page of the Statistics Details window, select the Receive data set information check box.
2. Click View > Refresh when the time interval has elapsed.
Chapter 7. Viewing system health

Statistics information for a DB2 subsystem can be viewed as numerical values and percentages on various Statistics Details windows or as snapshots in graphical format.


To view Statistics information in graphical format you can do one of the following:

• In the System Overview window, select the DB2 subsystem in the folders pane and then click the System Health toolbar button.

• You can also use the menu bar or pop-up menu: click the DB2 subsystem in the folders pane, then click Selected > Monitor > System Health on the menu bar or Monitor > System Health on the pop-up menu.

If you are not connected to the selected DB2 subsystem, you are prompted to log on.

The System Health window is displayed, split into the following panes:

• The folders pane on the left lists one or more of the following data groups:
  – The System Overview data group, which contains links to data views in data groups that you have defined. These linked data views are displayed as performance graphs on the Data Views page of the System Overview window. They are refreshed at the refresh rate that you specified for the DB2 subsystem in the System Overview window.
  – Any data groups and data views that you have defined.
• The contents pane on the right displays the contents of the selected data group.

You can arrange one or more counter categories, such as Hit ratios or Physical locks (P-locks), as data views in a data group. Each data view consists of a graphical representation, a legend, and a report of the counters selected for the counter category. Each data group can contain a different selection and arrangement of data views.

This section uses scenarios to help you understand and get started with system health. In addition, it describes the tasks that you are most likely to perform in system health.

Related information:

• If you are monitoring a member of a data sharing group, refer to Chapter 11, “Monitoring data sharing groups,” on page 65 for more information.

• If you are working in different time zones, refer to “Working in different time zones” on page 74 for more information.

The scenarios in this section are based on a data view that you create with the following steps. The options that you select and any alternatives are explained later in the section.

“Scenario 1: Viewing current system health” on page 39
If your system is not performing well and you want to know when this started, you are interested in snapshots that were taken earlier and are probably no longer displayed to you. The following scenario tells you how to view past system health using the data view that you created and helps you understand the chart and the values displayed.

Scenario 3 describes how to create a data view. This topic describes how to change the properties of a data view.

If you want to examine a snapshot in more detail or print the current chart, you must stop the continuous addition of new snapshots to your chart without canceling data collection. To achieve this freeze the display of snapshots. In the folders pane, click the data view that you want to freeze and then click Selected > Freeze.

You can display one or more data views as performance graphs on the Data Views page of the System Overview window. This data view must have been created in a data group that you defined and it must contain a link in the System Overview data group of the System Health window.

You can copy data views and data groups within a DB2 subsystem and export and import entire data groups. This is useful, for example, if you want to share your configurations with your colleagues or use the same data views or data groups under several DB2 subsystems. Copying and moving data views between data groups also helps you organize your views.

This topic lists reasons for gaps and sudden drops or rises in charts.

---

**Getting started**

The scenarios in this section are based on a data view that you create with the following steps. The options that you select and any alternatives are explained later in the section.

Perform the following steps:

1. Define a data group in which you will place the data view:
   a. Click Data Groups and then click Selected > New. The New Data Group window is displayed.
   b. Type My Locking in the New name field and then click OK.
      The new group appears in the folders pane of the System Health window.

2. Click Data views and then click Selected > New to define a data view. The New Data View wizard appears.

3. On the Category page:
   - In the Data view name field, type Locking as the name for this data view.
   - In the Data view category list, select Locking. The categories in the list correspond to the Statistics categories for counters and data elements.
   - Click Next to display the Counter page.

4. On the Counters page:
• In the Counter selection list, select the Lock requests and Unlock requests check boxes to specify the counters for the data view.
• Leave Not stacked selected as type of counter display. The counters are then displayed independently of one another as separate bars in a bar chart or lines in a line chart.
• Click Next to display the Thresholds page.

5. On the Thresholds page:
• Next to Static scale, change the default 1000 units to 30 and select Second.
• Click Next to display the Graphics page.

6. On the Graphics page, leave the default selections and values. Note that Bar chart is selected to display the counters as bars.

   Click Finish.

When you work with System Health for the first time, data is refreshed every 6 seconds and the new My Locking data view looks similar to this one:

![System Health window containing new data group and data view](image)

**Scenario 1: Viewing current system health**

The following scenario shows how to collect and display snapshots and helps you understand the chart and the values displayed. As an example, it uses the data view that you previously created.

Perform the following steps:
1. To start the collection and display of snapshots, in the toolbar, select **Automatic** in the **Refresh** field.

2. To specify how often a snapshot is to be collected and shown in the data view: click in the time field next to the **Refresh** field and overtype the displayed time with **0:00:06**, which is 6 seconds. Then press Enter. The data in the data view is refreshed every 6 seconds, which is the minimum refresh time.

By default, the latest eight snapshots are displayed in a bar chart. When this number is exceeded, a scroll bar appears at the bottom of the chart for you to scroll through the snapshots collected since the start of the collection. By default, up to 100 snapshots are kept in memory and can be viewed. Any older snapshots are stored in the history data set and can be viewed in history mode. See “Scenario 2: Viewing past system health” on page 41.

The background color of a snapshot alternates for you to see when a new snapshot starts. This is useful if you selected several counters for a data view and, therefore, a snapshot consists of several bars.

The y-axis of the chart ends slightly above unit 700 because the highest visible value of one of the counters is just under 700. The y-axis changes when the highest value of one of the counters increases or decreases.

The values shown in the chart represent the delta between two subsequent snapshots. For example, assume that each minute 30 lock and unlock requests are performed, which is one every two seconds. Then a delta value of 3 is shown for snapshots that are taken every 6 seconds. The delta is smaller if you decrease the refresh time and is higher if you increase the refresh time.

3. To see which counters are represented in the data view and in which colors, click **Legend**.

4. To view the values for the individual counters, you can do one of the following:
   - Click a snapshot in the data view, to view the values for a specific snapshot.
   - Click **Report** to get an overview of several snapshots.

The scale of a chart depends on the threshold that you set for the counters in the data view.

5. To change the threshold for the data view:
   a. Click **Selected > Properties**. The Properties window is displayed. Click the **Thresholds** tab.

      A threshold for a counter is specified as units per time interval. The **Static scale** field shows 30 units per second, which you specified when creating the data view. This means that the threshold is reached if a lock or an unlock request is performed 30 times per second.

   b. Change 30 to 60 and then click **Finish**.

The y-axis of the data view reflects the threshold change. Because the data is refreshed every 10 seconds, the threshold is reached if a lock or an unlock request is performed, 600 times during this period. Therefore, the red horizontal (threshold) line is now at unit 600 and the y-axis of the chart ends slightly above it.
Scenario 2: Viewing past system health

If your system is not performing well and you want to know when this started, you are interested in snapshots that were taken earlier and are probably no longer displayed to you. The following scenario tells you how to view past system health using the data view that you created and helps you understand the chart and the values displayed.

For the purpose of this scenario, it is assumed that you have collected locking data for at least a couple of minutes and you selected a refresh time of 10 seconds and a threshold of 60 units per second.

Perform the following steps:

1. To start the display of past system health, in the toolbar, select History in the Data field.
   
   The history slider is activated and the Refresh field is disabled.

2. Move the slider to a time during which snapshots were collected and wait a couple of seconds to receive the data.

The chart has changed as follows:

- The chart shows the eight snapshots collected from the time that the slider indicates. The time of the first and last snapshots displayed is shown below the chart.

  Note that the collection of the current snapshot continues in the background. So when you leave history mode, the most recent snapshots are displayed.

- The scale of the y-axis, the place of the threshold line, and the size of the bars changed:

  When you view the current system health you can specify how often the snapshots are refreshed. History snapshots are, however, displayed at the interval at which the OMEGAMON Collector collects data, which is 60 seconds for the recording interval. Because the refresh rate is now 60 seconds (instead of the 10 seconds you previously specified), the y-axis of the chart now ends above 3500 and contains a (threshold) line at unit 3600 and the size of the bars is adjusted accordingly.

For more information about how to select history snapshots in different ways, see Chapter 12, “Viewing history data,” on page 67.

The number of snapshots available is limited by the size of the history file on the host. If their number exceeds this size, the oldest snapshot is deleted. Your chart reflects this change and the timestamp to the lower left of the chart is adapted.

Scenario 3: Creating a data view

Scenario 3 describes how to create a data view.

You can create a data view in one of the following ways:

- Create a data view from scratch as shown in “Getting started” on page 38.

- Copy an existing data view and then change it according to your needs. You can also copy a data view that is delivered with OMEGAMON XE for DB2 PE and contained in the Default Group data group.

- Use the templates delivered with OMEGAMON XE for DB2 PE. To create a data view using a template click Data views under the data group that is to contain
the new data view and then click Selected > Open Predefined Data View. The Open Predefined Data View window appears, which lists the templates that you can select.

---

**Changing the properties of a data view**

This topic describes how to change the properties of a data view.

Most of your tasks in system health changes to the system health chart. They are explained in the following sections using the data view you created in “Getting started” on page 38. To change this data view:

Click the data view in the folders pane and then click Selected > Properties. The Properties window is displayed, which is similar to the New Data View wizard.

- “Changing the method for displaying the counters” on page 42
  In many cases, it is useful to display the counters as lines instead of bars. Or, you might want to see the ratio between the counters.

- “Specifying a global threshold” on page 43
  When defining a data view, you must specify a global threshold for all counters. This threshold enables you to see at which time a counter exceeds a certain value.

- “Specifying and adjusting single thresholds” on page 44
  In addition to the global threshold, you can also specify a threshold for each counter in your data view. These thresholds do not affect the scale of the chart. You can specify the thresholds if you view the counters in a non-stacked bar or line chart.

- “Changing the appearance of the bars, lines, or areas in the chart” on page 47
  At any time, you can change the color of bar, line, and area charts and the pattern of bar charts. In addition, you can add a grid to your chart where a vertical line separates the snapshots. You perform these changes on the Graphics page of the Properties window.

- “Changing the number of visible snapshots in the chart” on page 47
  By default, a chart contains eight snapshots in a bar chart or 30 snapshots in a line or area chart. This is defined in the Number of visible snapshots field on the Graphics page of the Properties window. You might, however, want to examine a longer snapshot period in a bar chart or view fewer snapshots in a line chart. You can change the default to a number from 4 through 99 or the number in the Maximum number of kept snapshots field.

**Changing the method for displaying the counters**

In many cases, it is useful to display the counters as lines instead of bars. Or, you might want to see the ratio between the counters.

OMEGAMON XE for DB2 PE provides the following chart types:

- “Non-stacked bar chart” on page 43
- “Non-stacked line chart” on page 43
- “Stacked bar chart” on page 44
- “Stacked area chart” on page 44
- “Stacked-to-100% bar chart” on page 45

To view these charts, you must change your selections under Type of counter display on the Counters page of the Properties window and under Chart type on the Graphics page of this window.
If a data view contains counters represented by numeric values and counters expressed as percentages, the chart has two scales, one for the numeric values and one for the percentages.

“Non-stacked bar chart”
This section describes the non-stacked bar chart.

“Non-stacked line chart”
This section describes the non-stacked line chart.

“Stacked bar chart” on page 44
This section describes the stacked bar chart.

“Stacked area chart” on page 44
This section describes the stacked area chart.

“Stacked-to-100% bar chart” on page 45
This section describes the stacked-to-100% bar chart.

Non-stacked bar chart
This section describes the non-stacked bar chart.

A sample is shown in Figure 7.

- Characteristics and purpose:
  The counters are displayed independently of one another as separate bars in a bar chart. They can be a mixture of numeric and percentage values. This chart type is useful if you want to know the absolute values of each counter displayed and specify thresholds for individual counters (see “Specifying and adjusting single thresholds” on page 46).

- Selections on Counters and Graphics pages:
  On the Counters page, select Not stacked as type of counter display.
  On the Graphics page, select Bar chart as chart type.

Figure 7. Non-stacked bar chart

Non-stacked line chart
This section describes the non-stacked line chart.

A sample is shown in Figure 8 on page 44.

- Characteristics and purpose:
  The counters are displayed independently of one another as separate lines in a line chart. They can be a mixture of numeric and percentage values. This chart type is useful if you want to get an overview of the absolute values of each counter displayed over a larger time period. You can specify thresholds for individual counters (see “Specifying and adjusting single thresholds” on page 46).
Selections on Counters and Graphics pages:

On the Counters page, select Not stacked as type of counter display. On the Graphics page, select Line chart as chart type.

Stacked bar chart
This section describes the stacked bar chart.

A sample is shown in Figure 9:

- Characteristics and purpose:
  - The counters are accumulated in a single bar. They can be numeric values or percentage values. This chart type is useful if you want to see the value that each snapshot adds up to.

- Selections on Counters and Graphics pages:
  - On the Counters page, select Stacked as type of counter display.
  - On the Graphics page, select Bar chart as chart type.

Stacked area chart
This section describes the stacked area chart.

A sample is shown in Figure 10 on page 45:

- Characteristics and purpose:
  - The counters are accumulated in an area. They can be numeric values or percentage values. This chart type is useful if you want to view, over a larger period, the value that each snapshot adds up to.

- Selections on Counters and Graphics pages:
  - On the Counters page, select Stacked as type of counter display.
On the Graphics page, select **Area chart** as chart type.

![Stacked area chart]

**Figure 10. Stacked area chart**

**Stacked-to-100% bar chart**

This section describes the stacked-to-100% bar chart.

A sample is shown in [Figure 11](#).

- **Characteristics and purpose:**
  
  The counters are shown proportionally in a bar chart. They are accumulated to add up to 100%. For example, if the counters have the values: a=2, b=5, c=7. the values shown are a=14%, b=36%, c=50%.

  This chart type is comparable to a pie chart where single values are changed to percentages to fill 100%. It is useful if you want to see the ratio between the counter values and you are not interested in thresholds for individual counters.

- **Selections on Counters and Graphics pages:**
  
  On the Counters page, select **Stacked to 100%** as type of counter display.
  
  On the Graphics page, **Bar chart** is selected because this is the only choice.

![Stacked-to–100% bar chart]

**Figure 11. Stacked-to–100% bar chart**

**Specifying a global threshold**

When defining a data view, you must specify a global threshold for all counters. This threshold enables you to see at which time a counter exceeds a certain value.

For example, when setting the threshold for the My Locking data view to 60 units per second, you want to see at a glance when a lock or an unlock request is performed, more than 60 times per second. The global threshold determines the scale of the chart and is represented as a red horizontal line. Step 5 on page 40 shows you how to define or change this global threshold.
If you are not sure which unit and time interval to specify, you can try a couple of values for the units and time interval. Or, to get you started, you can define the scale to automatically adapt to the highest visible value of a counter.

To adapt the scale to the highest visible value:
1. Display the Thresholds page of the Properties window.
2. Click Dynamic scale and then click Finish.

You can use this kind of counter display to calculate the units and time interval for the scale. However, it is also useful if you want to compare the actual values of the counters with each other or get a better view of the relation between two counters.

**Specifying and adjusting single thresholds**

In addition to the global threshold, you can also specify a threshold for each counter in your data view. These thresholds do not affect the scale of the chart. You can specify the thresholds if you view the counters in a non-stacked bar or line chart.

To specify thresholds for the lock and unlock request counters of the My Locking data view:
1. Display the Thresholds page of the My Locking Properties window.
2. Under Single thresholds, select the Threshold check box for each counter and specify a threshold:
   - For Lock requests, specify higher than 200 per Minute
   - For Unlock requests, specify higher than 100 per Minute
3. On the Graphics page, click Line chart as chart type and then click Finish.

You get a line chart with two additional threshold lines in the color of the respective counter. They are at about 20 units for lock requests and about 15 for unlock requests.

If you select a bar chart as chart type, you only see the threshold line if it is exceeded. In this case, the part of the bar exceeding this threshold is shaded.

Later you might want to change the global threshold (next to Static scale on the Thresholds page), which affects the scale of the chart. If you leave the single thresholds as they are, the proportions between the scale and the single thresholds are no longer correct.

To set the proportions right, perform the following steps on the Thresholds page of the Properties window:
1. Double the number next to Static scale: change 30 to 60.
2. The Adjust single thresholds button becomes available. Click this button.
   Under Single thresholds, the thresholds for the counters are automatically doubled.
3. Click Finish.
Changing the appearance of the bars, lines, or areas in the chart

At any time, you can change the color of bar, line, and area charts and the pattern of bar charts. In addition, you can add a grid to your chart where a vertical line separates the snapshots. You perform these changes on the Graphics page of the Properties window.

Except for non-stacked bar charts, a grid separates each snapshot. In a non-stacked bar chart, however, two subsequent snapshots are distinguished by a different background. Therefore, the grid appears after every two snapshots.

Changing the number of visible snapshots in the chart

By default, a chart contains eight snapshots in a bar chart or 30 snapshots in a line or area chart. This is defined in the Number of visible snapshots field on the Graphics page of the Properties window. You might, however, want to examine a longer snapshot period in a bar chart or view fewer snapshots in a line chart. You can change the default to a number from 4 through 99 or the number in the Maximum number of kept snapshots field.

You can also use the plus (+) and minus (-) signs next to the x-axis of the chart to increase or decrease the number of snapshots displayed.

The Maximum number of kept snapshots field defines how many snapshots are kept in memory by the data view. When this limit is exceeded the oldest snapshot is deleted and the latest snapshot is added. You can change the number in this field according to your needs.

Freezing the display of snapshots

If you want to examine a snapshot in more detail or print the current chart, you must stop the continuous addition of new snapshots to your chart without canceling data collection. To achieve this freeze the display of snapshots. In the folders pane, click the data view that you want to freeze and then click Selected > Freeze.

The name of the data view is shown in italics in the folders pane for you to see that the view is frozen. Data collection continues in the background. To see the dynamic updates, click Selected > Freeze again.

Displaying data views as performance graphs in the System Overview window

You can display one or more data views as performance graphs on the Data Views page of the System Overview window. This data view must have been created in a data group that you defined and it must contain a link in the System Overview data group of the System Health window.

If you want to display the IFI interface data view in the System Overview window, click the IFI interface data view in the folders pane of the System Health window and then click Selected > Display in System Overview.

A link to the selected data view is shown in the System Overview data group and the linked data view immediately appears on the Data Views page of the System Overview window. The name of the link consists of the name of the original data
group and the name of the original data view. The icon in front of the original data view has changed to indicate that this data view is shown in the System Overview window.

When you change a data view, you always change the original data view. The link is automatically updated.

The data views that are displayed on Data Views page of the System Overview are refreshed at the rate that you specified for the DB2 subsystem on the System Overview window. Snapshots continue to be collected and shown in the System Overview window even after you stop snapshot collection in the System Health window.

Reusing data-view and data-group configurations

You can copy data views and data groups within a DB2 subsystem and export and import entire data groups. This is useful, for example, if you want to share your configurations with your colleagues or use the same data views or data groups under several DB2 subsystems. Copying and moving data views between data groups also helps you organize your views.

To export or import a data group, click the data group in the folders pane and then click Selected > Export or Selected > Import. Use copy, cut, and paste to copy or move a data group or data view.

Gaps and sudden drops or rises in charts

This topic lists reasons for gaps and sudden drops or rises in charts.

If there is a gap in a line chart or between two bars in a bar chart, or two consecutive snapshots differ considerably from each other, the interval between the snapshots might have changed for one of the following reasons:

• DB2 has been restarted. Because the data view shows delta values, the delta between the last value before the DB2 stop and the first value after the DB2 restart would be a negative number. To reflect this situation, a gap appears in the chart and the Report section of the data view shows a value of N/C. To view the Report section click Report.

• The interval at which history data is collected might have been configured. A line chart shows a sudden drop or rise and a bar chart continues with much smaller or larger bars.
Chapter 8. Monitoring activities of DB2 Connect gateways and connections of DCS applications

You can monitor the activities of DB2 Connect servers (DB2 subsystem) that serve as DB2 Connect gateways. You can also monitor the connections of Database Connection Services (DCS) applications within the Distributed Relational Database Architecture (DRDA) of DB2. You can use the information that you obtain through these monitoring activities to evaluate the health of a DB2 Connect gateway and to make changes necessary to tune the system.

To monitor the activities of a DB2 Connect gateway and the connections of DCS applications, your system must meet the following criteria:

- Performance Expert Agent for DB2 Connect Monitoring is installed on the system, on which the DB2 Connect gateway runs, and is configured.
- At least one OMEGAMON Collector is registered for a Performance Expert Agent for DB2 Connect Monitoring.
- Performance Expert Agent for DB2 Connect Monitoring and the OMEGAMON Collector are started.

Related reading: Refer to [Configuration and Customization](#) for information about how to install, configure, and start Performance Expert Agent for DB2 Connect Monitoring and to register the OMEGAMON Collector.

Performance Expert Agent for DB2 Connect Monitoring periodically collects snapshots of performance-related information about the DB2 Connect gateway and the connections of DCS applications and sends them to the OMEGAMON Collector. One Performance Expert Agent for DB2 Connect Monitoring can send data to one or more OMEGAMON Collectors, and one OMEGAMON Collector can receive data from one or more Performance Expert Agents for DB2 Connect Monitoring. The collected data is stored in the DB2PM database of the OMEGAMON Collector.

[Figure 12 on page 50](#) provides an overview of how the activities of DB2 Connect gateways and the DCS connections are monitored.
Performance Expert Client enables you to view the collected data from various perspectives. You can view:

- A list of all DB2 Connect gateways that are connected to a specific DB2 subsystem. You can also view Statistics details on them.
- Statistics details on a specific DB2 Connect gateway, independent of any DB2 subsystem
- A list of all DCS applications that are connected to any DB2 subsystem and view details on them
- Information about the DCS application that is related to a specific thread

Related information:

- Some windows or panes show the key performance counters in a table. One or more columns might be hidden. For information about how to view hidden counters, to hide counters that you are not interested in, or to change the order of the columns, refer to “Customizing table columns” on page 73.
- You can display a list of all DB2 Connect gateways that are connected to a DB2 subsystem and view Statistics details on them.
- You can view information about a specific DB2 Connect gateway. In the System Overview window, select a DB2 Connect gateway in the folders pane and then click the Statistics toolbar button ( ).
- You can display a list of all the DCS applications that are connected to any DB2 subsystem and view details on them.
- You can view information about the DCS application that is related to a specific thread.
Viewing all DB2 Connect gateways connected to a DB2 subsystem

You can display a list of all DB2 Connect gateways that are connected to a DB2 subsystem and view Statistics details on them.

To view Statistics details:
1. In the System Overview window, select a DB2 subsystem in the folders pane and then click the Statistics Details toolbar button ( ).
   If you are not connected to this DB2 subsystem, you are prompted to log on.
2. In the folders pane of the displayed Statistics Details window, click DB2 Connect Server.
   The DB2 Connect Server pane opens, which lists all the DB2 Connect gateways that are connected to this DB2 subsystem.
3. To get more Statistics details on a specific DB2 Connect gateway, double-click it.
   The DB2 Connect Server ip page opens, where ip stands for the IP address of the selected DB2 Connect gateway. On the various panes, you find:
   - Statistics about the DB2 Connect gateway, including details on the number of agents and pooled agents, the connections waiting for the host to reply, and the connections waiting for the client to send a request
   - Statistics about the processes at the selected DB2 Connect gateway, such as the CPU and the working set
   - The amount of time that is required to process a sample SQL statement
   - Statistical details on the packages received at the DB2 Connect gateway

Viewing Statistics details on a specific DB2 Connect gateway

You can view information about a specific DB2 Connect gateway. In the System Overview window, select a DB2 Connect gateway in the folders pane and then click the Statistics toolbar button ( ).

If you are not connected to this DB2 Connect gateway, you are prompted to log on to the OMEGAMON Collector that is receiving information from the Performance Expert Agent for DB2 Connect Monitoring that is monitoring the DB2 Connect gateway.

The Statistics window opens. The information shown in this window is identical to the information on the DB2 Connect Server ip page of the Statistics Details window. See “Viewing all DB2 Connect gateways connected to a DB2 subsystem.”
Viewing information about all DCS applications connected to any DB2 subsystem

You can display a list of all the DCS applications that are connected to any DB2 subsystem and view details on them.

To view details:
1. In the System Overview window, select a DB2 Connect gateway in the folders pane and then double-click Application Summary in the contents pane.
   If you are not connected to this DB2 Connect gateway, you are prompted to log on.
   The Thread Summary window opens, which shows the key data for the DCS application connected to any DB2 subsystem.
2. To get more details on a specific DCS application, double-click it.
   The Thread Details window opens. On its various panes, you find:
   • An overview of the DCS application, such as cumulative counters and status information.
   • Information about the SQL statement that was last executed by the DCS application, including network Statistics, the host response time, and the CPU time distribution.
   • Outbound and inbound data and the network time taken to transmit the data.

Viewing information about the DCS application related to a thread

You can view information about the DCS application that is related to a specific thread.

To view information about the DCS application that is related to a specific thread:
1. In the System Overview window, click a DB2 subsystem in the folders pane and then double-click Thread Summary in the contents pane.
   If you are not connected to this DB2 subsystem, you are prompted to log on.
   The Thread Summary window opens, which shows the key performance counters for all connected threads.
2. Double-click a thread.
   The Thread Details window opens.
3. In the folders pane of the Thread Details window, click DB2 Connect Server.
   The DB2 Connect Server pane is displayed, which lists the related DCS application.
4. To get more details on this DCS application, double-click it.
   The DB2 Connect Server appl_id page is displayed. appl_id stands for the identifier that is generated when the application connects to the database at the database manager or when Distributed Database Connection Services (DDCS) receives a request to connect to a DRDA database. The information shown on the various panes of this page is identical to the information on the Thread Details window. See "Viewing information about all DCS applications connected to any DB2 subsystem."
The gateway snapshot time

The Gateway Snapshot Time counter on the DB2 Connect Server pane of the Statistics Details window and on the Statistics window shows the timestamp at which the snapshot was taken at the DB2 Connect gateway. This timestamp usually differs from the snapshot timestamp of the OMEGAMON Collector.

If you are viewing current data, the OMEGAMON Collector displays the most recent data that was received from the DB2 Connect gateway. In history mode, the OMEGAMON Collector searches for a DB2 Connect gateway snapshot that is closest to the history snapshot of the OMEGAMON Collector.

If the DB2 Connect gateway, OMEGAMON Collector, Performance Expert Client, or all of them are in different times zones, the times shown in the Gateway Snapshot Time counter and for the OMEGAMON Collector snapshot are adapted to the Performance Expert Client time. For example, if the OMEGAMON Collector receives a snapshot from the DB2 Connect gateway that was taken at 11 a.m., the OMEGAMON Collector location is two hours ahead of the DB2 Connect gateway location, and the Performance Expert Client location is three hours ahead of the OMEGAMON Collector location, the Gateway Snapshot Time counter displays a time of 16:00 (4 p.m.).
Chapter 9. Viewing DB2 system parameters

You can view the system parameter values that you specified when configuring a DB2 subsystem.

To view the database configuration do one of the following:

- In the System Overview window, select the DB2 subsystem in the folders pane and then click **System Parameters** toolbar button ( )
- You can also use the menu bar or pop-up menu: click the DB2 subsystem in the folders pane, then click **Selected > Monitor > System Parameters** on the menu bar or **Monitor > System Parameters** on the pop-up menu.

If you are not connected to the selected DB2 subsystem, you are prompted to log on.

The System Parameters window shows the current values for the selected DB2 subsystem.

To view detailed information for a system parameter, click the name of the parameter in the folders pane.

Related information:

- The System Parameters window shows some of its system parameters in tables. In contents panes containing a table:
  - One or more columns might be hidden. For information about how to view hidden counters, to hide counters that you are not interested in, or to change the order of the columns, refer to “Customizing table columns” on page 73.
  - You can choose to view details on a table entry in another window or on a notebook page. For more information, refer to “Viewing details on a table entry in a contents pane” on page 74.
- Some windows or panes show the key performance counters in a table. One or more columns might be hidden. For information about how to view hidden counters, to hide counters that you are not interested in, or to change the order of the columns, refer to “Customizing table columns” on page 73.
- Performance counter values that are too long are truncated. For information about how to view the entire value, refer to “Viewing long performance counter values” on page 74.
- If you are working in different time zones, refer to “Working in different time zones” on page 74 for more information.
Chapter 10. Working with exception processing

Exception processing is an efficient way to monitor DB2 subsystems for performance problems. When exception processing is active, you are informed when certain events occur, or when specific counters reach levels that might produce problems.

Exceptions are recorded by the OMEGAMON Collector. To run exception processing, it must be set up during the customization of the OMEGAMON Collector.

Related reading: For more information about setting up exception processing, refer to Configuration and Customization.

Exception processing is started when the OMEGAMON Collector is started. It continues until you stop it, the OMEGAMON Collector or DB2 is stopped, or you log off from the DB2 subsystem that you are monitoring. When you leave Performance Expert Client you can request that the collection of exception processing data is continued.

OMEGAMON XE for DB2 PE supports:
- Event exception processing: This monitors a DB2 subsystem for the occurrence of particular events.
- Periodic exception processing: This periodically monitors thread-activity and Statistics fields for exception conditions.

This section explains how to start and stop exception processing, to view the exceptions that occurred, and to use the exception user exit.

"Starting exception processing"
This topic explains how to start exception processing.

"Processing event exceptions” on page 58
This topic shows how to process event exceptions.

"Processing periodic exceptions” on page 61
You can use periodic exception processing to periodically check DB2 counters against specific thresholds. When the value of a counter falls above or below these thresholds, an exception is logged.

"Working with the exception user exit” on page 63
OMEGAMON XE for DB2 PE supports a user exit to handle event and periodic exceptions. This user exit is a predefined exit point where a user-written routine can be given control.

Starting exception processing

This topic explains how to start exception processing.

To work with exception processing, you can do one of the following:
- In the System Overview window, select the DB2 subsystem in the folders pane and then click the Exception Processing toolbar button ( ).
In the System Overview window, click **Tools > Exceptions > Exception Processing**.

The Exception Processing window is displayed.

This window provides information about the status of both event and periodic exception processing for all DB2 subsystems to which you are logged on. The icons that are displayed when you click **Event Exceptions** in the folders pane of the window have the following meaning:

- ![ ] The event is supported by the OMEGAMON Collector and switched on at its startup.
- ![ ] The event is supported by the OMEGAMON Collector but was not switched on at its startup.
- **N/A** The event is not supported by the OMEGAMON Collector.

The Exception Processing window shows up to the latest 9999 exceptions recorded. If you want to change this number, click **Exception Processing > Settings**. The Exception Settings window is displayed. On its pages, you can change the number of entries that is collected in the log for event exception and periodic exception processing.

If you want to be informed whenever an exception is recorded, you can choose to be notified by a message or a beep. Click **Exception Processing > Settings**. The Exception Settings window is displayed. On its pages, you can specify the kind of notification for event exceptions and periodic exceptions.

---

### Processing event exceptions

This topic shows how to process event exceptions.

When you monitor event exceptions, you are informed about the following events:

- Authorization failure
- Coupling facility rebuild start
- Coupling facility rebuild stop
- Coupling facility alter
- Data set extension
- Deadlock
- EDM pool full
- Global trace start
- Log space shortage
- Thread commit in doubt
- Timeout
- Unit of recovery problem

All events must be enabled on the OMEGAMON Collector.

**Related reading:** Refer to [Configuration and Customization](#) for information about how to enable an event.

You can monitor exceptions for one or more DB2 subsystems.
“Starting and stopping event exception processing”
This topic show how to start and stop event exception processing.

“Viewing event exceptions”
To get more information about an event exception, double-click it in the Event Exception Log pane of the Exception Processing window or in the 100 Most Recent Exceptions pane of the System Overview window.

“Viewing deadlocks” on page 60
This topic shows how to find out if a deadlock occurs.

“Viewing details on a deadlock” on page 60
When a deadlock occurs, you need to know what caused the deadlock and how to resolve it. OMEGAMON XE for DB2 PE helps you find the reasons for a deadlock by supplying information, such as which threads are involved in the deadlock, which statements led or might have led to the deadlock, and which thread holds the resource that is requested by another thread.

Starting and stopping event exception processing
This topic show how to start and stop event exception processing.

To start monitoring for event exceptions:
1. In the Exception Processing window, click Exception Processing > Activation - z/OS.
   The Activation window is displayed. The exact name of, the layout of, and the selections possible on, this window depend on whether you are logged on to one or to several DB2 subsystems. The following table shows the various possibilities.

<table>
<thead>
<tr>
<th>If you are logged on to ...</th>
<th>Description of Activation window</th>
</tr>
</thead>
<tbody>
<tr>
<td>One DB2 subsystem</td>
<td>The Activation – subsystem is displayed, where subsystem stands for the name of the DB2 subsystem to which you are logged on. The event list shows all events supported by z/OS. The events enabled by the OMEGAMON Collector are selected.</td>
</tr>
<tr>
<td>Several DB2 subsystems</td>
<td>The Activation – z/OS window is displayed. This window consists of the DB2 subsystems pane, listing all DB2 subsystems to which you are logged on, and the Activation pane. Select the DB2 subsystems you want to monitor. The event list appears and shows all events supported by z/OS. The events that are enabled on the OMEGAMON Collector of at least one DB2 subsystem are selected. The selected events that are not enabled by all OMEGAMON Collectors are followed by an asterisk (*).</td>
</tr>
</tbody>
</table>

2. Click the Start ( ) button next to Event exception processing.

To stop event exception processing:
1. In the Exception Processing window, click Exception Processing > Activation.
   The Activation window is displayed.

2. Click the Stop ( ) button next to Event exception processing.

Viewing event exceptions
To get more information about an event exception, double-click it in the Event Exception Log pane of the Exception Processing window or in the 100 Most Recent Exceptions pane of the System Overview window.

When an event exception occurs, you are informed in the following ways:
• An entry is added to the Event Exception Log pane of the Exception Processing window.
• An entry is added to the 100 Most Recent Exceptions pane of the System Overview window.
• A message appears, a beep is issued, or both, if you requested this kind of notification in the Exception Settings window.

**Viewing deadlocks**
This topic shows how to find out if a deadlock occurs.

When a deadlock occurs, you are informed in the following ways:
• An entry is added to the Event Exception Log pane of the Exception Processing window.
• In the folders pane of the System Overview window, the icon changes next to the DB2 Subsystem for which the deadlock was recorded and next to the folders that contain this DB2 Subsystem. The event exception icon (⚠️) change remains, by default, for at least five minutes or for the minimum period of time that you specified on the Preferences page of the Configuration window. See “Specifying global settings” on page 14. An event exception icon overrules any warning or problem icon.
• An entry is added to the Exceptions page of the System Overview window.
• By a message, a beep, an e mail, or a mixture of them. Whether you receive these types of information, and which of them, depends on your specifications in the Exception Settings window and on the Exception page of the OMEGAMON Collector Properties window. To receive an e mail, you must also have requested this type of information about the Activation window.
• By using a user exit. In this case, you must have enabled the user exit and specified its path on the Exception page of the OMEGAMON Collector Properties window. In addition, you must have selected the user exit in the Activation window. For information about how to write a user exit, refer to “Working with the exception user exit” on page 63.

**Viewing details on a deadlock**
When a deadlock occurs, you need to know what caused the deadlock and how to resolve it. OMEGAMON XE for DB2 PE helps you find the reasons for a deadlock by supplying information, such as which threads are involved in the deadlock, which statements led or might have led to the deadlock, and which thread holds the resource that is requested by another thread.

To view this information:
1. Double-click a deadlock in the Event Exception Log pane of the Exception Processing window or on the Exceptions page of the System Overview window. The various pages of the Deadlock Details window provide you with all the information that you need to narrow down the reasons for the deadlock.
2. To get information about the thread that was rolled back (*victim*), about the system and the DB2 Subsystem on which the deadlock occurred, and about the number of threads that are involved in the deadlock, have a look at the Overview page.
Processing periodic exceptions

You can use periodic exception processing to periodically check DB2 counters against specific thresholds. When the value of a counter falls above or below these thresholds, an exception is logged.

To run periodic exception processing, you must first define thresholds for specific fields.

“Establishing thresholds”

DB2 provides a comprehensive set of thread-activity and Statistics fields. However, you usually need to define only a limited number of thresholds. Long response times are a good indicator of a performance problem, so start by defining exception thresholds for time fields. You can, for example, set thresholds that are appropriate to your environment for class 1 and class 2 elapsed times.

“Starting and stopping periodic exception processing” on page 62

This topic describes how to start and stop periodic exception processing.

“Viewing periodic exceptions” on page 62

This topic describes how to view periodic exceptions.

Establishing thresholds

DB2 provides a comprehensive set of thread-activity and Statistics fields. However, you usually need to define only a limited number of thresholds. Long response times are a good indicator of a performance problem, so start by defining exception thresholds for time fields. You can, for example, set thresholds that are appropriate to your environment for class 1 and class 2 elapsed times.

Decide which are the most important applications or transactions in your system. Always define exception thresholds for critical business applications. Frequently executed applications are also good candidates for exception thresholds.

In a threshold set, you specify thresholds for all DB2 counters that you want to monitor together.

To create a threshold set:

1. In the Exception Processing window, click Exception Processing > New Threshold Set.
   The New Threshold Set window is displayed.
2. Select z/OS as operating system.
3. Type a unique name for the set and your name (this is usually your logon user ID). Then click OK.
   An empty Threshold Set Editor window is displayed.
4. To add a threshold, click Threshold Set > New Threshold.
   The New Threshold window is displayed.
5. Under Exception field, you select the counter you want to monitor. Select the appropriate exception category and exception subcategory. Then select the counter from the Select the exception field list.
6. Under Warning and problem thresholds, specify the threshold values for warnings and problems for the selected counter.
7. Under Qualifier, you can specify filter criteria for the counter.
8. Click OK to save your specifications.
The Threshold Set Editor window lists the new threshold, together with the specifications you made in the New Threshold window.

9. You can continue with one or more of the following tasks or proceed with step 10:
   - To define more thresholds to the threshold set, click Threshold Set > New Threshold.
   - To change a threshold, click it and then click Selected > Edit.
   - If a threshold in the set should not be used during period exception processing, deactivate it: click the threshold and then click Selected > Active.

10. When you have finished defining thresholds and want to save your changes, click Threshold Set > Save. The Exception Processing window lists the new threshold set under the z/OS folder in the Threshold Sets folder.

To change the properties of a threshold set, click it in the folders pane of the Exception Processing window and then click Selected > Properties. The Threshold Set Properties window is displayed, which is similar to the New Threshold Set window.

To change the contents of a threshold set by adding more thresholds or removing or changing some of them, click the threshold set in the folders pane of the Exception Processing window and then click Selected > Edit. The Threshold Set Editor window is displayed.

**Starting and stopping periodic exception processing**

This topic describes how to start and stop periodic exception processing.

To start periodic exception processing:

1. In the Exception Processing window, click, for example, Exception Processing > Activation - z/OS (depending on which operating system you want to start periodic exception processing).

   The Activation window is displayed. For more information about the exact name of, the layout of, and the selections possible on this window, refer to Table 2 on page 59.

2. If you want to start periodic exception processing for several DB2 subsystems at once, you must select the subsystems you want to monitor.

3. Ensure that your threshold set is displayed in the Threshold set field. In addition, type the time interval at which the thread and Statistics fields are checked for exceptions.

4. Click the Start ( ) button next to Periodic exception processing.

All active thresholds in the threshold set are used during periodic exception processing.

To stop periodic exception processing:

1. In the Exception Processing window, click Exception Processing > Activation.

   The Activation window is displayed.

2. Click the Stop ( ) button next to Periodic exception processing.

**Viewing periodic exceptions**

This topic describes how to view periodic exceptions.
When a periodic exception occurs that is outside of the specified warning or problem threshold, you are informed in the following ways:

- An entry is added to the Event Exception Log pane of the Exception Processing window.

- A warning icon (triangle) or a problem icon (square) appears:
  - Next to the affected counter in the window that contains this counter.
  - In the folders pane of the System Overview window, next to the DB2 subsystem that contains the affected counter and next to the folders that include this DB2 subsystem.

A problem icon overrules a warning icon. No icon is shown for counters that are listed in a table.

When you move your mouse pointer over the counter, hover help shows the timestamp of the exception. If this counter is on a KPIs page of the System Overview window, hover help also contains the defined warning and problem thresholds.

The icon disappears after the counter value falls below or above the threshold or you stop periodic exception processing and after you refresh the data. In the System Overview window, you need not refresh the data.

- An entry is added to the 100 Most Recent Exceptions pane of the System Overview window.
- A message is displayed, a sound (beep) is played, or both, if you specify this kind of notification in the Exception Settings window.

You can get more information about a periodic exception from the Periodic Exception Log pane of the Exception Processing window and the 100 Most Recent Exceptions pane of the System Overview window. In the Periodic Exception Log pane, click the exception and then:

- Click **Selected > Current Statistics Details** to see the corresponding Statistics values.
- Click **Selected > Field Exception History** to see a log of the exception values for the counter.
- Click **Selected > Thread Identity** to see information about the application causing the exception.
- Click **Selected > Current Thread Details** to see thread information. (This is available only if your OMEGAMON Collector supports this function.)

In the 100 Most Recent Exceptions pane, right-click the exception and select the information you want to see.

**Working with the exception user exit**

OMEGAMON XE for DB2 PE supports a user exit to handle event and periodic exceptions. This user exit is a predefined exit point where a user-written routine can be given control.

The name of the exception processing user exit is DGOMUPXT. A sample of this user exit it provided in TKO2SAMP.

To activate the user exit, do the following in the Exception Processing window:

1. Click **Exception Processing > Activation**.
   - The Activation window is displayed.
2. Select the User exit check box.

3. Click the Start (●) button next to Periodic exception processing.
   Periodic exception processing must be running in order to use the user exit—even if you are only interested in event exceptions.

Related reading: Refer to Configuration and Customization for information about customizing this user exit.
Chapter 11. Monitoring data sharing groups

If you are working with a member of a data sharing group, you might want to view, from time to time, the monitoring information collected for another member in the data sharing group. Or you might want to compare the data collected for all members in the group. Most of the monitoring functions allow you to switch among the individual members and between a member and the group. You find a Show Data for list in the toolbar.

From this list, you can select another member or the group. Depending on your selection, the window shows the data for the selected member or the group. If a member is not active, the member name in the list is followed by QUIESCED or FAILED. This depends on why the member became inactive.

Sometimes, while you are working with a member, another member is added to the group, a member is deleted, or the status of a member is changed. To refresh the displayed list, click View > Refresh Data Sharing Group Information.

To get monitoring information from all members of a data sharing group, ensure that the monitor traces are started on all members.

Related reading: For information about how to ensure this, refer to the description of the DATASHARINGGROUP and DB2COMMAND startup parameters in Configuration and Customization

This section describes the windows displayed when you monitor the thread of a data sharing group and view Statistics information about it.

“Monitoring the threads of a data sharing group” When you request the display of all active threads connected to a member of a data sharing group, the Thread Summary window shows the member name in the Show Data for list and lists all active threads running on this member.

“Viewing Statistics on a data sharing group” on page 66 When you request Statistics information about a member of a data sharing group, the Statistics Details window shows the member name in the Show Data for list and displays the Statistics information for this member.

“Viewing the system health of a data sharing group” on page 66 When you want to view the system health of a member of a data sharing group, the System Health window shows the member name in the Show Data for list and displays the system health for this member.

Monitoring the threads of a data sharing group

When you request the display of all active threads connected to a member of a data sharing group, the Thread Summary window shows the member name in the Show Data for list and lists all active threads running on this member.

When you select the group from the Show Data for list, all active threads running on the entire group are displayed.

The Member column in the window shows, for each thread, the member on which it is running. In the case of CP parallelism or sysplex query parallelism, the parent thread is displayed and the values of the children are accumulated.
Viewing Statistics on a data sharing group

When you request Statistics information about a member of a data sharing group, the Statistics Details window shows the member name in the Show Data for list and displays the Statistics information for this member.

When you select the group from the Show Data for list, the entries in the folders pane are reduced to those available in group view. The performance counters are displayed in tabular format, with a column for each active member of the data sharing group.

In member view, part of the Statistics information is already displayed in tabular format, such as the information about the Buffer Management pane. When you view this pane for the entire group, the Buffer Management pane shows the values for the most important buffer-pool performance counter, which is the hit ratio, for each buffer pool and member in the data sharing group. The counter name is displayed above the buffer-pool table.

Thus, when Statistics information is shown in tabular format in member view and you want to view this information in group view, OMEGAMON XE for DB2 PE selects the most important performance counter in the table and displays its values for the entire group.

Viewing the system health of a data sharing group

When you want to view the system health of a member of a data sharing group, the System Health window shows the member name in the Show Data for list and displays the system health for this member.

When you select another member from the Show Data for list, the displayed data views are cleared and the snapshots of the selected member appear.

When you select the group from the Show Data for list, the displayed data views show the following:

- A chart for each member in the data sharing group.
- A list of all members in the data sharing group, instead of a report.

To hide the chart of a member, clear the appropriate check box in the member list. To display the charts in a different order, right-click the member you want to move and then click the appropriate command. To view the report on a member, right-click its chart.
Chapter 12. Viewing history data

You can view history data for threads, locking conflicts, Statistics, and system parameters. This data is stored as snapshots.

History data is useful, for example, if you want to examine events that lead to or follow an exception without recreating the situation.

The OMEGAMON Collector must be enabled for collecting history data. The data is then collected at intervals that you defined during installation.

Related reading: For information about setting up the OMEGAMON Collector to collect history data, see [Configuration and Customization](#).

You can display history data in the Thread Summary, Statistics Details, System Health, and System Parameters window, and in all windows dealing with threads involved in a locking situation.

To view history data:

1. Click **View > History**.
   
The history slider is activated.

   The slider is divided into units where each unit stands for the date and time at which a snapshot was collected. The timestamp above the slider indicates the date and time of the snapshot at the current slider position. The timestamps below the slider show the time range through which data is available in history mode. This is useful, for example, if you zoom the time interval displayed to you.

2. To view the data of a specific snapshot, do one of the following:
   
   • Move the slider to the date and time you want.
   
   • Click **View > History Settings**. A window is displayed on which you can specify the date and time of the snapshot data you want. Click **OK** to get the snapshot data.
   
   • To view the next snapshot, click the right arrow (↑) or **View > Forward**. To view the previous snapshot, click the left arrow (↓) or **View > Back**. You can repeat these commands until you have reached the snapshot you want.
   
   • If the slider contains too many units for you to move the slider to an exact date and time, you can decrease the time interval shown by clicking the plus (+) sign above the slider as often as you need. To increase it again, click the minus (-) sign.

   To display the current data again, click **View > History** again to deactivate the history slider.

   **Restriction:** When you view SQL statements in the dynamic SQL cache in history mode, you cannot define a filter. For more information about SQL statements data, refer to “Viewing the SQL statements in the dynamic SQL cache” on page 35.
# Chapter 13. Using Explain products to analyze and improve SQL statements

This topic explains how to use Explain products to analyze and improve SQL statements.

To determine and improve the access path of dynamic and static SQL statements that contain a SELECT, UPDATE, INSERT, DELETE, or VALUES clause, you can use one of the following Explain products:

- IBM DB2 Query Workload Tuner for z/OS Version 5.1
- IBM InfoSphere® Optim™ Query Workload Tuner Version 4.1 or later (including Data Studio) (before DB2 12)

You can use Explain products to view the access path of a dynamic or static SQL statement when:

- Monitoring an application or thread
- Viewing Statistics on the SQL statements stored in the dynamic SQL statement cache

If you want to use Query Workload Tuner, you must first define the local database alias of the currently monitored DB2 subsystem:

1. Open the following wizard or window:
   - The New DB2 System wizard as described in “Defining a DB2 subsystem” on page 10
   - The DB2 System Properties window as described in “Changing the properties of a DB2 subsystem” on page 13

2. Open the DB2 Subsystem page.

3. In the Local DB Alias field, type the local database alias of the DB2 subsystem.

## Displaying the access path while monitoring an application or thread

This topic shows how to view the access path while monitoring an application or thread.

To view the access path:

1. Open the Thread Details window.
2. In the folders pane, click SQL Statement.
   The SQL Statement pane shows the SQL statement that is currently run by the thread. The Explain button is enabled.
3. Under SQL statement text, click Explain. If the statement contains a SELECT, UPDATE, INSERT, DELETE, or VALUES clause, Query Workload Tuner is opened to view the access path for this statement.

© Copyright IBM Corp. 1997, 2016
Displaying the access path while viewing Statistics on SQL statements

This topic shows how to display the access path while viewing Statistics on SQL statements stored in the dynamic SQL statement cache.

To display the access path:
1. Open the Statistics Details window.
2. In the folders pane, click SQL Statements.
   The SQL Statements pane is displayed without any entries.
3. To display the SQL statements that are in the cache:
   a. Click the Filter (_filter_ ) toolbar button to check the filter values and set the appropriate values for your system. For more information about defining filter criteria, see step 5 on page 35.
   b. Select the Receive statement cache information check box.
      The list is refreshed whenever you click View > Refresh or when an automatic refresh occurs.
4. Double-click a statement.
   The SQL Statements text page opens, where text stands for the first couple of characters of the statement text.
5. Under SQL statement, click Explain.
6. If the statement contains a SELECT, UPDATE, INSERT, DELETE, or VALUES clause, the following window opens depending on the Explain products installed:
   - If Query Workload Tuner is installed and launched, a new Project is defined and the Statement text is shown. Use the corresponding function of Query Workload Tuner to generate the Access Plan.
Chapter 14. Exporting snapshot data for saving and printing

You can export snapshot data to HTML format. You can then print the data or save it as an HTML file.

To export snapshot data:

1. Do one of the following in the window containing the snapshot data:
   - Click the Print/Export toolbar button.
   - Click the leftmost menu and then click Print/Export.
   The Print/Export window is displayed.

2. You can change the settings in this window as follows:
   - If the window consists of several pages and you want to export them all, click All under Pages.
   - If the window contains a large table, you can:
     - Specify how many columns and rows you want to export.
       Example: To export only the first five columns, select Only first for Columns and then specify 5 in the field.
     - Specify after which column the table is split. Select the Split after check box and then select the column number.

3. Click OK.
   A Web browser window is displayed showing the window contents in HTML format. You can use your Web browser to save or print the contents of the window.

If your window contains a table with many columns and you specified to split the table after a specific number of columns, for example three, your HTML file looks similar to the example shown in Figure 13.

<table>
<thead>
<tr>
<th>Number</th>
<th>Buffer Pool</th>
<th>Hit Ratio</th>
<th>Getpage Requests</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>BP0</td>
<td>75.0</td>
<td>20</td>
</tr>
<tr>
<td>2</td>
<td>TOTAL</td>
<td>75.0</td>
<td>20</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Number</th>
<th>Synch Read</th>
<th>Read UO</th>
<th>Buffer Updates</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>5</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>2</td>
<td>5</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

Figure 13. Example of a split wide table

To make the table easier to read, the rows are numbered in the Number column.
Chapter 15. Working with windows displaying snapshots

This section provides you with the information that applies to all windows displaying snapshots.

"Customizing table columns"
Some contents panes of the Thread Details, Statistics Details, and System Parameters window show the key performance counters in a table. One or more columns might be hidden.

"Viewing details on a table entry in a contents pane" on page 74
Some windows show part of the performance information and system parameters in tables. In the contents panes containing a table, you can get further details on a table entry by double-clicking the entry. When you work with Performance Expert Client for the first time, the window becomes a notebook where the initial counter categories or system parameters are shown on the Main page and where further details on the additional notebook pages are displayed.

"Viewing long performance counter values" on page 74
Some performance counter values exceed the length of the field in which they are displayed and are therefore truncated.

"Working in different time zones" on page 74
The windows displaying snapshots contain timestamps to inform you when the snapshots were taken. If the OMEGAMON Collector and Performance Expert Client are in different time zones, the snapshot times are adapted to the Performance Expert Client time.

Customizing table columns

Some contents panes of the Thread Details, Statistics Details, and System Parameters window show the key performance counters in a table. One or more columns might be hidden.

To view hidden counters, to hide counters that you are not interested in, or to change the order of the counters, perform the following steps:

1. Click View > Customize Columns.
   The Customize Columns window is displayed.

2. To make a column visible, click the column in the Hidden columns list and then click Add ( ). The column is removed from the Hidden columns list and displayed at the bottom of the Visible columns list.
   To make all hidden columns visible, click .

3. To hide a column, click the column in the Visible columns list and then click Remove ( ). The column is removed from the Visible columns list and displayed in the Hidden columns list.
   To hide all columns, click .

4. To move a column up in the hierarchy, click the column in the Visible columns box and then click Move up. To move this column to the top of all columns, click Move to top.
   To move a column down in the hierarchy, click the column in the Visible columns box and then click Move down. To move this column to the bottom of all columns, click Move to bottom.
5. Click OK.
   The previous window is displayed with the columns rearranged, hidden, or made visible according to your specifications.

**Viewing details on a table entry in a contents pane**

Some windows show part of the performance information and system parameters in tables. In the contents panes containing a table, you can get further details on a table entry by double-clicking the entry. When you work with Performance Expert Client for the first time, the window becomes a notebook where the initial counter categories or system parameters are shown on the Main page and where further details on the additional notebook pages are displayed.

If you want to compare the data on the individual pages, you can change to window view where each notebook page becomes a window within the main window that you can move, cascade, and tile according to your needs. Click **View > Switch to window view** in the main window. To return to page view, click **View > Switch to page view** in the main window. Your selection remains valid throughout Performance Expert Client until you change it again.

**Viewing long performance counter values**

Some performance counter values exceed the length of the field in which they are displayed and are therefore truncated.

To view the entire value, move your mouse pointer over the field containing the value. Hover help is displayed showing the value in its full length. If the value is longer than 40 characters, a line break is inserted after every 40 characters.

To view the invisible parts of the value, click in the field containing the value and then use the left or right arrow, or press the Home or End key to go to the beginning or end of the value.

You can also copy the value by marking it and using copy and paste.

**Working in different time zones**

The windows displaying snapshots contain timestamps to inform you when the snapshots were taken. If the OMEGAMON Collector and Performance Expert Client are in different time zones, the snapshot times are adapted to the Performance Expert Client time.

For example, if a snapshot is taken at 4 p.m. and the time at the OMEGAMON Collector location is six hours ahead of your Performance Expert Client, the window displaying this snapshot shows a time of 10:00 (10 a.m.).
Part 3. Working with Performance Warehouse

This topic first describes the tasks you need to perform before you can start working with Performance Warehouse and then how to use Performance Warehouse to perform analysis tasks on DB2 performance data using processes, rules of thumb, and queries.

Performance Warehouse provides a process-oriented view of performance-analysis tasks. It allows you to automate tasks that previously required user interaction, such as loading DB2 data into the Performance Warehouse database or generating reports.

A process can consist of steps that link together these manual tasks. For example, you might want to transfer DB2 trace records on your MVS system to the Performance Warehouse database for further analysis. Your corresponding Performance Warehouse process might consist of a:
• CONVERT step that converts a save data set to a Save-File data set.
• LOAD STATISTICS step that loads the data set into the Performance Warehouse database.

Processes represent recurring performance-analysis tasks, they can be scheduled for automatic and repeated execution. You can trace these process executions from the workstation.

Processes produce output data that provides DB2 performance-related information. You can load this data into the Performance Warehouse database and then use rules of thumb and SQL queries to analyze it. Rules of thumb represent a category of expert rules. These rules help you identify more complex performance problems and provide you with tuning recommendations. For example, you can combine several performance counters in a value expression and relate this expression to problem and warning thresholds. You can also create, store, and run SQL queries on the Performance Warehouse database.

Sample processes, rules of thumb, and queries are provided to help you get started.

Chapter 16, “Running Performance Warehouse in a data-sharing environment,” on page 77
The Performance Warehouse database is maintained by the OMEGAMON Collector that runs with the startup parameter PERFORMANCEWAREHOUSE=YES. In a data sharing group, the OMEGAMON Collectors might be installed on more than one member.

Chapter 17, “Logging on to Performance Warehouse,” on page 79
You log on to a Performance Warehouse by connecting to its Performance Warehouse database.

Chapter 18, “Managing Performance Warehouse systems,” on page 81
You can add and delete Performance Warehouse systems.

Chapter 19, “Defining and running processes,” on page 83
Processes consist of one or more steps that perform tasks, such as loading existing DB2 performance data into the Performance Warehouse database or generating reports.
Chapter 20, “Using rules of thumb to analyze performance data,” on page 97
Rules of thumb apply a few simple rules and ratios to key performance indicators.

Chapter 21, “Defining and running queries,” on page 109
You can use the query facility to define performance-management queries to run on the Statistics and Accounting tables in the Performance Warehouse database.
Chapter 16. Running Performance Warehouse in a data-sharing environment

The Performance Warehouse database is maintained by the OMEGAMON Collector that runs with the startup parameter PERFORMANCEWAREHOUSE=YES. In a data sharing group, the OMEGAMON Collectors might be installed on more than one member.

Start the Performance Warehouse server task only for one OMEGAMON Collector in the data sharing group to avoid conflicts.

Figure 14 shows a typical data-sharing environment running Performance Warehouse.

The environment includes:
- Two MVS systems in a Parallel Sysplex® environment with one data sharing group, DSG 1, that comprises the members A1, A2, and A3, and additional DB2 subsystems B1 and C1.
- A Performance Warehouse that contains the performance data of the DB2 subsystems A1, A2, and A3, and a Performance Warehouse each for B1 and C1.
- OMEGAMON Collector 1 that is dedicated to data sharing group DSG 1 on MVS 1 maintains the Performance Warehouse database in a data sharing group.

The OMEGAMON Collectors 1, 2, and 4 run the processes to produce reports and load data into the Performance Warehouse database. If SMF data is to be loaded, the OMEGAMON Collector requires read access to the corresponding SMF data set.

© Copyright IBM Corp. 1997, 2016
Performance Expert Clients that want to use Performance Warehouse connect to the DB2 subsystem or the DB2 data sharing group that contains Performance Warehouse. If you wanted to connect to the data sharing group and access Performance Warehouse, you would specify the location of DSG 1 as the database name and MVS 1 or MVS 2 as the host name when cataloging the DB2PM database of the OMEGAMON Collector by using the Configuration Assistant of DB2, regardless of which member of DSG 1 you want to connect to.
Chapter 17. Logging on to Performance Warehouse

You log on to a Performance Warehouse by connecting to its Performance Warehouse database.

You can log on to Performance Warehouse automatically or manually:

- You can automatically log on to a Performance Warehouse associated with a DB2 subsystem. You can associate a Performance Warehouse with a DB2 subsystem when defining the DB2 subsystem for monitoring from Performance Expert Client (see step 7 on page 12) or when changing the properties of the DB2 subsystem (see “Changing the properties of a DB2 subsystem” on page 13).

- You can manually log on to an associated Performance Warehouse or to any Performance Warehouse that was configured using the Configuration Assistant of DB2. When you log on manually the DB2 subsystem that it is associated with, the database need not exist any more. If you removed the associated DB2 subsystem from the System Overview window but kept the DB2 catalog entries, you can still work with Performance Warehouse.

If you log on to a Performance Warehouse database that is maintained by an OMEGAMON Collector that is not running, you can define processes, rules of thumb, and queries but you cannot run them.

"Logging on to a Performance Warehouse automatically"

To log on to a Performance Warehouse automatically, select a DB2 subsystem ID in the folder pane of the System Overview window, then click Selected > Monitor > Performance Warehouse - Expert.

"Logging on to a Performance Warehouse manually” on page 80

To log on to a Performance Warehouse manually, click the Performance Warehouse toolbar button ( ) in the System Overview window.

Logging on to a Performance Warehouse automatically

To log on to a Performance Warehouse automatically, select a DB2 subsystem ID in the folder pane of the System Overview window, then click Selected > Monitor > Performance Warehouse - Expert.

The Expert page of the Performance Warehouse window is displayed. The folders pane lists, under the z/OS folder, all Performance Warehouse systems to which you previously logged on or that you added manually (see “Adding a Performance Warehouse” on page 81). The names that appear are the DB2 connection aliases, which associate a Performance Warehouse with a DB2 subsystem.

In addition, you are logged on to the Performance Warehouse that is associated with the selected DB2 subsystem. You can now work with the items that are listed on the displayed page of the Performance Warehouse window, or you can move to another page to perform a different set of tasks.
Logging on to a Performance Warehouse manually

To log on to a Performance Warehouse manually, click the Performance Warehouse toolbar button ( ) in the System Overview window.

The Expert page of the Performance Warehouse window is displayed. The folders pane lists, under the z/OS folder, the DB2 connection alias of all Performance Warehouse systems to which you previously logged on or that you added manually (see Chapter 18, “Managing Performance Warehouse systems,” on page 81).

If no Performance Warehouse systems are listed because you are working with Performance Warehouse for the first time or the Performance Warehouse of your choice is not listed, add the Performance Warehouse systems you need. For more information refer to Chapter 18, “Managing Performance Warehouse systems,” on page 81.

Click the Performance Warehouse to which you want to log on and click Selected > Connect to open the Connect to Performance Warehouse window.

Specify your DB2 user ID and your password and then click OK.

You are logged on to the specified Performance Warehouse. You can now work with the items listed on the displayed page of the Performance Warehouse window or move to another page to perform a different set of tasks.
Chapter 18. Managing Performance Warehouse systems

You can add and delete Performance Warehouse systems.

**Adding a Performance Warehouse**

You can add a Performance Warehouse system automatically or manually.

A Performance Warehouse is automatically added to the folders pane of the Performance Warehouse window the first time you perform an automatic logon to a Performance Warehouse. For information on how to do this, refer to “Logging on to a Performance Warehouse automatically” on page 79. The name under which a Performance Warehouse appears in the Performance Warehouse window is the database alias, which associates a Performance Warehouse with a DB2 subsystem.

To add a Performance Warehouse manually, perform the following steps:
1. In the Performance Warehouse window, click **Performance Warehouse > New Performance Warehouse**. The New Performance Warehouse window is displayed.
2. Select z/OS.
3. In the **Database alias** field, type the alias of a Performance Warehouse database. This is the alias that you specified as database alias when cataloging the DB2PM database of an OMEGAMON Collector by using the Configuration Assistant of DB2.

   **Related reading:** For further information about cataloging the DB2PM database, see [Configuration and Customization](#).

4. If you want to log on to the new Performance Warehouse after leaving this window, select the **Connect immediately after configuration** check box.
5. Click **OK**.

The new Performance Warehouse is added to the z/OS folder and remains part of this folder until you delete it again. If you requested to log on immediately after defining the new Performance Warehouse, the Connect to Performance Warehouse window is displayed.

The name under which Performance Warehouse appears in the Performance Warehouse window is the database alias that you specified in the **Database alias** field of the New Performance Warehouse window and which associates a Performance Warehouse with a DB2 subsystem.

**Deleting a Performance Warehouse**

To delete a Performance Warehouse:
1. Select the Performance Warehouse to be deleted.
2. If you are still logged on to this Performance Warehouse, click **Selected > Disconnect**.
3. Click **Selected > Delete**.

The Performance Warehouse is removed from the respective folder.
Chapter 19. Defining and running processes

Processes consist of one or more steps that perform tasks, such as loading existing DB2 performance data into the Performance Warehouse database or generating reports.

This section describes processes and reports in more detail, uses scenarios to show how to define and run processes, and gives hints and tips on certain tasks.

A process can consist of one or more of the following steps or step combinations:

- The CONVERT step reads an existing save data set and produces a save-file data set that can be used as input for a LOAD step.
- The LOAD step loads an existing file or save-file data set into the Performance Warehouse database.
- The REPORT step generates Statistics and Accounting reports from existing DB2 performance data. You can use various commands and subcommands to produce different report types. This step can include:
  - Creation, conversion, and loading of save data sets into the Performance Warehouse database.
  - Creation and loading of file data sets into the Performance Warehouse database.
- The CRD (collect report data) step collects report data and stores it in MVS data sets.

To create different report types, you add various commands and subcommands to the REPORT step.

The following scenario shows how you can make use of existing data sets that were not generated by a Performance Warehouse REPORT step. It describes how to transfer save or save-file data sets on an MVS system to the Performance Warehouse database.

Suppose you are a database administrator for several OS/390 locations hosted on an MVS system. Users tell you that they have DB2 performance problems during online transaction processing on certain DB2 locations every day between 11 a.m. and 12 noon.

If an input data set does not exist, you must collect the relevant performance data before you can define your Accounting and Statistics reports.

You might want to collect performance data on a regular basis, for example, to collect Statistics data between 12 noon and 4 p.m. every day.

The following sections give hints and tips on process-related Performance Warehouse tasks.
Report types

To create different report types, you add various commands and subcommands to the REPORT step.

The GLOBAL command automatically appears as the first command in the REPORT step. You use this command to filter input data, set default values for subcommand options, and define global processing options. The following options are, for example, supported by the GLOBAL command:

- FROM
- TO
- INTERVAL
- BOUNDARY
- INCLUDE/EXCLUDE
- TIMEZONE

Table 3 shows the command options for Accounting commands and subcommands. Table 4 shows the command options for Statistics commands and subcommands. For more information about the individual command options, refer to Report Command Reference.

Restriction: After a process has run, all output data sets on the host are stored in the Performance Warehouse database and removed from the host. If you want to use the output data sets created by a REPORT step as input for a LOAD step or a CONVERT and LOAD step, you must include a LOAD FILE or LOAD SAVE subcommand as part of your REPORT step.

Table 3. Supported Accounting command options.

<table>
<thead>
<tr>
<th>Command options</th>
<th>ACCOUNTING REDUCE</th>
<th>ACCOUNTING REPORT</th>
<th>ACCOUNTING TRACE</th>
<th>ACCOUNTING SAVE</th>
</tr>
</thead>
<tbody>
<tr>
<td>FROM</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
<tr>
<td>TO</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
<tr>
<td>INTERVAL</td>
<td>*</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BOUNDARY</td>
<td>*</td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EXCEPTION/NOEXCEPTION</td>
<td></td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>SCOPE</td>
<td></td>
<td>*</td>
<td></td>
<td></td>
</tr>
<tr>
<td>ORDER</td>
<td></td>
<td></td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>LAYOUT</td>
<td></td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>INCLUDE/EXCLUDE</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>TIMEZONE</td>
<td></td>
<td></td>
<td></td>
<td>*</td>
</tr>
<tr>
<td>TOP</td>
<td></td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
</tbody>
</table>

Table 4. Supported Statistics command options

<table>
<thead>
<tr>
<th>Command options</th>
<th>STATISTICS REDUCE</th>
<th>STATISTICS REPORT</th>
<th>STATISTICS TRACE</th>
<th>STATISTICS SAVE</th>
<th>STATISTICS FILE</th>
</tr>
</thead>
<tbody>
<tr>
<td>FROM</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>TO</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
</tbody>
</table>
Table 4. Supported Statistics command options (continued)

<table>
<thead>
<tr>
<th>Command options</th>
<th>STATISTICS REDUCE</th>
<th>STATISTICS REPORT</th>
<th>STATISTICS TRACE</th>
<th>STATISTICS SAVE</th>
<th>STATISTICS FILE</th>
</tr>
</thead>
<tbody>
<tr>
<td>INTERVAL</td>
<td>*</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>BOUNDARY</td>
<td>*</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>EXCEPTION/NOEXCEPTION</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>SCOPE</td>
<td>*</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>ORDER</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>LAYOUT</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td></td>
<td></td>
</tr>
<tr>
<td>INCLUDE/EXCLUDE</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td></td>
</tr>
<tr>
<td>DSETSTAT</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
<td>*</td>
</tr>
<tr>
<td>TIMEZONE</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Scenario 1: Transferring performance data into the Performance Warehouse database

The following scenario shows how you can make use of existing data sets that were not generated by a Performance Warehouse REPORT step. It describes how to transfer save or save-file data sets on an MVS system to the Performance Warehouse database.

You can perform this scenario on the following pages of the Performance Warehouse window:
- Expert
- Report and Load

"Creating a process group” on page 86
A process needs a process group as a container.

"Creating a process using a process template” on page 86
Process templates are supplied with the product. You can find these templates in the Public process group. Here, you use the template DB2PM.Templates.Load Warehouses 2 to create a process.

"Viewing the process properties” on page 86
To view the process properties, select the Transfer Statistics Save process in the folders pane, and then click Selected > Properties.

"Configuring the process steps” on page 87
The copied template contains default values for the process steps.

"Running the process” on page 87
To run the process immediately, select the process in the folders pane, and then click Selected > Execute. The process is scheduled to start immediately and is activated.

"Viewing the output data sets” on page 88
When the process finishes (status FINISHED on the Process Execution pane), you can view its output.
Creating a process group

A process needs a process group as a container.

To create a process group:
1. In the folders pane, select Process Groups and then click Selected > Create.
   The Process Group Properties window is displayed.
   The Author, Creation date and time, and Modification date and time fields are filled in when you click OK. The Author field will contain your DB2 user ID.
2. In the Name field, type a unique name for the process group.
   Example: Legacy.
3. In the Description field, you can type a description for the process group.
   Example: Type Transfer "legacy" performance data sets into Performance Warehouse.
4. Click OK to save the process group and return to the Performance Warehouse window.
   The new group appears in the folders pane as a subitem of Process Groups.

Creating a process using a process template

Process templates are supplied with the product. You can find these templates in the Public process group. Here, you use the template DB2PM.Templates.Load Warehouses 2 to create a process.

This template contains a CONVERT step and a LOAD STATISTICS step.
1. In the folders pane, under Public, select DB2PM.Templates.Load Warehouses 2 and then click Selected > Copy.
   The Copy Process window is displayed.
2. In the New process group list, select the Legacy process group.
3. In the New process name field, type a unique name for the copied process.
   Example: Transfer Statistics Save.
4. Click OK.
   When you return to the Performance Warehouse window, the process appears under Processes of the Legacy process group. The template's steps are also copied.

Viewing the process properties

To view the process properties, select the Transfer Statistics Save process in the folders pane, and then click Selected > Properties.

The Process Properties window is displayed:
1. Ensure that the following is set:
   • Status is set to in definition so that you can make changes to the process.
   • Scope is set to private. When you copy a process template, the scope changes from public to private so that this process is not available to other users.
   • Schedule of process is set to immediately.
2. Change the description in the Description field to match the process.
3. Click OK to save the changes to the process and return to the Performance Warehouse window.
Configuring the process steps

The copied template contains default values for the process steps.

You must configure the steps to add:

- An input data set to the CONVERT step
- Target tables to the LOAD STATISTICS step

To configure the CONVERT step:

1. In the folders pane, click Steps. In the contents pane, select the CONVERT step and then click Selected > Properties. The Convert Properties window is displayed.
2. Click the Options tab.
3. Change the name of the input data set to my.input.data.set and click OK to save the changes.

To configure the LOAD STATISTICS step:

1. In the folders pane, click Steps. In the contents pane, select the LOAD STATISTICS step and then click Selected > Properties. The Load Statistics Step Properties window is displayed.
2. Click the Options tab. Specify the types of target tables that you want to load into the Performance Warehouse database.
3. Click OK to save the changes.

The process definition is now complete so you can run the process.

Running the process

To run the process immediately, select the process in the folders pane, and then click Selected > Execute. The process is scheduled to start immediately and is activated.

The following information is recorded about processes:

- The processes (with their start and stop timestamps and their status) that are currently running and have run since you started working with Performance Warehouse.
- The individual steps of each process, with their start and stop timestamps and their status.
- The output data sets of each step in a process.

While the process is running, you can view its progress. In the folders pane, click Process Executions to view the progress of the process. The Process Executions pane is displayed, listing the process executions for all the processes. To view only the Transfer Statistics Save process, you must define filter criteria.

To define filter criteria:

1. Click View > Filter. The Filter Process Execution window is displayed.
2. Specify the filter conditions.

You can use wildcard characters in the filter criteria: _ (underscore) for one character and % for more than one character.

Example:

- In the Name field, type Transfer Sta%
3. Click OK.

The Process Executions pane then lists only the process-execution entries for the Transfer Statistics Save process.

**Viewing the output data sets**

When the process finishes (status FINISHED on the Process Execution pane), you can view its output.

To view the output:
1. On the Process Executions pane, select the process execution and then click Selected > Details.
   The Process Execution Details window is displayed. It contains information about all the steps of the process and the output data sets generated by these steps.
2. To view the list of output data sets generated by the LOAD STATISTICS step, click the Output Data Set folder under LOAD.
3. To view the contents of a data set, double-click the data set.
   The contents of the data set are shown in a Web browser. You can use your browser to save and print the data set. For information about how to specify your Web browser of choice, see “Specifying global settings” on page 14.

To delete the data set from the Performance Warehouse database, select the corresponding data set, and click Delete.

---

**Scenario 2: Defining Accounting and Statistics reports using an existing input data set**

Suppose you are a database administrator for several OS/390 locations hosted on an MVS system. Users tell you that they have DB2 performance problems during online transaction processing on certain DB2 locations every day between 11 a.m. and 12 noon.

You decide to generate Accounting reports to determine if there is a DB2 problem. You also decide to generate a Statistics report to get an overview of system activity. You think that you might also need to analyze the data later using queries and rules of thumb, so you make sure that the performance data is transferred to the Performance Warehouse database.

To create the reports and transfer the data, you must:
1. Create a REPORT step.
2. Define the Accounting and Statistics reports.
3. Run the process to generate reports and transfer data to the Performance Warehouse database.
4. View and analyze the generated reports.

"Scenario 1: Transferring performance data into the Performance Warehouse database" on page 85 describes how to work with process groups, processes and steps, how to run the process, and how to view the results. This scenario describes how to use Performance Warehouse to define the reports the DBA needs to analyze.
the problem. It assumes that you have an existing input data set containing the Accounting and Statistics performance records for the timeframe and DB2 locations in question. If this is not the case, proceed with “Scenario 3: Collecting performance data for the generation of Accounting and Statistics reports” on page 92.

To define the reports you must:
1. Specify an input data set.
2. Filter the performance records to produce meaningful results.
3. Set up an Accounting report.
4. Transfer data to the Performance Warehouse database.
5. Set up a Statistics report.

You can perform these tasks on the following pages of the Performance Warehouse window:
- Expert.
- Report and Load.

Specifying an input data set

The input data set on the MVS system contains the Accounting and Statistics performance records for the timeframe and the DB2 locations in question.

To specify the input data set:
1. In the folders pane, click Steps. In the contents pane, select the REPORT step and then click Selected > Properties.
   The Report Step Properties window is displayed.
2. Click the Options tab.
3. In the Current data set specification pane, click Add.
   The Add Input Data Set window is displayed.
4. Type the name of the data set and click OK.

Specifying filter criteria for the performance records

You know that the performance problems occur during online processing for certain locations in a particular timeframe. You can specify filter criteria to account for these symptoms and apply them to all reports.

To set up an Accounting report, right-click REPORT in the folders pane and click Add.

Transferring Accounting performance data to the Performance Warehouse database

To analyze Accounting performance data produced by the REPORT step at a later date, you must transfer the data to the Performance Warehouse database. You need to include a LOAD command in the REPORT step to do this.

To set up a Statistics report, right-click REPORT in the folders pane and click Add.
Specifying filter criteria for the performance records

You know that the performance problems occur during online processing for certain locations in a particular timeframe. You can specify filter criteria to account for these symptoms and apply them to all reports.

You use the GLOBAL command to specify these global performance-record filter criteria:

1. Click GLOBAL in the folders pane.
   The GLOBAL command options are shown in the Current data set specification pane.
2. To restrict the records to the timeframe, type 11:00:00:00 in the From Time field and 12:00:00:00 in the To Time field.
3. To include performance records from online transaction-processing applications only, click the Include filter button.
   The Include/Exclude Filter window is displayed.
   a. Select the row containing the DB2 PE identifier CONNTYPE (connection type) and click Add.
   The Add Include/Exclude Value window is displayed.
   b. Associate the following values with CONNTYPE:
      - CICS®
      - IMS-MPP
      - IMS-TBMP
   The symbol in the Usage column shows whether the DB2 PE identifier is included or excluded.
   c. Click OK to include the filter in the GLOBAL command options.

The performance problems occur only at certain “slow” locations but you do not know exactly which locations are affected. However, you do know that the location names starting with BOE and DVI perform well. You use a filter with wildcard characters to ensure that these “good performers” are excluded from the report.

4. To exclude performance records from a particular location, click the Exclude filter button.
   The Include/Exclude Filter window is displayed.
   a. Select the row containing the DB2 PE identifier LOCATION and click Add.
   The Add Include/Exclude Value window is displayed.
   b. Associate the following values with LOCATION:
      - BOE*
      - DVI*
   c. Click OK to include the filter in the GLOBAL command options.

Setting up an Accounting report

To set up an Accounting report, right-click REPORT in the folders pane and click Add.

On the Add Command window:
1. Select ACCOUNTING and click OK.
   The ACCOUNTING folder is added to the REPORT step.
2. Right-click the ACCOUNTING folder and click Add.
   The Add Command window is displayed
3. Select REPORT and click **OK**.
   The REPORT subcommand is added to the ACCOUNTING REPORT set and the current ACCOUNTING REPORT command options are shown in the Current ACCOUNTING REPORT command options pane.

4. To get as much detailed information in the report as possible, select LONG in the **Layout** field.
   You need to produce two reports with different aggregation levels:
   - Aggregated information for all online transaction application executions
   - Aggregated information for each online transaction application execution

5. To filter the information needed for all online transaction application executions:
   a. Click the **Order** filter button.
      The Order Filter window is displayed. Set 1 contains the default order criteria PRIMAUTH and PLANNNAME.
   b. Use the appropriate buttons to remove PRIMAUTH and PLANNNAME and add the DB2 PE identifier INTERVAL.
      INTERVAL represents the information needed for all online transaction application executions.

6. To filter the information needed for each online transaction application execution:
   a. Select Set 2 in the **Selected identifier for** field.
   b. Add the DB2 PE identifier CORRNAME using the appropriate button.
      CORRNAME represents the information needed for each online transaction application execution.
   c. Click **OK** to add the filter criteria to the ACCOUNTING REPORT command options.

**Transferring Accounting performance data to the Performance Warehouse database**

To analyze Accounting performance data produced by the REPORT step at a later date, you must transfer the data to the Performance Warehouse database. You need to include a LOAD command in the REPORT step to do this.

To transfer the data:
1. Right-click the **ACCOUNTING** folder and click **Add**.
   The Add Command window is displayed.
2. Select SAVE and click **OK**.
   The **SAVE** folder is added to the Accounting report.
3. Right-click the **SAVE** folder and click **Add**.
   The Add Command window is displayed.
4. Select LOAD SAVE and click **OK**.
   The LOAD SAVE subcommand is added to the ACCOUNTING SAVE set and the current LOAD command options are shown in the Current DB2 LOAD command options pane.
5. Select the target tables to be loaded with the performance records and click **Add**.
Setting up a Statistics report

To set up a Statistics report, right-click REPORT in the folders pane and click Add.

On the Add Command window:

1. 

2. Select STATISTICS and click OK.
   The STATISTICS folder is added to the REPORT step.

3. Right-click the STATISTICS folder and click Add.
   The Add Command window is displayed.

4. Select REPORT and click OK.
   The REPORT subcommand is added to the STATISTICS REPORT set and the current STATISTICS REPORT command options are shown in the Current STATISTICS REPORT command options pane.

5. To get as much detailed information in the report as possible, select LONG in the Layout field and click OK.

The REPORT step is now complete and you can run the process. For information about how to run a process and view the output, see “Running the process” on page 87 and “Viewing the output data sets” on page 88.

Scenario 3: Collecting performance data for the generation of Accounting and Statistics reports

If an input data set does not exist, you must collect the relevant performance data before you can define your Accounting and Statistics reports.

In “Scenario 2: Defining Accounting and Statistics reports using an existing input data set” on page 88, you used an input data set that contained the Accounting and Statistics performance records for the timeframe and DB2 locations in question.

The list of tasks necessary to define the reports would then look as follows:

1. Create a CRD (collect report data) step.
2. Filter the performance records to produce meaningful results.
3. Set up an Accounting report.
4. Transfer data to the Performance Warehouse database.
5. Set up a Statistics report.
6. Schedule the process containing the CRD and REPORT steps.

You can perform this scenario on the following pages of the Performance Warehouse window:
• Expert
  • Report and Load

“Creating a CRD (collect report data) step” on page 93
To create a CRD step, click Steps in the folders pane and click Selected > Create.

“Scheduling the process containing the CRD (collect report data) and REPORT steps” on page 93
To start data collection at 11 a.m., you must schedule the process containing the CRD and REPORT steps. In the folders pane, select the appropriate process and then click Selected > Properties.
Creating a CRD (collect report data) step

To create a CRD step, click Steps in the folders pane and click Selected > Create.

On the Create Step window:
1. Select CRD.
   The CRD Step Properties window is displayed.
2. Click the Options tab.
3. To configure the data collection, select Data under Options categories.
   The Current data option pane is displayed.
4. Under Data categories, select Accounting and Statistics.
5. Specify which IFCIDs you want to collect.
6. To specify the criteria for the data collection to stop, select Stop under Options categories.
   The Current stop conditions pane is displayed.
7. In scenario 2, the database administrator wants to collect data between 11 a.m. and 12 noon. To specify this, select the Elapsed time check box and type a duration of one hour.
8. Click OK to save the configuration of the CRD step.

Steps 2 on page 92 to 5 on page 92 are described in “Scenario 2: Defining Accounting and Statistics reports using an existing input data set” on page 88.

Scheduling the process containing the CRD (collect report data) and REPORT steps

To start data collection at 11 a.m., you must schedule the process containing the CRD and REPORT steps. In the folders pane, select the appropriate process and then click Selected > Properties.

In the Process Properties window:
1. Click Schedule.
   The Process Schedule Properties window is displayed.
2. Click At schedule time and then click the button next to the schedule string. The Schedule Process window is displayed.
3. Set the schedule to 11 a.m.:
   • Under Minutes, select Specify minutes and type 0.
   • Under Hours, select Specify hours and type 11.
4. Click OK until you return to the Performance Warehouse window.

Recommendation: The Public process group contains the template Ad-Hoc Report, which consists of a CRD step and a REPORT step. This template collects data for five minutes and generates an Accounting and Statistics report in LONG format. You can use this template to get started.

Scenario 4: Collecting performance data regularly

You might want to collect performance data on a regular basis, for example, to collect Statistics data between 12 noon and 4 p.m. every day.

To perform this task:
1. Define a process consisting of a single CRD (collect report data) step.
2. Schedule the process to run periodically and activate it.

You can perform this scenario on the following pages of the Performance Warehouse window:
- Trace
- Report and Load
- Expert

It is recommended that you use the Trace page because it only contains the items you need to configure and activate, and for which you want to view the progress, such as the CRD process.

To define a CRD process:
1. Copy the process template DB2PMTEMPLATES.Collect Report Data from the Public process group to a process group of your own. This template collects Accounting and Statistics data for the duration of 5 minutes.
2. Display the properties for the Collect Report Data step and change the following option categories on the Options page:
   - For Output data set, type an output data set name and select Append.
   - For Data, clear the Accounting check box.
   - For Stop, specify an elapsed time of 4 hours.

To schedule the process, proceed as described in “Scheduling the process containing the CRD (collect report data) and REPORT steps” on page 93, but type 12 under Hours.

To activate the process, display the process properties and change the status from in definition to active.

For more details on how to define, schedule, activate, and view the progress of a process, refer to “Scenario 1: Transferring performance data into the Performance Warehouse database” on page 85.

---

### Hints and tips

The following sections give hints and tips on process-related Performance Warehouse tasks.

- **“Understanding the schedule string” on page 95**
  When you specify a schedule for a process, the specifications you make in the Schedule Process window are reflected as a string in the Schedule of process field of the Process Properties window and in the At scheduled time field of the Process Schedule Properties window. This string can look as follows: 2007/1/16/*/16/58

- **“Deleting process executions of processes scheduled ‘immediately’” on page 95**
  If you run a process that is scheduled ‘immediately’ and delete the process execution entry within five minutes after the process has finished, the OMEGAMON Collector runs the process again.

- **“Reusing output data sets produced by a REPORT step” on page 95**
  After a process has run, all output data sets on the host are stored in the Performance Warehouse database and removed from the host.

- **“Deleting data permanently” on page 95**
  To permanently delete data sets and files from the Performance Warehouse
Understanding the schedule string

When you specify a schedule for a process, the specifications you make in the Schedule Process window are reflected as a string in the Schedule of process field of the Process Properties window and in the At scheduled time field of the Process Schedule Properties window. This string can look as follows: 2007/1/16/*/16/58

A string consists of the following parts, in this sequence: year/month/day/day-of-the-week/hour/minute. A 0 for the day of the week stands for Saturday. An asterisk (*) represents all allowed values for a field.

Important: When you define a schedule in the Schedule Process window, you can specify the dates and weekdays when you want to run a process. However, you cannot specify that a process should run at a certain date only if this date is a specific day of the week.

For example, if you type 1 under Days and 5 under Months and select the Monday check box under Day of week, the process will run on May 1st and on every Monday. In this example, the string would look similar to this one: */5/1/2/*/*

Deleting process executions of processes scheduled 'immediately'

If you run a process that is scheduled ‘immediately’ and delete the process execution entry within five minutes after the process has finished, the OMEGAMON Collector runs the process again.

This is because the OMEGAMON Collector replaces ‘immediately’ with the time at which the process was started and interprets this time as a schedule when no process execution is available.

Reusing output data sets produced by a REPORT step

After a process has run, all output data sets on the host are stored in the Performance Warehouse database and removed from the host.

If you want to use the output data sets created by a REPORT step as input for a LOAD or a CONVERT and a LOAD, you must define a LOAD FILE or LOAD SAVE subcommand as part of your REPORT step.

Deleting data permanently

To permanently delete data sets and files from the Performance Warehouse database, you must delete them in the Process Execution Details window or delete the appropriate process execution entry from the Process Executions pane of the Performance Warehouse window.

For information about how to delete data from the tables in the Performance Warehouse database, refer to Chapter 22, “Overview of the Performance Warehouse database,” on page 117.
Chapter 20. Using rules of thumb to analyze performance data

Rules of thumb apply a few simple rules and ratios to key performance indicators.

The sample rules of thumb delivered with the product have been assembled by DB2 experts in the field over many years and are valuable criteria by which to measure the performance of applications in a DB2 system. They can be executed as they are.

Related reading:
• For more information about the sample rules of thumb, see Reporting User’s Guide
• The samples are described in detail in the Online Help:
  – Click Help in the following windows:
    - Definition page of the Rules-of-Thumb Cluster Properties window
    - Definition page of the Rule-of-Thumb Properties window
    - Rules-of-Thumb Analysis window.
  – Use the links under the related topic Predefined rule-of-thumb cluster definitions for z/OS.

This section describes how to define rules of thumb and how to use them to analyze performance data. You always start in the Performance Warehouse window.

In the System Overview window, click the Performance Warehouse toolbar button to start Performance Warehouse. The Performance Warehouse window is displayed.

Managing rule-of-thumb groups
A rule-of-thumb group is a container for rule-of-thumb clusters and rules of thumb.

Managing rule-of-thumb clusters and rules of thumb” on page 99
A rule-of-thumb cluster represents a counter category that you want to analyze and for which you want to define rules of thumb. Examples of counter categories are Accounting and Statistics.

“Analyzing the performance data” on page 104
You can use rules of thumb to analyze data in the Performance Warehouse database.

Managing rule-of-thumb groups
A rule-of-thumb group is a container for rule-of-thumb clusters and rules of thumb.

The Public rule-of-thumb group contains the sample rules of thumb delivered with the product and those rules of thumb that other users have made generally available.

“Creating a rule-of-thumb group” on page 98
To create a rule-of-thumb group, select Rule-of-Thumb Groups in the folders pane of the Performance Warehouse window and then click Selected > Create.
“Changing a rule-of-thumb group”
You can change the description of the rule-of-thumb group, or rename or delete the rule-of-thumb group.

“Copying a rule-of-thumb group”
If you want to create several rule-of-thumb groups that only differ in a rule-of-thumb cluster property or a rule of thumb, you might prefer to copy and change a rule-of-thumb group.

Creating a rule-of-thumb group
To create a rule-of-thumb group, select Rule-of-Thumb Groups in the folders pane of the Performance Warehouse window and then click Selected > Create.

The Rule-of-Thumb Group Properties window is displayed. The Author, Creation date and time, and Modification date and time fields are filled in when you click OK. The Author field will contain your DB2 user ID. Then:
1. Specify a unique name for the rule-of-thumb group in the Name field.
2. You can type a description for the rule-of-thumb group in the Description field. This is optional.
3. Click OK to save this rule-of-thumb group and return to the Performance Warehouse window.
   The new group appears in the folders pane as a subitem of Rule-of-Thumb Groups.

Changing a rule-of-thumb group
You can change the description of the rule-of-thumb group, or rename or delete the rule-of-thumb group.

You can change a rule-of-thumb group in one of the following ways:
- Change the description of the rule-of-thumb group.
  To change the description, click the rule-of-thumb group and click Selected > Properties.
- Rename a rule-of-thumb group.
  To rename a group, click the rule-of-thumb group and click Selected > Rename.
- Delete a rule-of-thumb group.
  To delete a group, click the rule-of-thumb group and click Selected > Delete.

Copying a rule-of-thumb group
If you want to create several rule-of-thumb groups that only differ in a rule-of-thumb cluster property or a rule of thumb, you might prefer to copy and change a rule-of-thumb group.

When you copy a rule-of-thumb group, any rule-of-thumb clusters and rules of thumb that it contains are copied with it.

To copy a rule-of-thumb group:
1. In the folders pane of the Performance Warehouse window, under Rule-of-Thumb Groups, click the rule-of-thumb group and then click Selected > Copy.
   The Copy Rule-of-Thumb Group window is displayed.
2. In the New rule-of-thumb group name field, specify a unique name for the copied group.
3. Click OK.
The copied group appears in the folders pane.

Managing rule-of-thumb clusters and rules of thumb

A rule-of-thumb cluster represents a counter category that you want to analyze and for which you want to define rules of thumb. Examples of counter categories are Accounting and Statistics.

The first rule of thumb that you define for a cluster or copy or move into the cluster determines the cluster category. Any additional rules of thumb that you create for a cluster, or copy or move into the cluster must match this cluster category.

Creating a rule-of-thumb cluster

You can create a rule-of-thumb cluster using a template. Templates are displayed under the Public rule-of-thumb group. To create a cluster using a template, copy the template, and then change the copy.

In a rule of thumb, you specify the tables, report blocks, and columns that you want to analyze for a specific counter category.

You can change the properties of a rule-of-thumb cluster or a rule of thumb, or rename or delete a rule-of-thumb cluster or a rule of thumb.

Creating a rule-of-thumb cluster

You can create a rule-of-thumb cluster using a template. Templates are displayed under the Public rule-of-thumb group. To create a cluster using a template, copy the template, and then change the copy.

To create a rule-of-thumb cluster without a template:

1. In the folders pane of the Performance Warehouse window, click Rule-of-Thumb Clusters and then click Selected > Create.
The Rule-of-Thumb Cluster Properties window is displayed.
The Author, Creation date and time, and Modification date and time fields are filled in when you click OK. The Author field will contain your DB2 user ID.

2. Specify a unique name for the rule-of-thumb group in the Name field.

3. In the Scope list, click one of the following:
   - private if you do not want to make this rule-of-thumb cluster available to other users.
   - public if you want other users to view, copy, and use this rule-of-thumb cluster as a template.

4. You can type a description for the rule-of-thumb cluster in the Description field.

5. Click OK to save the new rule-of-thumb cluster and return to the Performance Warehouse window.
The new rule-of-thumb cluster appears as a subitem of Rule-of-Thumb Clusters and contains the subitem Rules of Thumb.

To ensure name uniqueness throughout the rules-of-thumb-group folder, the rule-of-thumb cluster is displayed under the following name:
user.rotgroup.rotclustername, where user stands for the DB2 user ID of the
rule-of-thumb cluster creator, **rootgroup** for the rule-of-thumb group that this rule-of-thumb cluster belongs to, and **roclustename** for the name of the rule-of-thumb cluster.

**Creating a rule of thumb**

In a rule of thumb, you specify the tables, report blocks, and columns that you want to analyze for a specific counter category.

You also define the analysis rules, set the thresholds, and provide tuning recommendations.

To create a rule of thumb:

1. Click **Rules of Thumb** for the cluster in the folders pane of the Performance Warehouse window and then click **Selected > Create**. The General page of the Rule-of-Thumb Properties window is displayed. The **Author**, **Creation date and time**, and **Modification date and time** fields are filled when you click **OK**. The **Author** field will contain your DB2 user ID.

2. Specify a unique name for the rule of thumb in the **Name** field.

3. If this is the first rule of thumb in the cluster, select the counter category for the rules of thumb that you want to add in the **Type** list. You can define rules of thumb for Accounting and Statistics. **Important**: The counter category you select here determines the category for the entire cluster. Therefore, this selection is not available for the second and subsequent rules of thumb in the cluster.

4. You can type a description for the rule of thumb in the **Description** field. This is optional.

5. Click the **Definition** tab. On the Definition page you can select the:
   - Tables
   - Report blocks
   - Columns that you want to analyze and for which you want to set rules, threshold values, and tuning recommendations.

You can do the following:

   - Select a report block or a table. Your selection determines the content of the **Columns** box.
   - Fill the **Filter expression** and **Additional columns** boxes by clicking a column in the **Columns** box and then clicking the appropriate **Add** button. The entry appearing in these boxes consists of the table and column names.
   - If you add several columns to the **VALUE expression** box, you must use operators to combine the columns into expressions. Simple arithmetic expressions are allowed that contain the operators (, ), +, −, /, *. The result of the arithmetic expression is run against the values that you specify under **WARNING** and **PROBLEM thresholds**.
   - If you want to include the values of columns that are not part of the arithmetic expression in the analysis result, add these columns to the **Additional columns** box.
   - The SQL query generated from the specifications for this and all other rules of thumb in the cluster and for the rules-of-thumb cluster itself must not exceed 32 KB.

6. Make your selections and fill in the various fields.
7. Click OK to save the new rule of thumb and to return to the Performance Warehouse window.

The new rule of thumb appears in the contents pane of the Performance Warehouse window.

“This example shows how to define your rule of thumb on the Definition page of the Rule-of-Thumb Properties window.”

“Defining filter criteria and additional columns for the rule-of-thumb cluster”

You can specify additional columns and define filter criteria to reduce the analysis result. Your specifications apply to all rules of thumb in the cluster.

Example of a rule-of-thumb definition

This example shows how to define your rule of thumb on the Definition page of the Rule-of-Thumb Properties window.

Assume the following:

You want to analyze specific data of the Buffer Pool Read report block of the DB2PM_STAT_BUFFER table. If the result of dividing the value in the NO_PREFETCH_NO_BUF column by the value in the SEQ_PREFETCH_REQ column is greater than 0.01, you want to get a warning. If the result exceeds 0.05, you want to be informed that a problem exists. In both cases, you want to give the recommendation that the EDM pool must be increased. In addition, you want the analysis result to include the value of the SEQ_PREFETCH_REQ column.

Your selections and specifications would then look as follows:

1. In the Report block list, click BUFFER POOL READ.
2. In the Columns box, click NO_PREFETCH_NO_BUF and then click Add ( ) next to the VALUE expression box.
   The selected column is added to the VALUE expression box, preceded by the table name.
3. In the Columns box, click SEQ_PREFETCH_REQ and then click Add ( ) next to the VALUE expression box.
   The selected column is added to the VALUE expression box, preceded by the table name. Performance Expert leaves a space between this and the previously added column.
4. In the VALUE expression box, type the operator / between the two columns to specify the division.
5. In the Columns box, click SEQ_PREFETCH_REQ and then click Add ( ) next to the Additional columns box.
6. In the VALUE list (under WARNING and PROBLEM thresholds), click the operator > because you want to be notified when the result of the previously selected columns exceeds a certain value.
7. In the WARNING threshold field, type 0.01.
8. In the PROBLEM threshold field, type 0.05.
9. In both Recommendation fields, type Increase BP size as needed.

Defining filter criteria and additional columns for the rule-of-thumb cluster

You can specify additional columns and define filter criteria to reduce the analysis result. Your specifications apply to all rules of thumb in the cluster.

To define the additional columns and filter criteria:
1. Click the rule-of-thumb cluster, and then click **Selected > Properties**. The Rule-of-Thumb Cluster Properties window is displayed.

2. Click the **Definition** tab to do the following:
   - Select a report block or a table. Your selection determines the content of the **Columns** box.
   - Fill the **Filter expression** and **Additional columns** boxes by clicking a column in the **Columns** box and then clicking the appropriate **Add (↑)** button. The entry appearing in these boxes consists of the table and column names.
   - If you want the values of additional columns included in the analysis result of all rules of thumb, add these columns to the **Additional columns** box.
   - If you add several columns to the **Filter expression** box, you must use operators to combine the columns into an SQL query.
   - You can use variables in the filter expression that you can resolve during the rules-of-thumb analysis. See “Resolving variables” on page 105 for more information.
   - The SQL query generated from the specifications on this page and for all rules of thumb in the cluster must not exceed 32 KB.

3. Make your selections and fill in the various fields.

4. Click **OK** to save the changes.

### Changing a rule-of-thumb cluster or a rule of thumb

You can change the properties of a rule-of-thumb cluster or a rule of thumb, or rename or delete a rule-of-thumb cluster or a rule of thumb.

You can change a rule-of-thumb cluster and its rules of thumb in one of the following ways:

- Change the properties of a rule-of-thumb cluster or a rule of thumb.
  To change the properties, click the cluster or the rule of thumb and click **Selected > Properties**.
- Rename a rule-of-thumb cluster or a rule of thumb.
  To rename a cluster or a rule of thumb, click the cluster or the rule of thumb and click **Selected > Rename**.
- Delete a rule-of-thumb cluster or a rule of thumb.
  To delete a cluster or a rule of thumb, click the cluster or the rule of thumb and click **Selected > Delete**.

The tasks of copying and moving rule-of-thumb clusters are similar. You move a rule-of-thumb cluster to another rule-of-thumb group by copying it to the other rule-of-thumb group and then deleting it from the original rule-of-thumb group.

The tasks of copying and moving rules of thumb are similar. You move a rule of thumb to another rule-of-thumb cluster by copying it to the other rule-of-thumb cluster and then deleting it from the original rule-of-thumb cluster. You can copy a rule of thumb within the same rule-of-thumb cluster.
Copying or moving a rule-of-thumb cluster to another rule-of-thumb group
The tasks of copying and moving rule-of-thumb clusters are similar. You move a rule-of-thumb cluster to another rule-of-thumb group by copying it to the other rule-of-thumb group and then deleting it from the original rule-of-thumb group.

You can copy a rule-of-thumb cluster within the same rule-of-thumb group.

To copy a rule-of-thumb cluster:
1. In the folders pane of the Performance Warehouse window, under Rule-of-Thumb Clusters, click the rule-of-thumb cluster and then click Selected > Copy.
   The Copy Rule-of-Thumb Cluster window is displayed.
2. In the Rule-of-thumb group list, click an existing rule-of-thumb group to which you want to copy the rule-of-thumb cluster. You can select the same rule-of-thumb group that already contains the rule-of-thumb cluster.
3. In the New rule-of-thumb cluster name field, specify a name for the copy that is unique throughout the destination process group.
4. Click OK to return to the Performance Warehouse window.

The copied rule-of-thumb cluster appears under Rule-of-Thumb Clusters of the selected rule-of-thumb group.

If you copied a public rule-of-thumb cluster, its scope has changed from public to private.

Copying or moving a rule of thumb to another rule-of-thumb cluster
The tasks of copying and moving rules of thumb are similar. You move a rule of thumb to another rule-of-thumb cluster by copying it to the other rule-of-thumb cluster and then deleting it from the original rule-of-thumb cluster. You can copy a rule of thumb within the same rule-of-thumb cluster.

To copy a rule of thumb, the following must apply:
• The destination rule-of-thumb group must contain at least one rule-of-thumb cluster.
• The rule of thumb that you want copy must be the first rule of thumb in the rule-of-thumb cluster or fit the cluster category. The cluster category is determined by the counter category of the first rule of thumb that you copy or move into, or create for, this cluster.

To copy a rule of thumb:
1. In the folders pane of the Performance Warehouse window, click Rules of Thumb. In the contents pane, click the rule of thumb and then click Selected > Copy.
   The Copy Rule of Thumb window is displayed.
2. In the Rule-of-thumb group list, click a rule-of-thumb group to which you want to copy the rule of thumb. You can select the same rule-of-thumb group that already contains this rule of thumb.
3. In the Rule-of-thumb cluster field, click a rule-of-thumb cluster to which you want to copy the template. You can select the same rule-of-thumb cluster that already contains this rule of thumb.
4. In the New rule-of-thumb name field, specify a name for the copy that is unique throughout the destination rule-of-thumb cluster.

5. Click OK to return to the Performance Warehouse window.

The copied rule of thumb appears under the selected rule-of-thumb group and rule-of-thumb cluster.

### Analyzing the performance data

You can use rules of thumb to analyze data in the Performance Warehouse database.

For information about how to load data, see “Scenario 1: Transferring performance data into the Performance Warehouse database” on page 85. You can analyze the data using all rules of thumb in a cluster or using individual rules of thumb. If you analyze an entire rule-of-thumb cluster, the analysis result will show a column for each of the rules of thumb in the cluster.

Several users can analyze the same data at the same time. To avoid a locking conflict, make sure that you are not analyzing the data while another user is loading data into the Performance Warehouse database.

1. To analyze the data, do one of the following:
   - If you want to use a single rule of thumb:
     a. In the folders pane of the Performance Warehouse window, select the appropriate rule-of-thumb cluster and then click its subitem Rules of Thumb.
        The contents pane lists all rules of thumb that you defined for this rule-of-thumb cluster.
     b. Select the rule of thumb you want and then click Selected > Analyze.
   - If you want to use all rules of thumb defined for a rule-of-thumb cluster:
     In the folders pane of the Performance Warehouse window, select the appropriate rule-of-thumb cluster and then click Selected > Analyze.
     The Options page of the Rules-of-Thumb Analysis window is displayed, which shows the filter expression specified for the rule-of-thumb cluster.

2. Specify filter criteria. For more information refer to “Specifying filter criteria” on page 105.

3. Resolve variables. For more information refer to “Resolving variables” on page 105.

4. Sort the analysis result by the result of the arithmetic expression defined for a specific rule of thumb. For more information refer to “Sorting the analysis result” on page 106.

5. Click Analyze to run the analysis.

The Result matrix page of the Rules-of-Thumb Analysis window is displayed. For more information about this and the other pages of this window, see “Viewing and understanding the analysis result” on page 106.

The LOADLOG table holds report and trace interval data for loaded data. You can use the trace start and end time, and the ID of the job step as criteria for filtering rules of thumb. This can be useful if you want to analyze only those trace records loaded by a specific user for a particular step at a certain time.

Unresolved variables in the filter expression are prefixed by a colon.
On the Result matrix and the Column details pages of the Rules-of-Thumb Analysis window, the analysis result is sorted by timestamp or as shown in the Variables context field on the Options page. You can change the order by selecting the result of the arithmetic expression specified for a rule of thumb as sort criterion. In this case, the Column details page shows the results of the arithmetic expression instead of the attention values.

Specifying filter criteria

The LOADLOG table holds report and trace interval data for loaded data. You can use the trace start and end time, and the ID of the job step as criteria for filtering rules of thumb. This can be useful if you want to analyze only those trace records loaded by a specific user for a particular step at a certain time.

To specify filter criteria:

1. On the Options page of the Rules-of-Thumb Analysis window, click **Time** in the folders pane. The Time setting area is displayed in the lower-right corner of the contents pane. This area shows information from the LOADLOG table. It contains the user ID of the user that loaded the data, the trace interval data, and the load-job step ID associated with the load job. For more information about this table, refer to “The LOADLOG table” on page 119.

2. Select a row that holds the appropriate trace-start time, trace-end time, or step-log ID and click **Start time**, **End time**, or **LOAD step**. If more than one table is referenced, the Select Table window is displayed. Select a table from the list and click **OK**. The corresponding filter expression is displayed in the text field. You can combine expressions using the AND, OR, and NOT operators. For example, if you clicked **Start time**, the filter expression comprises the table name, the trace-start time column name, and the value of the trace-start time for the selected row in the time-setting table. If you clicked **LOAD step**, the filter expression comprises the table name, the step-log ID column name, and the value of the step-log ID for the selected row in the time-setting table.

3. Click **Apply**. The filter expression is inserted in the Variables context field directly after the WHERE clause.

4. To remove the filter expression from the WHERE clause, click **Reset**.

Resolving variables

Unresolved variables in the filter expression are prefixed by a colon.

To resolve these variables:

- On the Options page of the Rules-of-Thumb Analysis window, click **Variables** in the folders pane. The Variables setting area is displayed in the contents pane. This area shows a list of variables found in the filter expression with the last-saved values for these variables. Values are saved each time you analyze the
trace data or execute a query using the same variables. You can enter a value for each of the variables shown. These values are used when you analyze the trace data.

- Click **Reset** to change the values of the variables back to the saved values.

**Sorting the analysis result**

On the Result matrix and the Column details pages of the Rules-of-Thumb Analysis window, the analysis result is sorted by timestamp or as shown in the *Variables context* field on the Options page. You can change the order by selecting the result of the arithmetic expression specified for a rule of thumb as sort criterion. In this case, the Column details page shows the results of the arithmetic expression instead of the attention values.

To sort the analysis result:

1. On the Options page of the Rules-of-Thumb Analysis window, click **Order by expression value** in the folders pane.
   - If you selected a single rule of thumb, the **Select rule of thumb** list contains this rule of thumb. If you selected a rule-of-thumb cluster, all rules of thumb in the rules-of-thumb cluster are listed.

2. Select the rule of thumb for the arithmetic expression that you want to use to sort the analysis result.
   - You specified the arithmetic expression in the **VALUE expression** box on the Definition page of the Rule-of-Thumb Properties window for a rule of thumb. The sort direction (ascending or descending) depends on whether you set lower or upper limits for the **WARNING** and **PROBLEM** thresholds.

**Viewing and understanding the analysis result**

The first page that you see after the analysis finishes is the Result matrix page.

The Result matrix page shows:

- A list of the entire trace data that was created between the trace-start and trace-end times that you specified on the Time pane of the Options page. The data is sorted as follows:
  - By timestamp
  - As shown in the *Variables context* field on the Options page
  - By the result of the arithmetic expression of the rule of thumb selected on the Order by value expression pane on the Options page
- Additional columns you specified for the rule-of-thumb cluster (cluster definition columns).
- A column for each rule of thumb that you used for the analysis.
- The attention value (**OK**, **warning**, **problem**) of the analysis for each timestamp and rule of thumb. The result depends on your specifications on the Definition page of the Rule-of-Thumb Properties window.
  - A dash (–) means that a value is not available.

To reduce the list displayed on the Result matrix page, you can display only rows with at least one warning or a higher attention level or only rows with at least one problem:

- Click **View > Warning** to view all rows that contain at least one warning or at least one problem.
- Click **View > Problem** to view only rows that contain at least one problem.
Your selection remains valid until you click View > All again.

If there are a lot of entries in the list, they are not displayed all at one time. You can move to the next or previous set of entries by clicking View > Next or View > Previous. If you previously reduced the list, for example, to rows that show only problems, this selection remains valid when you move to the next or previous set of entries.

**Viewing the results for a specific timestamp**

In the Result matrix page, click a row in the Timestamp column to view the result of all rules of thumb for a specific timestamp. The Row details page of the Rules-of-Thumb Analysis window is displayed.

**Viewing the results for all timestamps**

In the Result matrix page, click a column other than the Timestamp column or the Cluster definition columns to view the result of a rule of thumb for all timestamps. The Column details page of the Rules-of-Thumb Analysis window is displayed.

**Viewing the results for a specific timestamp**

In the Result matrix page, click a row in the Timestamp column to view the result of all rules of thumb for a specific timestamp. The Row details page of the Rules-of-Thumb Analysis window is displayed.

This page lists all the rules of thumb, the attention values, and the cluster-definition column values for a specific date and time.

The Cluster definition columns field shows the values for the columns that you added as additional columns to the rules-of-thumb cluster that contains the analyzed rules of thumb (see the Definition page of the Rules-of-Thumb Cluster Properties window).

The Rule of thumb details shows the result of the first rule of thumb in the list for which the Attention column contains a value.

To view the result of another rule of thumb, click it in the ROT Name column. For more information about the individual fields, see Explanation of the individual fields in the Rules of thumb details.

**Viewing the results for all timestamps**

In the Result matrix page, click a column other than the Timestamp column or the Cluster definition columns to view the result of a rule of thumb for all timestamps. The Column details page of the Rules-of-Thumb Analysis window is displayed.

This page lists the timestamps, the attention values, and the cluster-definition column values for the selected rule of thumb. If the analysis result is sorted by the result of the arithmetic expression of a specific rule of thumb, the results of the arithmetic expression are shown instead of the attention values and you are informed of the sort.

The Cluster definition columns field shows the values for the columns that you added as additional columns to the rules-of-thumb cluster that contains the selected rule of thumb (see the Definition page of the Rules-of-Thumb Cluster Properties window).
The Rules of thumb details shows the result of the first timestamp in the list for which the Attention column contains a value. To view the result of another timestamp, click it in the Timestamp column.

Explanation of the individual fields under Rules of thumb details on the Row Details and Column Details pages:

**ROT description**
- The description that you specified for the rule of thumb on the General page of the Rule-of-Thumb Properties window.

**VALUE expression**
- The arithmetic expression that you specified in the VALUE expression box on the Definition page of the Rule-of-Thumb Properties window.

**VALUE**
- The result of the arithmetic expression and its relation to the appropriate threshold value, as defined on the Definition page of the Rule-of-Thumb Properties window.

**Recommendation**
- The recommendation that you specified on the Definition page of the Rule-of-Thumb Properties window in the case of a problem or a warning.

**VALUE expression columns**
- The individual table columns that you selected for the VALUE expression box on the Definition page of the Rule-of-Thumb Properties window and the value produced by the analysis.

**Additional columns**
- The table columns that you added as additional columns to the selected rule of thumb (see the Definition page of the Rule-of-Thumb Properties window) and the values produced by the analysis.
Chapter 21. Defining and running queries

You can use the query facility to define performance-management queries to run on the Statistics and Accounting tables in the Performance Warehouse database.

For example, Accounting tables contain performance data that shows how many resources are consumed by the applications. Appropriate queries on the ACCOUNTING table can help you achieve performance improvements. A set of queries is provided. They can be run as they are but you can also define and save your own queries.

You always start on the Performance Warehouse window. In the System Overview window, click the Performance Warehouse toolbar button to start Performance Warehouse. The Performance Warehouse window is displayed.

"Managing query groups"
A query group is a container for queries. The Public query group contains the sample queries delivered with the product and those queries that other users have made generally available.

"Managing queries" on page 110
After you define query groups you can create and change queries.

"Running a query" on page 112
You can run queries on the data in the Performance Warehouse database.

Managing query groups

A query group is a container for queries. The Public query group contains the sample queries delivered with the product and those queries that other users have made generally available.

In the sample queries, the query strings and value expressions are not formatted. However, you can copy the queries and rules, and insert blanks or new lines to get a more readable format.

"Creating a query group"
Before you define a query, you must create a query group to contain this query.

"Changing a query group" on page 110
You can change the description of the query group, or rename or delete a query group.

"Copying a query group" on page 110
If you want to create several query groups that only differ in a query property, you might prefer to copy and change a query group. When you copy a query group, any queries that it contains are copied with it.

Creating a query group

Before you define a query, you must create a query group to contain this query.

To create a query group:

1. In the folders pane of the Performance Warehouse window, select Query Groups and then click Selected > Create.

The Query Group Properties window is displayed.
The Author, Creation date and time, and Modification date and time fields are filled in when you click OK. The Author field will contain your DB2 user ID.

2. In the Name field, specify a unique name for the query group.
3. You can type a description for the query group in the Description field. This is optional.
4. Click OK to save this query group and return to the Performance Warehouse window.

The new group appears in the folders pane as a subitem of Query Groups.

**Changing a query group**

You can change the description of the query group, or rename or delete a query group.

You can change a query group in one of the following ways:
- Change the description of the query group.
  To change the description, click the query group and click Selected > Properties.
- Rename a query group.
  To rename a group, click the query group and click Selected > Rename.
- Delete a query group.
  To delete a group, click the query group and click Selected > Delete.

**Copying a query group**

If you want to create several query groups that only differ in a query property, you might prefer to copy and change a query group. When you copy a query group, any queries that it contains are copied with it.

To copy a query group:
1. In the folders pane of the Performance Warehouse window, under Query Groups, click the query group and then click Selected > Copy.
   The Copy Query Group window is displayed.
2. In the New query group name field, specify a name for the copy that is unique within the query-group folder.
3. Click OK.
   When you return to the Performance Warehouse window, the copy appears in the folders pane.

**Managing queries**

After you define query groups you can create and change queries.

“Creating a query” on page 111
To create a query, select Queries in the folders pane of the Performance Warehouse window and then click Selected > Create.

“Changing a query” on page 111
You can change the properties of a query, or rename or delete a query.

“Copying or moving a query to another query group” on page 111
The tasks of copying and moving queries are similar. You move a query to another query group by copying it to the other query group and then deleting it from the original query group.
Creating a query

To create a query, select Queries in the folders pane of the Performance Warehouse window and then click Selected > Create.

The General page of the Query Properties window is displayed. The Author, Creation date and time, and Modification date and time fields are filled in when you click OK. The Author field will contain your DB2 user ID. Then:
1. Specify a unique name for the query in the Name field.
2. You can type a description for the query in the Description field. This is optional.
3. Click the Definition tab. Here you can select or specify the SQL string that makes up the query.
4. Select a report type.
5. Select a report block or a table. Your selection determines the content of Columns.
6. Select a row in Columns that contains the column or table name you want to include in your query and then select this name to include it in the query. For more information about the Columns contents, refer to “The Performance Warehouse data tables” on page 117.
7. Click Add column or Add table to add the column or table name to the query. You can use SQL query operators to combine the names.
8. Click OK to save the query and return to the Performance Warehouse window.

Changing a query

You can change the properties of a query, or rename or delete a query.

You can change a query in one of the following ways:
• Change the properties of a query, such as the scope, description, or query definition.
  To change the properties, click the query and click Selected > Properties.
• Rename a query.
  To rename a query, click the query and click Selected > Rename.
• Delete a query.
  To delete a query, click the query and click Selected > Delete.

Copying or moving a query to another query group

The tasks of copying and moving queries are similar. You move a query to another query group by copying it to the other query group and then deleting it from the original query group.

You can copy a query within the same query group.

To copy a query:
1. In the folders pane of the Performance Warehouse window, click Queries. In the contents pane, click the query you want to copy and then click Selected > Copy.
   The Copy Query window is displayed.
2. In the Query group list, click an existing query group to which you want to copy the query. You can select the same query group that already contains this query.
3. In the **New query name** field, specify a unique name for the copied query.
4. Click **OK** to return to the Performance Warehouse window. The copied query appears under the selected query group.

### Running a query

You can run queries on the data in the Performance Warehouse database.

For information about how to load data, see “Scenario 1: Transferring performance data into the Performance Warehouse database” on page 85. Several users can run their queries on the same data. In this case, however, to avoid a locking conflict, make sure that you are not running the query while another user is loading data into the Performance Warehouse database.

1. In the folders pane of the Performance Warehouse window, select the appropriate query group and then click its subitem **Queries**. The contents pane lists all the queries in the query group.
2. Click the query you want to run and then click **Selected > Execute**. The View SQL page of the Query Execution window is displayed. It shows the query definition. From here you can edit the query, specify filter criteria, and resolve any unresolved variables in the query expression. Note that variables must begin with a colon followed by at least one alphanumeric character, such as `:c`. It can also consist of alphanumeric and underscore characters, for example, `:connect_type6`.
3. Specify filter criteria. For more information refer to “Specifying filter criteria.”
4. Resolve variables. For more information refer to “Resolving variables” on page 113.
5. Click **Execute** to start the query. The View Result page of the Query Execution window is displayed. For more information about this window, see “Viewing the query results” on page 113.

**Specifying filter criteria**

The LOADLOG table holds report and trace interval data for loaded data. You can use the trace start and end time, and the ID of the job step as criteria for filtering queries. This can be useful if you want to analyze only those trace records loaded by a specific user for a particular step at a certain time.

Unresolved variables in the query expression are prefixed by a colon. After the query has run, the View SQL page of the Query Execution window is displayed.

1. On the View SQL page of the Query Execution window, click **Time**. The **Time setting** area is displayed in the contents pane.
This area shows information from the LOADLOG table. It contains the user ID of the user that loaded the data, the trace-interval data, and the load-job step ID associated with the load job. For more information about this table, refer to “The LOADLOG table” on page 119.

2. Select a column that holds the appropriate trace-start time, trace-end time, or step-log ID and click Start time, End time, or LOAD step. The Select Table window is displayed.

3. Select a table from the list and click OK.

   The corresponding filter expression is displayed in the text field. You can combine expressions using the AND, OR, and NOT operators.

   For example, if you clicked Start time, the filter expression comprises the table name, the trace start time column name, and the value of the trace start time of the selected row in the time-setting table. If you clicked LOAD step, the filter expression comprises the table name, the step-log ID column name, and the value of the step-log ID of the selected row in the time-setting table.

4. Click Apply. The filter expression is inserted in the query at the current cursor position.

Resolving variables

Unresolved variables in the query expression are prefixed by a colon.

To resolve these variables:

1. On the View SQL page of the Query Execution window, click Variables.

   The Variables setting area is displayed in the contents pane.

   This area shows a list of variables found in the query expression with the last-saved values for these variables. Values are saved each time you analyze the trace data or execute a query using the same variables. You can enter a value for each of the variables shown. These values are used when you run the query.

2. Click Reset to change the values of the variables back to the saved values.

Viewing the query results

After the query has run, the View SQL page of the Query Execution window is displayed.

The query expression is shown at the top of the page. The table shows the result of the query. The column headings are defined by the query. The number of rows read from the result set is shown at the bottom of the table. To sort the contents of the table, click a column heading.

• To save the results in a format that can be used by standard spreadsheet programs, click Save.

   The result matrix, the query properties, and the query expression are saved.

• To view the query results in a Web browser, click Browse.

   You can use the Web browser’s standard functions to print the query results.
Part 4. Additional information

These topics provide additional information that can be helpful when you work with OMEGAMON XE for DB2 PE.

Chapter 22, “Overview of the Performance Warehouse database,” on page 117
To analyze your performance data, you can run SQL queries against the tables in the Performance Warehouse database. The sample queries delivered with Performance Warehouse help you understand the contents of, and relationships between, the tables and how data can be joined to evaluate performance data and identify performance problems.

Chapter 23, “Troubleshooting,” on page 121
This section helps you solve common problems that you might encounter.

Chapter 24, “Accessibility features in Performance Expert Client,” on page 125
This section describes the major accessibility features in Performance Expert Client.
Chapter 22. Overview of the Performance Warehouse database

To analyze your performance data, you can run SQL queries against the tables in the Performance Warehouse database. The sample queries delivered with Performance Warehouse help you understand the contents of, and relationships between, the tables and how data can be joined to evaluate performance data and identify performance problems.

However, to use your queries efficiently, you must understand the data model designed for the performance-relevant tables. In addition, you must be familiar with the LOADLOG table, which you need to access and manage the data in the Performance Warehouse database, for example, if you want to delete or archive it.

The Performance Warehouse database consists of:

- Performance Warehouse data tables that store the DB2 performance data collected from DB2.
- Control tables that establish the infrastructure of Performance Warehouse.

The Performance Warehouse database contains the following Performance Warehouse data tables for table space **STAT**.

The LOADLOG table contains the information you need to access and manage the performance data.

---

### The Performance Warehouse data tables

The Performance Warehouse database contains the following Performance Warehouse data tables for table space **STAT**.

**Table 5. Performance Warehouse data tables for table space **STAT**.**

<table>
<thead>
<tr>
<th>Table name</th>
<th>Table description</th>
</tr>
</thead>
</table>
| DB2PM_STAT_BUFFER     | One row for each buffer pool that is active at the start of:  
|                       | • The corresponding delta record for file data.  
|                       | • The interval record for save-file data.                                                                                                                                 |
| DB2PM_STAT_DATASET    | One row for each open data set that has an I/O event rate of at least one event per second during the reporting interval.                                      |
| DB2PM_STAT_DDF        | For each delta record (file data) or interval record (save-file data), one row per remote location participating in distributed activity using the system-directed access method and one row for all remote locations using the application-directed access method. |
| DB2PM_STAT_GBUFFER    | One row per group buffer pool that is active at the start of the corresponding delta record for file data or of the interval record for save-file data.     |
| DB2PM_STAT_GENERAL    | **For file data:** One row for each Statistics delta record, containing data from IFCID 1 and 2. A delta record is a set of counters describing the DB2 activity between two consecutive DB2 Statistics records pairs.  
|                       | **For save-file data:** One row for each Statistics interval record, containing data from IFCID 1 and 2. A Statistics interval record is a set of counters describing the DB2 activity within the interval specified by the user. |
The Performance Warehouse database contains the following Performance Warehouse data tables for table space ACCS:

**Table 6. Performance Warehouse data tables for table space ACCS**

<table>
<thead>
<tr>
<th>Table name</th>
<th>Table description</th>
</tr>
</thead>
<tbody>
<tr>
<td>DB2PMSACCT_BUFFER</td>
<td>One row per buffer pool used.</td>
</tr>
<tr>
<td>DB2PMSACCT_DDF</td>
<td>One row per remote location participating in distributed activity.</td>
</tr>
<tr>
<td>DB2PMSACCT_GBUFFER</td>
<td>One row per group buffer pool used.</td>
</tr>
<tr>
<td>DB2PMSACCT_GENERAL</td>
<td>One row per DB2 Accounting record, which is written when a thread terminates, is reused, or becomes inactive.</td>
</tr>
<tr>
<td>DB2PMSACCT_PROGRAM</td>
<td>One row per package and DBRM executed.</td>
</tr>
<tr>
<td>DB2PMSACCT_RLF</td>
<td>One row per resource limit type encountered.</td>
</tr>
</tbody>
</table>

**Related reading:** For more information about these tables, refer to the part on the Performance Warehouse database in Reporting User’s Guide.

The Performance Warehouse database described in the Reporting User’s Guide contains more tables than the one described here. However, it must be created and managed manually using the sample CREATE and LOAD parts shipped with OMEGAMON XE for DB2 PE. The Performance Warehouse database described here is created automatically, managed by the OMEGAMON Collector, and is accessible using the Performance Warehouse client.

**Related reading:** The Accounting and Statistics tables are associated in a 1:n relationship as described in Reporting User’s Guide.

The general table is the parent table for all other tables. Each row in the general table is associated with zero, one, or several rows in the other tables. For Accounting SAVE tables, use the columns LOCAL_LOCATION to CLIENT_TRANSACTION for joining related data. For Statistics tables, use the columns LOCAL_LOCATION, GROUP_NAME, SUBSYSTEM_ID, MEMBER_NAME, INTERVAL_TSTAMP, and BEGIN_REC_TSTAMP for joining related data.

The Accounting and Statistics tables in the Performance Warehouse database contain the following additional columns: STEPLOGID of type INTEGER and ROW_ID of type ROWID. These columns are populated by the OMEGAMON Collector and DB2 when performance data is loaded into the Performance Warehouse data tables. The value of STEPLOGID references the LOADLOG table and can be used to correlate the performance data and the LOAD step that loaded the data. DB2 generates the ROW_ID values automatically when rows are added to the Performance Warehouse data tables. They are used in the rules-of-thumb analysis to correlate general and detailed analysis results.
The LOADLOG table

The LOADLOG table contains the information you need to access and manage the performance data.

Table 7. LOADLOG table

<table>
<thead>
<tr>
<th>Column name</th>
<th>Data type</th>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>LL_ID</td>
<td>INTEGER</td>
<td>P</td>
<td>Unique LOADLOG ID</td>
</tr>
<tr>
<td>LL_INSERTEDBY</td>
<td>VARCHAR(8)</td>
<td></td>
<td>User ID of the user who inserted the data</td>
</tr>
<tr>
<td>LL_STARTTS</td>
<td>TIMESTAMP</td>
<td></td>
<td>Date and time of the first event recorded</td>
</tr>
<tr>
<td>LL_STOPTS</td>
<td>TIMESTAMP</td>
<td></td>
<td>Date and time of the last event recorded</td>
</tr>
<tr>
<td>LL_LOADTYPE</td>
<td>CHAR(10)</td>
<td></td>
<td>Load type: ACCOUNTING, STATISTICS</td>
</tr>
</tbody>
</table>

Each row in the table is associated with a LOAD step executed by the OMEGAMON Collector and has a unique LL_ID. This LL_ID is referenced by an Accounting or a Statistics table with its foreign key STEPLOGID, which is defined with delete rule ON DELETE SET NULL. If you delete a row from the LOADLOG table, the column STEPLOGID of the dependent rows is set to NULL. To delete data from the DB2PM_STAT and DB2PMSACCT tables:

1. Determine the entries using the LOADLOG table and apply a search condition on the STEPLOGID column in the DELETE statements.
2. Delete the corresponding LOADLOG entries.

The LOADLOG entries related to the LOAD steps are displayed under **Time setting** on the View SQL page of the Query Execution window and on the Options page of the Rules-of-Thumb Analysis window. They help you restrict your queries and rules of thumb to the time intervals during which data was loaded.
Chapter 23. Troubleshooting

This section helps you solve common problems that you might encounter.

“Creating a diagnostic report”
If you have an error that you cannot resolve yourself, for example, if a function does not work correctly or an error message appears that you do not understand, you can create a diagnostic report that you can send to IBM support as a problem management report (PMR).

“Responding to dialog boxes” on page 122
OMEGAMON XE for DB2 PE supports a modal dialog boxes, such as message boxes, to which you must respond before you can proceed with any other action.

“Troubleshooting for Performance Expert Client” on page 122
This topic describes the problems that you might encounter in Performance Expert Client.

“Troubleshooting for Performance Warehouse” on page 122
The following sections describe the problems that you might encounter in Performance Warehouse.

Creating a diagnostic report

If you have an error that you cannot resolve yourself, for example, if a function does not work correctly or an error message appears that you do not understand, you can create a diagnostic report that you can send to IBM support as a problem management report (PMR).

You create a report from the System Overview window. To forward the report to IBM support, ensure that you have specified your e-mail settings in the global settings. For more information about specifying global settings, see “Specifying global settings” on page 14.

To create a diagnostic report:

1. In the System Overview window, click Help > Diagnostics.
   The Diagnostics window is displayed.
2. Click the Start ( ) toolbar button to start recording diagnostic information.
3. When you have recorded the entire information, click the Stop ( ) toolbar button.
4. Do one of the following:
   • Click the Send ( ) toolbar button to send the diagnostic report to IBM support.
     The Send Diagnostic Information window is displayed. Type a brief description of the problem in the Subject field and click OK. The diagnostic report is sent to IBM support and deleted from your system.
   • Click the Save ( ) toolbar button.
     The Save Diagnostic Information window is displayed. In the Scenario field, provide a detailed description of the error situation and click OK.
Responding to dialog boxes

OMEGAMON XE for DB2 PE supports a modal dialog boxes, such as message boxes, to which you must respond before you can proceed with any other action.

If such a dialog box is in the background, do the following:
1. Press Alt+Tab.
   A dialog box is displayed.
2. Press the Tab key while holding the Alt key until the Java™ Cup and Steam Logo is selected.
3. Release the Alt key.
   The previously invisible dialog box is displayed in the foreground.
4. Respond to the dialog box.

Troubleshooting for Performance Expert Client

This topic describes the problems that you might encounter in Performance Expert Client.

Performance Expert Client does not work correctly after startup

If you have a firewall installed on your workstation, ensure that Performance Expert Client has correct access permissions. Otherwise, Performance Expert Client does not work correctly.

Launching Netscape as HTML browser

If launching an HTML browser from Performance Expert Client fails, the browser is opened separately.

Troubleshooting for Performance Warehouse

The following sections describe the problems that you might encounter in Performance Warehouse.

“Solving code-page problems when accessing Performance Warehouse”
For some installations, you might receive SQL0332 errors when accessing Performance Warehouse.

“Restarting the OMEGAMON Collector” on page 123
Before restarting the OMEGAMON Collector, which manages Performance Warehouse, disconnect from all Performance Warehouse clients and all subsystems of Performance Expert Clients that are connected.

“Running a CONVERT step with an incorrect data set” on page 123
CONVERT steps assume Save data sets as input that were produced by Performance Expert batch reports. If a CONVERT step runs with an incorrect input data set, the OMEGAMON Collector fails (see error log) and is unable to run any processes. In this case, the OMEGAMON Collector must be stopped and restarted.

Solving code-page problems when accessing Performance Warehouse
For some installations, you might receive SQL0332 errors when accessing Performance Warehouse.
To solve this problem, set DB2CODEPAGE to a value that is compatible with the host SCCSID. In addition, the SYSlBM.SYSSTRINGS table must contain a row that maps the two values in the INCCSID OUTCCSID columns. For more information about DB2CODEPAGE values, see the section National Language Support Considerations in one of the DB2 Connect Quick Beginnings books.

If you still cannot connect to Performance Warehouse, you might see the following message: SQL0332N - There is no available conversion for the source code page "1208 UNKNOWN 3" to the target code page. Reason Code. SQLSTATE=57017.

To solve this problem, add DISABLEUNICODE=1 in the file sqllib\db2cli.ini for the DB2 subsystem, where sqllib is the default DB2 Connect installation directory. See also the technical notes (Technotes) #1008683 and #1008573.

If DISABLEUNICODE does not work, you might get the following message: SQL0332N There is no available conversion for the source code page "01208" to the target code page "00437". Reason code "DSNXRIVB". SQLSTATE=57017.

To solve this problem, UNICODE support on z/OS must be enabled correctly including Enforced Subset and Round Trip method in the conversion image. For more information, see APAR PQ40270 and PMR #68853.

**Restarting the OMEGAMON Collector**

Before restarting the OMEGAMON Collector, which manages Performance Warehouse, disconnect from all Performance Warehouse clients and all subsystems of Performance Expert Clients that are connected.

This is necessary because the clients might hold a lock on the Performance Warehouse data tables and prevent the OMEGAMON Collector from restarting and initializing.

**Running a CONVERT step with an incorrect data set**

CONVERT steps assume Save data sets as input that were produced by Performance Expert batch reports. If a CONVERT step runs with an incorrect input data set, the OMEGAMON Collector fails (see error log) and is unable to run any processes. In this case, the OMEGAMON Collector must be stopped and restarted.
Chapter 24. Accessibility features in Performance Expert Client

This section describes the major accessibility features in Performance Expert Client.

Accessibility features help users who have a physical disability, such as restricted mobility or limited vision, use software products successfully. For general information about accessibility refer to “Accessibility features” on page xiii.

You can:
• Operate all features using the keyboard instead of the mouse.
• Access the individual help files.
• Change the system settings to high contrast for all user interface controls and all client area contents.

This section explains how to use these accessibility features.

“Operating all features by using the keyboard”
You can use keys or key combinations to perform operations that can also be done through mouse actions. All menu items can be accessed from the keyboard. In those cases, the keyboard equivalent appears to the right of the menu item, or the shortcut letter is underlined. Some keyboard items also have shortcuts.

“Changing the system settings for colors, fonts, and accessibility options” on page 127
If you are not satisfied with the colors, fonts, and accessibility options supplied by OMEGAMON XE for DB2 PE you can change them within your operating system or within Performance Expert Client

Operating all features by using the keyboard

You can use keys or key combinations to perform operations that can also be done through mouse actions. All menu items can be accessed from the keyboard. In those cases, the keyboard equivalent appears to the right of the menu item, or the shortcut letter is underlined. Some keyboard items also have shortcuts.

To navigate through a window or dialog by using the keyboard instead of the mouse, use the following keyboard shortcuts:

Table 8. Navigating through a window or dialog

<table>
<thead>
<tr>
<th>Navigating through a window or dialog</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Access the window menu</td>
<td>Alt, then down arrow (consecutively)</td>
</tr>
<tr>
<td>Access the menu bar in a window</td>
<td>Alt+underlined letter or F10</td>
</tr>
<tr>
<td>Activate a menu item in the menu bar</td>
<td>Enter</td>
</tr>
<tr>
<td>Access controls in a dialog</td>
<td>Alt+underlined letter</td>
</tr>
<tr>
<td>Navigate through the menu bar</td>
<td>Right arrow, left arrow, down arrow, up arrow</td>
</tr>
<tr>
<td>Move to the next set of controls</td>
<td>Tab or F6</td>
</tr>
<tr>
<td>Move to the previous set of controls</td>
<td>Shift+Tab</td>
</tr>
</tbody>
</table>
Table 8. Navigating through a window or dialog (continued)

<table>
<thead>
<tr>
<th>Navigating through a window or dialog</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Move within tables</td>
<td>Tab or right arrow, Shift+Tab or left arrow, down arrow, up arrow</td>
</tr>
<tr>
<td>Move within folders panes</td>
<td>Up arrow, down arrow</td>
</tr>
<tr>
<td>Expand a folder</td>
<td>Right arrow</td>
</tr>
<tr>
<td>Collapse a folder</td>
<td>Left arrow</td>
</tr>
<tr>
<td>Move within list boxes</td>
<td>Up arrow, down arrow</td>
</tr>
<tr>
<td>Move within combo boxes</td>
<td>Up arrow, down arrow</td>
</tr>
<tr>
<td>Move to a split bar in a window</td>
<td>F8</td>
</tr>
<tr>
<td>Resize a window by using the split bar</td>
<td>Arrow keys</td>
</tr>
</tbody>
</table>

To perform main tasks in windows by using the keyboard instead of the mouse, use the following keyboard shortcuts:

Table 9. Keyboard shortcuts in a window

<table>
<thead>
<tr>
<th>Task</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Help</td>
<td>F1</td>
</tr>
<tr>
<td>Close the active window</td>
<td>Ctrl+W or Alt+F4</td>
</tr>
<tr>
<td>Exit the application</td>
<td>Ctrl+Q</td>
</tr>
<tr>
<td>Cut</td>
<td>Ctrl+X</td>
</tr>
<tr>
<td>Copy</td>
<td>Ctrl+C</td>
</tr>
<tr>
<td>Paste</td>
<td>Ctrl+V</td>
</tr>
<tr>
<td>Print</td>
<td>Ctrl+P</td>
</tr>
<tr>
<td>Refresh displayed data</td>
<td>F5</td>
</tr>
<tr>
<td>Enter or leave history mode</td>
<td>Ctrl+H</td>
</tr>
<tr>
<td>Move back in history mode</td>
<td>Alt+left arrow</td>
</tr>
<tr>
<td>Move forward in history mode</td>
<td>Alt+right arrow</td>
</tr>
<tr>
<td>Add a new DB2 system in System Overview</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Add a new configuration in Trace Configurations</td>
<td>Ctrl+N</td>
</tr>
<tr>
<td>Cancel thread in Thread Summary and Details</td>
<td>Del</td>
</tr>
<tr>
<td>Delete Trace Configuration in Trace Configurations</td>
<td>Del</td>
</tr>
<tr>
<td>Open Trace Configuration</td>
<td>Ctrl+Alt+N</td>
</tr>
<tr>
<td>Open Trace Activation</td>
<td>Ctrl+Alt+A</td>
</tr>
<tr>
<td>Open Exception Processing</td>
<td>Ctrl+Alt+E</td>
</tr>
<tr>
<td>Open System Overview</td>
<td>Ctrl+Alt+O</td>
</tr>
<tr>
<td>Open Buffer Pool Analysis</td>
<td>Ctrl+Alt+B</td>
</tr>
<tr>
<td>Open DB2 command for the active DB2 subsystem</td>
<td>Ctrl+Alt+D</td>
</tr>
<tr>
<td>Open Statistics Details for the active DB2 subsystem</td>
<td>Ctrl+Alt+S</td>
</tr>
<tr>
<td>Open System Health for the active DB2 subsystem</td>
<td>Ctrl+Alt+H</td>
</tr>
</tbody>
</table>
Table 9. Keyboard shortcuts in a window (continued)

<table>
<thead>
<tr>
<th>Task</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open Threads in Lock Conflicts for the active DB2 subsystem</td>
<td>Ctrl+Alt+L</td>
</tr>
<tr>
<td>Open Locking Conflicts for the active DB2 subsystem</td>
<td>Ctrl+Alt+C</td>
</tr>
<tr>
<td>Open System Parameters for the active DB2 subsystem</td>
<td>Ctrl+Alt+Y</td>
</tr>
<tr>
<td>Open Performance Warehouse for the active DB2 subsystem</td>
<td>Ctrl+Alt+P</td>
</tr>
<tr>
<td>Open Thread Summary for the active DB2 subsystem</td>
<td>Ctrl+Alt+T</td>
</tr>
</tbody>
</table>

To perform main tasks in dialogs by using the keyboard instead of the mouse, use the following keyboard shortcuts:

Table 10. Keyboard shortcuts in a dialog

<table>
<thead>
<tr>
<th>Task</th>
<th>Shortcut</th>
</tr>
</thead>
<tbody>
<tr>
<td>Confirm a dialog</td>
<td>Enter</td>
</tr>
<tr>
<td>Cancel a dialog</td>
<td>Esc</td>
</tr>
<tr>
<td>Activate a button that has the focus</td>
<td>Spacebar or Enter</td>
</tr>
<tr>
<td>Select and deselect check boxes and radio buttons</td>
<td>Spacebar</td>
</tr>
<tr>
<td>Navigate within check box and radio button groups</td>
<td>Tab</td>
</tr>
<tr>
<td>Open combination box menu</td>
<td>Alt+down arrows</td>
</tr>
<tr>
<td>Close combination box menu</td>
<td>Esc</td>
</tr>
<tr>
<td>Move up and down in combination box menu</td>
<td>Up arrow, down arrow</td>
</tr>
<tr>
<td>Activate combination box menu item</td>
<td>Spacebar or Enter</td>
</tr>
<tr>
<td>Move within a list box</td>
<td>Up arrow, down arrow</td>
</tr>
<tr>
<td>Activate a list box entry</td>
<td>Enter</td>
</tr>
<tr>
<td>Move to a tab in a window containing tabbed pages</td>
<td>Ctrl+Up</td>
</tr>
<tr>
<td>Move between the pages of a window containing tabs if the tab has the focus</td>
<td>Right arrow, left arrow</td>
</tr>
</tbody>
</table>

Changing the system settings for colors, fonts, and accessibility options

If you are not satisfied with the colors, fonts, and accessibility options supplied by OMEGAMON XE for DB2 PE you can change them within your operating system or within Performance Expert Client.

You must restart OMEGAMON XE for DB2 PE before the new settings take effect.

To change the settings within Performance Expert Client:
1. In the System Overview window, click Monitor > Configuration. The Configuration window is displayed.
2. Click the **Accessibility** tab.

3. To specify the appearance scheme for high contrast and font size, select one of the following options in the **High contrast scheme** list:
   - To use the default settings, select `[None]`.
   - To specify a white background containing black text in normal font size, select **Black on white**.
   - To specify a white background containing black text in large font size, select **Black on white (large font)**.
   - To specify a black background containing white text in normal font size, select **White on black**.
   - To specify a black background containing white text in large font size, select **White on black (large font)**.
Part 5. Appendixes
Notices

This information was developed for products and services offered in the US. This material might be available from IBM in other languages. However, you may be required to own a copy of the product or product version in that language in order to access it.

IBM may not offer the products, services, or features discussed in this document in other countries. Consult your local IBM representative for information on the products and services currently available in your area. Any reference to an IBM product, program, or service is not intended to state or imply that only that IBM product, program, or service may be used. Any functionally equivalent product, program, or service that does not infringe any IBM intellectual property right may be used instead. However, it is the user’s responsibility to evaluate and verify the operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter described in this document. The furnishing of this document does not grant you any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive, MD-NC119
Armonk, NY 10504-1785
US

For license inquiries regarding double-byte character set (DBCS) information, contact the IBM Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan Ltd.
19-21, Nihonbashi-Hakozakicho, Chuo-ku
Tokyo 103-8510, Japan

INTERNATIONAL BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR PURPOSE. Some jurisdictions do not allow disclaimer of express or implied warranties in certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors. Changes are periodically made to the information herein; these changes will be incorporated in new editions of the publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) described in this publication at any time without notice.

Any references in this information to non-IBM websites are provided for convenience only and do not in any manner serve as an endorsement of those
websites. The materials at those websites are not part of the materials for this IBM product and use of those websites is at your own risk.

IBM may use or distribute any of the information you provide in any way it believes appropriate without incurring any obligation to you.

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the exchange of information between independently created programs and other programs (including this one) and (ii) the mutual use of the information which has been exchanged, should contact:

IBM Director of Licensing
IBM Corporation
North Castle Drive, MD-NC119
Armonk, NY 10504-1785
US

Such information may be available, subject to appropriate terms and conditions, including in some cases, payment of a fee.

The licensed program described in this document and all licensed material available for it are provided by IBM under terms of the IBM Customer Agreement, IBM International Program License Agreement or any equivalent agreement between us.

The performance data discussed herein is presented as derived under specific operating conditions. Actual results may vary.

Information concerning non-IBM products was obtained from the suppliers of those products, their published announcements or other publicly available sources. IBM has not tested those products and cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of those products.

Statements regarding IBM’s future direction or intent are subject to change or withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM’s suggested retail prices, are current and are subject to change without notice. Dealer prices may vary.

This information contains examples of data and reports used in daily business operations. To illustrate them as completely as possible, the examples include the names of individuals, companies, brands, and products. All of these names are fictitious and any similarity to actual people or business enterprises is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which illustrate programming techniques on various operating platforms. You may copy, modify, and distribute these sample programs in any form without payment to IBM, for the purposes of developing, using, marketing or distributing application programs conforming to the application programming interface for the operating platform for which the sample programs are written. These examples have not been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample programs are provided "AS IS", without warranty of any kind. IBM shall not be liable for any damages arising out of your use of the sample programs.

**Trademarks**

IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business Machines Corp., registered in many jurisdictions worldwide. Other product and service names might be trademarks of IBM or other companies. A current list of IBM trademarks is available on the web at "Copyright and trademark information" at [www.ibm.com/legal/copytrade.shtml](http://www.ibm.com/legal/copytrade.shtml).

Adobe is either a registered trademark or a trademark of Adobe Systems Incorporated in the United States, and/or other countries.

Intel, Itanium, and Pentium are trademarks or registered trademarks of Intel Corporation or its subsidiaries in the United States and other countries.

Linux is a trademark of Linus Torvalds in the United States, other countries, or both.

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries, or both.

Java and all Java-based trademarks and logos are trademarks or registered trademarks of Oracle and/or its affiliates.

UNIX is a registered trademark of The Open Group in the United States and other countries.

Other product and service names might be trademarks of IBM or other companies.

**Terms and conditions for product documentation**

Permissions for the use of these publications are granted subject to the following terms and conditions.

**Applicability**

These terms and conditions are in addition to any terms of use for the IBM website.

**Personal use**

You may reproduce these publications for your personal, noncommercial use provided that all proprietary notices are preserved. You may not distribute, display or make derivative work of these publications, or any portion thereof, without the express consent of IBM.
Commercial use

You may reproduce, distribute and display these publications solely within your enterprise provided that all proprietary notices are preserved. You may not make derivative works of these publications, or reproduce, distribute or display these publications or any portion thereof outside your enterprise, without the express consent of IBM.

Rights

Except as expressly granted in this permission, no other permissions, licenses or rights are granted, either express or implied, to the publications or any information, data, software or other intellectual property contained therein.

IBM reserves the right to withdraw the permissions granted herein whenever, in its discretion, the use of the publications is detrimental to its interest or, as determined by IBM, the above instructions are not being properly followed.

You may not download, export or re-export this information except in full compliance with all applicable laws and regulations, including all United States export laws and regulations.

IBM MAKES NO GUARANTEE ABOUT THE CONTENT OF THESE PUBLICATIONS. THE PUBLICATIONS ARE PROVIDED "AS-IS" AND WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESSED OR IMPLIED, INCLUDING BUT NOT LIMITED TO IMPLIED WARRANTIES OF MERCHANTABILITY, NON-INFRINGEMENT, AND FITNESS FOR A PARTICULAR PURPOSE.
Bibliography

You can order many IBM publications such as product manuals or IBM Redbooks online at the IBM Publications Center website.

You can also order by telephone by calling one of the following numbers:
- In the United States: 800-879-2755
- In Canada: 800-426-4968

In other countries, contact your software account representative to order Tivoli publications.

IBM Tivoli OMEGAMON XE for DB2 Performance Expert publications

The product library covers the following information units:

**OMEGAMON XE for DB2 PE and OMEGAMON XE for DB2 PM**
- Configuration and Customization GH12-7072
- Parameter Reference SH12-7073
- Monitoring Performance from the OMEGAMON Classic Interface SH12-7068
- Monitoring Performance from the IBM Tivoli OMEGAMON Enhanced 3270 User Interface SH12-7074
- Monitoring Performance from Performance Expert Client SH12-7069
- Monitoring Performance from ISPF SH12-7070
- Report Command Reference SH12-7066
- Report Reference SH12-7065
- Reporting User’s Guide SH12-7071
- Messages GH12-7067
- Buffer Pool Analyzer Configuration Guide SH12-7076
- Buffer Pool Analyzer User’s Guide SH12-7075
- Program Directory for Performance Monitor, GI19-5019
- Program Directory for Performance Expert, GI19-5020
- Quick Start Guide for the SQL Dashboard and the end-to-end SQL monitoring functions GH12-7064

Information on InfoSphere Optim Performance Manager for Linux, UNIX, and Windows
- IBM InfoSphere Optim Performance Manager in the Knowledge Center

The documentation is provided in PDF and htm format in the:
- Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS in the IBM Knowledge Center
- Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS in the IBM Knowledge Center

IBM Tivoli Monitoring information

For the most current information, see Tivoli Monitoring in the IBM Knowledge Center
IBM z/OS information

For the most current information, see the z/OS information in the IBM Knowledge Center.

IBM DB2 information

For the most current information, see:

- IBM DB2 Tools Product Documentation
- IBM DB2 for z/OS in the IBM Knowledge Center

Other IBM information

For IBM publications that are not directly related to OMEGAMON XE for DB2 PE and PM, see IBM Publications Center or IBM Knowledge Center.
Index

A
access path of SQL statements 69
accessibility 125
accessibility features xiii
ACCOUNTING REDUCE subcommand 84
ACCOUNTING REPORT command, filter options 91
ACCOUNTING REPORT subcommand 84
Accounting report, setting up 90
ACCOUNTING SAVE subcommand 84
ACCOUNTING TRACE subcommand 84
accumulated values, definition 31

B
bibliography 135
buffer pool analysis, introduction 6
buffer pool, refreshing 36

C
chart, changing type 42
command
understanding syntax diagrams x
comments, sending xiii
conventions used vii
CONVERT step
changing 87
definition 83
input data set, specifying 87
CRD (collect report data) step
creating 93
definition 83
scheduling 93

data view (continued)
global threshold
changing 40
specifying 45
grid, adding 47
percentages 43
single threshold, specifying 46
snapshot
changing the number of visible snapshots 47
freezing their display 47
DB2 commands, issuing 16
DB2 Connect gateway
changing its properties 13
defining 12
logging on 14
monitoring 49
DB2 subsystem
changing its properties 13
DB2 commands, issuing 16
defining 10
exception processing 57
logging off 17
logging on 14
properties, specifying 11
SQL activity tracing 26
starting several monitoring functions 15
system parameters, viewing 55
threads, viewing all active 21
DB2 system parameters, viewing 55
DCS applications, monitoring connections of 49
defining the DB2 systems to be monitored 10
delta processing 33
delta values, definition 31
DGOMUPXT user exit 63
diagnostics
creating report 121
e mail settings, specifying 14
disability 125
dynamic SQL statement cache 35

e mail settings, specifying
for sending diagnostics reports 14
exception processing 58
exception processing definition 57
exception processing
event exception processing
event exception log 59
events, list 58
starting 59
stopping 59
exception notification 58
interval processing 33
periodic exception processing
periodic exception log 63
starting 62

exception processing (continued)
periodic exception processing (continued)
stopping 62
threshold set, changing 62
threshold set, creating 61
thresholds, definition 61
types, definition 57
user exit, activating 63
exporting snapshot data 71

F
FILE subcommand 84
filtering threads 24
font size, how to change 127

G
gauge values
Statistics 31
GLOBAL command
command options 84
exclude filter 90
filter criteria, specifying 90
include filter 90
timestamp option 90

d history data
delta processing 33
enabling collection 67
interval processing 33
viewing 67

I
interval processing 33

K
keyboard shortcuts 125

L
LOAD command, specifying tables 91
LOAD step
changing 87
definition 83
output data set, viewing 88
target tables, specifying 87
LOADLOG table 119

© Copyright IBM Corp. 1997, 2016

137
locking history data, viewing 67
threads associated with resource 30
threads, viewing all 29
long performance counter values 74

M
main functions of OMEGAMON XE for DB2 PE 3
message DGOK3638, reactivating 14
modal dialog boxes 122

O
OMEGAMON Collector
history data, enabling collection 67
restarting 123
OMEGAMON XE for DB2 PE
main functions 3
order filter, specifying for ACCOUNTING REPORT command 91

P
password, saving 14
performance counter values, long 74
Performance Expert Agent for DB2 Connect Monitoring 49
Performance Expert Client
components and features 5
leaving 17
Performance Expert Client does work correctly after startup 122
starting 8
Performance Warehouse
adding systems 81
architecture overview 77
deleting systems 81
introduction 6
logging on 79
OMEGAMON Collector option for 77
Performance Warehouse data tables 117
Performance Warehouse database
description 117
loaded tables, specifying 87
loading performance data 85
performance data, transferring data to 91
periodic exception processing
definition 61
starting 62
stopping 62
threshold set, changing 62
threshold set, creating 61
process
Accounting report, setting up 90
creating 86
definition 75
executing 87
output data set, viewing 88
properties, viewing 86
running
filter criteria, specifying 87
limiting processes shown 87
process (continued)
running (continued)
progress, viewing 87
scheduling 93
Statistics report, setting up 92
step types 83
template, using 86
understanding the schedule string 95
process executions
limiting processes shown 87
viewing 87
process group, creating 86

Q
query
copying 111
creating 111
deleting 111
filter criteria, specifying 112
job-step ID filter, specifying 112
properties, changing 111
renaming 111
results
printing 113
spreadsheet, saving 113
viewing 113
running 112
scope, changing 111
timestamp filter, specifying 112
variables, resolving 113
query group
changing description 110
copying 110
creating 109
deleting 110
renaming 110
Query Workload Tuner 69
rule of thumb (continued)
moving to another rule-of-thumb cluster 103
renaming 102
timestamp filter, specifying 105
variables, resolving 105
rule-of-thumb group
analysis result 106
changing 102
copying to another rule-of-thumb group 103
creating 99
definition 99
filter criteria, specifying 101
moving to another rule-of-thumb group 103
rule-of-thumb group
changing 98
changing description 98
copying 98
creating 98
deleting 98, 102
renaming 98, 102

S
SAVE subcommand 84
schedule string 95
sending comments xiii
service xii
shortcuts 125
snapshots
changing the number of visible snapshots 47
definition 31
exporting 71
history data, viewing 67
long performance counter values 74
printing 71
saving 71
time zones 74
SQL activity traces
creating 26
viewing 27
SQL statements
determining the access path 69
viewing 35
starting several monitoring functions 15
Statistics
buffer pool, refreshing 36
data sharing group 66
delta processing 33
gauge values, definition 31
graphical format, viewing 37
high-water mark values, definition 31
history data, viewing 67
interval processing 33
processing modes 32
regular processing 32
snapshot values, definition 31
viewing 31
STATISTICS FILE subcommand 84
STATISTICS REDUCE subcommand 84
STATISTICS REPORT subcommand 84
Statistics report, setting up 92

redbooks xii
REDUCE subcommand 84
regular processing 32
report
Accounting, setting up 90
commands, allowed 84
Statistics, setting up 92
subcommands, allowed 84
REPORT step
definition 83
filter criteria, specifying 90
input data set, specifying 89
loading data 91
REPORT subcommand 84
rule of thumb
analysis result 106
changing 102
copying to another rule-of-thumb cluster 103
creating 100
defining 100
deleting 102
filter criteria, specifying 105
job-step ID filter, specifying 105
rule of thumb
moving to another rule-of-thumb cluster 103
renaming 102
timestamp filter, specifying 105
variables, resolving 105
rule-of-thumb group
analysis result 106
changing 102
copying to another rule-of-thumb group 103
creating 99
definition 99
filter criteria, specifying 101
moving to another rule-of-thumb group 103
rule-of-thumb group
changing 98
changing description 98
copying 98
creating 98
deleting 98, 102
renaming 98, 102

SAVE subcommand 84
schedule string 95
sending comments xiii
service xii
shortcuts 125
snapshots
changing the number of visible snapshots 47
definition 31
exporting 71
history data, viewing 67
long performance counter values 74
printing 71
saving 71
time zones 74
SQL activity traces
creating 26
viewing 27
SQL statements
determining the access path 69
viewing 35
starting several monitoring functions 15
Statistics
buffer pool, refreshing 36
data sharing group 66
delta processing 33
gauge values, definition 31
graphical format, viewing 37
high-water mark values, definition 31
history data, viewing 67
interval processing 33
processing modes 32
regular processing 32
snapshot values, definition 31
viewing 31
STATISTICS FILE subcommand 84
STATISTICS REDUCE subcommand 84
STATISTICS REPORT subcommand 84
Statistics report, setting up 92

redbooks xii
REDUCE subcommand 84
regular processing 32
report
Accounting, setting up 90
commands, allowed 84
Statistics, setting up 92
subcommands, allowed 84
REPORT step
definition 83
filter criteria, specifying 90
input data set, specifying 89
loading data 91
REPORT subcommand 84
rule of thumb
analysis result 106
changing 102
copying to another rule-of-thumb cluster 103
creating 100
defining 100
deleting 102
filter criteria, specifying 105
job-step ID filter, specifying 105
rule of thumb
moving to another rule-of-thumb cluster 103
renaming 102
timestamp filter, specifying 105
variables, resolving 105
rule-of-thumb group
analysis result 106
changing 102
copying to another rule-of-thumb group 103
creating 99
definition 99
filter criteria, specifying 101
moving to another rule-of-thumb group 103
rule-of-thumb group
changing 98
changing description 98
copying 98
creating 98
deleting 98, 102
renaming 98, 102

SAVE subcommand 84
schedule string 95
sending comments xiii
service xii
shortcuts 125
snapshots
changing the number of visible snapshots 47
definition 31
exporting 71
history data, viewing 67
long performance counter values 74
printing 71
saving 71
time zones 74
SQL activity traces
creating 26
viewing 27
SQL statements
determining the access path 69
viewing 35
starting several monitoring functions 15
Statistics
buffer pool, refreshing 36
data sharing group 66
delta processing 33
gauge values, definition 31
graphical format, viewing 37
high-water mark values, definition 31
history data, viewing 67
interval processing 33
processing modes 32
regular processing 32
snapshot values, definition 31
viewing 31
STATISTICS FILE subcommand 84
STATISTICS REDUCE subcommand 84
STATISTICS REPORT subcommand 84
Statistics report, setting up 92

redbooks xii
REDUCE subcommand 84
regular processing 32
report
Accounting, setting up 90
commands, allowed 84
Statistics, setting up 92
subcommands, allowed 84
REPORT step
definition 83
filter criteria, specifying 90
input data set, specifying 89
loading data 91
REPORT subcommand 84
rule of thumb
analysis result 106
changing 102
copying to another rule-of-thumb cluster 103
creating 100
defining 100
deleting 102
filter criteria, specifying 105
job-step ID filter, specifying 105
rule of thumb
moving to another rule-of-thumb cluster 103
renaming 102
timestamp filter, specifying 105
variables, resolving 105
rule-of-thumb group
analysis result 106
changing 102
copying to another rule-of-thumb group 103
creating 99
definition 99
filter criteria, specifying 101
moving to another rule-of-thumb group 103
rule-of-thumb group
changing 98
changing description 98
copying 98
creating 98
deleting 98, 102
renaming 98, 102

SAVE subcommand 84
schedule string 95
sending comments xiii
service xii
shortcuts 125
snapshots
changing the number of visible snapshots 47
definition 31
exporting 71
history data, viewing 67
long performance counter values 74
printing 71
saving 71
time zones 74
SQL activity traces
creating 26
viewing 27
SQL statements
determining the access path 69
viewing 35
starting several monitoring functions 15
Statistics
buffer pool, refreshing 36
data sharing group 66
delta processing 33
gauge values, definition 31
graphical format, viewing 37
high-water mark values, definition 31
history data, viewing 67
interval processing 33
processing modes 32
regular processing 32
snapshot values, definition 31
viewing 31
STATISTICS FILE subcommand 84
STATISTICS REDUCE subcommand 84
STATISTICS REPORT subcommand 84
Statistics report, setting up 92
troubleshooting (continued)
  launching Netscape as HTML browser 122
  Performance Expert Client does work correctly after startup 122
  responding to dialog boxes 122
  restarting OMEGAMON Collector 123
  running a CONVERT step with an incorrect data set 125
  solving code-page problems when accessing Performance Warehouse 123

U
  updates xii
  user exit, exception processing 63

W
  water marks
    Statistics 31
  Web browser settings, specifying 14
  where to find information xii
Readers’ Comments — We'd Like to Hear from You

IBM Tivoli OMEGAMON XE for DB2 Performance Expert on z/OS
IBM Tivoli OMEGAMON XE for DB2 Performance Monitor on z/OS
Monitoring Performance from
Performance Expert Client
Version 5.4.0

Publication No. SH12-7069-00

We appreciate your comments about this publication. Please comment on specific errors or omissions, accuracy, organization, subject matter, or completeness of this book. The comments you send should pertain to only the information in this manual or product and the way in which the information is presented.

For technical questions and information about products and prices, please contact your IBM branch office, your IBM business partner, or your authorized remarketer.

When you send comments to IBM, you grant IBM a nonexclusive right to use or distribute your comments in any way it believes appropriate without incurring any obligation to you. IBM or any other organizations will only use the personal information that you supply to contact you about the issues that you state on this form.

Comments:

Thank you for your support.
Send your comments to the address on the reverse side of this form.
If you would like a response from IBM, please fill in the following information:

Name

Address

Company or Organization

Phone No.

Email address
Readers’ Comments — We’d Like to Hear from You

IBM Deutschland Research & Development GmbH
IBM Analytics, Platform
Dept. 0606
Schoenaicher Strasse 220
71032 Boeblingen
Germany
Product Number: 5655-W37
5655-W38