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About this information
This information contains details about the DataQuant for Workstation and
DataQuant for WebSphere® Administrator applications. 1 The information includes
instructions for:
v Installing DataQuant for Workstation applications
v Installing DataQuant for WebSphere applications
v Using DataQuant for Workstation Administrator to configure a repository
v Using DataQuant for WebSphere Administrator to configure a repository
v Setting up resource limits to control resource usage
Specific changes since the previous edition of this book are indicated by a vertical
bar (|) to the left of a change. Editorial changes that have no technical significance
are not noted.
Always check the DB2® and IMS™ Tools Library page for the most current version
of this publication:
www.ibm.com/software/data/db2imstools/db2tools-library.html

Who should read this information
This information is intended for all DataQuant for Workstation or DataQuant for
WebSphere users.
This information is intended for the person that is responsible for configuring and
maintaining the DataQuant query and reporting tool set, which consists of the
following applications:
v DataQuant for Workstation
v DataQuant for Workstation Administrator
v DataQuant for WebSphere
v DataQuant for WebSphere Administrator
This information is not intended for users.

Service updates and support information
To find service updates and support information, including software fix packs,
PTFs, Frequently Asked Questions (FAQs), technical notes, troubleshooting
information, and downloads, refer to the following web page:
http://www.ibm.com/support/entry/portal/Overview/Software/
Information_Management/DB2_Tools_for_z~OS

Highlighting conventions
This information uses the following highlighting conventions:

1. Throughout this information, the IBM® DataQuant client for WebSphere Application Server is referred to as DataQuant for
WebSphere and the IBM DataQuant client for the workstation environment is referred to as DataQuant for Workstation.
© Copyright IBM Corp. 1995, 2015
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v Boldface type indicates commands or user interface controls such as names of
fields, folders, icons, or menu choices.
v Monospace type indicates examples of text that you enter exactly as shown.
v Italic indicates the titles of other publications or emphasis on significant terms. It
is also used to indicate variables that you should replace with a value.

How to look up message explanations
You can use any of the following methods to search for messages and codes.

Searching an information center
In the search box that is in the upper left toolbar of any Eclipse help system, such
as the http://pic.dhe.ibm.com/infocenter/dzichelp/v2r2/index.jsp , enter the
number of the message that you want to locate. For example, you can enter
DFS1065A in the search field.
Use the following tips to help you improve your message searches:
v You can search for information about codes by entering the code; for example,
enter -327.
v Enter the complete or partial message number. You can use wildcards in the
message number to broaden your search; use * to represent multiple characters
and use ? to represent any single character. For example:
– The search string DFS20?I returns any messages that begin with the string
DFS20, followed by any single character, followed by I.
– The search string DFS20??I returns any messages that begin with the string
DFS20, followed by any two characters, followed by I.
– The search string DFS20*I returns any messages that begin with the string
DFS20, followed by any number and type of characters, followed by I.
The information center contains the latest message information for all of the
information management products that are included in the information center.

Using a web search engine
You can use any of the popular search engines that are available on the web to
search for message explanations. When you type the specific message number or
code into the search engine, you are presented with links to the message
information in IBM information centers.

How to send your comments
Your feedback is important in helping to provide the most accurate and
high-quality information. If you have any comments about this book or any other
documentation, use either of the following options:
v Use the online reader comment form, which is located at:
http://www.ibm.com/software/data/rcf
v Send your comments by e-mail to comments@us.ibm.com. Be sure to include the
name of the book, the part number of the book, the version of your product,
and, if applicable, the specific location of the text you are commenting on (for
example, a page number or table number).
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Chapter 1. Planning to install
Before you install DataQuant, review the system requirements and understand the
differences between DataQuant for Workstation and DataQuant for WebSphere.

Overview
DataQuant for Workstation Administrator and DataQuant for WebSphere
Administrator are both part of the IBM DataQuant for z/OS® and IBM DataQuant
for Multiplatforms query and reporting tool set for IBM's DB2 relational database
management system.
These two administrative applications are used to configure and manage the query
environment for the following applications:
v DataQuant for Workstation which is an Eclipse-based2, rich client desktop
application, that provides querying, reporting and Business Intelligence (BI)
solution development and execution capabilities.
v DataQuant for WebSphere which is a Java-based Web application that delivers a
substantial subset of the DataQuant for Workstation capabilities using a pure
HTML, thin-client deployment model. DataQuant for WebSphere is capable of
running on a variety of operating systems, delivering this thin-client,
HTML-based experience to users via a variety of web browsers across a number
of platforms.

Managing the query environment
The DataQuant for Workstation Administrator and the DataQuant for WebSphere
Administrator applications are used to perform the administrative tasks that enable
the users of the DataQuant for Workstation and DataQuant for WebSphere
applications to access data.
The tasks the administrator might perform are as follows:
v Configuring JDBC drivers
v Creating repositories
v Connecting to repositories
v Configuring data source information
v Setting up resource limits to control resource consumption and user actions
v Monitoring the performance of your query environment
In most instances, a single user is responsible for performing the necessary
administrative tasks for DataQuant for Workstation and DataQuant for WebSphere
users. The DataQuant administrator can choose to perform the administrative tasks
using DataQuant for Workstation Administrator or DataQuant for WebSphere
Administrator.
2. Eclipse is an open source community whose projects are focused on providing an extensible development platform and
application frameworks for building software. Eclipse provides extensible tools and frameworks that span the software
development lifecycle, including support for modeling, language development environments for Java™, C/C++, PHP and others,
testing and performance, business intelligence, rich client applications and embedded development. A large, vibrant ecosystem of
major technology vendors, innovative start-ups, universities and research institutions and individuals extend, complement and
support the Eclipse Platform. The Eclipse Foundation is a not-for-profit, member supported corporation that hosts the Eclipse
projects. Full details of Eclipse and the Eclipse Foundation are available at www.eclipse.org.
© Copyright IBM Corp. 1995, 2015
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Administrators can configure every feature that is available in the application
using DataQuant for Workstation Administrator. Administrators can configure the
most widely used feature set using DataQuant for WebSphere Administrator. There
are some features that cannot be configured using DataQuant for WebSphere
Administrator.

DataQuant for Workstation system requirements
Before installing DataQuant for Workstation ensure that your environment meets
the following minimum requirements.

Hardware requirements
Each workstation on which DataQuant for Workstation runs should accommodate
the following minimum requirements:
v Network connectivity
v Approximately 1 GB of disk space (single language installation)
v Minimum of 1 GB of RAM

Software requirements
DataQuant for Workstation can run on any of the following operating systems:
v Microsoft Windows Server 2003
v Microsoft Windows Server 2008
v Microsoft Windows Server 2012
v Microsoft Windows Vista
v Microsoft Windows 7
v Microsoft Windows 8
v Microsoft Windows 8.1
v Red Hat Enterprise Linux WS 5 and 6
v SUSE Linux10, 11, and 12
v Mac OS X V10.5 , V10.6, V10.7, and V10.8
Note: For Linux x64, 32-bit GUI libraries are required.
The following functions require additional support:
v Adobe Flash Player 10.1.51 or later on the client (required if deploying visual
dashboards using the optional Flash output format)
v Database connectivity requires an appropriate JDBC driver for each type of
RDBMS accessed.
v DataQuant for z/OS requires a QMF™ Enterprise Edition Version 8 (5625-DB2),
Version 9 (5635-DB2) or Version 10 (5605-DB2) license in order to both access
QMF objects and enable the QMF interoperability features described in this
information.
v DB2 QMF Version 11
v For proper rendering of a visual project in the HTML5 mode make sure that you
have Microsoft Internet Explorer V9.0 or later installed on the workstation.
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Database servers (subject to license restrictions)
DataQuant for Workstation supports the following database servers:
v DB2 V11.x for z/OS VUE
v DB2 V10.x for z/OS VUE
v DB2 V9.x for z/OS VUE
v DB2 V11.x for z/OS
v DB2 V10.x for z/OS
v DB2 V9.x for z/OS
v DB2 for iSeries V5.4, V6.1, and V7.1
v DB2 for Linux, UNIX, and Windows V9.x or higher
v Informix® Dynamic Server (IDS) Version 9.x, 10.x, and V11.x
v Model 204 V7R1 for z/OS
v Model 204 V7R1 for z/VM®
*z/OS, OS/390®, and VSE & VM support is limited to DataQuant for z/OS.

Prerequisites
The following DataQuant for Workstation functions have software dependencies:
v Database connectivity requires an appropriate JDBC driver for each type of
RDBMS that is accessed.
v DataQuant for Workstation OLAP support requires InfoSphere® Warehouse
V9.5.2 or later or other MDX-based OLAP servers with support for XMLA
connectivity.
v DataQuant for z/OS requires a QMF Enterprise Edition Version 8 (5625-DB2),
Version 9 (5635-DB2) or Version 10 (5605-DB2) license in order to both access
QMF objects and enable the QMF interoperability features described in this
information.
v Exporting result sets to Microsoft Excel requires a minimum level of Excel 2003.
If you are running a pre-2003 version of Microsoft Excel, the Export to Excel
feature is not supported.

DataQuant for WebSphere system requirements
Before installing DataQuant for WebSphere, ensure that your environment meets
the following minimum requirements.

Hardware requirements
DataQuant for WebSphere requires 500 MB hard disk space and 1 GB of RAM.
50 MB RAM per user is the minimum requirement, accessing DataQuant for
WebSphere.

Software requirements
DataQuant for WebSphere has the following software requirements:
v One of the following application servers:

Chapter 1. Planning to install
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v
v
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– WebSphere Application Server Versions 6.1, WebSphere Application Server V7
or WebSphere Application Server V8 on any platform supported by
WebSphere Application Server.
– Apache Tomcat V5.5 and later
One of the following Web browsers (with JavaScript support enabled) on each
client:
– Microsoft Internet Explorer V7.0 or later
– Mozilla Firefox V40.0 or later
– Apple Safari browser V5.1 or later
– Google Chrome browser V44.0 or later
Java Runtime Environment (JRE) V1.6 or later
Adobe Flash Player 10.1.51 or later on the client .
Required if deploying dashboards that use the optional Flash output format.
An appropriate JDBC driver for each type of database that you want to access
DataQuant for z/OS requires a QMF Enterprise Edition Version 8 (5625-DB2) or
Version 9 (5635-DB2) license in order to both access QMF objects and enable the
QMF interoperability features described in this information.

The following Web browsers support the HTML5 renderer in visual projects:
v Microsoft Internet Explorer V9.0 or later
v Mozilla Firefox V18.0 or later
v Google Chrome browser V24.0 or later
v Apple Safari browser V6.1 or later

Database servers (subject to license restrictions)
DataQuant for WebSphere supports any database that provides a JDBC driver.
DataQuant for WebSphere supports the following database servers:
v DB2 V11 for z/OS VUE
v DB2 V10 for z/OS VUE
v DB2 V9 for z/OS VUE
v DB2 V11 for z/OS
v DB2 V10 for z/OS
v DB2 V9 for z/OS
v DB2 Server for VSE and VM V7.3 and V7.4
v DB2 for iSeries V5.4, V6.1, and V7.1
v DB2 for Linux, UNIX, and Windows V9.5 or higher
v Informix Dynamic Server (IDS) Version 9.x, 10, V11, and V12
v Model 204 V7R1 for z/OS
v Model 204 V7R1 for z/VM
*z/OS, OS/390, and VSE & VM support is limited to DataQuant for z/OS.

Prerequisites
The following DataQuant for WebSphere functions have software dependencies:
v Database connectivity requires an appropriate JDBC driver for each type of
RDBMS that is accessed.
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v DataQuant for WebSphere OLAP support requires InfoSphere Warehouse V9.5.2
or later, or other MDX-based OLAP servers with support for XMLA connectivity.
v IBM DataQuant for z/OS requires a QMF Enterprise Edition Version 8 license
(5625-DB2), or Version 9 license (5635-DB2) in order to both access QMF objects
and enable the QMF interoperability features described in this information.
v Exporting result sets to Excel requires a minimum level of Excel 2003.
If you are running a pre-2003 version of Excel, the Export to Excel feature is not
supported.

iSeries terminology
DataQuant for Workstation and DataQuant for WebSphere use SQL terminology,
which, in some cases, is different than iSeries terminology.
The following table lists iSeries system terms and corresponding SQL relational
database terms. For more information, refer to DB2 for iSeries Database Programming.
Table 1. Mapping between iSeries and SQL terminology
iSeries term

SQL term

Library: Groups related objects and
allows you to find objects by name.

Collection: Consists of a library, journal, journal
receiver, SQL catalog, and, optionally, a data
dictionary. A collection groups related objects
and allows you to find the objects by name.

Physical file: A set of records.

Table: A set of columns and rows.

Record: A set of fields.

Row: The horizontal part of a table containing a
serial set of columns.

Field: One or more characters of related
information of one data type.

Column: The vertical part of a table of one data
type.

Logical file: A subset of fields and
records of one or more physical files.

Package: An object type that is used to run SQL
statements.

User profile

Authorization name or authorization ID

Chapter 1. Planning to install
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Chapter 2. Installing DataQuant
Installing DataQuant involves running the setup executable file to install the
DataQuant for Workstation and, optionally, deploying DataQuant for WebSphere to
an application server.
Note: To check the installation results, see the installation log file in the temporary
folder of the user home directory.

Setup executable
DataQuant for Workstation is implemented as a high performance, Eclipse-based
desktop application, combining the portability of Java with the performance of
native applications.
The following table lists the DataQuant for Workstation setup executable file and
supported operating systems:
A self-contained installation package is available for each of the following
supported platforms:
Table 2. Platforms, versions, and executable files supported by DataQuant for Workstation
Operating system

Version

Setup executable file

Windows

XP, 2003, 2008, Vista, 7

setupwin32.exe

Macintosh

10.5 and 10.6

setupMac.zip
Note: The Mac OS X installer is
packaged inside the archive.

Red Hat Linux

WS Versions 5 and 6
Enterprise

setupLinux.bin

SUSE Linux

Versions 10 and 11

setupLinux.bin

Installing DataQuant for Workstation
To install DataQuant for Workstation, run the appropriate setup executable on the
target operating system and follow the installation prompts. Upon completion of
the installation, it is recommended that you apply the latest available fix packs.

About this task
This topic describes how to run the setup process to install DataQuant. It assumes
you have downloaded the DataQuant setup executable file to your computer. It
provides information about the properties and values you can set during the
installation process.
During installation you will specify license information and where to install the
product. You will also select which the feature set (Administrator, User or both) to
install.
You can stop the installation at time by clicking Cancel.

© Copyright IBM Corp. 1995, 2015
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Procedure
1. Go to the directory where you have downloaded setup executable file.
2. Run the setup executable file to begin the installation. The installer program
prepares the product for installation.
3. On the Introduction panel, read the recommendations and description of the
installation process and click Next.
4. On the License Agreement panel, read the licensing terms and select I accept
the terms of the License Agreement to proceed with the installation. Click
Next.
Note: If you select I do not accept the terms in the license agreement, the
installation process stops.
5. If you are installing DataQuant for Workstation for z/OS and you want to
grant users the ability to interoperate with existing QMF objects and
infrastructure, you must specify the path to your QMF Enterprise Edition V8,
V9 or V10 license. If you do not want to install this feature you will leave this
field blank. The license files (host.lic for V8 or workstation-zSeries.lic for
V9 and V10) can be found in the directory where QMF Enterprise Edition was
installed.
6. On the Choose Install Folder panel, select Choose to specify the directory
where DataQuant will be installed or accept the default destination. Click Next.
v Select Typical if you want to install the workstation application, all of its
components and features and download the DataQuant for WebSphere
application files.
For a description of the applications, components, and features, see
DataQuant applications, components, and features.
v If you want to install particular components, select Custom and choose from
the applications, components, and features listed in the panel beneath the
Install Set field.
If you selected specific applications and components to install and you then
want to revert to the options of typical installation, select Typical from the
Install Set drop-down list.
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Table 3. DataQuant applications, components, and features
Application

Components and features

Description

DataQuant for Workstation

v DataQuant for Workstation DataQuant for Workstation
includes a User component
User.
and an Administrator
v DataQuant for Workstation
component.
Administrator
v Support for OLAP and
XMLA data sources
Select this feature to
download the files that
will allow users to create
and edit multidimensional
queries.
v Support for Virtual Data
Sources
Select this feature to
download the files that
will allow administrators
to create and edit virtual
data sources.
v Support for Data Source
Environments
Select this feature to
download the files that
will allow administrators
to create and edit Data
Source Environments.
v Translated Help Systems
Select the help systems
that you want to install in
addition to the English
help system

Select the component that
suits your role and the
manner in which you will
use the application. For
example,
v Select the
DataQuant for
Workstation User
component if your
intention is use the
application on your own
personal workstation.
v Select the
DataQuant for
Workstation Administrator
component if your
intention is to create
product configuration that
will be made available to
multiple users across the
enterprise and to
administer that
configuration on behalf of
the enterprise users.
Administrators use this
component to grant user
access to repositories and
define resource limits. It
should be installed only
for those users who will
be allowed to perform
these tasks.

Application

Components and features

Description

DataQuant for WebSphere

A Typical installation
includes both DataQuant for
Workstation and DataQuant
for WebSphere. However,
you can choose to install
only DataQuant for
WebSphere.

If you select this option,
DataQuant for WebSphere (in
a EAR file)DataQuant for
WebSphere is downloaded to
a folder labeled DataQuant
for WebSphere in the
directory where you have
chosen to install DataQuant
for Workstation.

Chapter 2. Installing DataQuant
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Application

Components and features

Description

Web Service

Select this component to
install the files necessary to
set up the web service
interface for DataQuant for
WebSphere.

Web-based connectivity
permits users to access a
shared repository without
the need for direct database
connectivity from the
workstation. Connecting to
repositories using a
web-based connection allows
for consolidation of data
access at a central server and
removes the need to
distribute JDBC drivers
across each desktop running
DataQuant for Workstation
This is only needed if
developing or running
independent applications
that will use the web service
APIs.

7. Select where to create product icons and click Next.
8. On the Pre-Installation Summary panel, review the summary information.
v If you want to make changes, click Previous until you reach the panel that
contains values that you want to change.
v If you are satisfied with your selections, click Install and complete the
installation.

Results
You have successfully installed DataQuant
If you selected DataQuant for WebSphere from the installation wizard, you can
deploy DataQuant for WebSphere to the application server.
After completing the install successfully, you are ready to configure the product for
use.

Installing a fix pack
This topic describes how install a fix pack of the DataQuant for Workstation
application.

About this task
You use the same steps to install a fix pack as you do to install the original
application. The application must not be uninstalled before the new fix pack can be
introduced. When the fix pack executable file is run, the existing installation of
DataQuant for Workstation is automatically updated. For specific steps, see
“Installing DataQuant for Workstation” on page 7.
Note: Depending on the fix pack, if you implement repository or QMF catalog
protection using static SQL packages, it might be necessary to rebind them. When
you download the fix pack executable, check the accompanying readme file for
steps on how to rebind your existing static SQL packages.
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Uninstalling DataQuant for Workstation
To uninstall DataQuant for Workstation use the add or remove program facility of
your operating system .
If you do not plan on reinstalling DataQuant for Workstation, you must delete all
repository storage before you uninstall the product. To delete repository storage
using DataQuant for Workstation Administrator, right-click the repository storage
in the Repositories view and select Delete Repository Storage from the pop-up
menu.
Note: You should only delete repository storage if you no longer want to retain
the DataQuant objects that are stored in the repository storage.
The following table lists ways to uninstall DataQuant for Workstation.
Table 4. Methods for uninstalling DataQuant for Workstation
Method

Procedure

Run the uninstaller manually

Go to the uninstaller and run it.
The uninstaller is located in the _uninst folder of the
directory in which you installed DataQuant for
Workstation.

Uninstall from the Start menu

Available for Windows installation only
If you chose to add the program icon to the Start menu
when you installed DataQuant for Workstation, you can
run the uninstaller from the Start menu. For example,
on a Windows operating system select Start >
DataQuant > Uninstall.

Uninstall from the Control Panel

Available only for Windows installation only
Use the Control Panel function to uninstall DataQuant
for Workstation.

Reverting to an earlier fix pack
This topic describes how to revert to a previous fix pack of the DataQuant for
Workstation application.

About this task
If it is necessary to revert back to a previous fix pack, the same steps that you use
to install a new fix pack apply. The existing installation does not have to be
uninstalled. When the fix pack executable is run, the existing installation of
DataQuant for Workstation is automatically updated. For specific steps, see
“Installing DataQuant for Workstation” on page 7.
Note: As with installing a new fix pack, if you implement repository or QMF
catalog protection using static SQL packages, it might be necessary to rebind them.
When you download the fix pack executable, check the accompanying readme file
for steps on how to rebind your existing static SQL packages.
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Deploying DataQuant for WebSphere to the application server
The installation media includes an Enterprise Archive (EAR) file and a Web
Archive (WAR) file that can be immediately deployed to your web application
server using your server's administration console.

Obtaining the DataQuant for WebSphere installation file
The DataQuant for Workstation installation media includes the files that are used
to install DataQuant for WebSphere.
The files are the DataQuant for WebSphere Enterprise Archive (EAR) file and the
DataQuant for WebSphere Web Archive (WAR) file. You must run the DataQuant
for Workstation installation package to obtain access to these files. To download
the files during installation, select the DataQuant for WebSphere feature. The files
are placed in a folder labeled DataQuant for WebSphere in the directory where you
have chosen to install DataQuant for Workstation. You can keep the files local or
copy them to a WAS server machine.

Opening the WebSphere Administrative Console
Start the WebSphere Administrative Console by opening a web browser on a client
machine, and entering the appropriate URL.
By default, the URL is http://host:port/ibm/console, where host is the host name
of the WAS server and port is the port on which the Administrative Console is
configured to listen (9060, by default).

Installing the new application
Follow this procedure to install the new application.

About this task
In the navigation tree on the left side of the Administrative Console window:

Procedure
1. Expand Applications.
2. Click Install New Application. The Preparing for the application installation
page displays on the right side of the Administrative Console window.
3. On the first Preparing for the application installation page, specify the location
of the DataQuant for WebSphere EAR file that you want to install.
v If the DataQuant for WebSphere EAR file is on the local machine, click
Local file system. Use the Browse button to search for and locate the file.
v If the file is on the WAS server machine, click Remote file system. Use the
Browse button to search for and locate the file.
4. When you install using the DataQuant for WebSphere EAR file, the default
context root for the application is always DQWebSphere12. If for some reason
you need to specify an alternate context root for the application, you must use
the DataQuant for WebSphere WAR file for installation, enter the alternate
context root in the Context root field, and follow the prompts to complete the
installation.
5. Click Next. The second Preparing for the application installation page opens.
6. Click Generate Default Bindings.
7. Click Next. The Step 1: Select Installation options page opens.
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8. Verify that the Deploy Web Services check box is clear and click Next. The
Step 2: Map modules to servers page opens.
9. Accept the default values and click Next. The Step 3: Map virtual hosts for
Web modules page opens.
10. Note the name of the application server listed for the DataQuant for
WebSphere module and click Next. The Step 4: Map security roles to
users/groups page opens.
11. Specify whether you will map a security role named dqadmin for the
DataQuant for WebSphere application. If you have WebSphere security
enabled, you must map at least one user ID to this role. The dqadmin role is
used to authenticate a user before performing various administrative tasks in
DataQuant for WebSphere, such as binding packages. Use this page to specify
whether the role should be mapped to all users (effectively eliminating
authentication for the role), to all authenticated users (allowing any
authenticated user to perform DataQuant administration functions), or only to
users or groups that you specify.
12. Click Next.
13. Review the summary page that lists the options that you have chosen and
click Finish.
14. After WAS has finished installing the application, save the configuration. You
will receive a message dialog informing you of the progress of the installation
and that the installation of the application is complete. The Enterprise
Applications page opens.
15. Click Save to Master Configuration and click Save.

Configuring access to JDBC drivers
The last element of configuration that you must perform using the WebSphere
Administrative Console is to provide access to any JDBC drivers that will be used
by DataQuant for WebSphere.

About this task
In the navigation tree on the left side of the Administrative Console window:

Procedure
1. Expand Servers.
2. Click Application Servers. The Application Servers page displays on the right
side of the Administrative Console window.
3. In the displayed list of application servers, click the application server where
you installed the DataQuant for WebSphere application. The properties of the
application server are displayed.
4. Under Server Infrastructure expand JAVA and Process Management. and
click Process Definition. The Process Definition page displays.
5. For z/OS, in the ProcessType list, click Servant. The Process Definition page
displays.
6. In the Additional Properties list, click Java Virtual Machine. The Java Virtual
Machine page displays.
7. In the Classpath list, add all of the *.zip or *.jar files that are required by the
JDBC drivers that will be used by DataQuant for WebSphere. For example, for
the DB2 Universal Database™ V8 Type 4 driver on Microsoft Windows, you
might enter:

Chapter 2. Installing DataQuant
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C:\Program Files\ibm\SQLLib\Java\db2jcc.jar
C:\Program Files\ibm\SQLLib\Java\db2java.zip
C:\Program Files\ibm\SQLLib\Java\sqlj.zip

For the Type 4 driver on z/OS you might enter:
/usr/lpp/db2810/jcc/classes/db2jcc.jar
/usr/lpp/db2810/jcc/classes/db2jcc_license_cisuz.jar
/usr/lpp/db2810/jcc/classes/db2jcc_javax.jar
/usr/lpp/db2810/jcc/classes/sqlj.zip

8. For non-z/OS platforms, you can skip to Step 11. For z/OS, you must specify
a list of directories that contain the native code libraries used by the JDBC
driver. Return to Servers and select Custom Properties from the Additional
Properties list. The Custom Properties page displays.
9. Click the New button. The Configuration page opens.
10. In the General Properties list, specify the library path name in the Name
field as LIBPATH and specify the directories list in the Value field. For example,
in the Value field you might specify:
/usr/lpp/db2810/lib
/usr/lpp/db2810/jcc/lib

11. When you have finished adding the required files, click OK and save the
configuration. After the configuration is saved, you must restart the server for
the changes to take effect.

Customizing Java Virtual Machine system properties and files
You can specify Java Virtual Machine system properties and files for saving the
DataQuant system properties and files, especially when you configure a cluster to
share application settings and other folders among cluster nodes and to set a
timeout for a user session.

About this task
By default, all DataQuant system properties and files are stored in the user home
directory, the path to which is in the user.home Java Virtual Machine system
property. But you can use dataquant.instance.area.global,
dataquant.instance.area.shared, or dataquant.instance.area Java Virtual
Machine system properties to customize the directories for storing files.
If you want to specify a timeout for a user session to close the session when a user
do not work with application, use the dataquant.use.session.timeout parameter.
The following table describes the available parameters.
Table 5. Java Virtual Machine parameters
Parameter

Description

dataquant.instance.area.global This property is responsible for
the folder that is distributed
among several cluster nodes. It
is used to store server
configuration files, scheduled
tasks, and personal repositories.
If this parameter is not set, the
settings from the
dataquant.instance.area are
applied.
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Stored files
v Repository connections data
(repositories.xml)
v JDBC drivers properties
(.bi.jdbc.drivers)
v License files
v Cache files

Table 5. Java Virtual Machine parameters (continued)
Parameter

Description

Stored files

dataquant.instance.area.shared This property is responsible for
the application folder that is
shared among several cluster
nodes. If this parameter is not
set, the settings from the
dataquant.instance.area are
applied.

v Log files
v Session data:
– User settings
– User global variables
– Logins and passwords

dataquant.instance.area

This property is responsible for
v Temporary files
storing temporary files. If this
parameter is not set, the settings
from the java.io.tmpdir Java
Virtual Machine system property
are applied.

dataquant.use.session.timeout

This property is responsible for
the timeout of a user session. If
it is set to true, the user session
is closed after the HTTP session
timeout that is specified on the
server. If this parameter is set to
false or not defined, the session
is active until the user closes the
application.

-

To specify particular paths for saving system properties and files:

Procedure
1. For DataQuant for Workstation
a. In the application installation directory, open the eclipse.ini file.
b. Add the parameters the value of that you want to customize with the -D
prefix and specify the path for the new storage. For example,
-Ddataquant.instance.area=C:\work\
c. Save the eclipse.ini file.
2. For DataQuant for WebSphere:
a. Start the WebSphere Administrative Console by opening a web browser on
a client machine, and entering the appropriate URL.
b. Navigate to the Process definition and, in the Custom properties for Java
Virtual Machine, add the required properties
dataquant.instance.area.global, dataquant.instance.area.shared,
dataquant.instance.area, or dataquant.use.session.timeout depending on
the parameters that you want to modify.
c. Save the added parameters.

Starting the application
Follow this procedure to start the new application.

About this task
In the navigation tree on the left side of the Administrative Console window:

Procedure
1. Expand Applications.
2. Click Enterprise Applications. The Enterprise Applications page displays on
the right side of the Administrative Console window.
Chapter 2. Installing DataQuant
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3. In the displayed list of installed applications, select the check box next to
DataQuant for WebSphere.
4. Click Start. The application is now available.

Accessing the application
Upon completion, you should be able to access DataQuant for WebSphere using
one of the following URLs (assuming the use of the suggested context root of
DQWebSphere12)
URL to launch DataQuant for WebSphere application:
http(s)://[server]:[port]/[ContextRoot]/user
For example: http://www.ibm.com:9080/DQWebSphere12/user
URL to launch DataQuant for WebSphere Administrator application:
http(s)//:[server]:[port]/[ContextRoot]/admin
For example: http://www.ibm.com:9080/DQWebSphere12/admin

Completing the installation
The final steps to installing DataQuant for WebSphere are to set up JDBC driver
library information, configure repositories, and set up repository connection
information. In addition, if this instance of DataQuant for WebSphere is for z/OS
and you want users to access QMF objects, you must specify where to find the
QMF Enterprise Edition Version 8, Version 9 or Version 10 license.

About this task
The DataQuant for WebSphere administrator is virtually identical to the DataQuant
for Workstation administrator. However, if you have installed DataQuant for
WebSphere on the same system as DataQuant for Workstation, the two applications
have different configuration files (located in the user's Application Data folder).
You must take direct action to register JDBC drivers and define repositories for
both DataQuant for Workstation and DataQuant for WebSphere.
You can configure your new installation of DataQuant for WebSphere in two ways:

Procedure
1. Use the DataQuant for WebSphere application to configure drivers and
repositories. (See Chapter 3, “Configuring the environment,” on page 17 for
more information).
2. Configure the drivers and repositories using DataQuant for Workstation and
then copy the .bi.jdbc.drivers and repositories.xml files from the application data
location on the workstation to the equivalent application data location on the
web server.
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Chapter 3. Configuring the environment
Configuring the environment for DataQuant for Workstation and DataQuant for
WebSphere involves a number of administrative steps.
This chapter provides an overview of the administrative tasks. It is intended to
provide you with an understanding of the broad concepts before you configure the
environment. The administrative tasks include:
1. Setting up the connection data needed to access the relational data sources in
your enterprise:
v Providing the location of the JDBC driver files that will be used to access the
relational data sources in your enterprise
v Creating a direct connection using DRDA®
2. Creating a repository within which data source definitions and authored
content will reside
3. Defining the means by which users will connect to your repository, thereby
gaining access to your configured data sources and DataQuant content.

Configuring JDBC Drivers
DataQuant for Workstation and DataQuant for WebSphere use JDBC drivers to
connect to relational data sources. The product is already preloaded with the
configuration information for each of the popular JDBC drivers (DB2, Informix,
Oracle, MySQL, SQL Server, Derby). However, the product does not include the
actual JDBC driver files. Administrators must define the location of the JDBC
driver files in order for DataQuant for Workstation and DataQuant for WebSphere
to load and use the driver. You only need to define the location of the driver files
for those database types that you intend to access using the DataQuant products.
Using DRDA to connect to relational data sources: Depending on your
environment, you can use DRDA to connect directly to relational data sources.

Defining a repository
Prior versions of DataQuant for Workstation and DataQuant for WebSphere
utilized a Server Definitions File (SDF) to store the location of data sources
accessible within the DataQuant products. In recent releases, the SDF has been
replaced by a content repository. The repository offers the following key
improvements over the older SDF approach:
v The repository is not limited to storing data source (server) definitions. It is
capable of storing all content created within the DataQuant products, including
queries, forms, reports, dashboards, result sets and scheduled jobs. This is
particularly useful when creating content that executes against non-DB2 data
sources, where storage within a DataQuant catalog is not appropriate.
v The repository has the ability to tailor the environment of a given DataQuant
user. For example, queries, reports and dashboards can be routed to use
US-based data sources for North American users and European data sources for
European users. This mapping of data sources is done dynamically, without the
need to change the underlying DataQuant objects.
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v Similarly, the repository has the ability to tailor the presentation of DataQuant
objects on a per user or regional basis. Business users can be presented with a
set of folders arranged in business terms whereas technical users may retain a
database-centric tree of available objects.
Repositories are stored within a relational database of your choosing. Similar to a
DataQuant catalog, they consist of a set of tables, accessible via stored procedures
or static SQL packages. You may choose to place the repository tables in the same
database as your production data or within a stand alone database created
specifically for repository use. The repository is essentially a structured form of the
SDF file, with additional capabilities. As such, it can be adequately served by a
distributed database such as DB2 on LUW, Informix, Oracle, SQL Server or
MySQL.
Repositories can also be given an optional security model. If you elect to use
repository security, you have the additional ability to control the repository content
on a per user and group basis. For example, users in group A may see data sources
A, B and C whereas users in group B see data sources A, D and E. Permissions can
be applied to all DataQuant objects, including queries, forms, procedures,
dashboards and individual workspace folders.
If you elect to use repository security, you may use one of the following methods:
v LDAP/Active Directory: DataQuant uses an external Active Directory or
LDAP-based service to authenticate the user and obtain the user and group
listings.
v Database security: DataQuant uses the user's database logon as the basis of the
security model. This approach is equivalent to the DataQuant catalog security
model.
v Internal security: Users and groups can be defined directly within DataQuant
itself.
DataQuant also supports personal repositories. A personal repository is stored
within the DataQuant built-in database engine. This type of repository is intended
for individual use, providing a means of storing content on a local workstation
without the need for a relational database.

Defining the means by which users connect to your repository
Once your repository has been created, your final step involves creating the
connection information that DataQuant for Workstation and DataQuant for
WebSphere will use to connect to the repository. Once this connection has been
defined, you are ready to distribute the configuration information with the
installation of DataQuant for Workstation. users that install the product will then
be immediately connected to your repository when they open the software.

Distributing your configuration settings with the installation
program
Once you have finished configuring your environment , you are ready to make it
available to your users. Your final steps include:
1. Defining the data sources in the repository that will be accessible to DataQuant
users.
2. Distributing the configuration information with the setup program.
3. Copying the configuration information to DataQuant for WebSphere.
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“Creating the JDBC driver configuration file” on page 29
If you are using JDBC to connect to the database repositories and data sources,
you must specify where DataQuant will find the JDBC driver files for each type
of database that will host a repository or be accessed as a data source.
“Using DRDA to connect to database repositories and data sources” on page 31
You can use the Direct DRDA Connection to establish a connection to DB2
database repositories and data sources.
“Creating a shared repository storage” on page 32
A shared repository storage is a set of database tables. You must create a shared
repository storage for storing database connection and resource limit
information, as well as the database objects that users will use for reporting and
querying actions.
“Adding repositories to the repository storage tables” on page 39
You can add repositories to the repository storage tables. Repositories serve as a
centralized place in which an aggregation of data, such as queries, procedures,
forms, dashboards, and, reports are developed for a specific set of data sources.
Each repository that you create can have its own independent objects, security
models, and users.
“Defining a connection to the database” on page 48
As an administrator, you create a data source to provide DataQuant with the
information it needs to connect to a database.
“Creating the repository connection for DataQuant” on page 78
DataQuant needs to know how to access the application data (as grouped by
the repository name) so that end-users will have access to this data. The way to
provide this connection data to DataQuant is to create it using the DataQuant
connection wizard.
“Exporting the configuration data to users” on page 92
DataQuant administrators are responsible for ensuring that a QMF
interoperability license (if required), the application executable, the JDBC JAR
files, a populated JDBC driver information file, and a populated repository
connection information file are available to each machine that is running
DataQuant for Workstation and to each server (or workstation) that is running
DataQuant for WebSphere.

Importing relational data source information from QMF for Windows
You can add relational data source information to a repository from an existing
server definition file by using the Import QMF for Windows Configuration Settings
wizard.

About this task
The Import QMF for Windows Configuration Settings wizard opens automatically
the first time you launch DataQuant for Workstation. Also you can open the
wizard by selecting File > Import > QMF for Windows Configuration Settings.
Note: Data sources in QMF for Windows Version 8.1 and QMF for WebSphere
Version 8.1 and prior were referred to as servers in the SDF.
To import the related data source information from QMF for Windows:

Procedure
1. Select the settings and preferences that you want to import on the first page of
the Import QMF for Windows Configuration Settings wizard.
Chapter 3. Configuring the environment
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2. Select Import the content of the last used server definition file, and then
select whether to add the related data source information to a new personal
repository or to the current repository. Click Next.

3.
4.

5.
6.
7.

8.

9.
10.

Note: If you are running DataQuant for Workstation for the first time, the
current repository option is not available. If you select the new personal
repository option, the repository created will have the same name as the
server definition file from which you are importing content. If a repository
with this name already exists or if the name contains restricted symbols, you
are prompted to enter a unique and valid name.
To add user authentication information and search filter settings, select Import
server-related information check box.
Specify the server definition file on the second page of the Import QMF for
Windows Configuration Settings wizard. The default path to the server
definition file is specified automatically. If the server definition file is not
located in the default path, specify the correct path in the File path field.
Select encoding type from the Encoding list. If encoding is correct, you can
view the contents of the specified file in the preview area.
If required, prepare configuration packages by selecting Bind Packages, and
then click Next.
Select the server whose settings you want to edit from the Servers Found list.
Each of the servers that are defined in the server definition file are displayed
in the list.
To modify the connection parameters to the selected server, edit the Alias,
URL and Driver fields. If you selected Bind Packages, click Next to proceed.
Otherwise, click Finish to complete the import process.
Review the list of data sources for which you want to bind packages in the
QMF Catalog table.
Specify the settings for package binding. Some settings are specified by
default. The following table lists the default values:

Table 6. Binding preferences
Preference

Default value

Collection ID for Packages

QMF11

Grant permission on packages

PUBLIC

Database username and Database
password

Authorization parameters are imported from the
selected server definition file. Note: Selecting
several data sources with different authorization
information can cause problems.

11. Click Finish and wait until the import process is complete.

QMF for Windows settings
QMF for Windows settings can be imported to DataQuant for Workstation.
The following table lists the QMF for Windows settings that you can import by
using the Import QMF for Windows Configuration Settings wizard.
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Table 7. The settings that you can import from QMF for Windows
Setting

Description

To view in QMF for
Windows

To view in DataQuant for
Workstation

Favorites

The contents of the
Favorites folder

Open Database Explorer
tree

Open Personal view

Recently used objects

The list of recently used
objects

Open Database Explorer
tree

Open Personal view and
Repository Explorer view

Global variables

The list of global variables

Select View >Global
Variables

Select View > Preferences
> Global variables

Saved join definitions

The list of joins that are
added automatically on the
basis of information about
the tables that you have
ever joined in Prompted or
Query Builder editors.

Export preferences

The settings for exporting
query result and export
report type to a file or
database.

Select Results > Save to
File or Results > Save to
Database

Select File > Export

LOB options

LOB object settings

Select View > Options >
LOBs

Select View > Preferences
> LOBs

Grid options

The default font properties, Select Results > Font and
formatting options, cell
Results > Format.
colors and other grid
settings

Select Results > Font and
Results > Format

Page setup settings

The page settings that are
used for printing

Select File > Page Setup

Select File > Page Setup

User interface settings

The user interface settings
such as language, default
font and null values
display options

Select View > Options >
General and View >
Options > Appearance

Select View > Preferences
> General and View >
Preferences > Appearance

Command bar history

The history of commands
entered in command bar

Server - related settings

User authentication
information and search
filter settings
Note: Availability depends
on the Import the content
of the last used server
definition file option.

Considerations for configuring the product and environment
There are several things to consider before configuring the product.
This section provides an overview of the administrative tasks to help you
understand of the broad concepts prior to starting the configuration process.
1. Setting up the connection data needed to access the relational data sources in
your enterprise:
v Providing the location of the JDBC driver files that will be used to access the
relational data sources in your enterprise
v Creating a direct connection using DRDA
Chapter 3. Configuring the environment
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2. Creating a repository within which data source definitions and authored
content will reside
3. Defining the means by which users will connect to your repository, thereby
gaining access to your configured data sources and DataQuant content.

Connecting to relational data sources
Using JDBC to connect to relational data sources: You can use JDBC drivers to
connect to relational data sources. The product is already preloaded with the
configuration information for each of the popular JDBC drivers (DB2, Informix,
Oracle, MySQL, SQL Server, Derby and so on). However, the product does not
include the actual JDBC driver files. Administrators must define the location of the
JDBC driver files in order for DataQuant for Workstation and DataQuant for
WebSphere to load and use the driver. You must define the location of the driver
files for those database types that you intend to access using the DataQuant
products.
Using DRDA to connect to relational data sources: Depending on your
environment, you can use DRDA to connect directly to relational data sources.

Defining a repository
Prior versions of DataQuant for Workstation and DataQuant for WebSphere
utilized a Server Definitions File (SDF) to store the location of data sources
accessible within the DataQuant products. In recent releases, the SDF has been
replaced by a content repository. The repository offers the following key
improvements over the older SDF approach:
v The repository is not limited to storing data source (server) definitions. It is
capable of storing all content created within the DataQuant products, including
queries, forms, reports, dashboards, result sets and scheduled tasks. This is
particularly useful when creating content that executes against non-DB2 data
sources, where storage within a DataQuant catalog is not appropriate.
v The repository has the ability to tailor the environment of a given DataQuant
user. For example, queries, reports and dashboards can be routed to use
US-based data sources for North American users and European data sources for
European users. This mapping of data sources is done dynamically, without the
need to change the underlying DataQuant objects.
v Similarly, the repository has the ability to tailor the presentation of DataQuant
objects on a per user or regional basis. Business users can be presented with a
set of folders arranged in business terms whereas technical users can retain a
database-centric tree of available objects.
Repositories are stored within a relational database of your choosing. Similar to a
DataQuant catalog, they consist of a set of tables, accessible via stored procedures
or static SQL packages. You can choose to place the repository tables in the same
database as your production data or within a stand alone database created
specifically for repository use. The repository is essentially a structured form of the
SDF file, with additional capabilities. As such, it can be adequately served by a
distributed database such as DB2 on LUW, Informix, Oracle, SQL Server or
MySQL.
Repositories can also be given an optional security model. If you elect to use
repository security, you have the additional ability to control the repository content
on a per user and group basis. For example, users in group A can see data sources
A, B and C whereas users in group B see data sources A, D and E. Permissions can
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be applied to all DataQuant objects, including queries, forms, procedures,
dashboards and individual workspace folders.
If you elect to use repository security, you can use one of the following methods:
v LDAP/Active Directory: DataQuant uses an external Active Directory or
LDAP-based service to authenticate the user and obtain the user and group
listings.
v Database security: DataQuant uses the user's database logon as the basis of the
security model. This approach is equivalent to the DataQuant catalog security
model.
v Internal security: Users and groups can be defined directly within DataQuant
itself.
DataQuant also supports personal repositories. A personal repository is stored
within the DataQuant built-in database engine. This type of repository is intended
for individual use, providing a means of storing content on a local workstation
without the need for a relational database.

Defining the means by which users connect to your repository
Once your repository has been created, your final step involves creating the
connection information that DataQuant for Workstation and DataQuant for
WebSphere will use to connect to the repository. Once this connection has been
defined, you are ready to distribute the configuration information with the
installation of DataQuant for Workstation. users that install the product will then
be immediately connected to your repository when they open the software.

Distributing your configuration settings with the installation
program
Once you have completed the above administration steps, your DataQuant
environment is ready for use. Your final steps include:
1. Defining the data sources in the repository that will be accessible to DataQuant
users.
2. Distributing the configuration information with the setup program.
3. Copying the configuration information to DataQuant for WebSphere.

Overview
Administrators configure DataQuant so users can access the data sources needed
to create queries, reports, and visual dashboards.
Generally, configuration tasks are performed by the Administrator from DataQuant
Administrator component. The Administrator component consists of a variety of
views, perspectives, and editors to facilitate the process. For description of the
views, perspectives, and editors, see Perspectives, Views, and Editors in the Product
overview help.
Configuring DataQuant can be divided into the following tasks:
v Setting up repositories and connecting to the database
This involves the following sub-tasks:
– Defining the JDBC driver library
– Configuring the repository storage
Chapter 3. Configuring the environment
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– Creating the repository
– Defining the connection to the database
v Populating repositories with the data sources, workspaces, and environments
that define how users interact with data and determine what is exposed to the
users in the DataQuant User component.
This involves the following sub-tasks:
– Creating virtual data sources
– Setting up workspaces
– Creating entity relationship (ER) diagrams
– Setting up environments
v Setting permissions for accessing data
This activity involves the following sub-task:
– Assigning users and groups permission to use repository objects
v Managing resources and usage
DataQuant provides administrators with the capability to optimize usage by
setting up and managing resource limits.
Managing resources and usage involves the following tasks:
– Setting up data source resource limits
– Creating resource limits groups
– Setting up group schedules
– Assigning users to resource limits groups
After configuring DataQuant, the administrator creates a repository connection,
which provides users with access to the data.

Using DataQuant for Workstation versus DataQuant for
WebSphere to create the configuration
You can configure DataQuant for multiple users by using either the DataQuant for
WebSphere Administrator component or the DataQuant for Workstation
Administrator component.
The method you choose to configure DataQuant is a matter of preference. The
following diagrams illustrate both methods.

Application Server

3

1
Start
Thin Client and
create configuration

2

Administrator

Users point
browser
to web address

Provide url address of thin
client configuration to users

Figure 1. Using DataQuant for WebSphere to configure DataQuant for multiple users

1. Start DataQuant for WebSphere in your web browser.
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Users

2. Using the Administrator component, complete the configuration steps for a
shared configuration.
3. Provide users with URL.

Application Server

3

1
Start
Thin Client and
create configuration

2

Administrator

Users point
browser
to web address

Users

Provide url address of thin
client configuration to users

Figure 2. Using DataQuant for Workstation to configure DataQuant for multiple users

1. Using the Administrator component, configure DataQuant for Workstation on
your workstation.
The result of completing the configuration steps is an updated repositories.xml
file and an updated .bi.jdbc.drivers file.
2. Put the installer executable (or silent installation options file) on a shared file
server and use the DataQuant for Workstation File > Export feature to export a
settings.xml file with the repository connection and JDBC driver information
to the shared file server.
For information about creating a response file for a silent installation, see
Creating a silent installation options file.
3. Users access the shared directory in the file server and install DataQuant for
Workstation by running the installer GUI or the silent installation.
When users run the installer, the configuration data in the settings.xml is
applied to the installed application. As a result, when users start DataQuant,
they are connected to a repository and have access to the data sources as
determined by the Administrator’s configuration.

Setting general preferences
You use the General page of the Preferences window to specify the language,
orientation direction, locale settings, and object default actions.

About this task
To specify the general user preferences for the current DataQuant application
interface session:

Procedure
1. Select View > Preferences. The Preferences window opens. Select General
from the tree.
2. Conditional: If available as an option on the Preferences window, select from
the Language drop-down list of supported languages the language that will
be used for the current application interface session. Select the value Auto to
use the local language of the current machine.
Chapter 3. Configuring the environment
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3. Select from the Direction drop-down list the orientation that will be used to
display information in the current DataQuant application interface session.
You can select Left-to-Right or Right-to-Left. You can select Auto to use the
default orientation of the current machine.
4. Select from the Locale setting for numbers, currencies, times, and dates
drop-down list the language that will be used to display numbers, currencies,
times and dates in the current DataQuant application interface session. Select
the value Auto to use the local language of the current machine.
5. Click one of the Default Action for Objects radio buttons to specify the action
that DataQuant will perform when you double-click an object that is included
in an explorer tree. Select Run object to run the object that is selected. Select
Display object to display the SQL content of the object.
6. In the Default Tab for the Query Editor area, you can specify the tab on
which the Query Editor is opened by default for a new query.
7. In the Scheduler Type area, select the scheduler that you want to use for the
scheduled tasks:
v Select the DataQuant for Workstation scheduler option to work with the
application scheduler.
v Select the Native option, to work with the operating system scheduler.
8. Click the Line width ellipsis (...) or enter the value of the maximum line
width.
The available values for line width are from 10 to 1000. The default value is
79.
This value is used in the Query menu item Reformat Text for SQL text.
Additionally, the value specified in the Line width field:
v Controls the maximal line length in the DDL scripts, which are displayed
when you create or update repository storage or QMF catalogs.
v Controls the maximal line length in the DDL scripts that are produced
when you run the Export Update Scripts wizard.
Note: The Export Update Scripts wizard provides users with the capability
to upload the DDL to a mainframe data set and run it in the z/OS
environment. Using the Line width field you can ensure the data sets meet
the limitation requirement of 72 characters per line.
9. Select the Convert rollover time check box if you want DataQuant to allow
Java to convert and express 24 hour rollover time as the next day. For
example, if you select the check box, Java converts 2012-01-01:24:00:00 to
2012-01-02:00:00:00. The converted format is displayed by DataQuant in the
result sets and visual projects.
Clear the Convert rollover time check box if you want DataQuant to preclude
Java from converting and expressing the 24 hour rollover time as the next day.
If you clear the check box, DataQuant uses the timestamp value saved in the
database.
Note: The Convert rollover time feature applies only if you are using a
DRDA connection with a DB2 database.
10. Select the Always run in background check box to perform long running
operations displayed in the Progress dialog in the background without
blocking you from doing other work.
11. Click Apply to save your preferences choices.
12. Click Restore Defaults to restore the default preference values.
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13. Click OK to close the Preferences window.

Switching DataQuant to the FIPS-140 security standard
You can switch DataQuant to the FIPS-140 computer security standard by
configuring a security provider definition.

About this task
To switch to the FIPS-140 standard:

Procedure
1. In the DataQuant installation directory, open the java.security file in edit
mode.
2. Find a list of security provider definitions by looking for the following:
security.provider.N=, where N represents a number.
3. Insert the following line to the first position of this list:
security.provider.1=com.ibm.crypto.fips.provider.IBMJCEFIPS
4. Modify the numbers for the other security provider definitions in the list. When
you open DataQuant, the application will work in FIPS-140 mode.

Configuring repositories and connecting to the database
You need to configure the repositories and define the DataQuant connection to the
database.

About this task
Repositories provide a logical grouping of DataQuant objects (queries, procedures,
visual reports, and visual dashboards) and contain the database connection
information and resource limits. Generally speaking, only administrators work
with repositories.
The tasks required to configure repositories and connect to a database vary,
depending on whether you are configuring DataQuant for yourself or for multiple
users.
If you are configuring DataQuant for multiple users, you perform the following
tasks:
1. Define the JDBC driver library
2. Configure the repository storage
3. Create a shared repository
4. Define the connection to the database
5. Create the repository connection
6. Export the configuration to the users
The tasks for configuring repositories and connecting to a database are described
in the following table:
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Table 8. Configuring repositories and connecting to a database task descriptions
Task

Purpose

Information

Defining JDBC
Driver Library

Define the location of the driver
files for the database that you
intend to access with DataQuant.

You can connect to database
repositories and data sources by
defining the JDBC driver library or
by using DRDA.
JDBC driver files are not included
with DataQuant, but DataQuant
does include the configuration data
for the most commonly used JDBC
drivers.
You need to define the JDBC driver
files so that DataQuant for
Workstation and DataQuant for
WebSphere can load and use the
driver.
See Defining the JDBC driver
library for detailed steps.
See Using DRDA to connect to
database repositories and data
sources for detailed steps.

Configuring
repository
storage

Configure the storage that is used
to hold database connection and
resource limit information, as well
as the database objects to be used
by developers.

Configuring shared repository
storage involves the following
tasks:
v Specifying JDBC/JNDI
connection and user login
information
v Creating and updating tables
v

Protecting repository storage
tables and granting user
permissions

v Setting maximum number of
simultaneous database
connections
Creating a
repository

Create repository into which users See Creating repositories for
can save queries, reports, and other detailed steps.
data objects.

Defining a
connection to
the database

Add a relational data source or
See Defining a connection to the
multidimensional data source to
database for detailed steps.
define the DataQuant connection to
the database.
The connection information is
stored in the Repository.
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Creating the
repository
connection

Provide DataQuant for Workstation See Creating the repository
and DataQuant for WebSphere with connection for DataQuant for
information needed to connect the
detailed steps.
repository

Providing
access to the
configured
product

Allow multiple users to install and See Exporting the configuration
access DataQuant for Workstation
data to users for detailed steps.
or access DataQuant for WebSphere
configuration from their web
browser.
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Creating the JDBC driver configuration file
If you are using JDBC to connect to the database repositories and data sources, you
must specify where DataQuant will find the JDBC driver files for each type of
database that will host a repository or be accessed as a data source.

Before you begin
Open the Administrator perspective if you have not already done so. To open the
Administrative perspective go to the menu pane and select Window > Open
perspective > Other > Administrator.
The JDBC driver files that are required to connect to a specific database must be
installed on or accessible to the machine that you are currently using to configure
repositories and data sources. DataQuant does not ship with these drivers.

About this task
The procedure in this task describes how to add the required JDBC driver files to
your DataQuant environment configuration.
Note: The multiplatform version of DataQuant for Workstation includes the JDBC
driver that can be used to connect to DB2 UDB for Linux, UNIX and Windows
data sources. If you are using the multiplatform version of DataQuant for
Workstation, you do not have to perform the set up process for this driver.
To specify the JDBC driver information for each type of database that will host a
repository or be accessed as a data source, perform the following procedure:

Procedure
1. Select Preferences from the View menu to open the Preferences window. Select
JDBC Libraries. The JDBC Libraries page opens. DataQuant supplies
pre-populated libraries named for specific databases. For example, you will see
libraries named IBM solidDB®, DB2, Derby, Informix, MS SQL, Oracle, SUN
ODBC, and Netezza. Expanding a database library reveals that each is
pre-populated with one or more driver libraries. The driver libraries are named
for the most commonly used drivers for each type of database. Expanding the
driver libraries reveals the class name for each type of driver.
2. If a JDBC driver is not listed in the pre-populated libraries, you can add a user
defined JDBC driver library and driver class name:
a. Select Add Driver. The Add New Driver Library window opens.
b. The JDBC driver information is organized by libraries. Enter a name for the
driver library in the Enter new library name field. It is recommended that
the name that you specify describes the JDBC driver that will be included in
the library. For example, if you are adding information for a DB2 Type 2
UDB driver, you might call the library DB2 Type 2 UDB driver. However,
this is a descriptive field and can include any text.
c. Specify the actual name of the driver class that will be used in the Driver
class name field. This can be found in your JDBC driver documentation. For
example, for a DB2 Type 2 UDB driver you might specify:
com.ibm.db2.jdbc.app.DB2Driver.
d. Optionally, you can specify a generic example of a correctly formatted URL
that could be used to connect to the database in the URL templates field. To
add a URL template, select the Add URL template icon. The text New
template displays in the Template field. Replace the text New template
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3.

4.

5.

6.

with a sample of how the URL should be formatted. For example, if you are
adding JDBC driver information for DB2 Type 2 UDB driver, you might
specify the following JDBC URL template: jdbc:db2://host:50000/database.
The generic information as specified in the template is presented when you
are adding data sources to the repository and when you are creating
repository connections. You will replace the generic information with the
specific database information.
e. Optionally, you can add additional JDBC driver properties to the URL
template. Click JDBC driver properties. The Advanced JDBC Settings
window opens. Select the properties that will be supported or can be used
when connecting to a database using JDBC. They will be reflected in the
URL template.
If you are using DataQuant for Workstation, for each driver class entry in a
library, both pre-populated and user defined, you must specify where to find
the associated JDBC driver JAR files. To specify where to find the associated
JAR files:
a. Expand the library that contains the JDBC driver class name to which you
want to add JAR file location information.
b. Select Add JARS. The Add JARS to [libraryname] window opens.
c. Search for and select the JDBC driver files that you want to add.
d. Select Open. The location of the JDBC driver JAR files is saved in the JDBC
library that you have selected.
Select Apply. The JDBC library information that you have specified is saved in
the bi.jdbc.drivers file for the current machine. You must repeat the previous
step for each pre-populated and user defined driver that will be used to access
various database repositories or data sources.
You can make the following changes to the JDBC driver information:
v To edit user defined JDBC driver library information, select an existing JDBC
driver library from the list and click Edit. The Edit Driver Library window
opens where you can make changes to the Edit library name, Driver class
name, and URL templates fields.
v If you are using DataQuant for Workstation, to edit the location of the JAR
files, select a JAR file from the list of files that have been added to the JDBC
library, and click Edit. The Edit JAR URL window opens. Specify the name
and location in the Edit JAR location field.
v To remove a JDBC driver library, select an existing JDBC driver library from
the list and click Remove. The library, including all the JAR files that it
contains, is removed. You can not remove any pre-populated libraries.
v If you are using DataQuant for Workstation, to remove a JAR file from a
JDBC driver library, select an existing JAR file from the list and click
Remove. The JAR file is removed.
Click OK. The Preferences window closes.

Results
The JDBC driver information is saved and DataQuant can connect to your
database.
Note: The information that you entered in the wizard is written to a file named
.bi.jdbc.drivers. This file is saved in the personal settings directory of the
machine/server that you are using to configure DataQuant repositories.
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What to do next
Now you are ready to create the shared repository storage tables on your database.
Note: For more information on configuring JDBC libraries, refer to the Creating and
Connecting to a repository cheat sheet. This cheat sheet details how to configure
JDBC libraries and describes how you can copy the JDBC settings file for
distribution across multiple systems. The cheat sheet is accessible from the
DataQuant for Workstation Help menu. To open the cheat sheet, select Help >
Cheat Sheets. Select Creating and connecting to a repository from the Cheat Sheet
window.

Using DRDA to connect to database repositories and data
sources
You can use the Direct DRDA Connection to establish a connection to DB2
database repositories and data sources.

Before you begin
The Direct DRDA Connection is supported only for DB2 for z/OS Version 8,
Version 9, and Version 10. Do not use it for DB2 LUW or DB2 for iSeries.

About this task
In contrast to JDBC driver libraries, the Direct DRDA Connection is included with
DataQuant and does not require additional driver installation.
You can specify the Direct DRDA Connection when creating a relational data
source, shared repository storage, or shared repository connection.
To specify the Direct DRDA Connection:

Procedure
1. From the JDBC Driver drop-down list of the connection parameters section,
select Direct DRDA Connection. The connection will be used to access the
database that hosts the repository storage.
2. In the JDBC URL list specify the URL that points to the database that hosts the
repository storage.
The templates for the URL can be displayed in the list:
jdbc:rsbi:db2://{server}:{port}/{database}

You must specify the server, port, and database information.
Note: You can also use the Build URL by URL Template window to form the
correct string. To do so, click Build URL to open the Build URL by URL
Template window. From the JDBC URL drop-down list, select the template. In
the table, specify the server, port, and database information and click OK. The
result URL string is added to the JDBC URL list.
3. Click Advanced to specify Direct DRDA Connection string properties and their
values to be used for the database that hosts the repository storage tables.
See Direct DRDA Connection properties for more information.
4. To bind the direct DRDA package click Bind Packages. The Bind Packages
dialog opens.
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In order for Direct DRDA Connection to properly work you must bind Direct
DRDA packages when you are connecting to a database for the first time.
When the binding operation completes, users can connect to the database by
using Direct DRDA Connection. They do not have to bind packages again.
a. In the Owner ID field you can enter a privileged SQLID with the necessary
rights for the binding process, in case a user who establishes a server
connection has no administrator privileges for the database. If the value of
this field is not specified, the CURRENT SQLID, the user name set in the
Set User Information dialog, will be used to perform the installation
process.
b. Click Install to start the installation process.
5. Continue specifying the relational data source, shared repository storage, or
shared repository connection parameters.

Direct DRDA Connection properties
Direct DRDA Connection properties define how the connection to a particular data
source is established. You can specify Direct DRDA Connection properties in the
Advanced JDBC Settings window.
The Direct DRDA Connection has the following property:

Parameters
SECURITY_MECHANISM
This property specifies the Direct DRDA Connection security mechanism. The
data type of this property is integer. Possible values are:
v SECMEC.I_USRIDPWD = 3
Neither user ID nor password is encrypted.
v SECMEC.I_EUSRIDPWD = 9
Both user ID and password are encrypted.
v SECMEC.I_EUSRPWDDTA = 13
The user ID, Password, and Data are encrypted.
If you do not specify a value for SECURITY_MECHANISM, the requester
attempts to connect using the security mechanism without any encryption.
If the server accepts only encrypted login information, the requester attempts
to switch to the corresponding security mechanism.
If a connection cannot be established because the server does not support that
security mechanism, an exception is thrown.

Creating a shared repository storage
A shared repository storage is a set of database tables. You must create a shared
repository storage for storing database connection and resource limit information,
as well as the database objects that users will use for reporting and querying
actions.

Before you begin
Before you begin this task, make sure you have:
v Installed and configured your database management system (DBMS).
v Installed the JDBC driver JAR files and license files so that DataQuant can
connect to the database.
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Open the Administrator perspective if you have not already done so. To open the
Administrative perspective go to the menu pane and select Window > Open
perspective > Other > Administrator.
Make sure the Repository view is open in the workbench. To open the Repository
view select Window > Show view > Repositories. The Repositories tab opens in
the workbench.

About this task
Creating the repository storage tables is a multistep process with multiple options
presented in each step. The options you select in one step will determine the next
step in the process.
The steps in this topic provide an overview of the process for creating the shared
repository storage on your database, so that the data in the repositories can be
obtained for further relocation or distribution in a network. See the subsequent
topics in this section for detailed descriptions of the wizards employed.
The maximal line length of the DDL scripts displayed when creating shared
repository storage is determined by the value set in the Line width field on the
General Preferences page. See Setting general preferences in the User help for more
information.
To create the repository storage on your database:

Procedure
1. Right-click in the Repositories view. Select New > Shared Repository Storage.
The Enter connection parameters for new shared repository storage page of the
Create New Shared Repository Storage wizard opens.
2. On the Enter connection parameters for new shared repository storage page,
specify the JDBC connection information and user login information that will
be used to connect to the database that will host the repository storage.
3. Click Next. The Create or upgrade repository storage tables page of the wizard
opens.
4. On the Create or upgrade repository storage tables page, specify that the
database objects that are required by the DataQuant applications in order to
access the repository storage will be created or upgraded.
5. Click Next. If necessary, the Upgrade repository storage tables page opens
listing the SQL statements that will be used to create or update the required
repository storage tables. If this page opens, click Next. The Protect repository
storage tables page of the wizard opens.
6. On the Protect repository storage tables page of the wizard specify whether the
database repository storage tables will be protected from unauthorized users.
7. Click Finish.

Results
You have created the shared repository storage on your database.

What to do next
The next step is to add repositories to the repository storage tables.
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Specifying JDBC/JNDI connection and user login information
The first step to creating shared repository storage is to specify the connection and
the user login information that will be used when accessing the database that hosts
the repository storage. The connection can be either JDBC or JNDI.

About this task
To specify the connection and user login information for the database that hosts
the repository storage:

Procedure
1. Open the Create New Shared Repository Storage wizard and navigate to the
Enter connection parameters for new shared repository storage page.
2. In the Connection type radio group, select JDBC or JNDI. If you selected
JNDI:
a. In the Data Source name field, specify the JNDI data source name and
location.
b. Click Advanced to specify any driver-specific connection string keywords
and their values that will be used for the database that is hosting the
repository storage tables. For information on any keywords that are
required by a selected database driver, consult the specific driver's
documentation.
If you selected JDBC:
a. In the JDBC Driver field specify the library for the JDBC driver that will be
used to access the database that is hosting the repository storage. You can
select from a drop down list of libraries that you defined when you set up
the JDBC driver information. You can use the ellipsis (...) to the right of the
field to open the JDBC Libraries dialog where you can create additional
JDBC driver libraries.
Note: If you work with a DB2 for z/OS database, you can use the Direct
DRDA Connection. In contrast to JDBC libraries, the Direct DRDA
Connection comes with DataQuant and does not require additional driver
installation.
Note: The Direct DRDA Connection is supported only for DB2 for z/OS
Version 8, Version 9, and Version 10. Do not use it for DB2 LUW or DB2 for
iSeries.
See Using DRDA to connect to database repositories and data sources for
more information.
b. In the JDBC URL list, specify the URL that points to the database that hosts
the repository storage within which the repository to which you want to
connect resides.
The format for the URL can be displayed in the list.
Note: You can also use the Build URL by URL Template dialog box to
form the correct string.
Click Build URL to open the Build URL by URL Template dialog box. From
the JDBC URL drop-down list, select the template. In the table, specify the
server, port, and database information and click OK. The result URL string
is added to the JDBC URL list.
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c. Click Advanced to specify any driver-specific connection string keywords
and their values that will be used for the database that is hosting the
repository storage tables. The list of available advanced properties will
change depending on both the type of driver being used, and the version of
the driver. For information on any keywords that are required by a selected
database driver, consult the specific driver's documentation.

3.
4.

5.

6.
7.
8.

Note: For the DB2 Type 4 UDB driver and the DB2 Universal JDBC Driver,
to receive extended SQL exception error messages, check the
retrieveMessagesFromServerOnGetMessage option in the Advanced JDBC
Settings window.
d. If you use the Direct DRDA Connection, bind packages by clicking the Bind
Packages button.
Specify the user information. Click the Set User Information button to open
User Information dialog.
In the User Information dialog, select User ID and password are required to
require the use of a user ID and password when accessing the database that is
hosting the repository storage. If the database that is hosting the repository
storage allows access without a user ID and password, selecting this option will
override that allowance, and a user ID and password will be required to access
the repository storage tables.
Specify the user ID and password that will be used to access the database in
the User ID and Password fields. The user ID and password that you specify
when connecting to the host repository are used to authorize the user in that
repository. The user ID and password that you specify must have
administrative privileges on the host database in order to create the repository
storage tables. This mode is only available on DB2.
To remember this password every time you use the specified user ID to connect
to the database, select the Remember password check box.
Click Test Connection to test the connection to the database. If you have
specified any information incorrectly you will not be able to connect.
Click Next. The Create or update the repository storage tables page of the
wizard opens.

Creating and updating tables
The second step to creating shared repository storage is to specify whether the
database objects that are required by the DataQuant applications in order to access
the repository storage will be created or updated.

About this task
Several database tables are required to support the shared repository storage that is
being created on the database. You must specify whether DataQuant should check
to see if the tables exist or need updating.
To create or update the repository storage tables:

Procedure
1. Open the Create New Shared Repository Storage wizard and navigate to the
Create or update repository storage tables page.
2. Select one of the following options:
v Click Repository storage tables have already been created to bypass this
step. You might select this option if all the repository storage tables already
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exist and you are certain that the tables have not changed. An example of
this situation might be if you are editing the repository storage options and
your intent is to re-bind packages or re-run stored procedures for the
repository storage tables. Click Next. The Protect repository storage tables
page of the wizard opens.
v Click Create or upgrade repository storage tables to check if the tables have
been created or have to be updated.
3. Optionally you can type the owner name in the Owner ID field, if you work
with DB2 databases. The Owner ID provides the administrator privileges to the
user who operates under the login without SYSADM authority.
Tip: (for DB2 for z/OS databases)

|

When the user without administrator privileges creates or updates the shared
repository storage tables and enters the owner name in the Owner ID field, the
user login and Owner ID are automatically inserted to the RSBI.AUTHID_TABLE
as the PRIMARY_ID and SECONDARY_ID correspondingly. This allows the user to
create shared repositories with database-based security provider and
automatically work with the repositories as an administrator.
4. If repository storage tables have not been created, you can select the Enable
customization of database object names check box to open a window where
you can customize how database objects are named.
5. Click Next. Depending on the status of the tables you will proceed as follows:
v If all the tables have been created and have not changed, a message is issued.
Click OK in the message window. The Protect repository storage tables page
of the wizard opens.
v If the tables have to be created or updated and you did not select the Enable
customization of database object names check box, then the Update
repository storage tables page of the wizard opens listing the SQL statements
that will be used to create or update the required repository storage tables.
You can make changes to the SQL statements as described on the page. Click
Next. The Protect repository storage tables page opens.
v If the tables have to be created and you selected the Enable customization of
database object names check box, then the Enter Substitution Variable
Values window opens. Enter your customized database object names in the
Value column and click OK.

|
|
|
|
|
|

Note: The Value column of the window displays the default name of each
database object. This gives you an opportunity to review and/or rename the
objects that will be created. For example, one could preface all index names
with the prefix "IX".
The Enter Substitution Variable Values window closes and the Protect
repository storage tables page of the wizard opens.

Protecting repository storage tables and granting user
permissions
The last step to creating shared repository storage is to specify whether the shared
repository storage tables will be protected from unauthorized users.

About this task
Several tables in repository storage are used by DataQuant to store processing
information. Some of these tables store sensitive information, for example the
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permissions table. By default all users can access these repository storage tables
and make changes to the tables. You can choose to protect the repository storage
tables. In protection mode the repository storage tables are accessed using a
collection of stored procedures or static SQL packages depending on what the
database that is hosting the repository storage supports. Users of the repository
storage must then be granted permission to run the stored procedures or static
SQL packages.
To protect the repository storage tables:

Procedure
1. Open the New Shared Repository Storage wizard and navigate to the Protect
repository storage tables page.
2. Specify whether the shared repository storage tables will be protected from
unauthorized users. By default the Protection method check box is not selected.
This means that all users will have access to the repository storage tables and
can make changes to any of those tables. To specify that you will protect the
repository storage tables, select the Protection method check box. The fields
that you will use to specify the protection method become available.
3. Select one of the following protection methods:
v Select Stored procedures to specify that you will use stored procedures to
protect the repository storage tables. You can select this option if the
repository storage tables are located on one of the following databases:
– Informix
– DB2 UDB LUW V9 and above
– DB2 z/OS V9 and above in NFM
– DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
– Microsoft SQL Server
v Select Static SQL packages to specify that you will use static SQL packages
to protect the repository storage tables. You can select this option if the
repository storage tables are located on a DB2 database that you will connect
to using the IBM DB2 Universal driver for JDBC or the Direct DRDA
connectivity provided by the product (the latter option is available for DB2
for z/OS connectivity only).
4. Type, or select from the drop-down list, the name that you want to use to
identify the collection of stored procedures or static SQL packages in the
Collection ID field.
5. Optionally you can type the owner name in the Owner ID field, if you work
with DB2 databases. The Owner ID provides the administrator privileges to the
user who operates under the login without SYSADM authority.
6. Click Create. The stored procedures are created or the static SQL packages are
bound. A message is issued that informs you of the success of the either
process. You can also use the Delete button to remove a collection of stored
procedures or packages.
7. Specify which users will have permission to run the stored procedures or static
SQL packages for the repository storage tables on this database. To grant
permission to all users, enter PUBLIC in the User IDs field and click Grant. To
grant permission to specific users, type their user IDs in the field and click
Grant. A message is issued that informs you that the selected user IDs have
been granted permission to run the stored procedures or packages.
Optionally, you can revoke permission to run the stored procedures or static
SQL packages from any user that is listed in the User IDs list box. To revoke
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permission from one or more users, highlight one or more of the user IDs and
click Revoke. A message is issued informing you that permission to run the
stored procedures or static SQL packages has been revoked from the selected
user IDs.
8. Click Finish. The repository storage tables are created. The location of the new
repository storage tables is listed in the Repositories view. After you have
created the shared repository storage in the database, you can add one or more
repositories that will share the storage. Each repository that you create can have
its own independent objects, security models, and users.

Setting maximum number of simultaneous database
connections
An advanced feature in creating repository storage tables allows you to specify the
maximum number of simultaneous database connections.

About this task
This advanced feature exists in both Workstation and WebSphere, and contains the
concurrent access to repository storage database limit.
To set the maximum number of simultaneous database connections:

Procedure
1. In the Repositories view right-click the repository storage to which you want
to specify simultaneous database connections. Select Edit from the pop-up
menu. The Edit Repository Storage window opens.
2. Click the Advanced tab.
3. Specify the number of database connections in the Maximum number of
simultaneous database connections field. The default value is 10.
4. Click OK. The maximum number of simultaneous database connections is set
in the repository storage tables.

Creating repositories
In order to begin using DataQuant, you must create at least one repository. A
repository is a centralized storage area. It is the place where objects such as
queries, forms, and reports are saved. It is also where the application interface will
look for the information necessary to connect to any data sources that your users
want to access.
The Administrator perspective of the application interface provides the views,
menus, and wizards that enable you to create, manage, and maintain repositories
DataQuant supports personal and shared repositories.

Personal repositories
Personal repositories serve a single user and are stored in the personal settings
directory of the machine that is running DataQuant. For example, in a windows
operating system, the personal repository is saved under the following path
(shown here on two lines):
C:\Documents and Settings\[UserName]\Application Data\
IBM\DataQuant for Workstation\Personal Repositories
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Note: The Application Data folder is a hidden folder and will not appear in
Windows Explorer unless you configure Explorer to display hidden files and
folders. For other operating systems, the file is similarly located in the
workstation's personal settings directory. Each user can create their personal
repository from the User perspective of the application interface that they are
using. Personal repositories do not support any of the extended features of
repositories such as security.

Shared repositories
Shared repositories are designed to support multiple users with a single user as the
administrator. Shared repositories can reside in any JDBC-compliant database. They
support the security and workspace features that allow the administrator to control
the view of enterprise resources on a per-user or per-group basis. In addition they
support the login mapping feature, and network or Web service access. In order to
create a shared repository, the administrator must have the Administrator
component installed and the privileges to bind packages or create stored
procedures on the database where the repository will reside.
Note: In DataQuant for Workstation and DataQuant for WebSphere V1.2 Fix Pack
2 and later, the following changes have occurred:
v Database-based repositories are now referred to as shared repositories.
v Personal repositories have replaced file-based repositories. You can no longer
create file-based repositories. However, you can still connect to any file-based
repositories that were created prior to V1.2 Fix Pack 2

Adding repositories to the repository storage tables
You can add repositories to the repository storage tables. Repositories serve as a
centralized place in which an aggregation of data, such as queries, procedures,
forms, dashboards, and, reports are developed for a specific set of data sources.
Each repository that you create can have its own independent objects, security
models, and users.

Before you begin
Make sure the Repository view is open in the workbench. To open the Repository
view select Window > Show view > Repositories. The Repositories tab opens in
the workbench.

About this task
The information in this topic describes how to add a repository within the
repository storage tables on a database.
As part of the procedure for adding repositories, you define the permissions for
accessing the repositories. These permissions determine which users or user groups
have access to the repositories.
To add a repository to the repository storage table, perform the following steps:

Procedure
1. In the Repositories view right-click the repository storage to which you want
to add a repository. Select New > Shared Repository from the pop-up menu.
The Create New Shared Repository wizard opens.
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2. Specify the name that will be used to identify the repository in the Name field.
3. Optionally, type a comment that describes the repository in the Comment field.
This comment will display with the properties for the repository.
4. Select the type of security that will be applied to the repository. From the
Security provider drop-down list select one of the following:
v None: Specifies that no additional security beyond what is provided by the
database that is hosting the repository will be applied. All users will have
full access to the contents of the repository.
v Internal: Specifies that a layer of security beyond what is provided at the
database level will be applied. This level of security allows you to define
users and groups, and then assign them permission to access the repository.
This level of security also allows you to control which objects a user or
group can access or view when they are connected to the repository. User
and group definitions, and their assignments, are stored within the
repository. Users will log on to DataQuant for Workstation or DataQuant for
WebSphere using their defined user IDs and passwords. They will be granted
access to a repository or to repository objects based on the permissions that
they are assigned by the DataQuant administrator.
v LDAP: Specifies that a layer of security beyond what is provided at the
database level will be applied. This level of security allows you to control the
users and groups who are permitted access to the repository. This level of
security also allows you to control which objects a user or group can access
or view when connected to the repository. If you choose the LDAP security
option, the user identities and group affiliations are obtained from an
existing LDAP server. Users will log on to DataQuant for Workstation or
DataQuant for WebSphere using their LDAP user names and passwords.
They will be granted access to a repository or to repository objects based on
the permissions that they are assigned by the DataQuant administrator.
v Database-based: Specifies that the security settings of the host database will
be used to protect the shared repository.
5. If you selected either Internal or LDAP security, click Next. One of the
following wizard pages opens:
v If you selected Internal security, the Internal security provider options page
opens. Specify the user name and password that will identify the DataQuant
administrator account. The DataQuant administrator account is the account
that is used to create additional administrative accounts, as well as apply
security permission levels to different users and groups.
v If you selected LDAP security, the LDAP security provider options page
opens. Specify one or more values for the LDAP fields. These fields are used
to obtain all LDAP users and groups. You will be asked to specify an existing
LDAP group in your directory that represents the DataQuant administrator
account. All LDAP accounts that belong to this group will have DataQuant
administrator privileges and can create additional administrative accounts, as
well as apply security permission levels to different users and groups.
6. Click Finish.

Results
You have created and added to the list of available repositories that are contained
within the shared repository storage.
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What to do next
The next step is to configure data source information in the repository.
If you have applied Internal security to the repository you can choose to create the
users and groups that can access the repository at this point, or after you have
configured data source information. If you assigned LDAP security to the
repository, all the users and groups that were obtained from your LDAP server can
access the repository. For both types of secured repositories, Internal and LDAP,
you assign users and groups permission to access repository objects on an ongoing
basis as the needs of your environment dictate or change.
If you are just creating the repository, you must populate the repository with data
source information before you can specify the level of access a user or group will
have to the objects that are in the repository.

Specifying internal security fields
For repositories with Internal security, you must specify the user name and
password that will identify the DataQuant administrator account.
Administrator login
Use this field to specify a user name that will identify the DataQuant
administrator. The DataQuant administrator account is the account that is
used to create additional administrative accounts as well as create new
user and group accounts. In addition, only administrator accounts can be
used to apply security permissions to user and groups.
Administrator password
Use this field to specify the password that will be used in conjunction with
the user ID that is specified in the Administrator login field.
Confirm Administrator password
Use this field to confirm the password that you specified in the
Administrator password field.
Days for password expiration (0 - without limit)
Use this field to specify the number of days until the password will expire.
A value of zero (0) indicates that the password will not expire.
Warning before password expiration date (days)
Use this field to specify the number of days prior to the expiration day
that a warning to change the password will be issued.

Specifying users and groups for Internal security option
The Internal security option requires that you identify the users and groups that
will be able to access the repository.

About this task
Each repository that you create can have a different set of users and groups that
are allowed access. After you identify the users and groups that are allowed to
access the repository, you can then assign them permission to access specific
objects within the repository.
To set up the users and groups that can access a repository that has Internal
security:
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Procedure
1. Open the Users and Groups view by selecting Window > Show View > Users
Groups.
2. To add a new user that will be able to access this repository, right-click the
Users node and select New > User from the pop-up menu. The New
Repository User window opens. Specify the new user information.
3. To add a new group that will be able to access this repository, right-click the
Groups node and select New > Group from the pop-up menu. The New
Repository Group window opens. Specify the new group information.
4. To edit a user's password, right-click the user name in the tree and select Set
Password from the context menu. The Set Password For User window opens.
Specify the new password in the Password field.
5. To delete a user or group, right-click a user or group name in the tree and
select Delete from the pop-up menu. The selected user or group is deleted.
6. To refresh the list of user and groups names, right-click anywhere in the view
or on any element in the tree and select Refresh from the pop-up menu. The
list is refreshed.
7. To edit a user's or group's properties, right-click a user or group name in the
tree and select Properties from the pop-up menu. The Properties for [User]
window opens if you have selected a user or the Properties for [Group]
window opens if you have selected a group. Edit the fields that you want to
change and click OK.
8. You can choose to either leave the Users and Groups view open or close the
view by clicking the close icon. The next step to setting up users and groups
for repositories with Internal security is to assign permission to use repository
objects.
Creating a user:
You must define each user that will be allowed to access a repository that has been
assigned the Internal security option.
About this task
To create a new user that will be allowed to access a repository with Internal
security:
Procedure
1. Open the New Repository User window, by expanding the repository tree to
the Users and Groups branch, then right-click Users, select New > User
2. Specify the ID that the user will use to connect to the repository in the User
name field.
3. Specify the user's full name in the Full name field.
4. Specify the password for the user name in the Password field.
5. Retype the password for the user name in the Confirm password field.
6. Optionally, you can type a description of the user in the Description field. This
description is displayed with the user's properties.
7. To automatically create a default home workspace for the user, select the Has a
home workspace check box.
8. Add the new user to a group by using the Group Membership check boxes.
Each group that you have created is listed. You can select one or more group
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check boxes. The user will be added to each group whose check box is selected.
If the group that you want to add the user to is not listed, you must define the
group.
9. Click Finish. The user identity is created and will be allowed to access the
repository. You will repeat this process for each new user that will have access
to the repository. After specifying the users and groups that can access the
repository, the next step is to assign them permission to use repository objects.
Creating new group:
You must define each group that will be allowed to access a repository that has
been assigned the Internal security option.
About this task
To create a new group that will be allowed to access a repository with Internal
security:
Procedure
1. Open the New Repository Group window, by expanding the repository tree to
the Users and Groups branch, then right-click Groups, select New > Group
2. Specify the name of the group in the Group Name field.
3. Add users to the new group by using the Members check boxes. Each user that
you have created is listed. You can select one or more user's check boxes.
4. Specify the parent folder for the new group by using the Parent field. The
current group hierarchy is displayed. From the tree, select the group that will
be the parent for the new group.
5. Optionally, you can type a description of the group in the Description field.
This description is displayed with the group's properties.
6. Click Finish to create the new group.
Editing user properties:
You can edit the properties that you have specified for each user that will be
allowed to access a repository that has been assigned the Internal security option.
About this task
To edit a user's properties:
Procedure
1. Open the Users and Groups view by selecting Window > Show View > Users
& Groups > Other. Expand the DataQuant Workbench and select Users and
Groups. Right-click a user name in the tree and select Properties from the
pop-up menu. The Properties for [User] window opens.
2. On the User General page of the Properties for [User] window, the User name
field displays the name of the selected user. You can edit the following user
fields on this page:
v Type any changes to the user's user name in the User name field.
v Type any changes to the user's full name in the Full Name field.
v Type any changes to the description in the Description field.
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v Specify a new password for the user by clicking the Set Password button.
The Set Password for [User] window opens where you can specify the new
password.
3. On the User Membership page of the Properties for [User] window, you can
add and remove the user to and from groups. All of the groups that have been
created for the repository are listed in the Member of list box. Each group has
a corresponding check box. The check box is selected if the user belongs to that
group and cleared if the user does not belong to the group. To add the user to
a group, select the group's corresponding check box. To remove the user from a
group, clear the group's corresponding check box.
4. Click OK. The changes that you have made to the user's properties are saved.
Editing group properties:
You can edit the properties for each group that can access an internally secured
repository.
About this task
To edit a group's properties:
Procedure
1. Open the Users and Groups view by selecting Window > Show View > Users
& Groups > Other. Expand the DataQuant Workbench and select Users and
Groups. Right-click a group name in the tree and select Properties from the
pop-up menu. The Properties for [Group] window opens.
2. The Group name field in the Group General page of the Properties window
displays the name of the selected group. You can make changes to the name of
the group in this field.
3. The parent group for the selected group displays in the Parent group field. To
change the parent group of the selected group, click Change. The Edit Parent
Group window opens. Expand the branches of the Groups tree until you
expose the group to which you want to add the selected group. Click Set As
Parent. The selected group will be moved to the new parent group.
4. The description for the group is displayed in the Description field. You can
edit the description text by typing new text directly in the field.
5. Click Apply to apply the Group General properties that you have changed.
6. You can add and remove users to and from the selected group using the Group
Membership page of the Properties for [Group] window. All of the users that
have been defined for the repository are listed in the Members list box. The
corresponding check box for each user is selected if the user belongs to the
group and clear if the user does not belong to the group. To add the user to a
group, select the group's corresponding check box. To remove the user from a
group, clear the group's corresponding check box.
7. Click Apply to apply the Group Membership properties that you have
changed.
8. Click OK. The changes that you have made to the group's properties are saved.

Specifying LDAP security fields
If you specified the LDAP security option for a repository, you must specify the
LDAP security parameters in order to obtain the user identities and group
affiliations from your LDAP server.
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About this task
Note: All users and groups that are defined in your LDAP server are obtained and
granted permission to access the repository. To specify what type of access the
users and groups can have to the repository, you edit the repository's security
properties assigning permission levels to each user or group.
Specifying LDAP Main fields:
You must specify the LDAP Main fields if you have selected LDAP security for the
database repository.
Host

Use this field to specify the IP address of the LDAP server.

Port

Use this field to specify the contact port that is used by your LDAP server.
For example, the LDAP protocol specifies the use of TCP/IP port number
389 for LDAP. However, this value can vary based on what has been
specified in your environment.
To use the Secure Sockets Layer (SSL) protocol to communicate with the
LDAP server, select the Use SSL check box and specify the appropriate
SSL port number in the Port field.
Note: The LDAP server that you use must be configured to use SSL.

Auth type
Use this field to specify what type of LDAP authentication should occur
for this repository. Select None to allow a user to authenticate to an LDAP
server as an anonymous user. Select Simple to require that a user
authenticates to the LDAP server with a distinguished name (DN) and a
password.
User DN
Use this field to specify the user-distinguished name that can be used to
access your LDAP directory. This field is available only if your LDAP
directory requires authentication in order to access, and you specified
Simple in the Auth Type field.
Password
Use this field to specify the password that is associated with the user's
distinguished name that you specified in the User DN field.
Base DN
Use this field to specify (or select from the drop-down list) the
distinguished name or names that will lead to the entry in the LDAP
directory under which all users and groups will be retrieved. A
distinguished name is a unique name for an entry in your LDAP directory.
For example: ou=people, o=eastcoast.
Account required
Select this check box to specify that a master account can be used to edit
the LDAP repository settings.
Login Specifies the login that will be used as the master account.
Password
Specifies the password that will be used for the master account.

Chapter 3. Configuring the environment

45

Specifying LDAP Group fields:
You must specify the LDAP Group fields if you have selected LDAP security for
the database repository.
Base RDN
Use this field to specify the relative distinguished name for a group. For
example: o=Sales.
Search scope
Specifies the possible scopes for the directory search. You can specify:
v One level: To search the one level below the Base RDN level, excluding
the base object.
v Subtree: To search the whole subtree rooted at the Base RDN level,
including the base object and all its child objects.
Object class
Specify the object class to which the group belongs. For example:
objectclass:posixGroup indicates that all entries under Base RDN belong
to the posixGroup class.
Name attribute
Specify the name of an attribute whose value specifies the group name.
Description attribute
Specify the name of an attribute whose value specifies the description of
the group.
Name filter
This field specifies the standard search string that will be used to search
groups by name. This field is generated based on the values that you
specify in the Name attribute and Object class fields.
All groups filter
This field specifies the standard search string that will return all the groups
under the Base RDN. This field is generated based on the values that you
specify in the Name attribute and Object class fields.
User's group
Use this field to specify the group to which the member belongs.
Administrator's group
Use this field to specify the group whose members will be granted
administrator permissions within the content of the DataQuant products.
Member attribute
Specifies the name of a groups entry's attribute whose value specifies
membership in the group. You can specify an RDN that will refer to a user
entry or a user's name.
Member type
Specifies the member type based on what was specified in the Member
attribute field. If you specified an RDN in the Member attribute field, the
member type is DN. If you specified a user name in the Member attribute
field, the member type is Value.
Specifying LDAP User fields:
You must specify the LDAP User fields if you have selected LDAP security for the
database repository.
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Base RDN
Use this field to specify the relative distinguished name for a user. For
example: uid=Mike.
Search Scope
Specifies the possible scopes for the directory search. You can specify:
v Onelevel: To search the one level below the Base RDN level, excluding
the base object.
v Subtree: To search the whole subtree rooted at the Base RDN level,
including the base object and all its child objects.
Object class
Specify the object class to which the user belongs. For example:
objectclass:sales indicates that all entries under Base RDN belong to the
sales class.
Name attribute
Specify the name of an attribute whose value specifies the user name.
Description attribute
Specify the name of an attribute whose value specifies the description of
the user.
Name filter
This field specifies the standard search string that will be used to search
users by name. This field is generated based on the values that you specify
in the Name attribute and Object class fields.
All users filter
This field specifies the standard search string that will return all the users
under the Base RDN. This field is generated based on the values that you
specify in the Name attribute and Object class fields.
Full name attribute
Use this field to specify the name of the attribute that contains a user's full
name.
Login attribute
Specify the name of an attribute whose value specifies the login of the
user.
Specifying LDAP Authenticator fields:
You must specify the LDAP Authentication fields if you have selected LDAP
security for the database repository.
Authenticator type
Use this field to specify the type of authentication that will occur. You can
choose:
v Bind: to use an LDAP bind operation.
v Compare: to use a string compare with the value of the Password
attribute and that of a user's entry.
User's password attribute
Use this field to specify the attribute that will be retrieved in a user's entry
as a password. This field is used only if you specified Compare in the
Authenticator type field.
Append base DN
Select this check box to specify that when authenticating a user, the base
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DN will be appended to a user's RDN. This field is used only if you
specified Bind in the Authenticator type field.
Allow empty password
Select this check box to allow an empty password.

Defining a connection to the database
As an administrator, you create a data source to provide DataQuant with the
information it needs to connect to a database.
The data source you add depends on the type of database that DataQuant is
connecting to.
Table 9. Databases and data source types
If DataQuant is connecting to a

Create a

Relational database

Relational data source

Multidimensional database

Multidimensional data source

Cloudant database

Cloudant data source

Enabling QMF catalog functionality
You can configure a relational data source in the repository so that it can use a
QMF catalog. By enabling access to the QMF catalog users can access any objects
that are saved in the QMF catalog and, if they choose, they can save any new
objects to the QMF catalog.

About this task
The QMF catalog is a set of database tables that contain saved objects (queries,
procedures and forms); user resource limits and profiles; reports; and other
miscellaneous settings and information. QMF catalogs reside on database servers
that host a DB2 database.
Note: QMF catalogs have been superseded by repositories in DataQuant Version 1
and later but have been retained for those who want to share QMF objects with
QMF for TSO/CICS or earlier versions of the QMF distributed products.
DataQuant Version 1 repositories offer more flexibility and enable users to take
advantage of all the powerful DataQuant Version 1 features.
The maximal line length of the DDL scripts displayed when creating or updating
QMF catalogs is determined by the value set in the Line width field on the
General Preferences page. See Setting general preferences in the User help for more
information.
By configuring a data source to access a QMF catalog, you can retrieve any QMF
objects that have been saved in an existing QMF catalog. You can also save any
QMF objects that you might create to a QMF catalog. This allows you to share and
use objects regardless of the application version or platform that was used to create
the QMF object.
In addition, if you configure a data source to access a QMF catalog, you can
control resource usage with the resource limits that have been set for the data
source and the user and saved in the QMF catalog.
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To configure a data source so that it can access a QMF catalog:

Procedure
1. Open the QMF catalog wizard.
2. Specify what type of catalog objects you will create using the Create or update
catalog objects page of the QMF catalog wizard.
3. Click Next.
4. If it was decided that a set of QMF catalog tables has never been created on the
data source, the Create Objects page of the wizard opens. The SQL to create the
catalog tables is displayed. You can make changes to the SQL. If it was decided
that a set of QMF catalog tables has already been created for this data source
and there are no required updates, than this step is bypassed.
5. Click Next.
6. The Protect QMF catalog tables page of the wizard opens. From the Protect
QMF catalog tables page you will specify whether the QMF catalog tables will
be protected from unauthorized users. You will also specify user permission to
use those stored procedures or SQL packages.
7. Click Next.
8. The Select QMF Catalog page of the wizard opens. From the Select QMF
Catalog page you will select the QMF catalog that the data source will use.
9. Click Finish. The QMF catalog wizard closes. Control returns to the Enable
data source plug-ins page of the New Relational Data Source wizard.

Creating or updating QMF catalog objects
The first step to enabling QMF catalog functionality is to choose whether the QMF
catalog objects will be created or updated on the current data source.

About this task
To create or update QMF catalog database objects:

Procedure
1. On the Enable data source plug-ins page of the New Relational Data Source
wizard, select QMF Catalog Plug-in Enable plug-in check box. The Create or
update catalog objects page of the QMF catalog wizard opens.
2. On the Create or update catalog objects page, you will specify whether a set of
QMF catalog tables has ever been created on the data source and what kind of
object names (long or short) are or will be supported by the QMF catalog that
exists or will be created. Select one of the following:
v Select Catalog tables have already been created if the QMF catalog tables
already exist on this data source. A set of catalog tables would have been
created for the data source when it was originally configured in either a
repository or by a prior version of the application. You would select this
option if you know the tables have already been created and you only want
to rerun stored procedures or rebind the catalog packages.
v Select Create or update catalog tables to support short names if you are
configuring a new data source that has never had the QMF catalog tables
installed and you will only use short names for objects, or you are upgrading
from a previous version of the application and the existing QMF catalog
tables will continue to support only short names for objects. If no QMF
catalog tables exist on the data source, then they will be created. If you are
upgrading to a new version, and a set of tables exist on the data source, they
will be checked and updated or added as necessary. You are given the
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opportunity to confirm and modify the SQL statements used to create the
tables. Any data that is in the existing catalog tables is maintained.
v Select Create or update catalog tables to support long names if you are
configuring a data source for the first time and want to create a set of QMF
catalog tables that use long names; you are upgrading from a previous
version of the application and the existing QMF catalog tables will continue
to support only long names for objects; or you want to convert the existing
catalog tables that support short names to catalog tables that support long
names. To select this option, the data source that you are configuring must
support long names. If you choose to create the QMF catalog tables so that
they support long names, QMF applications prior to Version 8.1 will not be
able to use the long names QMF catalog tables.
If no QMF catalog tables exist on the data source, then they will be created
and they will support long names. If a set of QMF catalog tables that support
long names are detected on the data source, they will be updated or added
to as necessary. If an existing set of QMF catalog tables that use short names
are detected on the data source, they will be converted to support long
names. The data source will be checked to ensure that the support for long
names is available. There is no requirement to use long names in the QMF
catalog tables. If the data source uses long names, the QMF catalog tables can
still use short names. Once converted, only 8.1 or later of QMF applications
can use these QMF catalog tables.
You are given the opportunity to confirm and modify the SQL statements
used to create or update the tables. Any data that is in the existing catalog
tables is maintained.
v If you do not want to create a set of QMF catalog tables for this data source,
select Do not create catalog tables. You would select this option if the data
source you are configuring will not host a QMF catalog; will use a set of
QMF catalog tables that reside on a different data source; or a set of QMF
catalog tables has already been created for this data source and you are just
selecting a different QMF catalog.
3. If catalog tables have not been created, you can select the Enable customization
of database object names check box to open a window where you can
customize how database objects are named.
4. Click Next to open the next page of the wizard. If you selected:
v Catalog tables have already been created option, the Protect QMF Catalog
tables page of the wizard opens.
v Create or update catalog tables to support short names or Create or update
catalog tables to support long names option and you did not check the
Enable customization of database object names check box, the Choose
object listing option page of the wizard opens.
v Create or update catalog tables to support short names or Create or update
catalog tables to support long names option and you did check the Enable
customization of database object names check box, the Enter Substitution
Variable Values window opens. Enter your customized database object
names in the Value column and click OK.
Note: The Value column of the dialog displays the default name of each
database object. This gives you an opportunity to review and/or rename the
objects that will be created. For example, one could preface all index names
with the IX .
The Choose object listing option page of the wizard opens.
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v Do not create catalog tables option, the Select QMF Catalog page of the
wizard opens.

Creating database objects for the QMF catalog
The second step to enabling QMF catalog functionality is to review and run the
SQL that will be used to create the database objects for the QMF catalog.

About this task
This step of the process is necessary only if catalog objects have never been created
on the data source or the existing catalog objects need to be updated.
To modify the SQL statements that will be used to create or update the required
database objects:

Procedure
1. If you chose to create or update catalog tables, the Choose object listing option
page of the QMF catalog wizard opens.
2. Select an object listing option from the radio group:
v Include all objects - This option includes all objects that are saved in the
data source, regardless of a user's ability to access them.
v Include only objects accessible by either the user's primary or current
authorization ID
v Include only objects accessible by any of the user's primary or current
authorization ID
3. Click Next. The Create objects page of the QMF Catalog wizard opens.
4. The SQL that will be used to create or update the tables is displayed in the
field. Type any changes that you want to make to the SQL statements directly
in the field. You can modify any of the SQL statements to customize any
parameters. You can not change the name of any of the objects. You must use a
semi-colon(;) to separate multiple statements. Unless absolutely necessary, it is
recommended that you run the SQL as it is displayed.
5. Click Next. A QMF catalog named Default will be created when this step is
run. The Protect QMF Catalog tables page of the wizard opens.

Protecting catalog tables and granting user permissions
The third step to configuring a relational data source to use a QMF catalog is to
specify whether the QMF catalog tables will be protected from unauthorized users
and to specify the users that will have permission to access the tables.

About this task
Several tables in the QMF catalog store sensitive information that should not be
available to the public. You can choose to protect the QMF catalog tables. In
protection mode, the QMF catalog tables are accessed using a collection of stored
procedures or SQL packages depending on what the database that is hosting the
QMF catalog supports. Users of the QMF catalog must then be granted permission
to run the stored procedures or static SQL packages.
To protect the QMF catalog tables:

Procedure
1. Open the Protect QMF Catalog tables page of the wizard.
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2. To specify the type of protection that will be applied to the QMF catalog
tables, select one of the following from the Connect using Protected Mode
radio group:
v Never: You select this option to specify that no protection will be placed on
the QMF catalog tables. This method will expose the QMF catalog tables to
unauthorized use. With no protection the QMF catalog tables can be
accessed by any user using dynamic queries. When the database
administrator grants permissions to a user to access the QMF catalog that
resides on the database, that permission will extend to the whole QMF
catalog including the tables in the QMF catalog that store sensitive
information.
v If possible: You select this option to specify that the QMF catalog tables
will be protected using either stored procedures or static SQL packages if
they are available on the data source. You will specify the users that can
run the stored procedures or static SQL packages. If a set of stored
procedures or static SQL packages is not available, access to the QMF
catalog tables will be as if they are unprotected.
v Always: You select this option to specify that the QMF catalog tables will
always be protected using either stored procedures or static SQL packages.
You will specify the users that can run the stored procedures or static SQL
packages. If a set of stored procedures or static SQL packages is not
available, the query to access the QMF catalog tables will fail.
3. If you selected If possible or Always from the Connect using Protected
Mode radio group, the Protect check box becomes available.
4. Select the Protect check box. The protection method options become available.
5. Select one of the following protection methods:
v Select Stored procedures to specify that you will use stored procedures to
protect the QMF catalog tables. You can select this option if the repository
storage tables are located on one of the following databases:
– DB2 UDB LUW V9 and above
– DB2 z/OS V9 and above
– DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
v Select Static SQL packages to specify that you will use static SQL packages
to protect the QMF catalog tables. You can select this option if the
repository storage tables are located on a DB2 database that you will
connect to using the IBM DB2 Universal driver for JDBC or the Direct
DRDA connectivity provided by the product (the latter option is available
for DB2 for z/OS connectivity only).
6. Type, or select from the drop-down list, the name that you want to use to
identify the collection of stored procedures or static SQL packages in the
Collection ID field.
7. Optionally you can type the owner name in the Owner ID field, if you work
with DB2 databases. The Owner ID provides the administrator privileges to
the user who operates under the login without SYSADM authority.
8. Click Create. The stored procedures are created or the static SQL packages are
bound. A message is issued that informs you of the success of either process.
You can also use Delete to remove a collection of stored procedures or static
packages.
9. You must specify which users will have permission to run the stored
procedures or static SQL packages for the QMF catalog tables on this
database. To grant permission to all users, highlight PUBLIC in the User IDs
list and click Grant. To grant permission to specific users, type their user IDs
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in the field, highlight one or more of the user ID(s) and click Grant. A
message is issued that informs you that the selected user IDs have been
granted permission to run the stored procedures or static SQL packages.
Optionally, you can revoke permission to run the stored procedures or SQL
packages from any user that is listed in the User IDs list box. To revoke
permission from one or more users, highlight one or more of the user IDs and
click Revoke. A message is issued informing you that permission to run the
stored procedures or static SQL packages has been revoked from the selected
user IDs.
10. Click Next. The Select QMF Catalog page of the QMF Catalog wizard opens.

Selecting the QMF catalog
The last step to configuring a data source so that it can access a QMF catalog is to
select a QMF catalog.

About this task
To select the QMF catalog for the data source:

Procedure
1. Open the Select QMF Catalog page of the QMF Catalog wizard.
2. From the Data source name list, select the data source that hosts the QMF
catalog that you want the data source that you are configuring to use. This
could be the same data source as the one you are currently configuring or a
different data source that has already been configured in your repository.
3. From the Catalog list, select the catalog that you want the current data source
that you are configuring to use. You can choose one of the following types of
catalogs:
v Default: This is the main QMF catalog. It is created automatically as a result
of running the SQL statements to create objects on the data source. All
objects saved to a default catalog are saved together. The Default catalog is
the only catalog that can be used by QMF for TSO/CICS and versions of
QMF prior to 7.2.
v Extended: Extended catalogs are extensions of the default catalog. While a
data source can only host a single default QMF catalog, it can host multiple
extended catalogs. Extended catalogs are useful when several data sources
share one QMF catalog. Without extended catalogs, all objects would be
saved into the default QMF catalog. With extended catalogs, each data source
can isolate their saved objects in a particular catalog extension.
4. Optional: To create a new extended catalog that will reside on the current data
source, select the Add catalog icon. The Add Catalog window opens.
5. Optional: To edit the name or the CCSID of an existing extended QMF catalog,
select the Edit catalog icon. The Edit Catalog window opens. You can also use
this window to edit the CCSID for the Default QMF catalog.
6. Optional: To delete an existing extended catalog from the current data source
select the Remove catalog icon. You should use caution when deleting
extended catalogs as DataQuant for Workstation removes the extended catalog
and all of its contents regardless of whether other data sources might be
configured to use the extended catalog.
7. Optional: Select Refresh List to refresh the list of available extended catalogs in
the list box.
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8. Click Finish. The QMF Catalog wizard closes. This is the last step to
configuring a data source to use a QMF catalog. Control returns to the Enable
data source plug-ins page of the New Relational Data Source wizard.

Creating an extended catalog
You can create extended QMF catalogs to organize user access to objects within the
overall default QMF catalog.

About this task
Instead of all objects being in the main default catalog, they can be isolated in
smaller extended catalogs. There are many reasons to use extended catalogs. You
can use them to control a user's view of objects. You can use them to isolate objects
from one data source that is sharing a QMF catalog on another data source. An
extended catalog can contain only the selected objects from a specific data source.
You can also set up extended catalogs that have different CCSID settings from the
main Default catalog.
Note: Performance, a user's views of objects, and the overall maintenance of your
query environment can be adversely impacted when a data source uses an
extended catalog (or a Default catalog) that resides on a different data source.
To create an extended catalog:

Procedure
1.
2.
3.
4.

Open the Add catalog window.
Specify a unique name for the extended catalog in the Name field.
Select a CCSID code page for the extended catalog from the CCSID list.
Click OK. The new extended catalog is created.

Editing an extended catalog's properties
You can change the name or CCSID properties of an extended QMF catalog. You
can also change the CCSID property of the default QMF catalog.

About this task
To edit the properties of an extended or default QMF catalog:

Procedure
1. Open the Edit catalog window.
2. Specify a new name for the extended catalog in the Name field. You can not
change the name of the Default QMF catalog.
3. Select a new CCSID code page for the extended catalog from the CCSID list.
You can change the CCSID of the Default QMF catalog.
4. Click OK. The changes to the QMF catalog: property values are saved.

Creating a new multidimensional data source
You must add configuration information to your repositories for all
multidimensional data sources.
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About this task
Multidimensional data sources are accessed using XMLA. Multidimensional data is
organized by one or more dimensions. Multidimensional data structures are often
referred to as cubes. Queries for multidimensional data sources accessed using
XMLA are written in MDX.
To configure multidimensional data source information in a repository:

Procedure
1. Open the New Multidimensional Data Source wizard in one of the following
ways:
v Right-click the Multidimensional Data Sources node in the Repositories
view. Select New. Select Multidimensional Data Source from the pop-up
menu. The New Multidimensional Data Source wizard opens.
v From the File menu, select New. Select Other from the pop-up menu. The
New window opens. Expand the Repository folder. Select Multidimensional
Data Source. The New Multidimensional Data Source wizard opens.
2. In the Data Source Name field, type a name that will be used to identify the
data source in the repository. This can be any name.
3. DataQuant will use XML for Analysis (XMLA) via HTTP protocol to connect to
a multidimensional data source. You specify the URL that will point to the data
source in the HTTP URL field.
4. Select User ID and password are required to require the use of a user ID and
password when accessing this multidimensional data source. If the data source
allows access without a user ID and password, selecting this option will
override that allowance, and a user ID and password will be required to access
the data source.
5. Specify the user ID and password that will be used to access the data source in
the User name and Password fields. To test the connection, click the Test
Connection button.
6. Select the multidimensional data source that you want to add to the repository
from the Data Source list box. All the data sources that are located at the
specified URL address are listed in the Data Source list box. You can refresh
the list using the refresh button.
7. Optional: Type a comment that describes the data source in the Description
field. This comment will display with the properties for the data source.
8. Click Finish. The multidimensional data source is listed in the Repositories
view under the Multidimensional Data Sources node. You would repeat this
process for all multidimensional data sources that you want to be accessible
from the repository.

Results
Note: Support for resource limits or login mapping is not available for
multidimensional data sources.

Creating a new relational data source
You must add configuration information to your repositories for all relational data
sources.
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About this task
Relational data sources are accessed using JDBC. A relational data source stores
data in database tables. Each database table comprises a number of columns, and
one or more rows. Queries for relational data sources are written in SQL.
To create a new relational data source:

Procedure
1. From the Repositories view, right-click the repository to which you want to
add the relational data source configuration information. Select New >
Relational Data Source. The Add new relational data source name and
connection parameters page of the Create New Relational Data Source wizard
opens.
2. In the Connection type radio group, select JDBC or JNDI. If you selected
JNDI:
a. In the Data Source name field, specify the JNDI data source name and
location.
b. Click Advanced to specify any driver-specific connection string keywords
and their values that will be used for the database that is hosting the
repository storage tables. For information on any keywords that are
required by a selected database driver, consult the specific driver's
documentation.
if you selected JDBC
v In the JDBC Driver field specify the library for the JDBC driver that will be
used to access the database that hosts repository storage.
You can select from a drop-down list of libraries that you defined when you
set up the JDBC driver information. You can click the ellipsis (...) to open the
JDBC Libraries window where you can create additional JDBC driver
libraries.
Note: If you work with a DB2 for z/OS database, you can use the Direct
DRDA Connection. In contrast to JDBC libraries, the Direct DRDA
Connection comes with DataQuant and does not require additional driver
installation.
Note: The Direct DRDA Connection is supported only for DB2 for z/OS
Version 8, Version 9, and Version 10. Do not use it for DB2 LUW or DB2 for
iSeries.
See Using DRDA to connect to database repositories and data sources for
more information.
v In the JDBC URL list, specify the URL that points to the database that hosts
the repository storage within which the repository to which you want to
connect resides.
The format for the URL can be displayed in the list.
Note: You can also use the Build URL by URL Template dialog to form the
correct string. To do so, click Build URL to open the Build URL by URL
Template window. From the JDBC URL drop-down list, select the template.
In the table, specify the server, port, and database information and click OK.
The result URL string is added to the JDBC URL list.
v Click Advanced to specify any driver-specific connection string keywords
and their values that will be used when connecting to this shared repository.
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For information on any keywords that are required by a selected driver,
consult the specific driver's documentation.

3.
4.

5.

6.

7.
8.

Note: For the DB2® Type 4 UDB driver, to receive extended SQL exception
error messages, check the retrieveMessagesFromServerOnGetMessage
option in the Advanced JDBC Settings window.
v If you use the Direct DRDA Connection, bind packages by clicking Bind
Packages.
Click Set User Information. The User Information window opens.
Select the User ID and password are required check box to specify that user
information will be requested each time this data source is accessed. This check
box can be left clear if the data source does not require logon information, or if
the logon information is obtained using some other means, such as Kerberos or
Windows authentication.
Select the Try to use repository login and password to connect to this data
source check box to specify that before requesting logon information from the
user, the current repository login and password will be used to try and connect
to the data source (such as the case in Kerberos security).
Specify the user ID and password that will be used to access the data source in
the User name and Password fields. Click OK. The User Information window
closes and control returns to the Create New Relational Data Source wizard.
To test the connection, click Test Connection.
Click Next. The second page of the Create New Relational Data Source wizard
opens where you will enable the Database, QMF catalog, ER diagram, and
OLAP plug-ins for the data source.

Enabling data source plug-ins
The second step in configuring a relational data source is to enable one or more of
the available plug-ins that provide additional functionality for the data source.

About this task
For each relational data source that you configure in the repository you can enable
additional functionality that applies specifically to that data source. The available
plug-in(s) that you can enable include the following:
v QMF Catalog Plug-in: When you enable the QMF Catalog plug-in for a
relational data source, users can access the QMF catalog that you specify
whenever they are connected to the data source. They will be able to view and
access any objects that are saved in the QMF catalog and, if they choose, they
can save any new objects to the QMF catalog.
v OLAP: You would enable this plug-in if you are connecting to a legacy DB2
OLAP server that uses a SQL interface.
To enable plug-ins for a relational data source:

Procedure
1. Open the Enable data source plug-ins page of the Create New Relational Data
Source wizard.
2. To configure this data source to use a QMF catalog, select the QMF Catalog
Plug-in Enable Plug-in check box. The QMF Catalog Wizard opens. Upon
completion of the wizard's processing, control returns to the Enable data source
plug-ins page of the Create New Relational Data Source wizard.
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3. The QMF catalog will be available to this relational data source. By default, the
node label for the QMF catalog as it will appear in the repository will be QMF
Catalog. You can specify a unique name. Type the name that you want to use
to identify this QMF catalog in the Catalog Label field. Optionally, you can
type a comment that describes the QMF catalog in the Comment field.
4. To change any of the QMF catalog plug-in parameters, click Parameters. The
QMF Catalog Plug-in Parameters window opens. Upon completion of
modifying the parameters, control returns to the Enable data source plug-ins
page of the Create New Relational Data Source wizard. You can also open the
QMF Catalog Plug-in Parameters window from the Repository Explorer view
by right-clicking a data source, selecting Properties from the pop-up menu, and
selecting Plug-ins from the Properties list.
5. By default, the node label for all of the native database objects for this
relational data source as it appears in the repository will be Database. You can
specify a unique name. Type the name that you want to use to identify these
database objects in the Label field. You can also choose to type a comment that
describes the native database objects in the Comment field.
6. Select the OLAP check box in the Additional Plug-ins list box if you are
connecting to a legacy DB2 OLAP server that uses a SQL interface and you
want to run OLAP queries against the data source. Optionally you can type a
comment in the field to the right of the OLAP check box.
7. Click Next. The third page of the Create New Relational Data Source wizard
opens where you will select the resource limits provider for the data source.

Selecting the resource limits provider
The third step in configuring a relational data source is to specify whether the
resource limits that will govern access to the data source will be provided from the
repository or from the QMF catalog.

About this task
To specify the resource limits provider for a relational data source:

Procedure
1. Open the Select resource limits provider page of the Create New Relational
Data Source wizard.
2. From the Resource limits provider drop-down list, select where the resource
limits for this data source are defined. Your choices are:
v Repository if the resource limits are defined in the repository.
v QMF Catalog if the resource limits are defined in a QMF catalog. This option
is only available if you have enabled the QMF Catalog plug-in for the data
source.
3. To add, edit, or delete resource limits, right-click the data source in the
Repository Explorer view (after it has been created) and click Properties from
the pop-up menu. Select Resource Limits from the Properties tree. You can
add, edit, and delete resource limits groups, schedules and user assignments.
4. Click Finish. The Repositories view lists the data source configuration
information under a folder named Relational Data Sources. The objects for
each data source will be organized in three folders that will include database
objects, QMF catalog objects if the QMF catalog was enabled, and OLAP objects
if the OLAP plug-in was enabled. You have completed the process of
configuring a relational data source in the repository. You would now
customize the feature set of the data source.
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Note: From the Repositories view of the data source, you can view and move
the listed objects. However, if you want to run any objects you must be
connected to the repository. To connect to the repository you must set up
repository connection information if it has not been created. Click the
repository connection information for the repository that is listed in the
Repository Connections view. When you are connected to the repository select
the object to run from the Repository Explorer view.
5. You can selectively perform any of the following to customize the feature set of
the data source:
v Set up login mapping for the data source.
v Add data source information to a workspace.
v Set up customized workspaces and assign the users and groups that will be
allowed to use them.
v Assign the users and groups permission to access any repository object.
v Create, edit, or delete resource limits groups, schedules, and resource limit
values.
v Set up repository connections.

Specifying additional parameters
You can specify additional data source parameters on the Information page of the
data source Properties window.

About this task
You must specify the settings for additional data source parameters that determine
how the data source retrieves data. To specify these additional parameters:

Procedure
1. From the Repository Explorer view, right-click the data source that you want to
edit and select Properties from the pop-up menu. The Properties window
opens.
2. Select Information. The Information page opens.
3. Specify the settings in the Additional parameters table. Valid additional
parameters include:
Emulate Host QMF Column Naming (DB2 Only)
Specifies whether the data source emulates the column naming
conventions of the host QMF catalog. This option is only valid for DB2
data sources.
Enable Spatial Extensions
Specifies whether extensions are enabled for spatial data that is stored
in the data source.
Schema Retrieval Method
Specifies how schemas are retrieved from the database. If you select
getTables, the schemas are organized by their table names. If you select
getSchemas, the schemas are organized by their owners.
Do Not Access Database to Retrieve Query Metadata
Specifies whether query metadata is retrieved from the host database.
Use this parameter to reduce the time of running the query and display
the result set faster. It is FALSE by default. When this parameter is set
to TRUE, the application does not refer to database and does not
retrieve the metadata. So the result set is displayed faster, but the
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amount of R/W (read and write) queries is smaller than when the
metadata are retrieved and this parameter is set to FALSE.
4. When you finished specifying the additional parameters, click Apply. The
changes are saved to the data source.
5. Click OK. The Properties window closes.

Creating a Hive data source
You can create Hive data sources to work with Apache Hadoop, which is the open
source software framework, used to reliably managing large volumes of structured
and unstructured data.

Before you begin
Make sure you have defined the Hive driver library JAR files so that DataQuant
can connect to Hive data sources.

About this task
Hive data source is a data warehouse infrastructure that provides data
summarization and ad hoc querying. Hive data sources are accessed using special
drivers for JDBC. The current JDBC interface for Hive only supports running
queries and fetching results.
To create a Hive data source:

Procedure
1. Select File > New > Other > Repository > Hive Data Source. The Create New
Hive Data Source wizard opens.
2. Type the data source name in the Data Source Name field.
3. Specify the necessary parameters in the Connection Parameters area. You must
set the Host name, Port number, and Database name.
4. Click Set User Information button to specify the necessary user parameters.
5. Click Advanced button to select the advanced parameters supported by the
installed Hive driver.
6. In the Description field, you can enter the description of the created data
source.
7. Click Finish to create the Hive data source and close the Create New Hive
Data Source wizard.

Creating Cloudant data sources
You create a Cloudant data source to define a connection to a Cloudant database
from DataQuant for Workstation and DataQuant for WebSphere.

About this task
Cloudant is a NoSQL database as a service that stores data as a collection of JSON
documents.
To create a Cloudant data source:
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Procedure
1. From the main menu, select File > New > Other to open the "Select a wizard"
page of the New wizard.
2. Expand the Repository folder, select Cloudant Data Source, and click Next to
open the Create Cloudant Data Source wizard.
3. In the Data Source Name field, enter the name that you want to use for the
data source.
4. In the URL field, enter a Cloudant database URL.
5. Click Set User Information and in the User Information dialog, specify the user
authentication settings for accessing the data source.
v Select the User ID and password are required check box to always request
the user information when users access the data source.
v Select the Try to use repository login and password to connect to this data
source check box to request the logon information from the user, if the
repository login and password are not available for accessing the data source.

6.

7.
8.
9.

Note: This option is available only for secure repositories.
v Select the Allow users to save password check box to enable users to save
the password for the data source.
In the User name and Password fields, specify the credentials that you want to
use for accessing the data source and click OK to close the User Information
dialog.
To test the connection to the data source, click Test Connection.
In the Comment field, you can enter the description to the data source. This
description is displayed with the data source properties.
Click Finish to close the Create Cloudant Data Source wizard and add a new
Cloudant data source.

Results
The created Cloudant data source is added under the Cloudant Data Sources
node.

Populating the repository
After configuring the repository storage and creating the shared repository, you
need to populate the repository.

About this task
By populating the repository you are setting up the workspace for your users,
determining what will be exposed to them when they start DataQuant for
Workstation or DataQuant for WebSphere.

Creating a virtual data source
Create a virtual data source to tailor the way users view enterprise data. Virtual
data sources introduce a database metadata layer that allows you to optionally
hide the complexities of your underlying database structures.

About this task
This feature provides two fundamental advantages:
Chapter 3. Configuring the environment

61

1. Users are shielded from the complexities of your underlying data model.
Obscure column names and table names can be replaced with user-friendly
variants and complex table joins can be represented by a single virtual table,
much like a database view.
2. Users are insulated from database schema changes. Database administrators can
readily make changes to the underlying database schemas without affecting
DataQuant dashboards, queries, and reports, provided that the same database
metadata model remains the same.
Virtual data sources offer the following key facilities:
v Ability to create a virtual table, derived from one or more physical database
tables, with the ability to rename any or all of the underlying columns.
Administrators can also omit one or more underlying table columns from the
virtual table variant. For example, one can represent table XYZ123, which
contains columns N1312, N0983 and N2903, with a virtual table called
CustomerData, with columns CustomerName and OrderDate (renaming the first
two columns and omitting the third column).
v Ability to add virtual tables to a single virtual database, each of which draws
data from an independent data source. For example, you can create a database
that contains tables from both DB2 and SQL Server databases. Users can run
queries that join these disparate tables from two or more databases.
To create a new virtual data source:

Procedure
1. Open the New Virtual Source wizard in one of the following ways:
v Right-click the Virtual Data Sources node in the Repositories view. Select
New > New Virtual Data Source from the pop-up menu. The New Virtual
Source wizard opens.
v Select File > New > Other. The New window opens. Expand the Repository
folder. Select New Virtual Data Source. The New Virtual Source wizard
opens.
2. Enter a name for the new virtual data source in the Data Source Name field.
3. Specify the virtual data source parameters in the Parameters area:
a. Select In-memory check box to create an inner in-memory database for the
work of the virtual data source.
b. If you want to save the inner database in to the file system, select Back up
server on shutdown check box. Then when you shut down the application
in normal mode the database will be saved to the file system and retrieved
at the next launch of the application.
4. Click Finish. The new virtual data source is listed under the Virtual Data
Sources node.

Results
You have added a new virtual data source.
The new virtual data source is displayed under the Virtual Data Sources node.

What to do next
You can now add tables to the virtual data source.
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Adding tables to virtual data sources
You can add tables to your virtual data sources.

About this task
To add tables to a virtual data source:

Procedure
1. From the Repositories view, expand the virtual data source until you expose
the Tables node.
2. Populate virtual data sources with tables.
Virtual tables can be based on physical tables or queries. You can create the
queries that will be the source of the virtual table. When creating these queries
you will specify their associated virtual data source. You will save the query.
Tables can be selected directly from any relational data source. You add a table
or query to the Tables node in one of two ways:
v From the Repositories or Repository Explorer view, select the table or query
that you want to add to the virtual data source. With the mouse button
pressed, drag the table to the virtual data source you created.
v From the Repositories or Repository Explorer view, right-click the table or
query that you want to add to the virtual data source and select Copy from
the pop-up menu. Right-click the Tables node and select Paste from the
pop-up menu.

Results
Virtual data source tables are displayed to users in their workspaces just as if they
were regular relational database tables. They can write queries that use the tables.

Virtual data source editor
Use the virtual data source editor to manage data source content and structure and
to administer user and user group authorization to a data source.
To open a virtual data source in the virtual data source editor:
1. From the Repository Explorer view, locate the virtual data source you want to
work with and double-click it.
2. The virtual data source opens in the virtual data source editor.
The virtual data source editor is organized by tabs into two sections:
v A Structure section, from which you can modify the structure of a virtual data
source
v A Security section, from which you can administer user and user groups
authorization to the data source repository.

Overview of the Structure section of the virtual data source editor
The Structure section contains two panes: Repository Explorer and Tables.
In the Repository Explorer pane you can select the tables to add to the virtual data
source.
To add a table, select it and use the command button. The newly added table
displays in the Tables pane.
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From the Tables pane, you can modify the table in the following ways:
v Add new columns to the table by using Add Column.
v Change the position of the row column by using the Move Up and Move Down
buttons.
v Edit table SQL by using the pop-up menu.
v Delete a table or column from the table by using Delete.
v Edit a column with expression by selecting it and using Edit .
v Specify cache expiration schedules for tables by using Assign Expiration
Schedules.
When you select a table from the Table pane, Add column is activated and the
Add column window opens.
Two user actions that can be completed from the Add column window:
v Select available columns of the table [table name].
This option is available when there are columns in the original table that were
deleted from the virtual one.
v Or, enter an expression here.
You can form a conditional expression to be applied to a new column.

Overview of the Security section of the virtual data source editor
The virtual data source editor is divided into four sections:
v A Tables pane showing the tree of the virtual tables.
From the tree of virtual tables, select the objects to which you want to apply
authorization rights.
v A Permissions pane listing the owners and the permissions currently authorized
for them.
For more information about permissions, see Assigning users and groups
permission to use repository objects .
v A Groups or users names pane showing the list of the users and user groups to
which access permissions can be granted.
You can filter the list by selecting or clearing the Show users and Show groups
check boxes.
v A Row level security conditions pane for entering the titles of specific rows to
be displayed to a particular user.
Note: These titles must be entered according to the SQL syntax rules.
Security section is available only when you work with a secure repository.
To grant user-specific permissions, select the user in the Groups or users names
pane and use the command bar to insert the Group or users names in the
Permissions pane. In the Permissions pane you can select or clear the check boxes
that apply to each permission.

Scheduling cache expiration for virtual data sources
You can schedule caching for virtual data sources and tables that they store.
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About this task
When you schedule caching for a virtual data source, records from the tables that
are stored in this virtual data source are updated with the specified frequency. If
you open one of these tables, its records will be retrieved from cache rather than
from the virtual data source. You can also schedule caching for individual tables
within a virtual data source.
To create a cache schedule for a virtual data source:

Procedure
1. Open the Create New Expiration Schedule wizard in one of the following ways:
a. Select File > New > Other > Virtual Data Source Schedule.
b. In the Repositories or Repository Explorer view, right-click the required
virtual data source and select New > Virtual Data Source Schedule.
2. From the Data source list, select the data source to which you want to specify
the cache expiration scheduler.
3. In the Schedule name field, enter the name you want to use for this schedule.
4. In the Data Expires area, specify the period of the cache expiration. The
available options are:
a. Hourly: Select this option to specify that the same cache data will be used
for one hour period.
b. Daily: Select this option to specify that the same cache data will be used for
a 24 hour period.
c. Weekly: Select this option to specify that the same cache data will be used
for a period of 7 days.
d. Monthly: Select this option to specify that the same cache data will be used
for a month.
e. At specific date: Select this option to specify that the same cache data will
be used until a specific date is reached. If you select this option, the cache
will be updated on the specific date.
f. Never expires: Select this option to specify that the same cache data will
always be used. If you select this option, the cache will never be updated.
g. Always expired: Select this option to specify that the data will always be
updated every time a query is run against this virtual data source.
5. If you selected Hourly, Daily, Weekly, Monthly, or At specific date, click
Next.
6. Depending on the type of schedule that you are creating one of the following
variations of the Set schedule properties page of the wizard opens:
a. If you selected Hourly, specify the date and time that the hour period will
start in the Begin date and the Begin time fields. In the Expiration Interval
area, specify expiration interval in Hours and Minutes fields.
b. If you selected Daily, specify the date and time that the 24 hour period will
start in the Begin date and the Begin time fields. You specify when the 24
hour period will occur in the Data Expires area:
v Select Daily to specify that the 24 period will occur every day.
v Select Each to specify that the 24 hour period will occur every number of
days and select the number from the list.
v Select Days of week to specify that the 24 hour period will occur on one
or more specific days. You must select the check boxes for the proper
days.
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c. If you selected Weekly, specify the date and time that the week will start in
the Begin date and the Begin time fields. You can select a number from the
Each week list to specify that the 7 day period will occur every number of
weeks. In the Days of Week area, specify particular days on which the
cache will be updated.
d. If you selected Monthly, specify the date and time that the month will start
in the Begin date and the Begin time fields. You can enter a specific day in
the Day field or to specify that data retrieval will occur on a specific day of
the week in the month in the Or field. In the Select Months area, specify
the required months.
e. If you selected At specific date, specify the date and time that will trigger
data retrieval in the Date and time list. Click the cell, the ellipsis (...)
appears. Then click the ellipsis (...) to open a calendar where you will select
the date and time.
7. Click Finish. The schedule is created and listed in the Schedules node of the
particular virtual data source in the Repository Explorer view.

Specifying settings of cache expiration schedules in virtual data
sources
You can use expiration schedules for virtual data sources and tables that they store
on the Cache Settings page of virtual data source Properties window.

About this task
When the Use expiration schedules check box is clear the caching expiration mode
equals Always Expired for a virtual data source. Records from the tables stored in
this virtual data source are updated each time on-demand.
To specify particular cache schedule for virtual data sources or their tables:

Procedure
1. From the Repositories or Repository Explorer view, right-click a virtual data
source and select Properties.
2. In the Properties for [data source] window, select Cache Settings.
3. On the Cache Settings page, select the Use expiration schedules check box.
The schedule expiration settings become available.
4. From the Default expiration schedule list, select the schedule that you want
to use as the default one for the whole virtual data source.
Note: A created virtual data source has Always Expired default settings. To add
more schedules create them in Create New Virtual Data Source Schedule
wizard.
5. To assign a particular cache expiration schedule to a particular table click the
Schedule name column of the table the settings of which you want to modify
and select the required scheduler from the list of available ones.
Note: If tables contain any substitutional variables, only Always Expired
expiration schedule is applied to such tables.
6. If you have any tables that require authorization for accessing them, you must
specify the authorization settings for the virtual data source. Click the Manage
Authorization button. The Manage Authorization dialog opens.
7. All the data sources that require authorization are listed there. This
authorization data will be used for updating the cache. Click Login column
for the required data source. The Edit Data Source Login dialog opens.
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8. Enter the proper values in the Login and Password fields and click OK.
9. When you finish specifying authorization data for all required data sources,
click OK in the Manage Authorization dialog.
10. Click Apply and then click OK to close the Properties for [data source]
window.

Setting up workspaces
Use the workbench to create workspaces for DataQuant for Workstation users.
In Eclipse, workspaces are used to organize a collection of projects. In DataQuant
for Workstation, users can create a workspace to house projects that hold the
artifacts (data sources and repository objects) needed to build interactive visual
tools, such as visual dashboards and reports.
As the administrator you can choose to have your DataQuant for Workstation
users work with repository objects from a workspace, or directly from the
repository. Every repository that you create has one default workspace that is
created automatically. Initially, all users have access to the default workspace.
The first step to setting up a workspace is to specify the contents of the workspace.
You can then assign users and groups permission to use the workspace and the
workspace objects.

Advantages of using workspaces
There are advantages to having your users access repository objects from a
workspace. If you have chosen the Internal or LDAP security option for the
repository, you can create one or more workspaces and assign specific users and
groups varying levels of access to the entire workspace or to specific objects within
the workspace. If you have chosen no additional security for the repository, then
one or more workspaces can help organize repository objects.
If you choose not to use workspaces and have your DataQuant for Workstation
users access repository objects directly from the repository, you should recommend
they alter the views that are opened by default with the User perspective. Instead
of opening the Workspaces view by default, change the perspective so that the
Repository Explorer view opens by default.

Adding content to the workspace
You can populated the workspaces you create by adding data source and
repository objects that will be available to the users of the workspace.

About this task
Initially, every workspace, including the default workspace created automatically
when you created the repository, is empty.
This task describes how to add content to a workspace.
To add content to a workspace, perform the following procedure:
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Procedure
1. From the Repositories or Repository Explorer view select an object (such as a
data source, folder, query, dashboard, report) that you want to add to the
workspace. The object that you select must be available to you in the repository
to which you are currently connected.
2. With the mouse button pressed drag the object to the workspace folder. Release
the mouse button. You can also right-click the object and select Copy from the
pop-up menu, then right-click the workspace folder to which you want to add
the object.
3. Depending on the type of object that you selected a pop-up menu opens. One
or more of the following options become available:
v Copy Here to make a copy of the object in the workspace.
v Move here to move the object from the repository to the workspace.
v Create link here to create a link to the object. Each time a user or group
accesses the object they will actually link to the resource.
v Create offline entry to create an offline entry to the object. The Create
Offline entries window opens. Check each of the entries that you want to
copy (in their entirety). Offline entries allow you to work with an object from
a data source without actually accessing the data source. Users are
responsible for keeping offline entries in the workspace synchronized with
the actual contents of the repository.
v Paste as Offline is the same as Create offline entry except the object was
copied to the clipboard rather than dragged to the workspace.

Adding a workspace as a user
You can optionally choose to set up additional workspaces for your users and
groups.

About this task
To add a workspace as a user, perform the following procedure:

Procedure
1. Select File > New > Other. The New window opens. Expand the Repository
folder. Select Workspace. The Create New User Workspace wizard opens.
2. Specify the name for the new workspace in the Name field.
3. Specify a comment that describes the workspace in the Comment field.
4. Click Finish. After you have created a workspace, you specify what data source
information and objects will be available in the workspace, and specify the user
and groups that will have permission to use the workspace.

Working with ER diagrams
Use ER diagrams to specify relationships among columns of related tables and
store these relations.
For example, a table stores the staff data for everyone in a company. This table
includes a column that is named DEPT that stores the identifier of the department
in which an employee works. Another table stores the organization data of each
department in the company. This table includes a column that is named DEPTNAME
that stores the name of each department in the company. These two tables are
related, as they have columns that can be easily joined. But when a user opens
either one of these tables, this relationship is not readily apparent. By creating an
ER diagram that includes these two tables and all of their possible joins, you can
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make this relationship much easier to see. Now when users open these tables, the
ER Diagrams editor displays all of the relationships that you saved, and users can
make more effective and dynamic reports.

Creating ER diagrams
Use ER diagrams to create abstract and conceptual representations of relational
databases that can be used for building conceptual connections among table
columns.

About this task
To create an ER diagram:

Procedure
1. From the main menu, select, select File > New > Other. The New window
opens.
2. Expand the DataQuant Objects folder, select ER Diagram, and click Next. The
Create New ER Diagram wizard opens.
3. Enter a name for the ER diagram in the Name field.
4. Enter the data source that you want to associate with the ER diagram in the
Data source list. The Data source list is populated with all data sources in the
repository.
5. Click Finish. The new ER diagram is added to the data source and the ER
Diagram editor with this diagram opens.
Editing ER diagrams:
When you created an ER diagram manually, you must specify the tables and
column joins that you want to include in the entity relationship.
About this task
When you include tables that have possible column connections in your ER
diagram, you make the process of building queries and reports much easier for
your users.
To edit an ER diagram:
Procedure
1. Double-click the ER diagram that you want to edit. The ER Diagram editor
opens. The associated data source is displayed in the left pane of the editor.
2. Expand the Tables node of the Database folder.
3. Drag each of the tables that you want to include in the diagram to the right
pane of the editor. A visual representation of each table that you add is
displayed.
4. To set up join conditions between tables, select a column from one table and
drag it to a column in another table. A connecting line is drawn between the
joined columns. You can set up multiple join conditions.
5. To edit a join condition, right-click a connection line and select Edit. The Join
Tables window opens.
6. Select the type of join for linking two tables. The available join types are:
v Inner join includes only those rows with matching values in both tables in
the query results.
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v Left outer join includes all the rows from the left table and only the rows
from the right table that match with rows from the left table in the query
results.
v Right outer join includes all the rows from the right table and only the
rows from the left table that match with rows from the right table in the
query results.
v Full outer join includes s all rows from both tables in the query result.
7. Click Change. The new join conditions are saved.
8. To delete a join condition, right-click a connection line and select Delete.

9.

10.
11.

12.

13.

Note: All the join modifications (adding, editing, and deleting) that you
specify for two tables in an ER diagram are automatically applied to these
tables in other ER diagrams in this data source. If you add only one of the
joined tables to an ER diagram, you can add the other table automatically by
right-clicking the ER diagram and selecting Add Linked Tables.
To add a textual note to the ER diagram, right-click in the ER diagram editor
and select Add Text. A text box is displayed. You can add text, resize the text
box, and move the text box from one point in the diagram to another. Use text
notes allow to convey additional information about the tables and joins in the
ER diagram to your users.
To delete a text box, right-click it and select Delete.
To show or hide a column of a table, right-click the column name in the table
diagram and select Hide/Show columns. The Hide/Show Columns window
opens and contains all of the available table columns.
Select a column's associated check box to show the column, clear it to hide the
column, and click OK. The Hide/Show Columns window closes and the
changes to the table diagram are displayed.
When you are finished adding tables and configuring join conditions, click the
Save icon. The edited ER diagram is saved to the ER Diagrams folder of the
data source. Now, when a user builds a query that includes one or more of
these tables, the join conditions that you configured are automatically added
to the query and displayed in the Query Builder editor.

Creating ER diagram folders
You can create entity relationship diagram folders to add a folder for ER diagrams
to the data source.

About this task
To create an ER diagram folder:

Procedure
1. From the main menu, select, select File > New > Other. The New window
opens.
2. Expand the DataQuant Objects folder, select ER Diagrams folder, and click
Next. The Create New ER Diagrams Folder wizard opens.
3. Specify attributes for an ER Diagrams Folder:
a. Enter a name for the ER diagram folder in the Name field.
b. Enter a parent folder for the new ER diagram folder in the Parent folder
field.
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c. Optional: If you want to add a comment to describe the new folder with ER
Diagrams, type it in the Comment field. This comment is displayed in the
properties of the created ER diagram folder.
4. Click Finish. The Create New ER Diagrams Folder wizard closes and the new
ER diagram folder is displayed under the parent folder in the data source.

Results
You can create new ER diagrams, copy the existing ones, or move them to ER
diagram folders for grouping. You can also populate ER diagram folders with ER
diagrams automatically.

Populating ER diagrams automatically
You can specify the tables to which you want to create joins automatically and
QMF populates existing ER diagram folders with ER diagrams for these tables.

Before you begin
You must have an ER diagram folder to populate it.

About this task
To populate ER diagrams:

Procedure
1. In the Repository Explorer view, right-click the ER diagram folder that you
want to populate and select Populate.
2. In the Set Name Filter window, you can specify the following criteria:
a. In the Object owner field, specify the identifier that owns the tables that
you want to join in ER diagrams. You must specify the owner in the correct
format for identifiers. You can use a pattern with a wildcard character in
this field to match multiple owners.
b. In the Object name field, specify the identifier that names the tables join in
ER diagrams. You must specify the name in the correct format for
identifiers. You can specify a matching pattern with a wildcard character to
match multiple names.
3. Click OK to close the Set Name Filter window and start the populating
process.

Results
When the ER diagram is built, it is displayed in the ER Diagram editor. For
detailed information about editing the created ER diagrams, see the Editing ER
diagrams topic.

Setting up environments
An environment is a collection of data source definitions.
Environments allow you to point a repository object to a different data source
without making any changes to the objects themselves. This can be useful for
testing purposes when it is not recommended to test objects against production
data. You can define a test environment that points to a test data source and use it
for development. End-users can use a production environment once all objects have
been tested.
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One default environment always exists and cannot be deleted.
When you create a new environment, it reads data source definitions from the
default environment. You can then change those definitions so they point to
different locations.
If you have more than one environment available, you can switch between them.

Creating a new environment
You can create a new environment using the Create New Environment wizard.

About this task
To create a new environment:

Procedure
1. From the Administrator perspective, select File > New > Other. The New
window opens.
2. Expand the Environments folder, select Environment and click Next. The
Create New Environment wizard opens.
3. Specify a name for the environment in the Environment Name field and click
Next.
4. Use the check box to select the data sources that you want to include in the
environment from the Environments Contents table. Unchecked items use
original data source definitions (as defined in the default environment).
5. Select the connection string you want to specify and click Test Connection.
The Log on to Data Source window opens. The Connection Settings wizard
opens.
6. Specify a user name in the User name field and a password in the Password
field and click OK. The system displays The connection to the data source
was established.
7. To change the connection string of the data source, select the connection string
that you want to edit and click the ellipsis (...). The Connection Settings
wizard opens.
8. Either specify a new JDBC URL in the JDBC URL field or use the Build JDBC
URL field to build the JDBC URL.
9. Click Advanced to specify additional JDBC settings. The Advanced JDBC
Settings wizard opens.
10. Enter any required driver-specific connection string keywords for this data
source and click OK.
Note: For more information on any keywords that might be required or
supported by the selected driver, consult the driver's documentation.
11. Click OK. The Connection Settings window closes and control returns to the
Create New Environment wizard.
12. Click Finish. The Create New Environment wizard closes and the new
environment is listed under the Environments node.

Editing environment connection settings
You can edit connection settings and add data sources to an environment by using
the Edit Environment dialog.
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About this task
To edit the connection settings from an existing environment:

Procedure
1. From the Repositories view, expand the Environments folder, right-click the
environment that you want to edit and select Edit. The Edit Environment
window opens.
2. Use the check box to select the data sources that you want to include in the
environment from the Environments Contents table. Clear items use original
data source definitions (as defined in the default environment).
3. Select the connection string you want to specify and click Test Connection.
The Log on to Data Source window opens. The Connection Settings wizard
opens.
4. Specify a user name in the User name field and a password in the Password
field and click OK. The system displays The connection to the data source
was established.
5. To change the connection string of the data source, select the connection string
that you want to edit and click the ellipsis (...). The Connection Settings
wizard opens.
6. Either specify a new JDBC URL in the JDBC URL field or use the Build JDBC
URL field to build the JDBC URL.
7. Click Advanced to specify additional JDBC settings. The Advanced JDBC
Settings wizard opens.
8. Enter any required driver-specific connection string keywords for this data
source and click OK.
Note: For more information on any keywords that can be required or
supported by the selected driver, consult the driver's documentation.
9. Click OK. The Connection Settings window closes and control returns to the
Edit Environment window.
10. Click OK. The Edit Environment window closes and the changes to the
environment are saved.

Setting permissions
The administrator can manage user and user group permissions to access data.
Permissions are applied to the repository.

Assigning users and groups permission to use repository
objects
You can assign security permission levels for users and groups and control their
access to repositories and any object in the repository.

About this task
Security permission levels for users and groups can only be assigned for secured
repositories (those created with Internal or LDAP security). You can apply
permission levels to any object that is listed in the repository including for
example, directories, folders, workspaces and individual query and reporting
objects.
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Only users who have been identified as DataQuant administrators can assign
security permission levels to users and groups. In addition, users that have been
granted full permission privileges can modify permissions that have been applied
to objects.
To assign users and groups different levels of permission to use repository objects:

Procedure
1. Right-click any repository object that is listed in the Repositories, Repository
Explorer or Workspaces views. Select Properties from the pop-up menu. The
Properties window opens. Select Security from the sidebar. The Security page
of the window opens.
2. Each user or group that has been granted permission to use this repository is
listed in the Group or user names list. To add additional users and groups,
click the Add button. The Select Users or Groups window opens.
3. Each user and group can be assigned different levels of permissions for the
selected repository object. The levels of permission that are available are listed
in the Permissions for list. To assign a level of permission, select a group or
user and check the corresponding check box for the level of permissions that
you want to assign. Your choices are:
v Full: grants the user or group permission to perform all functions (edit, view,
browse and delete) on the repository object. In addition, full permission
allows users to modify permissions that have been assigned to the repository
object.
v Edit: grants the user or group permission to make changes to, as well as
view and browse, the repository object.
v Browse: grants the user or group permission to see the contents of the
repository object. For example, browse privileges on a directory in the
repository allows a user to see what is inside that directory. Browse
privileges on a query object allows a user to open and run the query object.
v View: grants the user or group permission to see the repository object listed
in the repository. For example, view privileges on a directory in the
repository allows the user only to see the directory. The user cannot open the
directory or see the contents of the directory. View privileges on a query
object allow a user only to see the object. They cannot open or run the object.
v None: denies the user or group permission to see that the repository object is
included in the repository.
4. Click Apply permissions to child folders and objects to apply the selected
level of permission to all of the folders and objects that are under the object to
which the permission is being applied.
5. To remove permission from a user or group, select the user or group from the
Group or user names list. Click Remove. The user or group will be removed
from the list.
6. Click Apply.
7. Click OK.

Selecting the users and groups that are allowed repository
object access
You must select the users and groups that will be allowed to access a repository
object.
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About this task
To select the users and groups that will be allowed access to a repository object:

Procedure
1. Right-click any repository object that is listed in the Repositories, Repository
Explorer or Workspace views. Select Properties from the pop-up menu. The
Properties window opens. Select Security from the tree. The Security page of
the window opens. Click Add. The Select Users or Groups window opens.
2. The users and groups that are available for assignment are listed in the Group
or user names list box. These are the users and groups that you either specified
using the Users and Groups view if you selected Internal repository security,
or obtained from your LDAP server if you selected LDAP repository security.
3. To filter the users and groups that are listed you can:
v Use the Name filter field.
v Clear the Show users check box. Only Groups will be listed.
v Clear the Show groups check box. Only Users will be listed.
4. To select a user or group and grant them permission to use this repository
object, select the user or group from the Group or user names list box and click
the move right (>>) icon. The user or group is now listed in the Selected
objects list box.
5. To remove a user or group from the Selected objects list box, click the move
left (<<) icon.
6. Click OK. The Select Users or Groups window closes. The users or groups that
you have moved to the Selected objects list box are added as users and groups
that can access the repository object. They are listed in the Group or user
names list box of the Properties dialog.

Assigning users and groups administrative permission for
database-based security
Database-based security takes the security settings of the host database and uses
these settings to protect the shared repository.

Before you begin
Make sure you are operating on the RSBI objects.

About this task
To determine if a user has administrator authorization, DataQuant calls for the
contents of RSBI.ADMIN_VIEW and runs the following SQL statement:
SELECT COUNT(*) FROM RSBI.ADMIN_VIEW WHERE AUTHID=:OWNER

Where OWNER is the user login. If this statement returns the value that is greater
than zero, the user is the repository administrator.
The database-based security for shared repositories requires SYSADM authority on
DB2 and DBA authority on Oracle. Without this authority users cannot administer
the repository.
For DB2 databases you can populate the RSBI.AUTHID_TABLE with PRIMARY_IDs and
SECONDARY_IDs pairs of users and groups, where the group does have SYSADM
authority.
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Results
The ADMIN_VIEW will have the list from SYSIBM.SYSUSERAUTH with the addition of the
PRIMARY_IDs from the AUTHID_TABLE, whose SECONDARY_IDs are also in the list from
SYSIBM.SYSUSERAUTH.

Example
The following examples illustrate the QMF authorization processes on different
server types:
DB2 for z/OS
CREATE VIEW "RSBI"."ADMIN_VIEW" (
"AUTHID")
AS
SELECT A."GRANTEE" AS "AUTHID"
FROM "SYSIBM"."SYSUSERAUTH" A
WHERE A."SYSADMAUTH" IN (’G’, ’Y’)
UNION
SELECT A."PRIMARY_ID" AS "AUTHID"
FROM "RSBI"."AUTHID_TABLE" A
INNER JOIN
"SYSIBM"."SYSUSERAUTH" B ON
B."GRANTEE" = A."SECONDARY_ID"

DB2 for iSeries
CREATE VIEW "RSBI"."ADMIN_VIEW" (
"AUTHID")
AS
SELECT "AUTHID"
FROM "RSBI"."ADMIN_TABLE"

DB2 LUW
CREATE VIEW "RSBI"."ADMIN_VIEW" (
"AUTHID")
AS
SELECT A."GRANTEE" AS "AUTHID"
FROM "SYSIBM"."SYSDBAUTH" A
WHERE A."DBADMAUTH" = ’Y’
UNION
SELECT A."PRIMARY_ID" AS "AUTHID"
FROM "RSBI"."AUTHID_TABLE" A
INNER JOIN
"SYSIBM"."SYSDBAUTH" B ON
B."GRANTEE" = A."SECONDARY_ID"

DB2 for z/VM
CREATE VIEW "RSBI"."ADMIN_VIEW" (
"AUTHID")
AS
SELECT A."NAME" AS "AUTHID"
FROM "SQLDBA"."SYSUSERLIST" A
WHERE A."AUTHOR" = ’’
AND A."DBAAUTH" = ’Y’
UNION
SELECT A."PRIMARY_ID" AS "AUTHID"
FROM "RSBI"."AUTHID_TABLE" A
INNER JOIN
"SQLDBA"."SYSUSERLIST" B ON
B."NAME" = A."SECONDARY_ID"
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Oracle
CREATE VIEW "RSBI"."ADMIN_VIEW" (
"AUTHID")
AS
SELECT A."GRANTEE" AS "AUTHID"
FROM "SYS"."DBA_ROLE_PRIVS" A
WHERE A."GRANTED_ROLE" = ’DBA’

Setting up login mapping for a data source
Login mapping enables a user to login to a repository and gain access to one or
more of the database data sources that have been configured in that repository
using a single user ID and password.

About this task
With login mapping, administrators can set up users so that they can login to a
repository and access any data source without specifying another user ID and
password that is specific to the database data source. By setting up login mapping,
users do not have to continually reenter login information every time they access a
database data source, and they do not have to know the login information for each
database data source.
You set up login mapping for each data source that you include in the repository.
Login mapping can only be set up for data sources that reside in protected
repositories. Protected repositories are those that were created with the security
option Internal or LDAP.
To set up login mapping for a data source:

Procedure
1. Right-click a data source in the Repositories or the Repository Explorer view.
Select Properties from the pop-up menu. The Properties window opens. Select
Login Mapping from the tree. The Login Mapping page of the window opens.
All users and groups that have been defined for the repository are listed in
the Data source login list list box. This list is empty if you have not defined
any users or groups.
2. To set up mapping for a user or group, highlight a user or group and click the
Edit data source login icon above the list box. The Edit Data Source Login
window opens.
3. Specify the user ID that will be used to login to the database data source in
the Login field.
4. Specify the password that will be used to login to the database data source in
the Password field.
5. Verify the password by retyping it in the Verify password field.
6. Specify the priority that will be placed on this login information in the
Priority field. You can enter any numerical value in this field with the value
of 1 having the lowest priority. The Priority value is used to determine what
login mapping ID and password will be invoked for a user that is a member
of multiple groups. Consider the following:
v User X is a member of two groups, Group A and Group B. You have
assigned a login mapping ID and password for Group A that gives all users
assigned to Group A a certain level of access to the data source. You have
assigned a login mapping ID and password for Group B that gives all users
assigned group B a lesser level of access to the database data source. As a
member of both groups, when User X accesses the data source, it is unclear
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what login information that should be used. Should it be the based on the
user as a member of Group A or Group B. The Priority field resolves this
issue. You would assign a priority value to the login information. For
example, Group A is assigned a priority of 10 and Group B is assigned a
priority of 5. When a user that is a member of both groups accesses the
data source, access is granted based on the login information of the group,
to which the user is a member, with the highest priority. In this example
that would be Group A. It is important to note that in this scenario, you can
not assign the same priority value to more than one group.
v User X is a member of two groups, Group A and Group B. However, User
X must have a distinct level of access to a data source that is different than
any other member of either group. You will use the Priority field to resolve
this issue. You will assign a login mapping user ID and password to Group
B and assign a priority value of 5 to the mapping information. You will
assign a login mapping user ID and password to Group A and assign a
priority value of 10 to the mapping information. You will assign a login
mapping user ID and password for User X and assign a priority value of 25
to mapping information. When User X accesses the data source, the
mapping information with the highest priority value will be used. It is
important to note that in this scenario, you can not assign the same priority
value to a group and individual user that is a member of the group.
7. Click OK. The data source login information for the selected user or group is
listed in the Data source login list as follows:
v Login mapping owner lists the name of the user or group that will use this
login to access the data source. This is the same name that appears in the
Users and groups list box.
v Login specifies the login user ID that will be used to access the data source
for the user or group.
v Priority specifies the priority that is assigned to the login information. This
priority value determines which login information will be invoked for users
that are members of multiple groups.
You will repeat this process for each user or group for which you want to set
up login mapping information.
8. To edit existing data source login information, select the data source login
information from the Data source login list and click the Edit data source
login icon located above the list box. The Edit data source login window
opens. You can make changes to any of the fields. Click OK to close the Edit
data source login window.
9. To delete existing data source login information, select the data source login
from the Data source login list and click the Remove data source login icon
located above the list box.
10. Click OK. The login mapping parameters that you have specified for each
user or group are in effect for the data source. You must set up login mapping
information individually for each data source in the repository.

Creating the repository connection for DataQuant
DataQuant needs to know how to access the application data (as grouped by the
repository name) so that end-users will have access to this data. The way to
provide this connection data to DataQuant is to create it using the DataQuant
connection wizard.

78

Installing and Managing DataQuant

About this task
You must create connection information for each repository. The repository
connection information specifies how a shared repository will be accessed. You
decide the type of connection to create depending on how you want to set up your
environment.
The repository connection information is saved in a file called settings.xml. This
file is saved in the personal settings directory of the machine that is running the
application interface. You can use this file to streamline the process of setting up
the environment for all users of DataQuant.
To create repository connection information:

Procedure
1. Open the Create New Repository Connection wizard by right-clicking
anywhere in the Repository Connections view and selecting New > Repository
Connection.
2. Select the type of connection that you will create from one of the following
radio buttons:
v Shared repository to create a repository connection to a shared repository
using a client/server JDBC connection. With client/server access, the user's
workstation establishes a direct connection to the repository database using
its locally installed JDBC driver. For this type of connection each workstation
that runs DataQuant for Workstation and the server (workstation) that runs
DataQuant for WebSphere must have JDBC drivers installed.
v File-based repository to create a repository connection to a file-based
repository stored at a given location. (DataQuant for Workstation only)
v Network repository to create a repository connection to a shared repository
using direct network access. Network connectivity permits users to access a
shared repository without the need for direct database connectivity from the
workstation. Connecting to repositories using a network connection allows
for consolidation of data access at a central server and removes the need to
distribute JDBC drivers across each desktop running DataQuant for
Workstation.
v Web service repository to create a repository connection to a shared
repository through the DataQuant for WebSphere web services API using a
HTTP or HTTPS connection. Web service connectivity permits users to access
a shared repository without the need for direct database connectivity from
the workstation. Connecting to repositories using a web service connection
allows for consolidation of data access at a central server and removes the
need to distribute JDBC drivers across each desktop running DataQuant for
Workstation.
3. Click Next. The second page of the Create New Repository Connection wizard
opens. The second page of the wizard differs depending on the type of the
repository connection that you are defining.

Creating shared repository connections
You create a shared repository connection to set up the information that will enable
you to connect to a shared repository that resides in a database using a
client/server JDBC connection.
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About this task
The steps in this task describe how to create a shared repository connection.
Note: The connection mode for the shared repository connection is determined by
settings on the Protection tab of the Edit Repository Storage window.
To complete the process of creating a shared repository connection:

Procedure
1. Open the second page of the Create New Repository Connection wizard.
2. Specify a name for the repository connection in the Connection name field.
This name will be used to identify the connection as it appears in the
Repository Connections view. You can enter any name but it is recommended
that the name identifies the repository for which this connection information
applies.
3. Select the Connect immediately check box to connect to the shared repository
immediately. If this check box is clear, the connection information will be
created, saved and displayed in the Repository Connections view, but you
will not be immediately connected to the repository.
4. In the Connection type radio group, select JDBC or JNDI.
If you select JNDI:
v In the Data Source name field, specify the JNDI data source name and
location.
v Click Advanced to specify any driver-specific connection string keywords
and their values that will be used for the database that is hosting the
repository storage tables.
For information on any keywords that are required by a selected database
driver, consult the specific driver's documentation.
If you select JDBC:
v In the JDBC Driver field specify the library for the JDBC driver that will be
used to access the database that hosts the repository storage.
You can select from a drop-down list of libraries that you defined when you
set up the JDBC driver information. You can click the ellipsis (...) to open
the JDBC Libraries window where you can create additional JDBC driver
libraries.
Note: If you work with a DB2 for z/OS database, you can use the Direct
DRDA Connection. In contrast to JDBC libraries, the Direct DRDA
Connection comes with the product and does not require additional driver
installation.
Note: The Direct DRDA Connection is supported only for DB2 for z/OS
Version 8, Version 9, and Version 10. Do not use it for DB2 LUW or DB2 for
iSeries.
See the Installing and Managing PDF for information about using DRDA to
connect to database repositories and data sources.
v In the JDBC URL list, specify the URL that points to the database that hosts
the repository storage within which the repository to which you want to
connect resides.
The format for the URL can be displayed in the list.
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Note: You can also use the Build URL by URL Template window to form
the correct string. To do so, click Build URL to open the Build URL by URL
Template window. From the JDBC URL drop-down list, select the template.
In the table, specify the server, port, and database information and click
OK. The result URL string is added to the JDBC URL list.
v Click Advanced to specify any driver-specific connection string keywords
and their values that will be used when connecting to this shared
repository.
For information on any keywords that are required by a selected driver,
consult the specific driver's documentation.
v If you use the Direct DRDA Connection, bind packages by clicking Bind
Packages.
5. In the JDBC Driver field specify the library for the JDBC driver that will be
used to access the database that hosts the repository. Select from a drop-down
list of libraries that you defined when you set up the JDBC driver
information. Click the ellipsis (...) to open the JDBC Libraries window where
you can create additional JDBC driver libraries.
6. In the JDBC URL field specify the URL that points to the database that hosts
the repository storage within which the repository to which you want to
connect resides. The format for the URL can be displayed in the field if you
specified an example when setting up the JDBC libraries.
7. Click Set User Information to specify the user information that will be used
to connect to the repository. The Set User Information window opens.
a. Select the User ID and password are required check box to specify that
user information will be requested each time a connection is made to this
shared repository. In some cases, leaving this check box clear will enable
users to access the repository without overtly specifying their user
information.
b. Enter the user ID and password that will be used to access the specified
repository database in the User name and Password fields.
c. To remember the password, select the Remember password check box.
d. To enable the Single-Use Password Mode, click Advanced and select
Enabled.
In the Repository storage connections timeout field, enter the time in
minutes that the Single-Use Password Mode feature will remain enabled
(while not being used) without being closed by application.
Note: A value of zero 0 sets unlimited idle state for the connection
timeout, meaning that connection will close only when the session ends.
Enabling the Single-Use Password Mode feature provides users with the
ability to log into the repository for the entire session without having to
reenter his or her user ID and password.
Using this feature assumes that you selected User ID and password are
required and that you have selected Remember password check box.
If you do not select the Remember password check box, the system will
prompt you for a user ID and password whenever you open the Edit
Repository Connection wizard.
8. Click OK to close the User Information window.
9. Select Hide from web service clients to exclude this connection from the list
of available connections in the Repository connection name field in
DataQuant for WebSphere.
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This check box is displayed in DataQuant for WebSphere user interface only. If
you are working in the DataQuant for Workstation user interface, Hide from
web service clients is not an option.
If you select this check box, the user cannot establish a web service connection
to this repository connection.
10. In the Repository name field, select the repository to connect to. If no
repositories are listed, click Refresh .
11. Click Finish. The repository connection is listed in the Repository
Connections view. If you selected Connect immediately, you are connected to
the repository that you selected. This repository connection information is
entered in the connections settings file. The next step to creating repository
connection information is to distribute this information to each user that will
be running DataQuant for Workstation or to the server (workstation) that is
running DataQuant for WebSphere.

Creating file-based repository connections
If you are using DataQuant for Workstation, you can create a file repository
connection to set up the information that will enable you to connect to a file-based
repository that is stored on a local or network drive.

About this task
File connections can only be created for legacy, file-based repositories. The later
versions of DataQuant for Workstation and DataQuant for WebSphere have
replaced file-based repositories with personal repositories.
To complete the creation of a file-based repository connection:

Procedure
1. Open the second page of the Create New Repository Connection wizard.
2. Specify a name for the repository connection in the Connection name field.
This name will be used to identify the connection as it appears in the
Repository Connections view. You can enter any name but it is recommended
that the name identifies the repository for which this connection information
applies.
3. Select the Connect immediately check box to connect to the file-based
repository immediately. If this box is clear, the connection information will be
created, saved and displayed in the Repository Connections view, but you will
not be immediately connected to the repository.
4. Click Finish. The repository connection is listed in the Repository Connections
view. If you selected the Connect immediately, you are connected to the
repository that you selected. This repository connection information is entered
in the connections settings file.

Configuring repository caching
You can configure a caching functionality on your repositories. When caching is
enabled on a repository, the system saves the content of the repository
(dashboards, queries, visual reports, and other objects) to the memory on the
workstation client or on on the web server if you are using DataQuant for
WebSphere.
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About this task
This task describes how to configure repository caching.
Considerations:
v Caching happens in local memory on your machine if you are using DataQuant
for Workstation and in memory on the web server if you are using DataQuant
for WebSphere.
Subsequently, the next time you access the repository objects, information is
retrieved from memory (without sending a request to the repository), hence
retrieval time is reduced.
The following content is cached:
– Content of objects
– Path to objects
– Metadata to tables
v When you make changes to cached repository objects, the cache is refreshed to
reflect the changes.
v For DataQuant for Workstation, the repository cache is cleared whenever you
shut down your machine or close the application.
v For DataQuant for Workstation, end-users can set repository caching parameters
for the version of the application running on their machine.
v For DataQuant for WebSphere, repository caching is shared between all
connections made with the same Repository Connection login.
v For DataQuant for WebSphere, you must have administrator authorization in
order to change repository connection settings.
To configure repository caching:

Procedure
1. Open the second page of the Creating New Repository Connection wizard or of
the Edit Repository Connection wizard.
2. In the Repository cache area, select the Enable check box to activate cache
configuration options.
The radio buttons for predefined cache validation are enabled in the
Predefined modes section.
To implement a predefined cache validation mode, select the associated radio
button. The cache validation processing for each predefined mode are as
follows:
v Low relevance-High performance
If selected, cache validation is not performed.
v Balanced relevance/performance
If selected cache validation is performed every 5 minutes. This is the default
setting for cache validation.
v High relevance-Low performance
If selected cache validation is performed every 60 seconds (1 minute).
3. To implement custom cache validation, select the Use custom cache settings
check box.
When you select the Use custom cache settings check box, the options for
predefined cache validation modes are disabled.
Click Custom. . . to launch the Repository Cache Settings wizard.
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Use this wizard to specify cache size information and to set validation
intervals.
The wizard consists of two panes:
v The Repository Caches pane on the left
This pane lists the specific types of repository-related data to cache.
v The Repository Caches Settings pane on the right
This pane is where you set the caching parameters.
You can set parameter values for general caching, which are applied to each
type of repository-related data.
You can also set parameter values for the different types of repository-related
data. These types include:
– Content Cache
– Server Metadata Cache
– Structure Cache
– Table Metadata Cache
a. To set general cache settings, click Repository Caches in the list pane and
set a value in the Cache validation time (minutes) field.
The value you enter represents how often (in minutes) that cache validation
occurs.
The value you enter determines how often the cache validates that the
objects in it haven't changed. The system checks the last updated date for
every cached object stored in the repository.
The default value is 5 minutes.
Any object that has been changed gets removed from the cache.
Any object that has not been accessed within the time specified, are not
removed from the cache.
Enter 0 (zero) if you never want to refresh the cache. This is useful for
repositories with static content.
b. To set parameter values for the different types of repository-related data,
expand Repository Caches and select the type of data to configure. The
types of repository-related data and their configuration parameters are as
follows:
v Content Cache
Includes the following parameter:
– Content size (megabytes) specifies the maximum size allowed (in
megabytes) for cached content.
The value entered represents the total combined size of all objects
stored in the cache and saved to memory on your machine if you are
using DataQuant for Workstation and on the web server if you are
using DataQuant for WebSphere.
When a new object is added to the cache whose size has reached the
maximum allowed size, the system removes objects until it has enough
space to accommodate the new object.
Those objects that have not been accessed for the longest period of
time are removed first.
v Server Metadata Cache
Includes the following parameters:
– Lifetime limit (minutes)
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Parameter sets maximum time (in minutes) for records to be kept in
cache. Lifetime is calculated for each record starting from the moment
of its creation. Upon expiration of specified lifetime record is forced
out of cache.
– Inactivity (minutes)
Parameter sets maximum time (in minutes) for records to be kept in
cache without being referenced. Inactivity period is calculated for each
record starting from the moment of its last use. Upon expiration of
specified inactivity period record is forced out of cache.
v Structure Cache
Includes the following parameters:
– Lifetime limit (minutes)
Parameter sets maximum time (in minutes) for records to be kept in
cache. Lifetime is calculated for each record starting from the moment
of its creation. Upon expiration of specified lifetime record is forced
out of cache.
– Inactivity (minutes)
Parameter sets maximum time (in minutes) for records to be kept in
cache without being referenced. Inactivity period is calculated for each
record starting from the moment of its last use. Upon expiration of
specified inactivity period record is forced out of cache.
v Table Metadata Cache
Includes the following parameters:
– Lifetime limit (minutes)
Parameter sets maximum time (in minutes) for records to be kept in
cache. Lifetime is calculated for each record starting from the moment
of its creation. Upon expiration of specified lifetime record is forced
out of cache.
– Inactivity (minutes)
Parameter sets maximum time (in minutes) for records to be kept in
cache without being referenced. Inactivity period is calculated for each
record starting from the moment of its last use. Upon expiration of
specified inactivity period record is forced out of cache.
4. Click Finish to exit the wizard.

Results
You have enabled repository caching and have set the parameters by which
caching occurs. The settings are saved to the product configuration.
The system allows you to read and write (save) file Cache settings and uses it to
set the current settings directly to the Caches. All settings are grouped by services
in the set of configuration records.

Creating network repository connections
You create a network repository connection to set up the information that will
enable you to connect to a shared repository using direct network access.

About this task
Network connectivity permits users to access a shared repository without the need
for direct database connectivity from the workstation. Connecting to repositories
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using a network connection allows for consolidation of data access at a central
server and removes the need to distribute JDBC drivers across each desktop
running DataQuant for Workstation.
DataQuant for Workstation users can connect to repositories via a centralized
machine running the DataQuant network repository service. Network connectivity
provides similar capabilities to the web-based approach but does not require a web
application server in order to operate. In order to use network connectivity you
must set up and start the network repository service.
Note: When you create a network repository connection in DataQuant for
Workstation (client) the version of network repository service (server) must be at
the same release levels. If the release levels (between the client and server) do not
match, network repository connections will not work.
To complete the creation of a network repository connection:

Procedure
1. Set up and start network repository service.
2. Open the second page of the Create New Repository Connection wizard.
3. Specify a name for the repository connection in the Connection name field.
This name will be used to identify the connection as it appears in the
Repository Connections view. You can enter any name but it is recommended
that the name identifies the repository for which this connection information
applies.
4. Select the Connect immediately check box to connect to the repository
immediately. If this check box is clear, the connection information will be
created, saved and displayed in the Repository Connections view, but you will
not be immediately connected to the repository.
5. Specify the name or the IP address of the server (or workstation) that is
running your network service in the Server host field.
6. Specify the contact port for the network server in the Port field.
7. Click Refresh.
The available repository connections for the specified network repository
service are retrieved. Select the repository connection that you want to use from
the list of available repository connections.
8. Click Finish.
The repository connection is listed in the Repository Connections view.
If you selected Connect immediately, you are connected to the repository that
you selected. This repository connection information is entered in the
connections settings file.

Setting up network repository services
DataQuant for Workstation users can connect to shared repositories by using a
centralized machine that runs the DataQuant network repository service.

About this task
To set up the DataQuant network repository service:
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Procedure
1. During the installation of DataQuant for Workstation, all *.jar files are placed in
the API installation directory. Copy them to a required directory on the server
machine.
2. Copy the product license files to the directory on the server machine referred to
in 1. The product license files are located under WEB-INF/config in DataQuant
for WebSphere or in the DataQuant for Workstation installation directory.
3. Copy the repositories.xml and .bi.jdbc.drivers files to the directory on the server
machine referred to in 1. These files are created at installation and populated
when you configure repositories with repository connection information and set
up JDBC drivers. If you use the DataQuant for Workstation administrator
component, you find the files in the DataQuant for Workstation installation
directory. If you use the DataQuant for WebSphere Administrator application
you find the files in the DataQuant for WebSphere installation WEB-INF/config
directory.
4. To start the network repository service, run the following lines as one
command:
java -cp CLASSPATH com.ibm.bi.qmf.core.repository.RepositoryService
PORT_NUMBER PATH_TO_REPOSITORIES.XML

Where:
v CLASSPATH: Contains the location of the files that were copied to the
directory on the server in step one.
v PORT_NUMBER: The port on which the network repository service must
operate. It can be any free TCP/IP port of your choosing.
v PATH_TO_REPOSITORIES.XML: Provides the path containing the
repositories.xml and .bi.jdbc.drivers files. If omitted, the files are assumed to
be in the current directory.
Sample command line (issue the following lines as one command):
java -cp "$qmf_jar_file_name.jar"
com.ibm.bi.qmf.core.repository.RepositoryService
8889

5. DataQuant for Workstation users connect to the network repository service by
using the machine name and designated port as defined in the Network
Repository connection information.

Creating web service repository connections
You create a Web service repository connection to set up the information that will
enable you to connect to a shared repository through the DataQuant for
WebSphere web services API using a HTTP or HTTPS connection.

About this task
You can used web-based connectivity to access a shared repository without the
need for direct database connectivity from the workstation. By using this method
to connect to repositories you consolidate data access at a central server, thus
removing the need to distribute JDBC drivers across each desktop running
DataQuant for Workstation.
Web-based connectivity is provided by the DataQuant for WebSphere built-in
repository web service. To enable this facility, you must have DataQuant for
WebSphere deployed to a WebSphere Application Server (WAS) instance. In
addition, you must have repository connection information available to this version
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of DataQuant for WebSphere. DataQuant for Workstation users connect to the
repository using the URL and port to the DataQuant for WebSphere server.
Note: When you create a network repository connection in DataQuant for
Workstation (client) the version of network repository service (server) must be at
the same release levels. If the release levels (between the client and server) do not
match, network repository connections will not work.
To complete the creation of a web service repository connection:

Procedure
1. Deploy DataQuant for WebSphere to a WebSphere Application Server (WAS)
instance; configure one or more shared repositories, and set up shared
repository connection information for each repository.
2. Open the second page of the Create New repository Connection wizard.
3. Specify a name for the repository connection in the Connection name field.
This name will be used to identify the connection as it appears in the
Repository Connections view. You can enter any name but it is recommended
that the name identifies the repository for which this connection information
applies.
4. Select the Connect immediately check box to connect to the web service
repository immediately. If this box is clear, the connection information will be
created, saved and displayed in the Repository Connections view, but you will
not be immediately connected to the repository.
5. In the Web Server URL field, specify the URL to launch the instance of
DataQuant for WebSphere whose web services API will be used for this
connection. This is the URL address that was created when the instance of
DataQuant for WebSphere was deployed.
6. Click Refresh. The available repository connections that have been defined for
the instance of DataQuant for WebSphere that you specified in the Web Server
URL field are retrieved. Select the repository connection that you want to use
from the list of available connections.
7. Click Finish.
The repository connection is listed in the Repository Connections view.
If you selected Connect immediately, you are connected to the repository that
you selected. This repository connection information is entered in the
connections settings file. The next step to creating repository connection
information is to distribute this information to each user that will be running
DataQuant for Workstation.

Results
Currently, when the DataQuant for WebSphere client opens, it connects to the last
accessed repository. An additional connection URL parameter has been added to
control which repository connection should be used when the DataQuant for
WebSphere client opens.
For example:
http://host:port/DataQuant/user?repository=MyConnection

If the connection parameter points to an invalid connection, then the system opens
open the Switch Repository window. You can pass logon information for secured
repository connections using the user and password parameters.
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For example:
http://host:port/DataQuant/
user?repository=MyConnection&user=userLogin&password=userPassword

.

Setting up login mapping for a data source
Login mapping enables a user to login to a repository and gain access to one or
more of the database data sources that have been configured in that repository
using a single user ID and password.

About this task
With login mapping, administrators can set up users so that they can login to a
repository and access any data source without specifying another user ID and
password that is specific to the database data source. By setting up login mapping,
users do not have to continually reenter login information every time they access a
database data source, and they do not have to know the login information for each
database data source.
You set up login mapping for each data source that you include in the repository.
Login mapping can only be set up for data sources that reside in protected
repositories. Protected repositories are those that were created with the security
option Internal or LDAP.
To set up login mapping for a data source:

Procedure
1. Right-click a data source in the Repositories or the Repository Explorer view.
Select Properties from the pop-up menu. The Properties window opens. Select
Login Mapping from the tree. The Login Mapping page of the window opens.
All users and groups that have been defined for the repository are listed in
the Data source login list list box. This list is empty if you have not defined
any users or groups.
2. To set up mapping for a user or group, highlight a user or group and click the
Edit data source login icon above the list box. The Edit Data Source Login
window opens.
3. Specify the user ID that will be used to login to the database data source in
the Login field.
4. Specify the password that will be used to login to the database data source in
the Password field.
5. Verify the password by retyping it in the Verify password field.
6. Specify the priority that will be placed on this login information in the
Priority field. You can enter any numerical value in this field with the value
of 1 having the lowest priority. The Priority value is used to determine what
login mapping ID and password will be invoked for a user that is a member
of multiple groups. Consider the following:
v User X is a member of two groups, Group A and Group B. You have
assigned a login mapping ID and password for Group A that gives all users
assigned to Group A a certain level of access to the data source. You have
assigned a login mapping ID and password for Group B that gives all users
assigned group B a lesser level of access to the database data source. As a
member of both groups, when User X accesses the data source, it is unclear
what login information that should be used. Should it be the based on the
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user as a member of Group A or Group B. The Priority field resolves this
issue. You would assign a priority value to the login information. For
example, Group A is assigned a priority of 10 and Group B is assigned a
priority of 5. When a user that is a member of both groups accesses the
data source, access is granted based on the login information of the group,
to which the user is a member, with the highest priority. In this example
that would be Group A. It is important to note that in this scenario, you can
not assign the same priority value to more than one group.
v User X is a member of two groups, Group A and Group B. However, User
X must have a distinct level of access to a data source that is different than
any other member of either group. You will use the Priority field to resolve
this issue. You will assign a login mapping user ID and password to Group
B and assign a priority value of 5 to the mapping information. You will
assign a login mapping user ID and password to Group A and assign a
priority value of 10 to the mapping information. You will assign a login
mapping user ID and password for User X and assign a priority value of 25
to mapping information. When User X accesses the data source, the
mapping information with the highest priority value will be used. It is
important to note that in this scenario, you can not assign the same priority
value to a group and individual user that is a member of the group.
7. Click OK. The data source login information for the selected user or group is
listed in the Data source login list as follows:
v Login mapping owner lists the name of the user or group that will use this
login to access the data source. This is the same name that appears in the
Users and groups list box.
v Login specifies the login user ID that will be used to access the data source
for the user or group.
v Priority specifies the priority that is assigned to the login information. This
priority value determines which login information will be invoked for users
that are members of multiple groups.
You will repeat this process for each user or group for which you want to set
up login mapping information.
8. To edit existing data source login information, select the data source login
information from the Data source login list and click the Edit data source
login icon located above the list box. The Edit data source login window
opens. You can make changes to any of the fields. Click OK to close the Edit
data source login window.
9. To delete existing data source login information, select the data source login
from the Data source login list and click the Remove data source login icon
located above the list box.
10. Click OK. The login mapping parameters that you have specified for each
user or group are in effect for the data source. You must set up login mapping
information individually for each data source in the repository.

Creating web links to data objects
Use the Web Link wizard to create web links to DataQuant objects. You can use
these links to open the objects directly in web browsers.

Before you begin
If you are using DataQuant for Workstation, the Web Link wizard is available only
when you have an available web service repository connection.
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About this task
To create a web link to data objects:

Procedure
1. From the main menu, select File > New > Other > Web Link to open the Web
Link wizard.
Note: You can also access this wizard from the repository tree pop-up menu
option Create Web Link . If you access the wizard by using this method, the
Repository object field and User-Defined Parameters are pre-filled
automatically.
2. From the Repository object field, select the object to which you want to create
a web link.
3. Specify settings for the following Predefined Parameters:
v The Toolbar check box indicates whether to show or hide the toolbar.
v The Run check box indicates whether to run the object when it is opened.
v The Environment check box indicates whether to use the default
environment to run the object.
If you want to use an environment other than the default one, select the
check box and choose from the list of environments.
v The Renderer mode check box is available for ad hoc reports, compiled
visual projects, and visual dashboards. It determines the mode in which
visual object is rendered.
4. Specify User-Defined Parameters to represent the selected parameters of
repository objects.
You can add parameters into the generated URL by selecting Include in URL
check box.
When the Toolbar check box is selected, the URL formula is:
http://{host}:{port}/{app_context}/g?object_name&param1=value1

When the Toolbar check box is clear, for visual dashboards the URL formula is:
http://{host}:{port}/{app_context}/go?object_name&param1=value1

5. Click Next to display the second page of the Web Link wizard.
On the page, you can add data sources. Use the Add Data Source and Remove
Data Source buttons to edit the list of data sources. In the Login and Password
fields, you can enter logins and passwords for added data sources.
In the Web link name field, enter the name of the current object, which you
want to use in the URL. For example, if you want to convert OBJECT_NAME
to object_name, the value with the selected Toolbar:
http://{host}:{port}/{app_context}/g?OBJECT_NAME

becomes:
http://{host}:{port}/{app_context}/g?object_name

When the Toolbar check box is clear, for visual dashboards the URL is:
http://{host}:{port}/{app_context}/go?object_name

You can change the link name by using the Web link name field.
If you leave the Web link name field empty, a new name is created
automatically. To override the name in the database, you must have the
administrator permission.
6. Click Create to generate a web link.
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If the specified link name exists, you must either rename it, or leave the Web
link name field empty to create the name automatically.
7. Click Open Web Link to open the created web link in the browser.
8. Click Finish to close the Web Link wizard.

Distributing the configured application
The administrator is responsible for distributing a fully configured and operational
application to the users.
To do this, the administrator needs to ensure that the application executable, the
JDBC JAR files, a populated JDBC driver information file, and a populated
repository connection information file are available to each machine that is running
DataQuant for Workstation and to each server (or workstation) that is running
DataQuant for WebSphere.

Exporting the configuration data to users
DataQuant administrators are responsible for ensuring that a QMF interoperability
license (if required), the application executable, the JDBC JAR files, a populated
JDBC driver information file, and a populated repository connection information
file are available to each machine that is running DataQuant for Workstation and
to each server (or workstation) that is running DataQuant for WebSphere.

About this task
The following steps describe the most streamlined process for making the
DataQuant configuration available to your users.

Procedure
1. Ensure that the JDBC JAR files are available (assuming that the location of the
JDBC driver files is identical for each machine) as follows:
v to each machine running DataQuant for Workstation that will connect
directly to repositories and data sources using direct database connections.
v to each server (workstation) running DataQuant for WebSphere that will
connect directly to repositories and data sources using direct database
connections.
2. Place the DataQuant for Workstation installation executable in a directory that
is available to all users.
3. Using DataQuant for Workstation administrative perspective, specify the JDBC
driver location information for each type of JDBC driver that will be used to
connect to shared repositories and database data sources. The .bi.jdbc.drivers
file is automatically updated. Place the JDBC driver information file
(.bi.jdbc.drivers) alongside the DataQuant for Workstation installation
executable.
4. Using DataQuant for Workstation administrative perspective, specify the
information required to connect to one or more shared repositories. The
repositories.xml file is automatically updated. Place the connection settings
file (repositories.xml) alongside the DataQuant for Workstation installation
executable.
5. In order for DataQuant for z/OS users to access QMF objects, a QMF
Enterprise Edition V8, V9 or V10 license must be available. If you want your
users to access QMF objects, place the license file (host.lic for V8 or
workstation-zSeries.lic for V9 and V10) alongside the DataQuant for
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Workstation installation executable. The license file is found in the directory
where the V8, V9 or V10 QMF application was installed.
6. You can set up a silent installation of DataQuant for Workstation. A silent
installation runs on its own without user intervention. There is no need for
users to monitor the installation and provide input via dialog boxes. Using a
silent installation, you as the administrator can control what features are
installed on the users machine. To set up a silent installation, create the silent
installation options file, modify the executable name to include the silent
installation parameters, and place the file alongside the DataQuant for
Workstation installation executable.
7. DataQuant for Workstation users can now install the application by running the
executable. The repository connection information and JDBC driver information
will automatically be set up on their machine. If a QMF Enterprise Edition V8,
V9 or V10 license is available, the z/OS user will have access to QMF objects. If
the application executable has the silent installation parameter specified, the
user will not have to respond to any dialog messages. In lieu of users running
the executable, administrators can also use distribution software to complete
the installation of DataQuant for Workstation on each user machine.
8. To update each instance of DataQuant for WebSphere with the latest repository
connection and JDBC driver information. You can do one of the following:
v Drop the repository connections file (repositories.xml) and the JDBC driver
information file (.bi.jdbc.drivers) in the home directory of the workstation
or server that is running DataQuant for WebSphere. This makes the
repository connection and JDBC driver information available to each user of
that DataQuant for WebSphere application.
v Using DataQuant for Workstation export the repository connections settings
file (repositories.xml) and the JDBC driver information file
(.bi.jdbc.drivers) to a general location. The exported file is called
settings.xml. Using DataQuant for WebSphere Administrator import the
settings.xml file. The repository connection and JDBC driver information is
updated on the server (or workstation) that is running DataQuant for
WebSphere.

Results
You have exported the DataQuant configuration data to your users. Users can now
begin using the product.

What to do next
Each time the repository connections or JDBC information files are updated, they
must be distributed again to all the users of DataQuant for Workstation and to all
the servers (or workstations) that are running DataQuant for WebSphere

Installing the product silently
A silent installation runs on its own without user intervention. Users must not
monitor the installation and provide input via dialog boxes. Using a silent
installation, you as the administrator can control what features are installed on the
user machine. To set up a silent installation, you must create a silent installation
options file and place the file in the same directory as the DataQuant for
Workstation installation executable.

About this task
To install the product silently, see the following topics:
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Creating a response file:
To run a silent installation of DataQuant for Workstation, you must create a
response file that specifies all installation options. This file must specify all the
features that you want to install and installation paths.
About this task
To create a response file:
Procedure
1. In the command line, run the installation command.
v See the example for a Windows installation to the current directory:
setupwin32.exe -r installer.properties
where:-r specifies that the installation software runs in record mode.
v See the example for a Windows installation to the custom directory:
setupwin32.exe -r C:\drive_path\response_file.properties
where:
– -r specifies that the installation software runs in record mode.
– C:\drive_path\response_file.properties specifies the path to the
response file that you want to create.
2. As the installation proceeds, you select the features that each user that runs this
executable installed on their machine.
3. Upon completion of the installation, the application is installed in the directory
that you specified during the installation.
Results
The response file is created and saved in the current directory or the directory that
you specified in the path.
What to do next
Distribute the files to the user machines to that you want to install the software
and run the silent installation.
Running the silent installation:
To run a silent installation of DataQuant for Workstation, you distribute the
response file among the user machines to that you want to install the application.
Before you begin
You must have the response file.
About this task
To run the silent installation :
Procedure
1. Optional: If you want the JDBC, repository storage, repository connection, and
license information to be included in the user installation, copy the repositories
connections file (repositories.xml), the JDBC driver file (.bi.jdbc.drivers),
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license file (*.lic), and storage file (.storage) from the application home
directory to the directory where the installation executable is stored.
2. To prepare for the silent mode, rename the response file to
installer.properties and place it in the same directory with setupwin32.exe.
Use the command line to pass the following arguments for the Windows OS:
setupwin32.exe -i silentwhere:
v -i silent: specifies that the installation software runs in silent mode.
Note: If you want to use the response file that is stored in the directory that is
different from the one where the installation executable is stored, specify the
absolute path to the response file in the argument:
setupwin32.exe -i silent -f C:\drive_path\response_file.properties
Results
The installation is silent; the product directories are created without notification to
the user.

Exporting and importing the JDBC driver and connection
information
DataQuant administrators can distribute repository connection and JDBC driver
information by exporting the repositories.xml file and the .bi.jdbc.drivers file;
and importing the settings.xml file.

About this task
To export and then import the repository connection and JDBC driver information:

Procedure
1. Populate the repository connection repositories.xml and the JDBC driver
information .bi.jdbc.drivers files.
2. Open the Export window by selecting File > Export. Select Connection and
JDBC library settings from the list of available export destinations.
3. Click Next. The Export Connection and JDBC Library Settings page of the
wizard opens.
4. A single file called settings.xml will be exported. If you are using DataQuant
for Workstation, specify where to save the settings.xml file in the Settings
file field. You can use Browse to locate a directory that is accessible to all
users.
5. Select the connection information that you want to include in the exported
settings file. All of the repository connections that are currently defined are
listed in the Repository connections list box. Select the check box for each
connection that you want to include in the settings.xml file.
6. All of the JDBC driver libraries that you have defined are listed in the JDBC
libraries list box. Select the check box for each JDBC driver library that you
want to include in the settings.xml file.
7. Click Finish. If you are using DataQuant for WebSphere, the Save file window
opens which lists the settings.xml file. Click the Link to file hyperlink to
download the file to your local workstation and click OK. If you are using
DataQuant for Workstation, the Export Connection and JDBC Library Settings
page of the wizard closes. The files are exported to the location that you
specified in the Settings file field.
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8. For each instance of DataQuant that is installed on another machine or server,
import the repository connections and JDBC driver information settings.xml
file by selecting File > Import. Select Connection and JDBC library settings
from the Import window. The Import Connection and JDBC Library Settings
page of the wizard opens.
9. Specify where to find the settings.xml file in the Settings file field. You can
use Browse to locate the file.
10. Select the Repository connections check box to import the repository
connections that have been included in the settings.xml file.
11. Select the JDBC library settings check box to import the JDBC driver
information that has been included in the settings.xml file.
12. Specify how you want conflicts with previous settings files to be resolved
using the Conflict resolving radio buttons. Select Override existing settings
to replace all conflicting information with new information. Select Keep
existing settings to not update any existing information with new
information. Select Manually resolve conflicts to open the Conflicts window
where you will manually resolve conflicts between existing and new setting
information.
13. Click Finish. The Import Connections and JDBC Library Settings window
closes. The repository connection settings and JDBC driver information files
are updated for the current machine running DataQuant for Workstation and
the current server (or workstation) running DataQuant for WebSphere. You
can repeat this process each time the JDBC driver information or repository
connection information is updated.

Exporting update scripts
Use the Export Update Script feature to apply product updates to all your
repository storages and QMF catalogs when you installed a product update.

About this task
The scripts that are generated by the Export Update Script feature automate the
process for updating table structures, rebinding packages, and re-creating stored
procedures.
The maximal line length of the DDL scripts that are generated by this feature is
determined by the value set in the Line width field on the General Preferences
page. For more information, see Setting general preferences in the user help.
To generate the update scripts in the newly installed product version, perform the
following procedure:

Procedure
1. From the main menu, select File > Export, select Export Update Script, and
click Next.
The Export Storage Update Scripts wizard opens.
2. In the Repository Storages table, select the repository storages that you want to
update. Use Select All and Deselect All buttons for more convenient selection.
3. In the Settings pane, specify the following settings for the repository storages:
(Use the same settings for all selected storages.)
v Protect using: Stored procedures or Static SQL Packages to set the
protection method for the newly installed version of the product.
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v Collection ID for packages to set the collection ID for the packages to
update.
v Owner ID for packages to set the owner ID for the packages to update if it
is necessary to change a default.
v Grant permission on packages to to specify particular users and groups for
which you are granting permissions. Users and groups must be separated by
commas.
v Database username to set the username that is used to access the databases.
v Database password to set the password that is used to access the databases.
4. Click Next
5. In the QMF Catalogs table, select the QMF catalogs to update. Use Select All
and Deselect All buttons for more convenient selection.
All settings on the Repository Storages wizard page by default are duplicated
on the QMF Catalogs page.
v Protect using: Stored procedures or Static SQL Packages to set the
protection method for the newly installed version of the product.
v Collection ID for packages to set the collection ID for the packages to
update.
v Owner ID for packages to set the owner ID for the packages to update if it
is necessary to change a default.
v Grant permission on packages to to specify particular users and groups for
which you are granting permissions. Users and groups must be separated by
commas.
v Database username to set the username that is used to access the databases.
v Database password to set the password that is used to access the databases.
6. Click Finish to generate the files to update repository storages and QMF
catalogs.
The following files are generated and stored in a directory of your choosing:
v Database update SQL (.ddl files)
v Package installation properties (.bndtask) files
v Package installation scripts (bind.bat and bind.sh)
v Repository connections configuration file (repositories.xml)
This file updates configuration of existing and updated installations of the
product.
Note: The: .ddl scripts must be run first to avoid errors. The names of the .ddl
and .bndtask files are generated in the following format:
v <host>_<port>_<database>_repository.ddl
v <host>_<port>_<database>_repository.bndtask

Chapter 3. Configuring the environment

97

98

Installing and Managing DataQuant

Chapter 4. Managing resource limits
Resource limits help you manage resource consumption on a database data source.
By specifying resource limits you can control the actions a user can perform and
implement limits on the resources a user can consume when they access the data
source using DataQuant.
Resource limits can be applied globally to data sources or they can be applied to
individual queries that access any data source. Data source and query resource
limits allow you to control resource consumption on a per user, group, day of the
week, or time of day basis.

Setting up data source resource limits
You can set up one or more unique sets of resource limits that can be applied to
individual users or to groups of users when they access a data source.

About this task
For every data source that you add to a repository, the Add New Data Source
wizard creates a default set of resource limits. Based on your resource limits
provider selection, the default resource limits for the data source are stored in the
repository or the QMF catalog. The resource consumption at the data source for
every user of DataQuant for Workstation and DataQuant for WebSphere is
automatically controlled by that default set of resource limits. The default resource
limits are non-restrictive and are always active.
To modify the default resource limits or set up new, unique resource limits for a
data source:

Procedure
1. From the Repository Explorer view, right-click a relational data source. Select
Properties from the pop-up menu. The Properties for [data source] window
opens. Click the Resource Limits folder. The Resource Limits window opens.
2. All resource limits groups that exist for a data source are listed in the Resource
limits groups list box. Every data source has a resource limits group called
Default. The Default resource limits group includes all users and has no
resource limitations. Use the Show resource limits groups whose names match
field and the Refresh List button to search for specific resource limits groups
that exist on the data source. Use a percent (%) sign in the Show resource
limits groups whose names match field to list all resource limits groups that
exist on the data source.
3. Create a new resource limits group for the data source by clicking the Add
icon. The New Resource Limits Group window opens. Specify field values and
click OK.
4. Create a schedule and specify resource limit values for the resource limits
group by selecting the resource limits group from Resource limits groups list
box and clicking the Edit icon. The Edit Resource Limits Group window opens.
Specify field values and click OK.
5. Assign users to a resource limits group by selecting the resource limits group
from the Resource limits groups list box and clicking Assign. If you are using
© Copyright IBM Corp. 1995, 2015
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a repository as your resource limits provider, the Assignment for [resource
limits group name] window opens. If you are using a QMF catalog as your
resource limits provider, the Assign User Profiles to [resource limits group
name] window opens. Specify field values and click OK.
6. To delete a resource limits group, select the group from Resource limits groups
list box and click the Delete icon. The resource limits group is removed from
Resource limits groups list box.
7. Click OK to close the Resource Limits page of the Properties window.
Note: If a resource limit has been set at the query level and the data source
level, DataQuant will apply the most restrictive limit of the two. For example, if
the Maximum Rows to Fetch limit is set to 150,000 rows at the query level, but
set to 100,000 rows at the data source level, then DataQuant will apply the data
source limit of 100,000 rows when the query is run, since the lower number
constitutes a more restrictive limit. This selection process is repeated for every
resource limit that is set at both the query and data source levels.

Setting up query resource limits
You can set up one or more unique sets of resource limits that can be applied to an
individual query.

About this task
Each time a user runs the query at any data source, the resource limits assigned to
the user will control their resource consumption at that data source. Each set of
resource limits can place specific restrictions that can be implemented based on the
time of day or day of week that the query is run. You can apply resource limits to
any query that has been saved in a repository. The resource limits that you can
apply to a query are the Timeouts, LOBs, and Cache resource limits.
To set up resource limits for a query:

Procedure
1. From the Repository Explorer or Repositories view, right-click a query that has
been saved in the repository. Select Properties from the pop-up menu. The
Properties for [query name] window opens. Click the Resource Limits folder.
The Resource Limits window opens.
2. All resource limits groups that exist for a query are listed in the Resource
limits groups list box. Every data source has a resource limits group called
Default. The Default resource limits group includes all users and has no
resource limitations. Use the Show resource limits groups whose names match
field and the Refresh List button to search for specific resource limits groups
that exist on the data source. Use a percent (%) sign in the Show resource
limits groups whose names match field to list all resource limits groups that
exist on the data source.
3. Create a new resource limits group for the data source by clicking the Add
icon. The New Resource Limits Group window opens. Specify field values and
click OK.
4. Create a schedule and specify resource limit values for the resource limits
group by selecting the resource limits group from Resource limits groups list
box and clicking the Edit icon. The Edit Resource Limits Group Schedule
window opens. Specify field values and click OK.
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5. Assign users to a resource limits group by selecting the resource limits group
from the Resource limits groups list box and clicking Assign. If you are using
a repository as your resource limits provider, the Assignment for [resource
limits group name] window opens. If you are using a QMF catalog as your
resource limits provider, the Assign User Profiles to [resource limits group
name] window opens. Specify field values and click OK.
6. To delete a resource limits group, select the group from Resource limits groups
list box and click the Delete icon. The resource limits group is removed from
Resource limits groups list box.
7. Click OK to close the Resource Limits page of the Properties window.
Note: If a resource limit has been set at the query level and the data source
level, DataQuant will apply the most restrictive limit of the two. For example, if
the Maximum Rows to Fetch limit is set to 150,000 rows at the query level, but
set to 100,000 rows at the data source level, then DataQuant will apply the data
source limit of 100,000 rows when the query is run, since the lower number
constitutes a more restrictive limit. This selection process is repeated for every
resource limit that is set at both the query and data source levels.

Definition of a resource limits group
A resource limits group is a set of resource limits that are implemented collectively,
for each user that is assigned to the group, according to a specified schedule. You
can create as many resource limits groups as you want, with each group having a
different set of resource limits implemented according to different schedules.
There are many permutations available to you for setting up resource limits
groups. The most common ways to set up resource limits groups and control
resource usage are by:
v data source
v user
v day of the week
v time of day
For example, a resource limits group can contain one set of limits that is in effect
weekdays between 8 AM and 6 PM and another that is in effect on weekends and
off-hours. In addition, each resource limits group can have different users assigned
allowing them to perform only certain functions on specific database data sources
or when running specific queries.

Default resource limits group
Initially, all users are assigned to the default resource limits group. Users who are
not assigned to any other resource limits group are governed by the limits defined
in the default resource limits group.
The default resource limits group is assigned a set of default resource limits and a
default schedule. The default resource limits are not restrictive and the default
schedule implements the resource limits 24 hours a day, every day of the week.
You can edit the default resource limits group and change the resource limits and
the schedule.
Note: Resource limits are always active. Governing based on default resource
limits is performed even if you do not set up resource limits groups. You should
review the limits specified for the default resource limits group to ensure that
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unassigned users that are governed by the default group are not granted limits
that are more extensive or restrictive than you intend.

Ensuring resource limits groups security
In order to protect the limits that have been specified for each user, QMF
catalog-based resource limits groups are securely stored in the table
RDBI.RESOURCE_TABLE that is part of the QMF catalog and resides on a
database server.
You must have the authorization to execute the DataQuant application package on
the database server in order to make any changes to a resource limits group. This
prevents unauthorized users from changing the resource limits.
A view named RDBI.RESOURCE_VIEW is defined for the resource limits table.
DataQuant applications access the resource limits information using the view so
the table remains intact.
Note: The Default resource limits group resource limit information is stored in the
repository and not in the RDBI.RESOURCE_TABLE on the database server. That
means any user who can access the repository can make changes to the resource
limits of the default resource limits group.

Creating resource limits groups
A resource limits group is a set of resource limits that are implemented collectively,
for each user that is assigned to the group.

About this task
You can create one or more resource limits groups for each data source that you
add to the repository.
To create a resource limits groups:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. Select a
resource limits group from the Resource limits groups list box. Click the Add
icon. The New Resource Limits Group window opens.
2. Type a name for the group in the Group name field. There are no restrictions
on the name.
3. Optional: In the Comments field you can specify up to 80 characters of
comments describing the resource limits group.
4. You can select the Create this group using schedules from the Default group
check box to create the resource limits group with the same schedules as the
default group. If this check box is cleared, the new resource limits group has no
schedules. You create or modify a resource limits group's schedule using the
Edit Resource Limits Group Schedule window.
5. Click OK. The New Resource Limits Group window closes. The new resource
limits group is created. Control returns to the Resource Limits window. The
next step to setting up resource limits is to create or edit the resource limits
group schedules.
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Setting up resource limits group schedules
The resource limits group schedule determines when the resource limits specified
for the group are in effect. You can create as many schedules for a resource limits
group as you need. Each schedule can be set up to implement a unique set of
resource limits.

Specifying multiple schedules for one resource limits group
Specify resource limits during different time periods using multiple schedules for
one resource limits groups.
When a user accesses a data source the resource limits groups to which the user
has been assigned are identified. The schedules of the identified groups are
verified to determine which resource limits are currently in effect. Because users
can be assigned to multiple resource limits groups, each with multiple schedules,
there can easily be overlapping spans of time when technically multiple sets of
resource limits could be in effect.
In the cases of overlapping schedules, a unique schedule number is used to
determine which schedule is in effect. The schedule with the lowest number takes
precedence.
For example, suppose that a resource limits group has the following four
schedules:
Table 10. Resource limits group schedules
Schedule #

1

2

3

4

From Day

Wednesday

Monday

Monday

Sunday

To Day

Wednesday

Friday

Friday

Saturday

From Time

10:30

9:00

17:00

00:00

To Time

11:30

17:00

9:00

24:00

You will notice that schedule #1 is embedded in schedule #2 and schedules #1, #2,
and #3 are embedded in schedule #4. If a user accessed this data source on
Wednesday at 11:00, schedules #1, #2, and #4 could be in effect. The schedule with
the lowest number is used.
When you create your resource limits group schedules, it is recommended that you
stagger your numbering so additional schedules can be inserted where appropriate
or deleted without impact. Keep in mind that schedules do not have to be
numbered sequentially but once a schedule is assigned a number it cannot be
changed.
All time and day ranges of the schedules are inclusive. That means if the From
time is 08:00, the schedule is in effect exactly at 08:00. If the To time is 17:00 the
schedule is in effect until 16:59:59. The from and to times can wrap around
midnight, and the from and to days can wrap around weekends.
When users are accessing data sources in different time zones, the clock used to
determine time resides on the data source being accessed. For example, an user in
New York is accessing a data source in California and it is 9:00 AM Monday in
New York. Based on the example schedules, schedule 3 is in effect because
according to the data source it is 6:00 California time.
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Determining the resource limits schedule in effect
Each resource limits group schedule has a unique number that specifies the
priority of the schedule.
The resource limits group schedule specifies the limits that have been set up for a
group of users. For each resource limits group, there can be more than one
schedule. Usually each schedule has different limits specified and is effective at
different times. However, some schedules can have different limits but overlapping
times where they are effective. In the cases of overlapping times, DataQuant uses
the unique schedule number to determine which schedule is in effect. The schedule
with the lowest number takes precedence.
For example; if a resource group has following four schedules:
Schedule #

1

2

3

4

From Day

Sunday

Monday

Wednesday

Monday

To Day

Saturday

Friday

Wednesday

Friday

From Time

00:00

09:00

10:30

17:00

To Time

24:00

17:00

11:30

09:00

Schedule 1, because it has the lowest number, is always in effect. The numbering of
these schedules as presented above does not make sense. As defined, schedule 3
will never be in effect because the time frame it spans always falls within schedule
1, and schedule 1 will always take precedence. This is a major consideration when
assigning numbers to the schedules.
When you create a schedule, you as the administrator can choose to assign any
number from 1 to 99 to that schedule. It is recommended that for the schedule
with the most selective time constraints, you assign the lowest number, and for the
schedule with the broadest time expanse, you assign the higher number.
Following this logic, the more appropriate way of numbering the above schedules
would be:
Schedule #

1

2

3

4

From Day

Wednesday

Monday

Monday

Sunday

To Day

Wednesday

Friday

Friday

Saturday

From Time

10:30

09:00

17:00

00:00

To Time

11:30

17:00

09:00

24:00

Now, on Wednesday at 10:30 AM, schedule 1 is in effect. On Monday at 10:30 AM,
schedule 2 is in effect, all other times on Monday through Friday from 9:00 AM to
5:00 PM schedule 2 is in effect, and from 5:00 PM to 9:00 AM schedule 3 is in
effect. On Friday evening schedule 3 is in effect until midnight. At midnight
Saturday morning, schedule 4 takes over. On Sunday at 10:30 AM schedule 4 is in
effect.
Additional considerations when creating schedules:
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v Schedules do not have to be numbered sequentially. Once a schedule is assigned
a number it cannot be changed, so it is recommended that you stagger your
numbering so additional schedules can be inserted where appropriate or deleted
without impact.
v All time and day ranges of the schedules are inclusive. That means if the From
time is 08:00, the schedule is in effect exactly at 08:00:00. If the To time is 17:00,
the schedule is in effect until 16:59:59.
v The from and to times can wrap around midnight, and the from and to days can
wrap around weeks.
v When users are accessing servers in different time zones, the clock used to
determine time resides on the server being accessed. For example, an user in
New York is accessing a server in California and it is 9:00 am Monday in New
York. Based on the example schedules, schedule 3 is in effect because according
to the server it is 6:00 California time.

Creating a resource limits group schedule
A resource limits group can have one or more schedules, each with a different set
of resource limits. The schedule defines when the associated set of resource limits
is in effect.

About this task
The set of resource limits specify what actions and resource usage is allowed while
the schedule is in effect.
To create or edit a resource limits group schedule:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. Select a
resource limits group from the Resource limits groups list box. Click the Edit
icon. The Edit Resource Limits Group window opens.
2. The Resource limits group that you selected is identified in the Group name
field.
3. Comments that were specified when the group was created are displayed in the
Comments field. You can make changes to the comment text by typing new
text directly in the field.
4. All of the schedules that have been defined for this resource limits group are
listed in the Schedule List list box.
5. The Status radio buttons indicate whether all of the schedules that are listed in
the Schedule List are collectively active or inactive. To activate all the
schedules listed in the Schedule List, select Active. All of the schedules are
active. To deactivate all the schedules listed in the Schedule List, click the
Inactive. None of the schedules are in effect except the default schedule. The
schedules are saved and can be activated at any time.
6. To create a new resource limits group schedule, click Add. The Main page of
the Edit Resource Limits Group Schedule window opens. Use the pages of the
Edit Resource Limits Group Schedule window to specify the individual
resource limits for the schedule.
7. To edit a resource limits group schedule, select the schedule from the Schedule
List and click Edit. The Timeouts page of the Edit Resource Limits Group
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Schedule window opens. Use the pages of the Edit Resource Limits Group
Schedule window to specify the individual resource limits for the schedule.
8. To delete a resource limits group schedule, select the schedule from the
Schedule List and click Delete. The selected resource limits group schedule is
deleted.
9. Click OK. The Edit Resource Limits Group window closes. The new resource
limits group schedule is created and any changes that you have made to the
resource limits parameters are saved. Control returns to the Resource Limits
window. The next step to setting up resource limits is to assign users to the
resource limits groups.

Specifying values for the resource limits
From the Edit Resource Limits Group Schedule window you enter the resource
limits that you want to be in effect for the schedule.

About this task
To specify the individual resource limits:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. Select a
resource limits group from the Resource limits groups list box. Click the Edit
icon. The Edit Resource Limits Group window opens. Select a schedule from
the Schedule List. Click Edit. The Edit Resource Limits Group Schedule
window opens.
2. Using the following pages of the Edit Resource Limits Group Schedule window
specify the parameters that will set up the resource limits for the selected
resource limits group schedule:
v Select the Main page to assign the schedule a priority and specify the time of
day and day of the week the schedule is in effect. You must specify these
parameters when you are creating a new schedule.
v Select the Timeouts page to specify warning and cancellation limits for idle
queries, idle connections, and server response time.
v Select the Limits page to specify warning and cancellation limits for the
maximum number of rows and bytes of data that can be retrieved. In
addition, select this page to specify the maximum number of simultaneous
connections that can be established to the database server.
v Select the SQL Verbs page to limit the SQL verbs that users assigned to this
resource limits group are allowed to use when this schedule is in effect.
v Select the Options page to specify access options including: database data
source access using either the DataQuant for Workstation or DataQuant for
WebSphere user interface and programming interface; database update
confirmation; isolation levels for user queries; mandatory account
information; and the ability to fetch all rows automatically, export data, edit
tables, and only run saved queries.
v Select the Save Data page to allow users assigned to this resource limits
group and using this schedule to save data at the database server.
v Select the Binding page to allow users assigned to this resource limits group
and using this schedule to bind or drop static packages for their queries.

106

Installing and Managing DataQuant

v Select the Object Tracking page to turn on DataQuant for Workstation or
DataQuant for WebSphere object tracking. You must turn on object tracking
in order to have meaningful object tracking reports.
v Select the LOB Options page to allow users, assigned to this resource limits
group and using this schedule, to access tables containing large object data
(LOB).
v Select the Cache page to control caching options for each user.
v Select the Object List page to define the default owner name that will be
used to filter data source objects and specify a specific list of owner names
that can be used to filter data source objects aside from the default name.
3. Click OK. The Edit Resource Limits Group Schedule window closes. All the
changes that you have made to the resource limits parameters are saved. The
Edit Resource Limits Group window stays open. From the Resource Limits
Group window, the next step to setting up resource limits is to assign users to
the resource limits groups.

Specifying Main resource limits
On the Main page of the Edit Resource Limits Group Schedule window you
specify the priority schedule number, and the day and time when the schedule will
be in effect.
The Main resource limits are as follows:
Number
Populate this text field with a number from 1 to 99. This number is used to
identify the schedule and represent the schedule's priority. A number is
assigned to the schedule only when it is created. The schedule number
must be unique. Once assigned, you cannot change the schedule number
and its assigned priority.
The schedule's priority number is used to decide which schedule is in
effect when schedules overlap. If two schedules for the resource limits
group cover the same time period, the schedule with the lower number
takes precedence.
Day Range
Select from the drop down lists a day of the week that will be the starting
day and a day of the week that will be the ending day for the schedule.
The schedule is in effect from the starting day to the ending day, inclusive.
You can specify a day range that wraps around the end of the week. For
example, selecting Friday through Monday activates the schedule Friday,
Saturday, Sunday, and Monday. In reverse, selecting Monday through
Friday activates the schedule Monday, Tuesday, Wednesday, Thursday, and
Friday.
Time Range
Select from the drop down lists a time to start and a time to end the
schedule. The schedule is in effect from the start time to the end time,
inclusive. Time is specified using a 24 hour clock. You can specify a time
range that wraps around midnight. For example, selecting 23:00 through
7:00 will activate the schedule from 11:00 at night until 7:00 in the morning.
In reverse, selecting 7:00 through 23:00 will activate the schedule from 7:00
in the morning till 11:00 at night.
Status Use these radio buttons to set the status of the individual schedule. The
status of the whole Resource Limits group, set using Status on the Edit
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Resource Limits Group window, takes precedence over the individual
schedule status. There are two choices of status:
v Active to activate this schedule.
v Inactive to deactivate this schedule. An inactive schedule remains as it
was defined until you activate it or delete the schedule from the
resource limits group. You can activate the schedule at any time.

Specifying Timeouts resource limits
On the Timeouts page of the Edit Resource Limits Group Schedule window you
set the timeout warning and cancellation limits for idle queries, idle connections,
and data source response time.
Idle Query Timeouts and Server Response Timeouts resource limits can be set for
both data sources and for individual queries. The Idle Connection Timeouts
resource limit can only be set for data sources and not for individual queries. The
Timeouts resource limits are as follows:
Idle Query Timeouts
These fields specify the amount of time that a query can remain idle. The
Warning limit field displays the number of seconds that a query can
remain idle before the user is informed and asked if the query should be
canceled. The Cancel limit field displays the number of seconds that a
query can remain idle before the query is automatically canceled.
Server Response Timeouts
These fields specify the amount of time that can be spent waiting for a
response from the database. The Warning limit field specifies the number
of seconds that can elapse before the user is informed and asked if the
database request should be canceled. The Cancel limit field specifies the
number of seconds that can elapse before the database request is
automatically canceled.
Note: A lower timeout limit prevents long running, runaway queries. A
higher timeout limit allows database requests to complete when the
database server is slow due to resource contention or other reasons.
Idle Connection Timeouts
This field specifies the amount of time that an idle connection to a
database data source is retained. The Cancel limit field specifies the
number of seconds that an idle connection is retained before it is
automatically closed.
Note: A lower timeout limit minimizes the resources consumed at the
database by idle connections. A higher timeout limit minimizes the
overhead of establishing connections.

Specifying Limits resource limits
On the Limits page of the Edit Resource Limits Group Schedule window you set
the warning and cancellation limits for the maximum number of rows and bytes of
data that can be retrieved from the database data source. In addition, you can
specify the maximum number of simultaneous connections that can be established
to the data source.
Limits resource limits can be set for data sources. The Limits resource limits are as
follows:
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Maximum Rows to Fetch
These fields specify the limits for the number of rows of data that can be
retrieved from a database data source when running a query. The Warning
limit field specifies the number of rows that can be retrieved from the data
source before you are notified that a row limit has been reached. The user
is prompted to select whether more data should be fetched or should the
query be canceled. The Cancel limit field displays the number of rows that
can be retrieved from the data source before the row limit is reached. The
query is then automatically cancelled.
Maximum Bytes to Fetch
These fields specify the limits for the number of bytes of data that can be
retrieved from a database data source when running a query. The Warning
limit specifies the number of bytes that can be retrieved from the data
source before the user is notified that the byte limit has been reached. The
user is then prompted to specify whether more data should be fetched or
should the query be canceled. The Cancel limit displays the number of
bytes that can be retrieved from the data source before the byte limit is
reached. The query is then automatically cancelled.
Maximum Connections
This field specifies the limit for the number of simultaneous connections
that can be established to a database data source. The Cancel limit
specifies the number of simultaneous connections that can be established to
a data source before the query requesting the next connection is
automatically canceled. Setting the limit to zero (0) indicates that there is
no limit to the number of connections.
Generally, connections to database data sources are reused. If you run one
query at a data source, then run another query at the same data source,
only one connection is required. However, if you run those two queries
simultaneously, then two connections are required. If another connection to
a data source is required and this limit is reached, an error is returned and
the operation is not performed.
Note: To enable table editing, you must specify that two or more
simultaneous connections are allowed.

Specifying SQL Verbs resource limits
On the SQL Verbs page of the Edit Resource Limits Group Schedule window you
specify the SQL verbs that users assigned to this resource limits group are allowed
to use when this schedule is in effect.
If a user tries to run a query that contains a disallowed verb, the query is canceled
without sending the SQL to the data source. SQL Verbs resource limits can be set
for data sources.
The use of the following SQL verbs can be controlled:
v ACQUIRE
v ALTER
v CALL
v COMMENT
v CREATE
v DELETE
v DROP
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v
v
v
v
v
v
v
v
v
v
v

EXPLAIN
GRANT
INSERT
LABEL
LOCK
REFRESH
RENAME
REVOKE
SET
SELECT
UPDATE

Specifying Options resource limits
On the Options page of the Edit Resource Limits Group Schedule window you
specify the levels of access users have to a data source and the data source objects.
Options resource limits can be set for data sources. The Options resource limits
are as follows:
Allow access to data source from user interface
This field specifies whether you have permission to access a data source
from the DataQuant for Workstation user interface when the current
resource limits group schedule is in effect.
Allow access to data source from programming interface
This field specifies whether you have permission to access a data source
from the DataQuant for Workstation application programming interface
(API) when the current resource limits group schedule is in effect.
Fetch all rows automatically
This field specifies how the data source will send query results data to the
application. By default, data is requested from the data source only as
required to display query results. For example, if 20 rows fill up the query
results window, only 20 rows are requested from the data source. When
you scroll down to make the 21st row visible, more data is requested. If
you run a query and then wait before scrolling down, the query remains
active for that wait time, consuming resources at the data source. If this
parameter is enabled, data is requested repeatedly until all data is received,
independent of your scrolling requests.
Confirm database updates
This field specifies whether or not you must confirm all data source
changes resulting from the queries that you run or the actions that you
perform when editing tables. If this check box is selected, you will be
prompted for confirmation before any data source changes can occur. If
this check box is cleared, data source changes can occur without
confirmation.
You can override this resource limit setting using the Confirm parameter
in a Procedure command. The following table shows the correlation of the
parameters, depending on the specified values.
Confirm database updates
value
Selected
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Procedure parameter value
confirm=yes

The confirmation dialog
behavior
appears

Confirm database updates
value

Procedure parameter value

The confirmation dialog
behavior

Selected

confirm=no

does not appear

Selected

not specified

appears

Cleared

confirm=yes

appears

Cleared

confirm=no

does not appear

Cleared

not specified

does not appear

Enable exporting of data
This field specifies whether a user can export query result data to a file
using the Export command from the File menu or the EXPORT DATA
procedure command.
Enable table editing
This field specifies whether or not you can edit a table using the table
editor feature .
Allow running saved queries only
This field specifies whether or not you can create and save new queries at
the database data source. If checked, you can only run queries that are
saved at the database data source. If clear, you can run queries, as well as
create and save new queries at the database data source.
Isolation level for queries
The Isolation level for queries parameter only applies to databases that
support transactions.
This field specifies the level of transaction isolation to be applied to a
user's queries. There are varying levels of isolation, each with a differing
degree of impact on transaction processing in the database.
Consult with your database administrator or the database server
documentation to determine if the database server being used is configured
to support transaction processing.
Valid values include:
v Default specifies that the isolation level for a query will be the default
specified for all applications.
v Repeatable Read specifies that the isolation level for a query will be
Repeatable Read (RR). The RR isolation level provides the most
protection from other applications.
v All (RS) specifies that the isolation level for a query will be Read
Stability (RS).
v Cursor Stability (CS) specifies that the isolation level for your query
will be Cursor Stability (CS). The CS isolation level provides the
maximum concurrency with data integrity.
v Change (UR) specifies that the isolation level for your query will be
Uncommitted Read (RS) which allows an application to read
uncommitted data.
v No Commit (NC) specifies that the isolation level for your query will be
No Commit (NC). An application running with an isolation level of NC
can not make permanent database changes.
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Account
This field specifies the default account information that will be sent to a
data source when you connect to that data source.
Account can be overridden
This field specifies whether you are allowed to override the default
accounting information specified in the Account field when connecting to a
data source. If selected, you can enter a new accounting string using the
Set User Information window. If clear, you cannot enter new accounting
information and you are prevented in some cases from accessing data
source objects that are not owned by your resource limits group.
Require account information
This field specifies whether you must specify a valid accounting string in
the Set User Information window before connecting to a database when
this schedule is in effect.
Allow printing
This check box must be selected in order for you to print objects that are
stored on the data source.

Specifying Save Data resource limits
On the Save Data page of the Edit Resource Limits Group Schedule window you
specify whether users assigned to this resource limits group and using this
schedule can save data at the database data source.
Save Data resource limits can be set for data sources. The Save Data resource
limits are as follows:
Allow save data command
This field specifies whether you can save data at the database data source.
Saving data can be extremely resource-intensive. As a result it can have a
significant impact on your database and network.
Default table space
This field specifies the default table space name that will be used for tables
created with the save data command. This field is only available if the
Allow save data command has been selected. The syntax of the table space
name that you specify must conform to the database rules for table space
names. Any value that you specify is used as part of the CREATE TABLE
SQL statement that runs when you save data to a new table. Entering an
asterisk (* ) specifies that the default table space will be taken from a user's
profile in the RDBI.PROFILE_VIEW.
You can switch the RDBI.PROFILE_VIEW to use RDBI.PROFILES or Q.PROFILES
tables by specifying them during the QMF Catalog creation.
Default table space can be overridden
This field specifies whether you can override the default table space. If
selected, you can specify any table space name subject to database security
authorizations. If this check box is not selected, you must use the table
space name specified in the Default table space field.
Allow to replace any existing data
This field specifies whether a user can override the existing data when the
objects are exported or imported to the database. If this option is selected,
a user can replace the existing data with the new one in the database. If
this check box is clear, a user can only append new data to the existing
one.
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Specifying Binding resource limits
On the Binding page of the Edit Resource Limits Group Schedule window you
specify whether users assigned to this resource limits group and using this
schedule can bind or drop static packages for their queries to or from the data
source.
Binding resource limits can only be set for data sources. The Binding resource
limits are as follows:
Allow binding of packages
This field specifies whether or not you can bind static packages for your
queries on the database data source.
Allow dropping of packages
This field specifies whether or not you can drop static packages from the
database data source.
Default collection ID
This field specifies the default collection ID for the static packages that you
bind.
Default collection ID can be overridden
This field specifies whether you must use the default collection ID. If this
check box is selected, you can specify any collection ID subject to database
security authorizations. If this check box is clear, you must use the default
collection ID that is specified in the Default collection ID field.
Default isolation level
This field specifies the default isolation level for the static packages that
you bind. You can select one of the isolation levels:
v Repeatable Read specifies that the default isolation level for the static
packages will be Repeatable Read (RR). The RR isolation level isolates
the SQL statements in the static package from the actions of concurrent
users for rows the requester reads and changes, including phantom
rows. RR isolation provides the most protection.
v All (RS) specifies that the default isolation level for the static packages
will be Read Stability (RS). The RS isolation level isolates the SQL
statements in the static package from the actions of concurrent users for
rows the requester reads and changes
v Cursor Stability (CS) specifies that the default isolation level for the
static packages will be Cursor Stability (CS). The CS isolation level
isolates the SQL statements in the static package and the current row to
which the database cursor is positioned from the actions of concurrent
users for changes the requester makes.
v Change (UR) specifies that the default isolation level for the static
packages will be Uncommitted Read (UR). The UR isolation level
isolates the SQL statements in the static package from the actions of
concurrent users for changes the requester makes.
v No Commit (NC) specifies that the default isolation level for the static
packages will be No Commit (NC). The NC isolation level does not
isolate the SQL statements in the static package from the actions of
concurrent users for changes the requester makes.
Default isolation level can be overridden
This field specifies whether you can override the isolation level specified in
the Default isolation level field. If this check box is selected, you can
specify any isolation level when binding packages. If this check is not
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113

selected, you must use the default isolation level specified in the Default
Isolation Level field to bind static packages.

Specifying Object Tracking resource limits
On the Object Tracking page of the Edit Resource Limits Group Schedule window
you activate object tracking.
Object tracking must be enabled in order to collect the tracking data that is used to
populate object tracking reports. Object tracking reports can help you locate
unused objects, locate frequently accessed data sources such as tables or columns
and spot potential problem areas. Object Tracking resource limits can be set for
data sources.
The Object Tracking resource limits are as follows:
Enable summary object tracking
This field specifies whether summary object tracking is activated for your
resource limits group. Summary tracking records the number of times an
object is run, and the most recent times it was run and modified.
Enable detailed object tracking
This field specifies whether detailed object tracking is activated for your
resource limits group. Detailed tracking records each time the object is run,
who ran it, and the results. A large amount of data can be collected if this
option is selected.
Note: This option must be enabled to use ad hoc object tracking or SQL
text tracking.
Enable ad-hoc object tracking
This field specifies whether a record of each ad-hoc query is kept in the
summary or detail object tracking tables. An ad-hoc query is a query that
has not been named or saved at the database data source.
Note: The Enable detailed object tracking option must be enabled in
order to enable this option.
Enable SQL text tracking
This field specifies whether a record of the SQL text of each query is kept
in the detail tracking table.
Note: The Enable detailed object tracking option must be enabled in
order to enable this option.
Last Used timestamp option
This field specifies when and by which commands data objects are
updated.
Note: In cases when the object is saved to the QMF Catalog, the data is
kept in the column LAST_USED of the table Q.OBJECT_DIRECTORY. If
the object is saved to the repository, then the data is kept in the column
LAST_USED of the RSBI.OBJECTS table.
The following options are available:
v Update when object is accessed (legacy mode)
Data is updated when you run any of the following commands against
the object:
– CONVERT
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– DISPLAY
– EXPORT
– IMPORT
– PRINT
– RUN
– SAVE
v Update when object is run, saved or imported
Data is updated after performing RUN, SAVE or IMPORT commands.
v Update only when object is run
Data is updated only after performing RUN command.
Last Used timestamp options can be overridden
Indicates whether the DSQEC_LAST_RUN variable value is ignored.
This check box is cleared by default.
Select this check box to change the variable value and override the
resource limit.

Specifying LOB Options resource limits
On the LOB Options page of the Edit Resource Limits Group Schedule window
you control a users ability to access, retrieve, and save data to and from tables
containing large objects (LOBs).
A Large Object (LOB) is a DB2 for z/OS and DB2 for Linux, UNIX, and Windows
data type that houses non-traditional data such as text, multimedia, image, video,
photograph, sound, or any very large data file inside a database table. Retrieving
or saving LOB data can consume a substantial amount of resources. Even just
accessing a table that contains LOB data can be resource consumptive. Using the
LOB Options resource limits, you can control access to tables on the database data
source that include LOB data. LOB Options resource limits can be applied to both
data sources and individual queries.
The LOB Options resource limits are as follows:
LOB Retrieval Option
This field specifies whether a user can retrieve large object (LOB) data
when this schedule is in effect. You can select one of the following:
v Disable LOB columns specifies that users can not retrieve LOB data and
can not query or access any table that contains LOB data.
v Disable LOB data retrieval specifies that users can not retrieve LOB
data but can query tables that contain LOB data. Query result data will
be returned for all columns in the table except those that contain LOB
data.
v Retrieve LOB data on demand specifies that users can query tables that
contain LOB data and result data will be returned for all columns
including those columns that contain LOB objects. However, the results
data for the LOB columns will not actually be displayed in the column.
A pointer is displayed. When the user selects the pointer, the LOB data
will be displayed in the query results.
You can also pull the data from the database by double-clicking on the
pointer.
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v Retrieve LOB data automatically specifies that users can query tables
that contain LOB data and the result data will be returned for all
columns, including those columns that contain LOB objects.
This option pulls ALL of the LOB data for ALL of the LOB columns
from the database to the local computer.
This option can potentially consume a large amount of resources and
time. The actual LOB data is not displayed in grids and reports. Instead,
pointers to the LOB data are displayed.
Enable saving LOB data
This field specifies whether users can save LOB data on the database data
source.
Maximum LOB column size
This field specifies the maximum size of a LOB column, in kilobytes, up to
2G (the maximum LOB size). The default is 0, no maximum. If a user
queries a table with LOB data that is larger than the maximum, the LOB
data will not be returned for display.
LOB options can be overridden
This field specifies whether a user can override the default LOB Options
resource limits that have been specified for their group.

Specifying Report Center resource limits
You can control the level of QMF Report Center functionality allowed for members
of a resource limits group.
With QMF Report Center you can generate custom reports using shared queries,
forms, procedures and tables that are stored on the database server. The custom
reports can then be viewed and manipulated in a variety of applications.
To control which Report Center functions are authorized for a resource limit group,
you specify settings on the Report Center page of the Edit Resource Limits Group
window.
The Report Center resource limits are as follows:
Allow display of all object types
Select this check box to allow members of this resource limits group to
access the objects that are used for their QMF Report Center reports.
Users do not need special permission to use the QMF Report Center
application or run reports. However, in order to create new reports they
need access to the stored objects. Some users might not have permission to
access these objects. By selecting this check box you are authorizing
members of this resource limits group to access the objects that are stored
on the database server and create new reports.
Note: The Allow display of all object types check box is selected by
default.
Allow administration of root node
Select this check box to allow the members of this resource limits group to
add folders to the root folder, Public Favorites, used by the QMF Report
Center application. The Public Favorites folder is stored on the database
server.
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QMF Report Center uses two top-level folders, Personal Favorites and Public
Favorites, to store user's reports. Each folder contains reports that point to
objects that reside on the database server. The objects are not contained
within the folders.
The Personal Favorites folder resides locally on the user's machine. This
folder and the reports contained in it can only be accessed by the user who
created it.
The Public Favorites folder resides on the database server. It can be accessed
(potentially) by all QMF Report Center users. However, in order to add a
first-level sub folder to the Public Favorites folder, users must have
permission. This option gives the members of this resource limits group
that permission.
If granted permission to create a first-level sub folder, the member of the
resource limit group is authorized to use the QMF Report Center security
options to control who can run or amend the reports residing in the folder.
The Public Favorites folder can have up to 50 first-level sub folders.
Note: The Allow administration of root node check box is cleared by
default.
Allow taking ownership of node
Select this check box to allow all members of this resource limits group
authorization to take ownership of a folder or a report in the Public
Favorites folder.
If this check box is selected, users can access any report or folder in the
Public Favorites folder regardless of whether they have been granted that
access by QMF Report Center security.
Note: The Allow taking ownership of node check box is cleared by
default.

Specifying Cache resource limits
On the Cache page of the Edit Resource Limits Group Schedule window you
activate caching for query results.
With this resource limit enabled, when a query is run, the results will be cached. If
the query is run again, and nothing has changed, the results will be taken from the
cached results rather than run again at the data source. Cache resource limits can
be applied to both data sources and individual queries.
The Cache resource limits are as follows:
Cache is enabled
This field specifies whether the caching of result set data is enabled.
Caching is disabled by default. If caching is enabled, result data from a
query is cached (stored) and is available for use by other users that have
the same privileges to access this data on the data source. Caching result
set data can significantly decrease resource consumption and improve
performance. The cached result set data is not automatically refreshed.
Auto data fetching enabled
This field specifies how the cached rows of data will be retrieved. This
resource limit becomes available if Cache is enabled is selected. When
selected, this option specifies that if the query result set is taken from the
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cache, the entire result set will be presented. When this option is not
selected, 100 rows (the default) of the query result set is presented.
Data expiration interval
This field specifies the time period the query result set data will remain in
cache. You can set the time period by specifying the number of days,
hours, and minutes. After this period, the cached query result set data will
be updated.
Cache options can be overridden
This field specifies whether the cache options can be overridden.

Specifying Object List resource limits
On the Object List page of the Edit Resource Limits Group Schedule window you
specify default and allowed owner names for data sources.
With Object List resource limits, you can define the default owner name that will
be used to filter data source objects. You can also specify a specific list of owner
names that can be used to filter data source objects aside from the default name.
The Object List resource limits are as follows:
Default Owner Name
This field specifies the default owner name that will be used to filter the
data source object list.
Default Owner Name can be overridden
This check box allows the user to override the current default owner name.
Allowed Owner Names
This field specifies the list of additional owner names that can be used to
filter the data source object list. Owner names should be separated by a
comma.
Allow <USERNAME>
This check box allows the current user's owner name to be used to filter
the data source object list.
Allow <SQLID>
This check box allows the current user's SQLID to be used to filter the data
source object list.

Assigning users to resource limits groups
You must specifically assign users to a resource limits group.

About this task
Once assigned, what each user can do using DataQuant for Workstation and
DataQuant for WebSphere is dictated by the resource limits group schedule. All
users who are not assigned to a resource limits group are automatically included in
the default resource limits group Default. The Default resource limits group
schedule has no restrictions.
In order to assign a user to a resource limits group, you must first specify
information that defines the user to DataQuant for Workstation and DataQuant for
WebSphere. The process of defining users to the applications and then assigning
them to a resource limits group varies slightly depending on the resource limits
provider that was selected for the data source.
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Assigning users to repository resource limits groups
To assign a user to a repository-based resource limits group, you select directly
from the list of available users and groups that were given access to the secured
repository when it was created.

About this task
The users and groups that are available for selection were defined based on the
type of security that was selected for the repository. If LDAP security was selected,
the users and groups were obtained from the LDAP server. If Internal security was
selected, you define the user and group information using the Users and Groups
view. If no security has been specified for the repository, and resource limits are
repository based, you do not have the ability to create resource limits groups and
make assignments.
The order in which you create user information or resource limits groups does not
matter. You can create user information first, then create resource limits groups.
You can create resource limits groups first, then user information. This flexibility is
intended as creating and editing user information and resource limits group
assignments is an ongoing process as the needs of your organizations change
To assign a user to a repository-based resource limits group:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. There are two
pages. Click the Resource Limits tab. Select a resource limits group from the
list of available resource groups. Click Assign. The Assignment for [resource
limits group name] window opens.
2. The users that have been defined for the data source and are available for
assignment, but have not been assigned to the selected resource limits group,
are listed in the Not assigned list box. The users that have been assigned to the
selected resource limits group are listed in the Assigned list box. To filter the
users that are listed in the Not assigned list specify the user ID of a specific
user or a wildcard character in the Name filter field. A percent (%) sign will
generate a list of all users that have been defined for the data source. If not
listed, the user or group has not been defined. You can define a new user or
group, and then refilter the list.
3. Select the user that you want to assign to the resource limits group from the
Not assigned list. Click Assign. The user is moved to the Assigned list.
4. To remove a user from the resource limits group, select the user from the
Assigned list. Click Unassign. The user is moved to the Not assigned list. To
remove all the users from the Assigned list and move them to the Not
assigned list, click Unassign All.
5. Click OK. Your additions or changes to the resource limits group user
assignments are saved.

Results
Note: You can also make user assignments to resource limits groups on the
Assignment page of the Resource Limits window.
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About collection IDs
Collection IDs identify a group of static SQL packages or stored procedures that
serve a particular purpose or function.
DataQuant includes a set of embedded SQL statements for working with
databases. These statements are installed as queries on the database server during
the DataQuant configuration, through a process commonly referred to as binding.
The database type determines whether the queries are bound as packages of static
SQL statements (for DB2 UDB and DB2 for z/OS databases) or as a set of stored
procedures (for all supported databases, but this option is not recommended for
DB2 UDB and DB2 for z/OS). This group of installed packages or stored
procedures is called a collection.
Each version of DataQuant has its own collection. When DataQuant connects to
database server, it automatically detects proper installed collection and uses it.
However, it is useful practice to incorporate the application version in the
collection ID name to help users differentiate collections from one version of
DataQuant to another.
Depending on the database type, the length of the collection ID can have some
restrictions.
In the case of stored procedures, the notion of a collection is usually synonymous
with owner ID or schema. The maximum length for collection ID field is determined
by database restriction on the maximum schema length. For more details on
schema length limits see the database documentation.
The collections of packages are supported by DB2 databases only. DB2 databases
can function in either short names or long names mode, depending on their
configuration. In short names mode the maximum number of characters allowed in
collection ID field is 8.
The following DB2 databases can be set up to support long names:
v iSeries V5R1 or later
v DB2 for z/OS V8 or later
v DB2 UDB V8 or later
For these DB2 databases the maximum length of the collection ID is 128 characters.

Servers that support long names
Long names apply to the names of objects that reside in the QMF catalog.
The following servers support long names:
v iSeries V5R1 or later
v zOS V8 or later

Long names for objects
Long names apply to the names of objects that reside in the QMF catalog.
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Long names for QMF objects that can be saved in the QMF catalog tables that
support long names can be up to 128 characters for the owner and name fields.

Short names for objects
Long names apply to the names of objects that reside in the QMF catalog.
Short names for QMF objects that can be saved in the QMF catalog tables can be
up to eight (8) characters for the owner and up to eighteen (18) characters for the
name.

Managing user assignments for all repository resource limits groups
Each user and group that is defined for a data source can be assigned to one or
more repository resource limits groups.

About this task
The Assignment page of the Resource Limits window lists each user or group that
is defined for a data source and each resource limits group that is defined for the
data source. From this window, you can assign a user to one or more resource
limits groups from a single dialog.
To make user assignments for all resource limits groups from one dialog:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. There are two
pages. Click the Assignment tab.
2. The users and groups that have been defined for the data source are listed in
the Users and Groups field. Expand the Groups folder to see all groups.
Expand the Users folder to see all users.
3. Each Users and Groups cell has a corresponding Resource groups drop-down
list box. The Resource groups list displays all the resource limits groups that
have been defined for the data source. To select a resource limits group, click
the Resource groups cell for the user or group, click the downward arrow, and
select a new resource limits group from the list of available resource limits
groups.
4. Click Save or OK. The new assignment is made.

Assigning users to QMF catalog-based resource limits groups
To assign a user to a QMF catalog-based resource limits group you must first
define a user profile for the user, and then you assign the user profile to the
resource limits group.
The order in which you create user profiles or resource limits groups does not
matter. You can create user information first, then create resource limits groups.
You can create resource limits groups first, then user information. This flexibility is
intended as creating and editing user information and resource limits group
assignments is an ongoing process as the needs of your organizations change.
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Granting QMF catalog user profile enrollment
When a user connects to a data source the correct user profile for their user ID is
located and their enrollment status is verified to determine which resource limits
group to use.
Access to a data source will be granted to a user based on the following types of
user ID enrollment:
v Restricted enrollment, where each user ID must have a matching user profile to
gain access to the data source.
v Open enrollment, where each user ID can either have a matching user profile to
gain access to a data source or automatically fall into a default user profile called
SYSTEM.
With open enrollment, every user has access to the SYSTEM user profile, giving
every user potential access to the data source. You can create unique profiles for
some users and allow other users to use the SYSTEM default profile.
With restricted enrollment, every user must have a unique user profile in order to
access the data source. When setting up restricted enrollment, you delete the
SYSTEM profile, which prevents users without unique profiles from accessing the
data source.

Determining which QMF catalog user profile to use
When DataQuant for Workstation or DataQuant for WebSphere connects to a data
source on behalf of a user, the user ID and password they provide are validated
first by the data source. If the user information is valid, then the user ID is looked
up in the user profile table, RDBI.PROFILE_TABLE.
The RDBI.PROFILE_TABLE is created at installation. All user IDs that are included
in the Q.PROFILES table at the time of installation are included in the
RDBI.PROFILE_TABLE.
Note: After the initial copy of Q.PROFILES, any user ID added directly to
Q.PROFILES is not automatically added to the RDBI.PROFILE_TABLE. You must
add those new user IDs using a DataQuant Administrator product (Workstation or
WebSphere).
The RDBI.PROFILE_TABLE includes the following columns:
Table 11. Determining resource limits
CREATOR

ENVIRONMENT

TRANSLATION

RESOURCE GROUP

userID

WINDOWS

English

TECH

userID

NULL

English

SALES

SYSTEM

WINDOWS

English

BASIC

SYSTEM

NULL

English

SYSTEM

When you create a new user profile, an entry is made in the table for the user ID
that you enter. The Creator column is the user ID that you enter, the Environment
and Translation columns are filled for you based on the environment and
language of the host system. The Resource Group column contains the resource
limits group to which this user is assigned.
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Determining database access with QMF catalog user profiles
DataQuant for Workstation and DataQuant for WebSphere determine which
resource limits group to use by locating the user's profile from the
RDBI.PROFILE_TABLE, finding the resource limits group name in the Resource
Group column of the table, then finding that resource limits group in the
RDBI.RESOURCE_TABLE, where the resource limits and schedule are retrieved.
When you are setting up your user profiles for your environment, there are many
permutations that can be used to control data source access. The following
summarizes some of the different combinations that you might use:
For restricted enrollment:
v User ID matches a user profile. User profile names a resource limits group.
Resource limits group exists. Access to data source is based on the resource
limits and schedule for the group.
v User ID does not match a user profile. There is no default user profile called
SYSTEM. User is denied access to the data source.
For open enrollment:
v User ID matches a user profile. User profile names a resource limits group.
Resource limits group exists. Access to data source is based on the resource
limits and schedule for the group.
v User ID does not match a user profile. There is a default user profile called
SYSTEM. The default user profile SYSTEM names a resource limits group. The
resource limits group exists. Access to data source is based on the resource limits
and schedule for the group.
v User ID matches a user profile. No resource limits group is assigned. Access to
the data source is based on the limits set for the default resource limits group.
v User ID does not match a user profile. There is a default user profile called
SYSTEM. There is no resource limits group that has been defined for the
SYSTEM user profile. User has access to the data source based on the limits set
for the default resource limits group.

Assigning users to QMF catalog resource limits groups
To assign a user to a QMF catalog-based resource limits group you must first
define a user profile for the user, and then you assign the user profile to the
resource limits group.

About this task
The order in which you create user profiles or resource limits groups does not
matter. You can create user information first, then create resource limits groups.
You can create resource limits groups first, then user information. This flexibility is
intended as creating and editing user information and resource limits group
assignments is an ongoing process as the needs of your organizations change.
To assign users to a QMF catalog resource limits group:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. There are two
pages. Click the Resource Limits tab. Select a resource limits group from the
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123

2.

3.

4.

5.

6.

list of available resource groups. Click Assign. The Assign User Profiles to
[resource limits group name] window opens.
The user profiles that have been created for the data source and are available
for assignment are listed in the User Profiles Not Assigned list box including
the SYSTEM user profile. You can modify the user profiles that are listed using
the Show User Profiles with creator matching field. In this field you can
specify the user ID of a specific user profile or a wildcard character. A percent
(%) sign will generate a list of all user profiles that have been created for the
data source. Click the Refresh List button to initiate the search. All the user
profiles stored in the table, RDBI.PROFILE_VIEW that match the value you
entered are retrieved. The users that have been assigned to the selected
resource limits group are listed in the Assigned list box.
If the user ID that you want to assign to a resource limits group is not listed in
the Not Assigned list, click Create New to create a new user profile. The New
Profile window opens. In the Creator field, specify a valid user ID for a user.
Click OK. The New Profile window closes. The new user profile is created and
assigned to the resource limits group. Control returns to the Assign User
Profiles to [resource limits group name] window.
Select the user that you want to assign to the resource limits group from the
Not Assigned list. Click Assign. The user is moved to the Assigned list. To
move all the users from the Not Assigned list to the Assign list, click Assign
All.
To remove a user from the resource limits group, select the user from the
Assigned list. Click Unassign. The user is moved to the Not Assigned list. To
remove all the users from the Assigned list and move them to the Not
Assigned list, click Unassign All.
Click OK. Your additions or changes to the resource limits group user
assignments are saved.

Results
Note: You can also make user assignments to resource limits groups, and create,
edit and delete user profiles, from the User Profiles page of the Resource Limits
window.

Managing user profiles
All users that will be assigned to a QMF catalog based resource limits group must
have a user profile.

About this task
You can use the User Profiles page of the Resource Limits window to create, edit
or delete user profiles, and assign new user profiles that you create to QMF catalog
resource limits groups.
To create, edit or delete user profiles:

Procedure
1. From the Repository Explorer view, right-click a data source. Select Properties
from the pop-up menu. The Properties for [data source] window opens. Click
the Resource Limits folder. The Resource Limits window opens. There are two
pages. Click the User Profiles tab.
2. The user profiles that have been created for the data source and meet the most
recent search criteria are listed in the User Profiles list box including the
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SYSTEM user profile. You can modify the user profiles that are listed using the
Show User Profiles whose names match field. In this field you can specify the
user ID of a specific user profile or a wildcard character. A percent (%) sign will
generate a list of all user profiles that have been created for the data source.
Click the Refresh List button to initiate the search.
3. To add a new user profile, click Add. The User Profile window opens. Specify
the field values and click OK. The user profile is created and assigned to a
resource group that you specify. Control returns to the User Profiles page.
4. To edit a user profile, select the user profile that you want to change from the
User Profiles list. Click Edit. The User Profile window opens. Make the
changes to the field values and click OK. The changes are saved and control
returns to the User Profiles page.
5. To delete a user profile, select the user profile that you want to delete from the
User Profiles list. Click Delete. The user profile is deleted from the profile
table.
Note: If you are choosing to use restricted enrollment, you must delete the
SYSTEM user profile.
6. Click Apply or OK. The changes that you have made to the user profiles are
saved.

Creating user profiles
You can create a new user profile or edit an existing user profile using the User
Profile dialog.

About this task
If you are creating a new user profile, you can assign the new user profile to a
resource limits group from the same window. If you are editing a user profile you
can change the resource limits group assignment to a different group. In either
case, the resource limits group you select must already have been created.
To create a new or edit an existing user profile:

Procedure
1. From the Repository Explorer view, using DataQuant for Workstation,
right-click a data source. Select Properties from the pop-up menu. The
Properties for [data source] dialog opens. Click the Resource Limits folder. The
Resource Limits window opens. There are two pages. Click the User Profiles
tab. Click Add. The User Profile window opens.
2. Specify a valid user ID for the user profile in the Creator field.
3. Specify a resource limits group to which the user profile will become a member
in the Resource Group field. Unless otherwise specified all new user profiles
are automatically assigned to the default resource limits group SYSTEM. To see
a list of the resource limits groups defined for this data source, click the button
with three dots to the right of the field. The Resource Limits Groups at [data
source] window opens. From the Resource Limits Groups at [data source]
window, select a resource limits group for the user profile. Click OK. The user
profile is assigned to the selected resource limits group. Control returns to the
User Profile window.
4. Specify a table space name that will be used when this user saves data using
the SAVE DATA command in the Space field. This field is only applicable if the
Default table space can be overridden resource limit setting in the Save Data
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tab has been checked, allowing users to override the default table space name
with a unique name. Click OK. The user profile is created.

Selecting a resource limits group for a user profile
Use the Resource Limits Group at window to view a list of the resource limits
groups that have been defined for the data source.

About this task
You can select from the list of available groups, the resource limits group to which
you will assign the user profile that you are creating or editing.
To select a resource limits group for a user profile:

Procedure
1. From the Repository Explorer view, using DataQuant for Workstation,
right-click a data source. Select Properties from the pop-up menu. The
Properties for [data source] window opens. Click the Resource Limits folder.
The Resource Limits window opens. There are two pages. Click the User
Profiles tab. Click Add. The User Profile window opens. Click the button with
three dots. The Resource Limits Group at window opens.
2. From the Resource limits group list, select the resource limits group to which
you want to assign the user profile.
3. Click OK. The user profile is assigned to the resource limits group that you
selected. The Resource Limits Groups at window closes. Control returns to the
User Profile window.
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Chapter 5. Managing repositories
Administrators are responsible for the ongoing maintenance of shared repositories,
and the query and reporting environment.
The following tasks describe maintaining repositories:

Deleting a repository
You can delete a repository from shared repository storage.

About this task
To delete a repository:

Procedure
1. The Repositories view is usually open and docked to the left, next to the
Repository Explorer view. If closed, you can open the Repositories view by
selecting Repositories from the View menu.
2. From the Repositories view, right-click the repository that you want to delete.
3. From the pop-up menu, select Delete Repository. A confirmation message is
issued. If you are sure that you want to delete the repository, click OK.

Editing shared repository storage properties
You can edit the properties of shared repository storage.

About this task
To edit shared repository storage properties:

Procedure
1. The Repositories view is usually open and docked to the left, next to the
Repository Explorer view. If closed, you can open the Repositories view by
selecting Repositories from the View menu.
2. From the Repositories view, right-click the shared repository storage whose
properties you want to modify. From the pop-up menu, select Edit. A multiple
page Edit Repository Storage window opens displaying the properties that you
can change.
3. Select Connection to change the JDBC connection or user login information.
The Connection page opens. You can make any of the JDBC connection or user
login information changes from this page.
4. Select Objects to update the repository storage database objects. The Objects
page opens. You can update the repository storage database objects from this
page.
5. Select Protection to change the protection status of the repository storage
tables. The Protection page opens. You can make any changes to the protection
status of the repository storage tables and grant or revoke users access to the
tables from this page.
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v Unprotected: Specifies that you will connect to the repository in unprotected
mode. In this mode, dynamic query access to the repository storage tables,
within which the repository resides, will be allowed. If the repository storage
tables are restricted to the connecting user ID, the connection will fail. If the
repository storage tables are unrestricted to the connecting user ID, the
connection will be made and the dynamic query will process.
v Auto: Specifies that the protection mode will be selected automatically
depending on whether a collection of stored procedures or static SQL
packages are available. If available, the repository storage tables within
which the repository resides will be accessed using the specified stored
procedures or static SQL packages. If the stored procedures or static SQL
packages are unavailable, dynamic query access (unprotected mode) will be
used.
v Protected: Specifies that you will connect to the repository in protected mode
using the specified stored procedures or static SQL packages to access the
repository storage tables within which the repository resides. If the specified
set of stored procedures or static SQL packages are not available, the
connection will fail.
6. Click OK. The Edit Repository Storage window closes. The changes that you
have made are applied.

Editing JDBC connection and user login information
You use the Connection page of the Edit Repository Storage window to edit the
JDBC connection information and the user login information that will be used to
connect to the shared repository storage.

About this task
To edit the JDBC connection and login user information for shared repository
storage:

Procedure
1. Open the Connection page of the Edit Shared Repository Storage window.
2. In the Connection type radio group, select JDBC or JNDI. If you selected
JNDI:
a. In the Data Source name field, specify the JNDI data source name and
location.
b. Click Advanced to specify any driver-specific connection string keywords
and their values that will be used for the database that is hosting the
repository storage tables. For information on any keywords that are
required by a selected database driver, consult the specific driver's
documentation.
If you selected JDBC:
a. In the JDBC Driver field specify the library for the JDBC driver that will be
used to access the database that is hosting the repository storage. You can
select from a drop down list of libraries that you defined when you set up
the JDBC driver information. You can use the ellipsis (...) to the right of the
field to open the JDBC Libraries dialog where you can create additional
JDBC driver libraries.
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Note: If you work with a DB2 for z/OS database, you can use the Direct
DRDA Connection. In contrast to JDBC libraries, the Direct DRDA
Connection comes with DataQuant and does not require additional driver
installation.
Note: The Direct DRDA Connection is supported only for DB2 for z/OS
Version 8, Version 9, and Version 10. Do not use it for DB2 LUW or DB2 for
iSeries.
See Using DRDA to connect to database repositories and data sources for
more information.
b. In the JDBC URL list, specify the URL that points to the database that hosts
the repository storage within which the repository to which you want to
connect resides.
The format for the URL can be displayed in the list.
Note: You can also use the Build URL by URL Template dialog box to
form the correct string.
Click Build URL to open the Build URL by URL Template dialog box. From
the JDBC URL drop-down list, select the template. In the table, specify the
server, port, and database information and click OK. The result URL string
is added to the JDBC URL list.
c. Click Advanced to specify any driver-specific connection string keywords
and their values that will be used for the database that is hosting the
repository storage tables. The list of available advanced properties will
change depending on both the type of driver being used, and the version of
the driver. For information on any keywords that are required by a selected
database driver, consult the specific driver's documentation.

3.

4.
5.
6.

Note: For the DB2 Type 4 UDB driver and the DB2 Universal JDBC Driver,
to receive extended SQL exception error messages, check the
retrieveMessagesFromServerOnGetMessage option in the Advanced JDBC
Settings window.
d. If you use the Direct DRDA Connection, bind packages by clicking the Bind
Packages button.
In the User Information dialog, select User ID and password are required to
require the use of a user ID and password when accessing the database that is
hosting the repository storage. If the database that is hosting the repository
storage allows access without a user ID and password, selecting this option will
override that allowance, and a user ID and password will be required to access
the repository storage tables.
To remember this password every time you use the specified user ID to connect
to the database, select the Remember password check box.
Click Test Connection to test the connection to the database. If you have
specified any information incorrectly you will not be able to connect.
If you have completed making changes to the repository storage properties,
click OK. If you will be making additional changes, click the Objects or
Protection tab, depending on the changes that you are making.

Updating database objects
You use the Objects page of the Edit Shared Repository Storage dialog to update
the database objects that are required for the repository storage.
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About this task
To update the repository storage objects that reside on the database:

Procedure
1. Open the Objects page of the Edit Repository Storage window.
2. Optionally you can type the owner name in the Owner ID field, if you work
with DB2 databases. The Owner ID provides the administrator privileges to the
user who operates under the login without SYSADM authority.
Tip: (for DB2 for z/OS databases)

|

When the user without administrator privileges creates or updates the shared
repository storage tables and enters the owner name in the Owner ID field, the
user login and Owner ID are automatically inserted to the RSBI.AUTHID_TABLE
as the PRIMARY_ID and SECONDARY_ID correspondingly. This allows the user to
create shared repositories with database-based security provider and
automatically work with the repositories as an administrator.
3. Click Update to check if the repository storage objects have been created or
have to be updated. Depending on the status of the objects you will proceed as
follows:
v If all the objects have not changed, a message is issued. Click OK in the
message window.
v If the objects have to be updated, then the Update repository storage tables
page opens listing the SQL statements that will be used to update the
required repository storage tables. You can make changes to the SQL
statements as described on the page.
4. If you have completed making changes to the repository storage properties,
click OK. If you will be making additional changes, click the Connection or
Protection tab, depending on the changes that you are making.

|
|
|
|
|
|

Editing protection options
You use the Protection page of the Edit Shared Repository Storage window to
update the protection options for the repository storage tables.

About this task
To update the protection options for the repository storage tables:

Procedure
1. Open the Protection page of the Edit Shared repository Storage window.
2. Depending on the current status of the Protection method check box, you can
change the protection status of the repository storage table in one of the
following ways:
v Clear the Protection method check box to remove the protected status of the
repository storage tables. This means that all users will have access to the
repository storage tables and can make changes to any of those tables.
v Select the Protection method check box to specify that you will protect the
repository storage tables. The fields that you will use to specify the
protection method become available.
3. Select one of the following protection methods:
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4.

5.

6.

7.

8.

v Select Stored procedures to specify that you will use stored procedures to
protect the repository storage tables. You can select this option if the
repository storage tables are located on one of the following databases:
– Informix
– DB2 UDB LUW V9 and above
– DB2 z/OS V9 and above in NFM
– DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
– Microsoft SQL Server
v Select Static SQL packages to specify that you will use static SQL packages
to protect the repository storage tables. You can select this option if the
repository storage tables are located on a DB2 database that you will connect
to using the IBM DB2 Universal driver for JDBC or the Direct DRDA
connectivity provided by the product (the latter option is available for DB2
for z/OS connectivity only).
Type, or select from the drop-down list, the name that you want to use to
identify the collection of stored procedures or static SQL packages in the
Collection ID field.
Optionally you can type the owner name in the Owner ID field, if you work
with DB2 databases. The Owner ID provides the administrator privileges to the
user who operates under the login without SYSADM authority.
Click Create. The stored procedures are created or the static SQL packages are
bound. A message is issued that informs you of the success of the either
process. You can also use the Delete button to remove a collection of stored
procedures or packages.
Specify which users will have permission to run the stored procedures or static
SQL packages for the repository storage tables on this database. To grant
permission to all users, enter PUBLIC in the User IDs field and click Grant. To
grant permission to specific users, type their user IDs in the field and click
Grant. A message is issued that informs you that the selected user IDs have
been granted permission to run the stored procedures or packages.
Optionally, you can revoke permission to run the stored procedures or static
SQL packages from any user that is listed in the User IDs list box. To revoke
permission from one or more users, highlight one or more of the user IDs and
click Revoke. A message is issued informing you that permission to run the
stored procedures or static SQL packages has been revoked from the selected
user IDs.
If you have completed making changes to the repository storage properties,
click OK. If you will be making additional changes, click the Objects or
Connection tab, depending on the changes that you are making.

Editing QMF catalog plug-in properties
You use the QMF Catalog Plug-in Parameters dialog to change or update the QMF
catalog plug-in parameters for a data source.

About this task
To edit the QMF catalog plug-in properties:

Procedure
1. The Repositories view is usually open and docked to the left, next to the
Repository Explorer view. If closed, you can open the Repositories view by
selecting Repositories from the View menu.
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2. From the Repositories view, right-click the data source whose QMF catalog
plug-in properties you want to modify. From the pop-up menu, select
Properties. The Properties window opens. Select Plug-ins. The Plug-ins
window opens. If the QMF Catalog Plug-in has been enabled for this data
source (the Enable plug-in check box is selected), the Parameters button is
available. Click Parameters. The QMF Catalog Plug-in Parameters window
opens.
3. Select Catalog Tables to update the QMF catalog tables. The Catalog Tables
page opens. You can update the QMF catalog tables from this page.
4. Select Protection to change the protection status of the QMF catalog tables. The
Protection page opens. You can make any changes to the protection status of
the QMF catalog tables and grant or revoke users access to the tables from this
page.
5. Select Catalog to change the QMF catalog that the current data source will use.
The Catalog page opens. You can make any changes to the QMF catalog
selected for this data source.
6. Select Sample Tables to create a set of sample tables for the current data
source. The Sample Tables page opens. You can create the sample tables from
this page.
7. Click OK. The Edit QMF Catalog Plug-in Parameters window closes. The
changes that you have made are applied.

Updating QMF catalog tables
Use the Catalog Tables page of the QMF Catalog Plug-in Parameters window to
update the QMF Catalog tables for a data source.

About this task
You would update the QMF Catalog tables if a new version of DataQuant has been
installed or if you want to change from a QMF catalog that supports short names
to one that supports long names.

Procedure
1. Open the Catalog Tables page of the QMF Catalog Plug-in Parameters window.
2. To update a set of QMF catalog tables that supports short names for objects,
select Update catalog tables to support short names. DataQuant will check the
existing QMF catalog tables on the data source, and update or add to the
existing tables as necessary. You are given the opportunity to confirm and
modify the SQL statements used to create the tables. Any data that is in the
existing catalog tables is maintained.
Select this option if you are upgrading from a previous version of DataQuant
and the existing QMF catalog tables will continue to support only short names
for objects.
3. To update a set of QMF catalog tables that supports long names for objects,
select Update catalog tables to support long names. DataQuant will check the
existing QMF catalog tables on the data source, and update or add to the
existing tables as necessary. You are given the opportunity to confirm and
modify the SQL statements used to create the tables. Any data that is in the
existing catalog tables is maintained.
Select this option if you are upgrading from a previous version of DataQuant
and the existing QMF catalog tables will continue to support long names for
objects. You would also select this option if you want to update the QMF
catalog tables from supporting short names to supporting long names. If an
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existing set of QMF catalog tables that use short names is detected on the data
source, those tables will be converted to support long names.
Note: In order to select this option, the data source must support long names.
DataQuant will check to ensure that the data source supports long names.
|
|
|

Tip: When the QMF Catalog tables are updated, QMF checks whether the
required QMF objects exist and restores the objects that are dropped to the
appropriate locations in a database.

|
|
|
|
|
|
|
|

The names of the QMF objects that are generated in a database when you
create the QMF Catalog and their property values are stored in the
RDBI.SERVER_INFO table. If a database administrator renames some objects in
a database, the information in the RDBI.SERVER_INFO becomes invalid.
During the update process, QMF detects the QMF objects that were renamed
and saves their actual names to the RDBI.SERVER_INFO table. The changes
that are made to the RDBI.SERVER_INFO table during the update process are
displayed in a log file.
4. Click OK to close the QMF Catalog Plug-in Parameters window. Any changes
that you have made to the QMF Catalog Plug-in parameters are saved.

Updating the protection status of QMF catalog tables
Use the Protection page of the QMF Catalog Plug-in Parameters window to update
the QMF catalog tables protection options.

About this task
You would update the QMF catalog table protection if you are updating your
version of DataQuant; changing the type of protection that has been specified for
the tables; or changing the stored procedures or static SQL packages that you
originally specified. You can also change user permissions to use the QMF catalog
packages at any time.

Procedure
1. Open the Protection page of the QMF Catalog Plug-in Parameters window.
2. To change the type of protection that will be applied to the QMF catalog tables,
select one of the following from the Connect using Protected Mode radio
group:
v Never: You select this option to specify that no protection will be placed on
the QMF catalog tables. This method will expose the QMF catalog tables to
unauthorized use. With no protection the QMF catalog tables can be accessed
by any user using dynamic queries. When the database administrator grants
permissions to a user to access the QMF catalog that resides on the database,
that permission will extend to the whole QMF catalog including the tables in
the QMF catalog that store sensitive information.
v If possible: You select this option to specify that the QMF catalog tables will
be protected using either stored procedures or static SQL packages if they are
available on the data source. You will specify the users that can run the
stored procedures or static SQL packages. If a set of stored procedures or
static SQL packages is not available, access to the QMF catalog tables will be
as if they are unprotected.
v Always: You select this option to specify that the QMF catalog tables will
always be protected using either stored procedures or static SQL packages.
You will specify the users that can run the stored procedures or static SQL
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3.
4.

5.

6.

7.

8.

9.

packages. If a set of stored procedures or static SQL packages is not
available, the query to access the QMF catalog tables will fail.
If you selected If possible or Always from the Connect using Protected Mode
radio group, the Protect check box becomes available.
Select one of the following protection methods:
v Select Stored procedures to specify that you will use stored procedures to
protect the QMF catalog tables. You can select this option if the repository
storage tables are located on one of the following databases:
– DB2 UDB LUW V9 and above
– DB2 z/OS V9 and above
– DB2 iSeries (when accessed with IBM Toolbox JDBC driver)
v Select Static SQL packages to specify that you will use static SQL packages
to protect the QMF catalog tables. You can select this option if the repository
storage tables are located on a DB2 database that you will connect to using
the IBM DB2 Universal driver for JDBC or the Direct DRDA connectivity
provided by the product (the latter option is available for DB2 for z/OS
connectivity only).
Type, or select from the drop-down list, the name that you want to use to
identify the collection of stored procedures or static SQL packages in the
Collection ID field.
Optionally you can type the owner name in the Owner ID field, if you work
with DB2 databases. The Owner ID provides the administrator privileges to the
user who operates under the login without SYSADM authority.
Click Create. The stored procedures are created or the static SQL packages are
bound. A message is issued that informs you of the success of either process.
You can also use Delete to remove a collection of stored procedures or static
packages.
You must specify which users will have permission to run the stored
procedures or static SQL packages for the QMF catalog tables on this database.
To grant permission to all users, highlight PUBLIC in the User IDs list and click
Grant. To grant permission to specific users, type their user IDs in the field,
highlight one or more of the user ID(s) and click Grant. A message is issued
that informs you that the selected user IDs have been granted permission to
run the stored procedures or static SQL packages. Optionally, you can revoke
permission to run the stored procedures or SQL packages from any user that is
listed in the User IDs list box. To revoke permission from one or more users,
highlight one or more of the user IDs and click Revoke. A message is issued
informing you that permission to run the stored procedures or static SQL
packages has been revoked from the selected user IDs.
Click OK to close the QMF Catalog Plug-in Parameters window. Any changes
that you have made to the QMF Catalog Plug-in parameters are saved.

Selecting a different QMF catalog for the data source
Use the Catalog page of the QMF Catalog Plug-in Parameters dialog to select a
different QMF catalog for the data source.

About this task
To select a different catalog for the data source:

Procedure
1. Open the Catalog page of the QMF Catalog Plug-in Parameters window.
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2. From the Data source name drop-down list of available data sources in the
currently connected to repository, select the data source that hosts the QMF
catalog that you want to use.
3. From the list of available QMF catalogs available on the data source that you
selected in Data source name, select the QMF catalog that you want the data
source to use. If the QMF catalog is not listed, you can add a new extended
QMF catalog using the Add icon. You can also edit an existing extended QMF
catalog's properties using the Edit icon or delete an existing extended QMF
catalog using the Delete icon.
4. Click OK to close the QMF Catalog Plug-in Parameters window. Any changes
that you have made to the QMF Catalog Plug-in parameters are saved.
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Chapter 6. Using sample tables
Nine sample tables are supplied with the DataQuant for Workstation and
DataQuant for WebSphere applications.
These tables contain information about a fictitious electrical parts manufacturing
company. They can be useful while you are learning how to use DataQuant for
Workstation or DataQuant for WebSphere. Sample tables are only available if you
have enabled a QMF catalog for a data source.

Activating sample tables
You must activate the sample tables.

About this task
To activate the sample tables:

Procedure
1. From the Repository Explorer view, right-click a data source that has been
configured to access a QMF catalog. Select Properties from the pop-up menu.
The Properties for [data source] dialog opens. Click the Plug-ins folder. The
Plug-ins dialog box opens. Select Plug-ins from the properties tree. Verify that
the Enable plug-in check box is selected. Click the Parameters button. The
QMF Catalog Plug-in Parameters dialog box opens. Click the Sample Tables
tab. The Sample Tables dialog box opens.
2. From the Sample Tables dialog box, click Create.
3. If you are prompted with the message that says existing sample tables will be
overwritten if new tables are created, respond to the confirmation message by
clicking Yes.
4. The status bar at the bottom of the dialog window lists the sample tables that
are being created.
5. Click OK to close the QMF Catalog Plug-in Parameters dialog box.

Sample table names and descriptions
This list includes the name of each sample table that is included with the
DataQuant application.
The following sample tables are available:
Q.APPLICANT
The company's prospective employees
Q.INTERVIEW
The interview schedule for the company's prospective employees
Q.ORG
Organization of the company by department, within division
Q.PARTS
Materials supplied by the company
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Q.PRODUCTS
Products produced by the company
Q.PROJECT
The company's projects
Q.STAFF
The company's employees
Q.SALES
Sales information for the company
Q.SUPPLIER
Vendors that supply materials to the company
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Chapter 7. Using object tracking reports
Object tracking reports show you detailed and summary information on object
usage by DataQuant for Workstation or DataQuant for WebSphere users.
With this information, you can spot potential problem areas and see where changes
to resource limits group schedules are needed. Object tracking reporting is
available for data sources with repository based or QMF catalog based resource
limits. In order to report on object usage you must activate object tracking for a
data source.

Activating object tracking
To track a user's object usage on a data source, you must activate object tracking
for their resource limits group.

About this task
You can activate object tracking for a resource limits group on a data source when
you define or update the schedules for the resource limits group.
Note: If your user ID has the required authority, you can query the detail and
summary tracking tables directly using DataQuant for Workstation or DataQuant
for WebSphere and see any tracking information contained within those tables.
To activate object tracking for a data source:

Procedure
1. Right-click a data source from either the Repositories or Repository Explorer
views. Select Properties from the pop-up menu. The Properties for [data
source] window opens. Click the Resource Limits folder. The Resource Limits
window opens. There are two pages. Click the Resource Limits tab.
2. Select a resource limits group from the list of available resource limits groups.
Click Edit. The Edit Resource Limits Group window opens.
3. All of the schedules that have been defined for this resource limits group are
listed in the Schedule List list box. To edit the resource limits group schedule,
select the schedule from the Schedule List list box and click Edit. The Edit
Resource Limits Group Schedule window opens.
4. Select the Object Tracking tab.
5. Check the type of object tracking that you want to activate. Your choices are:
v Enable summary object tracking: Select this check box to activate summary
object tracking. Summary object checking tracks an object and keeps a
summarized record of actions that pertain to the record.
v Enable detailed object tracking: Select this check box to activate detailed
object tracking. Detailed object checking keeps a detailed record of each
action taken using an object.
v Enable ad hoc object tracking: Select this check box to keep a record of each
ad hoc SQL query and the SQL text of that query. Detailed object tracking
must be activated in order to use ad hoc object tracking.
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v Enable SQL text tracking: Select this check box to specify that a record of
the SQL text of each SQL query is kept. Detailed object tracking must be
activated in order to use SQL text tracking.
6. Click OK.

Running the object tracking reports
After activating object tracking you can run any of the existing reports or you can
create your own report.

About this task
To run an object tracking report:

Procedure
1. Right-click a data source from either the Repositories or Repository Explorer
views. Select Object Tracking Reports from the pop-up menu. The Object
Tracking Reports window opens.
2. Select a report from the list of available reports and click Run. The list of
available report includes both standard object tracking reports that come with
the application and customized object tracking reports that you might have
added. The following standard object tracking reports are available:
v Cancellation Summary By User: This report shows which users most
frequently have their queries cancelled. High rates of cancellation can
indicate that the user needs more training or greater resource privileges.
v Cancellation Details For Single User: This report provides details about the
queries that were cancelled for a specific user, including the query name,
SQL text, and reason for cancellation.
v Performance Summary (Maximum) by Query: This report shows
performance data for queries, including their maximum elapsed time and
number of times run. The report is sorted in descending order to highlight
the queries with the most resource consumption.
v Performance Summary (Average) By Query: This report shows performance
data for queries, including their average elapsed time and number of times
run. It is sorted in descending order to highlight the queries with the most
resource consumption.
v Performance Summary (Cumulative) For Single Query: This report shows
which users most often run a specific query and the elapsed time of the
query. Use this report once a problem query is identified to determine the
users who run the query most frequently.
v Performance Details For Single Query: This report shows detail statistics for
each run of a query. It provides performance information, such as elapsed
time and bytes fetched for each run.
v Performance Profile For Single User: This report shows which queries have
been run by a user and the resources consumed by the queries. The report is
sorted in descending order to highlight the queries with the most resource
consumption.
v Performance Summary (Cumulative) By User: This report shows which
users are most actively using DataQuant and consuming the most resources.
v Time Period Performance Summary (Cumulative) By User: This report
shows, within a time period, which users most actively used DataQuant and
consumed the most resources.
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v Cancellation Summary By Repository User: This report shows which users
most frequently have their queries that are stored in the repository cancelled.
High rates of cancellation can indicate that the user needs more training or
greater resource privileges.
v Performance Summary (Maximum) by Repository Query: This report shows
performance data for queries that are stored in a repository, including their
maximum elapsed time and number of times run. The report is sorted in
descending order to highlight the queries with the most resource
consumption.
v Performance Summary (Average) by Repository Query: This report shows
performance data for queries that are stored in a repository, including their
average elapsed time and number of times run. It is sorted in descending
order to highlight the queries with the most resource consumption.
v Performance Summary (Cumulative) by Repository User: This report shows
which users are most actively using a repository and consuming the most
resources.
v Time Period Performance Summary (Cumulative) By Repository User: This
report shows, within a time period, which users most actively used a
repository and consumed the most resources.
3. A customized object tracking report is a visual report that you have created and
saved to a file. After you create the report, you can add the customized report
to the list of available object tracking reports, by clicking the Add button in the
Object Tracking Reports window. The Add Object Tracking Report window
opens. Specify the name of the report as it will appear in the list of available
object tracking reports in the Report title field. Optionally, you can enter a
description of the report in the Report description field. Specify the name of
the file where the visual report was saved in the Report file name field.
Specify where the query that was used for the visual report resides in the
Query for report field. If the visual report includes a query that runs against an
extended QMF catalog, specify the name and where the query resides in the
Extended query for the report field. Click OK. The report is added to the list.

Maintaining object tracking tables
Detail and summary object tracking tables should be maintained on a regular basis.
Detailed object tracking data about repository based objects is stored in the
RSBI.OBJ_ACTIVITY_DTL table and detailed object tracking data about QMF
catalog based objects is stored in the Q.OBJ_ACTIVITY_DTL table. Summarized
object tracking data about repository based objects is stored in the
RSBI.OBJ_ACTIVITY_SUMM table and summarized object tracking data about
QMF catalog based objects is stored in the Q.OBJ_ACTIVITY_SUMM table.
A row is added to the Q.OBJ_ACTIVITY_DTL table and the
RSBI.OBJ_ACTIVITY_DTL for each use of an object. For example, if a user executes
a query (object) 20 times, 20 rows are added to the table.
Only one row is added to the summary tables Q.OBJ_ACTIVITY_SUMM and
RSBI.OBJ_ACTIVITY_SUMM for each object regardless of the amount of times the
object is used. So in this example, the object usage count, a field in the table,
would increase by 20, but no new rows are added. Rows are added to the
summary table only when a new object is created and rows are automatically
deleted when an object is deleted.
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Since the summary tables will not grow without boundaries and the detail tables
will, it is more important to perform maintenance on the detail tables with greater
frequency than the summary tables. The following are recommendations for
optimum performance of the Q.OBJ_ACTIVITY_DTL table and
RSBI.OBJ_ACTIVITY_DTL detail tables:
v Run RUNSTATS for the table space and index.
v Delete old data periodically.
For example, for a DB2 database, you can run this query to delete all rows older
than 30 days from the QMF catalog object detail table (if your user ID has
permission to access the summary and detail tables):
DELETE FROM Q.OBJ_ACTIVITY_DTL WHERE "DATE"

(CURRENT DATE - 30 DAYS)

For a DB2 database, you can run the following query to delete all rows older
than 30 days from the repository object detail table (if your user ID has
permission to access the summary and detail tables).
If you are using DB2 for LUW:
DELETE FROM RSBI.OBJ_ACTIVITY_DTL WHERE
( DAYS ( CURRENT DATE ) - DAYS ( DATE (’1970001’))) - ETIME/3600/24/1000 >30

If you are using DB2 for z/OS:
DELETE FROM RSBI.OBJ_ACTIVITY_DTL WHERE
CAST(( DAYS ( CURRENT DATE ) - DAYS ( DATE (’1970001’))) AS BIGINT )
*86400000 - ETIME > 2592000000

v For DB2 for z/OS, perform maintenance on the repository object detail table and
its associated auxiliary table (RSBI.ACTIVITY_LOB_DATA) and index
(RSBI.IACTIVITY_LOB_DATA). For DB2 for z/OS, perform maintenance on the
QMF catalog object detail table and its associated table space (RAADB.RAAIX2 )
and index (Q.RAAIX2). Q.RAAIX2 is a default name that can be changed by the
database administrator when the QMF catalog is created.
Note: The first-used, last-used and last-modified summary statistics stored in the
summary table are not affected when you delete detailed data.

142

Installing and Managing DataQuant

Appendix A. Accessibility
Software accessibility features help those with physical disabilities, such as
restricted mobility or limited vision, use their computers.
Note: The DataQuant for Workstation application provides the best accessibility
functionality. Users with physical disabilities who must make use of the DataQuant
accessibility features should install and run DataQuant for Workstation, as opposed
to DataQuant for WebSphere.

Standard keyboard equivalents in DataQuant for Workstation
Keyboard equivalents use keyboard keys to perform mouse actions instead of
using a mouse.
The keyboard is the most frequently used alternative for performing mouse
functions. DataQuant supports the standard keyboard equivalents that include:
v Shortcut, or accelerator keys, to perform the most frequently used functions in
pull-down menus without going to the menu. For example:
– Ctrl+S to save
– Ctrl+P to print
– Ctrl+R to run a query
Shortcuts display in the pull-down menu next to its function.
v Mnemonics, or access keys, are available to perform each function on a menu or
window. A mnemonic for a function is the underlined character in the function
name. For example:
– Press F to open the File menu
– Press O to open the Open window
Use ALT to activate the mnemonic and move the keyboard focus.
For more information, refer to the documentation for your operating system for a
complete list of standard keyboard equivalents.

Standard keyboard navigation
Keyboard navigation refers to using keys instead of a mouse to move from item to
item on your screen.
The movement is usually in the order specified by the operating system or your
application. DataQuant applications follow the standards with regard to the typical
keys used for keyboard navigation such as using TAB and SHIFT+TAB to move
between controls, and arrow keys to move up, down, and sideways between items.

Operating system accessibility
Most operating systems have a set of accessibility options that enable individuals
with disabilities to customize system-wide settings.
DataQuant applications:
v Inherit their settings from the operating system
© Copyright IBM Corp. 1995, 2015

143

v Do not interfere with keyboard accessibility features built into the operating
system

Assistive technology products
DataQuant applications support assistive technology products, such as screen
readers and voice synthesizers.
Each DataQuant application interface requires special navigation when using a
screen reader with query results. See “Navigation in DataQuant for Workstation”
or “Navigation in DataQuant for WebSphere” on page 146 for more information.

Navigation in DataQuant for Workstation
The following table shows how to accomplish various tasks using keystrokes.
To:

Process:

Activate mnemonics in
menus

Press the Alt key. Mnemonics in each menu are activated.

Obtain online help

Press F1 to open a specific help task or Alt+H to open the Help
menu. Use the arrow keys to move through the menu
selections. Press Enter to open a menu command.

Display keyboard
shortcuts

Press Ctrl+Shift+L.

Display the Draw Query
wizard

Press Ctrl+D.

Display the switch list of Press Ctrl+F6 to move forward in the switch list and
the editors of the opened Ctrl+Shift+F6 to move in the opposite direction.
DataQuant objects and
switch between the
editors
Left to right switch
between the tabs of the
opened DataQuant
objects

Press Ctrl+Page Up

Right to left switch
between the tabs of the
opened DataQuant
objects

Press Ctrl+Page Down

Move focus through each Press TAB to move forward or SHIFT+TAB to move in the
element
opposite direction.
Emulate clicks on a link

Use the TAB key to jump from link to link, then press the Enter
key to open the link.

Emulate clicks on a
button

Use the TAB key to jump from button to button, then press
Space key to activate the button.

Within a window,
Press the Enter key.
activate the default action
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Within a window, cancel
the action

Press the ESC key.

Left to right switch
between views

Press Ctrl+F7
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To:

Process:

Right to left switch
between views

Press Ctrl+Shift+F7

Left to right switch
between perspectives

Press Ctrl+F8

Right to left switch
between perspectives

Press Ctrl+Shift+F8

Left to right switch
between tabs in the
active editor

Press Alt+Page Up

Right to left switch
between tabs in the
active editor

Press Alt+Page Down

Activate command bar

Press Ctrl+Shift+C

Use screen reader for
query results

1. Run the query.

or

3. Select Export to open the Export Query Results wizard.

Use browser to display
query results in high
contrast mode for the
visually impaired

2. Press Alt+R to open the Results menu
4. Use the TAB key to move through controls. Use arrow keys
to move through selection items in the control. Select HTML
from the Export Type list. Specify where to save the file in
the File name field.
5. Press Finish.
6. Open the *.htm file in a browser.
or
1. Run the query.
2. Press Alt+R to open the Results menu.
3. Select Export to open the Export Query Results wizard..
4. Use the TAB key to move through controls. Use arrow keys
to move through selection items in the control. Select CSV
from the Export Type list. Specify where to save the file in
the File name field.
5. Press Finish.
6. Open the *.csv file in supportive software such as Microsoft
Excel.

Add object or condition

Use TAB to switch between different sections of the Query
Builder editor, and then press Spacebar to expand the sections.

Select multiple objects

1. Tab to the list box.
2. Press Shift+Arrow to select additional, consecutive rows.
3. Press Shift+Enter to add the objects.

Edit rows in list boxes
(only for rows that can
be edited)

1. TAB to the list box, such as the Global Variables window.
2. Press the spacebar or use the up and down arrow keys to
select the row.
3. Press F2 to activate edit mode.
4. Use TAB to move between columns and rows.
5. Press Enter to accept edits.
6. Press TAB to exit the list box and move to the next control
in the dialog.
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To:

Process:

Edit query results

1. Press CTL+F7 or CTL+SHIFT+F7 until either the
Workspaces or Repository Explorer view is highlighted.
2. Use the down or up arrow keys to select the folder that
contains a table.
3. Use the right arrow key to expand folders and the left arrow
key to collapse folders.
4. Use the arrow keys to expose and select the table that you
want to edit.
5. Press the Menu key (the key to the left of the right-side of
the CTRL key).
6. Press the mnemonic key for Open With (the h key).
7. Use the down arrow key to highlight Table Editor.
8. Press the ENTER key. The table opens in Table Editor.

Change font for query
results

1. Run the query.
2. Press Alt+A to select all.
3. Press Alt+R to open the Results menu.
4. Press F to open the Font window.

Navigation in DataQuant for WebSphere
The following table shows how to accomplish various tasks using keystrokes.
To:

Process:

Move focus through each Press TAB to move forward or SHIFT+TAB to move in the
element
opposite direction.
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Emulate clicks on a link

Use the TAB key to jump from link to link, then press the Enter
key to open the link.

Emulate clicks on a
button

Use the TAB key to jump from button to button, then press
Space key to activate the button.

Within a dialog, activate
the default action

Press the Enter key.

Within a dialog, cancel
the action

Press the ESC key.

Move focus to the
command line

Press ALT+C.

Move focus to the main
menu

Press the left ALT key. Navigate through the menu commands
using the arrow keys.

Open pop-up menus

Press the Menu key if you have an extended keyboard. Press
the right Ctrl key. Navigate through the menu commands using
the arrow keys.

Activate top-level menu

Press Shift+Ctrl+1 (Shift+Ctrl+2, Shift+Ctrl+3, and so on)

Switch between open
editors

Press Shift+Ctrl+F6

Switch between open
views

Press Shift+Ctrl+F7
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Appendix B. Customizing DataQuant objects
This topic gives examples of the SQL that is used to create the DataQuant objects.
It also describes some modifications that you might make to the SQL.

Sample generated SQL
This example shows the SQL that can be generated to create required database
objects; this SQL is proposed and it can be modified
You can edit the SQL. For example:
CREATE NODEGROUP RDBING1 ON NODE (0);
CREATE NODEGROUP RDBING2 ON NODE (0);
CREATE REGULAR TABLESPACE RDBITSSC
IN NODEGROUP RDBING1
MANAGED BY SYSTEM USING(’RDBITSSC’);
CREATE TABLE RDBI.AUTHID_TABLE
(
PRIMARY_ID CHAR(8) NOT NULL,
SECONDARY_ID CHAR(8) NOT NULL
)
IN RDBITSSC
PARTITIONING KEY (SECONDARY_ID) USING HASHING
;
COMMENT ON TABLE RDBI.AUTHID_TABLE
IS ’Secondary authorization ID table FOR RDBI’;

Listing physical and logical files for iSeries
You can list physical and logical files for iSeries from the Create Objects
Follow these steps to list iSeries physical and logical files:
1. On the Create Objects page, scroll down to the following statement:
CREATE VIEW RDBI.TABLE_VIEW2

2. In the "CREATE" statement, modify the "WHERE" clause by adding a 'P' for
physical files and an 'L' for logical files. For example:
WHERE A.TABLE_TYPE IN (’T’,’V’,’P’,’L’)

3. Click OK to create the object.

Granting EXECUTE privilege for iSeries
You can use the built-in stored procedure QSYS.QCMDEXC(). to grant the EXECUTE
privilege for iSeries libraries.
If the built-in stored procedure QSYS.QCMDEXC() is registered on the target server,
DataQuant finds it at runtime and invokes it either explicitly when DataQuant
generates SQL DDL scripts during installation, or implicitly when binding static
packages or creating stored procedures depending upon the selected protection
method, stored procedures or static SQL packages.
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If the built-in stored procedure QSYS.QCMDEXC() is not registered on the target
server, then DataQuant does not invoke it at all. However, the libraries RSBI, Q,
RDBI, and the library where DataQuant stored procedures or static SQL packages
are created may not be granted the proper privileges. In this case, the database
administrator must perform the following grant privilege operations for iSeries
libraries:
v GRTOBJAUT OBJ(RSBI) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE);
v GRTOBJAUT OBJ(Q) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE);
v GRTOBJAUT OBJ(RDBI) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE);
v GRTOBJAUT OBJ(QFWPKG) OBJTYPE(*LIB) USER(*PUBLIC) AUT(*EXECUTE);
where QFWPKG is the library of DataQuant stored procedures or static SQL
packages.

Object views
Object views determine how lists are built.
The following views are created when objects are created:
v RDBI.TABLE_VIEW
v Q.RAA_OBJECT_VIEW
You can alter these views when you install DataQuant to tailor the list building.
These views differ based on the DB2 platform.
Lists for the extended catalog are built by the views that are created when you
select the Create Objects option. For queries, forms, and procedures, the view
Q.RAA_OBJECT_VIEW_X is the key and it interacts with other views and tables.

Q.RAA_OBJ_DIR_X
Look at the catalog_ids and owner names in Q.RAA_OBJ_DIR_X and display or
fail to display each object based on the conditions below.
"Yes" to any of the following questions causes the query, procedure or form to be
displayed in the list:
1. Does the object owner match the current user ID?
2. Does the object owner match the current SQLID?
3. Does the object owner match the secondary authorization ID of the current user
ID having the same catalog ID?
4. Is the object SHARED? (Restricted = N)
5. Is the user a SYSADM having the same catalog _ID?

RDBI.USER_ADMIN_VIEW_X
This view determines whether the user or a secondary authorization ID of the user
is a SYSADM.
It checks RDBI.ADMIN_VIEW and RDBI.CATALOG_DIR_X for:
v The current user ID or SQLID
v Secondary authorization ID of the current user having the same catalog_ID in
RDBI.CATALOG_DIR_X
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RDBLUSER.USER_AUTHID_VIEW_X
This view retrieves all rows from the base table RDBI.AUTHID_VIEW_X, where
the primary ID is that of the current user. It will list all secondary authorization
IDs for the current user.

RDBLADMIN_VIEW
This view obtains a list of GRANTEEs from the base table
SYSIBM.SYSUSERAUTH. It takes GRANTEEs who have been granted G or Y for
SYSADMAUTH.

RDBI.CATALOG_DIR_X
This table contains all rows of internal identifier of the distinct catalog and name
of the distinct catalog.

RDBI_AUTHID_VIEW_X
This table copies all rows from the base table RDBI.AUTHID_TABLE_X.

SYSIBM.SYSUSERAUTH
This table contains the SYSUSERAUTH information.

RDBI_AUTH_TABLE_X
A base table listing primary and secondary authorization IDs. This table must be
populated by the system or database administrator. DataQuant for Workstation
does not have access to the preexisting RACF/DB2 relationships during or after
installation, unless they are stored in a custom DB2 table of the administrator's
design.

Q.RAA_OBJECT_VIEW_X
For queries, forms, and procedures, the view Q.RAA_OBJECT_VIEW_X is the key
and it interacts with the other views and tables, as shown below.
Note: This view is for the Object Listing Option:
"Include only those objects that any of the user’s primary or
secondary authorization IDs are authorized to access. This option
requires the most database resources when producing lists."

The following SQL statements create this view:
CREATE VIEW Q.RAA_OBJECT_VIEW_X
(
CATALOG_ID,
OWNER, NAME, TYPE, SUBTYPE, OBJECTLEVEL, RESTRICTED, MODEL,
REMARKS
DELETED_BY_USER, DELETED_BY_SQLID, DELETED_TIMESTAMP
)
AS
SELECT A.CATALOG_ID,
A.OWNER, A.NAME, A.TYPE, A.SUBTYPE,
A.OBJECTLEVEL, A.RESTRICTED, A.MODEL,
B.REMARKS,
A.DELETED_BY_USER, A.DELETED_BY_SQLID, A.DELETED_TIMESTAMP
FROM Q.RAA_OBJ_DIR_X A, Q.RAA_OBJ_REM_X B
WHERE (A.CATALOG_ID = B.CATALOG_ID AND
A.OWNER = B.OWNER AND
A.NAME = B.NAME AND
A.DELETED_TIMESTAMP IS NULL AND B.DELETED_TIMESTAMP IS NULL)
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AND (A.RESTRICTED =’N’
OR A.OWNER IN (USER, CURRENT SQLID)
OR A.OWNER IN (SELECT C.SECONDARY_ID
FROM RDBI_USER_AUTHID_VIEW_X C
WHERE C.CATALOG_ID = A.CATALOG_ID)
OR EXISTS (SELECT D.AUTHID
FROM RDBI.USER_ADMIN_VIEW_X D
WHERE D.CATALOG_ID = A.CATALOG_ID))

RDBI.USER_ADMIN_VIEW_X
These SQL statements create the RDBI.USER_ADMIN_VIEW_X table.
CREATE VIEW RDBI.USER_ADMIN_VIEW_X
(
CATALOG_ID,
"AUTHID"
)
AS
SELECT B.ID, A."AUTHID"
FROM RDBI.ADMIN_VIEW A., RDBI.CATALOG_DIR_X B
WHERE A."AUTHID" IN (USER, CURRENT SQLID)
OR A."AUTHID" IN (SELECT C.SECONDARY_ID
FROM RDBI.USER_AUTHID_VIEW_X C
WHERE B.ID = C.CATALOG_ID)

RDBI.USER_AUTHID_VIEW_X
These SQL statements create the RDBI.USER_AUTHID_VIEW_X table.
CREATE VIEW RDBI.USER_AUTHID_VIEW_X
(
CATALOG_ID,
PRIMARY_ID,
SECONDARY_ID
)
AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_VIEW_X A
WHERE A.PRIMARY_ID = USER

RDBI.ADMIN_VIEW
These SQL statements create the RDBI.ADMIN_VIEW table.
CREATE VIEW RDBI.ADMIN_VIEW
(
"AUTHID"
)
AS
SELECT A.GRANTEE
FROM SYSIBM.SYSUSERAUTH A
WHERE A.SYSADMAUTH IN (’Y’, ’G’)

RDBI.CATALOG_DIR_X
These SQL statements create the RDBI.CATALOG_DIR_X table.
CREATE TABLE RDBI.CATALOG_DIR_X
(
ID SMALLINT NOT NULL
NAME VARCHAR (128) NOT NULL
)
IN RDBIDBX.RDBITSX1
CCSID EBCDIC

RDBI.AUTHID_VIEW_X
These SQL statements create the RDBI.AUTHID_VIEW_X table.

150

Installing and Managing DataQuant

CREATE VIEW RDBI.AUTHID_VIEW_X
(
CATALOG_ID,
PRIMARY_ID,
SECONDARY_ID
)
AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_TABLE_X A

RDBI.AUTHID_TABLE_X
These SQL statements create the RDBI.AUTHID_TABLE_X table.
CREATE TABLE RDBI.AUTHID_TABLE_X
(
CATALOG_ID SMALL INIT NOT NULL,
PRIMARY_ID CHAR (8) NOT NULL,
SECONDARY_ID CHAR (8) NOT NULL
)
IN RDBIDBX.RDBITSX
CCSID EBCDIC

Note: This table must be populated by the system or database administrator.
DataQuant for Workstation does not have access to the pre-existing RACF/DB2
relationships during or after installation.
For other tables, the view RDBI.TABLE_VIEW2_X is the key and interacts with the
other views and tables, as shown below.

RDBI.TABLE_VIEW2_X
RDBI.TABLE_VIEW2_X constructs a list of tables. First, it checks for tables listed in
the base table SYSIBM.SYSTABAUTH. All tables in SYSIBM.SYSTABAUTH have,
by definition, already had some type of authority granted to at least one user.
SYSIBM.SYSTABAUTH must answer "Yes" to one of the following questions:
1. Is the GRANTEE = the current user?
2. Is the GRANTEE = the current SQLID?
3. Is the GRANTEE = PUBLIC?
4. Is the GRANTEE = PUBLIC*?
5. Is the GRANTEE = a secondary authorization ID of the current USER having
the same catalog_ID?
6. Is the user a SYSADM having the same catalog_ID?
The table must have one of the following GRANTEE types:
v ''
v U
v G
The GRANTEE of the table must have Y or G authority on one of the following
four categories:
v DELETEAUTH
v INSERTAUTH
v SELECTAUTH
v UPDATEAUTH
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RDBI.USER_ADMIN_VIEW_X
This view determines whether the user or a secondary user ID of the user is a
SYSADM.
It checks the RDBI.ADMIN_VIEW and RDBI.CATALOG_DIR_X for:
v The current user ID
v Secondary user ID of the current user having the same catalog ID

RDBI.USER_AUTHID_VIEW_X
This view retrieves all rows from the base table RDBI.AUTHID_VIEW_X where the
primary ID is that of the current user. It will list all secondary authorization IDs
for the current user.

RDBI.ADMIN_VIEW
This view retrieves a list of GRANTEEs from the base table
SYSIBM.SYSUSERAUTH. It takes GRANTEEs who have been granted G or Y for
SYSADMAUTH.
Note: If you are setting up under an iSeries database, the RDBI.ADMIN_VIEW
refers to the RDBI.ADMIN_TABLE.

RDBI.AUTHID_VIEW_X
This view copies all rows from the base table RDBI.AUTHID_TABLE_X.

RDBI.AUTHID_TABLE_X
A base table listing catalogued, and primary and secondary authorization IDs.
Note: This table must be populated by the system or database administrator.
DataQuant for Workstation does not have access to the pre-existing RACF/DB2
relationships during or after installation, unless they are stored in a custom DB2
table of the administrator's design.
Also, for tables, the view RDBI.TABLE_VIEW2_X is the key and interacts with the
other views and tables, as shown below.

RDBI.ADMIN_TABLE
A base table used exclusively by iSeries databases that lists user IDs with
administrative privileges.
Note: This table must be populated by the system or database administrator. This
table takes the place of the base RDBI.AUTHID_TABLE for DB2 databases.
Also, for tables, the view RDBI.USER_ADMIN_VIEW and
RDBI.USER_ADMIN_VIEW_X are the keys and interact with the other views and
tables, as shown below.

RDBI.USER_ADMIN_VIEW_X
The following SQL statements create the RDBI.USER_ADMIN_VIEW_X table.
CREATE VIEW RDBI.USER_ADMIN_VIEW_X
(
CATALOG_ID,
"AUTHID"
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)
AS
SELECT B.ID, A."AUTHID"
FROM RDBI.ADMIN_VIEW A, RDBI.CATALOG_DIR_X B
WHERE A."AUTHID" IN (USER, CURRENT SQLID)
OR A."AUTHID" IN (SELECT C.SECONDARY_ID
FROM RDBI.USER_AUTHID_VIEW_X C
WHERE B.ID = C.CATALOG_ID)

RDBI.USER_AUTHID_VIEW_X
These SQL statements create the RDBI.USER_AUTHID_VIEW_X table.
CREATE VIEW RDBI.USER_AUTHID_VIEW_X
(
CATALOG_ID,
PRIMARY_ID,
SECONDARY_ID
)
AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_VIEW_X A
WHERE A.PRIMARY_ID = USER

RDBL.ADMIN_VIEW
These SQL statements create the RDBL.ADMIN_VIEW table.
CREATE VIEW RDBI.ADMIN_VIEW
(
"AUTHID"
)
AS
SELECT A.GRANTEE
FROM SYSIBM.SYSUSERAUTH A
WHERE A.SYSADMAUTH IN(’Y’, ’G’)

RDBI.AUTHID_VIEW_X
These SQL statements create the RDBI.AUTHID_VIEW_X table.
CREATE VIEW RDBI.AUTHID_VIEW_X
(
CATALOG_ID,
PRIMARY_ID,
SECONDARY_ID
)
AS
SELECT A.CATALOG_ID, A.PRIMARY_ID, A.SECONDARY_ID
FROM RDBI.AUTHID_TABLE_X A

RDBI.AUTHID_TABLE_X
These SQL statements create the RDBI.AUTHID_TABLE_X table.
CREATE TABLE RDBI.AUTHID_TABLE_X
(
CATALOG_ID SMALLINT NOT NULL,
PRIMARY_ID CHAR (8) NOT NULL,
SECONDARY_ID CHAR (8) NOT NULL
)
IN RDBIDBX.RDBITSX2
CCSID EBCDIC

Note: This table must be populated by the system or the database administrator.
DataQuant for Workstation does not have access to the pre-existing RACF/DB2
relationships during or after installation.
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RDBI.ADMIN_TABLE
These SQL statements create the RDBI.ADMIN_TABLE table for iSeries support.
QMF long name catalog support:
CREATE TABLE "RDBI"."ADMIN_TABLE"
(
"AUTHID" VARCHAR(128) NOT NULL
)
;
COMMENT ON TABLE "RDBI"."ADMIN_TABLE"
IS ’Administrator authorization ID table for RDBI’;
COMMENT ON COLUMN "RDBI"."ADMIN_TABLE"."AUTHID"
IS ’Authorization ID (user ID)’;

QMF short name catalog support: The only difference is that VARCHAR(128)
changes to VARCHAR(8):
CREATE TABLE "RDBI"."ADMIN_TABLE"
(
"AUTHID" VARCHAR(8) NOT NULL
)
;
COMMENT ON TABLE "RDBI"."ADMIN_TABLE"
IS ’Administrator authorization ID table for RDBI’;
COMMENT ON COLUMN "RDBI"."ADMIN_TABLE"."AUTHID"
IS ’Authorization ID (user ID)’;

Note: This table must be populated by the iSeries system or database
administrator.
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Appendix C. Troubleshooting
Use these topics to diagnose and correct problems that you experience with
DataQuant.

Problem displaying images in DataQuant for WebSphere using Internet
Explorer 8
Symptoms
Visual report and visual dashboard images do not display properly in DataQuant
for WebSphere when using Internet Explorer version 8.

Environment
DataQuant for WebSphere

Resolving the problem
Delete files from the Temporary Internet files folder in the Internet Explorer
browser:
1. Select Tools > Delete Browsing History from the menu bar. The Delete
Browsing History dialog opens.
2. Check the Temporary Internet files check box.
3. Click Delete. The Delete Browsing History dialog closes and the files are
deleted.
4. Reopen the visual report or visual dashboard.

DataQuant for Workstation Win32 API reverts to previous version of
QMF for Windows
Symptoms
If an earlier version of QMF for Windows that is installed alongside DataQuant for
Workstation Version 1 is opened, API instances automatically revert to QMF for
Windows, even after Version 1 has been reopened.

Causes
When DataQuant for Workstation Version 1 is installed, the application version
number is updated in the system registry. When a preexisting version of QMF for
Windows is opened, it automatically reverts the application's version number in
the system registry. When Version 1 is opened, this automatic rename does not take
place.

Resolving the problem
Any time that the QMF for Windows application is opened, you must manually
reset the version number in the system registry if you want API instances to point
to DataQuant for Workstation Version 1.
User response: To reset the application version number in the system registry:
1. Go to the following location in your workstation directory:
"C:\Program Files\IBM\IBM DataQuant\API

2. Double-click the file named qmfwin.exe

© Copyright IBM Corp. 1995, 2015
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Note: Win32 API uses active repository connections. If there is not an active
repository connection, the system opens up a dialog box that lists all available
connections where you must select the connection you want to use.
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Appendix D. Messages
This topic lists and describes the messages and return codes issued by the program
components of DataQuant for Workstation and DataQuant for WebSphere.
DataQuant for Workstation and DataQuant for WebSphere messages are numbered
as follows:
CPTprefixMESSnumber
CPTprefix
The abbreviation of the component of the application that threw the error.
This can be an indication of the first place to look in order to resolve the
error.
MESSnumber
The specific number of the error message.
For example: ABC0001
All of the error messages of each component are listed in alphabetical order. To
look up more information about a specific error message and how to resolve it,
search for the component prefix and number of the message in this publication.
Note: Since DataQuant supports DB2 databases, DB2 error messages are included
in the application. DB2 error messages have a component prefix of DB2. (for
example, DB20001) If you encounter a message with this component prefix, refer to
the DB2 online documentation at www.ibm.com. If you are using the DB2 Type 4
UDB driver or the DB2 Universal JDBC Driver, to receive extended SQL exception
error messages, check the retrieveMessagesFromServerOnGetMessage option in
the Advanced JDBC Settings window of the Edit Repository Connection wizard.
API1001

{0}

Explanation: This is a container for other messages.
User response: No action is required.
API1002

The API has not been initialized.

Explanation: The API instance has not been initialized.
This could mean that the QMFwin API was not
initialized, or a repository connection was not
established.
User response: Check the QMFwin API logs to
determine the error that caused the API instance to fail,
or establish a repository connection.
API1003

No data found.

Explanation: There was an attempt to obtain a row
that does not exist in a result set.

API1006

The specified source {0} is not valid.

Explanation: An invalid value was specified for the
SourceType parameter of the initializeProc() or
initializeQuery() function.
User response: Specify a valid value for the
SourceType parameter of any initializeProc() or
initializeQuery() function.
API1007

The specified source name is not valid.

Explanation: An invalid value was specified for the
Source, CollectionName, PackageName, or
ConsistencyToken parameter of an initializeProc(),
initializeQuery(), or initializeStaticQuery() function.
User response: Specify a valid value for the Source,
CollectionName, PackageName, or ConsistencyToken
parameter of any initializeProc(), initializeQuery(), or
initializeStaticQuery() function.

User response: No action required.
API1008

© Copyright IBM Corp. 1995, 2015

The specified database server {0} is not
valid.
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API1009 • API1030
Explanation: An unknown data source alias was
specified in a getServerAttributes(), getServerType() or
initializeServer() function.

User response: Check the QMFwin API logs to find
the root error.

User response: Specify a valid data source alias for
any getServerAttributes(), getServerType() or
initializeServer() function.

API1016

API1009

Explanation: An unexpected error occurred while
creating a query using the initializeQuery() function.

No database server has been specified.

Explanation: The initializeServer() function was not
invoked before other functions were invoked that
require an initialized data source.
User response: Ensure that the initializeServer()
function is invoked before other data source dependent
functions are called.
API1010

The specified row limit {0} is not valid.

A new query could not be created.
There may be too many documents
already open, or there may be
insufficient memory.

User response: Check the QMFwin API logs to find
the root error.
API1024

The specified column delimiter ({0}) is
not valid.

Explanation: An invalid value was specified for the
ColumnDelimiter parameter of an export() function.

Explanation: An invalid value was specified for the
RowLimit parameter of an open() function.

User response: Specify a valid value for the
ColumnDelimiter parameter of any export() function.

User response: Specify a positive value for the
RowLimit parameter of any open() function.

API1026

API1011

Explanation: An invalid or empty value was specified
for the FileName parameter of an export() function.

The specified query ID {0} is not valid.

The specified file name is not valid.

Explanation: An invalid value was specified for the
QueryID parameter of an API function.

User response: Specify a valid value for the FileName
parameter of any export() function.

User response: Specify a valid value for the QueryID
parameter of all relevant functions.

API1027

API1012

Explanation: An invalid value was specified for the
Format parameter in an export() function.

The SQL verb {0} cannot be used with
open().

Explanation: An open() function was called for a
query that does not contain the SELECT, VALUES,
WITH, or CALL SQL verbs.
User response: Ensure that any open() function calls a
query that contains one of the SQL verbs listed in the
error message text.
API1013

The SQL verb {0} cannot be used with
execute().

Explanation: An execute() function was called for a
query that contains the SELECT, VALUES, WITH, or
CALL SQL verbs.
User response: Ensure that any execute() function
does not call a query that contains one of the SQL
verbs listed in the error message text.
API1015

A new procedure could not be created.
There may be too many documents
already open, or there may be
insufficient memory.

Explanation: An unexpected error occurred while
creating a procedure using the initializeProc() function.
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The specified format ({0}) is not valid.

User response: Specify a valid value for the Format
parameter of any export() function.
API1028

The specified form name is not valid.

Explanation: An invalid or empty value was specified
for the Form parameter of a report related function.
User response: Specify a valid value for the Form
parameter of any report related functions.
API1029

The specified form source ({0}) is not
valid.

Explanation: An invalid value was specified for the
SourceType parameter of a report related function.
User response: Specify a valid value for the
SourceType parameter of any report related function.
API1030

The global variable name is invalid.

Explanation: An invalid value was specified for the
GlobalVariableName parameter of a global variables
related function.
User response: Specify a valid value for the

API1031 • API1046
GlobalVariableName parameter of any global variables
related function.
API1031

The specified host variable is not valid.

Explanation: An invalid value was specified for the
Value parameter of a setHostVariable() function.

API1039

The specified range of rows and
columns is not valid.

Explanation: Invalid values were specified for the
FirstRow, FirstCol, LastRow, and LastCol parameters of
an exporting result set function.

User response: Specify a valid value for the Value
parameter of any setHostVariable() function.

User response: Specify valid values for the FirstRow,
FirstCol, LastRow, and LastCol parameters of any
exporting result set function.

API1033

API1040

The specified owner and name ({0}) are
not valid.

The specified string delimiter ({0}) is not
valid.

Explanation: An invalid value was specified for the
OwnerAndName parameter of an API function.

Explanation: An invalid value was specified for the
StringDelimeter parameter of an export() function.

User response: Specify a valid value for the
OwnerAndName parameter of any relevant API
function.

User response: Specify a valid value for the
StringDelimeter parameter of any export() function.
API1041

API1034

The specified page length ({0}) is not
valid.

Explanation: An invalid value was specified for the
PageLength parameter of an exportReport() or
exportVisualReport() function.
User response: Specify a valid value for the
PageLength parameter of any exportReport() or
exportVisualReport() functions.
API1035

The specified page width ({0}) is not
valid.

Explanation: An invalid value was specified for the
PageWidth parameter of an exportReport() or
exportVisualReport() function.
User response: Specify a valid value for the
PageWidth parameter of any exportReport() or
exportVisualReport() function.
API1037

The specified procedure ID ({0}) is not
valid.

Explanation: An invalid value was specified for the
ProcID parameter or a procedure related function.
User response: Specify a valid value for the ProcID
parameter of any procedure related functions.
API1038

The specified table name is not valid.

Explanation: An invalid value was specified for the
TableName parameter of an export() function.
User response: Specify a valid value for the
TableName parameter of any export() function.
API1042

The specified target server is invalid.

Explanation: An invalid value was specified for the
Server parameter of a saveData() or copyQMFObject()
function.
User response: Specify a valid value for the Server
parameter of any saveData() or copyQMFObject()
function.
API1044

The specified time ({0}) is not valid.

Explanation: An invalid value was specified for the
Time parameter of a getQMFObjectInfo() function.
User response: Specify a valid value for the Time
parameter of any getQMFObjectInfo() function.
API1045

The specified type ({0}) is not valid.

Explanation: An invalid value was specified for the
Type parameter of a getQMFObjectInfo() function.
User response: Specify a valid value for the Type
parameter of any getQMFObjectInfo() function.

The specified resource ({0}) is not valid.

Explanation: An invalid value was specified for the
Resource parameter of a getResourceLimit() function.
User response: Specify a valid value for the Resource
parameter of any getResourceLimit() function.

API1046

The specified variable ({0}) is not valid.

Explanation: An invalid value was specified for the
VariableName parameter of a setVariable() function.
User response: Specify a valid value for the
VariableName parameter of any getVariable() function.
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API1053 • CLC00003
API1053

The SQL verb ({0}) cannot be used with
ExecuteStoredProcedure().

BIC00004

{0}

Explanation: The specified exception occurred.

Explanation: A query that does not contain the CALL
SQL verb was specified for an
executeStoredProcedureEx() function.

User response: Correct the specified exception and try
again.

User response: Specify a CALL query for any
executeStoredProcedureEx() function.

BIC00005

API1054

Can't prepare a static section.

Explanation: A static query was specified for a
prepare() function; only dynamic queries can be
specified.

Unknown exception.

Explanation: An error occurred while retrieving a
resource string.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Specify a dynamic query for any
prepare() function.

BIC00006

API10004

Explanation: The specified feature is not supported by
DataQuant

The values specified for ForceDialog
and SuppressDialog are mutually
exclusive.

Explanation: The initializeServer() function was called
and the values that were specified for ForceDialog and
SuppressDialog parameters were mutually exclusive
User response: Check the code that invokes the
initializeServer() function.
API10005

The specified value is not valid.

Explanation: The value that was specified for the
parameter of a function is incorrect.
User response: Check to ensure that all of the
specified parameter values for all of the functions that
were called in the API instance are valid.

User response: No action is required.
BIC00007

Internal Error

Explanation: There was an internal error.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: No action is required.
BIC00009

Fetching of children is cancelled by
user.

Explanation: The operation was cancelled by the user.
User response: Retry to fetch the specified objects.
Cannot convert {0} to number.

Explanation: The specified element can not be
converted into a numeral.
User response: Specify valid element to convert into a
numeral.
CLC00002

BIC00001

Object is not supported by DataQuant

Explanation: The specified object is not supported by
DataQuant

CLC00001
BIC00000

This feature is not supported by
DataQuant

Illegal Argument

Unable to evaluate linReg: data series
have different numbers of elements.

Explanation: The specified argument is not valid.

Explanation: The data series specified for the x and y
variables contain different numbers of data points.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Specify data series that contain the
same number of data points.

BIC00002

CLC00003

Null Pointer

Explanation: A null pointer exception occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
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Unable to evaluate linReg: not enough
data.

Explanation: The data series specified do not contain
enough rows to calculate the linear regression.
User response: Specify a query result set that contains
more than one row of data points.

CLC00004 • CLC00040
CLC00004

Unable to evaluate linReg: coefficient is
out of range.

Explanation: The value that you specified for the
nParam parameter of the linreg() function is invalid.
User response: Specify either a 0 or a 1 for the
nParam parameter. A 0 returns the slope of the linear
regression. A 1 returns the intercept of the linear
regression.

CLC00014

Evaluation of expression has failed.

Explanation: The evaluation of the specified
expression has failed.
User response: Check the syntax of the expression for
errors and try again.
CLC00016

Cannot parse an expression: {0}

Explanation: An internal error occurred.
CLC00005

Illegal data row range specified: from {0}
to {1}

Explanation: The range of data rows specified for the
nFirstRow and nLastRow parameters is invalid.
User response: Specify a valid range of data rows. The
nFirstRow value must specify a row before the
nLastRow value in the query result set.
CLC00006

Unable to calculate gammaIP: domain
error.

Explanation: Invalid arguments were specified in the
gammaIP function.
User response: Specify a valid argument in the
gammaIP function.
CLC00009

"{0}" function is not found in Lib class,
but supported in expressions.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00010

"{0}" function has wrong arguments
description.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00011

Type conversion error. Object of {0} type
cannot be converted to {1} type.

Explanation: The indicated object can not be
converted to the indicated type.
User response: Specify a valid object to be converted
to the indicated type.
CLC00012

Evaluation of expression failed: {0}

Explanation: The evaluation of the indicated
expression failed.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00018

Unknown function name: {0}.

Explanation: The indicated function name is not valid
User response: Specify a valid function name.
CLC00030

Unable to process URL: ''{0}''

Explanation: The indicated URL is invalid.
User response: Specify a valid URL.
CLC00034

"{0}" function description is missing.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00038

Multiple declarations of "{0}" library in
LibraryFactory class.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00039

Multiple declarations of "{0}" library in
LibraryFactory class.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00040

Cannot load "{0}" library in
LibraryFactory class.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Specify a valid expression for
evaluation.
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CLC00041 • CLC00055
CLC00041

Types "{0}" and "{1}" are not acceptable
for "{2}" function.

Explanation: The arguments that were passed to the
function are of invalid types.
User response: Check the syntax of the expression for
errors and try again.
CLC00042

Type "{0}" is not acceptable for "{1}"
function.

Explanation: The specified function does not accept
parameters of the given type.
User response: Check the syntax of the expression for
errors and try again.
CLC00043

Information service is undefined.

> Collect Support Data and forward it to customer
support.
CLC00049

Function "{0}" is defined for {1}
argument(s).

Explanation: An invalid number of parameters were
specified for the indicated function.
User response: Specify a correct number of
parameters for the indicated function.
CLC00050

Function "{0}" is undefined for argument
{1}.

Explanation: An invalid number of parameters were
specified for the indicated function.
User response: Specify a valid number of parameters
for the indicated function.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00044

Aggregation service is undefined.

Explanation: An internal error occurred.

CLC00051

One of the operands does not have
measurement units.

Explanation: One of the operands of the function does
not have measurement units.
User response: Make sure that all of the operands in
the function have measurement units.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

CLC00052

CLC00045

User response: Specify values that are not measured
to be multiplied.

Hierarchy service is undefined.

Cannot multiply two measured values.

Explanation: Measured values can not be multiplied.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00046

Color service is undefined.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00047

PPI service is undefined.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
CLC00048

Value provider is undefined.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
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CLC00053

Cannot create list from elements of "{0}"
type.

Explanation: A list can not be created using elements
of the indicated type.
User response: Specify elements of a different type to
be listed.
CLC00054

List cannot contain elements of different
types.

Explanation: The specified list can not contain
elements of different types.
User response: Specify elements of the same type to
be listed.
CLC00055

Types "{0}", "{1}" and "{2}" are not
acceptable for "{3}" function.

Explanation: The indicated function is not compatible
with the given types.
User response: Check the syntax of the expression for
errors and try again.

CLC00056 • DAL01006
CLC00056

Argument(s) with measurement units
are not acceptable for "{0}" function.

Explanation: The indicated function can not contain
arguments with measurement units.
User response: Remove all measurement units from
the arguments of the function.
CLC00057

Incorrect index given.

Explanation: An error occurred in the LineText
function.

parameter of any add, multiply, divide, or subtract
functions.
CLC00066

Cannot be evaluated for empty list.

Explanation: No value was specified for the List
parameter of a function.
User response: Specify a valid value for the List
parameter of any relevant function.
CLC00067

User response: Check the arguments that are specified
for the LineText function for errors.

Function @if has odd number of
parameters: @if(cond1, exp1, cond2,
exp2, ..., expn). expn is used when there
aren't true conditions

Explanation: The syntax of an @if function is invalid.
CLC00058

Types "{0}", "{1}", "{2}" and "{3}" are not
acceptable for "{4}" function.

Explanation: The indicated function is not compatible
with the given types.
User response: Check the expression syntax for errors
and try again.

User response: Check the syntax of any @if functions
for errors and try again.
DAL01001

The feature is not supported.

Explanation: The specified feature is not supported by
the database.

Explanation: A generic error occurred.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Check the syntax of the expression for
errors and try again.

DAL01002

CLC00059

Calculator exception cause: {0}

No column named ''{0}'' was found.

Explanation: The indicated column was not found.
CLC00060

Value for variable ''{0}'' is not defined.

Explanation: The value for the indicated variable is
not defined.
User response: Define the value for the indicated
variable.
CLC00061

Function "{0}" caused error: {1}

Explanation: The indicated function caused the
indicated error.
User response: Correct the indicated error and rerun
the function.

User response: Check the column name for errors or
specify a different column name.
DAL01004

Explanation: The specified row can not be retrieved or
set.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01005

CLC00062

Property "{0}" contains error: {1}

Explanation: The indicated property caused the
indicated error.
User response: Correct the indicated error and rerun
the function.
CLC00063

List sizes are not comparable.

Explanation: Invalid parameters with type List were
specified for add, multiply, divide, or subtract
functions.
User response: Specify a valid value for the List

The current row is unsuitable for get/set
operations.

The database cursor has been closed.

Explanation: The requested operation could not be
completed because the cursor is closed.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01006

An error occurred while accessing the
file. {0}

Explanation: An input/output error occurred while
accessing the file.
User response: Collect support data by selecting Help
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> Collect Support Data and forward it to customer
support.

> Collect Support Data and forward it to customer
support.

DAL01007

DAL01016

Character encoding {0} is not supported.

Cannot parse data (base64 encoding
rules violation)

Explanation: The indicated character encoding is not
supported.

Explanation: The XML file is corrupted.

User response: Use a character set that is supported
by your current JVM.

User response: Fix any errors in the XML file and try
again.

DAL01008

DAL01017

An error occurred while accessing the
database.\n{0}

Explanation: An error occurred while accessing the
indicated database.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01009

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
Class {0} is not suitable for server
description

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01012

Requested operation is not available in
offline mode

Explanation: The specified operation is not available
in offline mode.
User response: Specify a different operation to apply
to the active object, or switch to online mode and try
again.
DAL01013

Explanation: An internal error occurred; the indicated
package contains several queries with the same
specified name.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

An internal error occurred. {0}

Explanation: The indicated internal error occurred.

DAL01011

Duplicate query with name ''{0}'' is
detected in package ''{1}''.

Cannot create connection to server ''{0}''
due to the following: {1}

Explanation: A connection to the indicated server
could not be established due to the indicated error.

DAL01018

The source data is not compatible with
the target table.

Explanation: The attempt to save data in the database
table failed because of the following:
v Number of columns does not match.
v Columns have incompatible types.
User response: Select compatible target table and try
again.
DAL01019

Operation is not supported.

Explanation: An internal error occurred; the requested
operation can not be performed due to internal
limitations.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01020

Invalid SQL type definition: ''{0}''

Explanation: An internal error occurred; the indicated
SQL type definition is invalid (it can be mapped to
more than one known data types).
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Resolve the indicated error and retry
to connect to the server.

DAL01021

DAL01014

Explanation: DataQuant does not support or can not
initialize the SQLj support module.

Invalid set of connection parameters
used,

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
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This product does not contain SQLj
support module

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

DAL01022 • DAL01036
DAL01022

Cannot have two different driver
libraries with the same driver name.

DAL01030

Query parameter {0} is of wrong Java
type. Data type ''{1}'' is required.

Explanation: The driver with the specified driver
name is already defined in another library definition.

Explanation: An internal error occurred while running
the query. The query parameters have invalid types.

User response: Use (edit) the already defined driver
library instead of creating a new one.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

DAL01023

An error has occurred while saving
driver libraries list: {0}

Explanation: The indicated error occurred while the
driver libraries list was being saved.
User response: Resolve the indicated error and try
again.
DAL01025

An error has occurred while loading the
driver libraries list: {0}

Explanation: The indicated error occurred while trying
to load the driver libraries list.
User response: Resolve the indicated error and try
again.
DAL01026

Operation cannot be performed due to
resource limits restriction: {0}

Explanation: The operation could not be performed
due to the indicated resource limits restriction.
User response: Check your current resource limits by
selecting Resource Limits from the View menu. Specify
an operation within your resource limits or contact
your administrator for specific permissions.
DAL01027

User name is missing.

Explanation: The user name is missing from the User
Information dialog name field.
User response: Specify a user name.
DAL01028

Password is missing.

Explanation: The password is missing from the User
Information dialog.
User response: Specify a password.
DAL01029

Wrong JDBC URL: {0}.

DAL01031

Cached server descriptor cannot be
restored due to the following: {0}

Explanation: The cached server descriptor cannot be
restored due to the following error.
User response: Resolve the indicated error and try
again.
DAL01032

An error occurred while making remote
method call. {0}

Explanation: The indicated error occurred while the
operation was running on the server side.
User response: Refer to the indicated error description
for possible response(s).
DAL01033

Client request cannot be processed by
remote server.

Explanation: An internal error occurred; the client
request cannot be processed by a remote server.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01034

Attempt to use incomplete metadata
descriptor is detected.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01035

Editing is not supported for this data
set.

Explanation: An internal error occurred; this data set
cannot be edited.

Explanation: The indicated JDBC URL cannot be
processed by DataQuant. The URL may be incorrect.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Check the JDBC URL for errors or
specify a different URL.

DAL01036

The current row is unsuitable for
editing.

Explanation: An internal error occurred; the current
row can not be edited.
User response: Collect support data by selecting Help
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> Collect Support Data and forward it to customer
support.
DAL01037

The database server does not support
table renaming

Explanation: Tables in this database server can not be
renamed by DataQuant.

DAL01043

An attempt was made to modify a
deleted record.

Explanation: An internal error occurred; records that
have already been deleted can not be modified or
restored.

User response: No action is required.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

DAL01038

DAL01044

The edit operation was cancelled.

Explanation: The table editing operation was
cancelled by the user.
User response: No action is required.
DAL01039

The record could not be updated
(possibly concurrent edit/delete
operations).

Explanation: The record could not be updated. This is
most likely because it is locked due to a concurrent
edit/delete operation.

Connection is blocked due to the
following: {0}

Explanation: The attempted connection was blocked
due to the indicated error or restriction.
User response: Depending on the indicated problem,
either resolve the specified error or contact your
administrator to remove the restriction.
DAL01046

This product does not contain static
mode support module for selected
database.

User response: Refresh the result set and try again.

Explanation: This product does not contain static
mode support module for selected database.

DAL01040

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

The record could not be deleted
(possibly concurrent edit/delete
operations).

Explanation: The record could not be deleted. This is
most likely because it is locked due to a concurrent
edit/delete operation.

DAL01048

User response: Refresh the result set and try again.
DAL01041

The value of a calculated column is
longer than specified in the metadata

Driver class name ''{0}'' is not loaded.
This may be caused by an incorrect
driver class name or missing JDBC
driver libraries.

Explanation: The indicated driver class name can not
be loaded. This may be caused by an incorrect driver
class name or missing JDBC driver libraries.

Explanation: The data could not be exported because
one or more of the calculated columns in the result set
contains data that is longer than what is allowed in the
column's definition.

User response: Check that there is a proper definition
for the JDBC driver library that refers to the indicated
driver class.

User response: Increase the maximum column length
or modify the data in the calculated column.

DAL01049

DAL01042

Invalid type conversion detected.

Explanation: An internal error occurred; a type
conversion in the specified operation is invalid.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

Selected protection mode is not
supported by database.

Explanation: The selected protection mode is not
supported by the specified database.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01050

Driver specific functionality is not
available due to: {0}

Explanation: Driver specific functionality is not
available due to the indicated error.
User response: Resolve the indicated error and retry.
Verify that the JDBC driver library for the driver is
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properly configured and that it contains all of the
necessary JAR files. If the problem persists, collect
support data by selecting Help > Collect Support Data
and forward it to customer support.
DAL01200

Generic data access error has occurred.
{0}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01201

Generic data access error has occurred.
{0}, {1}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01202

Generic data access error has occurred.
{0}, {1}, {2}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01203

Generic data access error has occurred.
{0}, {1}, {2}, {3}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01204

Generic data access error has occurred.
{0}, {1}, {2}, {3}, {4}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.

> Collect Support Data and forward it to customer
support.
DAL01205

Generic data access error has occurred.
{0}, {1}, {2}, {3}, {4}, {5}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01206

Generic data access error has occurred.
{0}, {1}, {2}, {3}, {4}, {5}, {6}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01207

Generic data access error has occurred.
{0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DAL01208

Generic data access error has occurred.
{0}, {1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}

Explanation: An error with no textual description
occurred. Additional information may follow the
message. This error code may refer to different error
conditions depending on product versions.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
DDM0001

Unexpected error occurred.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

User response: Collect support data by selecting Help
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DDM0002

Object {0} have no fields with codepoint
{1}

DDM0010

Object {0} does not contain required
field {1}

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

DDM0003

DDM0011

Socket open exception. {0}

Explanation: Unable to establish TCP/IP connection.
User response: Check the host and port details in the
JDBC URL; ping the server to check that the network
connection works.

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0012

DDM0004

Socket write exception. {0}

Explanation: There was a network connection failure
or an internal error in the driver code was detected.
User response: Check you network connection. If the
connection works fine, send an error report to the
developers.
DDM0005

Data format exception detected.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DDM0006

Invalid JDBC URL {0}

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DDM0007

DSS header format error detected.

Explanation: An internal error in the driver code was
detected.

Object {0} does not support value {1}

Syntax error detected: {0}

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DDM0013

Syntax error detected: {0}

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DDM0014

Object {0} can hold no more repeated
fields {1}

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DDM0015

Illegal port number value: {0}

Explanation: The JDBC URL contains an invalid value
in the Port field.
User response: Specify a correct port number in the
JDBC URL.

User response: Send an error report to the developers.
DDM0016
DDM0008

Unsupported CCSID {0}

{0} is invalid length for the field {1} of
object {2}

Explanation: An internal error was detected in the
driver code.

Explanation: An internal error was detected in the
driver code.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

DDM0009

DDM0017

Cipher error {0}

Unknown FD:OCA descriptor type id {0}

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error was detected in the
driver code.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

168

Installing and Managing DataQuant

DDM0018 • DDM0033
DDM0018

Null value for non nullable data
detected.

Explanation: An internal error was detected in the
driver code.

DDM0026

Unknown DRDA type {0}

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
DDM0027
DDM0019

Whole number of FD:OCA {0} triplet
repeating groups cannot be placed in {1}
bytes

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0020

Illegal CPT triplet detected.

Explanation: An internal error was detected in the
driver code.

Infinite element count is not allowed for
RLO handler of {0}

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0028

An error occurred while parsing triplet
handler for DRDA type {0}

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
DDM0029
DDM0021

Illegal duplicated field {1} in object {0}

Unspecified value for JDBC statement
variable {0}

Explanation: An internal error was detected in the
driver code.

Explanation: An internal error was detected in the
driver code.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

DDM0022

DDM0030

Referenced FD:OCA triplet {0} not
found

Explanation: An internal error was detected in the
driver code.

Illegal type conversion.

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
DDM0031
DDM0023

FD:OCA {0} triplets cannot be
referenced from RLO triplet

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0024

Replication factor {0} is detected in RLO
triplet while only 1 and 0 is allowed by
DRDA

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0025

FD:OCA {0} triplets cannot be
referenced from GDA triplet

Explanation: An internal error was detected in the
driver code.

Illegal date or time format detected: {0}

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0032

Prepared statement parameter type {0}
(from java.sql.Type set) is not
supported.

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.
DDM0033

Unknown DB2 type {0}

Explanation: An internal error was detected in the
driver code.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
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DDM0035

Statement is closed.

Explanation: An attempt to work with a closed
Statement object was detected.
User response: Fix your program code.
DDM0036

ResultSet is closed.

DSCERRCD0001 FD:OCA triplet is not used in
DRDA descriptors, or the type code is
invalid.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

Explanation: An attempt to work with a closed
ResultSet object was detected.

DSCERRCD0002 FD:OCA triplet sequence error.

User response: Fix your program code.

Explanation: An internal error in the driver code was
detected.

DDM0037

Object is closed.

Explanation: An attempt to work with a closed object
was detected.

User response: Send an error report to the developers.

User response: Fix your program code.

DSCERRCD0003 An array description is required,
and this is not one (too many or too few
Row Lay Out (RLO) triplets).

DDM0038

Explanation: An internal error in the driver code was
detected.

Operation cannot be performed in
current ResultSet state.

Explanation: An attempt to work with a ResultSet
column of a result set that is not positioned on any
valid record was detected.

User response: Send an error report to the developers.

User response: Fix your program code.

DSCERRCD0004 A row description is required, and
this is not one (too many or too few
RLO triplets).

DDM0039

Explanation: An internal error in the driver code was
detected.

Error reply is received.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

DSCERRCD0005 Late environmental descriptor just
received, not supported.

DDM0040

Explanation: An internal error in the driver code was
detected.

Error reply is received for {0} command.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.
DDM0041

Error detected while processing {0}
object.

Explanation: An internal error in the driver code was
detected.

DSCERRCD0006 Malformed triplet; required
parameter is missing.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
DSCERRCD0007 Parameter value is not acceptable.
DRL00001

The maximum number of connections to
the server has been reached.

Explanation: An internal error in the driver code was
detected.

Explanation: The maximum number of connections to
the server has been reached.

User response: Send an error report to the developers.

User response: Increase the maximum of number of
connections parameter in the Repository Storage dialog
or set the value to zero to remove this restriction.

DSCERRCD0017 Meta-Data Descriptor (MDD)
present is not recognized as a Structured
Query Language (SQL) descriptor.
Explanation: An internal error in the driver code was
detected.
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User response: Send an error report to the developers.
DSCERRCD0018 MDD class is not recognized as a
valid SQL class.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DSCERRCD0019 MDD type is not recognized as a
valid SQL type.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DSCERRCD0033 Representation is incompatible
with SQL type (in prior MDD).
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

DSCERRCD0054 GDA length override missing or
incompatible with data type.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DSCERRCD0065 RLOreferences a LID which is not
an RLO or GDA.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
DSCERRCD0066 RLOfails to reference a required
GDA or RLO.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
ERM0001

Permanent Agent Error.

DSCERRCD0034 CCSID is not supported.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.
DSCERRCD0050 Group Data Array (GDA)
references a local identifier (LID) which
is not a Scalar Data Array (SDA) or
GDA.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

ERM0002

Not Authorized to Command.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
ERM0003

Command Check.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

DSCERRCD0051 GDAlength override exceeds limits.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

ERM0004

Command Not Supported.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

DSCERRCD0052 GDAprecision exceeds limits.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

ERM0005

Manager Dependency Error.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

DSCERRCD0053 GDA scale greater than precision or
scale negative.
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
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ERM0006

Manager-level Conflict.

ERM0015

RDB Access Failed Reply Message.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0007

ERM0016

Conversational Protocol Error.

Not Authorized To RDB.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0008

ERM0017

Parameter Not Supported.

RDB Not Found.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0009

ERM0018

Resource Limits Reached.

Resource Limits Reached.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0010

ERM0019

Data Stream Syntax Error.

Data Stream Syntax Error.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0011

ERM0020

Target Not Supported.

Invalid Request.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0012

ERM0021

Parameter Value Not Supported.

Abnormal End Unit of Work Condition.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0013

ERM0022

Conversational Protocol Error.

RDB Package Binding Process Active.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0014

ERM0023

RDB Currently Accessed.

Query Not Open.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.
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ERM0024

RDB Not Accessed.

ERM0033

End Unit of Work Condition.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0025

ERM0034

Data Descriptor Mismatch.

Invalid Descriptor.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0026

ERM0035

Object Not Supported.

Open Query Complete.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0027

ERM0036

RDB Package Binding Not Active.

Open Query Failure.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0028

ERM0037

RDB Update Reply Message.

Query Previously Opened.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0029

ERM0038

SQL Error Condition.

Command Violation.

Explanation: An internal error in the driver code was
detected.

Explanation: An internal error in the driver code was
detected.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

ERM0030

ERM1200

End of Data.

Generic DRDA error has occurred. {0}

Explanation: An internal error in the driver code was
detected.

Explanation: The indicated generic DRDA error has
occurred.

User response: Send an error report to the developers.

User response: Resolve the indicated generic DRDA
error and try again.

ERM0031

End of Query.

Explanation: An internal error in the driver code was
detected.

ERM1201

Generic DRDA error has occurred. {0},
{1}

User response: Send an error report to the developers.

Explanation: The two indicated generic DRDA error
have occurred.

ERM0032

User response: Resolve the two indicated errors and
try again.

Commitment Request.

Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
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ERM1202

Generic DRDA error has occurred. {0},
{1}, {2}

Explanation: The three indicated generic DRDA errors
have occurred.
User response: Resolve the three indicated errors and
try again.

EXPT1000

Explanation: The indicated export command can not
be performed.
User response: Resolve the first indicated error and
try again.
EXPT1001

ERM1203

Generic DRDA error has occurred. {0},
{1}, {2}, {3}

Explanation: The four indicated generic DRDA errors
have occurred.
User response: Resolve the four indicated errors and
try again.
ERM1204

Generic DRDA error has occurred. {0},
{1}, {2}, {3}, {4}

Explanation: The five indicated generic DRDA errors
have occurred.
User response: Resolve the five indicated errors and
try again.
ERM1205

Generic DRDA error has occurred. {0},
{1}, {2}, {3}, {4}, {5}

Explanation: The six indicated generic DRDA errors
have occurred.

Generic DRDA error has occurred. {0},
{1}, {2}, {3}, {4}, {5}, {6}

Explanation: The seven indicated generic DRDA
errors have occurred.
User response: Resolve the seven indicated errors and
try again.
ERM1207

Generic DRDA error has occurred. {0},
{1}, {2}, {3}, {4}, {5}, {6}, {7}

Explanation: The eight indicted generic DRDA errors
have occurred.

An unsupported data type {0} was
encountered.

Explanation: The result set contains columns with the
types that are not supported by the IXF370 format.
User response: Make sure that the result set does not
contain columns with any of the following types:
BINARY, VARBINARY, ROWID, LONGVARBINARY,
CLOB, DBCLOB, BLOB, GRAPHIC, VARGRAPHIC, or
LONGVARGRAPHIC.
EXPT1002

The length of column {0} must be less
than {1}.

Explanation: The length of the indicated column must
be less than the indicated length due to restrictions of
the IXF format.
User response: Make sure that the indicated data
column is less than the indicated length. Try to export
using another format (for example, XML).
EXPT1003

User response: Resolve the six indicated errors and
try again.
ERM1206

Cannot perform export command: {0}

The precision of column {0} must be an
odd number between {1} and {2},
inclusive.

Explanation: The precision of the indicated column
must be an odd number between the two indicated
values due to restrictions of the IXF format.
User response: Make sure the precision of the
indicated data column is an odd number between the
two indicated values. Try to export using another
format (for example, XML).
EXPT1004

The data could not be exported due to
an unsupported CCSID {0}.

Explanation: The indicated CCSID is not supported
for export.

User response: Resolve the eight indicated errors and
try again.

User response: Specify a valid CCSID for export. A
list of supported CCSIDs can be obtained from the
CCSID drop down menu in the Export dialog.

ERM1208

EXPT1005

Generic DRDA error has occurred. {0},
{1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}

Explanation: The nine indicated generic DRDA errors
have occurred.
User response: Resolve the nine indicated errors and
try again.
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The data could not be exported because
the single-byte code page is not
specified.

Explanation: A result set containing CLOB, CHAR,
VARCHAR, or LONGVARCHAR columns was
exported in IXF format but a CCSID that contains a
single-byte code page was not specified.

EXPT1006 • FRM1003
User response: Select a CCSID that contains a
single-byte code page.
EXPT1006

The data could not be exported because
the double-byte code page is not
specified.

Explanation: A result set containing DBCLOB,
GRAPHIC, VARGRAPHIC, or LONGVARGRAPHIC
columns was exported in IXF format but a CCSID that
contains a double-byte code page was not specified.
User response: Select a CCSID that contains a
double-byte code page.

EXPT1012

Explanation: There was an attempt to export a result
set to a table that does not exist.
User response: Specify a valid export table.
EXPT1013

The value in column {0} exceeds the
maximum length supported by the
dBASE file format.

Explanation: The value in the indicated column
exceeds the character limit that is supported by the
dBASE file format.
User response: Shorten the value in the indicated
column or specify a different file format for export.
EXPT1008

The data type of column {0} is not
supported in dBASE files.

Explanation: The data type of the indicated column is
not supported by the dBASE file format.
User response: Specify a different data type for the
indicated column or select a different file format for
export. Supported types: CHAR, VARCHAR,
SMALLINT, INTEGER, DECIMAL, BIGINT, DOUBLE,
FLOAT, DATE, and TIME.
EXPT1009

The row length in a dBASE file cannot
exceed 4000 characters.

Explanation: The summary length of all of the result
set's columns exceeds 4,000 characters, which is not
supported by the dBASE file format.
User response: Make sure that the length is shorter
than 4,000 characters, or select a different file format for
export.
EXPT1010

The specified data source does not exist.

Explanation: There was an attempt to export a result
set to a data source that does not exist
User response: Specify a valid data source.
EXPT1011

The operation cancelled.

Explanation: The user cancelled the export command
when prompted for a user name and password.
User response: Specify a valid user name and
password for the export command.

Invalid storage entry.

Explanation: The storage file contains corrupted data.
User response: Setup fonts and font mapping for PDF
export.
EXPT1014

EXPT1007

Name must be specified.

Cannot create font {0} for PDF

Explanation: The indicated font can not be created for
the PDF file format.
User response: Specify a different font for conversion,
specify a different file format for export, or set up fonts
and font mapping for PDF file export.
EXPT1015

{0} font is not mapped

Explanation: The indicated font name is not mapped
to the physical font file.
User response: Set up fonts and font mapping for
PDF file export.
FRM1001

The input line type is invalid.

Explanation: Corrupted form. The form loader is
hanging on a line with a certain first character, because
every line in a form file, according to the form file
format, starts with certain character (T, V, R, H, E, *)
that define the line type. The current line's first
character has an unknown type.
User response: Try to open and save again with exact
same version of DataQuant that was used to create the
form.
FRM1002

The input line is too short.

Explanation: The form loader is hanging on a line
with a certain character count, because each line type
must have a character count greater than a certain
number (T > 15, V > 11, R > 3, or H > 44). The current
line is too short.
User response: Try to open and save again with exact
same version of DataQuant that was used to create the
form.
FRM1003

The boolean value is invalid. Valid
values are YES or NO.

Explanation: Corrupted form: A boolean value in the
form file has a string other than YES or NO.
User response: Try to open and save again with exact
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FRM1004 • FRM1015
same version of DataQuant that was used to create the
form.
FRM1004

The numeric value is invalid. Valid
values are NONE, COLUMNS,
DEFAULT, or an integer value.

Explanation: Corrupted form: The form loader waits
for a valid Integer value or predefined word (NONE,
COLUMNS, or DEFAULT).
User response: Try to open and save again with exact
same version of DataQuant that was used to create the
form.
FRM1005

An invalid code was encountered.

Explanation: Corrupted form: Every table structure in
a form file has its own column types. The form loader
waits for certain column types depending on the table
type.
User response: Try to open and save again with exact
same version of DataQuant that was used to create the
form.
FRM1006

The object header is too short.

Explanation: The form loader is hanging on a line
with a certain character count, because each line type
must have a character count greater than a certain
number (T > 15, V > 11, R > 3, or H > 44). The current
line is too short.
User response: Try to open and save again with exact
same version of DataQuant that was used to create the
form.
FRM1007

The object header is invalid.

Explanation: Corrupted form: The object header
contains unexpected fields or data.
User response: Try to open and save again with exact
same version of DataQuant that was used to create the
form.
FRM1008

Invalid usage code.

Explanation: The "new column" of the form dialog
contains an invalid usage code.
User response: Leave the usage code field empty or
select one from the combo box.

FRM1010

Explanation: The length of the column heading must
be less then 40 characters.
User response: Ensure that the column heading is less
than 40 characters.
FRM1011

The value specified for {0} is
invalid.\r\nValid values are {1}.

There is no condition expression with
ID {0}.

Explanation: A form has a few detail blocks in the
“detail” branch (by default – one) and each detail can
use a condition that defines the detail as enabled or
disabled. The condition typed in the C1, C2, .. C999
format and the condition with the according index
should exist in the “conditions” branch.
User response: Specify YES, NO, or Ci where Ci is the
existing condition.
FRM1012

Line Wrapping Width must be NONE
when Number of Fixed Columns is not
NONE.

Explanation: In the Options page of the form designer,
when any number is defined in the Number of Fixed
Columns field, the Line Wrapping Width field must be
set to NONE.
User response: Specify NONE in either the Line
Wrapping Width field or the Number of Fixed
Columns field
FRM1013

The ID for calculation {0} is already
being used by a different calculation.

Explanation: In the Calculations page of the form
designer, two or more calculations with the same ID
were specified.
User response: Ensure that each calculation ID is
unique.
FRM1014

The ID for condition {0} is already being
used by a different condition.

Explanation: In the Conditions page of the form
designer, two or more conditions with the same ID
were specified.
User response: Ensure that each of the conditions are
unique.
FRM1015

FRM1009

The column heading "{0}" is too long.

Line Wrapping Width must be 0 if any
column uses a column wrapping edit
code.

Explanation: In the form dialog page, there are several
places where you can type or choose a listed value. An
invalid listed value was entered.

Explanation: If a column uses the wrapping edit code,
then in the Options page of the form designer, the Line
Wrapping Width field must be set to NONE.

User response: Enter a valid value from the list.

User response: Either set the Line Wrapping Width
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FRM1016 • FRM1026
field to NONE, or do not use the line wrapping edit
code.
FRM1016

Automatically Reorder Report Columns
must be TRUE when using the ACROSS
usage code.

Explanation: If any columns have the ACROSS usage
code, then in the Options page of the form designer,
the Automatically Reorder Report Columns field must
be set to TRUE.
User response: Either set the Automatically Reorder
Report Columns field to TRUE or do not use the
ACROSS usage code.
FRM1017

The ACROSS usage code requires other
columns to use the GROUP and
aggregate usage codes.

Explanation: If any columns use the ACROSS usage
code, then all other columns must use either the OMIT,
GROUP, or AGGREGATION usage code.
User response: Set the OMIT, GROUP, or
AGGREGATION usage codes for all other columns.
FRM1018

Only one column can use the ACROSS
usage code.

Explanation: Only one column can use the ACROSS
usage code.
User response: Ensure that only one column uses the
ACROSS usage code.
FRM1019

The GROUP usage code requires other
columns to use aggregate usage codes.

Explanation: When one column uses the GROUP
usage code, all of the other columns must use the
OMIT, GROUP, BREAK, or AGGREGATION usage
codes.
User response: Ensure that all of the other columns
use the OMIT, GROUP, BREAK, or AGGREGATION
usage codes.
FRM1020

The GROUP usage code requires all
other columns to use a non-blank usage
code.

Explanation: When a column uses the GROUP usage
code, all of the other columns must use the OMIT,
GROUP, BREAK, or AGGREGATION usage codes.
User response: Ensure that all of the other columns
use the OMIT, GROUP, BREAK, or AGGREGATION
usage codes.

FRM1021

The aggregate usage code can only be
used when the column has a numeric
data type.

Explanation: The SUM, CSUM, AVERAGE, STDEV,
PCT, TPCT, CPCT, and TCPCT usage codes can only be
used with numeric columns.
User response: Specify a different usage code than
SUM, CSUM, AVERAGE, STDEV, PCT, TPCT, CPCT, or
TCPCT for non-numeric columns.
FRM1022

There is no calculation expression with
ID {0}.

Explanation: In the Calculations page of the form
designer, the calculation usage code ID must be
specified.
User response: Specify a calculation ID for the
calculation usage code.
FRM1023

"{0}" is not a valid edit code for a
calculation.

Explanation: The specified edit code is not a valid
calculation edit code.
User response: Specify another calculation edit code.
FRM1024

Invalid edit code.

Explanation: The specified edit code is invalid.
User response: Check the reference section of the User
help to find a valid edit code.
FRM1025

Invalid string ''{0}'' is encountered.
Parsing failed.

Explanation: The form is corrupted or needs to be
opened with another locale because a string that
represents a number value can not be parsed in the
current locale.
User response: Try to open and save the form with
the same version of DataQuant that was used to create
the form or try to change the locale and reopen.
FRM1026

The variable ''{0}'' is invalid in this
context.

Explanation: The specified variable name is invalid
when used in the expression.
User response: Specify a valid variable name for the
expression.
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FRM1027 • IXF01003
FRM1027

There is no column {0}.

Explanation: The expression contains a variable that
refers to a column that does not exist.
User response: Specify a valid column number in the
expression variable.
FRM1028

The suffix '_B' is invalid in this context.

Explanation: The suffix '_B' can not be used in
predefined variables, and as such is invalid for the
current variable.
User response: Remove the suffix '_B' from all
predefined variables.

User response: Send an error report to the developers.
GERR00003 Generic driver error has occurred. {0},
{1}, {2}, {3}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
GERR00004 Generic driver error has occurred. {0},
{1}, {2}, {3}, {4}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

FRM1029

Unable to open linked data source.

Explanation: The form attempted to open a linked
data source and an error occurred during this process.
User response: Specify a valid data source object for
the form.

GERR00005 Generic driver error has occurred. {0},
{1}, {2}, {3}, {4}, {5}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

FRM1030

An error occurred while registering user
edit code.

Explanation: The FormCustomEditCode returned an
error.
User response: Review the FormCustomEditCode
implementation documentation and check for errors.
FRM1031

The user-defined edit routine class
could not be found. {0}

Explanation: The user implementation class
FormCustomEditCode can not be loaded by the
Classloader.

GERR00006 Generic driver error has occurred. {0},
{1}, {2}, {3}, {4}, {5}, {6}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
GERR00007 Generic driver error has occurred. {0},
{1}, {2}, {3}, {4}, {5}, {6}, {7}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.

User response: Check the className.jar CLASSPATH.
FRM1032

An error occurred while initializing
user-defined edit routine class. {0}

Explanation: An error occurred.
User response: See additional information in the
wrapped exception.

GERR00008 Generic driver error has occurred. {0},
{1}, {2}, {3}, {4}, {5}, {6}, {7}, {8}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
IXF01002

GERR00001 Generic driver error has occurred. {0}
Explanation: An internal error in the driver code was
detected.
User response: Send an error report to the developers.
GERR00002 Generic driver error has occurred. {0},
{1}, {2}
Explanation: An internal error in the driver code was
detected.
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The LOB column index is invalid.

Explanation: The file contains an invalid index of a
LOB column.
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01003

The LOB column length is invalid.

Explanation: The IXF file contains a LOB column that
has an invalid length.

IXF01004 • IXF01017
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01004

The end of the file was encountered
prematurely.

Explanation: A premature end of file was encountered
while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has and unknown format.
IXF01005

The length of record {0} is invalid.

Explanation: A corrupted record was encountered
while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01006

An invalid record length was
encountered in record {0}.

Explanation: An invalid record length was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01007

An invalid name length was
encountered in record {0}.

Explanation: An invalid column name length was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01008

An unrecognized record type was
encountered in record {0}.

Explanation: An unknown record type was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.

IXF01011

Explanation: The IXF file contains character data
which is encoded using a CCSID that is not supported
by DataQuant.
User response: Create an IXF file using another
CCSID to import to DataQuant.
IXF01012

An invalid value was encountered in
record {0}.

Explanation: An unexpected data value was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.

User response: The imported IXF file is corrupted or
has an unknown format.
IXF01013

An unsupported data type was
encountered in record {0}.

Explanation: An unsupported data type was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.

The data record ID in record {0} is
negative.

Explanation: An invalid data identifier was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01014

The position for a column is negative in
record {0}.

Explanation: An invalid column position was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.
IXF01015

The "IXF" identifier was not found in
record {0}.

Explanation: The imported IXF file has no “IXF”
signature, which is required at the beginning of its
contents.
User response: The imported IXF file is corrupted or
has unknown format.
The version of the IXF file is "{0}",
which is not supported.

Explanation: The imported IXF file version is not
supported by DataQuant.
User response: Check to see if the IXF file is version 0,
1 or 2. all others are not supported.
IXF01017

IXF01010

The column length is invalid.

Explanation: An invalid column name was
encountered while importing data from the IXF file.

IXF01016
IXF01009

An unsupported CCSID was
encountered in record {0}.

An invalid record count was
encountered in record {0}.

Explanation: An invalid column count was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.
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IXF01018 • MAIL1000
IXF01018

IXF file contents are corrupted.

User response: Ensure that a valid license file is being
used.

Explanation: The imported IXF file is corrupted.
User response: Check that you are specifying an IXF
file to import.
IXF01019

Data format is not supported in host IXF
files.

Explanation: An unsupported column type was
encountered while importing data from the IXF file.
User response: The imported IXF file is corrupted or
has an unknown format.

LIC1003

License file could not be found {0}.

Explanation: The license file could not be found.
User response: Use the Manage License dialog to add
the license to the product.
LIC1004

Unexpected file error: {0}.

Explanation: A file system error occurred while
loading the license file.
User response: Send an error report to the developers.

JOB1000

{0}
LIC1006

Explanation:
User response:
JOB1001

Unknown JDF file format.

Explanation: An incorrect job file was selected while
importing a job file in the old format (.jdf) to the new
format (.jdfx).
User response: Select a correct job file in the old
format to import.

Explanation: The license file digital signature
verification failed.
User response: Provide a valid license file.
LIC1007

Unexpected end of file.

Explanation: A corrupted job file was selected while
importing a job file in the old format (.jdf) to the new
format (.jdfx).
User response: Resave the job file in QMF version 8
and retry to import the file.
LIC1000

License field "{0}" has invalid date
format: {1}.

License has expired.

Explanation: The trial period of the license expired.
User response: Buy a full license.
LIC1008

JOB1002

License signature verification failed.

Unexpected error.

Explanation: An unexpected error occurred while
verifying the license.
User response: Ensure that the correct license file is
being used.
LIC1009

The license is incorrect.

Explanation: The license verification failed because of
an invalid license file.

Explanation: The format of the date at the specified
field is incorrect.

User response: Use the original license file.

User response: Ensure that the license file contains a
date in dd/mm/yyyy format.

LIC1010

LIC1001

User response: Use the Manage Licenses dialog to
import a valid license.

Required field "{0}" missed.

Explanation: No value was specified for the indicated
field.
User response: Ensure that a value is specified for the
indicated field.
LIC1002

Field "{0}" has invalid value "{1}". Valid
value is {2}.

Explanation: An incorrect value was specified for the
indicated field.
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License file not found.

Explanation: The license (any *.lic file) was not found
the user's home directory or in application's directory.

MAIL1000

{0}

Explanation: The indicated error occurred.
User response: Resolve the error and try again.

MAIL1001 • OLP1002
MAIL1001

SMTP server must be specified.

NLS00007

Generic error #{0} has occurred in
module {1} ({2}; {3}; {4}; {5}; {6}; {7}).

Explanation: The email server that will send the
message containing the object has not been specified in
the procedure command.

Explanation: The indicated error occurred.

User response: Specify the email server that will send
the message in the MAIL TO procedure command.
Check the MAIL TO procedure command topic in the
user help for more information.

NLS00008

User response: Send an error report to the developers.
Generic error #{0} has occurred in
module {1} ({2}; {3}; {4}; {5}; {6}; {7}; {8}).

Explanation: The indicated error occurred.
MAIL1002

Unknown type of attachment specified.

Explanation: The file specified in the MAIL TO
command is of an unknown file format, or was entered
incorrectly.
User response: Check the ATTACHMENT parameter
of the MAIL TO command for errors or specify a
different attachment. Check the MAIL TO procedure
command topic in the user help for more information.
NLS00001

Generic error #{0} has occurred in
module {1}.

Explanation: The indicated error occurred.

User response: Send an error report to the developers.
NLS00009

Generic error #{0} has occurred in
module {1} ({2}; {3}; {4}; {5}; {6}; {7}; {8};
{9}).

Explanation: The indicated error occurred.
User response: Send an error report to the developers.
OLCQ1000

{0}

Explanation: This is a wrapped message.

User response: Send an error report to the developers.

User response: Resolve the indicated error and try
again.

NLS00002

OLCQ1001

Generic error #{0} has occurred in
module {1} ({2}).

Explanation: The indicated error occurred.

Query was cancelled.

Explanation: The current query was cancelled.
User response: Rerun the query.

User response: Send an error report to the developers.
OLCQ1002
NLS00003

Generic error #{0} has occurred in
module {1} ({2}; {3}).

You must select at least one value for
each level.

Explanation: The indicated error occurred.

Explanation: At least one value must be selected in
every level of a slicer control.

User response: Send an error report to the developers.

User response: Select a value and try again.

NLS00004

OLCQ1005

Generic error #{0} has occurred in
module {1} ({2}; {3}; {4}).

Explanation: The indicated error occurred.
User response: Send an error report to the developers.
NLS00005

Generic error #{0} has occurred in
module {1} ({2}; {3}; {4}; {5}).

Cannot to find needed data source.

Explanation: A nonexistent data source was specified
for the OLAP query.
User response: Specify a valid data source for the
OLAP query.
OLP1000

{0}

Explanation: The indicated error occurred.

Explanation: This is a wrapped message.

User response: Send an error report to the developers.

User response: Resolve the indicated error and try
again.

NLS00006

Generic error #{0} has occurred in
module {1} ({2}; {3}; {4}; {5}; {6}).

Explanation: The indicated error occurred.
User response: Send an error report to the developers.

OLP1002

The database does not support OLAP
feature.

Explanation: The specified database does not support
OLAP functionality.
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User response: Specify a database with OLAP
functionality.

OLP1009

Cannot connect to database: {0}.

Explanation: Can not connect to the database.
OLP1003

Unable to locate cube measure {0}.

Explanation: The indicated cube measure could not be
found on the database.

User response: Check if connection to a database is
available or ask your administrator for more
information.

User response: Select a different database to search for
the cube measure.

OLP1010

OLP1004

Explanation: The cube structure as it is defined in the
OLAP query does not match the current cube structure.

Unable to locate cube dimension {0}.

Explanation: The indicated cube dimension could not
be found on the database.
User response: Select a different database to search for
the cube dimension.

User response: Check to make sure that the cube
structure that is defined in the OLAP query matches
the current cube structure.
OLQ1000

OLP1005

Unable to locate {0}.

Explanation: The indicated OLAP cube could not be
found on database.
User response: Select a different database to search for
the OLAP cube.
OLP1006

Cannot retrieve values for {0}.

Explanation: An error occurred while reading the
dimension information.
User response: Ensure that the indicated dimension
exists.
OLP1007

Measure or dimension cannot be added
because it is not related to any table
currently used in the layout.

Explanation: An error occurred while building the
SQL query to retrieve OLAP data from CubeViews; the
table that stores information about the selected measure
or dimension could not be found.
User response: Check the integrity of the CubeView
metadata.
OLP1008

There is not enough information to link
specified measure or dimension: {0}.

Explanation: An error occurred while building the
SQL query to retrieve OLAP data from CubeViews; the
tables that store information about the selected
measures or dimensions could not be joined.
User response: Check the integrity of the CubeView
metadata.

Cube definition is not suitable for
layout of the current query.

{0}

Explanation: This is a wrapped message.
User response: Resolve the indicated error and try
again.
OLQ1001

Internal Error.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
OLQ1002

Query was cancelled.

Explanation: The current query was cancelled.
User response: Rerun the query.
OLQ1003

You must select at least one value for
each level.

Explanation: At least one value must be selected in a
slicer control.
User response: Select a value and try again.
OLQ1004

Invalid type for saving the query.

Explanation: An invalid object type was selected in
which to save the query. OLAP queries can only be
saved in the *.oq file format.
User response: Save the OLAP query to a file with the
*.oq file extension.
OLQ1005

No data source was specified for the
query.

Explanation: A nonexistent data source was specified
for the OLAP query.
User response: Specify a valid data source for the
OLAP query.
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OLQ1006

Only one reference to dimension
hierarchy {0} can appear in the slicer.

PRC1002

An error occurred while parsing the
command: unexpected character ''{0}''.

Explanation: MDX DB2 DWE supports only one
dimension per slicer.

Explanation: An unexpected character was
encountered while parsing the procedure.

User response: Select only one dimension.

User response: Check the procedure's text for syntax
errors or invalid characters (using the documentation or
Content Assist via Ctrl+Space)

PE00001

Encountered ''{0}'' at column {1}. \r\n
Was expecting one of: {2}.

Explanation: An invalid character was encountered at
the indicated column.
User response: Replace the invalid character with one
of the indicated characters.
PE00002

Encountered ''{0}'' at column {1}. \r\n
Was expecting: {2}.

Explanation: An invalid character was encountered at
the indicated column.
User response: Replace the invalid character with the
indicated character.
PE00003

Expression needs a calculator to get a
value.

Explanation: The expression does not return a value.

PRC1003

Explanation: An unsupported parameter token was
encountered while parsing the procedure.
User response: Check the procedure's text for syntax
errors (using the documentation or Content Assist via
Ctrl+Space)
PRC1004

Parse exception occurred.

Explanation: An error occurred while parsing the
expression.
User response: Check the expression syntax for errors
and try again.
PRC1000

An unexpected error occurred while
parsing the command.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
PRC1001

An error occurred while parsing the
command: unexpected token "{0}".

Explanation: An unexpected token was encountered
while parsing the procedure.
User response: Check the procedure's text for syntax
errors (using the documentation or Content Assist via
Ctrl+Space)

The parameter ''{0}'' cannot be specified
twice.

Explanation: The indicated parameter was specified
twice in the same procedure command.
User response: Only specify one instance of the
indicated parameter.
PRC1005

User response: No action is required.
PE00004

The parameter ''{0}'' is invalid in this
context.

''{1}'' is not a valid value for parameter
''{0}''.

Explanation: The indicated value is not valid for the
indicated parameter.
User response: Specify a valid value for the indicated
parameter. See the Procedure Commands section of the
user help for more information on procedure
commands and their parameters.
PRC1006

You cannot set variable ''{0}''.

Explanation: The indicated variable can not be set
manually.
User response: Specify a valid variable and try again.
PRC1008

An error occurred while parsing the
command: unexpected end of line.

Explanation: An unexpected end of line was
encountered while parsing the procedure.
User response: Check the procedure's text for syntax
errors (using the documentation or Content Assist via
Ctrl+Space)
PRC1009

An error occurred while parsing the
command: unrecognized command ''{0}''.

Explanation: The indicated command is not valid.
User response: Check the procedure text for errors or
specify a different command.
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PRC1010

Parsing error at lines {0}-{1} (command
#{2}). {3}

Explanation: a syntax error was encountered while
parsing procedure.
User response: Check the procedure's text for syntax
errors (using the documentation or Content Assist via
Ctrl+Space)
PRC1011

An error occurred while parsing the
command: invalid object name ''{0}''.

Explanation: The indicated object name is invalid.
User response: Check the procedure text for errors
and specify a valid object name. See the Procedure
Commands section of the user help for more
information.
PRC1012

You must specify object type or object
name.

Explanation: A required object type or name was not
specified.
User response: Specify a valid object type or name
where needed in the procedure command text. See the
Procedure Commands section of the user help for more
information.
PRC1013

User response: Check the variable name for syntax
errors or specify another valid variable. Check the
Procedure Commands section of the user help for more
information.
Close bracket reached before end.

Explanation: An unexpected close bracket was
encountered while parsing the procedure.
User response: Check the procedure's text for syntax
errors (using the documentation or Content Assist via
Ctrl+Space)
PRC2001

An error occurred while retrieving {0}.
{1}

Explanation: The indicated error occurred while
retrieving the indicated object.
User response: Resolve the error and rerun the
procedure.

{0} does not exist.

Explanation: The indicated object does not exist.
User response: Specify a valid object in the procedure
command.
PRC2003

{0} exists but is of the wrong type.

Explanation: The indicated object exists in an open
window of the editor, but the object type that was
specified in the procedure command does not match
the type of the object.
User response: Make sure the object type that is
specified in the procedure command matches the type
of the object in the open window of the editor.
PRC2004

{0} does not exist or is of the wrong
type.

Explanation: There is no object of the specified object
type open in an open window of the editor, or the
object type is incorrect.
User response: Make sure that the object type that is
specified in the procedure command matches the type
of the object that is in the open window.
PRC2005

''{0}'' is an invalid variable name.

Explanation: The indicated variable name is invalid.

PRC1014

PRC2002

The procedure issued a command
against a current object, but no current
object of the correct type exists.

Explanation: The procedure does not specify a specific
object name, only an object type. In this instance, if an
object of this type is open in another window of the
editor, the procedure will run correctly. Since an object
of the type specified is not open in another window,
the procedure failed to run.
User response: Make sure an object of the specified
type is open in another window, or specify a specific
object name.
PRC2006

{0}

Explanation: This is a wrapped message.
User response: Resolve the indicated error and try
again.
PRC2007

The CONVERT command can only be
issued against queries; it cannot be
applied to {0}.

Explanation: The indicated object can not be
converted using the CONVERT command.
User response: Specify a query to be converted using
the CONVERT command. For more information, see
the CONVERT topic in the Procedure Commands
section of the user help.
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PRC2008

The operation was cancelled.

PRC2026

Explanation: The operation was cancelled by the user.

An error occurred while running the
procedure. {0}

User response: Rerun the operation.

Explanation: The indicated error occurred while the
procedure was being run.

PRC2011

User response: Resolve the indicated error and rerun
the procedure.

Saving in {0} format is not supported.

Explanation: The selected format is not supported
when exporting an object. Reports may only be
exported in TEXT, HTML and PDF formats.
User response: Change the export data format in the
procedure command.
PRC2017

The maximum nesting depth of
procedures was exceeded.

Explanation: More than 50 nested procedure levels are
not support.
User response: Redesign the procedure to decrease its
depth.
PRC2018

The specified query did not return a
result set.

Explanation: The SAVE DATA command was issued
against a query that does not contain a result set.
User response: Ensure that the query you are trying to
save contains a result set.
PRC2020

An error occurred while saving the
object at the server. {0}

Explanation: The indicated error occurred while the
object was being saved at the server.
User response: Resolve the indicated error and rerun
the procedure.
PRC2022

The operation cannot be performed
because no data is available.

Explanation: The EXPORT DATA command was
issued against an object that does not contain data.
User response: Ensure that the object that you are
trying to export contains data.
PRC2025

The procedure was terminated because
it recursively invokes itself.

Explanation: The procedure recursively invoked itself.
Recursion is not supported in procedures.
User response: Rewrite the procedure and remove the
recursion.

PRC2028

An error occurred while importing the
{0} file.

Explanation: An error occurred while the file was
being imported.
User response: Ensure that object that is being
imported is of a supported format.
PRC2029

Could not connect to a server {1}: {0}

Explanation: The data source alias that was specified
in the CONNECT TO command is undefined.
User response: Ensure that the command refers to a
valid data source in the repository.
PRC2030

Specified object {0} for import has
incompatible type.

Explanation: The IMPORT or DISPLAY command was
issued against an object with an unsupported type.
User response: Ensure that the object to be imported
or displayed is of a valid type.
PRC2031

Specified command, or some of its
parameters unsupported.

Explanation: The procedure contains commands or
parameters that are not supported.
User response: Check the procedure's text for syntax
errors (using the documentation or Content Assist via
Ctrl+Space)
PRC2032

Cannot save non-QMF object into QMF
Catalog.

Explanation: The specified object is a non-QMF object
and can not be saved into the QMF Catalog.
User response: Specify a different location in which
the save the object or specify a different object to be
saved.
PRC2033

You cannot set the value of {0}.

Explanation: The indicated parameter's value can not
be manually set with the SET GLOBAL command.
User response: Values for some DSQ variables cannot
be set manually (for example DSQAO_CONNECT_ID,
DSQAO_NUM_FETCHED, etc). Rewrite the procedure
to exclude these variable values.
Appendix D. Messages

185

PRC2035 • QEL00006
PRC2035

The printer name ''{0}'' is invalid.

QEL00002

Explanation: The indicated printer name is invalid.
User response: Check the spelling of the printer name,
or specify a different printer to use for the PRINT
command.
PRC2036

You are not authorized to use the table
editor at this data source.

Explanation: The Enable Table Editing resource limit
for the data source is turned off; you can not open
Table Editor of the data source

Explanation: The Maximum Rows to Fetch limit has
been reached. The indicated number of rows have been
retrieved so far.
User response: Check your Maximum Rows to Fetch
resource limit by selecting Resource Limits from the
View menu to see your specific allowances or ask your
administrator for more information.
QEL00003

User response: Ask your administrator to enable this
resource limit.
PRC2037

You are not authorized to edit tables at
this data source.

Explanation: The Enable Table Editing resource limit
for the data source is turned off; you cannot edit values
in a query's grid cells.
User response: Ask your administrator to enable this
resource limit.
REXX procedure references cannot be
determined.

Explanation: References for the procedure cannot be
built for REXX procedures.
User response: You can view references at the
Repository or Workspaces views for generic
procedures only.
PROC1001

Some substitution variables are not
defined.

Explanation: Some of the substitution variables of the
procedure are not defined.
User response: Ensure that all of the substitution
variables are defined for the procedure, or run this
procedure without the /batch parameter in the
command line. In this case DataQuant will ask for all
of the necessary variables values.

User response: Check your Maximum Bytes to Fetch
resource limit by selecting Resource Limits from the
View menu to see your specific allowances or ask your
administrator for more information.

You are not allowed to run queries
returning LOB data.

Explanation: You are not allowed to run queries that
contain large object data.
User response: Check your LOB Options resource
limits by selecting Resource Limits from the View
menu to see your specific allowances or ask your
administrator for more information.
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The length of a LOB column exceeds the
maximum allowable length.

Explanation: The length of a LOB column in the query
results exceeds the maximum allowable length.
User response: Check your Maximum LOB column
size by selecting Resource Limits from the View menu
to see your specific allowances or ask your
administrator for more information.
QEL00005

You are not allowed to use the ''{0}'' SQL
verb.

Explanation: You are not allowed to use the indicated
SQL verb.
User response: Check your SQL Verbs limits by
selecting Resource Limits from the View menu to see
your specific allowances or ask your administrator for
more information.
QEL00006

QEL00001

The Maximum Bytes to Fetch limit has
been exceeded. {0} bytes were retrieved
so far.

Explanation: The Maximum Bytes to Fetch limit has
been reached. The indicated number of bytes have been
retrieved so far.

QEL00004
PROC1000

The Maximum Rows to Fetch limit has
been exceeded. {0} rows were retrieved
so far.

You are not allowed to save data to
database.

Explanation: You are not allowed to save data to the
database.
User response: Check you Save Data resource limits
by selecting Resource Limits from the View menu to
see your specific allowances or ask your administrator
for more information.

QEN00001 • QRL00003
QEN00001

Query was cancelled.

QMF1004

Explanation: The active query was cancelled.

You are not authorized to print objects
from ''{0}'' data source.

User response: Rerun the query.

Explanation: The indicated data source name has a
restriction on printing for the current user.

QEN00003

User response: Contact your administrator to check
your specific permissions for printing.

Unexpected token: {0}

Explanation: An unexpected token was encountered
while parsing the query that calls the stored procedure.

QMF1005

User response: Check the query's syntax for errors.
QEN00004

Unexpected token: {0} is expected but {1}
was found.

QMF Catalog table structure is
obsolete.\nCatalog tables must be
updated.

Explanation: The indicated an error occurred because
the QMF Catalog has an obsolete structure.

Explanation: An unexpected closed bracket was
encountered while parsing the query that calls the
stored procedure.

User response: Contact your administrator to upgrade
the QMF Catalog.

User response: Check the query's syntax for errors.

QMF1006

QEN00005

Explanation: The indicated data source name has a
restriction on saving data for the current user.

Unexpected end of statement.

Explanation: An unexpected end of statement was
encountered while parsing the query that calls the
stored procedure.

You are not authorized to save data to
files from ''{0}'' data source.

User response: Contact your administrator to check
your specific permissions for saving data.

User response: Check the query's syntax for errors.
QRL00001
QEN00006

Expression {0} is not a stored procedure.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QEN00007

End of statement is expected but {0} was
found

Explanation: Tokens were encountered after the end of
statement while parsing the query that calls the stored
procedure.
User response: Check the query's syntax for errors.
QEN00008

Unsupported parameter data type: {0}

Explanation: An unsupported parameter was
encountered while parsing the query that calls the
stored procedure.
User response: Check the query's syntax for errors.
QEN00009

{0} is invalid value for this type: {1}

Explanation: When prompted for a value for a stored
procedure parameter, the user entered a value that is
not valid for that parameter's type.

You are not authorized to access this
data source in user interface mode.

Explanation: You are not authorized to access this
data source in user interface mode.
User response: Check your Options limits by selecting
Resource Limits from the View menu to see your
specific allowances or ask your administrator for more
information.
QRL00002

You are not authorized to access this
data source in automation mode.

Explanation: You are not authorized to access this
data source in automation mode.
User response: Check your Options limits by selecting
Resource Limits from the View menu to see your
specific allowances or ask your administrator for more
information.
QRL00003

You are not authorized to run unsaved
queries.

Explanation: You are not authorized to run unsaved
queries.
User response: Check your Options limits by selecting
Resource Limits from the View menu to see your
specific allowances or ask your administrator for more
information.

User response: Specify a valid value for the
parameter.
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QRL00004

You are not authorized to save data from
this data source to a file.

Explanation: You are not authorized to save data from
this data source to a file.
User response: Check your Save Data limits by
selecting Resource Limits from the View menu to see
your specific allowances or ask your administrator for
more information.
QRL00005

You are not authorized to save data from
this data source to the database.

QRY1001

Query was cancelled.

Explanation: The query was cancelled.
User response: Rerun the query.
QRY1002

An invalid header record was
encountered.

Explanation: The query was loaded with errors.
User response: Try to reload the query; otherwise the
query is corrupted.

Explanation: You are not authorized to save data from
this data source to the database.

QRY1003

User response: Check your Save Data limits by
selecting Resource Limits from the View menu to see
your specific allowances or ask your administrator for
more information.

Explanation: No data source was specified for the
query.

QRL00006

QRY1004

You are not authorized to retrieve LOB
data.

No data source was specified for the
query.

User response: Specify a data source for the query.
An unexpected ''R'' record was
encountered: {0}.

Explanation: You are not authorized to retrieve LOB
data.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.

User response: Check your LOB Options limits by
selecting Resource Limits from the View menu to see
your specific allowances or ask your administrator for
more information.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

QRL00008

QRY1005

No resource group for user {0} was
found.

Explanation: No resource group for the indicated user
was found.
User response: Specify a valid resource group for the
user.
QRL00009

The operation cannot be performed
because the processing of LOB data is
disabled.

Explanation: The operation cannot be performed
because the processing of LOB data is disabled.
User response: Check you LOB Options limits by
selecting Resource Limits from the View menu to see
your specific allowances or ask your administrator for
more information.
QRY0999

{0}

Explanation: This is a wrapped message.
User response: Resolve the indicated error and try
again.

An unexpected ''T'' record was
encountered: {0}.

Explanation: An error was encountered while loading
a type Trecord from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1006

An invalid ''T'' record was encountered:
{0}.

Explanation: An error was encountered while loading
a type T record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1007

A ''T'' record with invalid column
information was encountered: {0}.

Explanation: An error was encountered while loading
a type T record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
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> Collect Support Data and forward it to customer
support.
QRY1008

An unrecognized table type was
encountered: {0}.

Explanation: An error was encountered while loading
a record from the prompted query file during storage
of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1009

An invalid value in an ''R'' record for
table 1110 was encountered: {0}.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1010

An invalid value in an ''R'' record for
table 1150 was encountered: {0}.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1011

An invalid value in an ''R'' record for
table 1210 was encountered: {0}.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1012

An invalid value in an ''R'' record for
table 1310 was encountered: {0}.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

QRY1013

An invalid value in an ''R'' record for
table 1410 was encountered: {0}.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1014

An out of sequence 'R' record for table
1310 was encountered.

Explanation: An error was encountered while loading
a type R record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1015

An invalid ''V'' record was encountered:
{0}.

Explanation: An error was encountered while loading
a type V record from the prompted query file during
storage of info in the prompted query structure.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1016

There must be less than 16 tables in
Prompted Query.

Explanation: There must be less than sixteen tables
called from the Prompted Query editor.
User response: Ensure that there are less than sixteen
tables called from the Prompted Query editor and
rerun the query.
QRY1017

The same correlation ID was
encountered for two or more tables.

Explanation: The PqTable object for the specified
correlation ID already exists.
User response: Select another table for the Prompted
Query editor.
QRY1018

An invalid table correlation ID was
encountered.

Explanation: An error was encountered while
retrieving a valid correlation ID.
User response: Try to add the query to the Prompted
Query editor again, or collect support data by selecting
Help > Collect Support Data and forward it to
customer support.
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QRY1019

A column on which to join tables is in
more than one of the tables in the
query.

Explanation: A join column can only exist in one table
when multiple tables are joined in a single query.
User response: Ensure that any join columns in the
query exist in only one table.

QRY1026

Explanation: An invalid operator in a row condition
was encountered for numeric data.
User response: Check all of the operators in the row
conditions for errors and rerun the query.
QRY1027

QRY1020

A column on which to join tables is not
in any of the tables in the query.

Explanation: A specified join column is not present in
any of the tables in the query.
User response: Check the join column name for errors,
or specify a different join column.
QRY1021

Type of join columns for joined tables
mismatch.

QRY1022

The expression contains a syntax error:
{0}

An invalid sort direction was
encountered.

Explanation: An invalid sort direction was
encountered. Valid directions are Ascending or
Descending.
User response: Check all instances where sort
directions are applied and change them to either
ascending or descending.
QRY1028

Explanation: A columns that join two or more tables
must all be of the same column type.
User response: Ensure that all of the columns that
make up a single join are of the same column type.

The selected relational operator is not
valid for numeric data.

The prompted query format is an earlier
version, and contains join conditions
that cannot be migrated to the current
version. These join conditions have
been deleted.

Explanation: A join condition can only appear with
the higher of the two tables involved in the join. Also, a
table cannot be joined with a preceding table if there is
a third table between them with no join conditions.

Explanation: The indicated expression contains a
syntax error.

User response: Reordered elements of the array of
joins to match the current order of the tables.

User response: Correct the syntax error and rerun the
query.

QRY1029

QRY1023

Explanation: The indicated table is called in the SQL
code, but does not exist in the data source.

An invalid connector for a row
condition was encountered.

Explanation: An invalid connector for a row condition
was encountered.
User response: Check all row conditions for errors
and rerun the query.
QRY1024

An invalid expression type in a row
condition was encountered.

Explanation: An invalid expression type in a row
condition was encountered.
User response: Check all expression types in the row
conditions for errors and rerun the query.

User response: Check the table name for errors, or
enter a different table to be called.
QRY1030

An invalid operator in a row condition
was encountered.

Explanation: An invalid operator in a row condition
was encountered.
User response: Check all operators in the row
conditions for errors and rerun the query.
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The prompted query cannot be saved
because a table name exceeds the
maximum length allowed in the
prompted query export format.

Explanation: The prompted query cannot be saved
because a table name exceeds the maximum length
allowed in the prompted query export format.
User response: Decrease the length of the table name.
QRY1031

QRY1025

The table {0} does not exist.

The prompted query cannot be saved
because a column name used in a join
condition exceeds the maximum length
allowed in the prompted query export
format.

Explanation: The prompted query cannot be saved
because a column name used in a join condition
exceeds the maximum length allowed in the prompted
query export format.

QRY1032 • QRY1044
User response: Decrease the length of the join column
name.

QRY1038

QRY1032

Explanation: Subselects are not supported for queries
that are viewed in the Prompted Query editor.

The prompted query cannot be saved
because a column expression exceeds
the maximum length allowed in the
prompted query export format.

Explanation: The prompted query cannot be saved
because a column expression exceeds the maximum
length allowed in the prompted query export format.
User response: Decrease the length of the column
expression name.
QRY1033

The prompted query cannot be saved
because an expression in a row
condition exceeds the maximum length
allowed in the prompted query export
format.

Explanation: The prompted query cannot be saved
because an expression in a row condition exceeds the
maximum length allowed in the prompted query
export format.
User response: Decrease the length of the row
condition.
QRY1034

An invalid record was encountered.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
QRY1035

Only a SELECT query can be shown in
the prompted view.

Explanation: Only a SELECT query can be shown in
the Prompted Query editor.
User response: Make sure that the specified query
contains a SELECT statement.
QRY1036

Only simple SELECT statements are
supported.

Explanation: Only simple SELECT statements are
supported.
User response: Ensure that the specified query only
contains simple SELECT statements.

User response: Ensure that specified query does not
contain subselects if it is to be viewed in the Prompted
Query editor.
QRY1039

Unrecognized table reference.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.

Table locator references are not
supported.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
QRY1040

Table functions are not supported.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
QRY1041

Only AND conditions are supported for
joins in the prompted view.

Explanation: Only AND conditions are supported for
joins in queries that are viewed in the Prompted Query
editor.
User response: Ensure that the specified query only
contains AND conditions for joins if it is to be viewed
in the Prompted Query editor.
QRY1042

Quantified predicates are not supported.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
QRY1043

'Exists' predicates are not supported.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
QRY1044

QRY1037

You cannot view a query that has
subselects in the prompted view.

Only simple LIKE statements are
supported.

Explanation: Only simple LIKE statements are
supported.
User response: Ensure that the specified query only
contains simple LIKE statements.

Appendix D. Messages

191

QRY1045 • RCO0002
QRY1045

Only simple row conditions are
supported.

Explanation: Only simple row conditions are
supported.
User response: Ensure that the specified query only
contains simple row conditions.

QRY1052

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
QRY1053

QRY1046

An invalid value: {0}.

Expression cannot be empty.

Only SELECT statements are supported
in compound queries.

Explanation: An error occurred while constructing the
query.

Explanation: Only SELECT statements are supported
in compound queries.

User response: Check the query's syntax for errors
and try again.

User response: Ensure that only SELECT statements
are called in the specified compound query.

QRY1047

QRY1054

Invalid type for saving the query.

Explanation: The type that was set for the query is
invalid.
User response: Specify a valid type for the query or
collect support data by selecting Help > Collect
Support Data and forward it to customer support.

Explanation: The query can not be saved in the
prompted format.
User response: Save the query in another format.
QRY1055

QRY1048

Query content is not compatible with
Prompted Query format.

You cannot run an empty query.

Host variable predicates are not
supported.

Explanation: The specified query did not contain any
SQL code.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.

User response: Populate the query with at least a
SELECT statement and rerun.

User response: Check the SQL text for errors and try
again.

QRY1049

RCO0000

Some substitution variables are not
defined.

Explanation: Some of the substitution variables in the
query were not given values when the query was run.
User response: Ensure that all of the substitution
variables in the query are defined.

Explanation: An internal processor error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RCO0001

QRY1050

You cannot view a query that uses row
values in the predicate.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
'XMLExists' predicates are not
supported.

Explanation: An error occurred while parsing the SQL
text to construct the prompted query.
User response: Check the SQL text for errors and try
again.
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Type mismatch

Explanation: An unexpected error occurred while
processing the *.rco file.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RCO0002

QRY1051

Internal error

Function {0} is not implemented yet

Explanation: An unexpected error occurred while
processing the *.rco file.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

RCO0003 • REP01005
RCO0003

Undefined variable {0}

RCO0010

Database error {0}

Explanation: An unexpected error occurred while
processing the *.rco file.

Explanation: An unexpected error occurred while
processing the *.rco file.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

RCO0004

RCO0011

Missing variable name

Unknown database server type {0}

Explanation: An unexpected error occurred while
processing the *.rco file.

Explanation: An unexpected error occurred while
processing the *.rco file.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

RCO0005

REP01000

Syntax error in \"{0}\"

{0}

Explanation: An unexpected error occurred while
processing the *.rco file.

Explanation: The indicated error occurred while
accessing the repository.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Resolve the indicated error and try
again.
REP01001

RCO0006

Unknown function {0}

Explanation: An unexpected error occurred while
processing the *.rco file.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RCO0007

Unknown object type {0}

Explanation: An unexpected error occurred while
processing the *.rco file.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

An input/output error occurred: {0}

Explanation: The indicated error occurred in the
repository.
User response: Resolve the indicated error and try
again.
REP01002

Character encoding is not supported: {0}

Explanation: The indicated encoding error occurred
while the data was being processed.
User response: Ensure that UTF-8 encoding is used in
the repository storage database.
REP01003

Internal error has occurred: {0}

Explanation: The indicated error occurred.
RCO0008

Wrong parameters in \"{0}\"

Explanation: An unexpected error occurred while
processing the *.rco file.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RCO0009

Database object {0} not found

Explanation: An unexpected error occurred while
processing the *.rco file.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Resolve the indicated error and try
again.
REP01004

The following error has occurred while
accessing database: {0}

Explanation: The indicated error occurred while the
database was being accessed.
User response: Resolve the indicated error and retry
to connect to the database.
REP01005

Operation is not supported.

Explanation: The specified operation is not supported
by the repository.
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REP01006 • REP01018
User response: Specify a different operation and try
again.
REP01006

Object with such identifier not found.

Explanation: An error occurred while searching for
the object.
User response: Ensure that the specified object
identifier is correct.

REP01012

Explanation: The indicated object name already exists
as a different type of object. Each object in the database
must have a different name.
User response: Specify a different name for the object
and retry to save the object.
REP01013

REP01007

Object or file with URL \"{0}\" not
found.

Explanation: There are no objects or files with the
indicated URL.
User response: Check the URL for errors or specify a
different URL.
REP01008

Not enough permissions to perform
operation.

Explanation: Your user ID does not have permission
to perform the specified operation.
User response: Contact your administrator to check
your specific permissions or specify a different
operation to perform.
REP01009

Operation cancelled due to invalid
object identifier: {0}

Explanation: The operation was cancelled because the
indicated object identifier is invalid.
User response: Specify a different object identifier and
retry the specified operation.
REP01010

Cannot open connection: {0}

Explanation: The indicated error occurred while
establishing a connection to the repository database.
User response: Ensure that the repository database is
accessible.
REP01011

At least one line of the document is
longer than 79 characters, which is the
maximum supported length when
saving objects in the database.

Explanation: The maximum character length allowed
for documents saved to the database is seventy-nine
characters. The document contains at least one line that
is longer than seventy-nine characters.
User response: Ensure that all of the lines of the
document are less than seventy-nine characters and
retry to save the document.
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{0} already exists and has a different
type.

{0} does not exist.

Explanation: The indicated object could not be found
because it does not exist in the database.
User response: Specify a different object name to
search for in the database.
REP01014

{0} already exists.

Explanation: The indicated object could not be saved
because it already exists in the database.
User response: Specify a different name for the object
and retry to save the object.
REP01015

{0} has unsupported type and cannot be
accessed.

Explanation: The indicated object is of an
unsupported type.
User response: Ensure that all of the necessary
plug-ins are installed and available.
REP01016

Operation is impossible because object
is too large.

Explanation: The specified operation could not be
performed because the specified object is too large.
User response: Specify a different object or a different
operation and try again.
REP01017

Illegal state or illegal operation error.

Explanation: An internal error occurred in the
repository.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
REP01018

User is not logged on repository.

Explanation: You can not perform the specified
operation, because you are not connected to the
repository.
User response: Connect to the repository and try
again.

REP01019 • REP01037
REP01019

Not implemented.

Explanation: The indicated error occurred while
attempting to access a non-implemented functionality.
User response: Ensure that you are using the latest
version of the product.
REP01020

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
Initialization error occurred \"{0}\".

Explanation: An error occurred while the repository
was being initialized.
User response: Check the repository initialization
parameters and try again.
REP01022

Invalid initialization parameters were
specified \"{0}\".

Explanation: An error occurred while the repository
was being initialized.
User response: Check the repository initialization
parameters and try again.
REP01027

More authentication information for {0}
required.

Explanation: Not enough authentication information
was provided for the indicated object.
User response: Provide more authentication
information to the indicated object and try again.

Unexpected error occurred.

Explanation: An internal error occurred in the
repository.

REP01021

REP01030

A repository instance hasn't been
initialized.

REP01031

Repository storage table structure is
obsolete.\nContact repository storage
administrator.

Explanation: An error occurred while trying to access
a repository that has an obsolete structure.
User response: Contact your administrator to upgrade
the repository database structure.
REP01032

CCSID information could not be found
for current QMF catalog.

Explanation: An error occurred while trying to read
CCSID information from the QMF Catalog.
User response: Specify valid CCSID information and
try again.
REP01034

A repository with name {0} already
exists.

Explanation: The repository could not be created,
because a repository of the same name already exists.
User response: Specify a different name for the new
repository and try again.

Explanation: An error occurred while trying to access
a non-initialized repository.

REP01035

User response: Initialize the repository and try again.

Explanation: An error occurred while trying to access
an unsupported object.

REP01028

User response: Ensure that all of the required plug-ins
are installed and available.

Repository \"{0}\" could not be found.

Explanation: The indicated repository could not be
found.
User response: Check the repository name for errors
or specify a different repository and try again.
REP01029

Object type {0} cannot be added to this
folder.

Explanation: Objects of the indicated type can not be
added to the specified folder.
User response: Specify a different folder in which to
add the indicated object.

REP01036

Unknown object type.

Object {0} cannot be added to this
folder.

Explanation: The indicated object can not be added to
the specified folder.
User response: Specify a different folder in which to
add the indicated object.
REP01037

Repository could not be found.

Explanation: The specified repository could not be
found.
User response: Check the repository name for errors
or specify a different repository name and try again.
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REP01038 • RGEN1001
REP01038

Undefined or wrong repository
identifier

Explanation: An error occurred while trying to
initialize a repository with deprecated initialization
parameters.
User response: Change the repository connection
properties through the Edit Repository Connection
dialog and try again.
REP01039

There are no catalogs on the server

Explanation: No QMF catalogs exist on the specified
server.
User response: Specify a different server and try
again.
REP01042

You are not authorized to use objects
with Owner = {0}.

Explanation: Your user ID is not authorized to use
objects with the indicated owner.
User response: Specify an object that has a different
owner or contact your administrator for more
information.
REP01043

This data source cannot be accessed by
DataQuant

Explanation: The application can not access this data
source.

REP01047

Cannot find data source: {0}

Explanation: The indicated data source could not be
found.
User response: Specify a different data source and try
again.
REP01049

Object name cannot exceed {0}
characters.

Explanation: The indicated object name exceeds the
maximum character limit.
User response: Shorten the indicated object name and
try again.
REP01050

Object path cannot exceed {0} characters.

Explanation: The indicated object path exceeds the
character limit.
User response: Shorten the indicated object path and
try again.
REP01051

Cannot connect to repository \"{0}\"
because it is used by another instance of
DataQuant. Select different repository.

Explanation: You can not connect to the indicated
repository because it is being used by another instance
of the application.
User response: Select a different repository connection
and try again.

User response: Check your user license and try again.
REP01052
REP01044

Access to data source ''{0}'' blocked due
to QMF catalog restriction violation.\

Explanation: Access to the indicated data source is
blocked due to a restriction imposed by the QMF
catalog protection limits.
User response: Specify a different data source to
access or contact your administrator for more
information.
REP01045

Associated QMF catalog data source
could not be found: {0}

Explanation: The indicated QMF catalog data source
could not be found.
User response: Check the data source name for errors
or specify a different data source and try again.

Data Source plug-in \"{0}\" was not
properly initialized.

Explanation: The indicated plug-in was not properly
initialized.
User response: Change the plug-in parameters.
RGEN1000

An error has occurred while generating
the report: {0}

Explanation: The indicated error occurred while the
report was being generated.
User response: Resolve the indicated error and retry
to generate the report.
RGEN1001

The action was cancelled.

Explanation: The specified action was cancelled
User response: Rerun the specified action.

REP01046

Cannot find connection: {0}

Explanation: The indicated repository connection
could not be found.
User response: Specify a different repository
connection and try again.
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RGEN1002 • RLE00010
RGEN1002

The number of columns in the form
does not match the number of columns
in the query.

Explanation: The number of columns in the form does
not match the number of columns in its associated
query.
User response: Edit the number of columns in the
form to match the number of columns its associated
query.
RGEN1003

Internal error.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

RLE00004

Explanation: An error occurred while retrieving
resource limits.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RLE00005

The number of columns in the form
does not match the number of columns
in the query.

Explanation: The number of columns in the form does
not match the number of columns in its associated
query.
User response: Edit the number of columns in the
form to match the number of columns its associated
query.
RGEN1005

The data source object is not specified.

An error has occurred while obtaining
resource limits: {0}

Explanation: The indicated error occurred while
resource limits were being obtained.
User response: Resolve the indicated error and try
again.
RLE00006

RGEN1004

Unknown resource limits key is used to
retrieve limits.

Cannot retrieve resource limits because
resource limits key content is corrupted.
{0}

Explanation: The indicated error occurred while
attempting to retrieve resources limits.
User response: Resolve the indicated error and try
again.
RLE00007

The following error has occurred while
retrieving resource limits: {0}

Explanation: The indicated error occurred while
resource limits were being retrieved.

Explanation: The data source object for the report is
not specified.

User response: Resolve the error and try again.

User response: Specify a data source object for the
report and try again.

RLE00008

RLE00002

Cannot retrieve resource limits of type
{0}.

Explanation: The resources of the indicated type can
not be retrieved.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RLE00003

An error has occurred while retrieving
resource limits from remote site: {0}

Explanation: The indicated error occurred while
resource limits were being obtained from a remote site.
User response: Resolve the indicated error and try
again.

Data source cannot be accessed.

Explanation: Your user ID does not have permission
to access the data source.
User response: Check your resource limits by selecting
Resource Limits from the View menu or contact your
administrator for more information.
RLE00009

LOB data saving is denied.

Explanation: Your user ID does not have permission
to save objects that contain LOB data.
User response: Check your LOB Options resource
limits by selecting Resource Limits from the View
menu or contact your administrator for more
information.
RLE00010

You are only authorized to run saved
queries at this server.

Explanation: You are only allowed to run saved
queries while you are connected to the current server.
User response: Check you Save Data resource limits
by selecting Resource Limits from the View menu or
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RLE00011 • RPT00003
contact your administrator for more information.
RLE00011

You are not authorized to save objects at
this server.

Explanation: You are not authorized to save objects
while you are connected to the current server.
User response: Check your Save Data resource limits
by selecting Resource Limits from the View menu or
contact your administrator for more information.
RLE00012

You are not authorized to access data
source {0}.

User response: Check your Server Response Timeouts
resource limit by selecting Resource Limits from the
View menu or try to connect to the server during a
time of lighter server traffic.
RLW00004

The query has been idle for {0} seconds.

Explanation: The query has been idle for the indicated
number of seconds and the Idle Query Timeouts
warning limit has been reached.
User response: Click OK to continue running the
query. Click Abort to abort the query. Click Ignore to
ignore the warning.

Explanation: Your user ID is not authorized to access
the indicated data source.

RLW00005

User response: Try to connect to another data source,
or contact your administrator for information regarding
specific allowances.

Explanation: The query was cancelled because the Idle
Query Timeout limit was exceeded.

RLE00013

You are not authorized to access data
source {0}.

Explanation: Your user ID is not authorized to access
the indicated data source.
User response: Try to connect to another data source,
or contact your administrator for information regarding
specific allowances.
RLW00001

{0} rows were retrieved. The Maximum
Rows to Fetch warning limit has been
exceeded.

Explanation: The indicated number of rows were
retrieved and the warning limit for the Maximum
Rows to Fetch limit has been reached.
User response: Click OK to continue running the
query. Click Abort to abort the query. Click Ignore to
ignore the warning.
RLW00002

{0} bytes were retrieved. The Maximum
Bytes to Fetch warning limit has been
exceeded.

Explanation: The indicated number of bytes were
retrieved and the warning limit for the Maximum
Bytes to Fetch limits has been reached.
User response: Click OK to continue running the
query. Click Abort to abort the query. Click Ignore to
ignore the warning.
RLW00003

There has been no response from {0}.{1}
for {2} seconds.

Explanation: The query was cancelled because the
Server Response Timeout limit has been reached. There
was no response from the indicated server after a wait
time of the indicated length.
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The query was cancelled because the
Idle Query Timeout limit was exceeded.

User response: Attempt to rerun the query at a time
when there is less server traffic.
RLW00006

The operation cannot be performed
because the processing of LOB data is
disabled.

Explanation: The operation can not be performed
because the LOB Retrieval Option resource limits is
disabled.
User response: Check your LOB Retrieval Option
resource limit by selecting Resource Limits from the
View menu or contact your administrator for more
information.
RPT00001

Unable to process a Level component.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT00002

Report does not contain a main page.

Explanation: The visual report does not contain a
main page.
User response: Make sure that the report contains a
main page.
RPT00003

A group expression ''{0}'' is not correct.

Explanation: The indicated expression refers to a
nonexistent column.
User response: Ensure that the expression refers to a
valid column.

RPT00014 • RPT00048
RPT00014

BLOB locator was not initialized.

RPT00040

Explanation: An error occurred while retrieving a
BLOB locator.

A renderer for the selected report format
has generated an error. No output
contents has been produced.

User response: Reconnect to the repository and try
again.

Explanation: A renderer for the selected report format
has generated an error. No output contents have been
produced.

RPT00015

User response: Try to view the visual project in
another rendering mode, or reload the visual project.

Query results were not initialized.

Explanation: The query results were not initialized.
User response: Reconnect to the repository and try
again.

RPT00041

Internal error: unable to create reporter
engine.

Explanation: An internal error occurred.
RPT00033

Internal swing renderer error: too early
completion.

Explanation: The line object is incorrect.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Delete the line object and recreate it in
the designer.

RPT00042

RPT00034

Explanation: The visual project's data is corrupted.

Internal swing renderer error: incorrect
segment type.

Explanation: The line object is incorrect.
User response: Delete the line object and recreate it in
the designer.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT00043

RPT00035

Internal error in reporter engine.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
Invalid arguments was used: row and
column should be positive or zero.

Explanation: A row or column in the grid is of a
length that is less than zero when viewed in the HTML
or SWF rendering mode.
User response: Reload the visual project.

Unable to locate visual dashboard
format file.

Explanation: {CONFIG_DIR}/converter/repository/
world.xml can not be found or read.
User response: Reinstall DataQuant.
RPT00044

RPT00037

Unable to parse previously stored visual
project data.

Unable to read visual dashboard format
file.

Explanation: {CONFIG_DIR}/converter/repository/
world.xml can not be found or read.
User response: Reinstall DataQuant.
RPT00045

Unable to read visual dashboard scene.

Explanation: The visual project's data is corrupted.
RPT00038

Parameter {0} already exists.

Explanation: The specified parameter already exists.
User response: Specify a new name for the new
parameter.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT00048

RPT00039

Unable to process one or more
expressions in the visual dashboard to
render its runtime content.

Explanation: The renderer attempted to render a scene
that is undefined.

Unable to serialize object {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Reload the visual project.
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RPT00049 • RPT10001
RPT00049

Internal serialization error: no tag for {0}
object class.

Explanation: The tag description for the indicated
class could not be found during the serialization
process.

RPT00057

Invalid number value.

Explanation: While loading the visual project, a string
that was supposed to contain a number value was
encountered without digit characters.

User response: Reinstall DataQuant.

User response: Reload the visual project or try using a
different locale.

RPT00050

RPT00058

Unknown parameter type.

Explanation: An unknown parameter type was
encountered during the serialization process.
User response: Reload the visual project.
RPT00051

Invalid action type.

Explanation: An unknown action type was
encountered while loading the visual project.
User response: Reload the visual project.
RPT00052

Embedded visual dashboard picture is
corrupted.

Invalid date value.

Explanation: While loading the visual project, a string
that was supposed to contain a date value was
encountered with characters that could not be parsed
into a date value.
User response: Reload the visual project or try using a
different locale.
RPT00059

Invalid point value.

Explanation: While loading the visual project, a string
that was supposed to contain a point value was
encountered with characters that could not be parsed
into a point value.

Explanation: An embedded image in the visual
dashboard is corrupted and can not be opened.

User response: Reload the visual project.

User response: Check all of the embedded images in
the visual dashboard and delete any that are corrupted.

RPT00060

RPT00053

Invalid color value.

Explanation: Corrupted tags were encountered while
loading a ColorMap or a ColorSequence.
User response: Reload the visual project.
RPT00054

Invalid threshold value for color map.

Explanation: Corrupted tags were encountered while
loading a ColorMap or a ColorSequence.
User response: Reload the visual project.

Unable to read visual dashboard.

Explanation: An error occurred while loading the
visual dashboard.
User response: Reload the visual dashboard.
RPT00061

(Multiple possible messages; see Explanation)

Explanation:
1. Missing query alias. - A query with no query name
tag was encountered while loading the visual
project.
2. The offline visual report cannot be saved in file. Offline visual reports can not be saved to a file.
User response:

RPT00055

Invalid event type.

Explanation: An unknown event type was
encountered.

1. Reload the visual project.
2. Convert the visual report to an online report before
saving to a file.

User response: Reload the visual project.

RPT10001

RPT00056

Explanation: The Visionary World file can not be
found.

Missing image alias.

Explanation: An unknown image was found.
User response: Reload the visual project.
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Source Visionary World file has not
been specified.

User response: Ensure that the Visionary World file
exists and that it can be read.

RPT10002 • RPT10017
RPT10002

Configuration directory has not been
specified.

Explanation: The configuration directory for the
converter can not be found.
User response: Reinstall DataQuant.
RPT10003

Source Visionary World file has not
been found.

are saved in the correct locations.
RPT10010

Picture file {0} is too large.

Explanation: The indicated picture file is too long.
User response: Specify a smaller picture file to be
used in the visual project.
RPT10011

XML parsing error.

Explanation: The Visionary World file can not be
found.

Explanation: An XML parsing error occurred while
attempting to convert the Visionary World.

User response: Ensure that the Visionary World file
exists.

User response: Save the Visionary World file in
Visionary and try again.

RPT10004

RPT10012

Configuration directory has not been
found.

Explanation: The configuration directory for the
converter can not be found.

XML reading error.

Explanation: An input/output error occurred while
attempting to read the XML data.
User response: Try to convert the XML data again.

User response: Reinstall DataQuant.
RPT10013
RPT10005

Configuration file {0} has not been
found.

Explanation: The configuration file for the converter
can not be found.

Unable to create Visual Dashboard
object.

Explanation: An error occurred while attempting to
convert the Visionary World file.

User response: Reinstall DataQuant.

User response: Try to convert the Visionary World file
again.

RPT10006

RPT10014

Unable to locate Visionary Connection
file(s) in the folder {0}.

Explanation: The Visionary Connection files do not
exist in the proper locations.
User response: Check that all Visionary World files
are saved in the correct locations.
RPT10007

Unable to read Visionary Query file {0}.

Explanation: The Visionary World file that is specified
in the query can not be found.
User response: Check that all Visionary World files
are saved in the correct locations.
RPT10008

Unable to locate Visionary Scene file {0}.

Explanation: The indicated scene file is not saved in
the correct location.
User response: Check that all Visionary World files
are saved in the correct locations.
RPT10009

Unable to read an image file {0}.

Explanation: The image file that is specified by the
indicated name can not be found.

Cannot parse configuration file {0}.

Explanation: An error occurred while attempting to
parse the converter configuration files.
User response: Reinstall DataQuant.
RPT10015

Visual Dashboard for a connection is
not specified.

Explanation: The Visionary World file was not loaded
properly.
User response: Reload the Visionary World file.
RPT10016

Invalid color description has been
found.

Explanation: Corrupted tags were encountered while
loading a ColorMap or ColorSequence.
User response: Reload the Visionary World file.
RPT10017

Invalid color map description has been
found.

Explanation: Corrupted tags were encountered while
loading a ColorMap.
User response: Reload the Visionary World file.

User response: Check that all Visionary World files
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RPT10018 • RPT10034
RPT10018

Unknown tag: {0}

Explanation: Unknown tags were encountered while
attempting to convert the Visionary World file.
User response: Try to convert the Visionary World file
again.
RPT10019

Invalid scene template description.

Explanation: An error occurred while loading the
Visionary World scene file.
User response: Reload the Visionary World scene file.
RPT10020

Corrupted property value has been
found.

Explanation: An incorrect format or a corrupted value
was specified in a property tag.
User response: Reload the Visionary World file.

RPT10026

Unable to parse a number: {0}

Explanation: While loading the Visionary World file, a
string that was supposed to contain a number value
was encountered without digit characters.
User response: Reload the Visionary World file.
RPT10027

PointSet component XML is corrupted.

Explanation: While loading the Visionary World file, a
string that was supposed to contain a point value was
encountered with characters that could not be parsed
into PointSet value.
User response: Reload the Visionary World file.
RPT10028

Unknown expression type {0}.

Explanation: An unknown expression type was
encountered while loading the Visionary World file.
User response: Reload the Visionary World file.

RPT10021

Invalid URL or path format: ''{0}''

Explanation: The indicated URL or path format is
invalid.
User response: Check the URL for errors or specify a
different URL.

RPT10029

One or more queries do not have alias.

Explanation: A query alias tag that does not contain a
name property was encountered while converting the
Visionary World file.
User response: Reload the Visionary World file.

RPT10022

Unknown or unsupported event type

Explanation: A corrupted or unknown event type was
encountered.
User response: Reload the Visionary World file.
RPT10023

Function name in expression is missing

Explanation: A function name in an expression is
missing.

RPT10031

Explanation: While loading the Visionary World file, a
string that was supposed to contain a point value was
encountered with characters that could not be parsed
into PointSet value.
User response: Reload the Visionary World file.
RPT10032

User response: Reload the Visionary World file.
RPT10024

Cannot parse function argument

Unable to parse a point value.

Visionary World XML has been
corrupted.

Explanation: An error occurred while attempting to
load the Visionary World file.

Explanation: The function argument could not be
parsed while loading the Visionary World file.

User response: Reload the Visionary World file.

User response: Reload the Visionary World file.

RPT10033

RPT10025

Explanation: An internal error occurred.

Invalid scene template description.

Explanation: An error occurred while loading the
Visionary World scene file.
User response: Reload the Visionary World file.

Internal error: unable to access
Visionary World.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT10034

Unable to add parameter {0} to a Visual
Dashboard

Explanation: An internal error occurred.
User response: Collect support data by selecting Help

202

Installing and Managing DataQuant

RPT20001 • RPT30001
> Collect Support Data and forward it to customer
support.

User response: Reload the visual report.
RPT20009

RPT20001

Unable to access repository during
Visual Report conversion.

Explanation: The repository could not be accessed
while the Visual Report was being converted.
User response: This could possibly be because you
were not connected to the repository. Make sure you
are connected and try again.
RPT20002

Source visual report file has not been
specified.

Explanation: The source visual report file has not been
specified.
User response: Specify the source visual report file.
RPT20003

Source visual report file has not been
found.

Internal error: unable to access Visual
Report.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT20011

Unable to set a line style for a line
control.

Explanation: An undefined line style was encountered
while loading the visual report.
User response: Reload the visual report.
RPT20012

Invalid linked picture alias has been
found in Visual Report.

Explanation: A link to a picture without a name was
encountered while parsing the visual report data.

Explanation: The source visual report file could not be
found.

User response: Reload the visual report.

User response: Specify a valid source visual report
file.

RPT20013

RPT20004

Visual Report name has not been
specified.

Explanation: The visual report name has not been
specified.

Unable to create Visual Report control.

Explanation: An error occurred while loading a
primitive or control object.
User response: Reload the visual report.
RPT20015

User response: Specify a name for the visual report.

Invalid parameter name ''{0}'' has been
found.

Explanation: The parameter value is invalid.
RPT20005

Unable to create visual report.

Explanation: An error occurred while creating the
visual report.
User response: Reload the visual report.
RPT20006

Unable to open an embedded image.

Explanation: An embedded image file was not found.

User response: Specify a different name for the
parameter indicated.
RPT20016

Invalid parameter value ''{0}'' has been
found.

Explanation: The parameter value is invalid.
User response: Specify a different value for the
parameter indicated.

User response: Reload the visual report.
RPT30001
RPT20007

Unknown section type: {0}

Explanation: The structure of a section set and type
was not found while loading the visual report.
User response: Reload the visual report.
RPT20008

Unable to create Visual Report page
component.

Navigate to Embedded Scene:
Embedded Scene not found for name
''{0}''.

Explanation: The Navigate to Embedded Scene action
failed because the indicated embedded scene could not
be found.
User response: Correct the name of the embedded
scene that is associated with the Navigate to
Embedded Scene action, or specify another.

Explanation: An error occurred while parsing and
creating a page component.
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RPT30002 • RPT30047
RPT30002

Navigate back: can`t execute exit action
(maybe history is empty).

Explanation: The Navigate Back action failed,
possibly because the navigation history is empty.
User response: Reload the visual project and try
again.
RPT30021

DesignReporter: LevelTemplate is null.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30022

DesignReporter: unknown component
{0}.

Explanation: An unknown component was
encountered during runtime rendering.
User response: Reload the visual project.
RPT30024

The template is invalid. FillStyle or
LineStyle property is null!

Explanation: An error occurred while running the
substitution rule to change the Wedge template.
User response: Check the FillStyle and LineStyle
properties for errors.
RPT30025

The template is invalid. Height == {0}!

Explanation: An error occurred while running the
substitution rule to change a template.

fix the problem, reinstall the application.
RPT30035

No OutputComponentCreator in map
for {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30038

Could not find {0}.

Explanation: One of the objects in the Connections
folder could not be found.
User response: Reload the project or delete the
connection and try again.
RPT30040

Chart cannot read query result set.

Explanation: An error occurred while creating a
ClusterGraph, OrganizationChart, or TreeChart.
User response: Reconnect to the repository and reload
the visual project.
RPT30042

Error - axisLength is infinite.
totalPercentages:{0}
m_sceneRuntimePanel.getZoomFactor()
{1}

Explanation: The value of an axis's PercentageLength
property is invalid.
User response: Check the PercentageLength property
value of the axis for errors.

User response: Check the Height property for errors.

RPT30044

RPT30026

Explanation: A value other than UNCHECKED, CHECKED,
or INDETERMINATE was specified.

The template is invalid. Width == {0}!

Explanation: An error occurred while running the
substitution rule to change a template.
User response: Check the Width property for errors.
RPT30028

Cannot load resources for package {0}
and locale {1}.

Explanation: The bundle for the resource can not be
found.
User response: Restart the application. If this does not
fix the problem, reinstall the application.

User response: Ensure that any action that sets the
value of a checkbox sets it to UNCHECKED, CHECKED, or
INDETERMINATE.
RPT30045

Request for resource string ''{0}'' from
package {1} failed.

Explanation: An error occurred while requesting a
string resource.
User response: Restart the application. If this does not
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Unknown m_style: {0}.

Explanation: An invalid style property was specified
for a ComboBox object.
User response: Check the style property for the
ComboBox object for errors.
RPT30047

RPT30029

Unknown checkbox value: {0}.

Line is not horizontal or vertical.

Explanation: A segment in an ElbowConnector object
is set to neither vertical or horizontal.
User response: Reload the visual project.

RPT30048 • RPT30062
RPT30048

Unsupported segment type: {0}.

Explanation: An unsupported segment type was
encountered for an ElbowConnector object.
User response: Reload the visual project.
RPT30049

Could not get corner type last: {0} start:
{1} end: {2}.

Explanation: The start and end coordinates of a line
segment do not define a corner in an ElbowConnector
object.
User response: Reload the visual project, or delete and
re-create the ElbowConnector object.
RPT30050

Should not have gotten here.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30052

Unknown horizontal align: {0}.

Explanation: A value other than LEFT, RIGHT, or CENTER
was encountered in the HorizontalAlign property of an
object.
User response: Ensure that any action that sets the
value of the HorizontalAlign property of an object sets
it as LEFT, RIGHT, or CENTER.
RPT30053

Unknown vertical align: {0}.

Explanation: A value other than TOP, BOTTOM, or CENTER
was encountered in the VerticalAlign property of an
object.

RPT30055

Unknown arrowheadStyle: {0}.

Explanation: A value other than NONE, TRIANGLE,
CIRCLE, DIAMOND, or SWEPTPOINTER was encountered in
the MarkerShape property of an arrow object.
User response: Ensure that any action that sets the
value of the MarkerShape property of an arrow object
sets it as NONE, TRIANGLE, CIRCLE, DIAMOND, or
SWEPTPOINTER.
RPT30056

Unknown marker shape: {0}.

Explanation: A value other than HOLLOWCIRCLE,
HOLLOWDIAMOND, HOLLOWSQUARE, HOLLOWTRIANGLE,
HOLLOWTRIANGLE2, HOLLOWSTAR, HOLLOWPLUS, SOLIDCIRCLE,
SOLIDDIAMOND, SOLIDSQUARE, SOLIDTRIANGLE,
SOLIDTRIANGLE2, SOLIDSTAR,SOLIDPLUS, CROSS, PLUS,
BOXCROSS, or BOXPLUS was encountered in the
MarkerShape property of a data point object.
User response: Ensure that any action that sets the
value of the MarkerShape property of a data point
object sets it as HOLLOWCIRCLE, HOLLOWDIAMOND,
HOLLOWSQUARE, HOLLOWTRIANGLE, HOLLOWTRIANGLE2,
HOLLOWSTAR, HOLLOWPLUS, SOLIDCIRCLE, SOLIDDIAMOND,
SOLIDSQUARE, SOLIDTRIANGLE, SOLIDTRIANGLE2,
SOLIDSTAR,SOLIDPLUS, CROSS, PLUS, BOXCROSS, or
BOXPLUS.
RPT30060

Unknown attachmentStyle: {0}.

Explanation: A value other than TOPLEFT, TOPCENTER,
TOP, TOPRIGHT, CENTERLEFT, CENTER, CENTERRIGHT,
BOTTOMLEFT, BOTTOMCENTER, BOTTOM, or BOTTOMRIGHT was
encountered in the AttachmentStyle property of a
connector object.

User response: Ensure that any action that sets the
value of the VerticalAlign property of an object sets it
as TOP, BOTTOM, or CENTER.

User response: Ensure that any action that sets the
value of the AttachmentStyle property of a connector
object sets it as TOPLEFT, TOPCENTER, TOP, TOPRIGHT,
CENTERLEFT, CENTER, CENTERRIGHT, BOTTOMLEFT,
BOTTOMCENTER, BOTTOM, or BOTTOMRIGHT.

RPT30054

RPT30061

Unknown location anchor: {0}.

Unknown border type for table: {0}.

Explanation: A value other than BOTTOMLEFT,
LEFTCENTER, TOPLEFT, BASELINELEFT, BOTTOMCENTER,
CENTER, TOPCENTER, BASELINECENTER, BOTTOMRIGHT,
RIGHTCENTER, or BASELINERIGHT was encountered in the
LocationAnchor property of an object.

Explanation: An invalid value was encountered in the
BorderType property of an object.

User response: Ensure that any action that sets the
value of the LocationAnchor property of an object sets
it as BOTTOMLEFT, LEFTCENTER, TOPLEFT, BASELINELEFT,
BOTTOMCENTER, CENTER, TOPCENTER, BASELINECENTER,
BOTTOMRIGHT, RIGHTCENTER, or BASELINERIGHT.

RPT30062

User response: Ensure that any action that sets the
BorderType property of an object sets a valid value.
Unknown m_horizontalAlign: {0}.

Explanation: An invalid value was encountered in the
HorizontalAlign property of a table cell.
User response: Ensure that any action that sets the
HorizontalAlign property of a table cell sets a valid
value.
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RPT30063 • RPT30083
RPT30063

Unknown m_verticalAlign: {0}.

RPT30071

Unknown imageAnchor: {0}.

Explanation: An invalid value was encountered in the
VerticalAlign property of a table cell.

Explanation: An invalid value was encountered in the
ImageAnchor property of an object.

User response: Ensure that any action that sets the
VerticalAlign property of a table cell sets a valid value.

User response: Ensure that any action that sets the
ImageAnchor property of an object sets a valid value.

RPT30064

RPT30072

Unknown border type for table: {0}.

Explanation: An invalid value was encountered in the
Border property of a table.
User response: Ensure that any action that sets the
Border property of a table sets a valid value.
RPT30065

Unknown scrollBarStyle: {0}.

Embedded Scene: Unknown
scrollBarStyle.

Explanation: An invalid value was encountered in the
ScrollBarStyle property of an embedded scene object.
User response: Ensure that any action that sets the
ScrollBarStyle property of an embedded scene object
sets a valid value.

Explanation: An invalid value was encountered in the
ScrollBarStyle property of an object.

RPT30073

User response: Ensure that any action that sets the
ScrollBarStyle property of an object sets a valid value.

Explanation: An internal error occurred.

RPT30066

Unknown AlignmentStyle: {0}.

Explanation: An invalid value was encountered in the
AlignmentStyle property of a textbox object.
User response: Ensure that any action that sets the
AlignmentStyle property of a textbox object sets a valid
value.

Embedded Scene: unknown typeOfFind:
{0}.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30076

The cell chosen by client not found.

Explanation: The action can not be performed when
using the HTML rendering mode.
User response: Reload the visual project.

RPT30068

Unknown lineStylePattern: {0}.

Explanation: An invalid value was encountered in the
LineStylePattern property of an object.
User response: Ensure that any action that sets the
LineStylePattern property of an object sets a valid
value.
RPT30069

Unknown gradient type: {0}.

Explanation: An invalid value was encountered in the
GradientType property of an object.

RPT30077

Grid cell's click event could not be
dispatched.

Explanation: The action can not be performed when
using the HTML rendering mode.
User response: Reload the visual project.
RPT30079

Unknown page type - {0}.

Explanation: An internal error occurred.

User response: Ensure that any action that sets the
GradientType property of an object sets a valid value.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
service.

RPT30070

RPT30082

Unknown borderType: {0}.

Explanation: An invalid value was encountered in the
BorderType property of a textbox or embedded scene
object.
User response: Ensure that any action that sets the
BorderType property of a textbox or embedded scene
object sets a valid value.

Parameters group cloning problem {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30083

No class in map for {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
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RPT30088 • RPT30107
> Collect Support Data and forward it to customer
support.
RPT30088

Unable to serialize an object: {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30089

Value must be positive: {0}.

Explanation: The indicated value must be a positive
number.
User response: Ensure that the indicated value is a
positive number.

RPT30097

Explanation: An invalid value was specified for the
DateAxis property of an object.
User response: Ensure that any action that sets the
value of the DateAxis property of an object sets a valid
value.
RPT30098

Level was null when zoom was {0}.

Explanation: No level is specified for the indicated
zoom percentage.

Unhandled interval: {0}.

Explanation: An invalid value was specified for the
DateAxis property of an object.
User response: Ensure that any action that sets the
value of the DateAxis property of an object sets a valid
value.
RPT30099

RPT30090

Unknown interval: {0}.

Unknown dateInterval: {0}.

Explanation: An invalid value was specified for the
DateAxis property of an object.

User response: Ensure that a level is specified for the
indicated zoom percentage.

User response: Ensure that any action that sets the
value of the DateAxis property of an object sets a valid
value.

RPT30091

RPT30104

Chart can't find parent column: {0}.

Explanation: The indicated parent column could not
be found in the result set.
User response: Ensure that a valid column named is
specified in the DataLocator property of the group.
RPT30092

User response: Ensure that a valid column named is
specified in the DataLocator property of the group.
Hierarchy chart must have one
DataTemplate child.

Explanation: A hierarchy chart must have one
DataTemplate child.
User response: Check the Project Explorer and ensure
that the hierarchy chart only has one DataTemplate
child.
RPT30096

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

Chart can't find child column: {0}.

Explanation: The indicated child column could not be
found in the result set.

RPT30095

Shouldn't get here - roundIncrement: {0}
power: {1}.

RPT30105

Group name is undefined for group
header.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30106

Group name is undefined for group
footer.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

CurrentRowIndex < 0.

Explanation: The specified row index is less than zero.
The row index must be an integer that is equal to or
greater than zero.
User response: Ensure the specified row index is an
integer that is equal to or greater than zero.

RPT30107

m_templateRows contained a {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
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RPT30109 • RPT30127
RPT30109

Embedded Scene: Linked not found for
name {0}.

Explanation: The value of the LinkedScene property
of an embedded scene is invalid.
User response: Ensure that the scene that the
embedded scene is linked to exists and that the link
text is correct.
RPT30111

Unable to clone component {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response:
1. Check the global parameter name for errors or
specify a different global parameter.
2. Check the column name for errors or specify a
different column name.
RPT30121

Explanation: An invalid value was set for the
ResultSetIndex of a layout object.
User response: Ensure that any action that sets the
ResultSetIndex property of a layout object sets a valid
value.
RPT30122

RPT30112

Property {0} of component {1} doesn't
appear to be of type {2}.

Explanation: The property of the indicated object is of
an invalid type.
User response: Ensure that any action or expression
that sets the value of the property sets it to a valid
type.
Swing output cannot be created for
component {0}.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Select the query in the Repository
Explorer or Workspaces view and copy and paste the
key value from the Properties view, or specify a
different query's key.

Component {0} does not support action
{1}.

Explanation: The indicated component does not
support the indicated action.
User response: Specify a different action for the
component and try again.
RPT30118

Component {0} does not support
property {1}.

Explanation: The indicated component does not
support the indicated property.
User response: Specify a different property and try
again.
RPT30120

(Multiple possible messages; see Explanation)

Explanation:
1. The global parameter ''{0}'' does not exist - The
indicated global parameter does not exist.
2. Query ''{0}'' does not contain column named ''{1}'' The indicated column does not exist in the
indicated query.
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Component ''{0}'' cannot be created due
to the following problem: {1}

Explanation: The indicated component can not be
created due to the indicated error.
User response: Resolve the indicated error and try
again.
RPT30124

RPT30117

Query with key ''{0}'' does not exist.

Explanation: A query with the indicated key does not
exist in the repository.

RPT30123
RPT30114

Result set index ''{0}'' for query ''{1}'' is
out of bounds.

Result set index cannot be defined.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RPT30126

Security list ''{0}'' cannot be found.

Explanation: The indicated security list can not be
found.
User response: Check the security list name for errors
or specify a different security list.
RPT30127

Visual project ''{0}'' cannot be loaded
because of missing project descriptor.

Explanation: The indicated visual project can not be
loaded because it is missing a project descriptor.
User response: Ensure that the visual project has a
project descriptor and retry to load the project.

RSE01000 • RSE04017
RSE01000

{0}

Explanation: The indicated error occurred while
accessing the repository security provider.
User response: Resolve the indicated error and try
again.

RSE04008

Explanation: Access to the specified object is denied.
User response: Select a different object to access or
contact your administrator for more information.
RSE04011

RSE04000

System internal error occurred, please
check the error log.

Explanation: A system internal error occurred.
User response: Check the error log by selecting
Output from the context menu of the Window menu.
Cannot find User {0}

Explanation: The indicated user can not be found.
User response: Check the name of the user for errors
and try again.
RSE04002

User {0} already exists;

Explanation: The indicated user already exists.
User response: Specify a different user.
RSE04003

Group {0} already exists;

Explanation: The indicated group already exists.

Cannot remove User {0} from Group {1}

Explanation: The indicated user can not be removed
from the indicated group.
User response: Select another user to be removed
from the group.
RSE04012

RSE04001

Object access denied

Cannot delete User {0}

Explanation: The indicated user can not be deleted.
User response: Select another user to be deleted.
RSE04013

Cannot delete Group {0}

Explanation: The indicated group can not be deleted.
User response: Select another group to be deleted.
RSE04014

Cannot initialize security provider,{0}

Explanation: The indicated error occurred while
initializing the repository.

User response: Specify a different group.

User response: Resolve the indicated error and try
again.

RSE04004

RSE04015

Cannot find group {0}

Explanation: The indicated group can not be found.

This security provider is a read-only
one.

User response: Specify a different group.

Explanation: You can not change the principals of a
read-only security provider.

RSE04005

User response: Choose another security provider to
modify.

Not logged in with security provider.

Explanation: You attempted to access the repository
without logging in.

RSE04016

User response: Login to the repository and try again.
RSE04006

The user ID and password are invalid

Cannot find any name associates with
UID {0} in Repository

Explanation: The indicated repository identifier is
invalid.

Explanation: The user ID and password that were
entered are invalid.

User response: Specify a valid repository identifier
and try again.

User response: Check the user ID and password for
errors and try again.

RSE04017

RSE04007

Name "{0}" is in conflict with the
existing name.

Explanation: The new name that was entered already
exists.
User response: Select a different name.

AuthType is not
anonymous("none"),please specify
principal and credentials

Explanation: An error occurred while initializing the
LDAP security provider.
User response: Change the repository initialization
parameters and try again.
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RSE04018 • RSE04032
RSE04018

LDAP Configuration contains illegal
values or some required values are
missing, please check the
preferences({0})

Explanation: An error occurred while initializing the
LDAP security provider.
User response: Change the repository initialization
parameters and try again.
RSE04019

Cannot connect to the LDAP server.
Communication broken or Directory
Service is not available.

information concerning specific permissions and
allowances.
RSE04025

Cannot find a attribute of entry {0}
specified in LDAP configurations.

Explanation: An error occurred while reading
attribute data from the LDAP configuration.
User response: Correct the configuration parameters
and try again.
RSE04026

UUID {0} mapping to an invalid
distinguished name {1}.({2})

Explanation: An error occurred while connecting to
the LDAP directory.

Explanation: The indicated distinguished name is
invalid.

User response: Check the network connection and try
again.

User response: Specify a valid distinguished name
and try again.

RSE04020

RSE04028

Cannot read User's password attribute
(Make sure you have enough permission
or PasswordAttribute in configuration is
correct.)

Explanation: An error occurred while reading data
from the LDAP directory.
User response: Ensure that the LDAP service is
accessible.
RSE04021

Invalid search filter in LDAP
configuration

Incorrect operation.

Explanation: An error occurred while editing the
principals of the security provider.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
RSE04029

Cannot register security provider.

Explanation: An error occurred while registering the
security provider in the provider registry.

Explanation: The specified search filter in the LDAP
configuration is invalid.

User response: Ensure that the registered name of the
provider is unique.

User response: Specify a valid search filter for the
LDAP configuration.

RSE04030

RSE04022

Explanation: An error occurred while accessing the
security provider service because the service is not
initialized.

LDAP server returned error

Explanation: An error occurred while reading data
from the LDAP directory.
User response: Ensure that the LDAP service is
accessible.
RSE04023

Cannot find the specified name {0}

Explanation: The indicated user name can not be
found.

Security provider not initialized.

User response: Initialize the security provider and try
again.
RSE04031

Security provider not registered.

Explanation: An error occurred while accessing the
security provider because the security provider is not
registered.

User response: Specify a different user name.

User response: Register the security provider and try
again.

RSE04024

RSE04032

Not enough permission to perform the
LDAP operations.

You can not remove default
Administrator.

Explanation: You user ID does not have permission to
perform LDAP operations.

Explanation: The default administrator can not be
deleted.

User response: Contact your administrator for more

User response: Specify a different administrator to be
deleted.
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RSE04033

You can not change the default
Administrator's membership.

SPL01004

Cannot read the User's name (attribute:
{0})

Explanation: The membership of the default
administrator can not be changed.

Explanation: The LDAP directory does not contain an
object that has the required attribute.

User response: Specify the membership of a different
administrator to change.

User response: Edit the userName attribute so that it
will point to an existing object in the LDAP directory.

RSE04035

SPL01005

You can not rename the Administrators
group.

LDAP server host or port was not
specified.

Explanation: The group of the default administrator
can not be renamed.

Explanation: The LDAP server host or port was not
specified.

User response: Specify the group of a different
administrator to be renamed.

User response: Specify the LDAP server and host.
SPL01006

RSE04036

Password has expired and is no longer
valid.

Explanation: The specified password has expired and
is no longer valid.
User response: Specify an updated password and try
again.

The base distinguish name of the LDAP
server must be present.

Explanation: The base distinguished name of the
LDAP server was not specified.
User response: Specify the base distinguished name of
the LDAP server.

Group could not became its own parent.

SPL01007

The distinguish name of user principal
must be present.

Explanation: A group may not be its own parent. You
must select a different group as the parent.

Explanation: The distinguished name of the principal
user was not specified.

User response: Select a different group to be the
parent of the specified group.

User response: Specify the distinguished name of the
principal user or use anonymous authentication.

SPL01001

SPL01008

RSE04037

Cannot find objectClass attribute of {0}

The credentials of user entry must be
specified.

Explanation: The indicated object does not have an
objectClass attribute. Every object in the LDAP
directory must contain this attribute.

Explanation: The credentials of the entry user were
not specified.

User response: Specify an objectClass attribute for the
indicated object.

User response: Specify the credentials of the entry
user or use anonymous authentication.

SPL01002

SPL01009

The returned entry {0} is not acceptable
for LDAP Security Provider, its
objectClass is not {1} or {2}

Cannot create LDAP entry for
administrator user: {0}

Explanation: The indicated object is defined as neither
a user or group in the LDAP security provider.

Explanation: The user who is associated with the
administrative account could not be found in the LDAP
directory.

User response: Edit the objectClass attribute of the
indicated object to specify whether it is a user or group.

User response: Specify the administrative user of the
LDAP directory.

SPL01003

SPL01010

Cannot read the Group's name
(attribute: {0})

Explanation: The LDAP directory does not contain an
object that has the required attribute.
User response: Edit the groupName attribute so that it
will point to an existing object in the LDAP directory.

Cannot create LDAP entry for
administrators group: {0}

Explanation: The group that is associated with the
administrative account could not be found in the LDAP
directory.
User response: Specify the administrative group of the
LDAP directory.
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SPL01011

Cannot create LDAP entry for everyone
group: {0}

Explanation: The group that is associated with the
everyone account could not be found in the LDAP
directory.
User response: Specify the everyone group of the
LDAP directory.
SPL01012

Cannot create LDAP entry for root
group: {0}

SPL01101

Currently Client Authentication is not
supported.

Explanation: Client Authentication is not supported.
User response: Use anonymous authentication.
SPL01103

SSL is not correctly initialized.

Explanation: The secure socket protocol factory is not
initialized.
User response: Restart the application and try again.

Explanation: The object that is associated with the
Base DN could not be found in the LDAP directory.

SPL01104

User response: Specify the Base DN object in the
LDAP directory.

Explanation: The indicated attribute was not found
while reading the LDAP object.

SPL01013

User response: Specify a valid value for the indicated
attribute.

Cannot find the JNDI extension package
or Sun's LDAP Service Provider.

Explanation: The JNDI extension package or Sun's
LDAP Service Provider was not located in the
CLASSPATH.

SPL01105

Attribute {0} is absent.

Object class name ''{0}'' is unknown.

Explanation: The object name has an invalid class
name; it must be either qmfUser or qmfGroup.

User response: Ensure that the CLASSPATH includes
both the JNDI extension package and Sun's LDAP
Service Provider.

User response: Specify either qmfUser or qmfGroup
for the indicated object name.

SPL01014

SQM02001

The catalog object is missing.

Explanation: The catalog object is not set.
User response: Specify the catalog object and try
again.
SPL01015

An input/output error occurred while
processing package ''{0}''. {1}

Explanation: The indicated error occurred while
processing the indicated package.
User response: Resolve the indicated error and try
again.

Empty name is not allowed.

Explanation: No name was specified as an RDN.

SQM02002

User response: Specify a name as an RDN.

Explanation: The indicated error occurred while
processing the SQLJ customization.

SPL01016

User response: Resolve the indicated error and try
again.

Illegal RDN of security object
(offending string: ''{0}'')

Explanation: The RDN is invalid. The RDN must be
one or more LDAP components that are separated by
commas.
User response: Specify valid components for the RDN.
SPL01017

Unknown attribute name ''{0}'' in RDN.

Explanation: An unknown attribute name was
encountered while parsing the RDN.
User response: Check the attributes of the RDN for
errors.

SQM02003

Error in SQLJ customization: {0}

No SQLJ installed

Explanation: The SQLJ library could not be loaded.
User response: Add sqlj.zip to the driver definition.
SQM02004

An error occurred while retrieving
profile data for package ''{0}''. {1}

Explanation: The indicated error occurred while the
profile data for the indicated package was being
loaded.
User response: Resolve the indicated error and try
again.
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SQM02005

An error occurred while loading the
profile for package ''{0}''.

SQM02013

An error occurred while loading data for
package ''{0}''.

Explanation: The indicated error occurred while the
profile for the indicated package was being loaded.

Explanation: An error occurred while the data for the
indicated package was being loaded.

User response: Resolve the indicated error and try
again.

User response: Resolve the indicated error and try
again.

SQM02006

SQM02014

While loading the class with the
implementation of package ''{0}'' the
following error has occurred: ''{1}''.

Explanation: The indicated error occurred while class
with the implementation of the indicated package was
being loaded.

Wrong customizer call pattern: {0}

Explanation: Package customization failed because of
an unexpected error.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

User response: Reinstall the application and try again.
SQM02016
SQM02007

A database access error occurred while
processing package ''{0}''. {1}

Explanation: The indicated database access error
occurred while the package was being processed.
User response: Resolve the indicated database access
error and try again.

Explanation: The indicated collection could not be
created due to the indicated error.
User response: Resolve the indicated error and try
again.
SQM02017

SQM02008

Cannot create collection ''{0}'' due to the
following: {1}

A database access error occurred: {1}

Profile for package ''{0}'' is too long to
be stored at database

Explanation: The indicated database access error
occurred.

Explanation: The profile for the indicated package is
too long to be stored at the database.

User response: Resolve the indicated error and try
again.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

SQM02009

User has no rights to execute queries of
package ''{0}''. Original error follows: {1}

SQM02018

Explanation: The user does not have permission to
access the package because of the indicated reason.
User response: Contact your database administrator.
SQM02010

An error occurred while deleting profile
for package ''{0}''. {1}

Explanation: The indicated error occurred while the
profile for the indicated package was being deleted.
User response: Resolve the indicated error and try
again.
SQM02011

Empty customizer call pattern

Explanation: Package customization failed because of
an unexpected error.

No collection ID (profile owner) is
specified. Cannot proceed in static
mode.

Explanation: The SQLJ package can not be loaded if
no collection ID is specified.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
SQM02019

Cannot prepare statement ''{0}'' of
package ''{1}'' due to the following error:
''{2}''

Explanation: The indicated statement of the package
can not be prepared due to the indicated error.
User response: Resolve the indicated error and try
again.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
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SQM02020

While checking user rights on package
''{0}'' the following error has occurred:
''{1}''

Explanation: The indicated error occurred while the
user rights on the indicated package were checked.
User response: Resolve the indicated error and try
again.
SQM02021

Inconsistent profile data for queries
package ''{0}'' were detected. Rebind
package.

Explanation: Inconsistent profile data for the indicated
queries package was detected.
User response: Rebind the package.
SQM02100

The required parameter ''{0}'' is missing.

Explanation: The indicated required parameter is
missing.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.
SQM02101

An error occurred while initializing the
connection. {0}

SQM02105

Static mode profile for package ''{0}'' is
not found.

Explanation: The static mode for the indicated
package was not found.
User response: Reinstall the application and try again.
SQM02106

An error occurred while creating
directory ''{0}''.

Explanation: The temporary directory for the
customization process could not be created.
User response: Ensure that the application has
permissions to create the directory and try again.
SQM02107

An error occurred while creating
profiles directory ''{0}''.

Explanation: An error occurred while the indicated
profile's directory was created.
User response: Ensure that the application has
permissions to create the directory and try again.
SQM02108

An error occurred while saving the
profile for package ''{0}''. {1}

Explanation: The indicated error occurred while the
profile for the indicated package was saved.

Explanation: The indicated error occurred while the
connection was initialized.

User response: Resolve the error and try again.

User response: Resolve the indicated error and try
again.

SQM02109

SQM02102

Explanation: The indicated error occurred while the
package description file was saved.

{0}

An error occurred while saving the
packages description file. {0}

Explanation: The indicated database access error
occurred.

User response: Resolve the error and try again.

User response: Resolve the indicated error and try
again.

SQM02110

SQM02103

Explanation: The indicated error occurred while
customization was started.

An error occurred while loading
package description class ''{0}''. {1}

Explanation: The indicated error occurred while the
package description class was loaded.
User response: Resolve the indicated error and try
again.
SQM02104

An error occurred while loading the
profile for package ''{0}''. {1}

Explanation: The indicated error occurred while the
profile for the indicated package was loaded.
User response: Resolve the indicated error and try
again.
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An error occurred while starting
customization. {0}

User response: Resolve the error and try again.
SQM02111

An error occurred while customizing
package ''{0}''. {1}

Explanation: The indicated error occurred while the
indicated package was customized.
User response: Resolve the indicated error and try
again.

SQM02112 • SYNERRCD0008
SQM02112

An error occurred while creating the
profiles data table. {0}

Explanation: The indicated error occurred while the
data table of the profile was created.
User response: Resolve the indicated error and try
again.

User response: Resolve the indicated error and try
again.
SYNERRCD0001 DSS header length less than 6.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.

SQM02113

No user ID list for GRANT/REVOKE
operation was specified.

Explanation: No user ID list for GRANT/REVOKE
operation was specified.
User response: Specify a user ID list for the
GRANT/REVOKE operation.
SQM02115

An error occurred while uninstalling the
packages. {0}

Explanation: The indicated error occurred while the
packages were uninstalled.
User response: Resolve the indicated error and try
again.
SQM02116

File with packages description was not
found. {0}

Explanation: The indicated error occurred while
preparing the packages descriptions based on the
previously build packages description file.

SYNERRCD0002 DSS header length does not match
the number of bytes of data found.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
SYNERRCD0003 DSSheader C-byte not D0.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
SYNERRCD0004 DSS header f-bytes either not
recognized or not supported.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

SYNERRCD0005 DSS continuation specified but not
found.

SQM02117

User response: Send an error report to the developers.

An error occurred while reading the
packages description file. {0}

Explanation: An internal error in the driver code
occurred.

Explanation: The indicated error occurred while the
packages description file was being read.

SYNERRCD0006 DSS chaining specified but no DSS
found.

User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

Explanation: An internal error in the driver code
occurred.

SQM02119

An error occurred while installing the
package {0}. {1}

User response: Send an error report to the developers.
SYNERRCD0007 Object length less than four.

Explanation: The indicated error occurred when the
indicated package was being installed.

Explanation: An internal error in the driver code
occurred.

User response: Resolve the indicated error and try
again.

User response: Send an error report to the developers.

SQM02120

An error occurred while uninstalling the
package {0}. {1}

Explanation: The indicated error occurred when the
indicated package was being uninstalled.

SYNERRCD0008 Object length does not match the
number of bytes of data found.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
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SYNERRCD0009 • SYNERRCD0024
SYNERRCD0009 Object length greater than
maximum allowed.

SYNERRCD0017 Too few command data objects
sent.

Explanation: An internal error in the driver code
occurred.

Explanation: An internal error in the driver code
occurred.

User response: Send an error report to the developers.

User response: Send an error report to the developers.

SYNERCRD0010 Object length less than minimum
required.

SYNERRCD0018 Duplicate object present.

Explanation: An internal error in the driver code
occurred.

Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
SYNERRCD0019 Invalid request correlator specified.
SYNERRCD0011 Object length not allowed.
Explanation: An internal error in the driver code
occurred.

Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.

User response: Send an error report to the developers.
SYNERRCD0020 Required value not found.
SYNERRCD0012 Incorrect large object extended
length field.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
SYNERRCD0013 Object codepoint index not
supported.
Explanation: An internal error in the driver code
occurred.

Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
SYNERRCD0021 Reserved value not allowed.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.

User response: Send an error report to the developers.

SYNERRCD0022 DSS continuation less than or
equal to two.

SYNERRCD0014 Required object not found.

Explanation: An internal error in the driver code
occurred.

Explanation: An internal error in the driver code
occurred.

User response: Send an error report to the developers.

User response: Send an error report to the developers.
SYNERRCD0015 Too many command data objects
sent.
Explanation: An internal error in the driver code
occurred.

SYNERRCD0023 Objects not in required order.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.

User response: Send an error report to the developers.

SYNERRCD0024 DSS chaining bit not 1, but
DSSFMT bit 3 set to 1.

SYNERRCD0016 Mutually-exclusive objects present.

Explanation: An internal error in the driver code
occurred.

Explanation: An internal error in the driver code
occurred.

User response: Send an error report to the developers.

User response: Send an error report to the developers.
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SYNERRCD0025 Previous DSS indicated current
DSS has the same request correlator, but
the request correlators are not the same.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
SYNERRCD0026 Previous DSS indicated current
DSS has the same request correlator, but
the request correlators are not the same.
Explanation: An internal error in the driver code
occurred.

THM1002

Cannot extract main theme CSS file
from the archive.

Explanation: The specified archive does not contain
the main CSS file.
User response: Ensure that the main CSS file is saved
to the archive and try again.
THM1003

Already registered. Try another theme
name.

Explanation: A theme with the same name already
exists.
User response: Specify a different name for the theme.

User response: Send an error report to the developers.
THM1004
SYNERRCD0027 DSS chaining bit not 1, but error
continuation requested.
Explanation: An internal error in the driver code
occurred.

Theme root folder already exists. Try
another theme name.

Explanation: A theme with the same name already
exists.
User response: Specify a different name for the theme.

User response: Send an error report to the developers.
UIM12001
SYNERRCD0028 Mutually-exclusive parameter
values specified.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
SYNERRCD0029 Codepoint not valid command.
Explanation: An internal error in the driver code
occurred.

Internal error has occurred: {0}

Explanation: The indicated internal error occurred.
User response: Resolve the indicated error and try
again.
UIM12004

An input/output error occurred: {0}

Explanation: The indicated input/output error
occurred.
User response: Resolve the indicated error and try
again.

User response: Send an error report to the developers.
UIM12005
SYNERRCD0030 The atmind instance variable is not
set to its default value of 0x00 on an
EXCSQLSTT command within an
atomic EXCSQLSTT chain.
Explanation: An internal error in the driver code
occurred.
User response: Send an error report to the developers.
THM1001

Cannot copy CSS file.

Explanation: The CSS file could not be copied to the
server.
User response: Ensure that the CSS file name is
correct and try again.

The file does not exist: {0}

Explanation: The indicated file does not exist.
User response: Specify a valid file and try again.
VAL00001

Variable {0} not found.

Explanation: The indicated variable was not found.
User response: Specify a valid variable.
VAL00003

Type conversion error. Object of {0} type
cannot be converted to {1} type.

Explanation: The indicated object can not be
converted to the indicated type.
User response: Specify an object of a different type to
be converted, or convert the object to a different type.
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VAL00004

Unit conversion error. Unit {0} cannot be
converted to {1}.

VAL00019

Cycle has been found in definition of
following properties: {0}.

Explanation: The indicated unit can not be converted
to the indicated type.

Explanation: The expression contains a cyclic
reference.

User response: Specify a different unit to be
converted, or convert the unit to a different type.

User response: Edit the expression to remove the
cyclic reference and try again.

VAL00005

VAL00021

An expression contains a syntax error.

Explanation: An expression that you entered contains
a syntax error.
User response: Check the expressions that you typed
for syntax errors.

Explanation: The expression could not be evaluated.
User response: Check the expression for syntax errors
and try again.
VAL00022

VAL00006

Wrong expression has been used.

Explanation: An incorrect expression has been used.
User response: Specify a valid expression.
VAL00007

Name ''{0}'' has invalid character at {1}.
The name must start with a letter and
should not contain special characters.
See the help for a list of invalid
characters.

Explanation: The indicated name contains an invalid
character at the indicated column.
User response: Check the help for syntax rules and
retype the invalid character.
VAL00008

Name cannot be empty. The name must
start with a letter and should not
contain special characters. See the help
for a list of invalid characters.

Cannot evaluate properties: {0}.

Validation failed: Cannot set {0} to {1}.
Value must be {2} {3}.

Explanation: The property can not have the indicated
value. Possible values are listed in the error message.
User response: Edit the property's expression and try
again.
VDS1000

{0}

Explanation: The indicated error occurred while
processing the virtual data source.
User response: Resolve the indicated error and try
again.
VDS1001

Internal Error.

Explanation: An internal error occurred.
User response: Collect support data by selecting Help
> Collect Support Data and forward it to customer
support.

Explanation: The name of a control can not be empty.
User response: Specify a correct name for the control.
VAL00009

Unable to process URL: ''{0}''

VDS1002

No data source was specified for the
query.

Explanation: No data source was specified for the
query.

Explanation: The indicated URL could not be
processed.

User response: Specify a data source for the query.

User response: Check the URL for errors and try
again.

VDS1003

VAL00010

Unable to process URI: ''{0}''

Explanation: The indicated URI could not be
processed.
User response: Check the URI for errors and try
again.

Configuration directory is not defined.

Explanation: The configuration directory is not
defined.
User response: Define the configuration directory.
VDS1004

Source data source not found for virtual
table ''{0}''.

Explanation: The source data source for the indicated
virtual table was not found. It is possible that the
source data source has been moved or deleted.
User response: Check the location of the source data
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source and copy the source table to the virtual data
source again if necessary.
VDS1005

Table is not defined in the query.

Explanation: The table is not defined in the query.

VDS1011

Source table not found ''{0}''.

Explanation: The indicated source table was not
found. This may be because the source table was
moved or deleted.

User response: Define the table in the query.

User response: Check the location of the source table
and copy it to the virtual data source again if necessary.

VDS1006

VDS1012

Source table column not found for
virtual column ''{0}'' in the table ''{1}''.

Explanation: The indicated virtual column does not
match any of the source table columns.
User response: Ensure that every column in the
virtual table has a corresponding column in the source
table.

Explanation: The indicated source query was not
found. This may be because the source query was
moved or deleted.
User response: Check the location of the source query
and copy it to the virtual data source again if necessary.
VDS1013

VDS1007

Source query not found ''{0}''.

Only tables and queries can be added to
the virtual data source.

Only SQL queries with SELECT
statement can be used to create virtual
tables.

Explanation: You attempted to move an object that
was not a table or a query to the virtual data source.
Only tables and queries may be added to the virtual
data source.

Explanation: You attempted to create a virtual table
using a source query that does not contain a SELECT
statement. Only queries with SELECT statements can
be used as source queries.

User response: Specify a table or query to be moved
to the virtual data source.

User response: Specify a query that contains a
SELECT statement as a source query.

VDS1008

VDS1014

Cannot find specified tables in data
source.

Explanation: The tables that are referenced in the
virtual data source can not be found in the source data
source. This may be because the source tables were
moved or deleted.
User response: Check the location of the source tables
in the data source and copy them to the virtual data
source again if necessary.

Explanation: The virtual table sources a query that
returns a result set that has columns with identical
names.
User response: Change the result set column names in
the source query and try again.
VDS1015

VDS1009

Cannot remove the last column from
virtual table.

Explanation: You attempted to remove the last column
from the virtual table. A virtual table must have at least
one column.
User response: Ensure that the virtual table has at
least one column.
Only queries for relational data sources
can be added.

Explanation: You attempted to add a query from a
multidimensional data source. Only queries for
relational data sources can be added to virtual data
sources.

Virtual table cannot be created because
source query returns one or more
unnamed columns.

Explanation: The source table of a virtual table must
not return unnamed columns.
User response: Specify a source query that does not
return unnamed columns.
VDS1016

VDS1010

Virtual table cannot be created because
source query returns columns with
ambiguous names.

Virtual table cannot be created because
source query returns multiple result
sets.

Explanation: Virtual tables can only be created using
source tables that return single result sets.
User response: Specify a source table that returns a
single result set.

User response: Specify queries for relational data
sources to be added to the virtual data source.
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Notices
This information was developed for products and services offered in the U.S.A.
This material may be available from IBM in other languages. However, you may be
required to own a copy of the product or product version in that language in order
to access it.
IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user's responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.
IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not give you
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Glossary
The glossary provides brief descriptions of product terms.
accessibility. Features that help those with physical
disabilities, such as restricted mobility or limited vision,
use their computer.

Draw Query Editor. Use the Draw Query editor to
create a query object automatically based on the query
type and tables that you specify.

breakpoints. Color maps that specify the value at
which the color changes.

drilldown. A navigation feature that enables your
users to click an object and jump to another scene that
contains more information that relates specifically to
the original object's value. The Drilldown wizard is
available for all layout objects that can display query
result data.

calculated columns. Columns of data that you add to
the query results.
classic reports. Text-based, tabular reports that are
generated using query results as the data source and a
form template.
color map. A color map can be used to vary the color
of a visual project object depending on a value
associated with the object.
color sequence. A color sequence can be used to
modify the color properties of a visual project object
based on an index value.
command bar. An interface that allows you to run
procedure commands directly from the DataQuant for
Workstation interface.
connectivity tool. An interface that allows you to
define dependencies between non-query driven objects
such as text box objects and label objects. The
Connectivity tool is only available when creating visual
dashboards.
cube structure tree. In the layout format, the Cube
Structure tree lists the dimensions and measures that
are contained in the cube.
data sources. Data sources allow you to create virtual
tables that can be edited and manipulated by users
without altering the original tables' content. Virtual
data sources work by introducing a metadata layer
which mediates between an administrator-defined,
virtual data source and the underlying data sources
that contain the physical tables and views.
data templates. Data templates are used to create and
control the visual representation of query result set data
within layout objects.
Diagram Query Editor. When building queries using
the Diagram Query editor, you supply table, join,
column, sort, and row information and the Diagram
Query editor constructs the Structured Query Language
(SQL) statements. The Diagram Query editor is not
available in DataQuant for WebSphere.
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edit codes. Edit codes specify how to format character,
date, graphic, numeric, time and timestamp data that
will appear in a specific column of a report. You can
also create user-defined edit codes.
embedded scene. An embedded scene object is a
container through which you can view all or a portion
of another scene and then navigate to that scene. The
scene where you place the embedded scene object is
considered the source scene. The destination scene is
the embedded scene.
event actions. You define event actions to objects to
provide scene interactivity and navigation. As a user
navigates your dashboard, mouse actions trigger
predefined events, such as jumps between scenes,
executing of SQL statements, or the launching of other
applications.
Expression Designer. The Expression Designer is used
to specify any property value that is associated with a
selected object. The Expression Designer is an
alternative way of specifying an object's properties. For
each property that can be specified for an object, you
are given templates that can help you format the value
of that property. In addition, you have more space
available to work and view your property value (which
can grow quite large if expressions are used).
fast save. When saving your query results data using
a "fast save" method, all the processing occurs at the
database. There is no further passing of data between
the DataQuant interface and the database. The
DataQuant interface adds SQL to the original query, the
query is rerun and the data is saved directly into the
specified table(s). Saving query results data using the
"fast save" process significantly improves performance
when a large amount of data is to be saved.
file-based repositories. If you are using DataQuant
for Workstation, you can create a file repository
connection to set up the information that enables you
to connect to a file-based repository that is stored on a

225

local or network drive. File connections can only be
created for legacy, file-based repositories.
formatting options. You can customize how the query
results will appear in the editor window. You can
specify different fonts, colors and text alignments for
each column heading and each cell of the column. You
can also specify that column and cell formatting be
applied based on the results of a conditional
expression. You can apply formatting options to entire
columns, individual cells, column headings, and
summary cells.
forms. Forms are considered objects and they can be
saved in your repository, in the QMF catalog, or in a
file. When you open a form object that has been saved,
you are actually running the form object to generate the
report. When opened, forms automatically use the
currently active query results as the data source.
form variables. Form variables are codes that you can
insert into text fields to produce information on the
report. For example, you can insert a date variable to
produce the current date whenever the report is
printed.
global parameter. A global parameter is available to
your entire visual project and to the user of your visual
dashboard. You can pass global parameters when you
specify object properties or when you create event
actions. You also have the option of making global
parameters public at run time so they are accessible to
the user.
global resources. Global resources can be used by all
the pages of a visual report or all the scenes of a visual
dashboard. You can use global resources for computing
object properties.
global variables. Global variables are variables that
stay active while the current session of DataQuant is
active. This is in contrast to substitution variables that
are active only during the execution of an object (query,
procedure, form). For objects that use global variables,
the value currently defined for the global variable is
used.
grouping and aggregation. Grouping and aggregation
options can be applied to query result columns to
organize the result data into logical or summarized
groupings. By adding grouping and aggregation you
can automatically obtain summary information about
your data and display the data more logically. For
example you can roll up data in a report by
department or average departmental commissions.
information zooming. Information zooming is a
navigation feature that presents a more detailed view
of data as your user zooms in on a scene or a data
point in a layout. Every layout object and scene has a
default zoom level (100% zoom). You can set up
information zooming navigation for whole scenes and
for individual layout objects. Information zooming on
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the layout object allows you to provide more query
information on each data point as the user zooms in on
a layout object. You use the same query results data for
each zoom level. Information zooming on the scene
level allows you to display an entirely different layout
and query results data for each zoom level.
JDBC drivers. DataQuant uses JDBC to connect to all
database repositories and data sources. DataQuant does
not include JDBC drivers. The location of the JDBC
drivers that DataQuant will use to connect to
repositories and data sources must be defined.
DataQuant administrators are responsible for
identifying where each instance of the application
interface will find the JDBC drivers.
job definition files. Job definition files (.jdfx) are
legacy DataQuant files that can be imported to set up
scheduled jobs.
job scheduler. DataQuant has the ability to schedule a
procedure object to be executed on a periodic, recurring
basis or at a specific date and time. A DataQuant
procedure can perform one or more sequential steps,
such as run queries, apply report templates, export
reports to PDF files, or send reports using email. You
can schedule your procedure to run at any given time
using your local scheduler or the DataQuant for
WebSphere scheduler.
layout objects. In a visual dashboard scene, layout
objects are used to display query results in visual
formats, such as charts, graphs, maps, tables and grids.
For most layout objects, you display the results of
multiple queries in a single layout. For example, you
could create a single XY chart that displays sales
figures derived from one query and spending figures
derived from another query. You can nest multiple
layout objects. When you nest layout objects, you can
pass query result information from a higher level
layout object to a lower level layout object. Because you
have the ability to pass this information, you can use
nested layout objects to display more detailed
information that relates to a specific data value.
Layout Properties dialog. An interface that allows you
to set all the options that are available for formatting
query results. The Layout Properties dialog uses a tree
structure to represent the columns in the query results.
Depending on what you have selected in the query
results, the Layout Properties tree displays branches for
all columns in the query results or for a single column
in the query results. You can apply formatting options
to entire columns, individual cells, column headings,
and summary cells.
Legacy Visionary world. You can create a new
dashboard from an existing Visionary world that was
created using a previous version of QMF Visionary. The
Visionary world that you import must have been
exported as an XML file using QMF for Visionary
Version 8.1, Fix Pack 13 or later.

LOB data. A large object (LOB) is a DB2 for z/OS and
DB2 for Linux, UNIX®, and Windows data type that
houses nontraditional data such as text, multimedia,
image, video, photograph, sound, or any very large
data file inside a database table. Retrieving or saving
LOB data can consume a substantial amount of
resources.
network repositories. A connection to a shared
repository using direct network access. Network
connectivity permits users to access a shared repository
without the need for direct database connectivity from
the workstation. Connecting to repositories using a
network connection allows for consolidation of data
access at a central server and removes the need to
distribute JDBC drivers across each desktop running
DataQuant for Workstation. This type of connection is
not applicable to DataQuant for WebSphere users.
OLAP queries. OLAP queries enable users to
dynamically access different dimensions of
multidimensional data. Using DataQuant for
Workstation and DataQuant for WebSphere you can
create an OLAP query for multidimensional data
sources that is queried using MDX and accessed using
XMLA.
palette objects. From the Palette view, you can insert
any graphical object that is listed into your visual
project. All objects from the Palette view can be
inserted in a visual dashboard. Not all objects available
from the Palette view can be inserted in a visual report.
The objects that cannot be inserted in a visual report
have interactive properties, and visual reports are not
interactive.
personal repositories. Personal repositories serve a
single user and are stored in the personnel settings
directory of the workstation (server) that is running the
DataQuant application interface.
perspectives. An interface used for querying data and
formatting results.
procedures. A set of commands that enable you to run
queries, print reports, import and export data, as well
as perform other functions.
Project Explorer view. The Project Explorer view
details in a tree structural all the elements and objects
of each visual report and each dashboard.
Prompted Query editor. An interface that allows you
to build simple to complex queries. The Prompted
Query editor prompts you for the information it needs
to build the SQL statement. You can also set sort and
row conditions using the Prompted Query editor.
(DataQuant for Workstation only)
QMF catalogs. A set of database tables that contain
saved objects (queries, procedures and forms); user
resource limits and profiles; reports; and other

miscellaneous settings and information. QMF catalogs
reside on database servers that host a DB2 database.
Query Editor. An interface that allows you to open
any database table that is accessible to you in your
workspace.
query parameters. Query parameters contain the
value that will be sent to the query and used at run
time.
regular save. When saving your query results data
using a "regular save" method, the interface that you
are using (DataQuant for Workstation or DataQuant for
WebSphere) saves the retrieved query results to the
database using an individual SQL INSERT statement
for each row of data. This type of save can be
expensive in terms of performance due to the overhead
of passing large amounts of data back to the database.
relational query. A query is a request for information
from a data source. To request information from a
relational data source your query is constructed using
SQL statements.
resource limits. DataQuant resource limits control
your data source access and resource consumption. You
must be connected to the data source in order to view
the resource limits that are in effect for your user ID
when you access that data source.
scene parameters. A parameter that is available only
to a specific scene in a visual dashboard. You can pass
scene parameters when you create embedded scenes
and event actions.
scheduled jobs. You can schedule your procedure to
run at any given time using your local scheduler or the
DataQuant for WebSphere scheduler. Procedures that
have been scheduled to run at another time are referred
to as scheduled jobs.
shared repositories. Shared repositories are located on
a database and can be shared by many users. Only
DataQuant administrators can create shared
repositories.
SQL Query editor. For those with SQL experience,
one way of creating a query is to type their own SQL
statements in the SQL Query editor. You can write a
single SQL statement that will return a single result set
or multiple SQL statements that will return multiple
result sets. The editor provides coloring support for
your SQL statements.
static SQL packages. Several tables in repository
storage are used by DataQuant to store processing
information. Some of these tables store sensitive
information, for example the permissions table. By
default all users can access these repository storage
tables and make changes to the tables. You can choose
to protect the repository storage tables. In protection
mode, the repository storage tables are accessed using a
Glossary
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collection of stored procedures or static SQL packages
depending on what the database that is hosting the
repository storage supports. Users of the repository
storage must then be granted permission to run the
stored procedures or static SQL packages.
substitution variables. Substitution variables are used
to enter changing values to a SQL query at run time.
This feature enables you to substitute a part of an SQL
statement and make it more generic. Substitution
variables are active only while the object (query,
procedure or form) is running. As a result, only one
object can access the substitution variable. The variable
will not exist after the object is executed.
Table Editor. An interface that allows you to open any
database table that is accessible to you in your
workspace.
Table Viewer. An interface that allows you to open
any database table that is accessible to you in your
workspace.
translation tables. Translation tables enable dashboard
designers to publish a single visual dashboard that may
be viewed in multiple languages. When content
developers create a dashboard, button captions, labels,
tool tips and other embedded text is entered directly
into the property values of the dashboard objects.
Using translation tables, content developers can supply
alternate versions of this entered text, to be displayed
when the user is in a different locale. For example, a
Japanese developer may elect to author a new
dashboard in Japanese but then also include translation
tables for German and French, each of which will be
used when the dashboard is viewed under German and
French locales.
usage codes. Usage codes provide summary
information about the data in a column. For example,
usage codes can provide total summary information at
the end of a column, or partial summaries at control
breaks in a table. The usage codes available depend on
the data in the column and the type of summary.
user preferences. The Preferences dialog is used to set
user preferences that will apply to specific functions in
the current DataQuant application interface session.
The Preferences dialog consists of two panes. The left
pane displays a hierarchical tree to organize the
preferences and the right pane displays the pages of
actual preference values.
variables bar. You can use the Variables bar to specify
a property value. The Variables bar is located in the
menu bar. From the Variables bar you can choose a
global or local parameter that has been defined for the
visual project and a column name from a set of query
results.
views. DataQuant views support editors and provide
alternative presentations as well as ways to navigate
the information in your window. Each view displays as
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a pane in the main workstation window. Each
perspective of DataQuant initially displays the views
that are most commonly used to perform specific
functions.
visual dashboards. Visual dashboards present
interactive or persistent data obtained from querying
multiple heterogeneous data sources across the
enterprise. Visual dashboards present data in a scene
format using a wide variety of graphics including
charts, graphs, maps and user interface widgets. Data
driven graphical objects can be easily linked so that
user selections will trigger unique data displays.
Content developers can create a visual dashboard that
can be viewed by multiple users with either DataQuant
for Workstation or DataQuant for WebSphere.
visual designer. You can quickly design visual reports
and dashboards using the intuitive Visual Designer
perspective that includes an editor that presents both
design and runtime views of the project; the Project
Explorer view which details the structural content of
each visual report and each dashboard; and the Palette,
Properties, Events and Output views which support the
Visual Designer editor and assist in creating visual
reports and dashboards.
visual reports. Visual reports are page-based, printable
reports that include both formatted text and graphics to
display persistent data to a wide variety of users.
Visual reports can also contain data driven graphics
(such as maps and charts) inserted in different sections
(such as the headers or footers) of the report. Each of
the data driven graphics can present data from multiple
queries that are run across the enterprise.
web service repositories. You create a Web service
repository connection to set up the information that
enables you to connect to a shared repository through
DataQuant for WebSphere web services API using a
HTTP or HTTPS connection. Web-based connectivity
permits users to access a shared repository without the
need for direct database connectivity from the
workstation. Connecting to repositories using a
web-based connection allows for consolidation of data
access at a central server and removes the need to
distribute JDBC drivers across each desktop running
DataQuant for Workstation. This type of connection
does not apply to DataQuant for WebSphere.
workspaces. All of the data sources and objects that
you can access are contained in one or more
workspaces that have been pre-populated for you by
the DataQuant administrator. Each workspace to which
you have access is listed in the Workspaces view. From
the Workspaces view, you can perform the majority of
query and reporting functions.
zoom. If you are using DataQuant for Workstation,
you can use the Zoom option to view in hexadecimal
or binary the contents of a cell in the query results.
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