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Revision Log 
Date  Revision 

Added information about accessing FileNet documentation and contacting customer 
support to "About This Document." 

01/06/2009 

Made various changes to meet IBM documentation requirements. 

11/03/2008 Added the following notes under Set Content Engine Security to clarify the topic: 

NOTE LDAP role groups refer to the LDAP groups that correspond to BPF 
Metastore roles. 

NOTE Restart the content engine application server after applying following 
permissions on BPF specific classes and objects. 

ecmdb00677566 / PJ35212 - Removed "Miscellaneous > Inbasket Filters > Priority" 
configuration note for Oracle: no need to edit this setting anymore for Oracle 
implementations using the Case Management Sample Application manifest since 
the default value works correctly with Oracle. 

ecmdb00662027 / PJ35211 - Added the following note to the Upgrade BPF section:

NOTE It is possible for BPF-3.5.2 and BPF-3.6.0 instances to share the same 
instance of AE/Workplace as long as the following considerations are kept in mind: 

• Access Roles are always read from the Application OS (the objectstore 
defined in BPF Explorer). 

• The combination of ObjectStore name in BPF Explorer and the Workplace 
preference name should be unique. If say you have created Workplace36 
preference for BPF3.6 application with OS36 and Workplace352 preference 
for BPF3.5.2 application with OS352 (with access roles created in both the 
objectstores), using the Workplace36 preference name for BPF3.5.2 and 
vice versa makes the application fail to logon with error "You are not 
assigned to any Roles". 

• The ObjectStore name in bootstrap and BPF Explorer could be different in 
case of BPF 3.5.2 application but it should be same for BPF 3.6 application.

ecmdb00553451 / PJ35210 - Changed step 10 of the upgrade procedures to 
handle a known issue with upgrading from BPF 3.5.2. 

Old step 10: 

Import BPF manifest. To import case management manifest or metastore manifest 
exported in previous steps, see Import BPF Manifest. 

New step 10: 

If you are upgrading BPF 3.5.2 to BPF 3.6, the BPF Site Designer role needs to be 
defined. To enable Layout Designer, you must manually create a BPF Site 
Designer role and assign a user to that role in BPF Explorer. Refer to the IBM 
FileNet Business Process Framework Web Application User Interface Guide for 
more information about Layout Designer. 

10/31/2008 

ecmdb00387310 / PJ35209 - Changed screenshot and added the following note to 
the sections for setting for CredentialsProtection/UserToken in the 
WcmApiConfig.properties files in both AE and BPF: 
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Date  Revision 
NOTE Setting Clear encoding for CredentialsProtection/UserToken results in 
nuisance logins from AE/Workplace and should be avoided.  For practical 
purposes, Symmetric encoding should be used under all circumstances. 

ecmdb00371646 / PJ35208 - Added a note to the section for BPF Deployment > 
Deploy BPF Web Application > IBM WebSphere 6.0: 
 
NOTE Do NOT change the class loader mode from the default PARENT_FIRST 
setting.  Changing this to PARENT_LAST prevents BPF from working. 
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About This Document 
This document defines the procedures to perform an installation or upgrade of IBM® FileNet® 
Business Process Framework (BPF).  

BPF is built on the FileNet P8 Platform and leverages the latest in Web technology. BPF provides 
rapid development of process-driven applications that enable Web browser access for process 
participants. The BPF Web Application is data driven and configurable using the BPF Explorer. 

BPF is geared towards customers with the following requirements: 

• Case management workflow processes 

• Integration with the external systems 

• Role based work distribution and work management requirements 

• Push and pull mode of work distribution 

BPF utilizes other more foundational products from the FileNet P8 Platform product suite. These 
other products do not specifically focus on the requirements listed above, and oftentimes cannot 
satisfy unique user interface needs using out-of-the-box functionality the way BPF can. The intent is 
to allow customers to quickly deploy workflow solutions at a lower cost by minimizing the needed 
customization effort. 

BPF Installation/Upgrade Overview 

Installation 
The BPF Installation process is designed to copy or create the necessary BPF foundational 
components on a system that has already been installed with base FileNet products. The following 
FileNet products must be installed and operational before the BPF installation is started: 

• FileNet Content Manager 

• FileNet Business Process Manager 

• FileNet Workplace (Application Engine) 

• FileNet eForms Manager (optionally, if eForms integration from BPF is to be used) 

NOTE Steps to integration eForms with BPF are not included in this document and are not 
part of the standard BPF Installation Package implementation. For information on how to 
perform this configuration see the document entitled eForms Integration to BPF. 

At a high level, a typical BPF Installation process performs the following basic activities to deliver all 
the components needed for BPF use: 

• Copies the BPF Explorer configuration tool to the Web application server  

• Copies the BPF Web Application to the Web application server 

• Creates the BPF Meta database tables needed to support BPF 

• Configures the FileNet Content Engine (CE), Process Engine (PE), and Application Engine 
(AE) environment with BPF 

• Copies a set of sample application configuration files (Case Management Sample) into the 
FileNet environment, if desired. 
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Installation versus Deployment 
BPF is an application framework, which is used as a starting point to create custom Business Process 
Management applications through both configuration settings and by optionally adding code 
extensions. For most sites, the development system is the first environment where a BPF installation 
is performed. The typical BPF installation process is used to establish a copy of BPF for development 
purposes. The Case Management Sample Application is typically also installed, providing a working 
sample BPF application in which to test all BPF functionality for installation signoff.  

On the development system, whoever is developing the BPF custom application changes 
configuration files and possibly adds code extensions to create a site-specific BPF Web Application. 

For other environments (used for such activities as Unit Testing, User Acceptance Testing, 
Deployment Staging, Production, and so on), you should discuss with the customer whether a typical 
BPF installation is appropriate or if these environments have the completed BPF application deployed 
to them in a different manner than a typical BPF Installation. Some customers have a very specific 
process for staging and deploying web applications in their enterprise, and there might have to be 
some further consultation to help them plan how to deploy a BPF-based application per their process. 
Other customers without a deployment management process can have BPF installed into subsequent 
environments and then move the site-specific configuration and code extension files to the new 
environment manually. For more information on migrating BPF related configuration files between 
systems, see the BPF Explorer Handbook section entitled “Saving/Moving BPF Applications”. 

Upgrade 
The definition of a BPF upgrade in the context of this document refers to re-installing a more recent 
release of BPF software while preserving all site-specific configuration files in the environment being 
upgraded. Depending on the versions of BPF being upgraded from/to, the Upgrade instructions might 
also reference steps that alter data structures that have changed between versions. Refer to the 
Upgrade section of this manual for instructions to upgrade BPF.  

Typographical Conventions 
This document uses the conventions in the following table to distinguish elements of text. 

Convention  Usage 

UPPERCASE Environment variables, status codes, utility 
names. 

Bold Paths and file names, program names, clickable 
user-interface elements (such as buttons), and 
selected terms such as command parameters or 
environment variables that require emphasis. 

Italic User-supplied variables and new terms 
introduced in text 

<italic> User-supplied variables that replace everything 
between and including the angle bracket 
delimiters (< and >). 

Monospace Code samples, examples, display text, and error 
messages. 
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Access IBM FileNet documentation, compatibility matrices, and fix 
packs 
To access documentation, compatibility matrices, and fix packs for IBM FileNet products: 

1. Navigate to the Product Documentation for FileNet P8 Platform support page:  

(http://www.ibm.com/support/docview.wss?rs=3247&uid=swg27010422). 

2. Select a PDF or a Doc Link, whichever is appropriate. 

Customer support 
For information about contacting customer support: 

1. Navigate to the FileNet Product Family support page: 

(http://www.ibm.com/software/data/content-management/filenet-product-family/support.html). 

2. Click IBM FileNet Support Communications, or search for a particular support topic under 
“Enter search terms”. 

Feedback 
Your feedback helps us to provide quality information. Send your comments about this publication or 
any other IBM FileNet documentation by e-mail to comments@us.ibm.com. Be sure to include the 
name of the product, the version number of the product, and the name and part number of the book 
(if applicable). If you are commenting on specific text, include the location of the text (for example, a 
chapter and section title, a table number, a page number, or a help topic title). 

Plan the Installation 
Before you begin to install BPF: 

• Ensure that you have a fully installed and operational FileNet P8 Platform environment 
including Content Engine, Process Engine, Application Engine, and, optionally, eForms.  

• Retrieve updates to FileNet P8 documentation and software. To download the documents 
and updates from the IBM support page, see Access IBM FileNet Documentation, 
Compatibility Matrices, and Fix Packs.  

• Review the IBM FileNet Business Process Framework Hardware and Software Requirements 
Guide for information about BPF requirements that differ from FileNet P8 Platform 
requirements.  

• Review the IBM FileNet Business Process Framework Release Notes for known issues and 
limitations and to check for fix packs to be applied.  

• Review Installation Planning Considerations for a list of auxiliary information you might need 
to gather and a list of tasks you should perform before installing FileNet BPF. In addition, 
complete the following worksheets included in the this section:  

o BPF Prerequisite Worksheet 

o Platform Prerequisite Worksheet 

• Read through all steps in this document to become familiar with the tasks you must perform 
when installing BPF. 

http://www.ibm.com/support/docview.wss?rs=3247&uid=swg27010422
http://www.ibm.com/software/data/content-management/filenet-product-family/support.html
mailto:comments@us.ibm.com
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Installation Planning Considerations 
Customer Liaison 
Every installation requires a designated person from the customer site to act as a liaison to the 
service representative that is installing BPF. At a minimum, the liaison assists the service 
representative by responding to requests for information and facilitating work requests to other 
departments or groups. For example, the liaison facilitates LDAP account setup requests, DBA 
requests, and so on. 

The customer liaison should know or be aware of customer procedures for  

• Creating LDAP groups/users  

• Submitting database creation/manipulation requests  

• Allocating servers  

• Logging on to and running FileNet Workplace  

• Logging on to and running the Web Application console  

• Submitting IT requests to provide Internet access for downloads, and so on  

BPF Prerequisite Worksheet 
The following BPF Prerequisite Worksheet is a critical step in preparing for your BPF installation. The 
worksheet lists the main servers involved in the BPF installation and provides space to enter the 
collected information, which is necessary to complete the installation. In some cases, these servers 
might be one and the same; for example, the BPF Admin Workstation and the CE Server might be on 
the same server. 

Some of the prerequisite fields on the worksheet can be collected prior to the start of the installation, 
and other information is determined and noted on the worksheet as you perform the installation. 
Review all of the fields, and fill in as much as possible in advance. 

The goal of the worksheet is to have a complete and accurate set of site parameters when you are 
finished with the installation. This completed worksheet should be left with the customer and is a 
valuable reference when configuration issues or questions arise, or as a reference when performing 
future BPF installations or upgrades.  

References in this document to a BPF Prerequisite Worksheet field are shown like this: {item}. These 
items are referenced as part of the BPF installation procedure. 

The worksheet is arranged in the following manner:  Server function is in the title row and additional 
information associated with that server follows. 
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AE Server 
Server for the FileNet Application Engine. 

 Web Application Service Type/Version 
(example: WebLogic 8.1 SP2) 

 

 Operating System Type/Version  

 FileNet P8 Platform Release Version  

 Client Browser Type/Version  

 BPF Release Version  
Release number for the BPF release to be installed. 

 

 Machine Usage 
Production, QA, Development, and so on. 

 

 BPF Media Staging Folder {staging folder}  

 Machine Name {web application server}  

 Workplace URL {workplace url}  

 AE to PE Router Name {ae pe router name} 
Name of router running on AE server that connects to the PE. 

 

 BPF Installation Home {install.home} 
Home folder path for wfutil and BPF Operations. Folder created 
during BPF deployment. 

Environment Property: Build - install.home 

 

 Web Application Name {web application name} 
(example: bpf) 

 

 BPF Port Number {web port} 
Port number for the BPF Web Application.  
NOTE Consult your Web Application service for the correct port 
number. 

 

BPF Admin Workstation 
Administration workstation for the BPF Explorer application. This 
application is the utility for modifying the BPF meta database (BPF 
configuration). 

 

  Machine Name {bpf admin workstation}  

  Operating System Type/Version  

  Machine Usage 
Production, QA, Development, and so on. 

 

BPF Metadata Server 
Server for the BPF Metastore relational database. 

 

  Machine Name {meta data server}  

  Operating System Type/Version  
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  Database Type/Version  

  Machine Usage 
Production, QA, Development, and so on 

 

 Database Administrative User {meta admin user} 
Database Administrative Password {meta admin password} 
An administrator account needed to access the Metastore 
Provider. 
For more information on this user account in both Oracle and 
SQL Server, see below under Database Security 
Considerations. 

 

 Metastore User {meta user} 
Metastore Password {meta password} 
The account created for read/write access to the BPF Metastore 
database.  The BPF metastore creation scripts create this user 
and grant privileges. 
For more information on this user account in both Oracle and 
SQL Server, see below under Database Security 
Considerations. 

 

 For Oracle implementation: 
  Database System ID {meta database sid} 
For SQL implementation: 
  Database Name {meta database} 

 

 {meta datasource} 
Suggested name: Bp8MetadataDS. 

 

 {meta data server}  

 {meta connection pool}  

 {class path}  

 {meta authentication name} 
Suggested name: Bp8MetaAlias. 

 

CE Server 
Server for the Content Engine. 

 

 Machine Name {ce server}  

 Operating System Type/Version  

 Database Type/Version  

 FileNet P8 Platform Version  

 Machine Usage 
Production, QA, Development, and so on. 
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 Object Store Display Name {os display name} 
Name of BPF object store in CE.  Optionally use an existing 
object store, or create a new one using the FileNet P8 Platform 
Enterprise Manager (EM). Refer to the FileNet P8 Platform 
documentation for the creation procedure details. Suggested 
object store name: BPF Object Store.  

 

 Object Store Symbolic Name {os symbolic name} 
Symbolic name of BPF object store in CE.  

 

 Administrative User {ce admin user} 
An account with CE administrator privileges for upgrading 
existing CE objects. 

 

 Administrative Password {ce admin password} 
Password for {ce admin user} 

 

PE Data Server 
Server for the Process Engine database. 

 

  Machine Name {pe data server}  

 Operating System Type/Version  

 Database Type/Version  

 Machine Usage 
Production, QA, Development, and so on. 

 

 Database Name {pe database} 
Database used by PE. Database name can be determined by 
looking at Image Services System Configuration Editor 
(..\fnsw\bin\fn_edit.exe) on the Relational Databases 
tab and RDB Objects sub-tab. Look at the location for object 
db_name or fn_data; possibly named indexdb. 

 

 For Oracle implementation: 
  Database System ID {pe database sid} 
For SQL implementation 
  Database Name {pe database}. 

 

 Process Engine User {pe user} 
Process Engine Password {pe password} 
Oracle:  
System privileges needed: CREATE SESSION.   
Object privileges needed: SELECT on all F_SW schema tables, 
SELECT on all F_SW schema views. 
SQL Server:  
Roles needed: Public and db_datareader  

 

 {pe router url}  

 {pe connection pool}  
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 {pe datasource}  

 {pe class path}  

 {pe authentication name} 
Suggested name: Bp8PEAlias. 

 

PE Server 
Server for the Process Engine. 

 

 Machine Name  

 Operating System Type/Version  

 FileNet P8 Platform Version  

 Machine Usage 
Production, QA, Development, and so on. 

 

 Administrative User {pe admin user} 
An account with PE administrator privileges for upgrading the 
workflow map. 

 

 Administrative Password {pe admin password} 
Password for {pe admin user}. 

 

 

Platform Prerequisite Worksheet 

General Work Conditions 

Single customer resource designated to assist the service 
representative installing BPF. Enter name and contact 
info. 

 

Able to work from single work machine and remotely 
access servers. Remote access can be accomplished by 
using tools such as VNC and PC Anywhere. Enter access 
details. 

 

Electrical outlets available next to work machine. Used for 
laptop, cell phone charging, and so on. 

 

Land line (phone) available next to work machine.  

Able to access Internet from server on customer network. 
Internet access used for the following purposes: 

• Download BPF installation package and fix packs 

• Access e-mail 

 

Able to create folders on Internet server. Used for storing 
downloaded material. Enter folder location. 

 

Able to transfer files from designated Internet server to AE 
and CE server. Enter method. 

 

FileNet P8 Platform Function and Access 
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Object store to be used by BPF can be browsed from 
Workplace without error. Confirm CE is working. 

  

Workplace Tasks can be accessed without error. Confirm 
CE is working. 

 

P8 Workplace administrator access sufficient for 
accessing the following: 

• Admin > Site Preferences > General 

• Admin > Site Preferences > Bootstrap 

• Admin > Site Preferences > Access Roles 

• Admin > Site Preferences > Refresh 

• Admin > Process Configuration Console 

• Author > Advanced Tools > Search Designer 

• Author > Advanced Tools > Process Designer 

 

Process Task Manager on AE server can be run. Might be 
on Start menu (if on Windows®), but is usually run from 
FileNet/Router directory. 

 

Database Access 

DBA access for creating new database.  
Scripts need to be adjusted and run for creating BPF 
Metastore database. This is a generally static database 
used for storing BPF configuration information. 

 

DBA access to PE database. 
A new user needs to be created for read-only access to 
the PE database. Also, in some cases, some views might 
be needed to be re-created to work around a case 
sensitivity issue (Oracle only). 

 

LDAP Access 

New LDAP groups might need to be created.  

New LDAP users might need to be created.  

CE Access 

Able to run Enterprise Manager.  

Able to set security on CE objects.  

Able to reboot CE server.  
Rebooting might be needed in some cases to resolve 
problems. 

 

AE Access 

Able to logon to Web Application service administrator 
console. 
NOTE The BPF Web Application needs to be installed on 
the same machine where Workplace is installed. 
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Able to create JDBC DataSources.  

Able to restart BPF Web Application.  

Able to restart Web Application service.  

Able to reboot AE server. 
Rebooting might be needed in some cases to resolve 
problems. 

 

Misc. 

Need to have file privileges for installing BPF Explorer.  
(Installed using InstallShield setup. Can be installed on 
any machine with ODBC access to BPF Metastore.) 

 

Ability to remove carriage returns (^M) in various text files 
on non-Windows machines. 
Depending on the UNIX® platform, use any appropriate 
utility like dos2unix or dos2aix. 

 

Ability to edit text files, including XML files. 
On UNIX machines, the capability to validate an XML file 
is necessary. This can be accomplished using Netscape 
Navigator on UNIX servers. 
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Database Security Considerations 
This section is devoted primarily to clarifying the difference between the BPF {meta admin user} and 
the BPF {meta user} RDBMS accounts as referenced in the Prerequisite Worksheet below. 

The BPF install process requires two different RDMBS user accounts as described in the following 
paragraphs. 

The {meta admin user} is an administrator account needed to access the Metastore Provider 
normally during database creation only. 
 

Oracle: The SYSDBA privilege is required to create new database (assuming the BPF tablespaces 
are to be located in a new database).  Roles needed: DBA.  NOTE In many cases, it is necessary to 
ask a DBA who has access to an account with these privileges to perform the tasks of the {meta 
admin user} for you during the course of the install.  Many companies do not divulge the passwords 
for accounts with this level of privilege to installation personnel.  In such circumstances, consult with 
the customer and have one of their DBAs run these scripts for you using any account they like (as 
long as it has the DBA Role with the SYSDBA Privilege as indicated above).  See above under 
Customer Liaison. 

SQL Server: System Administrators server role. 

The {meta user} is an administrator account needed to access the Metastore Provider on an ongoing 
basis by both the BPF Web Application and BPF Explorer. 

This account needs to have read/write access to the BPF Metastore database.  The BPF metastore 
creation scripts create this user and grant privileges. 

Oracle: 

a. Roles: CONNECT 

b. System Privileges: CREATE SESSION (this comes with the CONNECT Role) 

c. Object Permissions:  either EXECUTE (for stored procedures) or INSERT, UPDATE, DELETE, and 
SELECT permission on all Bp8 objects.  If your schema is named Bp8 and you are using the Bp8 
user account (schema owner) as your {meta user}, then your {meta user} schema automatically has 
these permissions.  If you are using another account (other than schema owner) as your {meta 
user}, then you must develop and run scripts to grant all of the above privileges on each of the 
objects in the schema to your  {meta user}.  For example: 

GRANT INSERT, UPDATE, DELETE, SELECT ON application_settings TO Bp8; 

This needs to be done individually for each table, view, stored procedure, and so on, since the “ANY” 
privileges apply to the whole database and not just an individual schema – and there is no separate 
privilege to grant “SELECT” (for example) on all objects in a single schema. 

The default name of the BPF Oracle {meta user} and schema is “BP8”.  If you decide to use any 
other name for your {meta user} and schema in Oracle, you then also need to edit the copy of 
Bp8sql.xml used by BPF Explorer (and located in the home directory of BPF Explorer itself [in the 
same directory as BPF Explorer.msc]) so as to change the following entry at the beginning of the file 
to reflect your change 

<ORACLE>alter session set current_schema={meta user}</ORACLE> 

Assuming you choose to use it (the most common scenario), you also need to reflect this change 
throughout your Step0.oracle.Bp8.Metabase.1.0.sql file before running it (see below under Create 
BPF Metastore, Oracle), and then change the following line  

ALTER SESSION SET CURRENT_SCHEMA={meta user}; 
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at the beginning of the following SQL scripts before running them 

Step1.oracle.Bp8.Metabase.1.0.sql 
Step2.oracle.Bp8.Metabase.1.0.sql 
Step3.oracle.Bp8.Metabase.1.0.sql 
 

SQL Server: public and db_owner roles. 
 

LDAP Security Considerations 
The Case Management Sample Application maps its BPF Roles to Workplace Access Roles and then 
maps these Workplace Access Roles to existing LDAP users or groups. Users and/or Groups that 
can be mapped to the following Workplace Access Roles must therefore be prior to the BPF 
installation in your LDAP repository: 

o sue 

o joe 

o ana 

o mark 

NOTE The names of your LDAP Users and/or Groups do not need to reflect or resemble the 
names of the Workplace Access Roles to which they are to be assigned.  But since it often takes 
considerable lead-time to arrange for the creation of new LDAP Users and/or Groups, it is 
recommended that you make arrangements to have this done well before you begin the actual 
installation. 

JDBC Driver Requirements 
The JDBC drivers required to support BPF must be supplied by the customer in accordance with the 
IBM FileNet P8 3.6 Hardware and Software Requirements document and arrangements need to be 
made with the customer ahead of time to make sure that they are available prior to installing BPF. 
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Environment Configuration 
Configure Users/Groups 
Although there are a number of ways to set up the security authentication and authorization for BPF 
applications, the following describes the method of setup to support the BPF Case Management 
Sample Application.  

The Case Management Sample Application uses Workplace Access Roles and maps them to existing 
LDAP users or groups. There are four BPF Roles defined to support the Case Management Sample 
Application that must be defined in Workplace Access Roles: 

• Supervisor (Add “sue” LDAP user) 

• Indexer (Add “joe” LDAP user) 

• Reviewer (Add “mark” LDAP user) 

• Approver (Add “ana” LDAP user) 

• BPF Site Designers (Add “sue” LDAP user) 

NOTE In BPF, role membership is managed through LDAP security group membership. BPF Roles 
are linked to Workplace Access Roles, which are linked to LDAP Users or Groups. 

For reasons of performance enhancement, it is strongly recommend that you use Workplace access 
roles (BPF metastore setting "Enable Access Roles" set to true) instead of direct LDAP integration, 
especially in cases where the LDAP directory is large or complex (containing many levels of nested 
groups/folders). 

1. Within Workplace Site Preferences, define Workplace Access Roles corresponding to the BPF 
Roles mentioned above.  

a. Click Admin > Site Preferences. 

b. Click Access Roles. 

c. Click Add Role.  

d. Name the new role appropriately, such as Indexer. 

e. Remove all default added role members using the Delete Role button next to the access 
role. 

f. Select either User or Groups to display the appropriate list. 

g. Type one or more characters for the beginning of the user or group names to search for. 

h. Click Search. After a brief delay, the matching names are displayed. 

i. Click Accept. The Site Preferences page opens again, with the new user or group name 
listed for the role under Allowed Access. 

j. Add more access roles as appropriate. 

k. Click Apply. 

l. Make sure you have mapped just created Access Role to appropriate metastore security 
profile. 
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Copy CDROM Contents to Target Machine 
1. Mount CDROM device to a folder on target machine and copy the contents to the staging folder.  

The following table describes the BPF release software contents found on the CDROM. 

Folder/File Description 

{root} BPF_Installation_Guide.pdf Electronic copy of this Installation Guide 
document. 

 version.txt Contains BPF build version information. 

admin/  Contains the target files for BPF 
Explorer, which is installed and executed 
from an administrative Windows 
desktop. 

 filenet_bpf_explorer_setup.exe 
[Windows version] 

BPF Explorer setup package. 

documentation/  Standard documentation for BPF and its 
related components in the form of a Web 
site. 

 BPF_help/ Directory that contains the BPF help. 
You can read the help from this 
directory, or copy and deploy/add it on 
an application server as a Web site. 

 BPF_help.war Compressed version of the BPF Help 
that is required for installation on IBM 
WebSphere® application servers. 

 version.txt File that identifies the product software 
version associated with the BPF help, 
the documentation and Java™ reference 
documentation build numbers, and the 
build date. 

 readme.htm  

misc/  This folder contains sample code and 
Starter Solution demos. 

 solutions/ This folder contains library of sample 
configurations. The subdirectories below 
are different configuration templates. 

 base/config/ Base configuration 

     BPF_base.xml Metastore base configuration 

     ce_base.xml CE base configuration 

     qcreate_base.xml Base workflow queue configuration 

 case_management/ Case Management sample configuration 

         CaseManagement.pep The workflow map 

         qcreate_cm.xml CM workflow queue configuration 
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Folder/File Description 

         bp8_cm.xml BPF CM Metastore manifest 

         ce_cm.xml CE CM manifest 

         Auth For Work.doc 

        JaneGibbonsReceipts.tif 

        ExpenseForm.xls 

Master Agreement.pdf 

Sample documents 

         p8LeftLogOnBar.JPG 

        logon_logo.gif 
Web application logo and splash screen 

    components/  

       workplace/Bp8ViewActions.jsp P8 Workplace Integration Servlet 
extensions and sample configurations 

 wfutil/ BPF wfutil program files 

setup/  This folder contains the BPF Web 
Application Installer files. 

 BPF_installer.jar Installer JAR file 

 AIXfilenet_BPF_setup.exe IBM AIX® BPF Web Application setup 
package 

 HPUXfilenet_BPF_setup.exe HPUX BPF Web Application setup 
package 

 SOLARISfilenet_BPF_setup.exe SOLARIS BPF Web Application setup 
package 

 WINDOWSfilenet_BPF_setup.exe Windows BPF Web Application setup 
package 

 BPF_silent_input.txt Silent Installation Resource File. 

SQL/  Contains BPF Metastore SQL Scripts. In 
some cases, there is a prerequisite to 
update one or more of the database 
schemas. These scripts are typically 
executed by a site DBA. 

 Step0.oracle.Bp8.Metabase.1.0.SQL 

Step1.oracle.Bp8.Metabase.1.0.SQL 

Step2.oracle.Bp8.Metabase.1.0.SQL 

Step3.oracle.Bp8.Metabase.1.0.SQL 

Oracle version 

 Step1.mssql.Bp8.Metabase.1.0.SQL 

Step2.mssql.Bp8.Metabase.1.0.SQL 

Step3.mssql.Bp8.Metabase.1.0.SQL 

Microsoft® SQL version 
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Make Staging Folder Accessible 
The staging folder needs to be accessible from the various servers. The table below identifies which 
servers require access to specific sub folders under the staging folder.  

Server  Folder 

{bpf admin workstation} {staging folder}/misc 

{staging folder}/admin 

{meta data server} {staging folder}/sql 

{web application server} {staging folder}/misc 

{staging folder}/setup 

 

1. Share the original staging folder or copy the staging folder to other servers as indicated above 
(using ftp or some other tool of your choice). 

2. If a copy is performed to other servers, mark down on the worksheet for {staging folder} the 
additional staging folders created. 

Grant Access to Process Engine Database 
Grant the appropriate database role membership. See the “Process Engine User “on the prerequisite 
worksheet. 

Create JDBC DataSource – BPF Metastore 
NOTE  The XA driver type is not supported. 

Create DataSource 
Create the JDBC DataSource as follows: 

BEA WebLogic/Microsoft SQL Server 
1. Log into BEA WebLogic console using IE:  

http://{web application server}:7001/console. 

2. Configure connection pool: 

a. Select Services > JDBC > Connection pools.  

b. Click Configure a new JDBC Connection Pool.... 

c. Select Database Type: MS SQL Server. 

d. Select Database Driver: *BEA's MS SQL Server Driver (Type 4) Versions: 7.0,2000  

e. Click Continue. 

f. Determine the {meta connection pool} name and record on your worksheet. Suggested 
name: Bp8MetadataPool. 

g. Select Name: {meta connection pool}. 

h. Enter Database name: {meta database}. 

i. Enter Host name: {meta data server} 

j. Enter Port: 1433. 
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k. Enter Database user name: {meta user} 

l. Enter Database password: {meta password} 

m. Click Continue. 

n. Select the Test Driver Configuration.  
 
You should receive the Connection successful message. 

o. Select Create and Deploy. 

3. Create JDBC DataSource: 

a. Select Services > JDBC > DataSources.  

b. Select Configure a new JDBC DataSource....  

c. Determine the {meta datasource} name and record on your worksheet. Suggested name: 
Bp8MetadataDS. 

d. Enter name: {meta datasource}. 

e. Enter JNDI name: {meta datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same.  

f. Enter Honor Global Transactions: selected. 

g. Enter Emulate Two-Phase commit: unselected. 

h. Click Continue. 

i. Select {meta connection pool}. 

j. Select Continue. 

k. Select Create. 

BEA WebLogic/Oracle 
1. Log into BEA WebLogic console using IE:  

http://{web application server}:7001/console. 

2. Configure Connection Pool: 

3. Select Services > JDBC > Connection pools.  

a. Click Configure a new JDBC Connection Pool.... 

b. Select Database Type: Oracle. 

c. Select Database Driver: BEA's Oracle Driver (Type 4) 

d. Click Continue. 

e. Determine the {meta connection pool} name and record it on your worksheet. Suggested 
name: Bp8MetadataPool. 

f. Select Name: {meta connection pool}. 

g. Enter Database name: {meta database}. 

h. Enter Host name: {meta data server} 

i. Enter Port: 1521 (default). 

j. Enter Database user name: {meta user} 
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k. Enter Database password: {meta password} 

l. Click Continue. 

m. Modify Properties > SID if necessary. 

n. Select the Test Driver Configuration.  
 
You should receive the Connection Successful message.  

o. Select Create and Deploy. 

4. Create JDBC DataSource: 

a. Select Services > JDBC > DataSources.  

b. Select Configure a new JDBC DataSource....  

c. Determine the {meta datasource} name and record on your worksheet. Suggested name: 
Bp8MetadataDS. 

d. Enter name: {meta datasource}. 

e. Enter JNDI name: {meta datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same.  

f. Enter Honor Global Transactions: selected. 

g. Enter Emulate Two-Phase commit: unselected. 

h. Click Continue. 

i. Select {meta connection pool}. 

j. Select Continue. 

k. Select Create. 

IBM WebSphere/Oracle 
1. Logon to WebSphere Administrative Console: http://{web application 

server}:9060/ibm/console. 

2. Create JDBC Provider as follows: 

a. Record Oracle JDBC Driver as {meta connection pool} on worksheet. 

b. Click on Resources > JDBC Providers. 

Skip these sub-steps if {meta connection pool} already exists. Otherwise, do the following: 

c. Click New. 

d. Select the database type: Oracle. 

e. Select the provider type: {meta connection pool}.  

f. Select the implementation type: Connection pool DataSource.  

g. Click Next. 

h. Record the Class path as the {class path} on the worksheet. 

i. Click Apply. 

j. Save changes to master configuration. 
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k. Click on Environment > WebSphere Variables. 

l. Verify that any environment variables used in {class path} is set correctly. 

3. Create Initial JDBC DataSource: 

a. Click on Resources > JDBC Providers.  

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties.  

d. Click New. 

e. Enter the Name for the DataSource. Record this name on your worksheet as {meta 
datasource}.  

f. Enter JNDI name: {meta datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same. 

g. Enter Description: {meta datasource}. 

h. Enter URL: JDBC:oracle:thin:@{meta data server}:1521:{meta database sid}.  
 
NOTE If URL does not work for any reason try: JDBC:oracle:thin@{TNS Descriptor}.  
 
For example:  
JDBC:oracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(
HOST=p8demo35)(PORT=1521)))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_N
AME=Bp8.Metastore))) 

i. Click Apply. 

j. Save changes to master configuration. 

4. Create Authentication Entry as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties.  
 
NOTE Do not select DataSources (Version 4). 

d. Click {meta datasource}. 

e. Click J2EE Connector Architecture (J2C) authentication data entries under Related 
Items. 

f. Click New. 

g. Enter Alias name. Enter on your worksheet as {meta authentication name}.  

h. Enter User ID: {meta user}. 

i. Enter Password: {meta password}. 

j. Click Apply. 

k. Save changes to master configuration. 

5. Set JDBC DataSource Authentication: 

a. Click on Resources > JDBC Providers. 
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b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties. 

d. Click {meta datasource}. 

e. Select Component-managed authentication alias: {meta authentication name}. 

f. Click Apply. 

g. Save changes to master configuration. 

6. Test the connection: 

a. Click on Resources > JDBC Providers.  

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties. 

d. Select the checkbox for {meta datasource}. 

e. Click Test Connection.  

A success message should be displayed. 

IBM WebSphere/SQL Server 
1. Logon to the WebSphere Administrative Console:  

http://{web application server}:9060/ibm/console. 

2. Create JDBC Provider: 

a. Click on Resources > JDBC Providers. 

Skip these sub-steps if {meta connection pool} already exists. Otherwise, do the following: 

b. Click New. 

c. Select the database type: SQL Server. 

d. Select the provider type: {meta connection pool}.  

e. Select the implementation type: Connection pool DataSource.  

f. Click Next. 

g. Click Apply. 

h. Save changes to master configuration. 

3. Create Initial JDBC DataSource: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties.  
 
NOTE Do not select DataSources (Version 4). 

d. Click New. 

e. Enter the name for the DataSource. Suggested name: Bp8MetadataDS. Record this name 
on your worksheet as {meta datasource}.  
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f. Enter JNDI name: {meta datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same. 

g. Enter Description: {meta datasource}. 

h. Enter Database name: {meta database}. 

i. Enter Server name: {meta data server}. 

j. Click Apply. 

k. Save changes to master configuration. 

4. Create Authentication Entry: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties. 

d. Click {meta datasource}. 

e. Click J2EE Connector Architecture (J2C) authentication data entries under Related 
Items. 

f. Click New. 

g. Enter Alias name. {meta authentication name}. 

h. Enter User ID: {meta user}. 

i. Enter Password: {meta password}. 

j. Click Apply. 

k. Save changes to master configuration. 

5. Set JDBC DataSource Authentication: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties. 

d. Click {meta datasource}. 

e. Select Component-managed authentication alias: {meta authentication name}. 

f. Click Apply. 

g. Save changes to master configuration. 

6. Test the connection: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {meta connection pool}. 

c. Click DataSources under Additional Properties. 

d. Select the Checkbox for {meta datasource}. 

e. Click Test Connection.  

A success message should be displayed. 
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IBM Websphere/DB2 
BPF metastore is only supported with MS SQL Server and Oracle Database. Metastore database 
on DB2® is not supported in this release. 

JBOSS/SQL Server 
1. Create DataSource entry. 

a. In the JBOSS directories, copy msSQL-ds.xml  
from ...\docs\examples\jca  
to ...\server\default\deploy (if it does not already exist). 

b. In the ...\server\default\deploy\msSQL-ds.xml file, add the information below under 
<datasources>.  Replace worksheet items appropriately.  For example, replace {meta 
datasource} with Bp8MetadataDS. 

<datasources> 

 <local-tx-datasource> 

  <jndi-name>{meta datasource}</jndi-name> 
  <connection-url> 

   JDBC:jtds:SQLserver://{meta data 
server}:1433;DatabaseName={meta database} 
  </connection-url> 

  <driver-class>net.sourceforge.jtds.JDBC.Driver</driver-class> 

  <user-name>{meta user}</user-name> 

  <password>{meta password}</password> 

  <metadata> 

   <type-mapping>MS SQLSERVER2000</type-mapping> 

  </metadata> 

   </local-tx-datasource> 

</datasources> 

2. Place driver in lib directory: 

a. Download jtds-1.0.2.jar from SourceForge.net (http://sourceforge.net).   

b. Place the jar file in ...\server\default\lib. 

JBOSS/Oracle 
1. Create DataSource entry. 

a. In the JBOSS directories, copy oracle-ds.xml  
from ...\docs\examples\jca  
to ...\server\default\deploy (if it does not already exist). 

b. In the …\server\default\deploy\oracle-ds.xml file,  
add the information below under <datasources>.   

Replace worksheet items appropriately.  For example, replace {meta datasource} with 
Bp8MetadataDS. 

<datasources> 

http://sourceforge.net/


IBM FileNet Business Process Framework Installation Guide 
Environment Configuration 
 

 

© Copyright IBM Corp. 2006, 2009  33 

 <local-tx-datasource> 

  <jndi-name>{meta datasource}</jndi-name> 

  <connection-url> 

   JDBC:oracle:thin:@{meta data server}:1521:{meta database} 

  </connection-url> 

  <driver-class>oracle.JDBC.driver.OracleDriver</driver-class> 

  <user-name>{meta user}</user-name> 

  <password>{meta password}</password> 

   </local-tx-datasource> 

</datasources> 

2. Place driver in lib directory. 

a. Download ojdbc14.jar from Oracle.   

b. Place the jar file in ...\server\default\lib. 

Oracle Application Server/SQL Server 
1. Start the Oracle Application Server and from the Oracle Admin Console, create a unique OC4J 

Instance to use with your BPF application (assuming you do not already have one created for this 
purpose).  
 
CAUTION: Do not share this instance with Workplace, BPF or any other application using 
common XML parsing jar APIs otherwise you might encounter XML/XSL errors in Workplace 
integration with BPF or within BPF due to the class loader implementation used by OAS.) 

2. Click the OC4J Instance you created. 

3. Click Administration tab. 

4. Click DataSources. 

5. Click Create button. 

6. Enter the following information for MetaStore DataSource: 

a. Name: Enter the name of the {meta data source}: for example, Bp8MetadataDS 

b. Data Source Class: com.evermind.sql.DriverManagerDataSource 

c. JDBCURL:jdbc:datadirect:sqlserver://<database-ServerName>:<database-
port>;DatabaseName=<databaseName> 

d. JDBC Driver: com.ddtek.jdbc.sqlserver.SQLServerDriver 

e. Username: {meta user}  

f. Under option Use Cleartext Password, Select Password: Password {meta user 
password}. 

g. Location: {meta data source}: for example, Bp8MetadataDS 

h. Transactional(XA) Location: {meta data source}: for example, Bp8MetadataDS 

i. EJB Location: {meta data source}: for example, Bp8MetadataDS 

7. Click Apply to create the data source. 
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Oracle Application Server/Oracle 
1. Click the OC4J Instance you previously created. 

2. Click Administration tab. 

3. Click Data Sources. 

4. Click Create button. 

5. Enter the following information for Metastore DataSource: 

a. Name: Enter the name of the {meta data source}: for example, Bp8MetadataDS 

b. Data Source Class: com.evermind.sql.DriverManagerDataSource 

c. JDBC URL: jdbc:oracle:thin:@//<database-Servername>:<database-port>/<Metastore 
database SID> 

d. JDBC Driver: oracle.jdbc.driver.OracleDriver 

e. Username: {meta user}  

f. Under option Use Cleartext Password, Select Password: Password {meta user 
password}. 

g. Location: {meta data source}: for example, Bp8MetadataDS 

h. Transactional(XA) Location: {meta data source}: for example, Bp8MetadataDS 

i. EJB Location: {meta data source}: for example, Bp8MetadataDS 

6. Click Apply to create the data source. 

Create JDBC DataSource – Process Engine 

Create DataSource 

BEA WebLogic/Microsoft SQL Server 
1. Log into BEA WebLogic console using IE: http://{web application server}:7001/console. 

Configure connection pool as follows: 

a. Select Services > JDBC > Connection pools.  

b. Click Configure a new JDBC Connection Pool.... 

c. Select Database Type: MS SQL Server. 

d. Select Database Driver: *BEA's MS SQL Server Driver (Type 4) Versions: 7.0,2000  

e. Click Continue. 

f. Determine the {pe connection pool} name and record on your worksheet. Suggested name: 
Bp8ProcessPool. 

g. Enter Name: {pe connection pool}. 

h. Enter Database name: {pe database}. 

i. Enter Host name: {pe data server} 

j. Enter Port: 1433. 

k. Enter Database user name: {pe user} 
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l. Enter Database password: {pe password} 

m. Click Continue. 

n. Select the Test Driver Configuration.  
 
You should receive the Connection successful message. 

o. Select Create and Deploy. 

2. Create JDBC DataSource: 

a. Select Services > JDBC > DataSources.  

b. Select Configure a new JDBC DataSource....  

c. Determine the {pe datasource} name and record on your worksheet. Suggested name: 
Bp8ProcessDS. 

d. Enter name: {pe datasource}. 

e. Enter JNDI name: {pe datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same.  

f. Enter Honor Global Transactions: selected. 

g. Enter Emulate Two-Phase commit: unselected. 

h. Click Continue. 

i. Select {pe connection pool}. 

j. Select Continue. 

k. Select Create. 

BEA WebLogic/Oracle 
1. Log into BEA WebLogic console using IE: http://{web application server}:7001/console. 

2. Configure Connection Pool: 

a. Select Services > JDBC > Connection pools.  

b. Click Configure a new JDBC Connection Pool. 

c. Select Database Type: Oracle. 

d. Select Database Driver: BEA's Oracle Driver (Type 4) 

e. Click Continue. 

f. Determine the {pe connection pool} name and record on your worksheet. Suggested name: 
Bp8ProcessPool. 

g. Enter Name: {pe connection pool}. 

h. Enter Database name: {pe database}. 

i. Enter Host name: {pe data server} 

j. Enter Port: 1521. 

k. Enter Database user name: {pe user} 

l. Enter Database password: {pe password} 
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m. Click Continue. 

n. Modify Properties > SID if necessary. 

o. Select the Test Driver Configuration.  
 
You should receive the Connection Successful message.  

p. Select Create and Deploy. 

3. Create JDBC DataSource: 

a. Select Services > JDBC > DataSources.  

b. Select Configure a new JDBC DataSource....  

c. Determine the {pe datasource} name and record on your worksheet. Suggested name: 
Bp8ProcessDS. 

d. Enter name: {pe datasource}. 

e. Enter JNDI name: {pe datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same.  

f. Enter Honor Global Transactions: selected. 

g. Enter Emulate Two-Phase commit: unselected. 

h. Click Continue. 

i. Select {pe connection pool}. 

j. Select Continue. 

k. Select Create. 

IBM WebSphere/Oracle 
1. Logon to WebSphere Administrative Console: http://{web application 

server}:9060/ibm/console. 

2. Create JDBC Provider: 

a. Record Oracle JDBC Driver as {pe connection pool} on worksheet. 

b. Click on Resources > JDBC Providers. 
Skip this sub-step if {pe connection pool} already exists.  
Otherwise, do the following: 

c. Click on Resources > JDBC Providers.  

d. Click New. 

e. Select the database type: Oracle. 

f. Select the provider type: {pe connection pool}.  

g. Select the implementation type: Connection pool DataSource.  

h. Click Next. 

i. Record the Class path as the {class path} on the worksheet. 

j. Click Apply. 

k. Save changes to master configuration. 
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l. Click on Environment > WebSphere Variables. 

m. Verify that any environment variables used in {class path} is set correctly. 

3. Create Initial JDBC DataSource as follows: 

a. Click on Resources > JDBC Providers.  

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties.  

d. Click New. 

e. Enter the Name for the DataSource. Suggested name: Bp8ProcessDS.  
Record this name on your worksheet as {pe datasource}.  

f. Enter JNDI name: {pe datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same. 

g. Enter Description: {pe datasource}. 

h. Enter URL:  
JDBC:oracle:thin:@{pe data server}:1521:{pe database sid}.  
 
NOTE If URL does not work for any reason try:  
JDBC:oracle:thin@{TNS Descriptor}.  
For example:  
JDBC:oracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)(
HOST=p8demo35)(PORT=1521)))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_N
AME=Bp8.Metastore))) 

i. Click Apply. 

j. Save changes to master configuration. 

4. Create Authentication Entry as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties.  

d. Click {pe datasource}. 

e. Click J2EE Connector Architecture (J2C) authentication data entries under Related 
Items. 

f. Click New. 

g. Enter Alias name. Suggested name: Bp8ProcessAlias. Enter on worksheet as  
{pe authentication name}. 

h. Enter User ID: {pe user}. 

i. Enter Password: {pe password}. 

j. Click Apply. 

k. Save changes to master configuration. 

5. Set JDBC DataSource Authentication as follows: 

a. Click on Resources > JDBC Providers. 
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b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties. 

d. Click {pe datasource}. 

e. Select Component-managed authentication alias: {pe authentication name}. 

f. Click Apply. 

g. Save changes to master configuration. 

6. Test the connection as follows: 

a. Click on Resources > JDBC Providers.  

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties. 

d. Select the Checkbox for {pe datasource}. 

e. Click Test Connection.  

A success message should be displayed. 

IBM WebSphere/SQL Server 
1. Logon to the WebSphere Administrative Console:  

http://{web application server}:9060/ibm/console. 

2. Create JDBC Provider as follows: 

a. Click on Resources > JDBC Providers. 

Skip this sub-step if {pe connection pool} already exists.  
Otherwise, do the following: 

b. Click New. 

c. Select the database type: SQL Server. 

d. Select the provider type: {pe connection pool}.  

e. Select the implementation type: Connection pool DataSource.  

f. Click Next. 

g. Click Apply. 

h. Save changes to master configuration. 

3. Create Initial JDBC DataSource as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties.  

d. Click New. 

e. Enter the name for the DataSource {pe datasource}. Suggested name: Bp8ProcessDS. 
Record this name on your worksheet as {pe datasource}.  

f. Enter JNDI name: {pe datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same. 



IBM FileNet Business Process Framework Installation Guide 
Environment Configuration 
 

 

© Copyright IBM Corp. 2006, 2009  39 

g. Enter Description: {pe datasource}. 

h. Enter Database name: {pe database}. 

i. Enter Server name: {pe data server}. 

j. Click Apply. 

k. Save changes to master configuration. 

4. Create Authentication Entry as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties. 

d. Click {pe datasource}. 

e. Click J2EE Connector Architecture (J2C) authentication data entries under Related 
Items. 

f. Click New. 

g. Enter Alias name {pe authentication name}. Suggested name: Bp8ProcessAlias. Record 
this name on your worksheet as {pe authentication name}. 

h. Enter User ID: {pe user}. 

i. Enter Password: {pe password}. 

j. Click Apply. 

k. Save changes to master configuration. 

5. Set JDBC DataSource Authentication as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties. 

d. Click {pe datasource}. 

e. Select Component-managed authentication alias: {pe authentication name}. 

f. Click Apply. 

g. Save changes to master configuration. 

6. Test the connection as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider: {pe connection pool}. 

c. Click DataSources under Additional Properties. 

d. Select the Checkbox for {pe datasource}. 

e. Click Test Connection.  

A success message should be displayed. 
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IBM Websphere/DB2 
1. Logon to the WebSphere Administrative Console:  

http://{web application server}:9060/ibm/console. 

2. Create JDBC Provider as follows: 

a. Click on Resources > JDBC Providers. 

Skip this sub-step if {pe connection pool} already exists.  
Otherwise, do the following: 

b. Click New. 

c. Select the database type: SQL Server. 

d. Select the provider type as ‘DB2 Universal JDBC Driver Provider’.  

e. Select the implementation type: Connection pool DataSource.  

f. Click Next. 

g. Click Apply. 

h. Save changes to master configuration. 

3. Create Initial JDBC DataSource as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the appropriate provider ‘DB2 Universal JDBC Driver Provider’ 

c. Click DataSources under Additional Properties.  

d. Click New. 

e. Enter the name for the DataSource {pe datasource}. Suggested name: Bp8ProcessDS. 
Record this name on your worksheet as {pe datasource}.  

f. Enter JNDI name: {pe datasource}.  
 
NOTE The DataSource name and the DataSource JNDI name must be the same. 

g. Enter Description: {pe datasource}. 

h. Enter Database name: {pe database}. 

i. Enter Server name: {pe data server}. 

j. Click Apply. 

k. Save changes to master configuration. 

4. Create Authentication Entry as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the provider ‘DB2 Universal JDBC Driver Provider’ 

c. Click DataSources under Additional Properties. 

d. Click {pe datasource}. 

e. Click J2EE Connector Architecture (J2C) authentication data entries under Related 
Items. 

f. Click New. 
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g. Enter Alias name {pe authentication name}. Suggested name: Bp8ProcessAlias. Record 
this name on your worksheet as {pe authentication name}. 

h. Enter User ID: {pe user}. 

i. Enter Password: {pe password}. 

j. Click Apply. 

k. Save changes to master configuration. 

5. Set JDBC DataSource Authentication as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the provider ‘DB2 Universal JDBC Driver Provider’ 

c. Click DataSources under Additional Properties. 

d. Click {pe datasource}. 

e. Select Component-managed authentication alias: {pe authentication name}. 

f. Click Apply. 

g. Save changes to master configuration. 

6. Test the connection as follows: 

a. Click on Resources > JDBC Providers. 

b. Click on the provider ‘DB2 Universal JDBC Driver Provider’ 

c. Click DataSources under Additional Properties. 

d. Select the Checkbox for {pe datasource}. 

e. Click Test Connection.  

A success message should be displayed. 

JBOSS/SQL Server 
1. Create DataSource entry: 

In the JBOSS directories,  
copy msSQL-ds.xml  
from ...\docs\examples\jca  
to ...\server\default\deploy (if it does not already exist). 

In the ...\server\default\deploy\msSQL-ds.xml file,  

add the following under <datasources>.   

Replace worksheet items appropriately.   

For example, replace {pe datasource} with Bp8MetadataDS. 

<datasources> 

 <local-tx-datasource> 

  <jndi-name>{pe datasource}</jndi-name> 

  <connection-url> 

   JDBC:jtds:SQLserver://{pe data server}:1433;DatabaseName={pe 
database} 



IBM FileNet Business Process Framework Installation Guide 
Environment Configuration 
 

 

© Copyright IBM Corp. 2006, 2009  42 

  </connection-url> 

  <driver-class>net.sourceforge.jtds.JDBC.Driver</driver-class> 

  <user-name>{pe user}</user-name> 

  <password>{pe password}</password> 

  <metadata> 

   <type-mapping>MS SQLSERVER2000</type-mapping> 

  </metadata> 

 </local-tx-datasource> 

</datasources> 

2. Place driver in lib directory 

a. Download jtds-1.0.2.jar from SourceForge.net (http://sourceforge.net).   

b. Place the jar file in ...\server\default\lib. 

JBOSS/Oracle 
1. Create DataSource entry: 

In the JBOSS directories,  
copy oracle-ds.xml  
from ...\docs\examples\jca  
to ...\server\default\deploy (if it does not already exist). 

In the ...\server\default\deploy\oracle-ds.xml file, add the information below under 
<datasources>.  Replace worksheet items appropriately.  For example, replace {pe datasource} 
with Bp8MetadataDS. 

<datasources> 

 <local-tx-datasource> 

  <jndi-name>{pe datasource}</jndi-name> 

  <connection-url> 

   JDBC:oracle:thin:@{pe data server}:1521:{pe database} 

  </connection-url> 

  <driver-class>oracle.JDBC.driver.OracleDriver</driver-class> 

  <user-name>{pe user}</user-name> 

  <password>{pe password}</password> 

   </local-tx-datasource> 

</datasources> 

2. Place driver in lib directory. 

a. Download JDBC14.jar from Oracle.   

b. Place the jar file in ...\server\default\lib. 

Oracle Application Server/SQL Server 
1. Click the OC4J Instance you previously created. 

2. Click Administration tab. 

http://sourceforge.net/
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3. Click Data Sources. 

4. Click Create button. 

5. Enter the following information for PE DataSource: 

a. Name: Enter the name of the {pe datasource}: for example, Bp8ProcessDS 

b. Data Source Class: com.evermind.sql.DriverManagerDataSource 

c. JDBCURL:jdbc:datadirect:sqlserver://<database-ServerName>:<database-
port>;DatabaseName=<databaseName> 

d. JDBC Driver: com.ddtek.jdbc.sqlserver.SQLServerDriver 

e. Username: {pe user}  

f. Under option Use Cleartext Password, Select Password: Password {pe password}. 

g. Location: {pe datasource}: for example, Bp8ProcessDS 

h. Transactional(XA) Location: {pe datasource}: for example, Bp8ProcessDS 

i. EJB Location: {pe datasource}: for example, Bp8ProcdessDS 

6. Click Apply to create the data source. 

Oracle Application Server/Oracle 
1. Click the OC4J Instance you previously created. 

2. Click Administration tab. 

3. Click Data Sources. 

4. Click Create button. 

5. Enter the following information for PE DataSource: 

a. Name: Enter the name of the {pe datasource}: for example, Bp8ProcessDS 

b. Data Source Class: com.evermind.sql.DriverManagerDataSource 

c. JDBC URL: jdbc:oracle:thin:@//<database-Servername>:<database-port>/<PE database 
SID> 

d. JDBC Driver: oracle.jdbc.driver.OracleDriver 

e. Username: {pe user}  

f. Under option Use Cleartext Password, Select Password: Password {pe password}. 

g. Location: {pe datasource}: for example, Bp8ProcessDS 

h. Transactional(XA) Location: {pe datasource}: for example, Bp8ProcessDS 

i. EJB Location: {pe datasource}: for example, Bp8ProcdessDS 

6. Click Apply to create the data source. 
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Update Process Engine Database Views 

SQL Server 
No action required. 

Oracle 
Currently there is a case sensitivity issue with Oracle database views in P8 3.5: Database views need 
to be manually adjusted after modifying workflow queue definitions. 

1. Find views. 

In Oracle Enterprise Manager:  
Find {PE Database} > Schema > F_SW > Views.  
Find the views for all queues in the isolated region in question.  These views have names that 
adhere to the following naming convention:  “VWVQ” + <IsolatedRegionNumber> + “_” + 
<QueueName>.  NOTE It is not necessary to update the other views for logs or rosters, and so 
on.  Only the queues used by the BPF Web Application need to be updated. 

2. Create SQL statements. For each view do the following: 

a. Right-click: Show Object DDL. 

b. Ctrl+A, Ctrl+C: Put DDL contents in Notepad (for each view). 

c. Put a semi-colon after each DDL statement. 

3. Execute SQL statements as follows: 

a. Replace double-quotes (") with nothing for all SQL statements.  

b. Execute statements in Oracle SQL Worksheet. 

DB2 
The BPF Web Application does not require double quotes in Process Engine Database Views. 
Database Views need to be manually adjusted after modifying workflow queue definitions. For 
example, the following view script should be modified to remove double quotes. 

Original SQL Script: 

CREATE VIEW VWVQ1_Inbox AS SELECT F_WobNum, F_WorkSpaceId, F_Locked,  

F_LockMachine, F_LockUser, F_LockTime, F_LastUser, F_BoundUser,  

F_BoundMachine, F_Tag, F_UniqueId, F_OperationId, F_WorkClassId,  

F_EnqueueTime, F_CreateTime, F_InstrSheetId, F_WorkOrderId,  

F_TimeOut "F_TimeOut", F_Subject "F_Subject", F_Overdue "F_Overdue",  

F_StepName "F_StepName", Bp8CaseID "Bp8CaseID", F_UF006 "Priority",  

F_UF007 "DocumentType", F_UF008 "ReceivedDate", F_UF009 "Rejected",  

F_UF010 "SendToHost", F_UF011 "Expired", F_UF012 "Bp8CaseType",  

F_UF013 "AccountNumber", F_UF014 "CompanyName" FROM F_SW.VWQueue1_115  

WHERE F_Locked < 2 AND F_QueueWPClassId = 1 
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Modified SQL Script: 

CREATE VIEW VWVQ1_Inbox AS SELECT F_WobNum, F_WorkSpaceId, F_Locked,  

 F_LockMachine, F_LockUser, F_LockTime, F_LastUser, F_BoundUser,  

 F_BoundMachine, F_Tag, F_UniqueId, F_OperationId, F_WorkClassId,  

 F_EnqueueTime, F_CreateTime, F_InstrSheetId, F_WorkOrderId,  

 F_TimeOut F_TimeOut, F_Subject F_Subject, F_Overdue F_Overdue,  

 F_StepName F_StepName, Bp8CaseID Bp8CaseID, F_UF006 Priority,  

 F_UF007 DocumentType, F_UF008 ReceivedDate, F_UF009 Rejected,  

 F_UF010 SendToHost, F_UF011 Expired, F_UF012 Bp8CaseType,   

F_UF013 AccountNumber, F_UF014 CompanyName FROM F_SW.VWQueue1_115  

 WHERE F_Locked < 2 AND F_QueueWPClassId = 1 
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Install and Configure BPF Explorer and Metastore 
Install BPF Explorer 
Execute {staging folder}\admin\filenet_BPF_explorer_setup.exe to run the setup.   

NOTES 

• The setup assumes BPF Explorer is to access only one metastore.  Instructions for 
configuring BPF Explorer for multiple metastores are provided in the next step. 

• BPF versions are numbered in this format: {major}.{minor}.{build number}. For example: 
3.5.1. The version number shown by Windows for the various BPF Explorer binaries (such as 
Bp8Explorer.dll) have an extra zero in it; for example: 3.5.0.2. The correct version number is 
shown in the Product Name property. 

• If BPF Explorer is installed on a desktop with no CE client libraries, CE integration is 
disabled.  The CE client libraries are installed automatically with FileNet Enterprise Manager.  
But it is also possible to install just the CE client libraries without installing FileNet Enterprise 
Manager.  Consult your installation documentation for CE for more details. 

For both Microsoft SQL Server and Oracle 
When the BPF Explorer setup program is run, the following InstallShield wizard screens is displayed: 
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The default location for the BPF Explorer files is shown in the following screenshot. Although this is 
the suggested location, you can override it. 

 
Select the appropriate database type: 
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If Microsoft SQL Server is selected 
Enter the following variables from your worksheet into the following InstallShield screen: 

• SQLServer: {meta data server} 

• Database: {meta database} 
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If Oracle is selected 
Enter the TNS name for the {meta database}. The TNS name should be created and tested before 
the BPF Explorer install. 
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Completing the BPF Explorer Installation 
The following screen is displayed when the installation is complete: 

 

Create BPF Metastore 
Create BPF Metastore database as follows: 

Microsoft SQL Server 
1. If the meta database name {meta database} is different than the default value 'Bp8Metastore', 

perform the following steps to edit the Step1 script to reflect your meta database name. 
Otherwise skip this step. 

a. Open the following file in the editor of your choice: 

{staging folder}\SQL\Step1.msSQL.Bp8.Metabase.1.0.SQL 

b. Search for ‘Bp8Metastore’ text and replace with your meta database name {meta database}.  

c. Save the file.  

NOTE Execute Step 1 only when you are performing a new installation of the BPF Application. 
This step can be skipped if you are upgrading the BPF application.  

2. If Microsoft SQL Server is installed on a drive other than C: or in a path other than  
 
C:\Program Files\Microsoft SQL Server 
 
errors occur in the CREATE DATABASE statement in Step1.msSQL.Bp8.Metabase.1.0.SQL 
and you must perform the following steps to edit the Step1 script to reflect the true path of your 
actual Microsoft SQL Server install directory.  Otherwise skip this step. 
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a. Open the following file in the editor of your choice: 

{staging folder}\SQL\Step1.msSQL.Bp8.Metabase.1.0.SQL 

b. Search for the following SQL statement text and replace the sections in bold with the correct 
path for the install directory of Microsoft SQL Server on your machine.  
 
CREATE DATABASE [Bp8Metastore]  ON (NAME = N'Bp8Metastore_dat', FILENAME = 
N'c:\Program Files\Microsoft SQL Server\MSSQL\data\Bp8Metastore.mdf' , SIZE = 5, 
FILEGROWTH = 10%) LOG ON (NAME = N'Bp8Metastore_log', FILENAME = N'c:\Program 
Files\Microsoft SQL Server\MSSQL\data\Bp8Metastore.ldf' , SIZE = 5, FILEGROWTH = 
10%) 

c. Save the file. 

3. Open SQL Query Analyzer:  
Start menu > Programs > Microsoft SQL Server > Query Analyzer. 

4. Logon using the {meta admin user} and {meta admin password}. 

a. Select Master Database from the combo box on tool bar. 

a. Select File / Open… {staging folder}\SQL\Step1.msSQL.Bp8.Metabase.1.0.SQL 

5. Select Query > Execute. 

Oracle 
1. Verify the following prerequisites before starting the installation process: 

• Oracle database exists (can be created using the Oracle Database Configuration Assistant). 

• Oracle listener for database exists (can be created using the Oracle Net Configuration 
Assistant). 

• Net Service Name for database exists (can be created using the Oracle Net Configuration 
Assistant). 

• Able to logon to database and run scripts (by using Oracle SQL Plus Worksheet). 

2. Determine from the customer DBA if it is preferable to use a supplied BPF script (called Step0) to 
create a new tablespace and the necessary BPF users, or if they would prefer to install into an 
existing database configuration. To execute the Step0 script, follow the sub-steps below, 
otherwise skip this step.   

a. Locate the Step0 Script:  
{staging folder}\SQL\Step0.oracle.Bp8.Metabase.1.0.SQL.  

b. Modify the Step0 Script for the customer’s environment. In particular, the following might 
need to be modified: Data file location. (Should point to the appropriate database directory.) 

NOTE By default the user logon Bp8 (with password Bp8) is created with read/write access 
to the BPF Metastore. Record the appropriate information on your worksheet as {meta user} 
and {meta password}. 

By default the BPF_DATA tablespace is created. Record the appropriate name as the {meta 
database} on your worksheet. 

3. Grant the appropriate privileges to the {meta admin user}.  See the “Database Administrative 
User” on the Prerequisite worksheet. 
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4. Execute the following scripts using {meta admin user}: 

o {staging folder}\SQL\Step0.oracle.Bp8.Metabase.1.0.SQL 

o {staging folder}\SQL\Step1.oracle.Bp8.Metabase.1.0.SQL 

The scripts should execute without errors. If there are errors you might need to review the script for 
incorrect references. 

NOTE Execute Step 0 and Step 1 only when you are installing new BPF Application. These steps 
could be skipped if you are upgrading BPF application. 

DB2 
Not supported for BPF Meta database. 

Load BPF Metastore 
Load data into the BPF Metastore database as follows: 

Microsoft SQL Server 
1. Open the following: Start menu > Programs > Microsoft SQL Server > Query Analyzer. 

a. Logon using the {meta admin user}. 

b. Execute Step2 and Step3 scripts. 

i. Select the {meta database} if not already selected (in combo box on tool bar). 

ii. Select File… Open... {staging folder}\SQL\Step2.msSQL.Bp8.Metabase.1.0.SQL 

iii. Select Query... Execute. 

iv. Select File... Open … {staging folder}\SQL\Step3.msSQL.Bp8.Metabase.1.0.SQL 

c. Select Query... Execute. 

2. Assign Password 

The scripts create user Bp8 with a Bp8 password. Record this name on your worksheet as {meta 
user} and {meta password}. 

 You can assign a new password in this manner: 

3. Open Enterprise Manager: Start menu > Programs > Microsoft SQL Server > SQL Server 
Enterprise Manager.  

4. Right click on SQL Server Group > Security > Logins > bp8.  

5. Select Properties. 

6. Determine the {meta password} and record on your worksheet.  

7. Enter password: {meta password}.  

8. Click Ok and confirm the new password. 
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Oracle 
1. Connect as {meta user}. 

2. Execute the following scripts: 

• {staging folder}\SQL\Step2.oracle.Bp8.Metabase.1.0.SQL 

• {staging folder}\SQL\Step3.oracle.Bp8.Metabase.1.0.SQL 

DB2 
Not supported for BPF Meta database. 

Import Metastore Manifest 
1. Determine which manifest to use: 

Base {staging folder}\misc\base\config\BPF_base.xml 

Case Management 
Sample Configuration 

Use {staging folder}\misc\solutions\case_management\config\ 
BPF_cm.xml 

Custom Use your own custom manifest xml file. 
 

2. Log into BPF Explorer. 

3. Select Export and Import Management. 

4. Right-click for context menu: All Tasks > Import XML Manifest. 

5. Click Yes: Confirm loss of current configuration. 

6. Select your manifest. 

7. Click No: User information is not to be preserved. 

8. If you are importing a manifest from a BPF system where the Workflow User ID values in PE are 
different from those in the environment where the BPF system was created, you should update 
the WF_USER_ID column in the USERS table in the Metastore by setting all rows to NULL.  In 
this way, BPF automatically interrogates PE for the correct values for these users in your 
environment.  Otherwise, BPF assumes that existing values are correct, causing problems in the 
Web Application whereby a user who has opened a Case receives warnings that the Case is 
locked by another user even though this is not actually the case.  To reset the WF_USER_ID 
column, execute the following SQL statement against the Metastore: 
 
update users set wf_user_id=null 
 
If you are importing a manifest that was created in the same environment (a backup, for 
example), then you can skip this step, as the Workflow User ID values in PE should still be the 
same.  

Edit Metastore Settings 
1. Start the application by clicking Start Menu > Programs > FileNet Business Process 

Framework > BPF Explorer  

2. Login using {meta user} and {meta password}. 
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3. Edit the following settings: 

Setting Value 

Application Settings > System-
wide Settings > Process Engine 
Router URL 

{pe router url} 

NOTE The router name is case sensitive. 

Application Settings > System-
wide Settings > Content Engine 
Object Store Name 

{os display name} 

Application Settings > Web 
Application > Workplace 
Integration Servlet URL 

{workplace url}  

Language references: 

*| http://p8demo30:7001/Workplace/ 

This example indicates that the URL  

http://p8demo30:7001/Workplace/  

is to be used for all languages. Different URLs can be 
specified for particular languages; for example: 

{en-us|http://p8demo30:7001/WorkplaceEn/}  

{ru| http://p8demo30:7001/WorkplaceRu/}  

The language designations are the industry-standard 
designations used in web browsers. 

Workflow Configuration > 
Queues 

Change the object names for queues listed in this section 
to correspond to the isolated region in use (as determined 
by the router specified in the Application Settings > System-
wide Settings > Processing Engine Router URL).   

For example, if 26 is the isolated region, the object name 
for the Case Management queue would be 
“f_sw.VWVQ26_CaseManagement.”   

Change or view a queue’s object name by right clicking on 
the queue in question and selecting Properties. 

Workflow Configuration > 
Queue Filters 

(for Process Engine 
implementations using SQL 
Server only) 

Verify that the “NOLOCK” option is utilized in all queue filter 
SQL queries.   

For example:  SELECT COUNT(UserID) FROM Users 
WITH (NOLOCK) WHERE Username LIKE 'smith'.    

This option is necessary to reduce or eliminate deadlock 
contention.   

Change or view a queue filter’s SQL query by right clicking 
on the queue filter in question and selecting Properties. 

Workflow Configuration > 
Queue Filters 

(for Process Engine 
implementations using Oracle 
only and DB2) 

Verify that the “NOLOCK” option is not utilized in all queue 
filter SQL queries.  This syntax is not valid for Oracle. 

Change or view a queue filter’s SQL query by right clicking 
on the queue filter in question and selecting Properties. 
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Setting Value 

Miscellaneous > Inbasket 
Filters > Company Name 

(for Oracle implementations using 
the Case Management Sample 
Application manifest only) 

Change the Company Name regular template to be:  

UPPER(CompanyName) LIKE UPPER('%PARAM1%') 

Change or view the Company Name regular template by 
right-clicking on Company Name, selecting Properties, and 
clicking on Expression within the Regular area. 

Miscellaneous > Inbasket 
Filters > Account Number 

(for Oracle implementations using 
the Case Management Sample 
Application manifest only) 

Change the Account Number regular template to be:  

UPPER(AccountNumber) LIKE UPPER('%PARAM1%') 

Change or view the Account Number regular template by 
right-clicking on Account Number, selecting Properties, and 
clicking on Expression within the Regular area. 

 

Define Metastore Roles 
Define roles within BPF Explorer.  

Click on User and Access Information > Roles.   

These roles correspond to LDAP groups or Workplace access roles depending on Metastore settings.   

Further linking information is provided on the role properties screen in BPF Explorer. 

Configure BPF Explorer For Multiple Metastores 
This step can be skipped if BPF Explorer is to access only one BPF Metastore. 

By default BPF Explorer accesses the metastore specified during the BPF Explorer installation.  If 
configured for multiple metastores in the manner specified below, BPF Explorer presents a dropdown 
menu of metastores to the user as part of the BPF Explorer logon. 

Find the Windows registry information that controls metastore access: 

1. Open the registry editor: Start menu > Run.  Enter regedit.  Press OK. 

2. Find the following key: My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\FileNet Business 
Process Framework.  Under this key there should be a Common key. 

For each metastore do the following: 

a. Create an ODBC connection for the metastore: Start menu > Programs > Administrative 
Tools > DataSources (ODBC).   

b. Select the System DSN tab.   

c. Select Add.   

NOTE  An ODBC connection already exists for the metastore specified during BPF Explorer 
setup.   

d. In the registry editor export the common metastore settings:  

e. Click on Common.   

f. Select Registry > Export Registry File.  
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3. Change the following in the exported registry file: 

• Key name.  For example, change HKEY_LOCAL_MACHINE\SOFTWARE\FileNet Business 
Process Framework\Common to HKEY_LOCAL_MACHINE\SOFTWARE\FileNet 
Business Process Framework\Metastore1.  The key name determines the name of the 
metastore as shown to the user in the logon dropdown menu.  In the above example 
“Metastore1” would appear as one of the metastore choices. 

• DATABASE_CONNECTION_STRING.  Change the DSN to reference your ODBC DSN.  
NOTE This value is used by the WFImport.exe utility.  It requires that both UID and PWD be 
present as the WFImport.exe utility has no ability to ask for this information as user input at 
runtime.  We do not regard this as a security risk, however, since WFImport.exe is a tool that 
is typically used only during the development phase of a project.  The WFImport.exe should 
use ODBC on both Oracle and MSSQL configurations.  That is the only supported 
connectivity type for this utility. 

• BP8_EXPLORER_DATABASE_CONNECTION_STRING.  Change the DSN to reference 
your ODBC DSN.  NOTE This value should be configured to use ODBC on Microsoft SQL 
Server and OLEDB on Oracle.  Issues have been known to occur with Oracle ODBC drivers 
and it has been determined that, on Oracle platforms, OLEDB should be used for 
BP8_EXPLORER_DATABASE_CONNECTION_STRING and ODBC for 
DATABASE_CONNECTION_STRING. 
 

4. Import the edited registry file: Registry > Import Registry File. 

NOTE  Do not delete HKEY_LOCAL_MACHINE\SOFTWARE\FileNet Business Process 
Framework\Common. 
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Install and Configure the BPF Web Application  
Running the BPF Web Application Installer (GUI) 
Before running the BPF Web Application Installer program, Content Engine, Process Engine, and 
Application Engine should all be running and operational. The following steps launch InstallShield 
Wizard used to install the BPF Web Application. This user interface prompts for the site-specific 
information needed to install the BPF Web Application. Refer to your completed BPF Prerequisite 
Worksheet for the information needed.  

The steps for installation are: 

1. Start the BPF Setup wizard: 

• AIX - Navigate to /{staging folder}/setup/ and execute AIXfilenet_BPF_setup.bin. 

• HP-UX - Insert and mount the BPF CD. Navigate to /<staging folder>/setup/ and execute 
HPUXfilenet_BPF_setup.bin. 

• Solaris - Insert and mount the BPF CD. Navigate to /<staging folder>/setup/ and execute 
SOLARISfilenet_BPF_setup.bin. 

• Windows - Insert the BPF CD. Navigate to \<staging folder>\setup\ and execute 
WINDOWSfilenet_BPF_setup.exe.  

Respond to the setup wizard prompts. 

 
Figure 1--Welcome Screen 
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2. Click Next. 
The License Agreement screen appears. 

 
Figure 2--License Agreement Screen 

3. Review and accept the FileNet End User Software License Agreement, and click Next. 
The Custom Vs Typical Installation screen appears. 

 
Figure 3--Custom Vs Typical Installation Screen  
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4. Choose either a typical or custom installation based on what best suits the needs of the 
environment being installed. 

Typical  
When using the Typical option, the system assumes that the following items are to be 
automatically installed.   

• BPF Web Application 

• BPF Operations - Component Manager Component 

• Case Management Sample Application 

NOTE When performing a new installation on a development system, the Typical option 
should be used as there is not yet a custom application to install or deploy, and the Case 
Management Sample application is used to test that BPF is fully functional.  

Custom 
The Custom option allows the installer to individually select the components that should be 
installed. This is helpful when you need to: 

• Re-install a specific component that failed 

• Perform a BPF version upgrade (and perverse existing configuration), see the Upgrade 
section of this document for more information. 

• Perform an installation with custom configuration files.  

5. Select the installation type, and click Next. 

If you selected a Custom Installation the following screen appears: 

 
Figure 4—Custom Installation Feature Selection Screen 
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There are four check boxes on this screen.  Three boxes are already checked.  These three 
options are equivalent to performing the ‘Typical’ option. You can choose any combination of 
boxes to customize your installation.  When you click next, you are presented with options related 
to the boxes that are checked.   

BPF Web Application 
If selected, the BPF Web Application is installed. The BPF Web Application is a user interface that 
provides access to work by users. The BPF Web Application's user interface is highly configurable 
and is generated dynamically based on a user's role. Depending upon install choice made in 
subsequent installer screens, you get WAR file or EAR file or exploded folder format under install 
location.   

BPF Operations – Component Manager Component 
If selected, the BPF Operations Java Adapter for P8 Component Integrator is installed. BPF 
Operations is a P8 Component Integrator component that allows manipulating BPF Case object from 
a workflow component step. 

Case Management Sample Configuration 
If selected, the BPF Case Management same configuration files are copied to the BPF system being 
installed. This includes the Case Management Sample Application Content Engine Manifest, the PEP 
files, the Isolated Region Manifest.  

NOTE You are changing the configuration associated with the BPF environment and could potentially 
be overriding an existing configuration. 

User-defined Configuration 
If selected, you are prompted to supply site-specific configuration files as well as a location for custom 
code files to be copied into the BPF environment.  

NOTE You are changing the configuration associated with the BPF environment and could potentially 
be overriding an existing configuration. 

 
See following three screenshots for User–defined configuration choices. If User-defined Configuration 
is not selected, you can skip to Step 7, the Directory Name screen. 
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Figure 5—User Defined Configuration Screen  

6. Enter path information to the Custom CE Manifest Import XML file, the Custom Queue Config 
XML file, and the Custom Workflow Definition PEP Or XML File.  

NOTE This screen appears only if you selected User-defined Configuration. 

7. Once all fields are populated, Click Next.  

The custom code screen appears. 

 
Figure 6—Custom Code Folder Screen  
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This entry allows you to identify custom code that you wish to deploy with BPF. It requires that 
you have already created a folder that contains the custom code, and that your custom code 
folder structure exactly replicates the BPF Web Application folder structure. If you do not have 
any custom code to install you can leave this field empty. 

During the installation the contents of the custom code folder overlays the BPF Web Application 
folder, and this is why it is mandatory that they have the same folder structure. Any modules, 
including JSP, JAR, or XML files specified in the “Custom Code” folder is bundled as part of BPF 
WAR/EAR. 

NOTE This screen appears with Typical Installation Feature. With Custom Installation Feature 
Selection this screen will appear only if BPF Web Application feature is checked. 

8. Enter the path to custom code folder, if applicable. Click Next to continue. 

The Directory Name screen will appear. 

 
Figure 7—Directory Name Screen 

9. You can enter or browse to the location where you want to install the BPF software or accept the 
following default locations: 

• UNIX - /opt/FileNet/BPF 

• Windows - C:\Program Files\FileNet\BPF 

10. Click Next. 

The Select target Web Application Server Type screen will appear. 
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Figure 8—Select target Web Application Server Type Screen  

Based on the Web Application Server type selected, the following deployment options will be 
provided. Not all deployment options are available for all Web Application Server Types. 
Depending on the Web Application Server Type selected, some of the deployment options will be 
disabled.  

NOTE This screen will only appear if you checked BPF Web Application feature from Custom 
Installation Feature Selection Screen. 

The following combinations are valid: 

• Deploy BPF as WAR file (available for WebSphere, Oracle Application Server, or JBOSS) 

• Deploy BPF as EAR file (available for WebSphere only) 

• Deploy BPF as folder (available for WebLogic, or JBOSS) 

11. Check the radio buttons that match your deployment preference, and click Next. 

The Web Application Server Identification screen will appear. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 
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Figure 9—Web Application Server Identification screen  

 

12. Enter the Web Application Server Host Name {web application server} and the Web Application 
Server Port Number {web port}, and click Next. 

The Web Application Name screen will appear. 

 
Figure 10—Web Application Name Screen 



IBM FileNet Business Process Framework Installation Guide 
Install and Configure the BPF Web Application 
 

 

© Copyright IBM Corp. 2006, 2009  65 

13. Enter the Web Application Name. This becomes the file name for the deployment file or folder 
created by the Installer (example bpf.war). Click Next to continue.  

The DataSource Information screen will appear. 

 
Figure 11—DataSource Information Screen 

In this step, the DataSources have to be created and tested prior to proceeding to next screen.  
These should have been previously created and tested in the Environment Configuration section. 
BPF Installer will not perform DataSource name validation. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 

14. Provide the Process Engine JDBC DataSource name {pe datasource} and the BPF Metastore 
DataSource name {meta datasource}, and then click Next.  

The Administrator Logon and Password Information screen will appear. 
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Figure 12—Administrator Logon and Password Information screen  

The LDAP server logon and password, {ce admin user} and {ce admin password}, should be 
entered here. They will be used to login to Content Engine and Process Engine in order to import 
manifest and transfer work flow definition to Process Engine. 

15. Provide the required information and click Next. 
The Content Engine Java API Configuration screen will appear. 

 
Figure 13—Content Engine Java API Configuration screen  
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The Content Engine information you provide here will be used to update the 
“WcmApiConfig.properties” file in BPF Web Application. 

16. Provide the requested information, and click Next. 
The Workplace Location screen will appear. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 

 
Figure 14—Workplace Location Screen 

17. Enter or select the Workplace folder directory, select either HTTP or HTTPS, and click Next. 
The Router Location Screen will appear. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 
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Figure 15—Router Location Screen 

18. Enter or select the Router Configuration directory, and click Next. 
The Application Engine User Security Screen will appear. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Operations feature is checked. 

 
Figure 16—Application Engine User Security Screen 
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The Application Engine information you provide here will be used to update the 
“WcmApiConfig.properties” file in BPF Web Application. 

19. Provide Application Engine user security information as follows: 
 
NOTE Setting Clear encoding for CredentialsProtection/UserToken will result in 
nuisance logins from AE/Workplace and should be avoided.  For practical purposes, Symmetric 
encoding should be used under all circumstances. 

a. Select credentials protection, the encryption method to protect user logon credentials passed 
between Application Server and the Content Engine: 

o Clear encoding - encodes credentials using base 64 encoding. 

o Symmetric encryption - uses cryptography keys to encrypt and decrypt user credentials. 

o BPF Installer program will update 
"CredentialsProtection/UserToken=Symmetric or Clear" entry in the BPF 
"WcmApiConfig.properties" file. 

b. Enter the crypto key file path. This path should point to the same file as Workplace.  
BPF Installer will update the entry in the "WcmApiConfig.properties" file. 

20. Click Next.   
The User Token Security screen will appear. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 

 

 
Figure 17—User Token Security Screen 
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The Application Engine information you provide here will be used to update the 
“WcmApiConfig.properties” file in BPF Web Application. 

21. Provide Application Engine user security information as follows: 

a. Select credentials protection, the encryption method to protect user logon credentials passed 
between Application Server and the Content Engine: 
 
NOTE Setting Clear encoding for CredentialsProtection/UserToken will result in 
nuisance logins from AE/Workplace and should be avoided.  For practical purposes, 
Symmetric encoding should be used under all circumstances. 

o Clear encoding - encodes credentials using base 64 encoding.   

o Symmetric encryption - uses cryptography keys to encrypt and decrypt user credentials. 

o BPF Installer program will update 
"CredentialsProtection/UserToken=Symmetric or Clear" entry in the BPF 
"WcmApiConfig.properties" file. 

b. Enter the crypto key file path. This path should point to the same file as Workplace.  
BPF Installer will update the entry in the "WcmApiConfig.properties" file. 

22. Click Next.   
 
The Application Engine Router Configuration Screen will appear. 

 
Figure 158—Application Engine Router Configuration Screen 

Information you provide here will be used to import the workflow definition and copy queue 
definition to the Application Engine. 

23. Enter the Application Engine Router information requested, and click Next.  

The Documentation Server URL screen will appear. 
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NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 

 
Figure 169—Documentation Server URL Screen  

NOTE  In this step, your entry must be in the following format: 

http://<docserver:port#>/<BPF_help>/ 

where: 

docserver is the name of the Java web server. 

port# is the port number. 

BPF_help is the root folder of the documentation website. 

24. Enter the Documentation Server URL, which is where the BPF Documentation is installed, then 
click Next. 

The Upload and Download Directory screen will appear. 

NOTE This screen will appear with Typical Installation Feature. With Custom Installation 
Feature Selection this screen will appear only if BPF Web Application feature is checked. 
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Figure 20—Upload and Download Directory Screen  

25. Configure the Upload and Download Directory configuration as follows: 

a. Select the Upload Directory. 
 
(The Upload Directory is the directory used by BPF Web Application to store temporary 
copies of files uploaded to BPF. Leave the default option or browse for a directory to hold the 
temporary upload files.) 

b. Select the Download Directory. 
(The Download Directory is the directory used by BPF Web Application to store temporary 
copies of files downloaded from BPF. Leave the default option or browse for a directory to 
hold the temporary download files.) 
 
Click Next. 
 
The Product Install Summary screen will appear. 
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Figure 17—Product Install Summary Screen 

26. Verify the target installation location and features to be installed and click Install to begin the 
installation process. FileNet P8 Business Process Framework will be installed in the location 
shown. 

During BPF Web Application installation, the following progress bar will be displayed to indicate 
installation progress. Wait until the installation process is complete. 

 
Figure 18—Installation Progress Screen 
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The Product Install Completion screen will appear. 

 
Figure 19—Product Install Completion Summary Screen (with no errors) 

When the installation is complete, a summary screen is displayed which indicates the outcome of the 
installation process. If all components were successfully installed without error, you will receive the 
above message.  

If some components of the installation failed to install, the summary message will reflect the specific 
components that did not install. Refer to the following sections which describes these errors, the 
potential reason they did not install, and how install them manually. 

Select Finish to complete the installation.  

Verify that all software has been installed by checking the install folders with the table below: 

Folder/File Description 

{root}   

web/  Contains BPF Web Application EAR or 
WAR or Exploded folder format files. 
Web Application file format will depend 
upon the choices made while installing 
BPF Web Application. 

bpfops/  BPF Operation Component package. 

_uninstaller/  Uninstaller binary. Uninstaller binary will 
be used to uninstall BPF Web 
Application if required. 

_jvm/  Do not delete this folder. Uninstaller 
binary will use java run time program 
from this folder to uninstall BPF Web 
Application if required. 
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Folder/File Description 

 BPFInstaller.log Installer log file. 

 BPFInstallerAnt.log Installer creates this file to log output of 
Java Programs executed from installer 
binary in order to import BPF specific 
configuration to CE/PE. 

 logs/ This folder contains 
‘bpf_donot_delete.jar’ file. This JAR file 
contains temporary files used by 
installer to execute various java 
programs. Ignore it if install process was 
successful.   

 

Running the BPF Web Application Installer (Silent) 
You can install and configure BPF silently.  

Windows 
1. Log on to a Windows machine as a user who is a member of the local Administrators group. 

2. Insert the BPF installation CD in the CD drive. 

3. Copy the file BPF_silent_input.txt from the BPF installation CD to a local directory. 

4. Open BPF_silent_input.txt in the local directory with any text editor, edit it according to the 
instructions in the file itself, and save your edits. 

5. Open a DOS command-prompt window. 

6. Change your current directory to the BPF installation CD directory. 

7. Execute the following command, where E: is the drive assigned to the CD, and 
<response_file_path> is the directory path to BPF_silent_input.txt: 

E:\WINDOWSfilenet_bpf_setup.exe -options "<response_file_path>\BPF_silent_input.txt" -
silent 

NOTE Although the command above spans more than one line, type it without carriage returns. 

Check the file BPFInstaller.log, located in the <BPF install path> directory, to see if any errors 
occurred during the installation. 

UNIX 
Perform the following instructions to modify the BPF silent-install response file and launch the silent 
BPF install on a UNIX (AIX, HP-UX, or Solaris) machine. 

1. Log on to a UNIX machine as a user with write access to the /bin directory and read, write, and 
execute access to the directory where you plan to install. 

2. Mount the BPF installation CD in the CD drive. 

3. Copy the file BPF_silent_input.txt to a local directory. 

4. Open BPF_silent_input.txt in the local directory with any text editor, edit it according to the 
instructions in the file itself, and save your edits. 
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5. Change your current directory to the BPF installation CD directory. 

6. Execute the following command 

<directory of CD media>/<platform>setup.bin -options 
"<response_file_path>/BPF_silent_input.txt" -silent with these substitutions: 

7. Check the file BPFInstaller.log, located in the <BPF install path>, to see if any errors occurred 
during the installation. 

8. Verify that all software has been installed by checking the install folders with the table below: 

Folder/File Description 

{root}   

web/  Contains BPF Web Application EAR or 
WAR or Exploded folder format files. 
Web Application file format will depend 
upon the choices made while installing 
BPF Web Application. 

bpfops/  BPF Operation Component package. 

_uninstaller/  Uninstaller binary. Uninstaller binary will 
be used to uninstall BPF Web 
Application if required. 

_jvm/  Do not delete this folder. Uninstaller 
binary will use java run time program 
from this folder to uninstall BPF Web 
Application if required. 

 BPFInstaller.log Installer log file. 

 BPFInstallerAnt.log Installer creates this file to log output of 
Java Programs executed from installer 
binary in order to import BPF specific 
configuration to CE/PE. 

 logs/ This folder contains 
‘bpf_donot_delete.jar’ file. This JAR file 
contains temporary files used by 
installer to execute various java 
programs. Ignore it if install process was 
successful.   
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Troubleshooting Errors Identified during Installation 

GUI Mode 
During the automatic installation process, there are connections to various system components to 
import and configure data and parameters. If any errors occur during the installation process, (for 
example if the CE server is not responding) the installer will continue to install other components and 
will show error messages when the installation completes, as in the example below.  

 
Figure 20—Product Install Completion Summary Screen (with Errors) 

The following tables summarize the errors that can occur in the automated installation process. It 
includes the general cause of the problem, and a pointer to the specific section, located under the 
heading “Troubleshooting” in this document, which describe how to manually install the step that did 
not install. 

Silent Mode 
Search for Error key word from “BPFInstaller.log” file. The following table summarizes the errors that 
can occur in the Silent installation process. It includes the general cause of the problem, and a pointer 
to the specific section, located under the heading “Troubleshooting” in this document, which describe 
how to manually install the step that did not install. 

Error In Base Manifest or Case Management Manifest 

Error Message Problem Solution 

Non-critical exception encountered 
while installing Base Manifest to 
Content Engine Object Store.  

The Content Engine Base 
Manifest was not imported. 

 

Refer to Import Content 
Engine Base Objects. 
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Non-critical exception encountered 
while installing Case Management 
Manifest to Content Engine Object 
Store.  

The Content Engine Case 
Management Manifest was 
not imported. 

Refer to Import Content 
Engine Solution-Specific 
Objects. 

Error In Custom Objects Import In Content Engine 

Error Message Possible Problem Solution 

Non-critical exception encountered 
while installing Custom Manifest to 
Content Engine Object Store.  

The custom CE manifest 
import XML file was not 
imported. 

Use Enterprise Manager to 
import it manually. Refer to 
the FileNet P8 Platform 
documentation for the import 
procedure details. 

Error In Base Or Solution Specific Workflow Object Creation 

Error Message Possible Problem Solution 

Non-critical exception encountered 
while installing Base Workflow 
Queue Configuration.  

Certain base and solution specific 
workflow objects were not created. 

This might happen if the PE server 
was not responding. 

Create Base Workflow 
Object manually.  

Non-critical exception encountered 
while installing Case Management 
Workflow Queue Configuration.  

This might happen if the PE server 
was not responding. 

Create Solution 
Specific Workflow 
Object manually. 

Error In Custom Workflow Object Creation 

Error Message Possible Problem Solution 

Non-critical exception 
encountered while installing 
custom Workflow Queue 
Configuration. 

An error occurred during custom 
workflow object creation 
regarding the custom CE 
manifest import XML file. 

Refer to the FileNet P8 
Platform documentation to 
create workflow object 
manually. 

Error In Updating Solution Specific Process Map 

Error Message Possible Problem Solution 

Non-critical exception encountered 
while installing Case Management 
Workflow Transfer. 

An error occurred while installing the 
case management process map. 

Refer to Update 
Process Map. 
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Error In Updating Custom Process Map 

Error Message Possible Problem Solution 

Non-critical exception 
encountered while installing 
Custom Workflow Transfer. 

An error occurred while 
installing the Custom 
Workflow Transfer process 
map. 

Refer to the FileNet P8 Platform 
documentation to create process 
map manually. 

Error In Updating Taskman Policy File 

Error Message Possible Problem Solution 

Non-critical exception encountered 
while updating application engine 
taskman policy file. 

The taskman policy file in router folder 
was not updated. 

Refer Edit Taskman 
Policy. 

Error In Updating Taskman Login Configuration 

Error Message Possible Problem Solution 

Non-critical exception 
encountered while updating 
application engine taskman 
login configuration. 

The taskman login configuration in router 
folder in AE installation folder was not 
updated. 

Refer to Edit 
Taskman Login 
Configuration. 

Error In Updating vwtaskman.xml File 

Error Message Possible Problem Solution 

Non critical exception 
encountered while updating 
vwtaskman.xml.  

The vwtaskman.xml configuration in 
router folder in AE installation folder was 
not updated. 

Manually update 
vwtaskman.xml.  

Error In Updating taskman.properties File 

Error Message Possible Problem Solution 

Non critical exception 
encountered while updating 
taskman.properties. 

The taskman.properties configuration in 
router folder in AE installation folder was 
not updated. 

This might happen if provided 
Application Engine information was not 
correct. 

Manually update 
taskman.properties. 
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Error In Updating Workplace Integration Files 

Error Message Possible Problem Solution 

Non critical exception 
encountered while copying 
Bp8ViewActions.jsp to 
Workplace or updating 
Actions.xml, infopages.xml, 
Integration.xml. 

The Workplace files for BPF were not 
updated. 

 

Manually update 
Workplace files per 
instructions in the 
section entitled, 
Workplace Integration. 
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BPF Deployment 
Deploy BPF Web Application 
This step registers BPF as a Web Application with the Web server. 

IBM WebSphere 6.0 
NOTE Do NOT change the class loader mode from the default PARENT_FIRST setting.  Changing 
this to PARENT_LAST prevents BPF from working. 

1. Install BPF Web Application (WAR or EAR) as follows: 

a. Verify that the app_name.war or app_name.ear file was created before you continue. 

b. From the WebSphere Administrative Console, expand Applications.  

c. Click Install New Application.  

The "Preparing for the application installation" dialog opens. 
 
(If the Administrative Console is running locally) Select Local Path and browse to the location 
of the app_name.war or app_name.ear file created by the setup program.  
 
The default path is:  
UNIX - /opt/FileNet/BPF/web/ 
Windows - C:\Program Files\FileNet\BPF\web\  
 
NOTE Do not enter the machine name. 
 
(If the Administrative Console is remote) Select Remote File System and enter the fully-
qualified path to the app_name.war or app_name.ear file.  
 
NOTE Do not enter the machine name. 

2. Enter BPF and click Next to proceed to deploying a new application. 

a. Enter the context root as follows: 

NOTE The context root is the name of the application you log in to using the web interface, 
for example, http://<WebAApplicationServerName>:<port#>/<Context Root>. 

b. On the "Preparing for the application installation" screen, leave the defaults, and click Next. 

c. On the "Application Security Warning" screen, click Continue. 

d. At "Install New Application", Step 1, specify the application name.  
Enter BPF, or the name you chose to call the application, click Next. 

e. At "Install New Application", Step 2, Map modules to servers,  
specify the WebServer you are planning to use.  
Check BPF and click Next.  

f. At "Install New Application", Step 3, Map Virtual Hosts for Web Modules,  
check BPF, keep the default virtual host (default_host), and click Next. 

g. At "Install New Application", Step 4, verify your configuration and click Finish.  

h. Once the configuration is saved, click Save to Master Configuration. 
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3. Stop and restart the application server, (and restart the HTTP server, if installed). 

4. Start the Enterprise Application as follows: 

a. From the Administrative Console, expand Applications.  

b. Click Enterprise Application  to the left of the BPF (or whatever you named it) application, and 
click Start. 

BEA WebLogic 8.1.X 
1. Start the application server. 

2. From the WebLogic Server Console, <mydomain>, expand Deployments, and click   
Web Application Modules. 

3. Click Deploy a new Web Application Module. 

4. From the right pane of the WebLogic Server Console, browse to and select the radio button for 
the BPF folder in the <path to folder location>. 

The default path is: 

UNIX - /opt/FileNet/BPF/web/ 

Windows - C:\Program Files\FileNet\BPF\web\ 

5. Click Target Module and select BPF. 

6. Verify that the Name field has the value BPF. 

7. Click Deploy. 

NOTE To verify that the deployment was successful, expand Web Applications. The web 
application BPF will be listed. 

JBOSS 
NOTE  If you are running JBOSS as a service, make sure that the following directory path is 
included as a parameter in the command issued to the java service executable: 
 

"-Djava.endorsed.dirs=%JBOSS_ENDORSED_DIRS%" 
 

where JBOSS_ENDORSED_DIRS environment variable is set to = 
%JBOSS_HOME%\lib\endorsed 

BPF installed as folder 
1. On the JBOSS server, copy the {web application name} folder 

from: <BPF_Install_Path>/web/  
to: <JBOSS_HOME>/server/default/deploy/ 

2. Append the extension ".war" to the {web application name} folder copied under 
<JBOSS_HOME>/server/default/deploy/:  

<JBOSS_HOME>/server/default/deploy/{web application name}.war 

3. Start the application server. 
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BPF installed as WAR 
1. On the JBOSS server, copy the {web application name}.war 

from: <BPF_Install_Path>/web/  
to: <JBOSS_HOME>/server/default/deploy/ 

2. Start the application server. 

Oracle Application Server/SQL Server 

JVM memory setting 
1. Start the Oracle Application Server. 

2. From the Oracle Admin Console, select the OC4J Instance you previously created.  

a. In the OC4J admin window that opens, click Administration. 

b. Under Instance properties, click Server properties. 

c. Under Command Line Options, edit the Java Options field. 

Set your JVM memory settings by appending a minimum (-Xms<value>m) and maximum  
(-Xmx<value>m) value to the entries in the field. 
 
CAUTION: By default the Oracle Xmx entry is set to 256 Mb. This is too small to successfully 
deploy the BPF application. Oracle recommends setting the Xmx entry to 512 Mb. For more 
information, see the Oracle® Application Server Administrator’s Guide, chapter J.3.2.5 
Problems Deploying Large OC4J Applications. 
 

d. Click Apply to apply the settings. 

e. When prompted, click Yes to restart your OC4J server instance. 

f. Click OK to close the confirmation window. 

3. After the restart, from the console, verify that your HTTP server has been started. If not, start it 
now. 

SQL Server JDBC Driver jar files 
NOTE Only DataDirect Type4 JDBC driver for SQL Server is supported in Oracle Application Server.  
 
1. Copy the following three jar files into C:\ORACLE_HOME\j2ee\OC4JInstance\applib directory of 

your OC4J instance. 

• sqlserver.jar 

• util.jar 

• base.jar 

Deploy and configure the BPF application. 
1. In the console, select the OC4J Instance where you want to deploy the war file. 

2. Select the Applications tab. 

3. Click Deploy War File. 

4. Browse to and select the BPF application .war file from <BPF_Install_Path>/web/ folder. 

5. Provide an Application Name (for example, bpf). 
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6. Provide a map to URL value (for example, /bpf). 

7. Click Deploy. 

8. Once the application successfully deploys, click OK. 

Class loading settings 
After deployment, you must set the OC4J instance to allow for the loading of local classes first. 

1. In the console, click the OC4J instance you created. 

2. Click Applications. 

3. Under Deployed Applications, click the BPF application link (or the application name specified 
during deployment). 

4. Under Web Modules, click bpf. 

5. Under Administration, click Advanced Properties. 

6. Use the Edit orion-web.xml field to enable class loading by un-commenting the following line: 
 
<web-app-class-loader search-local-classes-first="true" include-war-manifest- classpath=" 
true" /> 

7. Click Apply to save the changes. 

8. When prompted, click Yes to restart your OC4J server instance. 

9. Click OK to close the confirmation window. 

Deploy BPF Help 

IBM WebSphere 
1. Install BPF Help as follows:  

 
From the WebSphere administrative console, 

a. Click on Applications > Enterprise Applications > {web BPF name}. 

b. Look at the Application binaries field. Record the path as {web BPF install path} on 
your worksheet. For example: $(APP_INSTALL_ROOT)/bp8demo35Node01Cell. 

c. Click on Applications > Enterprise Applications > Install. 

d. Specify path for Local file system: {staging folder}/documentation/BPF_help.war. 

e. Enter Context Root: {web BPF help name}. 

f. Press Next or Continue until Install New Application screen is reached.  

g. Enter the following: 

i. Directory to install Application: {web BPF install path}. 

ii. Application Name: {web BPF help name}.  
(For example: BPF Help. Record from your worksheet.) 

h. Click Next or Continue until final step is reached.  

i. Click Finish. (A success message should be displayed.) 
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j. Click Save to Master Configuration. 

k. Click Save. 

2. Confirm that BPF Help functional as follows: 

a. From the WebSphere administrative console under Applications > Enterprise 
Applications: 

i. Check-mark {web BPF help name}. 

ii. Click Start. 

b. Invoke help: http://{web application server}:9080/{web BPF help name}. 

BEA WebLogic 
1. Install BPF Help as follows: 

 
From the WebLogic administrative console: 

a. Click Deployments > Web Application Modules. 

b. Click Deploy a new Web Application Module. 

c. Click Upload your files. 

d. Browse... for {staging folder}/documentation/BPF_help.war. 

e. Click Upload. 

f. Select BPF_help.war and click Target Module. 

g. Enter Name: {web BPF help name}.  
(Record on your worksheet.) 

h. Click Deploy. 

2. Confirm BPF Help is functional as follows: 

a. Invoke help: http://{web application server}:7001/{web BPF help name}. 

JBOSS 
1. Copy the help directory  

from: {staging folder}\documentation\BPF_help  
to: JBOSS directory ..\server\default\deploy. 

2. Rename help directory  
from: JBOSS directory ..\server\default\deploy\BPF_help  
to: JBOSS directory ..\server\default\deploy\{web BPF help name}.war 

3. Restart JBOSS 

4. Confirm BPF help is functional by invoking:  

{application server}:8080/{web BPF help name} 

Oracle Application Server 
1. In the console, select the OC4J Instance where you want to deploy the war file. 

2. Select the Applications tab. 

3. Click Deploy War File. 
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4. Browse to {staging folder}/documentation/BPF_help.war. 

5. Provide an Application Name {web BPF help name}. 

6. Provide a map to URL value (for example, /bpf_help). 

7. Click Deploy. 

8. Once the application successfully deploys, click OK. 

Configure BPF Operations 
The JDBC DataSource configuration and roster configuration file (bp8_config.xml)is distributed 
inside the bp8ciops.jar file. 

Set the following XML elements as indicated: 

• User: {meta user} 

• Password: {meta password} 

• Database: {meta database} 

• Server: {meta data server} 

NOTE The appropriate <JDBC> section might need to be uncommented for your database.  
Furthermore, because XML parser errors can occur when using BPF_Operations with Oracle if the 
JDBC node for MSSQL is just commented out, the node for MSSQL should be deleted altogether 
from the bp8_config.xml file contained in bp8ciops.jar. 

Oracle 
• Set the DBType to Oracle. 

• Download classes12.jar from Oracle web site and copy it under 
{install.home}/bpfops/lib folder 

• Add classes12.jar and sqlJDBCDriver_stub.jar to vwtaskman.xml in the following manner. 

a.       Start the AE router (using routercmd). 

b.       Stop the Component Manager (in the AE Router). 

c.       Go to the Required Libraries tab. 

d.       Add classes12.jar and sqlJDBCDriver_stub.jar library listed above. 

Microsoft SQL Server 
• Set the DBType to msSQL.  

• Download jtds-0.8.jar JAR from SourceForge.net (http://sourceforge.net) and copy it 
under {install.home}/bpfops/lib folder 

• Add jtds-0.8.jar and oracleJDBCDriver_stub.jar to vwtaskman.xml in the following manner. 

a.       Start the AE router (using routercmd). 

b.       Stop the Component Manager (in the AE Router). 

c.       Go to the Required Libraries tab. 

d.       Add jtds-0.8.jar and oracleJDBCDriver_stub.jar library listed above. 

http://sourceforge.net/
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DB2 
Not supported for BPF Meta database. 

Edit BPF Operations Component Queue 
1. Run P8 Workplace > Admin > Process Configuration Console, right-click on the router icon 

for your Isolated Region and choose Connect. 

2. Open the Server node for your PE Server, right-click on the Component Queues node, and 
select the Register Additional Classes… menu item from the resulting context menu. 
 

 
3. Using the Jar File Locations tab on the resulting Component Registration dialog that appears, 

navigate to the classes12.jar and jtds-0.8.jar files used by BPF_Operations and add them.  
Then click OK. 
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4. Now right-click on the BPF_Operations component queue node and select Properties… from 

the context menu.  Then click on the Adaptor tab of the resulting property page dialog.  Make 
sure that Java Component is selected in the Adaptor dropdown, then click on the Configure 
button (ignoring any error regarding class introspection), navigate to the bp8ciops.jar file that 
BPF_Operations is using and select it. 
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5. You will now see a list of all of the available public methods in exposed by the Bp8Operations 
class.  Make whatever changes are required (noting that you will not be able to remove methods 
once they have been exposed and configured).  Then click OK. 
 

 
6. To configure individual operations that have been exposed here, click on the Operations tab 

next.  Make whatever changes are required, then click OK. 
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7. Commit your changes to isolated region by right-clicking on your router node and selecting 
Commit Changes from the context menu. 
 

 
8. Start Process Task Manager > Component Manager. 

9. Start Process Task Manager > Component Manager > BPF_Operations. 

NOTE See BPF Operations Logging Modification for the various logging options. 

Verify BPF Operations Component 
Start the FileNet P8 Platform Task Manager and verify that the BPF Operations component is started 
in Component Manager. 
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Configuration Tasks 
Configure Stored Searches 
Configure custom object type searches for Case search. 

NOTE Search templates need to be configured and stored in the CE repository in order for Search 
and Attach Document tool to function. 

Simple Search Configuration 
1. Using Enterprise Manager, create a folder for holding search templates and stored searches.  

For example: Object Stores > {os display name} > Root Folder > BPF > Searches. 

9. Using Search Designer (invoked from Workplace), create a search template. 
For example: 

a. Object Stores tab: Select {os display name}. 

b. Object Types tab: Check mark Custom Object. 

c. Object Types tab: Click Update Subclass. 

d. Object Types tab: Under View, select Editable. 

e. Object Types tab: Under Object Subclass, select the appropriate child class of Bp8Case (for 
the Case Management sample application, this would be Case Management). 

f. Search Criteria tab: Under View, select Editable. 

g. Search Criteria tab: Under Property, select Bp8CaseID. 

h. Search Criteria tab: Under Operator, select  “is equal to” 

i. From menu: File > Add New... 

j. Browse for your search folder. 

k. Enter Document Title: BPF Case ID Search. 

l. Click Next. 

m. Click Finish. 

10. Using Enterprise Manager, get the GUID for the folder containing the search templates. (This is 
achieved by right-clicking on the folder in question, selecting Properties, selecting the Properties 
tab, selecting All Properties as the filter, and copying the Property Value for the ID property. Save 
the GUID to a temporary file). 

11. Find {BPF Root}\WEB-INF\Toolbar.xml.  

a. Find the item section that starts with  
<Item Caption='Search' Name='Search' SearchMode='no'> 

b. Within that item section find the <Action> section with the "invokeWorkplaceObject" call. 
The first parameter in the "invokeWorkplaceObject" is a GUID.   

c. Substitute the current GUID with the GUID for your search folder.  NOTE  If the 
invokeWorkplaceObject method is used to invoke versionable content in CE (for example, if 
you choose to configure it to point to an actual Search Template or other document rather 
than a Folder in which Searches are stored), you will need to change the GUID value here 
whenever a new version of the content is created.  Otherwise, invokeWorkplaceObject will 
continue to invoke the old (original) version. 

d. Save the changes. 
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12. Restart the BPF Web Application within the Web Application server. 

13. Test the Search functionality when you log onto BPF (in later steps). 

Set Content Engine Security 
BPF Installer imports BPF specific data model files to the object store. After you have imported the 
required data model files to the object store, you must set the following security permissions as 
indicated below.  

NOTE LDAP role groups refer to the LDAP groups that correspond to BPF Metastore roles. 

NOTE Restart the content engine application server after applying following permissions on BPF 
specific classes and objects. 
 

Groups Security Permission Sets Default Instance Security 
Permission Sets 

Object Stores Realm (Top-level EM root node) 

Administrative users or groups Full Control  

#AUTHENTICATED-USERS 
(or LDAP role groups) 

Use stores and services  

{os display name} 
Root Node 

Administrative users or groups Full Control  

#AUTHENTICATED-USERS 
(or LDAP role groups) 

Use Object Store  

{os display name} > Other Classes > Custom Object 
• Bp8Object 

Administrative users or groups Full Control Full Control 

LDAP role groups Modify Properties Modify Properties 

{os display name} > Other Classes > Custom Object > Bp8Object 
• Bp8Attachment 

• Bp8AuditLogItem 

• Bp8Case and subclasses 
NOTE Each subclass can have different LDAP role groups assigned. 

NOTE If changing security on the object store with the object instances is already present, apply the 
Default Instance Security to existing instances of the classes listed above. 

Administrative users or groups Full Control Full Control 

LDAP role groups Modify Properties Modify Properties 
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Groups Security Permission Sets Default Instance Security 
Permission Sets 

{os display name} > Root Folder > BPF 
• Bp8Settings object instance [search for id = B4DF1A0E-CB28-4979-B34B-

F997F9E30E3D] 

NOTE This is the object instance, not the Bp8Settings class. 

Administrative users or groups Full Control  

LDAP role groups Modify Properties  

{os display name} > Root Folder > BPF 
• Site Layout folder 

Administrative users or groups Full Control  

LDAP role groups Modify Properties  

{os display name} > Document Class 
• Document Class(es) 

NOTE Each document class can have different LDAP role groups assigned. 

NOTE Users should be able to create and update document properties. 

Administrative users or groups Full Control Full Control 

LDAP role groups Modify Properties Modify Properties 
 

 

Optional Configuration Tasks 
Set Tuning Parameters 
TIP Temporarily Turn Off Metadata Cache. When configuring the system, turn Metadata cache off in 
BPF Explorer: Application Settings > Enable Metadata cache = False. 

NOTE When Metadata cache is enabled, BPF Explorer changes will take effect only after the Web 
Application is restarted.  

Set the following parameters: 

• Case ID – Reset the Case ID back to 1 with each release or set it to a particular starting 
number. To make that change, locate the Settings object in the Root Folder > BPF folder in 
the CE repository and set the Bp8LastCaseID to a desired number. 

• IE Cache Setting – Set the IE cache setting to automatic on user desktops to achieve best 
performance. To verify or correct the browser settings, open Tools > Internet Options > 
General tab > Settings and make sure the Check for newer versions of stored pages is set 
to Automatically. 

IBM WebSphere 
Set the HTTP Connection Timeout parameter as follows: 

1. Increase the HTTP connection timeout from the default 5 seconds to 10 seconds or more. 
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2. Modify ConnectionIOTimeout and ConnectionKeepAliveTimeout parameters in WebSphere.  

Changing these parameters is required to resolve timeout and xml parsing errors that might be 
observed on a slow or busy network connections.  

3. Follow the instructions in the link: 

http://www-
912.ibm.com/s_dir/slkbase.NSF/c1309d212e616c9f862569ec0070adc1/ 
b5eae9f64fa6e77286256e4e008025d3?OpenDocument 

BEA WebLogic 
1. Set JVM heap minimum and maximum settings to an equal number.  

(This will minimize the negative performance effects of the garbage collection in java. ) 

2. Set the heap size to 256Mb or more on the production installation. 

Index Content Engine Objects 
The following properties in the CE object store need to be indexed: 

Object Index field name 

Bp8Attachment Bp8ObjectGUID 

Bp8Attachment Bp8Attachment_Bp8Case 

Bp8AuditLogItem Bp8AuditLogItem_Bp8Case 

Bp8Case Bp8CaseID 
 

Do the following for each of the items previously listed using EM: 

1. Navigate to Enterprise Manager > {os display name} > Other Classes > Custom Object > 
Bp8Object. 

2. Right click on the appropriate object. 

3. Select Properties. 

4. Select Property Definitions tab. 

5. Check the Inherited Properties check box. 

6. Select the appropriate field name. 

7. Click Edit. 

8. Verify that the Indexed text box has value of single indexed. If not: 

a. Click Set/Remove button. 

b. Click Set radio button 

c. Check Single Indexed checkbox. 

d. Click OK. 

9. Click OK to close properties page. 
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BPF Operations Logging Modification 

Overview 
Logging in the BPF Operations component is turned on by default using a WARNING level. The 
following levels are supported: 

• error – Log errors only. 

• warning – Log errors and warnings (default). 

• info – Log all above and information type messages. 

• debug – Log information on the detailed level (this option can generate large file). 

By default, logging is directed to the bp8operations file located in the JAVA_HOME/bin folder.  
A new empty log is created at the end of each day. 

Extract XML File 
Extract log4j.xml from the bp8ciops.jar package using WinZip or another tool. 

Modify XML File 
Modify the following sections of the log4j.xml file: 

• Log File Name 
 
<param name="File" value="bp8operations.log"/>  
where value = the name and the location of the log file.  
 
NOTE The default location of log files is the \bin directory of the running JVM. Be aware 
that usage of absolute path (including drive letter) is impossible, but any relative path from bin 
directory of JVM directory can be used. For example: /../../../logs/bp8ciops.log. 

• Logging Level 
 
<level value ="error"/> where value = error | warning | info | debug 

Add XML File Back  
Add the log4j.xml file back to bp8ciops.jar.  

NOTE Create 'production' and 'debug' level copies of bp8ciops.jar to simplify management. 

Restart Component Manager 
The Component Manager needs to be restarted for the changes to take effect. 
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Installation Validation 
When BPF is initially installed in a development environment, it is installed with a test application 
configuration called the Case Management Sample Application. This application is a pre-configured 
application on top of BPF that can be used to test all aspects of BPF functionality. 

In order to validate that the Business Process Framework and BPF Explorer components have been 
installed properly and correctly integrated with FileNet Content Engine, Process Engine, and 
Application Engine, the following steps should be performed against the Case Management Sample 
Application.  

1. Access BPF from the following URL: http://{web application server}:{web port}/{web BPF 
name}. 

2. Logon to BPF as sue 

3. Create a new Case. 

4. Open the case from the Index Inbasket and enter sample case field data. 

5. Attach a document to the case using the Attach Document tool. 

6. Open the attached content in the Viewer. 

7. Perform a BPF Case Search. 

8. Perform the Action – Complete on the case, then locate the case in the Review Inbasket to 
make sure it was dispatched. 

9. Open Layout Designer (by using the Edit Layout tool). 

10. Log off BPF. 

11. Logon to BPF Explorer and verify all configuration data is present. 

12. In order to verify that BPF_Operations are working in Component Manager, add a new 
document to the Case Management Documents document class. It must have a 
DocEntryStatus value of 1, and a DocType value of 1. The subscription event will launch a 
workflow that will create a new case. If BPF_Operations are running, you will see a new 
Case in the Index Inbasket.  
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Troubleshooting 
Integrate BPF with P8 Workplace 

Edit Workplace Settings 
This step applies to [New] installations or any time Workplace is re-deployed.  

This step should also be reviewed when performing BPF upgrades. 

1. Set the following preferences: 

Under Workplace > Admin > Site Preferences > General: 

o Enable custom objects: Yes 

o Add as major version: Yes 

o Check in as major version: Yes 

2. Execute Workplace Integration as detailed below: 

Workplace Integration 
NOTES 

• GUID (Example: {5309C5AF-6D24-4BDB-BB6C-71C61E7EFC53}) 
 
The object GUIDs shown below are examples for referencing the Case Management class 
from the Case Management Sample Configuration. You need to add one or more Bp8 Case 
Object GUIDs representing classes in your solution. These classes would be Bp8Case child 
classes. Use FileNet Enterprise Manager to determine the GUIDS. 

• URL (Example: http://p8demo30:7001/BPF/Bp8Main.jsp) 
 
The URLs shown below are examples and might need to be changed. Consult the FileNet P8 
Platform documentation. 

• Folder References:  All the Workplace folder references are to the deployed instance of 
Workplace (the instance used by the Web server). 

• This procedure assumes you have imported the following CE manifests (in previous steps): 

o The base BPF manifest 

o The Case Management manifest or some other custom manifest 

• You have only imported the base BPF manifest if FileNet Enterprise Manager does not show 
any child classes under Bp8Case ({os display name} > Other Classes > Custom Object > 
Bp8Object > Bp8Case). 

Sun Solaris 
NOTE Various XML files are modified as part of the Workplace integration procedure. An editor 
should be used that supports UTF-8 encoding. 
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Remove carriage returns (^M characters) from various property and .xml files as follows: 

1. Change directories to Workplace .../WEB-INF. 

2. Execute the following commands: 

• find . -name "*.properties" -exec dos2unix '{}' '{}' \; 

• find . -name "*.xml" -exec dos2unix '{}' '{}' \; 

AIX 
NOTE Various XML files are modified as part of the Workplace integration procedure. An editor 
should be used that supports UTF-8 encoding. 

Remove carriage returns (^M characters) from various property and .xml files as follows: 

1. Change directories to Workplace .../WEB-INF. 

2. Execute the following commands: 

• find . -name "*.properties" -exec dos2aix '{}' '{}' \; 

• find . -name "*.xml" -exec dos2aix '{}' '{}' \; 

HP-UX 
NOTE Various XML files are modified as part of the Workplace integration procedure. An editor 
should be used that supports UTF-8 encoding. 

Remove carriage returns (^M characters) from various property and .xml files as follows: 

1.  Change directories to Workplace .../WEB-INF. 

2.  Execute the following commands: 

• find . -name "*.properties" -exec /{Staging Folder}/dos2ux.sh '{}' \; 

• find . -name "*.xml" -exec /{Staging Folder}/dos2ux.sh '{}' \; 

Edit Infopages.Xml 
NOTE  Lower case alpha hex digit characters should not be used for the id (GUID) parameters in 
Actions.xml and InfoPages.xml. Due to a limitation in Workplace, specifying {92689f34-9f53-44ce-
85ef-2d561e50d139} instead of {92689F34-9F53-44CE-85EF-2D561E50D139}, for example, as a 
GUID value in the InfoPages.xml and Actions.xml files (for the Bp8Case custom object class) will fail 
to work. Workplace will not pick up the value. Only upper case alpha hex digit characters should be 
used. 

See the procedure introduction for background information. The items in italics are not entered; they 
are shown in the example below for context only. 

Edit InfoPages.xml in Workplace...\WEB-INF as follows:  

Add the following section: 

<object key="objectInfoPages" version="3.0"> 

<list key="pages"> 

     <object key="infoPage"> 

     <array key="objectTypes"> 

      <value>customobject</value> 
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      </array> 

      <array key="classes"> 

       <value>{92689F34-9F53-44CE-85EF-2D561E50D139}</value> 

      </array> 

<setting key="url">http://{web app server}:{web port}/{web BPF 
name}/Bp8IntegrationServlet?_commandId=9000</setting> 
      <setting key="isPopup">true</setting> 

      <setting key="popupHeight">550</setting> 

        <setting key="popupWidth">650</setting> 

   <setting key="useToken">true</setting> 

  </object> 

</list> 

</object> 

NOTE The <object key="infoPage"> subsection can go at the end of the <list key="pages"> section. 
Search for </list>. 

Edit Actions.Xml 
NOTE  Lower case alpha hex digit characters should not be used for the id (GUID) parameters in 
Actions.xml and InfoPages.xml. Due to a limitation in Workplace, specifying {92689f34-9f53-44ce-
85ef-2d561e50d139} instead of {92689F34-9F53-44CE-85EF-2D561E50D139}, for example, as a 
GUID value in the InfoPages.xml and Actions.xml files (for the Bp8Case custom object class) will fail 
to work. Workplace will not pick up the value. Only upper case alpha hex digit characters should be 
used. 

See the procedure introduction for background information. The items in italics are not entered; they 
are shown in the example below for context only. 

Edit Actions.xml in Workplace...\WEB-INF. Add the following sections. 

Top Level Actions 
Add the following section to the <array key="topLevelActions"> section: 

   <!-- top level actions --> 

   <array key="topLevelActions"> 

  <value>openCase</value> 

   </array> 

Action Definitions 
Add the following section to the <list key="actionDefinitions"> section: 

  

<list key="actionDefinitions"> 

<object key="actionDefinition"> 

  <setting key="id">openCase</setting> 

<setting key="title" 
localizationKey="server.Actions_xml.openInCaseQuery">Open 
Case</setting> 
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<setting key="url">http://{web app server}:{web port}/{web BPF 
name}/Bp8IntegrationServlet?_commandId=9000&amp;id={OBJECT_ID}&amp;o
bjectType={OBJECT_TYPE}</setting> 

  <setting key="img">images/action/Launch16.gif</setting> 

  <setting key="hiddenForGuests">true</setting> 

  <array key="objectTypes"> 

    <value>customobject</value> 

  </array> 

  <array key="classes"> 

    <value>{92689F34-9F53-44CE-85EF-2D561E50D139}</value> 

  </array> 

  <setting key="isPopup">true</setting> 

  <setting key="useToken">true</setting> 

  <setting key="popupHeight">550</setting> 

  <setting key="popupWidth">650</setting> 

</object> 

</list> 

NOTES 

• The items above in braces (such as {OBJECT_TYPE}) are to be left As Is in the XML; do not 
substitute actual values. 

•  If BPF is deployed on a web farm or in a load balancing environment, {web app server} 
should be pointed to the name or address of the load balancer. 

Edit Integration.Xml  
See the procedure introduction for background information. The items in italics are not entered; they 
are shown in the example below for context only. 

Edit Integration.xml in Workplace...\WEB-INF.  
Add the following section: 

 <object key = "propertyPageConfiguration" version = "3.0"> 

  <list key = "commands"> 

   <object key = "command"> 

    <setting key = "id">4030</setting> 

    <setting key = "url">Bp8ViewActions.jsp</setting> 
    <setting key = "description">View by external 
request</setting> 

   </object> 

 

   <object key = "command"> 

    <setting key = "id">4040</setting> 

    <setting key = 
"url">operations/WcmCheckoutObject.jsp</setting> 
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    <setting key = "description">Check Out Document</setting> 

   </object> 

 

   <object key = "command"> 

    <setting key = "id">4050</setting> 

    <setting key = 
"url">operations/WcmCancelCheckout.jsp</setting> 

     <setting key = "description">Cancel Checkout From 
CheckoutList</setting> 

   </object> 

 

   <object key = "command"> 

    <setting key = "id">4060</setting> 

    <setting key = 
"url">wizards/WcmCheckinDocument.jsp</setting> 

    <setting key = "description">Quick Check In 
Document</setting> 

   </object> 

  </list> 

 </object> 

Copy Files  
Copy the following files to the main folder of the deployed Workplace instance (the parent folder of 
WEB-INF): 

• Bp8ViewActions.jsp 

These files can be found in the {staging folder}/misc/components/Workplace folder. 

Reload XML Files 
Reload the XML files in Workplace. 

1. Click on Admin > Site Preferences > Refresh. 

2. Click Reload configuration files. 

NOTE Refer to the FileNet P8 Platform documentation for further details on modifying the 
Actions.xml and InfoPages.xml files. 

Import Content Engine Base Objects 
If any error occurs during the import of the base CE objects, Installer would show an error message at 
the end of installation.  

In such a condition use Enterprise Manager [EM] to import it manually.  

Refer to the FileNet P8 Platform documentation for the import procedure details. 

Base BPF Objects {staging folder}/misc/base/config/ce_base.xml 
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Import Content Engine Solution-Specific Objects 
If any error occurs during the import of the solution specific CE objects, the Installer will show an error 
message at the end of installation.  

In such a condition use Enterprise Manager [EM] to Import it manually.  

Refer to the FileNet P8 Platform documentation for the import procedure details. 

Case Management 
Sample 
Configuration 

{staging folder}/misc/solutions/case_management/config/ce_cm.xml 

Base Or Solution-Specific Workflow Object Creation 
Certain base and solution specific workflow objects were not created during the BPF Installer. To 
perform this manually, replace the following parameter values: 

Replace Parameter Values for Base Configuration 
1. Find the {XML File}. The standard XML files can be found at:  

{staging folder}/misc/base/config/  
(base: “qcreate_base.xml” solution specific “qcreate_cm.xml”) 

2. Locate the section in the {XML File} similar to the following:  
<Logon UserName="Administrator" Password="password" 
RouterPath="rmi://localhost:32771/vwrouter"/>. 

3. Set the following parameters appropriately: 

• UserName: {pe admin user} 

• Password: {pe admin password} 

• RouterPath: Consult the FileNet P8 Platform documentation for the PE router path. 

4. Copy Queue Definition File To Temporary Folder as follows: 

 Copy the {XML File} to the {temp.folder}/wfutil folder. 

5. Copy Wfutil From Staging Folder To Temporary Folder as follows: 

Copy the contents from {staging folder}/misc/wfutil to 
{temp.folder}/wfutil folder. 

6. Run Workflow Utility Script as follows: 

Execute the instructions below for the wfutil utility.  
This utility resides in the {temp.folder}/wfutil folder.  

• wfutil needs to be executed from the temporary folder. 

• An output log file named wfutil.log is created in the \logs folder and will contain the 
results of the wfutil execution. 

• wfutil never deletes any workflow objects. It can only update existing workflow object 
definitions (queue, roster, event log) or create new objects. 
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Sun Solaris 
a. Reset attributes: chmod +x wfutil.sh. 

b. Execute script: wfutil.sh {XML File}.  
(You will see output in the command window with the status of each task being executed.) 

Microsoft Windows 
a. Execute script: wfutil.cmd {XML File}.  

(You will see output in the command window with the status of each task being executed.) 

AIX 
a. Reset attributes: chmod +x wfutil.sh. 

b. Execute script: ./wfutil.sh {XML File}.  
(You will see output in the command window with the status of each task being executed.) 

HP-UX 
a. Reset attributes: chmod +x wfutil.sh. 

c. Execute script: ./wfutil.sh {XML File}. (You will see output in the command window with the 
status of each task being executed.) 

Update Process Map 
This task has been automated in BPF Installer. If any error occurs during the update of process map, 
Installer would show an error message at the end of installation. In such a condition, follow under 
mentioned steps to use update process map. 

Determine which process map to use: 

Standard No process map. 

Case Management 
Sample Configuration 

Use {staging folder}\misc\solutions\case_management\ 
config\CaseManagement.pep. 

 

Bypass this step if you are using the standard process map. Otherwise, update the process map (as 
described below) if this is a new installation, or if your selected process map has changed.  

1. Start IE and go to http://{web application server}:{port}/Workplace.  
 
NOTE Consult your Web Application service for the correct port number. 

2. Select Author > Advanced Tools > Process Designer from the Workplace menu. 

3. Select File > Open... and navigate to the pep file. 

4. Click File > Validate. (There should be no errors.) 

5. Select File > Transfer. (Save workflow to desired folder location. Transfer should be successful.) 

6. Select File > Exit. (Check in the workflow.) 
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Create Workflow Subscription on the CE Case Management 
Documents Document Class 
Bypass this step if you are not using the standard process map (Case Management Sample 
Application).  If you are using the Case Management Sample Application, it will be necessary to 
create and configure this Workflow Subscription so that the creation event for new Case 
Management Documents objects will trigger the launch of new workflows that will either create new 
BPF Cases (with the new document attached) or attach the new document to an existing Case 
(depending on values configured below). 

Log on to FileNet Enterprise Manager (FEM) and open the Case Management Documents Class 
Properties screen by navigating through Object Stores > {os display name} > Document Classes 
> Case Management Documents.  Click on the Subscriptions tab and then click the Create button. 

 
Follow the steps indicated by the Content Engine Create a Subscription Wizard.  Begin by using 
“Case Management Workflow” for the Name and Description on the Name and Describe the 
Subscription screen.  Then click the Next button. 
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Next, on the Specify the Type of Object screen, click the Applies to all instances of class Case 
Management Documents radio button and make sure to check the Workflow checkbox.  Then click 
the Next button. 

 
 

Then, on the Specify Triggers screen, select and highlight Creation Event in the list of Available 
Events on the left-hand side of the dialog, then click on the >> button to move it over to the list of 
Subscribed Events on the right-hand side of the dialog. Then click the Next button. 
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On the Specify Workflow Information screen that follows, leave Workflow Event Action selected in 
the first dropdown list (Select a Workflow Event Action) and then select Case Management 
Workflow in the second dropdown (Select a Workflow Definition).  Doing this should automatically 
populate the third dropdown (Select a Version) with the number of the latest (current) version of your 
Case Management Workflow.  NOTE Your Case Management Workflow must be saved as a 
Workflow Definition document object in your Object Store for it to appear here in the list of available 
Workflows.  Simply transferring a Workflow Map to the Isolated Region in PE without also saving it in 
CE will not work.  The number in the Isolated Region field should default to whatever is actually in 
use on your machine.  Lastly, be sure to check the Enable Manual Launch checkbox before clicking 
the Next button. 
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Next, on the Specify Additional Properties screen, enter “DocEntryStatus=1” for Filter Expression 
and click the Next button.   

 
 

Lastly, on the Complete the Create a Subscription Wizard screen, confirm your settings and click 
the Finish button. 
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You should then see a Confirmation message indicating that you have successfully created the “Case 
Management Workflow” subscription. 

 
 

You will now need to re-open the properties for your new subscription and configure its Property 
Map.  To do this, while still on the Subscriptions tab of the property page for your Case 
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Management Documents Class Properties screen, highlight the new Case Management 
Workflow subscription and click the Properties button. 

 
 

Now click on the Workflow tab of the Case Management Workflow Properties screen that comes 
up and enter the Property Map settings as indicated below.  NOTE The Workflow Property and 
Document Property names for the Case Management Sample Application are all the same except 
for CasePriority (CE) and Priority (PE). 
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When you have finished adding the last mapping (ReceivedDate), click the Cancel button, then the 
Apply button, then the two successive OK buttons that you will be offered. 

Test Workflow Subscription on the CE Case Management 
Documents Document Class 
You are now in a position to test the Workflow Subscription you just created.  You can do this either 
by creating a new instance of the Case Management Documents class or by launching the 
Workflow manually. 

Launching the Workflow Subscription by Creating a New Instance 
To test the Workflow Subscription by creating a new instance of the Case Management Documents 
class, log on to Workplace, and browse to a folder in your Object Store in which you would like to 
place your new documents.  (NOTE You might need to create this folder yourself.)  Once there, click 
on the Add Document link to launch the Add Document Wizard.  Then click on the Change Class 
link and select Case Management Documents. 

 

 
 

Enter document property values in the resulting screen, making sure to change DocEntryStatus from 
None to DocEntry (1).    (This is because of the Filter Expression you set when configuring the 
Workflow Subscription itself.)  Otherwise the Workflow Subscription you created will not be launched 
at all.  For DocumentType you can then specify either 1 or 2. If you specify 1, the Workflow launched 
by the Workflow Subscription will create a new BPF Case regardless of any other values you enter 
here.  If you specify 2, the Workflow launched by the Workflow Subscription will check the 
AccountNumber value you specify here and try to find an existing BPF Case already in your system 
that has the same AccountNumber, attach this newly created document to it, and then terminate 
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itself.  So, if you enter 2, be sure to enter an AccountNumber value that matches that of a BPF Case 
already in your system. 

 
 

Once you have finished entering the document property values, click the Next button, adjust the 
security settings (on the resulting Set Security screen) as you wish (or take the defaults), then click 
Next again and, on the Select File screen, browse to a local file to upload as the content of this new 
document object.  When you are done, click the Finish button.  The Workflow Subscription should 
now launch a new Workflow.  To check the results, log on to the BPF Web Application and see if your 
new BPF Case was created (if you chose DocumentType=1) or if your new document was attached 
to a previously existing BPF Case with the same AccountNumber (if you chose DocumentType=2). 

Launching the Workflow Subscription Manually 
To launch the Workflow Subscription manually, either create a new Case Management Documents  
document and leave DocEntryStatus set to None (0) so that the Workflow Subscription will not fire 
through the Creation Event and then browse to it or browse to an existing Case Management 
Documents document in Workplace and open its Information page.  Once there, make sure to 
change the value of the DocEntryStatus property to DocEntry (1) if it is already set to any other 
value.  Otherwise, you will not be able to launch the Workflow Subscription at all.  (This is because of 
the Filter Expression you set when configuring the Workflow Subscription itself.)  Then, select 
Launch from the list of Actions available and you should be presented with the following screen. 
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Click the Launch link to see the following screen. 

 

 
Click on each of the four links under Information to review the values configured (noting that your 
current document will already be set as the Initiating Attachment) and then click the Launch button. 
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On the following screen, click the Assign link and browse  
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Troubleshooting the Workflow Subscription 
There are a number of things that can go wrong during the course of testing your Workflow 
Subscription.  The following are some of the most common. 

• If you launch your Workflow Subscription and nothing seems to happen (no new Case or no 
new Attachment on an existing Case), make sure that BPF_Operations is running in 
Component Manager.  If BPF_Operations is stopped (as in the following screenshot), restart 
it and see if your results now appear as expected. 
 

 

• If BPF_Operations is running and you still see no effects from launching your Workflow 
Subscription, open Process Administrator and search for new Work Items to see if any Work 
Item was launched at all. 
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If a Work Item was launched, open it in Process Tracker to see what went wrong.  Click on 
the Workflow History tab, highlight the line where the Exception occurred, right-click and 
select View Information Stack…  Then, highlight the line in the upper pane and then hover 
your mouse pointer above the Error Message text to see full information about the error. 
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• Alternatively, if a search in Process Administrator indicates that no Work Item was 
launched at all, open the Windows Application Event Log on the Content Engine server to 
see if any error occurred during launch. 

Edit Taskman Policy 
1. Edit taskman.policy. (By default, it is found in the Router folder in the AE installation folder.) 

2. If bp8ciops.jar file is not listed, create a new section to grant the required privileges. 

Example: 

 grant codeBase "file:{install.home}/bpfops/bp8ciops.jar "  

{ 

   permission java.security.AllPermission; 

 }; 

3. Save and close taskman.policy. 

Edit taskman.properties 
1. Edit taskman.properties. (By default, it is found in the Router folder in the AE installation folder.) 

2. Add path for {install.home}/bpfops/bp8ciops.jar to TaskManager.ComponentManager.ClassPath. 

Add Taskman libraries (vwtaskman.xml) 
The Task Manager utilizes the following libraries: 

Expected path Library short name 
{install.home}/bpfops/lib/xalan.jar xalan.jar 

{install.home}/bpfops/bp8ciops.jar bp8ciops.jar 

{install.home}/bpfops/lib/pe.jar pe.jar 

 

Add libraries to vwtaskman.xml in the following manner: (By default found in the Router subdirectory 
in the AE installation directory) 

a.       Start the AE router (using routercmd). 

b.       Stop the Component Manager (in the AE Router). 

c.       Go to the Required Libraries tab. 

d.       Add all of the libraries listed above.  

Edit Taskman Login Configuration 
1. Edit taskman.login.config as follows.  

(By default, it is found in the Router subdirectory in the AE installation directory.) 

2. Edit the routername setting under CELogin, if necessary, to match your environment settings. 
 
NOTE Do not use localhost as a system name. 
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Example: 

 CELogin 

 {  

   filenet.vw.server.VWLoginModule required routerurl="{web 
application server}:32771/{ae pe router name}"; 

   com.filenet.wcm.toolkit.server.operations.util.CELoginModule  

  required credTag=Clear; 

 }; 

3. Save and close taskman.login.config. 

Configure User Tokens  
1. Synchronize CryptoKeyFile key in WCMApiConfig.properties 

• Typical entries for Crypto key file in WCMApiConfig.properties configuration file are as 
follows: 

• CredentialsProtection = Symmetric 

CryptoKeyFile =C:\\Program Files\\FileNet\\Authentication\\CryptoKeyFile.properties 
(this could be any other accessible path to CryptoKeyFile.properties) 

• BPF uses “CryptoKeyFile.properties” file for passing user credential in encrypted form to 
Content Engine. This behavior is same as AE/Workplace. You can choose either of following 
values for  CredentialsProtection in BPF WCMApiConfig.properties file.  

• CredentialsProtection = Clear   
 
NOTE Setting Clear encoding for CredentialsProtection/UserToken will result in 
nuisance logins from AE/Workplace and should be avoided.  For practical purposes, 
Symmetric encoding should be used under all circumstances. 

Or  

CredentialsProtection = Symmetric 

• If “Symmetric” option is used then contents of “CryptoKeyFile.properties” used by BPF must 
be present inside “CryptoKeyFile.properties” file used by Content Engine. If BPF and Content 
Engine entries for “CryptoKeyFile.properties” different than you would get logon failure from 
BPF application. 

• If “Clear” option is used then contents of “CryptoKeyFile.properties” used by BPF will be 
ignored and will not be used while passing user credential to Content Engine. 

NOTE BPF and Workplace can point to same or different CryptoKeyFile. 

2. Synchronize UTCryptoKeyFile in WCMApiConfig.properties 

Correct entries inside WcmApiConfig.properties for using token sharing with Workplace is 

• CredentialsProtection/UserToken =Symmetric 

CryptoKeyFile/UserToken =C:\\Program 
Files\\FileNet\\Authentication\\UTCryptoKeyFile.properties (this could be any other accessible 
path to UTCryptoKeyFile.properties) 

• BPF uses “UTCryptoKeyFile.properties” file for token sharing with Workplace. Contents 
inside “UTCryptoKeyFile.properties” file used by BPF and Workplace must be identical. 
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These file can reside at any location but correct accessible path must be specified inside the 
WcmApiConfig.properties file. This file will be used by BPF and Workplace during Workplace 
integration with BPF. This will allow user logon to BPF from Workplace and to Workplace 
from BPF without asking for user credential again.  

3. Set Workplace Bootstrap properties as follows: 
WEB-INF/bootstrap.properties: 

• generateTokens=True  

• acceptTokens=True  

• tokenTimeoutValue=5  
(or sufficient number of minutes to account for clock differences between servers)  

NOTE  You can set these properties by clicking Workplace > Site Preferences > Bootstrap. 

See the FileNet P8 Platform documentation:  

FileNet P8 Documentation > Developer Help > Workplace Integration and 
Customization > User Tokens > Configuring Applications to Use Tokens. 

4. Verify the following FileNet Content Java API registry settings on the CE server: 

• CryptoKeyFile – Must point to a CryptoKeyFile.properties file with content identical to the 
UTCryptKeyFile.properties file of AE. 

•  Timeout – The value is intended to cover the amount of time the token is in transit and to be 
short enough so that the tokens cannot be reused in a security attack. You can increase the 
value if necessary. 

See the FileNet P8 Platform documentation:  

FileNet P8 Documentation > Developer Help > Content Java API > Getting 
Started > Concepts > Content Java API Registry Settings. 

5. Synchronize all clocks on the AE and CE servers. 

See the FileNet P8 Platform documentation:  

FileNet P8 Documentation > Developer Help > Workplace Integration and 
Customization > User Tokens > Configuring Applications to Use Tokens. 

6.  Restart applications. 

• Stop and restart Workplace in your Web Application server. 

• Restart the Apache SOAP listener on the Content Engine. 

Configure Toolbar Items 
Configure the BPF Inbasket Toolbar items. For initial testing, you might want to configure some 
simple search functionality. See the example below. 

See also in BPF Help: Help for Advanced Users and Designers > BPF Advanced Configuration 
> BPF Toolbar Interface. 

Edit BPF Web Application “web.xml” 
BPF Installer updates Meta Store DataSource Name {meta datasource} and Process DataSource 
Name {pe datasource} in web.xml during installation time. These should have been previously 
created and tested in the Environment Configuration section. BPF Installer does not perform 
DataSource name validation. In case any of these DataSource names have been entered wrong 
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during installation, you might want to edit web.xml file to correct these entries. These entries can be 
manually edited in web.xml by browsing {install.home}/web/{web application name}/WEB-INF 
location. WAR or EAR installation would require extracting contents in temporary folder and re-
bundling it after making correction in web.xml.  

Modify bold italic text to correct DataSource names. 

 <init-param> 

  <param-name>MetaStoreDSName</param-name> 

  <param-value>Bp8MetadataDS</param-value> 

 </init-param> 

 <init-param> 

  <param-name>ProcessStoreDSName</param-name> 

  <param-value>Bp8ProcessDS</param-value> 

 </init-param> 

Uninstall BPF 
NOTE You can have multiple versions or configurations of BPF on the same machine if required, 
deployed in different web applications. Only the specific BPF application to be upgraded needs to be 
un-deployed in this step. 

Uninstall BPF Web Application 
Do the following: 

1. On the AE server, stop the Component Manager BPF_Operations component using the FileNet 
Process Task Manager. 

2. Remove the folder {install.home}/BPFops. 

BEA WebLogic 
1. Log into BEA WebLogic console using IE: http://{web application server}:7001/console. 

2. Delete module by doing the following: 

a. Expand mydomain > Deployments > Web Application Modules (in tree-view pane). 

b. Right-click BPF. 

c. Select Delete BPF... 

d. Click Yes. 

e. Click Continue. 

IBM WebSphere 
1. Use IE to go to the WebSphere Admin page at:  

http://{web application server}:9060/ibm/console. 

2. Enter your name. 

3. Navigate to Applications/Enterprise Applications. 

4. Select BPF application name.  
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5. Click Stop. 

6. Reselect BPF (or other application name you have BPF deployed under)  

7. Click Uninstall followed by Save. 

JBOSS 
1. Delete the directories for BPF and BPF help under JBOSS ../server/default/deploy. 

Oracle Application Server 
1. In the console, select the OC4J Instance where you want to deploy the war file. 

2. Select the Applications tab. 

3. Un-Deploy the BPF WAR file. 

Remove All Deployment Information 

IBM WebSphere 
1. Execute the following from the WebSphere Admin page:  

 Environment > Update Web Server Plugin > OK 

NOTE This automates removal of the deployment file when uninstalling the Web Application.  
This step must be performed after every un-install. 

BEA WebLogic 
1. Stop WebLogic. 

2. Delete Deployment folder. 

Remove these folders manually from the WebLogic deployment folder: 

.../.wlnotdelete/extract/...<application name> 

.../upload/<application name> 

These folders might reside under C:/bea/user_projects/domains/mydomain/myserver: 

.../.wlnotdelete/extract/myserver_BPF_BPF 

.../upload/BPF 

NOTE These folders might be deleted when the Web Application is deleted in the previous step. 

JBOSS 
No action required. 

Oracle Application Server 
No action required. 



IBM FileNet Business Process Framework Installation Guide 
Uninstall BPF 
 

 

© Copyright IBM Corp. 2006, 2009  121 

Uninstall BPF Explorer 

Microsoft Windows 
Do the following on the server where BPF Explorer is installed: 

1. Open Start Menu > Settings > Control Panel > Add/Remove Programs. 

2. Select FileNet Business Process Framework Explorer. 

3. Select Change/Remove. 

Uninstall BPF Web Application 

Microsoft Windows 
Do the following on the server where BPF Explorer is installed: 

1. Open Start Menu > Settings > Control Panel > Add/Remove Programs. 

2. Select FileNet Business Process Framework. 

3. Select Change/Remove. 

UNIX 
1. Navigate to the /_uninst folder under the BPF installation location.  

The default location is:  /opt/FileNet/BPF/_uninst 

2. Go to {install.home}/_uninst folder and execute “uninstaller.exe” 

3. Run the uninstall program. 
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Remove BPF from the environment 
This is an optional standalone procedure. Follow it to completely remove an installation of BPF. If you 
are performing a BPF version upgrade, do not perform these steps. 

NOTE Some of the steps below refer to worksheet items. Some familiarity with the worksheet item 
and the installation procedure is assumed. 

Delete Object Store In Content Engine 
1. Run Start Menu > Programs > FileNet P8 Platform > Enterprise Manager SnapIn. 

2. Right-click Object Stores > {os display name}. 

3. Select Delete. 

4. Click Yes. 

5. Click Ok on other prompts. 

Delete Object Store Database 
Contact database system administrator to delete metastore database. 

Delete DataSources 

BEA WebLogic 
1. Log into BEA WebLogic console using IE: http://{web application server}:7001/console. 

2. Delete DataSources: 

a. Expand Services > JDBC > DataSources (in tree-view pane). 

b. Right click {meta datasource}. 

c. Select Delete {meta datasource}... 

d. Click Yes. 

e. Click Continue. 

f. Repeat the same process for the {pe datasource}. 

g. Delete pools as follows: 

i. Expand Services > JDBC > Connection Pools. 

ii. Right click {meta connection pool} 

iii. Select Delete {meta connection pool}... 

iv. Click Yes. 

v. Click Continue. 

h. Repeat the same process for the {pe connection pool}. 
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IBM WebSphere 
1. Logon to the WebSphere Administrative Console:  

http://{web application server}:9060/ibm/console. 

2. Create JDBC Provider: 

Click on Resources > JDBC Providers. 

3. Click appropriate JDBC provider 

4. Click Data source link 

5. Check {meta datasource} and {process datasource} and delete them by clicking Delete button. 

JBOSS 
1. In the JBOSS directories, browse to...\server\default\deploy 

2. Edit ‘msSQL-ds.xml’ or ‘oracle-ds.xml’ 

3. Delete meta datasource} and {process datasource} entries and save the files. 

Oracle Application Server 
1. Click the OC4J Instance you are using. 

2. Click Administration tab. 

3. Click Data Sources. 

4. Delete {meta datasource} and {process datasource} 

Delete Metastore Database 
Contact database system administrator to delete metastore database. 

Upgrade BPF  
NOTE It is possible for BPF-3.5.2 and BPF-3.6.0 instances to share the same instance of 
AE/Workplace as long as the following considerations are kept in mind: 

1. Access Roles are always read from the Application OS (the objectstore defined in BPF Explorer). 

2. The combination of ObjectStore name in BPF Explorer and the Workplace preference name 
should be unique. If say you have created Workplace36 preference for BPF3.6 application with 
OS36 and  Workplace352 preference for BPF3.5.2 application with OS352 (with access roles 
created in both the objectstores), using the Workplace36 preference name for BPF3.5.2 and vice 
versa will make the application fail to logon with error "You are not assigned to any Roles". 

3. The ObjectStore name in bootstrap and BPF Explorer could be different in case of BPF 3.5.2 
application but it should be same for BPF 3.6 application. 

BPF 3.5.x to BPF 3.6 (on P8 3.5.x) 
This task includes BPF upgrade instructions for WebSphere, WebLogic, Oracle Application Server 
and JBoss. 

Before you upgrade BPF 
Make sure the site has restorable backups of system and data of all FileNet P8 components. In case 
of an emergency, you might need to back out of the upgrade. For details on what to back up for 
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FileNet P8 components, see the topic FileNet P8 Documentation > Enterprise-wide Administration > 
Backup and Restore in the general FileNet P8 Platform help. Make backups of your custom and 
application-specific configurations. 

This section assumes that you have already upgraded all BPF dependent FileNet P8 products. The 
following steps describe BPF upgrade configuration only. The following areas will be covered during a 
BPF upgrade: 

• BPF Operations component. 

• Solution-specific code if any. 

• BPF Explorer application. 

• BPF metastore schema changes. 

• BPF metastore configuration. 

• BPF Web Application. 

To upgrade BPF 
1. Back up your existing bp8ciops.jar (used by BPF_Operations).  This JAR file contains two XML 

files, of which bp8_config.xml must and log4j.xml can contain custom and application-specific 
settings which you will need to copy back into the corresponding files in the new bp8ciops.jar 
installed during the upgrade. 

2. Back up the entire deployed folder used by the BPF Web Application.  Specifically, back up any 
of the BPF XSL files to which you have made custom modifications.  You will need to merge 
these changes back into the new XSL files installed during the upgrade.  Backing up the entire 
deployed folder will also make sure you do not lose any custom JavaScript in any of the 
*EventHandler* JavaScript files, your custom Bp8CustomStyles.css (if any), as well as the current 
copies of the .JS or .JSP files any custom tabs, tools, lookups, and so on, that you might have 
deployed – as well as the compiled class files for any of these or for any custom 
CaseEventHandler subclasses you might have deployed.  In general, refer to the BPF Developer 
Guide to review the various customization points available and verify just what custom code 
exists in the current application that will need to be redeployed after the upgrade. 

3. Export the configuration of your {meta database} to an XML manifest using the Export feature in 
BPF Explorer and (if possible) make a full database backup within your RDBMS. Consult the 
section of the BPF Explorer Handbook entitled “Saving/Moving BPF Configurations” for further 
details of what information you will need to save/backup prior to beginning your upgrade 
installation. 

4. Log on to the application server: 

UNIX - logon as root. 

Windows - log on as member of the local Administrator group or a user with equivalent 
permissions. 

5. Undeploy and remove BPF Web Application and BPF Explorer. Prior to executing this step, make 
sure you have backed up solution specific files. You will use backed up files while executing BPF 
Web Application installation steps below. To Undeploy and remove BPF Web Application and 
BPF Explorer see Uninstall BPF.  

6. Install BPF Web Application from media. On the Custom Vs Typical Installation screen, select the 
Custom option. See Install and Configure BPF Web Application.  All of below screen will appear 
when you will execute BPF Installer. Go through the text and screens below before executing 
BPF Installer. 
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Custom Vs Typical Installation Screen 

CAUTION Selecting the Typical option when upgrading could override existing BPF application 
configurations and should be used only when you DO NOT wish to preserve an existing 
application configuration.  

• From ‘Custom Installation Feature Selection Screen’ select the first two options to re-
install the new BPF Web Application and BPF Operations version only.   

• Select first two and last option when you want to add custom code to BPF Web Application 
Code (Your custom code backed up from step 2). You would need to copy all customization 
to a folder replicating BPF Web Application folder. Any modules including JSP, JAR or XML 
files specified in this folder will be bundled as part of WAR/EAR or in Exploded Folder. 

• User Defined Configuration and Custom Code Folder screens will only appear when you 
selected last option from Custom Installation Feature Selection screen. Leave all entries 
blank on User Defined Configuration screen. 

CAUTION Do not select fully backed up BPF Web application folder from step 2 as custom code 
folder. Only copy customization to a folder replicating BPF Web Application folder.  Any modules 
including JSP, JAR or XML files specified in this folder will be bundled as part of WAR/EAR or in 
Exploded Folder.   
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Custom Installation Feature Selection Screen 

 
Custom Installation Feature Selection Screen 
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User Defined Configuration Screen 

 
Custom Code Folder Screen 

CAUTION Selecting either Case Management Sample Configuration or User-defined 
Configuration options when upgrading could override existing BPF application configurations and 
should be used only as needed. 

7. In this step you will be deploying BPF Web Application which was installed in Step 6. To deploy 
BPF Web Application see Deploy BPF Web Application.  
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8. Make sure you uninstalled BPF Explorer while executing Step 5. Install BPF Explorer from 
/{staging folder}/admin/ folder. While installing BPF Explorer you would be pointing to your 
previous metastore database. To install see Install BPF Explorer. 

9. Load BPF metastore. This step will upgrade your metastore database with new database schema 
specific to BPF release you are upgrading to. To Load BPF Metastore see Load BPF Metastore. 

CAUTION Step 0 (for Oracle only) and Step 1 metastore scripts are executed only new BPF 
Application is installed. For upgrades, Step 0 and Step 1 scripts should not be executed. 

10. If you are upgrading BPF 3.5.2 to BPF 3.6, the BPF Site Designer role will need to be defined. To 
enable Layout Designer, you must manually create a BPF Site Designer role and assign a user to 
that role in BPF Explorer. Refer to the IBM FileNet Business Process Framework Web Application 
User Interface Guide for more information about Layout Designer. 

11. Configure BPF Operations.  Be sure to refer to the bp8_config.xml and log4j.xml files in your 
backup copy of bp8ciops.jar to verify the correct settings for your environment and copy the 
information from these files into the corresponding files in the new bp8ciops.jar installed by the 
upgrade. 
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BPF Release Identification 
The BPF release number can be identified in one of the following ways: 

Web Application Point to the following URL in IE:  
http://{web application server}:<{web port}>/{web BPF 
name}/About.jsp  

NOTE Consult your Web Application service for the correct port number. 

BPF Operations Extract Manifest.mf from the bp8ciops.jar using WinZip or any other 
archiver and check the Implementation-Version tag. 

Wfutil Extract Manifest.mf from the wfutil.jar using WinZip or any other 
archiver and check the Implementation-Version tag. 
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Notices 
This information was developed for products and services offered in the U.S.A.  

IBM may not offer the products, services, or features discussed in this document in other countries. 
Consult your local IBM representative for information on the products and services currently available 
in your area. Any reference to an IBM product, program, or service is not intended to state or imply 
that only that IBM product, program, or service may be used. Any functionally equivalent product, 
program, or service that does not infringe any IBM intellectual property right may be used instead. 
However, it is the user's responsibility to evaluate and verify the operation of any non-IBM product, 
program, or service. 

IBM may have patents or pending patent applications covering subject matter described in this 
document. The furnishing of this document does not grant you any license to these patents. You can 
send license inquiries, in writing, to: 

IBM Director of Licensing 
IBM Corporation 
North Castle Drive 
Armonk, NY  10504-1785 
U.S.A. 

For license inquiries regarding double-byte (DBCS) information, contact the IBM Intellectual Property 
Department in your country or send inquiries, in writing, to: 

IBM World Trade Asia Corporation 
Licensing 
2-31 Roppongi 3-chome, Minato-ku 
Tokyo 106-0032, Japan 

The following paragraph does not apply to the United Kingdom or any other country where 
such provisions are inconsistent with local law: INTERNATIONAL BUSINESS MACHINES 
CORPORATION PROVIDES THIS PUBLICATION "AS IS" WITHOUT WARRANTY OF ANY KIND, 
EITHER EXPRESS OR IMPLIED, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED 
WARRANTIES OF NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR 
PURPOSE. Some states do not allow disclaimer of express or implied warranties in certain 
transactions, therefore, this statement may not apply to you. 

This information could include technical inaccuracies or typographical errors. Changes are 
periodically made to the information herein; these changes will be incorporated in new editions of the 
publication. IBM may make improvements and/or changes in the product(s) and/or the program(s) 
described in this publication at any time without notice. 

Any references in this information to non-IBM Web sites are provided for convenience only and do not 
in any manner serve as an endorsement of those Web sites. The materials at those Web sites are not 
part of the materials for this IBM product and use of those Web sites is at your own risk. 

IBM may use or distribute any of the information you supply in any way it believes appropriate without 
incurring any obligation to you. 

Licensees of this program who wish to have information about it for the purpose of enabling: (i) the 
exchange of information between independently created programs and other programs (including this 
one) and (ii) the mutual use of the information which has been exchanged, should contact: 

IBM Corporation 
J46A/G4 
555 Bailey Avenue 
San Jose, CA  95141-1003 
U.S.A. 
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Such information may be available, subject to appropriate terms and conditions, including in some 
cases, payment of a fee. 

The licensed program described in this document and all licensed material available for it are 
provided by IBM under terms of the IBM Customer Agreement, IBM International Program License 
Agreement or any equivalent agreement between us. 

Any performance data contained herein was determined in a controlled environment. Therefore, the 
results obtained in other operating environments may vary significantly. Some measurements may 
have been made on development-level systems and there is no guarantee that these measurements 
will be the same on generally available systems. Furthermore, some measurements may have been 
estimated through extrapolation. Actual results may vary. Users of this document should verify the 
applicable data for their specific environment. 

Information concerning non-IBM products was obtained from the suppliers of those products, their 
published announcements or other publicly available sources. IBM has not tested those products and 
cannot confirm the accuracy of performance, compatibility or any other claims related to non-IBM 
products. Questions on the capabilities of non-IBM products should be addressed to the suppliers of 
those products. 

All statements regarding IBM's future direction or intent are subject to change or withdrawal without 
notice, and represent goals and objectives only. 

This information contains examples of data and reports used in daily business operations. To 
illustrate them as completely as possible, the examples include the names of individuals, companies, 
brands, and products. All of these names are fictitious and any similarity to the names and addresses 
used by an actual business enterprise is entirely coincidental. 

COPYRIGHT LICENSE: 

This information contains sample application programs in source language, which illustrate 
programming techniques on various operating platforms. You may copy, modify, and distribute these 
sample programs in any form without payment to IBM, for the purposes of developing, using, 
marketing or distributing application programs conforming to the application programming interface 
for the operating platform for which the sample programs are written. These examples have not been 
thoroughly tested under all conditions. IBM, therefore, cannot guarantee or imply reliability, 
serviceability, or function of these programs. 

Trademarks 
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of International Business 
Machines Corporation in the United States, other countries, or both. If these and other IBM 
trademarked terms are marked on their first occurrence in this information with a trademark symbol 
(® or ™), these symbols indicate U.S. registered or common law trademarks owned by IBM at the 
time this information was published. Such trademarks may also be registered or common law 
trademarks in other countries. A current list of IBM trademarks is available on the Web at "Copyright 
and trademark information" at www.ibm.com/legal/copytrade.shtml. 

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the United States, 
other countries, or both.  

Microsoft and Windows are trademarks of Microsoft Corporation in the United States, other countries, 
or both.  

UNIX is a registered trademark of The Open Group in the United States and other countries. 

Other company, product, or service names may be trademarks or service marks of others. 
 

http://www.ibm.com/legal/copytrade.shtml
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