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ibm.com and related resources

Product support and documentation are available from ibm.com.

Support and assistance

Product support is available on the Web. Click Support from the product Web site
at:

FileNet Content Manager Support
http://www.ibm.com/software/data/content-management/filenet-content-
manager/support.html

Information center

You can view the product documentation in an Eclipse-based information center
that you can install when you install the product. By default, the information
center runs in a Web server mode that other Web browsers can access. You can also
run it locally on your workstation. See the information center at
http://publib.boulder.ibm.com/infocenter/p8docs/v4r5m1/index.jsp.

PDF publications

You can view the PDF files online using the Adobe Acrobat Reader for your
operating system. If you do not have the Acrobat Reader installed, you can
download it from the Adobe Web site at http://www.adobe.com.

See the following PDF publications Web sites:

Product Web site

Product Documentation for FileNet
P8 Platform

http://www.ibm.com/support/docview.wss?rs=3278
&uid=swg27010422

“How to send your comments”
Your feedback is important in helping to provide the most accurate and highest
quality information.
“Contacting IBM” on page viii
To contact IBM customer service in the United States or Canada, call
1-800-IBM-SERV (1-800-426-7378).

How to send your comments
Your feedback is important in helping to provide the most accurate and highest
quality information.

Send your comments by using the online reader comment form at
https://www14.software.ibm.com/webapp/iwm/web/signup.do?lang=en_US
&source=swg-rcf.
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Consumability survey

You are invited to tell IBM how to improve the consumability of software
products. If you want to help IBM make IBM® FileNet® P8 easier to use, take the
Consumability Survey at http://www.ibm.com/software/data/info/
consumability-survey/.

Contacting IBM
To contact IBM customer service in the United States or Canada, call
1-800-IBM-SERV (1-800-426-7378).

To learn about available service options, call one of the following numbers:
v In the United States: 1-888-426-4343
v In Canada: 1-800-465-9600

For more information about how to contact IBM, see the Contact IBM Web site at
http://www.ibm.com/contact/us/.
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Planning and preparing for Business Process Framework
installation

Before you begin your installation of Business Process Framework, you must plan
the installation and prepare your environment.

“Planning the installation”
You must review the installation planning information before your Business
Process Framework installation so that you know what deployments are
supported, understand how the tasks in the installation tasks are organized by
Role, and know how to use the Installation and Upgrade Worksheet.
“Performing the required installation preparation tasks” on page 7
To efficiently carry out the required installation preparation tasks, you must
assign your staff to carry out the tasks that are organized by administrative
role.

Planning the installation
You must review the installation planning information before your Business
Process Framework installation so that you know what deployments are
supported, understand how the tasks in the installation tasks are organized by
Role, and know how to use the Installation and Upgrade Worksheet.

To install Business Process Framework:
v Retrieve updates to IBM FileNet P8 documentation and software.
v Read through this infocenter to become familiar with the tasks you are going to

perform when you set up your Business Process Framework software.

Important: Follow the planning, installing, and configuring tasks in the order
presented. If you do otherwise, or you install FileNet P8 components on machines
containing components for existing FileNet P8 systems, you might encounter
unforeseen problems or be required to perform additional installation steps. See
the IBM FileNet P8 Troubleshooting Guide.

“Prerequisites for installing Business Process Framework” on page 2
The Business Process Framework application works within the FileNet P8
Platform environment. You must install and configure your FileNet P8 Platform
environment before you install Business Process Framework.
“Installation and deployment stages of Business Process Framework” on page 2
Business Process Framework provides a sample application that you can use as
a starting point for developing your own customized application. You can
install Business Process Framework in development environment before you
deploy your finished application.
“Collocating different Business Process Framework versions” on page 3
You can choose to install the latest version of Business Process Framework on
the same server as an older versions. This configuration requires some
additional settings.
“Definition of installation roles” on page 4
The tasks in this guide and the rows in the Installation and Upgrade Worksheet
are organized by administrative roles. Your organization might have different
roles, and some of the responsibilities of listed roles will vary from those
assigned by default in this documentation.

© Copyright IBM Corp. 2002, 2009 1



“Using the installation and upgrade worksheet” on page 5
The Installation and Upgrade Worksheet is a Microsoft® Excel spreadsheet
(p8_worksheet.xls). The worksheet describes the properties and parameters
required to complete IBM FileNet P8 installation, upgrade, and configuration
programs, and provides a way to record the values you assign to these
properties and parameters.

Prerequisites for installing Business Process Framework
The Business Process Framework application works within the FileNet P8 Platform
environment. You must install and configure your FileNet P8 Platform
environment before you install Business Process Framework.

The Business Process Framework installation process is designed to copy or create
the necessary Business Process Framework foundational components on a system
on which the baseFileNet P8 Platform products are already installed. The following
FileNet P8 Platform components must be installed and operational before you
begin installing Business Process Framework:
v Content Engine
v Process Engine
v Application Engine
v FileNet eForms (Optional. This software is required only if eForms integration

from Business Process Framework is to be used.)

Business Process Framework must be collocated with Application Engine. Install
the Business Process Framework server on the same Web application server where
your Application Engine is installed and your Workplace application is deployed.

Installation and deployment stages of Business Process
Framework

Business Process Framework provides a sample application that you can use as a
starting point for developing your own customized application. You can install
Business Process Framework in development environment before you deploy your
finished application.

Business Process Framework is an application framework that provides a starting
point for creating custom Business Process Management applications. The
framework is defined through Business Process Framework configuration settings
and optionally through code extensions that you add.

Typically, Business Process Framework is first installed in the development
environment. The Case Management Sample Application is installed automatically
to provide a working Business Process Framework application that can be used to
test Business Process Framework functionality for installation signoff.

At a high level, a typical Business Process Framework installation process performs
the following basic activities to deliver the required Business Process Framework
components:
v Installs and deploys the Business Process Framework Web Application to the

Web application server
v Creates and populates the Business Process Framework Meta database tables

needed to support Business Process Framework.
v Configures the FileNet Content Engine, Process Engine, and Application Engine

environment with Business Process Framework.
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v Copies the application configuration files for the Case Management sample
application to the FileNet P8 environment (optional).

v Installs the Business Process Framework Explorer configuration tool on the
administration workstation.

In the development environment, the developers of Business Process Framework
custom applications modify the configuration files and optionally add code
extensions to create their site-specific Business Process Framework Web
applications.

Before installing Business Process Framework in another environment such as unit
testing, user acceptance testing, deployment staging, and production, you must
determine whether a typical Business Process Framework installation is required or
if a completed Business Process Framework application is to be deployed to that
environment using a different process. If your enterprise has specific processes for
staging and deploying web applications, you must develop a plan for deploying
Business Process Framework Web applications according to these processes. If your
enterprise does not have a deployment management process, you can install
Business Process Framework in the additional environments as usual. You then
manually move the site-specific configuration and code extension files to the new
environments. For more information on moving the Business Process Framework
configuration files to other environments, see the IBM FileNet Business Process
Framework Explorer Handbook.

Collocating different Business Process Framework versions
You can choose to install the latest version of Business Process Framework on the
same server as an older versions. This configuration requires some additional
settings.

It is possible for Business Process Framework 4.0.0 and Business Process
Framework 4.1.0 instances to share the same instance of Application Engine.
Consider the following requirements:
v Access Roles are always read from the application operating system (the Content

Engine ObjectStore defined in Business Process Framework Explorer).
v The combination of ObjectStore name in Business Process Framework Explorer

and the Workplace preference name should be unique. For example, if you have
created a Workplace41 preference for your Business Process Framework 4.1.0
application with OS41 and a Workplace400 preference for your Business Process
Framework 4.0.0 application with OS400 (with access roles created in both the
ObjectStores), then using the Workplace41 preference name for Business Process
Framework 4.0.0 and vice versa will make the application fail to logon with the
error ″You are not assigned to any Roles″.

v You must configure the Workplace InfoPages.xml and Actions.xml files in such
a way that Workplace will know which instance of Business Process Framework
(which URL) it should use to open Business Process Framework cases that the
user chooses in Workplace Search Results. In InfoPages.xml, you must configure
different “infoPage” nodes, each with “classes” nodes containing only those
OIID/GUID values for the relevant Bp8Case subclass(es) for each instance of
Business Process Framework. In Actions.xml, it will be necessary to configure
different actions, such as “openCase400” and “openCase410” and then configure
the “classes” node under each, to contain only those OIID/GUID values for the
relevant Bp8Case subclass(es) for each instance of Business Process Framework.
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That way, the users will not be able to see the incorrect action and will only see
the one that is appropriate for their own instance of Business Process
Framework.

Definition of installation roles
The tasks in this guide and the rows in the Installation and Upgrade Worksheet are
organized by administrative roles. Your organization might have different roles,
and some of the responsibilities of listed roles will vary from those assigned by
default in this documentation.

Installation administrator
v Runs IBM FileNet P8 installers during initial setup.
v Runs the Configuration Manager tool during initial setup, followed by starting

IBM FileNet Enterprise Manager.
v Runs IBM FileNet P8 Upgrade programs during upgrades.
v Abbreviated as IA. Responsible for coordinating the information described in

this worksheet. The information itself will require the input from the other roles.

The role of IA is usually filled by an IBM FileNet Certified Professional (FCP).

Information technology administrator
v Responsible for the networking and operating systems settings required by IBM

FileNet P8.
v Responsible for performing certain security configurations.
v Abbreviated as ITA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of ITA in the Role column.

Security administrator
v Responsible for configuring the directory servers required by IBM FileNet P8

components, including Content Engine and Application Engine.
v Creates and maintains directory server user and group accounts.
v Abbreviated as SA. Responsible for providing the information in the rows in the

Installation and Upgrade Worksheet with a value of SA in the Role column.

Database administrator
v Creates, configures, maintains database installations and database or table

spaces.
v Responsible for creating database accounts needed by IBM FileNet P8.
v For purposes of this documentation, the database administrator is expected to

have responsibilities regarding the JDBC data sources.
v Abbreviated as DBA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of DBA in the Role column.

Application server administrator
v Responsible for providing the application servers required by IBM FileNet P8.
v Responsible for application server administrative accounts.
v Abbreviated as ASA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of ASA in the Role column.
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IBM FileNet P8 administrator
v This role designation actually refers to the administrator or administrators who

perform regular maintenance of Content Engine, Process Engine Application
Engine, Workplace or Workplace XT.

v The administrator who logs on to Enterprise Manager by using the gcd_admin
account or an object_store_admin account is considered an IBM FileNet P8
administrator.

v Abbreviated as P8A. Responsible for providing the information in the rows of
the Installation and Upgrade Worksheet with a value of P8A in the Role column.

E-mail Administrator
v Creates an e-mail account that will be used to configure the Notification Tab of

the Process Task Manager so that Process Engine can send e-mail notifications to
end users. (Required only if you use this feature.)

v Abbreviated as EA.

Using the installation and upgrade worksheet
The Installation and Upgrade Worksheet is a Microsoft Excel spreadsheet
(p8_worksheet.xls). The worksheet describes the properties and parameters
required to complete IBM FileNet P8 installation, upgrade, and configuration
programs, and provides a way to record the values you assign to these properties
and parameters.

Administrators who are preparing the environment for installation or upgrade of
IBM FileNet P8 components must use the worksheet during their preparation tasks
to record the appropriate values and provide them to the Installation
Administrator who runs the installation or upgrade programs.

Some of the features of the Installation and Upgrade Worksheet are:
v Instructions: describes the worksheet and includes a button that runs the

Customize Worksheet macro.
v The two highlighted columns, Property or Parameter and ENTER YOUR

VALUE HERE, provide the simplest view of the requirement. The others add
identifying information and help you sort and filter the rows usefully.

v The Role column assigns each row to an administrator and uses the following
acronyms:
– ITA: Information Technology Administrator
– ASA: Application Server Administrator
– DBA: Database Administrator
– SA: Security Administrator
– P8A: IBM FileNet P8 Administrator

v Property definitions are contained in the column titled Description.
v Some rows, though not all, contain a hyperlink in the PPG Links column. Click

this hyperlink to run a query against the IBM Information Center, which opens
with the Search Results pane showing the topics that contain the words in the
query phrase. Browse the search results until you have enough information to be
able to enter a value in the Worksheet row.
“Running the Customize Worksheet macro” on page 6
The Customize Worksheet macro lets you extract only those rows that describe
your environment.
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“Autofiltering and sorting the Worksheet”
There are several ways to organize the Worksheet to make finding properties
and entering values easier.

Related reference

Installation and Upgrade worksheet
The worksheet is a Microsoft Excel spreadsheet that describes the properties and
parameters required to complete installation, upgrade, and configuration. It also
provides a way to record the values that you assign to these properties and
parameters.

Running the Customize Worksheet macro
The Customize Worksheet macro lets you extract only those rows that describe
your environment.

Important: For support of the full range of built-in filter and macro features, use
Microsoft Excel to view the Installation and Upgrade Worksheet file. You can use
other spreadsheet programs to view the file; however, filter and macro support can
vary. For example, in Calc from OpenOffice.Org, the column filters work as
expected, but the Customize Worksheet button does not.
To run the Customize Worksheet macro:
1. Open the Installation and Upgrade Worksheet (p8_worksheet.xls) and click the

Instructions worksheet (also called a tab).
2. Scroll down until you see the button representing the Customize Worksheet

macro. Click the button.
3. Select the components and options that describe the environment you are

preparing for IBM FileNet P8.
v Installation or Upgrade
v FileNet P8 Components
v Application Server type
v Operating system
v Database type
v Directory Server type
v Number of object stores (adds new sets of rows for creating additional data

sources)
v Name of customized sheet

4. Click OK. The macro copies the rows that fulfill your selection criteria into a
new worksheet with the name you entered. Enter the values for your
environment into this new worksheet.

5. Click the name of the new worksheet at the bottom of the Excel window. Add
your preparation values into this new worksheet.

6. Notice that the new worksheet has buttons at the top titled Show Installer
View and Show Full View, depending on its state. The Show Installer View
displays only those columns that you need while running installation or
configuration programs.

Autofiltering and sorting the Worksheet
There are several ways to organize the Worksheet to make finding properties and
entering values easier.

AutoFiltering is a quick way to display only those rows that meet a certain criteria.
To use AutoFilter:
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1. Make sure AutoFiltering is enabled. (Select the entire row with the column
headers, then click Data → Filter → Autofilter.) AutoFilter arrows will appear to
the right of the column labels.

2. Click the AutoFilter arrow in the Installation or Configuration Program
column header and select the program you are interested in (for example, PE
installer).

3. Click the AutoFilter arrow in the Setup Type column header, select Custom,
and specify Setup Type contains Installation.

4. For a custom AutoFilter, click the AutoFilter in any column header, select
Custom, and specify Setup Type contains “Installation”.

5. To turn off AutoFiltering in a column, click the column AutoFilter arrow and
select (All).

6. To reorder rows alphabetically, do a Sort:
a. Click anywhere in a column, for example, Column A Role.

The only possible values in the Role column are ASA, SA, DBA, ITA, and
P8A. Sorting on Role therefore groups the rows by this attribute, in
alphabetic order. Several other columns also have a limited number of
possible values which means they can be usefully sorted.

b. Click the Sort Ascending icon in the Excel toolbar, or use the Data → Sort
menu command. The rows sort on Role.
Sorting the Worksheet reassigns row numbers. If you refer to rows by
number, be aware that row numbers change if you change the sort order.

Performing the required installation preparation tasks
To efficiently carry out the required installation preparation tasks, you must assign
your staff to carry out the tasks that are organized by administrative role.

In addition to Business Process Framework specific preparation tasks, follow the
plan and prepare instructions in the Plan and Prepare Your Environment for IBM
FileNet P8 document for the components you are installing.

“IBM FileNet P8 administrator tasks” on page 8
The FileNet P8 Administrator must carry out several tasks to prepare your
environment for your IBM FileNet P8 Platform installation.
“Installation administrator tasks” on page 10
The Installation administrator must coordinate with and delegate
responsibilities to the other administrators to prepare for theBusiness Process
Framework installation.
“Information technology administrator tasks” on page 11
The Information Technology administrator must prepare the network and
operating systems, and carry out certain security configurations to prepare your
environment for Business Process Framework.
“Security administrator tasks” on page 11
The Security administrator must prepare the security environment for Business
Process Framework, including planning the security environment, configuring
the directory server, and creating accounts.
“Database administrator tasks” on page 13
The Database administrator must prepare the databases required for Business
Process Framework, including gathering information about data sources,
creating databases and database accounts, and installing client software.
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IBM FileNet P8 administrator tasks
The FileNet P8 Administrator must carry out several tasks to prepare your
environment for your IBM FileNet P8 Platform installation.

Review all rows assigned to the FileNet P8 Administrator (P8A) in the Installation
and Upgrade Worksheet. While you complete the following preparation tasks,
provide values for the rows that are appropriate to your installation.

Tip: With the Data → Filter → AutoFilter command enabled, as it is by default in
the shipping worksheet file (p8_worksheet.xls), perform the following actions to
quickly see only the properties assigned to a particular role:
v Click the AutoFilter drop-down arrow in the Role column header and select

P8A.
v Further filter the result set by clicking the AutoFilter drop-down arrow in any

of the other columns and selecting a value or clear a filter by selecting All.
“Configuring Content Engine integrated logon (optional)”
Business Process Framework Explorer provides the capability for the
application developer to log on to Content Engine and lookup properties while
configuring Business Process Framework application fields. You can configure
the Content Engine for Windows® Integrated Logon to avoid the requirement to
enter credentials from Business Process Framework Explorer.
“Preparing the bootstrap object store” on page 9
If the Bootstrap object store and the default object store are different, you can
prepare an object store to be the Bootstrap object store.
“Editing Workplace site preferences” on page 9
Site preferences in Workplace influence behavior in the Business Process
Framework Web application.
“Configuring Process Engine case-insensitive view support” on page 10
Process Engine 4.0.3 and later supports case-insensitive views. The new Process
Engine views provide case-insensitive column names. Using these new views
replaces the manual step of removing the quotation marks in the current VWV
views.

Configuring Content Engine integrated logon (optional)
Business Process Framework Explorer provides the capability for the application
developer to log on to Content Engine and lookup properties while configuring
Business Process Framework application fields. You can configure the Content
Engine for Windows Integrated Logon to avoid the requirement to enter
credentials from Business Process Framework Explorer.

The following IBM FileNet P8 documentation reference can assist you in
configuring Windows Integrated Logon for Content Engine: IBM FileNet P8
Documentation → System Administration → Enterprise-wide Administration →
IBM FileNet P8 Security → Authentication → Kerberos for Content Engine.
Because there are system prerequisites for Content Engine Integrated Logon, read
this topic before installing Business Process Framework Explorer. There is no
additional installation or configuration required by Business Process Framework
Explorer to use Windows Integrated Logon.

When running Business Process Framework Explorer, if you log in to Windows by
using a Windows Active Directory domain account, then Business Process
Framework Explorer always uses Integrated Logon to log on to the Content
Engine. If you have not configured Integrated Logon, Business Process Framework
Explorer returns an error when it attempts to log on to the Content Engine. You
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can still work in this environment by typing in by hand the values which Business
Process Framework Explorer otherwise retrieves from the Content Engine.

Preparing the bootstrap object store
If the Bootstrap object store and the default object store are different, you can
prepare an object store to be the Bootstrap object store.

The bootstrap object store stores the site preferences file for Workplace. These
settings are important to the functions of Business Process Framework. The
System-wide setting → Bootstrap Content Engine Object Store Name setting in
Business Process Framework Explorer specifies the display name of the Bootstrap
Object Store. This object store contains Workplace access roles, the Case ID
generation object (Bp8Settings), Business Process Framework stored searches, and
the Business Process Framework site preferences.

A Business Process Framework installation makes changes to the bootstrap object
store configuration. This happens automatically if you are using the default object
store for your bootstrap object store. If you choose to use one other than the
default, you must manually configure the bootstrap object store.

To manually configure the bootstrap object store:
1. Identify the object store that has the Workplace site preference file stored.
2. In Enterprise Manager, import ce_base.xml (available in the Business Process

Framework installation media) to the object store. This action generates a
Bp8Settings object called Settings in the OS → Root Folder → Business Process
Framework folder in the object store.

Editing Workplace site preferences
Site preferences in Workplace influence behavior in the Business Process
Framework Web application.

To set the Workplace site preferences for Business Process Framework:

Set these preferences under Workplace → Admin → Site Preferences → General

v Enable custom objects: Yes
This setting applies to search capabilities. Set this to Yes to allow Business
Process Framework to display necessary objects in search returns. Without this
setting, Workplace searches will not return custom objects like Business Process
Framework case objects or audit log objects.

v Add as major version: Yes
Business Process Framework does not support minor versions of documents in
Content Engine. If you save a document as a minor version, such as 1.1, you
will only see the previous major version, 1, in Business Process Framework. Set
this to yes to ensure that document version integrity is preserved.

v Check in as major version: Yes
Business Process Framework does not support minor versions of documents in
Content Engine. If you save a document as a minor version, such as 1.1, you
will only see the previous major version, 1, in Business Process Framework. Set
this to yes to ensure that document version integrity is preserved.
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Configuring Process Engine case-insensitive view support
Process Engine 4.0.3 and later supports case-insensitive views. The new Process
Engine views provide case-insensitive column names. Using these new views
replaces the manual step of removing the quotation marks in the current VWV
views.

To configure Process Engine case-insensitive views

Use the vwtool with the createDBviewsCI command to create database views that
are not case sensitive. For details, see the IBM FileNet P8 help topic System
Administration Process → Administration → Administrative tools → vwtool →
Commands → createDBviewsCI.

Tip: You can use vwtool to generate a list of database view names to use when
updating the object names of workflow queues in Business Process Framework
Explorer after installation.

Installation administrator tasks
The Installation administrator must coordinate with and delegate responsibilities to
the other administrators to prepare for theBusiness Process Framework installation.

To prepare for the installation:
v Complete the installation worksheet for your environment

If you are using the Installation and Upgrade Worksheet for your environment,
complete the worksheet with the relevant information as described in “Using the
installation and upgrade worksheet” on page 5.

v Verify the contents of the installation package
This information is a brief description of the contents of the Business Process
Framework installation package:

admin (folder)
Contains the filenet_bpf_explorer_setup.exe installation program for
Business Process Framework Explorer.

setup (folder)
Contains the platformfilenet_bpf_setup.bin or .exe files used to
install Business Process Framework.

“Installing Content Engine client libraries”
If Business Process Framework Explorer is installed on a desktop with no
Content Engine client libraries (the “COM Compatibility Client API”
installation feature), Content Engine integration is disabled.

Installing Content Engine client libraries
If Business Process Framework Explorer is installed on a desktop with no Content
Engine client libraries (the “COM Compatibility Client API” installation feature),
Content Engine integration is disabled.

The Business Process Framework Explorer is still usable for all configuration tasks,
but the Business Process Framework Explorer user does not have access to the lists
of object stores, classes and properties. Instead, the user must type in the names of
these entities.
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The Content Engine client libraries are not fully installed with Enterprise Manager.
You must also install the Content Engine client libraries even if installing
Enterprise Manager. See the IBM FileNet P8 Platform Installation and Upgrade Guide
for information.

Information technology administrator tasks
The Information Technology administrator must prepare the network and
operating systems, and carry out certain security configurations to prepare your
environment for Business Process Framework.

“Copying installation software disk contents to target machine”
When you are ready to install, you must make the installation software
available to the administrator who can run the installation.
“Making staging folder accessible”
The staging folder must be accessible from the various systems where Business
Process Framework software is to be installed.

Copying installation software disk contents to target machine
When you are ready to install, you must make the installation software available to
the administrator who can run the installation.

To copy installation software disk contents to a target machine:
1. Insert the disk for the target platform into a reader.
2. For systems other than Windows, mount the disk device.
3. Copy the contents of the disk to a staging folder. This folder must be accessible

to the systems where Business Process Framework software is to be installed.

Making staging folder accessible
The staging folder must be accessible from the various systems where Business
Process Framework software is to be installed.

The following table identifies which servers require access to specific subfolders of
the staging folder.

Table 1. Staging folders

Server Folder

Business Process Framework administrative
workstation

staging folder/misc

staging folder/admin

meta data server staging folder/sql

Web application server staging folder/misc

staging folder/setup

To make the staging folder accessible:
1. Use FTP or a tool of your choice to share the original staging folder or to copy

the staging folder to other servers as indicated in the preceding table.
2. If you copy the staging folder to other servers, record the locations.

Security administrator tasks
The Security administrator must prepare the security environment for Business
Process Framework, including planning the security environment, configuring the
directory server, and creating accounts.
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“Configuring LDAP security”
Your LDAP repository must include any users and groups that can be mapped
to Workplace access roles before you install Business Process Framework.
“Configuring users and groups in Workplace site preferences”
After you have created the users and groups in the LDAP repository, you can
map the user and access roles in the Workplace site preferences. This security
authentication and authorization method supports the Business Process
Framework Case Management sample application.

Configuring LDAP security
Your LDAP repository must include any users and groups that can be mapped to
Workplace access roles before you install Business Process Framework.

The Case Management Sample Application maps its Business Process Framework
Roles to Workplace access roles and then maps Workplace access roles to existing
LDAP users or groups. Users and groups that can be mapped to the following
Workplace access roles must therefore be in your LDAP repository before the
Business Process Framework installation:
v sue
v joe
v ana
v mark

The names of your LDAP users and groups do not have to reflect or resemble the
names of the Workplace access roles to which they are to be assigned. However,
since it often takes considerable lead time to arrange for the creation of new LDAP
Users and groups, it is recommended that you have the security administrator at
your site add the names of your LDAP users and groups to your LDAP repository
before you begin the actual installation.

Important: If you use Workplace access roles to assign Business Process
Framework roles, users that have Full Control access to a Content Engine object
store have access to all Business Process Framework roles. The privileges
associated with Full Control access override any limits set by the Workplace access
roles preventing you from excluding an object store super user from a given
Business Process Framework role. For information about other methods of
assigning roles, see the IBM FileNet Business Process Framework Explorer Handbook.

Configuring users and groups in Workplace site preferences
After you have created the users and groups in the LDAP repository, you can map
the user and access roles in the Workplace site preferences. This security
authentication and authorization method supports the Business Process Framework
Case Management sample application.

The Case Management sample application uses Workplace access roles and maps
them to existing LDAP users or groups. There are five Business Process
Framework Roles defined to support the Case Management sample application
that must be defined in Workplace access roles:
v Supervisor (Add sue LDAP user)
v Indexer (Add joe LDAP user)
v Reviewer (Add mark LDAP user)
v Approver (Add ana LDAP user)
v BPF Site Designers (Add sue LDAP user)
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In Business Process Framework, role membership is managed by LDAP security
group membership. Business Process Framework Roles are linked to Workplace
access roles, which are linked to LDAP Users or Groups.

To enhance performance, it is recommended that you use Workplace access roles
(set the Business Process Framework Metastore setting Enable Access Roles to true)
instead of direct LDAP integration, especially in cases where the LDAP directory is
large or complex (containing many levels of nested groups or folders).

Access Roles must be located in the bootstrap Object Store. This Object Store is
specified in Business Process Framework Explorer system-wide settings.

Within Workplace™ Site Preferences, define Workplace access roles corresponding
to the Business Process Framework Roles required for the Case Management
sample application.

To define corresponding roles:
1. Click Admin → Site Preferences.
2. Click Access Roles.
3. Click Add Role.
4. Name the new role appropriately, such as Supervisor.
5. Remove all default added role members by using the Remove link next to

each member.
6. Click Add New Members.
7. Select either User or Groups to display the appropriate list.
8. Type the beginning characters of the user or group name to be added to this

role, in this case, sue.
9. Click Search. After a brief delay, the matching names are displayed.

10. Choose the appropriate name, such as sue.
11. Click Accept. The Site Preferences page opens again, with the new user or

group name listed for the role under Allowed Access.
12. Add the other required access roles.

v Indexer (Add joe LDAP user)
v Reviewer (Add mark LDAP user)
v Approver (Add ana LDAP user)
v BPF Site Designers (Add sue LDAP user)

13. Click Apply.

When you reach define Metastore roles in Business Process Framework Explorer
you can map these new Workplace access roles to the appropriate security profile
in the Business Process Framework Metastore.

With LDAP integration and Access Roles enabled, an LDAP user who has full
control to the Bootstrap Object Store can see all user profiles, even if they are not
in the LDAP group mapped to an associated access role.

Database administrator tasks
The Database administrator must prepare the databases required for Business
Process Framework, including gathering information about data sources, creating
databases and database accounts, and installing client software.
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“JDBC driver requirements”
The JDBC drivers required to support Business Process Framework must be
available before the installation of Business Process Framework.
“Installing JDBC drivers” on page 15
The Business Process Framework installer uses JDBC to install the Metastore
database and to create the data source in the application server. You must put
the JDBC drivers in a folder on the Business Process Framework server that is
accessible to the installer.
“Configuring the firewall for database access” on page 16
If Business Process Framework Explorer and Business Process Framework Web
application are to access a remote database, you must enable communication
between the Business Process Framework server and the server on which the
database resides.
“Creating a new Metastore database (Step0 script)” on page 16
When you are installing a new Business Process Framework application, you
must create an empty Business Process Framework Metastore database before
you run the Business Process Framework installation program. The Business
Process Framework installation program then creates tables, and populates the
database with initial configuration data.
“Installing the database client for Business Process Framework explorer” on
page 20
First determine whether the database engine is local or remote. The database
engine is local if it is installed on a Windows instance where you plan to install
Business Process Framework Explorer software.
“Database security” on page 21
The Business Process Framework install process requires two different Rational®

database management system user accounts, which are referenced as Business
Process Framework meta admin user and Business Process Framework meta user
in the Business Process Framework Prerequisite Worksheet.
“Enabling accent insensitive collation (optional)” on page 23
Business Process Framework supports both accent-sensitive and accent
insensitive collation for Microsoft SQL Server databases. Accent-sensitive
collation is the default mode.

JDBC driver requirements
The JDBC drivers required to support Business Process Framework must be
available before the installation of Business Process Framework.

The JDBC drivers required to support Business Process Framework are listed in the
IBM FileNet P8 Hardware and Software Requirements document. Make arrangements
with the customer to make sure that the drivers are available before installing
Business Process Framework.

DB2

You can download the db2jcc.jar and db2jcc_license_cu.jar files from the IBM
Support site.

Microsoft SQL Server

You can download the latest jtds-1.x.y.jar file from SourceForge.net.

Oracle

You can download the ojdbc14.jar file from the Oracle Web site.
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Related information

Product documentation, requirement, and compatibility for IBM FileNet P8
Platform
Download IBM FileNet P8 Hardware and Software Requirements, the IBM FileNet
P8 Compatibility Matrix, and other IBM FileNet P8 documentation.

Download the IBM Application Development Client
The IBM Application Development Client includes the DB2 JDBC driver.

Download the jtds-1.x.y.jar file from Sourceforge for Microsoft SQL Server

Installing JDBC drivers
The Business Process Framework installer uses JDBC to install the Metastore
database and to create the data source in the application server. You must put the
JDBC drivers in a folder on the Business Process Framework server that is
accessible to the installer.

If the Metastore and Process Engine databases have different database types, the
directory must contain both JDBC drivers.

“Installing JDBC drivers on Oracle WebLogic Server”
You must put the JDBC drivers in a folder on the Business Process Framework
server that is accessible to the installer.
“Installing JDBC drivers on JBoss Application Server” on page 16
You must put the JDBC drivers in a folder on the Business Process Framework
server that is accessible to the installer.

Installing JDBC drivers on Oracle WebLogic Server:

You must put the JDBC drivers in a folder on the Business Process Framework
server that is accessible to the installer.

If the Metastore and Process Engine databases have different database types, the
directory must contain both JDBC drivers.

If you are using Oracle WebLogic Server with a DB2 Metastore database or a DB2
Process Engine database, you must place the drivers in a directory and add the
drivers to the CLASSPATH of startWebLogic.cmd or startWebLogic.sh.

To install JDBC drivers:
1. Open the WebLogic Server startup script.

Option Description

Windows BEA_HOME\user_projects\domains\
yourdomain\bin\startWeblogic.cmd

UNIX® BEA_HOME\user_projects\domains\
yourdomain\bin\startWeblogic.sh

2. Insert the following text in the script to add the drivers to the CLASSPATH.
The text is shown on two lines for readability. Type the text on a single line in
the script:
set CLASSPATH=c:\jdbc\db2jcc.jar;c:\jdbc\db2jcc_license_cu.jar;
%CLASSPATH%;%MEDREC_WEBLOGIC_CLASSPATH%

3. Restart WebLogic Server.
For more information, see “JDBC driver requirements” on page 14.
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Installing JDBC drivers on JBoss Application Server:

You must put the JDBC drivers in a folder on the Business Process Framework
server that is accessible to the installer.

If the Metastore and Process Engine databases have different database types, the
directory must contain both JDBC drivers.

To install JDBC drivers:
1. Place the drivers in the following directory: JBOSS_HOME/server/server_name/

lib

2. Restart JBoss Application Server.
For more information, see “JDBC driver requirements” on page 14.

Configuring the firewall for database access
If Business Process Framework Explorer and Business Process Framework Web
application are to access a remote database, you must enable communication
between the Business Process Framework server and the server on which the
database resides.

You do not have to configure the firewall if the database resides on the Business
Process Framework server.

Tip: The Business Process Framework firewall configuration is in addition to any
firewall configuration required for Process Engine. For more information about the
Process Engine requirements, see the IBM FileNet P8 Documentation topic: System
Administration → Process Engine Administration → System administration tasks →
Configure firewall ports and setup.

The database Listener port is used for communication between the Business
Process Framework Server and the database.

The ports are bi-directional between the Business Process Framework Server and
the database, and the database and the Business Process Framework Server.

The database ports are user-configurable.
v Oracle listener port (for example, 1521).
v DB2 listener port (for example, 50000).
v Microsoft SQL Server Server listener port (for example, 1433).

Creating a new Metastore database (Step0 script)
When you are installing a new Business Process Framework application, you must
create an empty Business Process Framework Metastore database before you run
the Business Process Framework installation program. The Business Process
Framework installation program then creates tables, and populates the database
with initial configuration data.

Business Process Framework provides a SQL script, called Step0, that contains
sample SQL for database creation. The Step0 script creates the database for DB2
and Microsoft SQL Server. For Oracle, the script creates only the table space and
schema. You can modify and run this script to create the database, or you can use
other tools to create an empty database.
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Important: Do not run the Step0 script if you are upgrading an existing Business
Process Framework application. In that case, the upgraded application uses the
existing Metastore database.

“Creating a DB2 database”
You can use the Step0 SQL Server script to create a Business Process
Framework database on DB2.
“Creating a Microsoft SQL Server database”
You can use the Step0 SQL script to create a Business Process Framework
database on Microsoft SQL Server.
“Creating an Oracle database” on page 18
You can use the Step0 SQL script to create a Business Process Framework table
space and schema on Oracle.

Creating a DB2 database:

You can use the Step0 SQL Server script to create a Business Process Framework
database on DB2.

To create a Business Process Framework database:
1. Create an operating system user to function as meta user for meta database, or

identify an existing user to fill that role.
2. Set the DB2 database page size to 32 KB.
3. If the meta database name meta database is different from the default value

BP8DB, then perform the following steps to change the name in the Step0
script. Otherwise, proceed to step 4. The maximum length for a database name
is eight characters.
a. Open the following file in the editor of your choice: staging

folder\SQL\DB2\Step0.DB2.Bp8.Metabase.1.0.sql

b. Replace all instances of the string BP8DB with your meta database name
meta database.

c. Save the file and close it.
4. If the database location has to be different so that the default location DB2 is

used, then specify the location in the Step0 script. Otherwise, continue with the
next step.
In a high availability environment the database must be on shared storage (for
example, a separate drive letter on Windows or a separate mount point on
UNIX). Running the Step0 script without modifying the location results in the
Metastore database being located on the node where the command was run
rather than on shared store, causing the cluster to fault during failover.

5. Open the Command Editor. Click Start menu → Programs → IBM DB2 →
Command Line Tools → Command Editor.

6. Change the Statement Termination Character to @ (at sign).
You can change this character at the bottom of the Command Editor window.

7. Click Selected → Open to open the Step0.DB2.Bp8.Metabase.1.0.sql file in
Command Editor.

8. Click Selected → Execute to run the script and create the Metastore database.

Creating a Microsoft SQL Server database:

You can use the Step0 SQL script to create a Business Process Framework database
on Microsoft SQL Server.
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To create a Business Process Framework database:
1. 1. If the meta database name meta database is different from the default value

Bp8Metastore, perform the following steps to change the name in the Step0
script. Otherwise, proceed to step 2.
a. Open the following file in the editor of your choice:

staging folder\SQL\SQL\Step0.mssql.Bp8.Metabase.1.0.SQL

b. Replace all instances of the string Bp8Metastore with your meta database
name meta database.

c. Save the file.
2. If SQL Server is installed in a location other than C:\Program Files\Microsoft

SQL Server, perform the following steps to change the path in the Step0 script.
Otherwise, proceed to the next step.

Important: If the path is different and you do not make this change, errors
occur in the CREATE DATABASE statement in
Step0.mssql.Bp8.Metabase.1.0.SQL.
a. Open the following file in the editor of your choice:

staging folder\SQL\SQL\Step0.mssql.Bp8.Metabase.1.0.SQL

b. Search for the following SQL statement text and replace the variable paths
with the correct path for the install directory of SQL Server on your
machine.
CREATE DATABASE [Bp8Metastore] ON
(NAME = N'Bp8Metastore_dat', FILENAME = N'
c:\Program Files\Microsoft SQL Server\MSSQL\data\Bp8Metastore.mdf' ,
SIZE = 5, FILEGROWTH = 10%) LOG ON
(NAME = N'Bp8Metastore_log', FILENAME = N'
c:\Program Files\Microsoft SQL Server\MSSQL\data\Bp8Metastore.ldf' ,
SIZE = 5, FILEGROWTH = 10%)

c. Save and close the file.
3. Click Start menu → Programs → Microsoft SQL Server → Query Analyzer to

open SQL Server Query Analyzer.
4. Log on by using the meta admin user and meta admin password.

a. Select Master Database from the combination box on toolbar.
b. Select File → Open, and select ... staging folder\SQL\SQL\

Step0.mssql.Bp8.Metabase.1.0.SQL.
5. Select Query → Execute.

Creating an Oracle database:

You can use the Step0 SQL script to create a Business Process Framework table
space and schema on Oracle.

To create Business Process Framework table space and schema:
1. Verify the following prerequisites before you begin the installation process:

v The Oracle database exists. This database can be created by using the Oracle
Database Configuration Assistant.

v The Oracle listener for the database exists. The listener can be created by
using the Oracle Net Configuration Assistant.

v The Net Service Name for the database exists. This name can be created by
using the Oracle Net Configuration Assistant.

v You are able to log on to database and run scripts by using Oracle SQL Plus
Worksheet.
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2. Determine if it is preferable in your environment to use the supplied Business
Process Framework script (called Step0) to create a new table space and the
necessary Business Process Framework users, or if they prefer to install into an
existing database configuration. To modify and run the Step0 script, perform
the following steps. Otherwise, proceed to the next step.
a. Locate the Step0 script:

staging folder\SQL\Oracle\Step0.oracle.Bp8.Metabase.1.0.SQL.

Important: It is highly recommended to create a separate table space for
Business Process Framework inside the database. The following procedure
customizes the Step0 script to create this table space.

b. Manually update the Step0 script as follows:
1) Uncomment the following statements by removing the two hyphens (--)

at the beginning of each statement:
--CREATE TABLESPACE "BPF_DATA" DATAFILE
'C:\ORACLE\ORADATA\HFOS\BPF_DATA.ora' SIZE 50M
-- EXTENT MANAGEMENT LOCAL SEGMENT SPACE

MANAGEMENT AUTO;
--CREATE TABLESPACE "BPF_INDEX" DATAFILE
'C:\ORACLE\ORADATA\HFOS\BPF_INDEX.ora' SIZE 50M
-- EXTENT MANAGEMENT LOCAL SEGMENT SPACE

MANAGEMENT AUTO;
-- IDENTIFIED BY "bp8"

DEFAULT TABLESPACE "BPF_DATA"

2) Comment out the following statement by adding two hyphens (--) at the
beginning of the statement: IDENTIFIED BY "bp8" DEFAULT TABLESPACE
"USERS"

The resulting updated SQL script looks like the following script:
CREATE TABLESPACE "BPF_DATA" DATAFILE

'C:\ORACLE\ORADATA\HFOS\BPF_DATA.ora'
SIZE 50M

EXTENT MANAGEMENT LOCAL SEGMENT SPACE
MANAGEMENT AUTO;

CREATE TABLESPACE "BPF_INDEX" DATAFILE
'C:\ORACLE\ORADATA\HFOS\BPF_INDEX.ora'
SIZE 50M

EXTENT MANAGEMENT LOCAL SEGMENT SPACE
MANAGEMENT AUTO;

CREATE USER "BP8" PROFILE "DEFAULT"
IDENTIFIED BY "bp8" DEFAULT TABLESPACE "BPF_DATA"
-- IDENTIFIED BY "bp8" DEFAULT TABLESPACE "USERS"
QUOTA UNLIMITED
ON "BPF_DATA"
ACCOUNT UNLOCK;

GRANT "CONNECT" TO "BP8";
GRANT "RESOURCE" TO "BP8";
GRANT "DBA" TO "BP8";
GRANT SELECT ANY TABLE TO "BP8";

ALTER SESSION SET CURRENT_SCHEMA=BP8;

c. Modify the Step0 script for your environment. In particular, ensure that the
data file location points to the appropriate database directory.
Verify the location of the DATAFILE before starting the script. Record the
appropriate name as the meta database.
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By default the user logon Bp8 (with password Bp8) is created with
read/write access to the Business Process Framework Metastore. Record the
appropriate information in your worksheet as meta user and meta password.

3. Grant the appropriate privileges to the meta admin user.
4. Run the customized step0 script or the script provided by the database

administrator, by using meta admin user, and taking care to run the script
against the Business Process Framework database. If errors occur, review the
script for incorrect references.

Installing the database client for Business Process Framework
explorer
First determine whether the database engine is local or remote. The database
engine is local if it is installed on a Windows instance where you plan to install
Business Process Framework Explorer software.

The database is remote if it is on a separate server from the Business Process
Framework Explorer.

Microsoft SQL Server

If you use a Microsoft SQL Server (local or remote), you do not have to
install the database client for Business Process Framework Explorer.

Database connections for Business Process Framework Explorer at run time
are handled through an ODBC data source.

For an Microsoft SQL Server database, the ODBC data source is
automatically created during the Business Process Framework Explorer
installation.

DB2

If you use a remote DB2 database, you must install the DB2 client
software, and test client connectivity to database server before installing
Business Process Framework Explorer application. If the DB2 database is
local to the Business Process Framework Explorer, this client software
installation is not necessary because the database server installation
includes the necessary client software.

Database connections for Business Process Framework Explorer at run time
are handled through an ODBC data source.

For an DB2 database, the ODBC data source is configured with a database
alias name. Make sure that the database alias name is configured and
tested before you install Business Process Framework Explorer.

Oracle

If you use a remote Oracle database, you must install the Oracle client
software, and test client connectivity to database server before installing
Business Process Framework Explorer application. If the Oracle database is
local to the Business Process Framework Explorer, this client software
installation is not necessary because the database server installation
includes the necessary client software.

The database connection for Business Process Framework Explorer at run
time are handled through the Oracle OLEDB Provider. This is the same
provider that is used for the Oracle SQLPlus client. Although Business
Process Framework Explorer uses the Oracle OLEDB Provider, the
WFImport utility that is used to import workflow configuration from PEP
files (workflow maps) uses an ODBC datasource.
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For an Oracle database, the ODBC data source is configured with a TNS
name. The TNS name must be created and tested before Business Process
Framework Explorer installation.

To install the Oracle client:

This procedure shows the minimal choices (specific to the needs of Business
Process Framework metastore) for installing a database client. Consult the Oracle 9i
or Oracle 10g installation documentation for complete preinstallation requirements
and instructions.

From the Available Products screen:
1. For Oracle 9i, choose from the list of available product components:

v Oracle 9i Client
v Oracle Network Utilities
v Oracle Database Utilities
v SQL *PLUS
v (Windows) Oracle Windows Interfaces (select all the subcomponents)
v Oracle Services for Microsoft Transaction Server

2. For Oracle 10g, choose from the list of available product components:
v Oracle 10g Client
v Oracle Network Utilities
v Oracle Database Utilities
v SQL *PLUS
v (Windows) Oracle Windows Interfaces (select all the subcomponents)
v Oracle Services for Microsoft Transaction Server

3. Using Oracle Net Configuration Assistant, test the connection to the Oracle
database server with an appropriate Oracle user and password.

See the Plan and Prepare Your Environment for IBM FileNet P8 for additional
information about installing and configuring database clients.

Database security
The Business Process Framework install process requires two different Rational
database management system user accounts, which are referenced as Business
Process Framework meta admin user and Business Process Framework meta user in
the Business Process Framework Prerequisite Worksheet.

“Meta database admin user for database creation”
The meta admin user is an administrator account required to access the
Metastore provider. Typically, this account is used only during database
creation.
“Meta database user for runtime access” on page 22
The meta user is an account required to access the Metastore Provider on an
ongoing basis by both the Business Process Framework Web Application and
Business Process Framework Explorer.

Meta database admin user for database creation:

The meta admin user is an administrator account required to access the Metastore
provider. Typically, this account is used only during database creation.
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It might be necessary to have a DBA with an account that has the privileges to
perform the tasks of the meta admin user during the installation. Many companies
do not divulge the passwords for accounts with this level of privilege to
installation personnel. In such circumstances, have one of your DBAs run these
scripts for you by using any account they choose (as long as it has the DBA Role
with the SYSDBA Privilege).

DB2

The SYSDBA privilege is required to create new database (assuming that the
Business Process Framework table spaces are to be located in a new database).
Roles required: DBA.

Oracle

The SYSDBA privilege is required to create new database (assuming that the
Business Process Framework table spaces are to be located in a new database).
Roles required: DBA.

SQL Server

System Administrators server role.

Meta database user for runtime access:

The meta user is an account required to access the Metastore Provider on an
ongoing basis by both the Business Process Framework Web Application and
Business Process Framework Explorer.

The meta user is an account required to access the Metastore Provider on an
ongoing basis by both the Business Process Framework Web Application and
Business Process Framework Explorer.

This account must have read/write access to the Business Process Framework
Metastore database. The Business Process Framework Metastore creation scripts
create this user and grant privileges for Microsoft SQL Server and Oracle. For DB2,
you must create an operating system user and assign it the appropriate privileges
yourself.

DB2

v System Privileges: Create table, View, and Stored Procedure.
v Group: Must be in DB2 user group. By default this group is named:

– DB2USERS on Windows platforms
– db2grp1 on UNIX platforms

Oracle

v Roles: CONNECT
v System Privileges: CREATE SESSION (this comes with the CONNECT Role)
v Object Permissions: Either EXECUTE (for stored procedures) or INSERT,

UPDATE, DELETE, and SELECT permission on all Bp8 objects.
If your schema is named Bp8 and you are using the Bp8 user account (schema
owner) as your meta user, then your meta user schema automatically has these
permissions.
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If you are using an account other than the schema owner as your meta user, then
you must develop and run scripts to grant to the meta user the specified
privileges on each object in the schema. For example: GRANT INSERT,
UPDATE, DELETE, SELECT ON application_settings to Bp8. Because the ANY
privileges apply to the whole database and not just an individual schema, you
must grant the specified privileges for each table, view, stored procedure, and so
on, individually. There is no separate privilege to grant SELECT, for example, on
all objects in a schema.
By default, both the Business Process Framework Oracle meta user and schema
are named BP8. If you use a different name for the meta user and schema, you
must change the following line in Bp8sql.xml file to use the new name:
<ORACLE>alter session set current_schema=meta user</ORACLE>

The Bp8sql.xml file is in the Business Process Framework Explorer home
directory in the same directory as the Business Process Framework Explorer.msc
file.
In addition, if you use the scripts provided with the Business Process
Framework software to create a Business Process Framework Metastore
manually, you must change the meta user name prior to running the scripts. (The
Business Process Framework installer normally creates the Business Process
Framework Metastore automatically; in this case there is no reason to change the
name in the scripts by hand.)
– In the Step0.oracle.Bp8.Metabase.1.0.sql file, change all references to the

meta user name.
– In the Step1.oracle.Bp8.Metabase.1.0.sql,

Step2.oracle.Bp8.Metabase.1.0.sql, and
Step3.oracle.Bp8.Metabase.1.0.sql files, change the meta user name in the
following line:
ALTER SESSION SET CURRENT_SCHEMA=meta user;

Microsoft SQL Server

public and db_owner roles.

Enabling accent insensitive collation (optional)
Business Process Framework supports both accent-sensitive and accent insensitive
collation for Microsoft SQL Server databases. Accent-sensitive collation is the
default mode.

To enable accent insensitive collation:
1. Navigate to the appropriate folder for your database:

v staging folder\sql\DB2

v staging folder\sql\Oracle

v staging folder\sql\SQL

2. 2. Edit the Step0, Step1, Step2, and Step3 files to change the following line:
COLLATE SQL_Latin1_General_CP1_CI_AS to COLLATE
SQL_Latin1_General_CP1_CI_AI

3. Load data into the Business Process Framework Metastore database manually.
For instructions, see “Loading the Business Process Framework Metastore” on
page 110.

4. Import the Business Process Framework Metastore manifest manually. For
instructions, see “Importing the Metastore manifest” on page 112.
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Installing and configuring Business Process Framework

After you plan your installation and perform the prerequisite tasks, you can install
and configure Business Process Framework.

“Environment conditions that require additional manual configuration after
installation”
The Business Process Framework installation program automatically configures
the P8 Platform environment to work with Business Process Framework.
However, some component versions require additional manual configuration
after the installation is complete.
“Installing Business Process Framework” on page 27
You can choose to install Business Process Framework automatically, using the
installation program, or manually. If you choose a manual installation, you
must also manually configure the applications after the installation.
“Verifying Business Process Framework server installation” on page 32
After you complete the Business Process Framework installation, you can verify
the installation by checking log entries and testing the connections and the
application.
“Configuring Business Process Framework server after installation” on page 40
The Business Process Framework server installation program configures many
necessary settings automatically. However, you must perform additional
configuration when you complete the installation.
“Installing Business Process Framework Explorer” on page 44
Business Process Framework Explorer provides the capability for the
application developer to log on to Content Engine and look up properties while
configuring Business Process Framework application fields. Install Business
Process Framework Explorer on a Windows machine.
“Verifying the Business Process Framework Explorer installation” on page 44
You can verify the Business Process Framework Explorer installation by
checking whether you can log on to Business Process Framework Explorer
without errors.
“Configuring Business Process Framework Explorer after installation” on page
44
Although the Business Process Framework Explorer installation program
automatically configures the application, you must perform some additional
configuration with the installation is complete.
“Logging on to a sample Business Process Framework Web application” on
page 49
You can verify the installation and configuration by logging on to the Business
Process Framework application you set up.

Environment conditions that require additional manual configuration
after installation

The Business Process Framework installation program automatically configures the
P8 Platform environment to work with Business Process Framework. However,
some component versions require additional manual configuration after the
installation is complete.
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Installing with Process Engine version 4.0.3 or later

If you install Business Process Framework with Process Engine version 4.0.3 or
later, you must perform the following additional configuration tasks manually:
v Creating base or solution-specific workflow objects

Important: Import qcreate_cm.xml and qcreate_base.xml from the BPF 4.1.0-003
fix pack package, not from the BPF4.1.0 installer package.

v Updating the Process Map
v Applying P8 Platform changes to the Business Process Framework installation

Installing with Application Engine versions 4.0.2.0, 4.0.2.1, or
4.0.2.2

Installing with certain versions of Application Engine can result in a login error. To
prevent the error, you can upgrade to Application Engine 4.0.2.3. To maintain an
earlier version of Application Engine, you can copy containericons.properties
and customobjecticons.properties from install_path\Config\AE\ to
install_path\Config\bpf.

Installing on Oracle WebLogic Server 10.x and WebSphere®

Application Server 7.x

Although Oracle WebLogic Server 10.x and WebSphere Application Server 7.x are
supported application server platforms, the Business Process Framework
installation program does not include these choices. During the installation, choose
Oracle WebLogic Server 9.2 instead of 10.x, or choose WebSphere Application
Server 6.1 instead of 7.x.

Installing on JBoss Application Server 4.2.3

JBoss Application Server 4.2.3 is a supported application server platform. However,
the Business Process Framework installation program does not deploy
automatically to JBoss Application Server 4.2.3. To enable manual deployment,
remove the following files from the /BPF/WEB-INF/lib directory:
v serializer.jar

v xalan.jar

v xercesImpl.jar

v xml-apis.jar

After you have deleted the jar files, manually deploy the Business Process
Framework application. See the task Manually deploying the Business Process
Framework Web application on JBoss Application Server.

Installing with DB2 9.5

If you want to use DB2 version 9.5, you must manually configure the Metastore
database. The installation program asks ″Do you want to create the Metastore
automatically?″ If you are installing with DB2 9.5, choose No for this option. After
the installation program is complete, follow the steps in Loading the Business
Process Framework Metastore on DB2 to manually create the Business Process
Framework Metastore database.
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Related tasks

“Creating base or solution specific workflow objects” on page 104
If certain base and solution specific workflow objects were not created during the
Business Process Framework automatic installation, you can create them by editing
XML files and importing them in the Process Configuration Console.
“Loading the Business Process Framework Metastore” on page 110
You can choose to manually load data into the Business Process Framework
Metastore database.
“Deploying the Web application on JBoss Application Server 4.0.x or 4.2.x” on page
143
You can manually deploy the Business Process Framework Web application on
JBoss Application Server 4.0.x or 4.2.x.
“Applying IBM FileNet P8 Platform changes to the Business Process Framework
installation” on page 144
You can apply IBM FileNet P8 Platform changes to the Business Process
Framework installation. Verify your installation and component versions.
Related reference

“Updating the process map” on page 105
Updating the process map is an automated process in the Business Process
Framework installation program. If an error occurs during this part of the
installation, you can manually update the process map using the Workplace
application.

Installing Business Process Framework
You can choose to install Business Process Framework automatically, using the
installation program, or manually. If you choose a manual installation, you must
also manually configure the applications after the installation.

“Installing Business Process Framework with automatic configuration”
You can choose to use the Business Process Framework automatic installation
program, for an interactive or silent installation. This installation tool not only
installs the application, but also configures the datasource and the FileNet P8
Platform environment.
“Manually installing Business Process Framework” on page 30
Although the easiest and safest way to install Business Process Framework is to
allow the installer to automatically perform most of the tasks, many portions of
the installation can instead be performed manually for more control.

Installing Business Process Framework with automatic
configuration

You can choose to use the Business Process Framework automatic installation
program, for an interactive or silent installation. This installation tool not only
installs the application, but also configures the datasource and the FileNet P8
Platform environment.

The Business Process Framework automatic installation program installs the
application on the Web application server. The installation program also does the
following configuration tasks automatically:
v Creating data sources on the Web application server.
v Deploying the Business Process Framework Web Application to the Web

application server.
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v Configuring Business Process Framework Operations XML files (bp8_config.xml
and log4j.xml).

v Adding appropriate database stubs in the Component Manager classpath.
v Running Metastore schema scripts.
v Importing Metastore database configuration.
v Updating the Workplace URL, Process Engine connection point name, and

Process Engine view names in the Metastore configuration.

You can only use automatic installation on the first instance of Business Process
Framework. Any additional Business Process Framework instances must be
installed and configured manually.

“Installing Business Process Framework interactively”
The Business Process Framework installation program prompts you for the
site-specific information required to install the Business Process Framework
Web application. See the completed Installation and Upgrade Worksheet for this
information.
“Installing Business Process Framework silently” on page 29
You can install and configure Business Process Framework silently. To do so,
you first must create a response file which can be used to perform a silent
installation or upgrade.
“Backup files created by the Business Process Framework installation program”
on page 30
The Business Process Framework installation program adds configuration to
files in the Application Engine installation. The installation program creates
backups of these files before it changes the files.

Installing Business Process Framework interactively
The Business Process Framework installation program prompts you for the
site-specific information required to install the Business Process Framework Web
application. See the completed Installation and Upgrade Worksheet for this
information.
v Ensure that the Content Engine, Process Engine, and Application Engine are

running and operational so that the installer can deploy the new application and
configure the IBM FileNet P8 environment.

v Ensure that the Business Process Framework Metastore database server is
running, so that the installer can populate the empty Metastore.

v Stop the Component Manager and close all open Process Task Manager tools on
the Application Engine so that the installer can update the vwtaskman.xml file in
the Application Engine Router directory.

To install Business Process Framework interactively:
1. Open your completed Installation and Upgrade Worksheet file.

Tip: In the worksheet file, verify that the Data → Filter → AutoFilter command
is enabled. To view Business Process Framework values, filter by BPF Installer
in the Installation or Configuration Program column.

2. 1. Start the Business Process Framework setup wizard:

Option Description

AIX®: Navigate to /staging_folder/setup and run
AIXfilenet_bpf_setup.bin.
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Option Description

HP-UX RISC: Navigate to /staging_folder/setup and run
HPUXfilenet_bpf_setup.bin.

HP-UX Itanium®: Navigate to /staging_folder/setup and run
HPUXIA64filenet_bpf_setup.bin.

Linux®: Navigate to /staging_folder/setup and run
LINUXfilenet_bpf_setup.bin.

Solaris: Navigate to /staging_folder/setup and run
SOLARISfilenet_bpf_setup.bin.

Windows: Navigate to \staging_folder\setup and run
WINDOWSfilenet_bpf_setup.exe.

3. Complete the Business Process Framework Web application installation
program screens with the values recorded in your Installation and Upgrade
Worksheet.

4. Restart the Application Engine and Business Process Framework application
server after the installation completes.

Installing Business Process Framework silently
You can install and configure Business Process Framework silently. To do so, you
first must create a response file which can be used to perform a silent installation
or upgrade.
v Ensure that the Content Engine, Process Engine, and Application Engine are

running and operational so that the installer can deploy the new application and
configure the IBM FileNet P8 environment.

v Ensure that the Business Process Framework Metastore database server is
running, so that the installer can populate the empty Metastore.

v Stop the Component Manager and close all open Process Task Manager tools on
the Application Engine so that the installer can update the vwtaskman.xml file in
the Application Engine Router directory.

To install Business Process Framework silently:
1. Open your completed Installation and Upgrade Worksheet file.

Tip: In the worksheet file, verify that the Data → Filter → AutoFilter command
is enabled. To view only Business Process Framework values, filter by BPF
Installer in the Installation or Configuration Program column.

2. Use the values specified in your Installation and Upgrade Worksheet to modify
the Windows or UNIX default silent input file to match your environment. The
silent input file is located at staging folder/setup/BPF_silent_input.txt. You
can also record a response file by running the installation program with the
following parameters:

Option Description

Windows Platformfilenet_bpf_setup.exe
-options-record BPFSilentInstall.rsp

UNIX Platformfilenet_bpf_setup.bin
-options-record BPFSilentInstall.rsp

3. To load parameters from the response file to use as initial values in the setup
UI, run the installation program with the following parameters:
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Option Description

Windows WINDOWSfilenet_bpf_setup.exe -options
BPFSilentInstall.rsp

UNIX PLATFORMfilenet_bpf_setup.bin -options
BPFSilentInstall.rsp

4. To perform a silent installation, where the parameters are taken from the
response file and no setup UI is presented, use one of these commands to run
the installation program:

Option Description

Windows WINDOWSfilenet_bpf_setup.exe –options
BPFSilentInstall.rsp –silent

UNIX PLATFORMfilenet_bpf_setup.bin –options
BPFSilentInstall.rsp –silent

Backup files created by the Business Process Framework
installation program
The Business Process Framework installation program adds configuration to files in
the Application Engine installation. The installation program creates backups of
these files before it changes the files.

The Business Process Framework Web Application installer updates the Workplace
configuration files under the AE_install_dir/FileNet/Config/AE folder and the
Process Engine connection configuration files under the /Router folder on the
Application Engine server.

During automatic installation, the installer creates copies of the original
configuration files, renamed to .bak, in the same directory as the original files.

Manually installing Business Process Framework
Although the easiest and safest way to install Business Process Framework is to
allow the installer to automatically perform most of the tasks, many portions of the
installation can instead be performed manually for more control.

To manually install Business Process Framework:
1. Follow the same steps as for automatic install, in the Configuration of the

environment before Business Process Framework server installation topic.

Tip: The Business Process Framework Operations component must be installed
and configured by the installer. You cannot manually configure this component.
Therefore, if you are performing a custom installation, you must select the
Business Process Framework Operations component on the Select features
screen to make the Business Process Framework Operations available to your
applications. (If you do not, you must run the installer again if you want to
install and configure the Business Process Framework Operations. Doing so
reinstalls the Business Process Framework Web application files. Because the
custom installation option does not support installation of individual
components, you must always select the Business Process Framework Metastore
and the Business Process Framework Web Application along with any other
components to be installed.)
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2. Run the installation program as documented in Installing Business Process
Framework with automatic configuration. On the screen Choose the installation
type that best suits your needs, choose Custom.

3. On the next screen, leave unchecked any feature you want to install or
configure manually:
a. Import of the Content Engine/Process Engine manifest and add or transfer

case management sample workflow
b. Creation of data sources
c. Deployment of the Web application
d. Creation of the Business Process Framework Metastore and import of

Business Process Framework manifest
4. Manually do only the configuration tasks you chose not to have the installer do

automatically:
a. If you did not select Case Management Sample Configuration on the Installer

screen which contains the select the features for Business Process
Framework and want to install the Case Management Sample Configuration
manually, then import the Content Engine/Process Engine manifest and
add/transfer case management sample workflow:
v “Importing Content Engine base objects” on page 103
v “Importing Content Engine solution specific objects” on page 103
v “Creating base or solution specific workflow objects” on page 104
v “Updating the process map” on page 105

b. If you did not select User-defined Configuration on the Installer screen
which contains the select the features for Business Process Framework and
want to install a user-defined configuration manually, then import the
user-defined Content Engine/Process Engine manifest, add or transfer
user-defined workflow and optionally install custom code:
v “Importing Content Engine base objects” on page 103
v “Importing Content Engine solution specific objects” on page 103
v “Creating base or solution specific workflow objects” on page 104
v “Updating the process map” on page 105
If you have custom code, manually add the custom code such as JSP, JAR,
or XML files to the Business Process Framework WAR or EAR or Business
Process Framework folder in the installation location and deployment
location.

c. If you selected Use Existing on the Installer screen that asks for the Process
Engine Datasource and Metastore Datasource, then create data sources:
v “Creating the JDBC data source for the Business Process Framework

Metastore” on page 115
v “Creating the JDBC data source for the Process Engine” on page 127

d. If you selected No on the Installer screen that asks if you want to deploy
Web application automatically, then deploy the Web application, following
the steps in “Deploying the Business Process Framework Web application”
on page 139.

e. If you selected No on the Installer screen that asks if you want to create
Metastore automatically, then load the Business Process Framework
Metastore and import the Business Process Framework manifest:
v “Loading the Business Process Framework Metastore” on page 110
v “Importing the Metastore manifest” on page 112

5. Continue the procedure followed during automatic installation.
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Follow the steps from “Verifying Business Process Framework server
installation,” through and including “Configuring Business Process Framework
server after installation” on page 40 (including all sections in between).

6. If you chose to manually import the Metastore Manifest, follow the steps in
“Editing the Metastore settings” on page 113.

7. Validate the Business Process Framework Web Application by following the
steps in “Logging on to a sample Business Process Framework Web
application” on page 49.

Verifying Business Process Framework server installation
After you complete the Business Process Framework installation, you can verify
the installation by checking log entries and testing the connections and the
application.
1. “Checking for errors logged during installation”

The automatic installation process creates connections to various system
components to import and configure data and parameters. If any errors occur
during the installation process (for example, if the Content Engine server is not
responding), the installer continues to install the other components and shows
error messages when the installation completes.

2. “Testing data source connections” on page 37
You can test the JDBC data source connections to the Business Process
Framework Metastore and the Process Engine.

3. “Verifying that the Web application is deployed and running” on page 39
You can use the application server console or tools to verify that the Business
Process Framework Web application is deployed and running.

4. “Verifying the Business Process Framework operations component” on page 40
You must verify that Verify that the Business Process Framework operations
component is started in Component Manager.

Checking for errors logged during installation
The automatic installation process creates connections to various system
components to import and configure data and parameters. If any errors occur
during the installation process (for example, if the Content Engine server is not
responding), the installer continues to install the other components and shows
error messages when the installation completes.

“Business Process Framework log file locations”
The Business Process Framework installation process creates log files to record
results and issues. Check the logs for errors after the installation.
“Business Process Framework error messages” on page 35
Search for the Error key word in the log files. If errors occur, you can do
manual configuration to correct the problems.

Business Process Framework log file locations
The Business Process Framework installation process creates log files to record
results and issues. Check the logs for errors after the installation.

Table 2. Log file names and descriptions

Log file Description

.../FileNet/BPF/BPFInstaller.log Contains the InstallShield log. This shows what
InstallShield-level components were started and which of
those components, if any, failed during installation.
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Table 2. Log file names and descriptions (continued)

Log file Description

.../FileNet/BPF/BPFInstallerAnt.log Contains the results of the manifest import of the
Business Process Framework specific configuration into
the Content Engine and Process Engine and the results of
Workplace integration configuration.
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Table 2. Log file names and descriptions (continued)

Log file Description

.../FileNet/BPF/instdata/logs/*.log These logs provide detailed information on the
configuration tasks performed by the installer. In general,
if a component is installed successfully, you will see
BUILD SUCCESSFUL at the end of the associated log in
this directory; otherwise you will see BUILD FAILED.

install_bpf_metastore_install.log
Log file for Metastore population

install_create_ear.log
Log file for packaging of the WebApp.

install_create_war.log
Log file for packaging of the WebApp.

install_DeployWebApp_appserver.StartApp.log
Log file for deployment of the WebApp.

install_is_bp8opcfg_bp8ciops.log
Log file for configuration of Business Process
Framework operations and modification of
bp8_config.xml and log4j.xml in bpfciops.jar.

install_is_bp8opcfg_taskman_jdbc.log
Log file for configuration of Application Engine
connection point and modification of
vwtaskman.xml.

install_MetastoreDS_appserver.Configjdbc.log
Log file for creation of the Metastore data source.

install_ProcessDS_appserver.Configjdbc.log
Log file for create Process Engine database data
source.

install_is_bpfup_del_webroot.log
Log file for deletion of temporary folder webroot.

install_summary.log
Summary showing whether each component was
installed or configured successfully.

.properties files
These files are for internal use by the installer
and are not generally useful for diagnostic
purposes. They can be ignored.

.all files
These files are for internal use by the installer
and are not generally useful for diagnostic
purposes. They can be ignored.

install_trace.log
These files are for internal use by the installer
and are not generally useful for diagnostic
purposes. They can be ignored.

install_status.log
These files are for internal use by the installer
and are not generally useful for diagnostic
purposes. They can be ignored.
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Table 2. Log file names and descriptions (continued)

Log file Description

.../FileNet/BPF/logs/bpf_donot_delete.jar This file contains temporary data created during import
of the manifest into Content Engine and Process Engine,
during workflow transfer, and during configuration of
Workplace integration.

This file is for internal use by the installer and is not
generally useful for diagnostic purposes. It can be
ignored.

Business Process Framework error messages
Search for the Error key word in the log files. If errors occur, you can do manual
configuration to correct the problems.

The following tables summarize the errors that might occur in the installation
process. In each table, the problem column identifies the general cause of the
problem. The solution column provides a reference to the topic in “Manually
editing installation settings” on page 99 that describes how to manually install the
component that did not install.

Table 3. Error in creating the BPFAssembly folder

Error message Possible problem Solution

The Business Process Framework
installer cannot create the
bpf_install_path/FileNet/
BPFAssembly folder on a UNIX server
if a previous or partially successful
installation or uninstallation exists.

1. Uninstall Business Process
Framework.

2. Manually delete the folder at
/InstallShield/Universal/
FileNet/BPF.

3. Reinstall Business Process
Framework.

Table 4. Error in base manifest or case management manifest

Error message Problem Solution

Noncritical exception encountered
while installing Base Manifest to
Content Engine Object Store.

The Content Engine Base Manifest
was not imported.

See “Importing Content Engine base
objects” on page 103

Noncritical exception encountered
while installing Case Management
Manifest to Content Engine Object
Store.

The Content Engine Case
Management Manifest was not
imported.

See “Importing Content Engine
solution specific objects” on page 103

Table 5. Error in custom objects import in Content Engine

Error message Possible problem Solution

Noncritical exception encountered
while installing Custom Manifest to
Content Engine Object Store.

The custom Content Engine manifest
import XML file was not imported

Use Enterprise Manager to import the
file manually. See the IBM FileNet P8
Platform documentation for the
import procedure details.
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Table 6. Error in base or solution specific workflow object creation

Error message Possible problem Solution

Noncritical exception encountered
while installing Base Workflow Queue
Configuration.

Certain base and solution specific
workflow objects were not created.

This error can occur if the Process
Engine server is not responding.

“Creating base or solution specific
workflow objects” on page 104
manually.

Noncritical exception encountered
while installing Case Management
Workflow Queue Configuration.

This error can occur if the Process
Engine server is not responding.

“Creating base or solution specific
workflow objects” on page 104
manually.

Table 7. Error in custom workflow object creation

Error message Possible problem Solution

Noncritical exception encountered
while installing custom Workflow
Queue Configuration.

An error occurred during custom
workflow object creation regarding
the custom Content Engine manifest
import XML file.

See the IBM FileNet P8 Platform
documentation to create workflow
object manually.

Table 8. Error in updating solution specific process map

Error message Possible problem Solution

Noncritical exception encountered
while installing Case Management
Workflow Transfer.

An error occurred while installing the
case management process map.

“Updating the process map” on page
105.

Table 9. Error in updating custom process map

Error message Possible problem Solution

Noncritical exception encountered
while installing Custom Workflow
Transfer.

An error occurred while installing the
Custom Workflow Transfer process
map.

See the IBM FileNet P8 Platform
documentation to create the process
map manually.

Table 10. Error in updating taskman policy file

Error message Possible problem Solution

Noncritical exception encountered
while updating Application Engine
taskman policy file.

The taskman policy file in the router
folder was not updated.

See “Editing the taskman policy” on
page 106.

Table 11. Error in updating taskman login configuration

Error message Possible problem Solution

Noncritical exception encountered
while updating Application Engine
taskman login configuration.

The taskman login configuration in
the router folder under the
Application Engine installation folder
was not updated.

See “Editing taskman login
configuration” on page 108.

Table 12. Error in updating vwtaskman.xml file

Error message Possible problem Solution

Noncritical exception encountered
while updating vwtaskman.xml.

The vwtaskman.xml configuration in
router folder under the Application
Engine installation folder was not
updated.

See “Adding taskman libraries
(vwtaskman.xml)” on page 106.

36 Installation Guide



Table 13. Error in updating taskman.properties file

Error message Possible problem Solution

Noncritical exception encountered
while updating taskman.properties.

The taskman.properties configuration
in the router folder under the
Application Engine installation folder
was not updated.

This error can occur the Application
Engine information provided during
installation was not correct.

See “Editing the taskman.properties
file” on page 106.

Table 14. Error in updating workplace integration files

Error message Possible problem Solution

Noncritical exception encountered
while copying Bp8ViewActions.jsp to
Workplace or updating Actions.xml,
infopages.xml, Integration.xml.

The Workplace files for Business
Process Framework were not
updated.

Manually update the Workplace files
as described in “Workplace
integration” on page 101.

Table 15. Error in creating data sources

Error message Possible problem Solution

Data sources were not created
properly during the automatic
installation.

Manually create the data sources
following the steps in these sections:

v “Creating the JDBC data source for
the Business Process Framework
Metastore” on page 115

v “Creating the JDBC data source for
the Process Engine” on page 127

Table 16. Error in deploying Web application

Error message Possible problem Solution

Web application was not properly
deployed during the automatic
installation.

Manually deploy the Web application
following the steps in this section:
“Deploying the Business Process
Framework Web application” on page
139

Table 17. Error in creating Business Process Framework metastore and importing the metastore manifest

Error message Possible problem Solution

The Business Process Framework
Metastore was not created or the
Metastore Manifest was not
successfully imported.

Manually create the Metastore and
import the manifest as described in:

v “Loading the Business Process
Framework Metastore” on page 110

v “Importing the Metastore manifest”
on page 112

Testing data source connections
You can test the JDBC data source connections to the Business Process Framework
Metastore and the Process Engine.

Installing and configuring Business Process Framework 37



“Testing the data source connection on WebLogic Server 8.1.5”
You can use the WebLogic Server 8.1.5 Administrative Console tools to test the
data source connections.
“Testing the data source connections on WebLogic Server 9.2.x and 10”
You can use the WebLogic Server 9.2.x or 10 Administrative Console tools to
check the data source connections.
“Testing the data source connections on WebSphere Application Server 6.0” on
page 39
You can use the WebSphere Application Server 6.0 Administrative Console to
test the data source connections.
“Testing the data source connections on WebSphere Application Server 6.1” on
page 39
You can use the WebSphere Application Server 6.1 Administrative Console to
test the data source connections.
“Testing the data source connections on WebSphere Application Server 7.0” on
page 39
You can use the WebSphere Application Server 7.0 Administrative Console to
test the data source connections.

Testing the data source connection on WebLogic Server 8.1.5
You can use the WebLogic Server 8.1.5 Administrative Console tools to test the
data source connections.

To test a data source connection:
1. Log in to WebLogic Server console by using a Web browser: http://web

application server:7001/console
2. Select Domain name → Services → JDBC → Connection Pools.
3. Select the Connection Pool which is used by Business Process Framework.
4. Click Configuration → Connections tab.
5. Select Show advance options.
6. Enable Test Reserved Connections and Test Created Connections.
7. Click the Testing tab.
8. Click Test pool. A success message should be displayed.
9. Repeat the previous steps for the Process Engine data source.

Testing the data source connections on WebLogic Server 9.2.x
and 10
You can use the WebLogic Server 9.2.x or 10 Administrative Console tools to check
the data source connections.

To test a data source connection:
1. Log in to WebLogic Server console by using a Web browser: http://web

application server:7001/console
2. Select Services → JDBC → Data Sources

3. Select the data source for the Metastore data source.
4. Click the Monitoring tab.
5. Click the Testing tab.
6. Select the target server.
7. Click the Test Data Source button. A success message displays.
8. Repeat steps for the Process Engine data source.
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Testing the data source connections on WebSphere Application
Server 6.0
You can use the WebSphere Application Server 6.0 Administrative Console to test
the data source connections.

To test the connections:
1. Log onto WebSphere Application Server Administrative Console: http://web

application server:9060/ibm/console.
2. Click Resources → JDBC Providers.
3. Select the JDBC provider that is used for the Business Process Framework

Metastore.
4. Click Data Sources in the Additional Properties.
5. Select the checkbox for meta datasource.
6. Click Test Connection. A success message displays.
7. Repeat steps for the Process Engine data source.

Testing the data source connections on WebSphere Application
Server 6.1
You can use the WebSphere Application Server 6.1 Administrative Console to test
the data source connections.

To test the connections:
1. Log onto WebSphere Application Server Administrative Console: http://web

application server:9060/ibm/console
2. Click Resources → JDBC Providers → Data Sources.
3. Select the checkbox for meta datasource.
4. Click Test Connection. A success message should be displayed.
5. Repeat steps for the Process Engine data source.

Testing the data source connections on WebSphere Application
Server 7.0
You can use the WebSphere Application Server 7.0 Administrative Console to test
the data source connections.

To test the connections:
1. Log onto WebSphere Application Server Administrative Console: http://web

application server:9060/ibm/console
2. Click Resources → JDBC → Data sources.
3. Select the checkbox for meta datasource.
4. Click Test connection. A success message is displayed.
5. Repeat steps for the Process Engine data source.

Verifying that the Web application is deployed and running
You can use the application server console or tools to verify that the Business
Process Framework Web application is deployed and running.
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To verify the deployment was successful:

Option Description

WebSphere Application Server 6.x or 5.x From the Administrative Console, expand
Applications. Click Enterprise Applications.
Verify that the Web application Business
Process Framework is listed and running.

WebLogic Server 9.2.x From the WebLogic Server Console,
mydomain, expand Deployments. Verify that
the Web application Business Process
Framework is listed and running.

WebLogic Server 8.1.x From the WebLogic Server Console,
mydomain, expand Deployments → Web
Application Modules. Verify that the Web
application Business Process Framework is
listed and running.

JBoss Application Server Verify that the bpf folder exists in the
JBOSS_HOME\server\<ServerType>\deploy
directory.

Verifying the Business Process Framework operations
component

You must verify that Verify that the Business Process Framework operations
component is started in Component Manager.

To verify the Business Process Framework operations component:
1. Start the IBM FileNet P8 Platform Task Manager.
2. Verify that the Business Process Framework operations component is started in

Component Manager.

Configuring Business Process Framework server after installation
The Business Process Framework server installation program configures many
necessary settings automatically. However, you must perform additional
configuration when you complete the installation.

“Updating Process Engine database views” on page 41
The queues used by the Business Process Framework Web application must be
updated. It is not necessary to update the other Process Engine views used for
logs or rosters. This update is not necessary if you are using Microsoft SQL
Server.
“Copying modified configuration files into the deployed Workplace
application” on page 43
The Business Process Framework install or upgrade modifies the
Integration.xml file and adds a Bp8ViewActions.jsp file in the Workplace
installation directory. The modified files must be incorporated into the deployed
Workplace application.
“Applying IBM FileNet P8 Platform changes after installation” on page 43
After the Business Process Framework installation is complete you can apply
IBM FileNet P8.
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Updating Process Engine database views
The queues used by the Business Process Framework Web application must be
updated. It is not necessary to update the other Process Engine views used for logs
or rosters. This update is not necessary if you are using Microsoft SQL Server.

To determine the views that are used by the Business Process Framework Web
application and must be updated:
1. Log on to Business Process Framework Explorer.
2. Expand Workflow Configuration → Queues.
3. Open the properties of each queue, the Object Name is the Process Engine

queue name you must update.
“Updating Oracle database views”
You must manually adjust the Process Engine database views after modifying
workflow queue definitions or transferring a workflow definition to the isolated
region when you use the Oracle database views. To change the view definition,
you must drop the view and re-create it.
“Updating DB2 database views” on page 42
You must manually adjust the Process Engine database views after modifying
workflow queue definitions or transferring a workflow definition to the isolated
region when you use the DB2 database views. To change the view definition,
you must drop the view and re-create it.

Updating Oracle database views
You must manually adjust the Process Engine database views after modifying
workflow queue definitions or transferring a workflow definition to the isolated
region when you use the Oracle database views. To change the view definition,
you must drop the view and re-create it.

To manually update Process Engine views:
1. Find the database views:

a. In Oracle Enterprise Manager, find pe database → Schema → pe runtime user
→ Views.

b. Find the views for all queues in the isolated region in question. These views
have names that adhere to the following naming convention: “VWVQ” +
<IsolatedRegionNumber> + “_” + <QueueName>.

Tip: You do not have to update the other views for logs or rosters, and so
on. You must update the queues used by the Business Process Framework
Web Application.

2. Create the SQL statements for each view:
a. Right-click Show Object DDL.
b. Click Ctrl-A, Ctrl-C: Put DDL contents in Notepad (for each view).
c. Put a semi-colon after each DDL statement.

3. Run the SQL statements as follows:
a. Delete the quotation marks (preferably, use search and replace to replace the

quotation marks (″) with nothing) for all SQL statements.
b. Run the statements in the Oracle SQL Worksheet.
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Updating DB2 database views
You must manually adjust the Process Engine database views after modifying
workflow queue definitions or transferring a workflow definition to the isolated
region when you use the DB2 database views. To change the view definition, you
must drop the view and re-create it.

To manually update Process Engine database views:
1. Browse for all views to be updated:

a. From DB2 Control Center, expand the object tree until you find the Views
folder.

b. Find the views for all queues in the isolated region in question. These views
have names that adhere to the following naming convention: ″VWVQ″ +
<IsolatedRegionNumber> + ″_″ + <QueueName>.

Tip: You do not have to update the other views for logs or rosters, and so
on. You only have to update the queues used by the Business Process
Framework Web Application.

2. Back up the views definition to a safe location:
a. From the Control Center, expand the object tree until you find the Views

folder.
b. Click the Views folder. Any existing views are displayed in the right pane.
c. Right-click the view object that you want to back up, and select Alter.
d. Copy the SQL statement from window and paste it into a file, and then

save the file.
3. Drop view by using the Control Center:

a. From the Control Center, expand the object tree until you find the Views
folder.

b. Click the Views folder. Any existing views are displayed in the right pane.
c. Select the view that you want to drop.
d. Right-click one of the selected views in the contents pane, and select Drop.

The Confirmation window opens.
e. To delete the view or views you selected in the Drop box, click OK.

4. Create View by using the Control Center:
a. From the Control Center, expand the object tree until you find the Views

folder.
b. Right-click the Views folder and select Create. The Create View window

opens.
c. Use the View schema list box to specify the schema for the view that you

are creating.
d. In the View name field, type the view name. The name must match the

view name you deleted earlier.
e. In the SQL statement box, paste the SQL text that you saved to a file in step

2. Go to the beginning of the SQL statement and delete ″CREATE VIEW
VIEW_NAME″. (Control center appends ″CREATE VIEW VIEW_NAME″
from view name text box.) Delete the quotation marks (preferably, use
search and replace to replace the quotation marks (″) with nothing) for all
SQL statements.

f. Click OK to begin processing the SQL statement.
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Copying modified configuration files into the deployed
Workplace application

The Business Process Framework install or upgrade modifies the Integration.xml
file and adds a Bp8ViewActions.jsp file in the Workplace installation directory. The
modified files must be incorporated into the deployed Workplace application.

To copy the modified files into the Workplace application:
v If Workplace is deployed as an exploded folder, or if you are using WebSphere

Application Server, you can re-deploy Workplace or:
1. Copy the Integration.xml and Bp8ViewActions.jsp files from the Workplace

installation directory to the deployed Workplace directory.
2. Restart the application server.

v If your installation directory contains a packaged .war or .ear file and you are
not using WebSphere Application Server:
1. Run the Workplace create_app_engine_deploy_type.script_type script in

the Workplace installation directory to generate a new .war or .ear file with
the updated Integration.xml and Bp8ViewActions.jsp files.

2. Redeploy Workplace.

Applying IBM FileNet P8 Platform changes after installation
After the Business Process Framework installation is complete you can apply IBM
FileNet P8.

Apply IBM FileNet P8 Platform changes.
The Business Process Framework 4.1 installation is packaged with JAR files from
these IBM FileNet P8 software levels:
v IBM FileNet P8 Content Engine: P8CE-4.0.1
v IBM FileNet P8 Process Engine: P8PE-4.0.2
v IBM FileNet P8 Application Engine: P8AE-4.0.1-000.001
v IBM FileNet P8 eForms: P8eForms-4.0.1

These IBM FileNet P8 software levels are the software versions required in order to
run Business Process Framework 4.1. If you have installed a later fix pack for the
Content Engine, Process Engine, Application Engine or (optionally) eForms, you
must replace certain JAR files in the Business Process Framework install and
deploy locations to ensure your Business Process Framework software functions
correctly. The following table identifies the JAR files that you must replace for each
component:

Component JAR Files

Content Engine Jace.jar javaapi.jar

Process Engine pe.jar peResources.jar

Application Engine v aeeforms.jar

v listener.jar mailapi.jar

v p8ciops.jar p8toolkit.jar

v soap.jar

v p8webappLogging.jar

v commons-fileupload-1.*.jar
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Component JAR Files

eForms v eforms-resources.jar

v eforms.jar

v itext-1.5.2.jar

v jai_codec.jar

v commons-httpclient-2.0.2.jar

You can find the new versions of these files in the Workplace WEB-INF\lib folder.
By default the WEB-INF folder on the Application Engine is in the following
location:
v Windows: C:\Program Files\FileNet\Workplace\WEB-INF\lib

v UNIX: /opt/FileNet/Workplace/WEB-INF/lib

Installing Business Process Framework Explorer
Business Process Framework Explorer provides the capability for the application
developer to log on to Content Engine and look up properties while configuring
Business Process Framework application fields. Install Business Process Framework
Explorer on a Windows machine.

To install Business Process Framework Explorer:
1. Open your completed Installation and Upgrade Worksheet file.

Tip: In the worksheet file, verify that the Data → Filter → AutoFilter command
is enabled. To view only Business Process Framework Explorer values, filter by
BPF Explorer Installer in the Installation or Configuration Program column.

2. Log on to the Windows machine with an account that has local administrator
privileges.

3. Navigate to the directory \staging folder\admin and run the following
command: filenet_BPF_explorer_setup.exe

4. Complete the Business Process Framework Explorer installation program
screens with the values recorded in your Installation and Upgrade Worksheet.

Verifying the Business Process Framework Explorer installation
You can verify the Business Process Framework Explorer installation by checking
whether you can log on to Business Process Framework Explorer without errors.

To verify Business Process Framework Explorer logon:
1. Verify that you can log on to Business Process Framework Explorer without

error.
2. If you configured Content Engine integration by installing the Content Engine

Client libraries, verify that you can access an Object Store from the Business
Process Framework Explorer Case Type or Application Field Property UI.

Configuring Business Process Framework Explorer after installation
Although the Business Process Framework Explorer installation program
automatically configures the application, you must perform some additional
configuration with the installation is complete.

“Updating the bootstrap operating system and Workplace site preference name
in Business Process Framework Explorer” on page 45

44 Installation Guide



If the bootstrap operating system is different from the case object store name,
you must change bootstrap operating system to the bootstrap name. You can set
this in the Business Process Framework Explorer application.
“Updating the pe runtime user in queue definitions if not using the default”
If you are using a pe runtime user other than the default, you must change
settings for that value in the Workflow Configuration.
“Updating queue filters” on page 46
If either one of the Metastore or Process Engine database is a Microsoft SQL
Server database, and the other is Oracle or DB2, then you must update the
queue filters.
“Defining Metastore roles” on page 46
You must define Metastore roles before you validate the installation because the
roles must be configured before you log in to the Web application.
“Modifying case type configuration” on page 46
You can modify the case type configuration of various properties.
“Updating queue names for case-insensitive views” on page 49
If your environment includes Process Engine 4.0.3 or later, you must update the
object name of each queue to match with Process Engine case-insensitive views.
“Restarting Business Process Framework application server” on page 49
After you modify any settings in Business Process Framework Explorer, restart
the Business Process Framework application server.

Updating the bootstrap operating system and Workplace site
preference name in Business Process Framework Explorer

If the bootstrap operating system is different from the case object store name, you
must change bootstrap operating system to the bootstrap name. You can set this in
the Business Process Framework Explorer application.

By default, the Business Process Framework installation sets the bootstrap
operating system to the case object store name. If the bootstrap operating system is
different from the case object store name, you must change bootstrap operating
system to the bootstrap name. This setting is named Content Engine Bootstrap
Object Store and is located under system-wide settings in the Business Process
Framework Explorer.

By default, the Business Process Framework installation sets the Workplace site
preference to Workplace. If your Workplace site preference name is not Workplace,
you must change the setting to the correct value in Business Process Framework
Explorer. This setting is named Workplace Preference Name and is located under
system-wide settings in the Business Process Framework Explorer.

Updating the pe runtime user in queue definitions if not using
the default

If you are using a pe runtime user other than the default, you must change settings
for that value in the Workflow Configuration.

If the value of pe runtime user is different than f_sw, change the alias prefix of the
object name of each queue in Workflow Configuration → Queues to match the
actual value of pe runtime user.

For example, if the user alias is dbo, the object name for the Case Management
queue is dbo.VWVQ1_CaseManagement. Change or view a queue object name by
right clicking the queue in question and selecting Properties.
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Updating queue filters
If either one of the Metastore or Process Engine database is a Microsoft SQL Server
database, and the other is Oracle or DB2, then you must update the queue filters.

To update the queue filters:

Option Description

Workflow Configuration → Queue Filters
(for Process Engine implementations by
using SQL Server only)

Verify that the NOLOCK option is utilized in all
queue filter SQL Server queries. For example:
SELECT COUNT(UserID) FROM Users WITH
(NOLOCK) WHERE Username LIKE 'smith'.

This option is necessary to reduce or
eliminate deadlock contention. Change or
view a queue filter’s SQL Server query by
right clicking the queue filter in question and
selecting Properties.

Workflow Configuration → Queue Filters
(for Process Engine implementations by
using Oracle and DB2)

Verify that the NOLOCK option is not utilized
in all queue filter SQL Server queries. This
syntax is not valid for Oracle.

Change or view a queue filter’s SQL Server
query by right clicking the queue filter in
question and selecting Properties.

Defining Metastore roles
You must define Metastore roles before you validate the installation because the
roles must be configured before you log in to the Web application.

To define roles within Business Process Framework Explorer.

Click User and Access Information → Roles.
These roles correspond to LDAP groups or Workplace access roles depending on
Metastore settings.
For more information, see the Business Process Framework Explorer Handbook
sections LDAP security definition and Workplace access roles and User and access
information configuration.

Modifying case type configuration
You can modify the case type configuration of various properties.

Business Process Framework uses the case type ID value to determine which object
store to search for Bp8CaseType objects and audit log objects. It also looks for the
right object store in which to place document objects. If you do not specify the
Bp8CaseType value, Business Process Framework will encounter errors when
searching for cases and attachments in multiple object stores.

“Adding a case type picklist” on page 47
You can create and add a case type picklist to the New Picklist properties.
“Updating the Bp8CaseType application field” on page 47
You can update the Bp8CaseType property on the Applications Field page.
“Selecting the field Bp8CaseType in workflow filters” on page 47
For each workflow query filter, you must change the Microsoft SQL Server
query string to add Bp8CaseType into the select field.
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“Adding the parameter Bp8CaseType in attachment and eForms tabs” on page
48
Using a database tool, open the TABS table in Metastore database. For the two
rows which TAB_NAME are Attachment and eForms, change the
TAB_CONTENT column value by adding a parameter Bp8CaseType .
“Exposing the field Bp8CaseType in inbasket” on page 48
For each Inbasket, its configuration must expose the Bp8CaseType field for all
case types on Case Fields tab of the Inbasket property page.
“Adding Bp8CaseType to create_eFormsCase tool” on page 48
If you plan to use eForms with Business Process Framework, you must add
Bp8CaseType to the create_eFormsCase tool.

Adding a case type picklist
You can create and add a case type picklist to the New Picklist properties.

To add a case type picklist:
1. Create a Case Type Picklist in Miscellaneous → Pick Lists → , right-click Pick

Lists and select New → Picklist.
2. In the New Picklist Properties page, input the Name: CaseType Picklist and

the description: Picklist for Case Type, value/text=type code/type
description.

3. Press Edit button to open Picklist Advanced Configuration page and input
Microsoft SQL Server:
SELECT case_type_id as ID, case_type_id as CODE, name as DESCRIPTION, -1
as ACTIVE FROM case_types ORDER BY name

After that, a Case Type picklist is created.

Updating the Bp8CaseType application field
You can update the Bp8CaseType property on the Applications Field page.

To update the Bp8CaseType application field:
1. Open Bp8CaseType property page in Case Fields Configuration → Application

Fields page.
2. Choose Case Type Picklist in the Pick list field and save.

Selecting the field Bp8CaseType in workflow filters
For each workflow query filter, you must change the Microsoft SQL Server query
string to add Bp8CaseType into the select field.

For example, for the filter Public Inbasket, follow the steps later in this section to
change its SQL Server query string:
1. Launch Business Process Framework Explorer.
2. Open the property page of the filter Public Inbasket.
3. Click the button Edit Query. Insert the string Bp8CaseType into the select list.

The original value is:
select %PAGESIZE% F_WobNum, F_UniqueId, F_Locked, F_LockUser, F_BoundUser,
Bp8CaseID, 9999 as queue_depth from %VIEWNAME% WHERE %FILTERBY% F_StepName='
STEPNAME%' order by %ORDERBY%, F_EnqueueTime, F_UniqueId asc

Change to:
select %PAGESIZE% F_WobNum, F_UniqueId, F_Locked, F_LockUser, F_BoundUser,
Bp8CaseID, Bp8CaseType, 9999 as queue_depth from %VIEWNAME% WHERE %FILTERBY%
F_StepName='%STEPNAME%' order by %ORDERBY%,F_EnqueueTime, F_UniqueId asc
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Adding the parameter Bp8CaseType in attachment and eForms
tabs
Using a database tool, open the TABS table in Metastore database. For the two
rows which TAB_NAME are Attachment and eForms, change the TAB_CONTENT
column value by adding a parameter Bp8CaseType .

For the row Attachment, the original value is:
Bp8AttachmentsTab.jsp?eventTarget=attachmentsTab&eventName=
ExecuteSearch&TabName={TABNAME}&Inbasket={IID}&Bp8CaseID={CFNAME}&_showatt=0

This value must be changed to:
Bp8AttachmentsTab.jsp?eventTarget=attachmentsTab&eventName=
ExecuteSearch&TabName={TABNAME}&Inbasket={IID}&Bp8CaseID={CFNAME}
& Bp8CaseType={CFNAME} & _showatt=0

For example, the following SQL command can be used to change the Attachment
row:
UPDATE TABS SET
TAB_CONTENT='Bp8AttachmentsTab.jsp?eventTarget=attachmentsTab&eventName=
ExecuteSearch&TabName={TABNAME}&Inbasket={IID}&Bp8CaseID={CFNAME}&Bp8CaseType=
{CFNAME}&_showatt=0'WHERE TAB_NAME='Attachment'

For the row eForms, the original value is:
/BpfFormServlet?Bp8CaseID={CFNAME}&mode=1&_showatt=0&page=P001

This value must be changed to:
/BpfFormServlet?Bp8CaseID={CFNAME} & Bp8CaseType={CFNAME} &
mode=1&_showatt=0&page=P001

For example, this Microsoft SQL Server command can be used to change the
eForms row:
UPDATE TABS SET
TAB_CONTENT='/BpfFormServlet?Bp8CaseID={CFNAME}&Bp8CaseType={CFNAME}&
mode=1&_showatt=0&page=P001'WHERE TAB_NAME='eForms'

Exposing the field Bp8CaseType in inbasket
For each Inbasket, its configuration must expose the Bp8CaseType field for all case
types on Case Fields tab of the Inbasket property page.

To expose the Bp8CaseType field:
1. Launch Business Process Framework Explorer.
2. Open the property page of the Inbasket you want to modify.
3. Open the Case Fields tab.
4. Select Bp8CaseType in the left list and click the button ->, then the field is

inserted into the right field list. Set its Visible and R/O value to YES.
5. Click the button Reset Layout.
6. Click the button and Apply” and click the button OK.

Adding Bp8CaseType to create_eFormsCase tool
If you plan to use eForms with Business Process Framework, you must add
Bp8CaseType to the create_eFormsCase tool.

Follow these steps to add the parameter Bp8CaseType to the tool
create_eFormsCase:
1. Start Business Process Framework Explorer.
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2. Open the property page of the tool create_eFormsCase.
3. Change the Handle URL value by adding the parameter objectStoreName. The

parameter value must be the correct object store symbolic name storing the case
object of the case type for which the eForms template is designed. For example,
this tool starts the eForms for Case Management tool, and the object store for
case object of Case Management is BPFOSCase.
The original value of Handle URL is:
ExtCommand.jsp?eForms&ExtTask=create_eform_case&id=

{46A4F3A1-41C2-46B9-AE71-4393D906B335}&vsId=
{6F434403-DFC8-4E7D-B9D5-4C9572AD80BD}&objectType=document

Change to:
ExtCommand.jsp?eForms&ExtTask=create_eform_case&id=

{46A4F3A1-41C2-46B9-AE71-4393D906B335}&vsId=
{6F434403-DFC8-4E7D-B9D5-4C9572AD80BD}&objectStoreName=
BPFOSCase&objectType=document

Updating queue names for case-insensitive views
If your environment includes Process Engine 4.0.3 or later, you must update the
object name of each queue to match with Process Engine case-insensitive views.

To update queue names:
1. In Business Process Framework Explorer, click Workflow Configuration →

Queues.
2. Right-click the first queue, and choose Properties.
3. In the Object name field, edit the name to match the case-insensitive Process

Engine view name, and click OK. You can obtain these names from a Process
Engine vwtool report.

4. Repeat the configuration changes for all remaining queues.

Restarting Business Process Framework application server
After you modify any settings in Business Process Framework Explorer, restart the
Business Process Framework application server.

Logging on to a sample Business Process Framework Web application
You can verify the installation and configuration by logging on to the Business
Process Framework application you set up.

When Business Process Framework is initially installed in a development
environment, it is installed with a test application configuration called the Case
Management Sample Application. This application is a preconfigured application
on top of Business Process Framework that can be used to test all aspects of
Business Process Framework functionality.

In order to validate that the Business Process Framework and Business Process
Framework Explorer components were installed properly and correctly integrated
with Content Engine, Process Engine, and Application Engine, the following test
case should be performed against the Case Management Sample Application.

To log on to a sample application:
1. Access Business Process Framework from the following URL: http://web

application server:web port/web BPF name
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2. Log on to Business Process Framework. If this is the first time you are logging
on to the Business Process Framework Web application, you will have to set
the Business Process Framework bootstrap information. Make sure you save
the bootstrap information to the Bootstrap Object Store.

3. Create a new Case.
4. Open the case from the Index Inbasket and enter sample case field data.
5. Attach a document to the case by using the Attach Document tool.
6. Open the attached content in the Viewer.

Tip: Ensure that the appropriate JRE is installed for the browser.
7. Perform a Business Process Framework Case Search. You must first configure

a case search. For more information, see “Configuring stored searches” on
page 77.

8. Choose Action → Complete on the case, then locate the case in the Review
Inbasket to make sure it was dispatched.

9. Open Layout Designer through the Edit Layout tool.
10. Log off Business Process Framework.
11. Log on to Business Process Framework Explorer and verify all configuration

data is present.
12. In order to verify that BPF_Operations are working in Component Manager,

add a new document to the Case Management Documents document class.
The document must have a DocEntryStatus value of 1, and a DocType value
of 1.
The subscription event launches a workflow that creates a new case. If
BPF_Operations is running, you see a new Case in the Index Inbasket. For
information on creating a workflow subscription, see “Modifying Business
Process Framework operations logging (optional)” on page 85.
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Planning and preparing for Business Process Framework
upgrade

Before you upgrade Business Process Framework, you must plan the upgrade and
prepare your environment.
1. “Planning the upgrade”

You must review the upgrade planning information before your Business
Process Framework installation so that you know what deployments are
supported, understand how the tasks in the installation tasks are organized by
Role, and know how to use the Installation and Upgrade Worksheet.

2. “Performing the required upgrade preparation tasks” on page 55
To do the required upgrade preparation tasks, you must assign your staff to
complete the tasks that are organized by administrative role.

Planning the upgrade
You must review the upgrade planning information before your Business Process
Framework installation so that you know what deployments are supported,
understand how the tasks in the installation tasks are organized by Role, and
know how to use the Installation and Upgrade Worksheet.

To install Business Process Framework:
v Retrieve updates to IBM FileNet P8 documentation and software.
v Read through this guide to become familiar with the tasks you perform when

you set up your Business Process Framework software.
v See “Using the installation and upgrade worksheet” on page 53 for more

information about an available P8 Worksheet to record information that is
required during installation.

Important: Follow the planning, installing, and configuring tasks in the order
presented. If you do otherwise, or you install FileNet P8 components on machines
containing components for existing FileNet P8 systems, you might encounter
unforeseen problems or be required to perform additional installation steps. See
the IBM FileNet P8 Troubleshooting Guide.

“Upgrade paths” on page 52
You must review the upgrade planning information before your Business
Process Framework installation so that you know what deployments are
supported, understand how the tasks in the installation tasks are organized by
Role, and know how to use the Installation and Upgrade Worksheet.
“Definition of upgrade roles” on page 52
The tasks in this guide and the rows in the Installation and Upgrade Worksheet
are organized by administrative roles. Your organization might have different
roles, and some of the responsibilities of listed roles varies from the roles
assigned by default in this documentation.
“Using the installation and upgrade worksheet” on page 53
The Installation and Upgrade Worksheet is a Microsoft Excel spreadsheet
(p8_worksheet.xls). The worksheet describes the properties and parameters
required to completeBusiness Process Framework installation, upgrade, and
configuration programs, and provides a way to record the values you assign to
these properties and parameters.

© Copyright IBM Corp. 2002, 2009 51



Upgrade paths
You must review the upgrade planning information before your Business Process
Framework installation so that you know what deployments are supported,
understand how the tasks in the installation tasks are organized by Role, and
know how to use the Installation and Upgrade Worksheet.

The following upgrade paths are available for this version of Business Process
Framework:
v Business Process Framework 4.0 (with FileNet P8 Platform 4.0) to Business

Process Framework 4.1 (with FileNet P8 Platform 4.0, 4.5, or 4.5.1)
Upgrade to 4.1 with FileNet P8 Platform 4.5 or 4.5.1 is supported only with the
installation of the Business Process Framework fix pack 4.1.0-003.

v Business Process Framework 3.6 (with FileNet P8 Platform 3.5) to Business
Process Framework 4.1 (with FileNet P8 Platform 4.0) for JBoss only

v Business Process Framework 3.5.2 (with FileNet P8 Platform 3.5) to Business
Process Framework 4.1 (with FileNet P8 Platform 4.0) for JBoss only

Before starting your upgrade, you must already have upgraded all related IBM
FileNet P8 products. It is not supported to change or upgrade other components at
the same time as the Business Process Framework upgrade. For example, changing
the IBM FileNet P8 Platform release, application server vendor or release, or
database vendor or release during a Business Process Framework upgrade is not
supported.

The upgrade process updates the Business Process Framework release software
while keeping any site-specific configuration. The following components are
updated during a Business Process Framework upgrade:
v Business Process Framework Web application
v Business Process Framework Explorer
v Business Process Framework Metastore schema changes
v Business Process Framework Metastore configuration
v Business Process Framework Operations component
v Solution-specific code if any

Definition of upgrade roles
The tasks in this guide and the rows in the Installation and Upgrade Worksheet are
organized by administrative roles. Your organization might have different roles,
and some of the responsibilities of listed roles varies from the roles assigned by
default in this documentation.

Installation administrator
v Runs Business Process Framework installers during initial setup.
v Runs Business Process Framework upgrade programs during upgrades.
v Abbreviated as IA. Responsible for coordinating the information described in

this worksheet. The information itself requires the input from the other roles.

The role of IA is typically filled by an FileNet Certified Professional (FCP).

Information technology administrator
v Responsible for the networking and operating systems settings required by

Business Process Framework.
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v Responsible for performing certain security configurations.
v Abbreviated as ITA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of ITA in the Role column.

Security administrator
v Responsible for configuring the directory servers required by Business Process

Framework components.
v Creates and maintains directory server user and group accounts.
v Abbreviated as SA. Responsible for providing the information in the rows in the

Installation and Upgrade Worksheet with a value of SA in the Role column.

Database administrator
v Creates, configures, maintains database installations and database or table

spaces.
v Responsible for creating database accounts required by Business Process

Framework.
v For purposes of this documentation, the database administrator is expected to

have responsibilities regarding the JDBC data sources.
v Abbreviated as DBA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of DBA in the Role column.

Application server administrator
v Responsible for providing the application servers required by Business Process

Framework.
v Responsible for application server administrative accounts.
v Abbreviated as ASA. Responsible for providing the information in the rows in

the Installation and Upgrade Worksheet with a value of ASA in the Role column.

IBM FileNet P8 administrator
v This role designation actually refers to the administrator or administrators who

perform regular maintenance of Content Engine, Process Engine Application
Engine, Workplace or Workplace XT.

v The administrator who logs on to Enterprise Manager by using the gcd_admin
account or an object_store_admin account is considered an IBM FileNet P8
administrator.

v Abbreviated as P8A. Responsible for providing the information in the rows of
the Installation and Upgrade Worksheet with a value of P8A in the Role column.

Using the installation and upgrade worksheet
The Installation and Upgrade Worksheet is a Microsoft Excel spreadsheet
(p8_worksheet.xls). The worksheet describes the properties and parameters
required to completeBusiness Process Framework installation, upgrade, and
configuration programs, and provides a way to record the values you assign to
these properties and parameters.

Administrators who are preparing the environment for installation or upgrade of
IBM FileNet P8 components must use the worksheet during their preparation tasks
to record the appropriate values and provide them to the Installation
Administrator who runs the installation or upgrade programs.

Some of the features of the Installation and Upgrade Worksheet are:
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v Instructions: describes the worksheet and includes a button that runs the
Customize Worksheet macro.

v The two highlighted columns, Property or Parameter and ENTER YOUR
VALUE HERE, provide the simplest view of the requirement. The others add
identifying information and help you sort and filter the rows usefully.

v The Role column assigns each row to an administrator and uses the following
acronyms:
– ITA: Information Technology Administrator
– ASA: Application Server Administrator
– DBA: Database Administrator
– SA: Security Administrator
– P8A: IBM FileNet P8 Administrator

v Property definitions are contained in the column titled Description.
v Some rows, though not all, contain a hyperlink in the PPG Links column. Click

this hyperlink to run a query against the IBM Information Center, which opens
with the Search Results pane showing the topics that contain the words in the
query phrase. Browse the search results until you have enough information to be
able to enter a value in the Worksheet row.
“Running the customize worksheet macro”
The Customize Worksheet macro lets you extract only those rows that describe
your environment.
“Autofiltering and sorting the worksheet” on page 55
There are several ways to organize the Worksheet to make finding properties
and entering values easier.

Running the customize worksheet macro
The Customize Worksheet macro lets you extract only those rows that describe
your environment.

Important: For support of the full range of built-in filter and macro features, use
Microsoft Excel to view the Installation and Upgrade Worksheet file. You can use
other spreadsheet programs to view the file; however, filter and macro support can
vary. For example, in Calc from OpenOffice.Org, the column filters work as
expected, but the Customize Worksheet button does not.

To run the Customize Worksheet macro:
1. Open the Installation and Upgrade Worksheet (p8_worksheet.xls) and click the

Instructions worksheet (also called a tab).
2. Scroll down until you see the button representing the Customize Worksheet

macro. Click the button.
3. Select the components and options that describe the environment you are

preparing for IBM FileNet P8.
v Installation or Upgrade
v IBM FileNet P8 Components
v Application Server type
v Operating system
v Database type
v Directory Server type
v Number of object stores (adds new sets of rows for creating additional data

sources)
v Name of customized sheet
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4. Click OK. The macro copies the rows that fulfill your selection criteria into a
new worksheet with the name you entered. Enter the values for your
environment into this new worksheet.

5. Click the name of the new worksheet at the bottom of the Excel window. Add
your preparation values into this new worksheet.

6. Notice that the new worksheet has buttons at the top titled Show Installer
View and Show Full View, depending on its state. The Show Installer View
displays only those columns that are required while running installation or
configuration programs.

Autofiltering and sorting the worksheet
There are several ways to organize the Worksheet to make finding properties and
entering values easier.

AutoFiltering is a quick way to display only those rows that meet a certain criteria.

To use AutoFilter:
1. Make sure AutoFiltering is enabled. (Select the entire row with the column

headers, then click Data → Filter → Autofilter.) AutoFilter arrows appear to the
right of the column labels.

2. Click the AutoFilter arrow in the Installation or Configuration Program
column header and select the program you are interested in (for example,
Process Engine installer).

3. Click the AutoFilter arrow in the Setup Type column header, select Custom,
and specify Setup Type contains Installation.

4. For a custom AutoFilter, click the AutoFilter in any column header, select
Custom, and specify Setup Type contains Installation.

5. To turn off AutoFiltering in a column, click the AutoFilter arrow and select
(All).

6. To reorder rows alphabetically, do a Sort:
a. Click anywhere in a column, for example, Column A Role.

The only possible values in the Role column are ASA, SA, DBA, ITA, and
P8A. Sorting on Role therefore groups the rows by this attribute, in
alphabetic order. Several other columns also have a limited number of
possible values which means they can be usefully sorted.

b. Click the Sort Ascending icon in the Excel toolbar, or use the Data → Sort
menu command. The rows sort on Role.
Sorting the Worksheet reassigns row numbers. If you refer to rows by
number, be aware that row numbers change if you change the sort order.

Performing the required upgrade preparation tasks
To do the required upgrade preparation tasks, you must assign your staff to
complete the tasks that are organized by administrative role.

In addition to the required upgrade preparation tasks, Business Process Framework
specific preparation tasks, follow the plan and prepare instructions in the Plan and
Prepare Your Environment for IBM FileNet P8 document for the components you are
installing.

“IBM FileNet P8 administrator tasks” on page 56
The FileNet P8 Administrator must carry out several tasks to prepare your
environment for your Business Process Framework upgrade.
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“Application server administrator tasks” on page 58
The application server administrator must coordinate with and delegate
responsibilities to the other administrators to prepare for theBusiness Process
Framework installation.
“Information technology administrator tasks” on page 58
The Information Technology administrator must prepare the network and
operating systems, and carry out certain security configurations to prepare your
environment for Business Process Framework.
“Database administrator tasks” on page 59
The Database administrator must prepare the databases required for Business
Process Framework, including gathering information about data sources,
creating databases and database accounts, and installing client software.

IBM FileNet P8 administrator tasks
The FileNet P8 Administrator must carry out several tasks to prepare your
environment for your Business Process Framework upgrade.

“Identifying the Business Process Framework version”
You can confirm the version of your Business Process Framework installation
by checking the About screen in the Web application, or by checking the
version.txt file.
“Backing up Business Process Framework files”
Before you run the Business Process Framework upgrade, you must back up
files that you want to preserve after the upgrade.
“Preparing the IBM FileNet P8 environment for upgrade” on page 57
Before you run the upgrade installation for Business Process Framework, you
must prepare the IBM FileNet P8 for the upgrade.
“Configuring Process Engine case-insensitive view support” on page 58
Process Engine 4.0.3 and later supports case-insensitive views. The new Process
Engine views provide case-insensitive column names. Using these new views
replaces the manual step of removing the quotation marks in the current VWV
views.

Identifying the Business Process Framework version
You can confirm the version of your Business Process Framework installation by
checking the About screen in the Web application, or by checking the version.txt
file.

To identify the software version:
1. Check the version information of the Web application by pointing to the

following URL: http://web_application_server:web_port/web_BPF_name/About.jsp
The port number depends on the application server you use.

2. Check the version number of the Business Process Framework Explorer.
v In the Explorer UI, click Help → About to see the version information.
v Check the version.txt file in install_path\FileNet\BPF\BPFExplorer.

Backing up Business Process Framework files
Before you run the Business Process Framework upgrade, you must back up files
that you want to preserve after the upgrade.

It is not a requirement to check in all the documents when running a Business
Process Framework application upgrade.

To back up files:
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1. Verify that all application users have logged off the Business Process
Framework application.

2. Back up your existing bp8ciops.jar used by BPF_Operations component. If
you are using BPF Operations, this JAR file is located at install_path/bpfops/
on the Application Engine where the BPF_Operations component runs under
the Component Manager. This JAR file contains two XML files, of which
bp8_config.xml must, and log4j.xml might contain custom and
application-specific settings which you must copy back into the corresponding
files in the new bp8ciops.jar installed during the upgrade.

3. Back up the entire deployed folder used by the Business Process Framework
Web application for recovery purposes.

4. Back up the Workplace files used by Business Process Framework, for recovery
purposes only:
v AE_install_path/FileNet/Config/AE/Actions.xml

v AE_install_path/FileNet/Config/AE/InfoPages.xml

v AE_deploy_path/Workplace/Bp8ViewActions.jsp

v AE_deploy_path/Workplace/WEB_INF/Integration.xml

5. Create a custom code folder and copy any custom code modules to be
deployed during the upgrade into this folder.
If you do not have any custom code you want to retain after the upgrade, you
can skip this step. If that is true and you have no production data, you might
want to simply perform a new install.
The folder structure must mimic the Business Process Framework Web
application folder structure exactly. Custom code is defined as any code
module that is not part of the Business Process Framework Web application,
but that has been created as an extension to the application and must be
deployed after an upgrade of the Business Process Framework Web application.
If there are no custom code modules to be deployed, continue with the next
step.

6. If you have any custom Web modules registered that uses Layout Designer,
back up the BPFModule.xml file located under the WEB-INF folder in the
deployed Business Process Framework Web application.

Preparing the IBM FileNet P8 environment for upgrade
Before you run the upgrade installation for Business Process Framework, you must
prepare the IBM FileNet P8 for the upgrade.

To prepare the IBM FileNet P8 environment:
1. Export the configuration of the isolated region by using the Export feature of

the Process Configuration Console.
2. Check that the Case Management Sample Workflow, eForms Case Management

Sample Workflow for eForms integration, or the customized workflows are in a
check-in state (optional but recommended).

3. Ensure that the Content Engine and Process Engine are running and
operational so that the installer can configure the IBM FileNet P8 environment.

4. Stop the Component Manager and close all open Process Task Manager tools
on the Application Engine so that the installer can update the vwtaskman.xml
file in the Application Engine Router directory.
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Configuring Process Engine case-insensitive view support
Process Engine 4.0.3 and later supports case-insensitive views. The new Process
Engine views provide case-insensitive column names. Using these new views
replaces the manual step of removing the quotation marks in the current VWV
views.

To configure Process Engine case-insensitive views

Use the vwtool with the createDBviewsCI command to create database views that
are not case sensitive. For details, see the IBM FileNet P8 help topic System
Administration Process → Administration → Administrative tools → vwtool →
Commands → createDBviewsCI.

Tip: You can use vwtool to generate a list of database view names to use when
updating the object names of workflow queues in Business Process Framework
Explorer after installation.
Related tasks

“Updating queue names for case-insensitive views” on page 73
If your environment includes Process Engine 4.0.3 or later, you must update the
object name of each queue to match with Process Engine case-insensitive views.

Application server administrator tasks
The application server administrator must coordinate with and delegate
responsibilities to the other administrators to prepare for theBusiness Process
Framework installation.

To prepare the application server for the upgrade:
1. Do not undeploy or remove the existing Business Process Framework Web

application before the upgrade. During upgrade, the installation program
removes the existing deployment and replaces it with a new one.

2. Prepare the Application Engine and Business Process Framework application
server for upgrade.
(WebSphere Application Server and WebLogic Server) Ensure that the
Application Engine and Business Process Framework application server is
running and operational so that the installation program can undeploy the old
application and deploy the new application.
(JBoss Application Server) Stop the Application Engine and Business Process
Framework application server so that the installer can undeploy the old
application and deploy the new application.

Information technology administrator tasks
The Information Technology administrator must prepare the network and
operating systems, and carry out certain security configurations to prepare your
environment for Business Process Framework.

“Copying installation software disk contents to target machine” on page 59
You must copy the installation software to a staging folder on the target server.
“Making the staging folder accessible” on page 59
The staging folder must be accessible from the various systems where Business
Process Framework software is to be installed.
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Copying installation software disk contents to target machine
You must copy the installation software to a staging folder on the target server.

To copy installation software disk contents to a target machine:
1. Insert the disk for the target platform into a reader.
2. For systems other than Windows, mount the disk device.
3. Copy the contents of the disk to a staging folder. This folder must be accessible

to the systems where Business Process Framework software is to be installed.

Making the staging folder accessible
The staging folder must be accessible from the various systems where Business
Process Framework software is to be installed.

The following table identifies which servers require access to specific subfolders
under the staging folder.

Table 18. Required servers

Server Folder

BPF admin workstation staging folder/misc

staging folder/admin

Metastore server staging folder/sql

Web application server staging folder/misc

staging folder/setup

To make the staging folder accessible:
1. Use FTP or a tool of your choice to share the original staging folder or to copy

the staging folder to other servers as indicated in the preceding table.
2. If you copy the staging folder to other servers, record the directory path for the

installation administrator.

Database administrator tasks
The Database administrator must prepare the databases required for Business
Process Framework, including gathering information about data sources, creating
databases and database accounts, and installing client software.

“Preparing the database for upgrade”
To prepare your database for an upgrade, you must back up your database and
export the configuration of your Metastore database to an XML manifest by
using the Export feature in the Business Process Framework Explorer.

Preparing the database for upgrade
To prepare your database for an upgrade, you must back up your database and
export the configuration of your Metastore database to an XML manifest by using
the Export feature in the Business Process Framework Explorer.

To prepare the database for upgrade:
1. Export the configuration of your Metastore database to an XML manifest by

using the Export feature in the Business Process Framework Explorer and make
a full database backup within your RDBMS.
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Consult the section of the BPF Explorer Handbook entitled Saving and Moving
BPF Configurations for further details of what information you have to save or
back up prior to beginning your upgrade.

Remember: The Business Process Framework Manifest export and database
backup are for recovery purposes only. The existing Business Process
Framework Metastore is upgraded in place.

2. Make a full database backup of the existing Business Process Framework Object
Store, for recovery purposes only.

3. Ensure that the Business Process Framework Metastore database server is
running, so that the installation program can update the Metastore.
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Upgrading and configuring Business Process Framework

After you have finished planning your upgrade and performing the prerequisite
tasks, you are ready to upgrade and configure Business Process Framework.
1. “Upgrading Business Process Framework server”

You can upgrade Business Process Framework server interactively by using the
upgrade installation program. You can also choose to run the installation
silently. Both methods automatically configure Business Process Framework
server.

2. “Validating Business Process Framework server upgrade” on page 63
Ensure that all expected application configuration and custom code are
deployed before you validate the Business Process Framework server upgrade
activity.

3. “Configuring Business Process Framework server after upgrade” on page 63
You must configure the Business Process Framework server after you upgrade.
The user name and password in the Process Task manager resets reset after
upgrade.

4. “Upgrading Business Process Framework Explorer” on page 64
You can upgrade Business Process Framework explorer by removing the
current version and reinstalling from the /staging folder/admin/ folder.

5. “Verifying Business Process Framework Explorer upgrade” on page 64
After you upgrade Business Process Framework Explorer, you can verify the
activity.

6. “Configuring Business Process Framework Explorer after upgrade” on page 65
You can configure Business Process Framework Explorer after you perform an
upgrade.

7. “Verifying the Business Process Framework Web application after upgrade” on
page 74
Ensure that the Business Process Framework upgrade was successful by
logging on to a sample Web application.

Upgrading Business Process Framework server
You can upgrade Business Process Framework server interactively by using the
upgrade installation program. You can also choose to run the installation silently.
Both methods automatically configure Business Process Framework server.

“Upgrading Business Process Framework server interactively”
The Business Process Framework Web application installer updates the
Workplace configuration files under the AE_install_dir/FileNet/Config/AE
folder and the Process Engine connection configuration files under the /Router
folder on the Application Engine server.
“Upgrading Business Process Framework server silently” on page 62
You can perform a silent upgrade to the Business Process Framework server.

Upgrading Business Process Framework server interactively
The Business Process Framework Web application installer updates the Workplace
configuration files under the AE_install_dir/FileNet/Config/AE folder and the
Process Engine connection configuration files under the /Router folder on the
Application Engine server.
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During automatic upgrade, the installer creates copies of the original configuration
files in the BPF_HOME/instdata/backup folder.

To upgrade interactively:
1. Open your completed Installation and Upgrade Worksheet file.

Tip: In the worksheet file, verify that the Data → Filter → AutoFilter command
is enabled. To view only Business Process Framework values, filter by BPF
Installer in the Installation or Configuration Program column.

2. 1. Start the Business Process Framework installation program:

Option Description

AIX Navigate to /staging_folder/setup and run
AIXfilenet_bpf_setup.bin

HP-UX RISC Navigate to /staging_folder/setup and run
HPUXfilenet_bpf_setup.bin

HP-UX Itanium Navigate to /staging_folder/setup and run
HPUXIA64filenet_bpf_setup.bin

Linux Navigate to /staging_folder/setup and run
LINUXfilenet_bpf_setup.bin

Solaris Navigate to /staging_folder/setup and run
SOLARISfilenet_bpf_setup.bin

Windows Navigate to \staging_folder\setup and run
WINDOWSfilenet_bpf_setup.exe.

3. Complete the Business Process Framework Web application upgrade program
screens with the values recorded in your Installation and Upgrade Worksheet.

4. Stop the Business Process Framework application server after running the
installer.

5. Delete all the following cache folders for the Business Process Framework Web
application:

Option Description

Oracle WebLogic Server bea_home/user_projects/domains/
app_domain/servers/server_name/tmp/
_WL_user.

WebSphere Application Server 5.x WAS_Home\temp\node_name\servers\server1\
bpf

WebSphere Application Server 6.x WAS_Home\profiles\profile-name\temp\
node_name\server1\bpf

6. Start the Business Process Framework application server.

Upgrading Business Process Framework server silently
You can perform a silent upgrade to the Business Process Framework server.

To install Business Process Framework silently:
1. Open your completed Installation and Upgrade Worksheet file.

Tip: In the worksheet file, verify that the Data → Filter → AutoFilter command
is enabled. To view only Business Process Framework values, filter by BPF
Installer in the Installation or Configuration Program column.
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2. Record a response file by running the installation program with the following
parameters:

Option Description

Windows Platformfilenet_bpf_setup.exe
-options-record BPFSilentUpgrade.rsp

UNIX Platformfilenet_bpf_setup.bin
-options-record BPFSilentUpgrade.rsp

3. To load parameters from the response file to use as initial values in the setup
UI, run the installation program with the following parameters:

Option Description

Windows WINDOWSfilenet_bpf_setup.exe -options
BPFSilentInstall.rsp

UNIX PLATFORMfilenet_bpf_setup.bin -options
BPFSilentInstall.rsp

4. To perform a silent upgrade, where the upgrade parameters are taken from the
response file and no setup UI is presented, use one of these commands to run
the installation program:

Option Description

Windows WINDOWSfilenet_bpf_setup.exe –options
BPFSilentUpgrade.rsp –silent

UNIX PLATFORMfilenet_bpf_setup.bin –options
BPFSilentUpgrade.rsp –silent

Validating Business Process Framework server upgrade
Ensure that all expected application configuration and custom code are deployed
before you validate the Business Process Framework server upgrade activity.

To verify the success of the Business Process Framework upgrade, verify the
upgrade by checking log entries and testing the connections and the application.

Configuring Business Process Framework server after upgrade
You must configure the Business Process Framework server after you upgrade. The
user name and password in the Process Task manager resets reset after upgrade.

To configure after the upgrade:
1. The user name and password for the BPF_Operation in Process Task manager

will be reset after upgrade. Change the user name and password after these
steps:
a. Navigate to Workplace → Admin → Process Configuration Console.
b. Open the Server node for your Process Engine Server
c. Open the Component Queues node.
d. Right click BPF_Operations.
e. Provide the proper user name and password in the Adaptor tab.
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2. If you are using Microsoft SQL Server 2005 for the Business Process Framework
Metastore, ensure that the Application Engine Process Task Manager is
configured to use the latest version of jtds-xxx.jar.

3. Apply IBM FileNet P8 Platform fix pack changes after upgrade
Follow the instructions under “Applying IBM FileNet P8 Platform changes to
the Business Process Framework installation” on page 144.

Upgrading Business Process Framework Explorer
You can upgrade Business Process Framework explorer by removing the current
version and reinstalling from the /staging folder/admin/ folder.

To upgrade the Business Process Framework Explorer:
1. Uninstall Business Process Framework Explorer.

a. Open Start Menu → Settings → Control Panel → Add/Remove Programs.
b. Select FileNet Business Process Framework Explorer.
c. Select Change/Remove.

2. Reinstall Business Process Framework Explorer from the /staging
folder/admin/ folder. While installing Business Process Framework Explorer,
enter the name of the existing Metastore database.
a. Open your completed Installation and Upgrade Worksheet file.
b. Log on to the Windows machine with an account that has local

administrator privileges.
c. Navigate to the directory \staging folder\admin and run the following

command: filenet_BPF_explorer_setup.exe
d. Complete the Business Process Framework Explorer installation program

screens with the values recorded in your Installation and Upgrade
Worksheet.

Verifying Business Process Framework Explorer upgrade
After you upgrade Business Process Framework Explorer, you can verify the
activity.

“Verifying Business Process Framework Explorer log on”
After you log on to Business Process Framework Explorer, you can verify the
activity.
“Verifying key parameters after upgrade” on page 65
You can verify that key settings in Business Process Framework Explorer are
the same as before the upgrade.

Verifying Business Process Framework Explorer log on
After you log on to Business Process Framework Explorer, you can verify the
activity.

To verify the Business Process Framework Explorer log on:
1. Verify that you can log on to Business Process Framework Explorer without

error.
2. If you have configured Content Engine integration by installing the Content

Engine Client libraries, verify that you can access an Object Store from the
Business Process Framework Explorer Case Type or Application Field Property
UI.
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Verifying key parameters after upgrade
You can verify that key settings in Business Process Framework Explorer are the
same as before the upgrade.

Configuring Business Process Framework Explorer after upgrade
You can configure Business Process Framework Explorer after you perform an
upgrade.

“Defining Business Process Framework site designer role (upgrade from 3.5.2
only)”
If you are upgrading Business Process Framework 3.5.2 to Business Process
Framework 4.1, the Business Process Framework Site Designer role must be
defined.
“Defining eForms case creation tool (upgrade from 3.5.2 only)”
You can configure the eForms Case Creation Tool to be available for existing
application upgrades from Business Process Framework 3.5.2.
“Updating toolbar.xml item sequence (upgrade from 3.5.2 only)” on page 66
If you have deployed as a WAR or EAR file, you must update the contents of
Toolbar.xml within the WAR or EAR.
“Removing redundant Priorities Filter picklist entry (upgrade from 3.5.2 only)”
on page 66
Since Business Process Framework 3.6, the Priorities picklist entry replaces the
old Priorities Filter entry.
“Modifying case type configuration” on page 66
You can modify the case type configuration of various properties.
“Exposing the new case operations features” on page 69
Business Process Framework 4.1 adds three new case operations: Merge Case,
Split Case and Reclassify Case. After an upgrade, these operations must be
added to Tools to make them available to the application, and to make the
upgrade consistent with a fresh installation. The new tools can then be exposed
from existing inbaskets only if that is desirable in your existing application.
“Modifying adhoc search definition” on page 71
You can modify search definitions. The adhoc search definitions show examples
of the values.
“Updating queue names for case-insensitive views” on page 73
If your environment includes Process Engine 4.0.3 or later, you must update the
object name of each queue to match with Process Engine case-insensitive views.

Defining Business Process Framework site designer role
(upgrade from 3.5.2 only)

If you are upgrading Business Process Framework 3.5.2 to Business Process
Framework 4.1, the Business Process Framework Site Designer role must be
defined.

To enable Layout Designer, you must manually create a Business Process
Framework Site Designer role and assign a user to that role in Business Process
Framework Explorer. Please see the Business Process Framework Web Application
UI Guide for more details on Layout Designer.

Defining eForms case creation tool (upgrade from 3.5.2 only)
You can configure the eForms Case Creation Tool to be available for existing
application upgrades from Business Process Framework 3.5.2.
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You can configure the eForms Case Creation Tool in the eForms Integration to
Business Process Framework document, to make the eForms Case Creation Tool
available to an existing application upgraded from Business Process Framework
3.5.2.

Updating toolbar.xml item sequence (upgrade from 3.5.2 only)
If you have deployed as a WAR or EAR file, you must update the contents of
Toolbar.xml within the WAR or EAR.

Follow these steps to update the toolbar.xml file. See “Updating the contents of
the Business Process Framework WAR file” on page 146 or “Updating the contents
of the Business Process Framework EAR file” on page 146 for more details.

To edit the XML file:

Edit the document BPF Deployment Home\WEB-INF\Toolbar.xml Ensure that the
items for Sign Out, Preferences, Search and other tools appear in the file in the
correct order, from right to left in the Web application.
(In 3.5.2 the items were displayed from left to right; in 3.6 and later, the display is
from right to left.)

Removing redundant Priorities Filter picklist entry (upgrade
from 3.5.2 only)

Since Business Process Framework 3.6, the Priorities picklist entry replaces the old
Priorities Filter entry.

The old Priorities Filter entry from 3.5.2 is now obsolete and redundant. The
following procedure is recommended to remove the redundant entry.

To remove the redundant Priorities Filter:
1. Replace Priority Filter pick list entry with Priority in any fields where it is used

in your current Web application.
2. Delete the Priorities Filter entry from the list at Miscellaneous → Pick Lists →

Priorities.

Modifying case type configuration
You can modify the case type configuration of various properties.

Business Process Framework uses the case type ID value to determine which object
store to search for Bp8CaseType objects and audit log objects. It also looks for the
right object store in which to place document objects. If you do not specify the
Bp8CaseType value, Business Process Framework will encounter errors when
searching for cases and attachments in multiple object stores.

“Adding a case type picklist” on page 67
You can create and add a case type picklist to the New Picklist properties.
“Updating the Bp8CaseType application field” on page 67
You can update the Bp8CaseType property on the Applications Field page.
“Selecting the field Bp8CaseType in workflow filters” on page 67
For each workflow query filter, you must change the Microsoft SQL Server
query string to add Bp8CaseType into the select field.
“Adding the parameter Bp8CaseType in attachment and eForms tabs” on page
68
Using a database tool, open the TABS table in Metastore database. For the two
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rows which TAB_NAME are Attachment and eForms, change the
TAB_CONTENT column value by adding a parameter Bp8CaseType .
“Exposing the field Bp8CaseType in inbasket” on page 68
For each Inbasket, its configuration must expose the Bp8CaseType field for all
case types on Case Fields tab of the Inbasket property page.
“Adding Bp8CaseType to create_eFormsCase tool” on page 68
The following step is only required if you are using, or intend to use, eForms
with Business Process Framework.

Adding a case type picklist
You can create and add a case type picklist to the New Picklist properties.

To add a case type picklist:
1. Create a Case Type Picklist in Miscellaneous → Pick Lists → , right-click Pick

Lists and select New → Picklist.
2. In the New Picklist Properties page, input the Name: CaseType Picklist and

the description: Picklist for Case Type, value/text=type code/type
description.

3. Press Edit button to open Picklist Advanced Configuration page and input
Microsoft SQL Server:
SELECT case_type_id as ID, case_type_id as CODE, name as DESCRIPTION, -1
as ACTIVE FROM case_types ORDER BY name

After that, a Case Type picklist is created.

Updating the Bp8CaseType application field
You can update the Bp8CaseType property on the Applications Field page.

To update the Bp8CaseType application field:
1. Open Bp8CaseType property page in Case Fields Configuration → Application

Fields page.
2. Choose Case Type Picklist in the Pick list field and save.

Selecting the field Bp8CaseType in workflow filters
For each workflow query filter, you must change the Microsoft SQL Server query
string to add Bp8CaseType into the select field.

For example, for the filter Public Inbasket, follow the steps later in this section to
change its SQL Server query string:
1. Launch Business Process Framework Explorer.
2. Open the property page of the filter Public Inbasket.
3. Click the button Edit Query. Insert the string Bp8CaseType into the select list.

The original value is:
select %PAGESIZE% F_WobNum, F_UniqueId, F_Locked, F_LockUser, F_BoundUser,
Bp8CaseID, 9999 as queue_depth from %VIEWNAME% WHERE %FILTERBY% F_StepName='
STEPNAME%' order by %ORDERBY%, F_EnqueueTime, F_UniqueId asc

Change to:
select %PAGESIZE% F_WobNum, F_UniqueId, F_Locked, F_LockUser, F_BoundUser,
Bp8CaseID, Bp8CaseType, 9999 as queue_depth from %VIEWNAME% WHERE %FILTERBY%
F_StepName='%STEPNAME%' order by %ORDERBY%,F_EnqueueTime, F_UniqueId asc
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Adding the parameter Bp8CaseType in attachment and eForms
tabs
Using a database tool, open the TABS table in Metastore database. For the two
rows which TAB_NAME are Attachment and eForms, change the TAB_CONTENT
column value by adding a parameter Bp8CaseType .

For the row Attachment, the original value is:
Bp8AttachmentsTab.jsp?eventTarget=attachmentsTab&eventName=
ExecuteSearch&TabName={TABNAME}&Inbasket={IID}&Bp8CaseID={CFNAME}&_showatt=0

This value must be changed to:
Bp8AttachmentsTab.jsp?eventTarget=attachmentsTab&eventName=
ExecuteSearch&TabName={TABNAME}&Inbasket={IID}&Bp8CaseID={CFNAME}
& Bp8CaseType={CFNAME} & _showatt=0

For example, the following SQL command can be used to change the Attachment
row:
UPDATE TABS SET
TAB_CONTENT='Bp8AttachmentsTab.jsp?eventTarget=attachmentsTab&eventName=
ExecuteSearch&TabName={TABNAME}&Inbasket={IID}&Bp8CaseID={CFNAME}&Bp8CaseType=
{CFNAME}&_showatt=0'WHERE TAB_NAME='Attachment'

For the row eForms, the original value is:
/BpfFormServlet?Bp8CaseID={CFNAME}&mode=1&_showatt=0&page=P001

This value must be changed to:
/BpfFormServlet?Bp8CaseID={CFNAME} & Bp8CaseType={CFNAME} &
mode=1&_showatt=0&page=P001

For example, this Microsoft SQL Server command can be used to change the
eForms row:
UPDATE TABS SET
TAB_CONTENT='/BpfFormServlet?Bp8CaseID={CFNAME}&Bp8CaseType={CFNAME}&
mode=1&_showatt=0&page=P001'WHERE TAB_NAME='eForms'

Exposing the field Bp8CaseType in inbasket
For each Inbasket, its configuration must expose the Bp8CaseType field for all case
types on Case Fields tab of the Inbasket property page.

Follow the steps later in this section to expose the Bp8CaseType field.

To expose the field:
1. Launch Business Process Framework Explorer.
2. Open the property page of the Inbasket you want to modify.
3. Open the Case Fields tab.
4. Select Bp8CaseType in the left list and click the button ->, then the field is

inserted into the right field list. Set its Visible and R/O value to YES.
5. Click the button Reset Layout.
6. Click the button and Apply” and click the button OK.

Adding Bp8CaseType to create_eFormsCase tool
The following step is only required if you are using, or intend to use, eForms with
Business Process Framework.
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Follow these steps to add the parameter Bp8CaseType to the tool
create_eFormsCase:
1. Launch Business Process Framework Explorer,
2. Open the property page of the tool create_eFormsCase.
3. Change the Handle URL value by adding the parameter objectStoreName. Set

the parameter value to the correct object store symbolic name storing case
object of the case type for which the eForms template is designed. For example,
this tool starts eForms for Case Management, and the object store for case
object of Case Management is BPFOSCase.
The original value of Handle URL is:
ExtCommand.jsp?eForms&ExtTask=create_eform_case&id=

{46A4F3A1-41C2-46B9-AE71-4393D906B335}&vsId=
{6F434403-DFC8-4E7D-B9D5-4C9572AD80BD}&objectType=document

Change to:
ExtCommand.jsp?eForms&ExtTask=create_eform_case&id=

{46A4F3A1-41C2-46B9-AE71-4393D906B335}&vsId=
{6F434403-DFC8-4E7D-B9D5-4C9572AD80BD}&objectStoreName=
BPFOSCase&objectType=document

Exposing the new case operations features
Business Process Framework 4.1 adds three new case operations: Merge Case, Split
Case and Reclassify Case. After an upgrade, these operations must be added to
Tools to make them available to the application, and to make the upgrade
consistent with a fresh installation. The new tools can then be exposed from
existing inbaskets only if that is desirable in your existing application.

For all of the three Case Operation tools configuration, fields Tool name, Display
label, and Handler URL must be set as shown. Settings for Appearance and
Visibility are recommended. Case Fields must be chosen on demand.

If Case Management Workflow is used for the Case Type, for Reclassify Case and
Split Case, the field CreateCase must be selected and set to 0 read-only (R/O).

To add the new case operation tools:
1. In Business Process Framework Explorer, navigate to Application Settings →

Tools.
2. Create a new tool called Merge Case.

a. In the right pane of the Tools window, right click and choose New → Tool.
b. Use the following General settings for the merge_case tool.

Table 19. Settings for Merge Case tool

For this field Specify this value

Case type Case Management

Tool name merge_case

Display label Merge Case

Handler URL MergeCase.jsp

Window width 800

Window height 600

Resizable (Checked)

Modal (Checked)
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Table 19. Settings for Merge Case tool (continued)

For this field Specify this value

Case mode (Checked)

Browse mode (Unchecked)

c. Specify the following Display Label settings:

Table 20. Display Label settings for Merge Case tool

Display Label Case Field Value Required Visible

Company Name Company Name (Blank) (Checked) (Checked)

Priority Priority (Blank) (Checked) (Checked)

Effective Date Effective Date (Blank) (Checked) (Checked)

Designated Rep Designated Rep (Blank) (Checked) (Checked)

Contract
Amount

Contract
Amount

(Blank) (Unchecked) (Checked)

Expired Expired (Blank) (Checked) (Checked)

d. Click Apply and OK to save the new tool.
3. Create a new tool called Reclassify Case.

a. In the right pane of the Tools window, right click and choose New → Tool.
b. Use the following General settings for the reclassify_case tool.

Table 21. Settings for Reclassify Case tool

For this field Specify this value

Case type Case Management

Tool name reclassify_case

Display label Reclassify Case

Handler URL ReclassifyCase.jsp

Window width 800

Window height 600

Resizable (Checked)

Modal (Checked)

Case mode (Checked)

Browse mode (Unchecked)

c. Specify the following Display Label settings:

Table 22. Display Label settings for Classify Case tool

Display Label Case Field Value Required Visible

CreateCase CreateCase 0 (Unchecked) (Checked)

Expired Expired (Blank) (Unchecked) (Checked)

Effective Date Effective Date (Blank) (Unchecked) (Checked)

Contract Notes® Contract Notes (Blank) (Unchecked) (Checked)

Contract
Amount

Contract
Amount

(Blank) (Unchecked) (Checked)

Company Name Company Name (Blank) (Unchecked) (Checked)
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Table 22. Display Label settings for Classify Case tool (continued)

Display Label Case Field Value Required Visible

Account
Number

Account
Number

(Blank) (Unchecked) (Checked)

Received Date Received Date (Blank) (Unchecked) (Checked)

Priority Priority (Blank) (Unchecked) (Checked)

d. Click Apply and OK to save the new tool.
4. Create a new tool called Split Case.

a. In the right pane of the Tools window, right click and choose New → Tool.
b. Use the following General settings for the split_case tool.

Table 23. Settings for Split Case tool

For this field Specify this value

Case type Case Management

Tool name split_case

Display label Split Case

Handler URL SplitCase.jsp

Window width 800

Window height 600

Resizable (Checked)

Modal (Checked)

Case mode (Checked)

Browse mode (Unchecked)

c. Specify the following Display Label settings:

Table 24. Display Label settings for Split Case tool

Display Label Case Field Value Required Visible

Company Name Company Name (Blank) (Checked) (Checked)

Priority Priority (Blank) (Checked) (Checked)

Effective Date Effective Date (Blank) (Checked) (Checked)

Designated Rep Designated Rep (Blank) (Checked) (Checked)

Contract
Amount

Contract
Amount

(Blank) (Unchecked) (Checked)

Expired Expired (Blank) (Checked) (Checked)

CreateCase CreateCase 0 (Checked) (Checked)

d. Click Apply and OK to save the new tool.

Modifying adhoc search definition
You can modify search definitions. The adhoc search definitions show examples of
the values.

There are three adhoc search definitions to be modified. Open BPF Explorer →
Application Settings → Web Application, and update the following three adhoc
search definitions values.
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“Case attachments list - adhoc search definition”
In the Case attachments list, there are search definitions that must be
configured. The adhoc search definitions show examples of the values.
“Attachments tab - adhoc search definition”
In the Attachments tab, there are search definitions that must be configured.
The adhoc search definitions show examples of the values.
“Viewer documents list - adhoc search definition” on page 73
In the Viewer documents list, there are search definitions that must be
configured. The adhoc search definitions show examples of the values.

Case attachments list - adhoc search definition
In the Case attachments list, there are search definitions that must be configured.
The adhoc search definitions show examples of the values.

To update the Case attachments list search definition field, add the new values to
the front of the existing entry. The original value is:
select a.Bp8ObjectID as Id, a.Bp8ObjectType as ObjectType, a.Id as AttachID,
d.DocumentTitle, d.VersionSeries, d.VersionStatus, d.MajorVersionNumber,
d.MinorVersionNumber, d.MimeType, d.isReserved, d.IsVersioningEnabled,
f.FolderName, c.Bp8CaseID from ((Bp8Attachment a left join Document d ON
d.VersionSeries = a.Bp8VersionSeries) left join Folder f ON f.Id = a.Bp8ObjectGUID)
left join CustomObject c ON c.Id = a.Bp8ObjectGUID where a.Bp8CaseID = ^1 and ^2
order by a.Bp8ObjectType desc, f.FolderName asc, d.DocumentTitle asc

Add the following new values at the front of the field:
select a.Bp8ObjectRepositoryId as ObjectStoreId, a.Bp8ObjectGUID as ObjectGUID,
a.Bp8ObjectClass as ObjectClassID, a.Bp8VersionSeries as DocVersionSeries,

The result will be the following list of values:
select a.Bp8ObjectRepositoryId as ObjectStoreId, a.Bp8ObjectGUID as ObjectGUID,
a.Bp8ObjectClass as ObjectClassID, a.Bp8VersionSeries as DocVersionSeries,
a.Bp8ObjectID as Id, a.Bp8ObjectType as ObjectType, a.Id as AttachID,
d.DocumentTitle, d.VersionSeries, d.VersionStatus, d.MajorVersionNumber,
d.MinorVersionNumber, d.MimeType, d.isReserved, d.IsVersioningEnabled, f.FolderName,
c.Bp8CaseID from ((Bp8Attachment a left outer join Document d ON d.VersionSeries =
a.Bp8VersionSeries) left outer join Folder f ON f.Id = a.Bp8ObjectGUID) left outer
join CustomObject c ON c.Id = a.Bp8ObjectGUID where a.Bp8CaseID = ^1 and ^2 order by
a.Bp8ObjectType desc, f.FolderName asc, d.DocumentTitle asc

Attachments tab - adhoc search definition
In the Attachments tab, there are search definitions that must be configured. The
adhoc search definitions show examples of the values.

To update the Attachments tab search definition field, add the new values to the
front of the existing entry. The original value is:
select a.Bp8ObjectID as Id, a.Bp8ObjectType as ObjectType, a.Id as AttachID,
f.FolderName, d.DocumentTitle, d.ReceivedDate, d.CompanyName, d.ContractAmount,
d.DocumentType, d.CasePriority, d.VersionSeries, d.VersionStatus,
d.MajorVersionNumber, d.MinorVersionNumber, d.MimeType, d.isReserved,
d.IsVersioningEnabled from (Bp8Attachment a left join Document d ON
d.VersionSeries = a.Bp8VersionSeries) left join Folder f ON f.Id =
a.Bp8ObjectGUID where a.Bp8CaseID = ^1 and ^2 order by a.Bp8ObjectType desc,
f.FolderName asc, d.DocumentTitle asc

Add the following new values to the front of the entry:
select a.Bp8ObjectRepositoryID as ObjectStoreId, a.Bp8ObjectGUID as ObjectGUID,
a.Bp8VersionSeries as DocVersionSeries,

The result will be the following list of values:
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select a.Bp8ObjectRepositoryID as ObjectStoreId, a.Bp8ObjectGUID as ObjectGUID,
a.Bp8VersionSeries as DocVersionSeries, a.Bp8ObjectID as Id,
a.Bp8ObjectType as ObjectType, a.Id as AttachID, f.FolderName, d.DocumentTitle,
d.ReceivedDate, d.CompanyName, d.ContractAmount, d.DocumentType, d.CasePriority,
d.VersionSeries, d.VersionStatus, d.MajorVersionNumber, d.MinorVersionNumber,
d.MimeType, d.isReserved, d.IsVersioningEnabled from (Bp8Attachment a left outer
join Document d ON d.VersionSeries = a.Bp8VersionSeries) left outer join Folder
f ON f.Id = a.Bp8ObjectGUID where a.Bp8CaseID = ^1 and ^2 order by a.Bp8ObjectType
desc, f.FolderName asc, d.DocumentTitle asc

Viewer documents list - adhoc search definition
In the Viewer documents list, there are search definitions that must be configured.
The adhoc search definitions show examples of the values.

To update the Viewer documents list search definition field, add the new values to
the front of the existing entry. The original value is:
select d.Id, d.ObjectType, a.Id as AttachID, d.DocumentTitle, d.isReserved,
d.IsVersioningEnabled , d.VersionSeries, d.VersionStatus, d.MajorVersionNumber,
d.MinorVersionNumber, d.MimeType from Bp8Attachment as a left join Document
as d on d.VersionSeries = a.Bp8VersionSeries where a.Bp8CaseID = ^1 and ^2 order
by d.DocumentTitle asc

Add the following new values at the front of the field:
select a.Bp8ObjectRepositoryID as ObjectStoreId, a.Bp8ObjectGUID as ObjectGUID,
a.Bp8VersionSeries as DocVersionSeries, a.Bp8ObjectType as ObjectType,
a.

The result will be the following list of values:
select a.Bp8ObjectRepositoryID as ObjectStoreId, a.Bp8ObjectGUID as ObjectGUID,
a.Bp8VersionSeries as DocVersionSeries, a.Bp8ObjectType as ObjectType,
a.Id as AttachID, a.Bp8ObjectID as Id, d.DocumentTitle, d.isReserved,
d.IsVersioningEnabled , d.VersionSeries, d.VersionStatus, d.MajorVersionNumber,
d.MinorVersionNumber, d.MimeType from Bp8Attachment as a left outer join Document
as d on d.VersionSeries = a.Bp8VersionSeries where a.Bp8CaseID = ^1 and ^2
order by d.DocumentTitle asc

Updating queue names for case-insensitive views
If your environment includes Process Engine 4.0.3 or later, you must update the
object name of each queue to match with Process Engine case-insensitive views.

To update queue names:
1. In Business Process Framework Explorer, click Workflow Configuration →

Queues.
2. Right-click the first queue, and choose Properties.
3. In the Object name field, edit the name to match the case-insensitive Process

Engine view name, and click OK. You can obtain these names from a Process
Engine vwtool report.

4. Repeat the configuration changes for all remaining queues.
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Related tasks

“Configuring Process Engine case-insensitive view support” on page 58
Process Engine 4.0.3 and later supports case-insensitive views. The new Process
Engine views provide case-insensitive column names. Using these new views
replaces the manual step of removing the quotation marks in the current VWV
views.

Verifying the Business Process Framework Web application after
upgrade

Ensure that the Business Process Framework upgrade was successful by logging on
to a sample Web application.

You must verify the Business Process Framework Web application after you
perform the upgrade. Follow the procedures in “Logging on to a sample Business
Process Framework Web application” on page 49.

To log on to a sample Web application:
1. Access Business Process Framework from the following URL: http://web

application server:web port/web BPF name

2. Log on to Business Process Framework. If this is the first time you are logging
on to the Business Process Framework Web application, you will have to set
the Business Process Framework bootstrap information. Make sure you save
the bootstrap information to the Bootstrap Object Store.

3. Create a new Case.
4. Open the case from the Index Inbasket and enter sample case field data.
5. Attach a document to the case by using the Attach Document tool.
6. Open the attached content in the Viewer.

Tip: Ensure that the appropriate JRE is installed for the browser.
7. Perform a Business Process Framework Case Search. You must first configure

a case search. For more information, see “Configuring stored searches” on
page 77.

8. Choose Action → Complete on the case, then locate the case in the Review
Inbasket to make sure it was dispatched.

9. Open Layout Designer through the Edit Layout tool.
10. Log off Business Process Framework.
11. Log on to Business Process Framework Explorer and verify all configuration

data is present.
12. In order to verify that BPF_Operations are working in Component Manager,

add a new document to the Case Management Documents document class.
The document must have a DocEntryStatus value of 1, and a DocType value
of 1.
The subscription event launches a workflow that creates a new case. If
BPF_Operations is running, you see a new Case in the Index Inbasket. For
information on creating a workflow subscription, see “Modifying Business
Process Framework operations logging (optional)” on page 85.
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Configuring Business Process Framework after installation or
upgrade

After you install or upgrade Business Process Framework, you can configure
additional settings and features.

“Configuring Business Process Framework for eForms (optional)” on page 76
The steps to integrate eForms with Business Process Framework are not
included in this document and are not part of the standard Business Process
Framework installation package implementation.
“Configuring Business Process Framework Explorer for multiple Metastores
(optional)” on page 76
You do not need to configure Business Process Framework Explorer if Business
Process Framework Explorer accesses only one Business Process Framework
Metastore.
“Configuring stored searches” on page 77
You can configure the search folder and templates so that you can perform
custom object type searches for Case search. You must configure the search
folder and templates and store them in the Bootstrap Object Store for the Search
and Attach Document tool to find them.
“Setting Content Engine security” on page 79
You must set security permissions for Business Process Framework data model
files that you imported into the object store.
“Deploying Business Process Framework documentation” on page 80
You can deploy the Business Process Framework documentation from the
documentation CD.
“Setting tuning parameters (optional but highly recommended)” on page 82
This optional but highly recommended step sets the Business Process
Framework Case ID and Microsoft Internet Explorer Cache Setting
parameters.
“Adding database indexes in the Content Engine database” on page 83
You must add database indexes to properties in the Content Engine object store.
“Configuring Business Process Framework SSL security (optional)” on page 84
You can optionally configure Business Process Framework to direct sign-ins
through a Secure Socket Layer (SSL) HTTPS connection.
“Modifying Business Process Framework operations logging (optional)” on
page 85
You can change the default Business Process Framework logging operations.
“Creating workflow subscription on the Content Engine Case Management
Documents document class (optional)” on page 86
You can create and configure workflow subscription on Content Engine Case
Management Documents document class.
“Configuring for multiple object store support” on page 90
You can configure Business Process Framework to support multiple object
stores.
“Legacy cases in a multiple object store environment” on page 93
The original cases that were created in Business Process Framework 4.0 are
stored in the DefaultOS in Business Process Framework 4.1. Likewise, any cases
that were created in Business Process Framework 4.1 before you configure the
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system for multiple object stores will have all their data stored in the
DefaultOS. These cases are referred to as legacy cases.

Configuring Business Process Framework for eForms (optional)
The steps to integrate eForms with Business Process Framework are not included
in this document and are not part of the standard Business Process Framework
installation package implementation.

For information on how to perform this configuration, see the eForms Integration
to Business Process Framework document.

Configuring Business Process Framework Explorer for multiple
Metastores (optional)

You do not need to configure Business Process Framework Explorer if Business
Process Framework Explorer accesses only one Business Process Framework
Metastore.

Business Process Framework Explorer can update multiple Metastores, but all
Metastores must be of the same database type, for example, DB2 or Oracle.

By default, Business Process Framework Explorer accesses the Metastore that you
specify as you install Business Process Framework Explorer. You can configure the
Windows registry to enable Business Process Framework Explorer to access
multiple Metastores of the same database type. When the user logs on, Business
Process Framework Explorer presents a menu listing the Metastores available to
the user.

To configure Business Process Framework Explorer for multiple Metastores:
1. Open the registry editor. Click Start → Run and enter regedit. Click OK.
2. Locate the My Computer\HKEY_LOCAL_MACHINE\SOFTWARE\FileNet Business

Process Framework key. Locate a Common key.
3. For each Metastore:

a. Create a new copy of the Bp8sql.xml file. Change the value of meta user in
the following line in the new copy of the Bp8sql.xml file:
<ORACLE>alter session set current_schema=meta user</ORACLE>

Tip: The Bp8sql.xml file is in the Business Process Framework Explorer
home directory in the same directory as the BPFExplorer.msc file.

b. Create an ODBC connection for the Metastore: Click Start Menu →
Programs → Administrative Tools → Data Sources (ODBC) .

c. Select the System DSN tab.
d. Select Add.

Tip: An ODBC connection already exists for the Metastore specified during
Business Process Framework Explorer setup.

e. In the registry editor, export the common Metastore settings. Click
Common. Select Registry → Export Registry File.

f. Change the following in the exported registry file:

Key name
For example, change HKEY_LOCAL_MACHINE\SOFTWARE\IBM FileNet
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Business Process Framework\Common to HKEY_LOCAL_MACHINE\
SOFTWARE\IBM FileNet Business Process Framework\Metastore1. The
key name determines the name of the Metastore as shown to the
user in the log on drop-down menu. In the above example
Metastore1 appears as one of the Metastore choices.

DATABASE_CONNECTION_STRING.
Change the DSN to reference your ODBC DSN.

This value is used by the WFImport.exe utility. It requires that both
UID (user ID) and PWD (password) be present as the WFImport.exe
utility has no ability to ask for this information as user input at
runtime. We do not regard this as a security risk but the
WFImport.exe is a tool that is typically used only during the
development phase of a project. The WFImport.exe must use ODBC
on DB2, Oracle and Microsoft SQL Server configurations. That is the
only supported connectivity type for this utility.

BP8_EXPLORER_DATABASE_CONNECTION_STRING
Change the DSN to reference your ODBC DSN.

This value must be configured to use ODBC on Microsoft SQL
Server and OLEDB on Oracle. Issues have been known to occur with
Oracle ODBC drivers and it has been determined that, on Oracle
platforms, OLEDB must be used for
BP8_EXPLORER_DATABASE_CONNECTION_STRING and
ODBC for DATABASE_CONNECTION_STRING.

DATABASE_SQL_XML
Change the full file path to point to the new copy of the Bp8sql.xml
file.

DATABASE_SQL_XML
Must be updated for Oracle only.

g. Import the edited registry file. Click Registry → Import Registry File.

Important: Do not delete HKEY_LOCAL_MACHINE\SOFTWARE\
FileNet Business Process Framework\Common.

Configuring stored searches
You can configure the search folder and templates so that you can perform custom
object type searches for Case search. You must configure the search folder and
templates and store them in the Bootstrap Object Store for the Search and Attach
Document tool to find them.

To configure a simple search:
1. Using Enterprise Manager, create a folder for holding search templates and

stored searches, for example: Object Stores → bootstrap os display name →
Root Folder → BPF → Searches.

2. Using Search Designer (invoked from Workplace), create a search template.
3. Go to the Object Stores tab. Select the Object Store containing the case objects

to be found.
4. Set the Object Types settings.

a. Click the Object Types tab.
b. Click Custom Objects.
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Tip: If Workplace was not configured to enable custom objects, this check
mark does not appear. To enable custom objects, do the task Editing
Workplace Site Preferences.

c. Verify that Documents is also selected.
d. Click Update Subclass List.
e. In the View section, select Editable.
f. In the Object Subclass section, select the appropriate child class of Bp8Case.

For the Case Management sample application, this is Case Management.
5. Set the Search Criteria settings.

a. Click the Search Criteria tab.
b. In the View column in the first table, select Editable.
c. In the Property column in the first table, Select Bp8CaseID.
d. In the Operator column, select is equal to.

6. Choose File → Add New → .... Browse for your search folder.
7. Enter the document title: BPFCase ID Search.
8. Click Next and Finish.
9. Using Enterprise Manager, get the GUID for the folder containing the search

templates. Right click the folder and select Properties. On the Properties tab,
select All Properties as the filter and copy the Property Value for the ID
property. Save the GUID to a temporary file.

10. Stop the Business Process Framework Web application in the Web application
server.

11. Update the BPF Deployment Home\WEB-INF\Toolbar.xml file.

Tip: If you have deployed Business Process Framework as a WAR or EAR file,
you must update the contents of Toolbar.xml file within the WAR or EAR. See
“Updating the contents of the Business Process Framework WAR file” on page
146 or “Updating the contents of the Business Process Framework EAR file”
on page 146 and perform the following steps:
a. Find the item section that starts with Item Caption='Search'

Name='Search' SearchMode='no'.
b. In that item section find the Action section with the invokeWorkplaceObject

call. The first parameter in the invokeWorkplaceObject is a GUID.
c. Substitute the current GUID with the GUID for your search folder. If the

invokeWorkplaceObject method is used to invoke versionable content in
Content Engine. For example, if you choose to configure it to point to an
actual Search Template or other document rather than a Folder where
Searches are stored, you must change the GUID value when a new version
of the content is created. Otherwise invokeWorkplaceObject continues to
invoke the original version.

d. Save the changes.
12. Repackage your WAR or EAR file, if you are using one.
13. Redeploy your Web application.
14. Restart the Business Process Framework Web application in the Web

application server.
15. Test the Search functionality when you log onto Business Process Framework.
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Setting Content Engine security
You must set security permissions for Business Process Framework data model
files that you imported into the object store.

Business Process Framework Installer imports Business Process Framework specific
data model files to the object store. After you import the required data model files
to the object store, you must set security permissions. LDAP role groups refer to
the LDAP groups that correspond to Business Process Framework Metastore roles.
1. Use Enterprise Manager to apply security permissions to the Business Process

Framework specific classes and objects as listed in the following tables.

Object Stores Realm (top-level EM root node)

Group Security permissions

Administrative users or groups Full Control

#AUTHENTICATED-USERS (or LDAP role
groups)

Use stores and services

os_display_name (root node)
Where os_display_name is the object store name.

Group Security permissions

Administrative users or groups Full Control

#AUTHENTICATED-USERS (or LDAP role
groups)

Use stores and services

os_display_name → Other Classes → Custom Object → object_type
Where object_type is one of the following types:
v Bp8Object

v Bp8Attachment

v Bp8AuditLogItem

v Bp8Case and subclasses, where each subclass might have different
LDAP role groups assigned

If you are changing security on an object store that contains the above
object instances, apply the Default Instance Security to any existing
instances of the classes listed above.

Groups Security permission sets
Default instance security
permission sets

Administrative users or
groups

Full Control Full Control

LDAP role groups Modify Properties Modify Properties

os_display_name → Root Folder → BPF → Bp8Settings: object instance [search
for id = B4DF1A0E-CB28-4979-B34B-F997F9E30E3D]

This is the object instance, not the Bp8Settings class.

Group Security permissions

Administrative users or groups Full Control

LDAP role groups Modify properties
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os_display_name → Root Folder → BPF → Site Layouts

Group Security permissions

Administrative users or groups Full Control

LDAP role groups Modify properties

os_display_name → Document Class → document_class_name
where each document_class_name subclass might have different LDAP
role groups assigned.

Group Security permissions

Administrative users or groups Full Control

LDAP role groups Modify properties

2. Restart the Content Engine application server.

Deploying Business Process Framework documentation
You can deploy the Business Process Framework documentation from the
documentation CD.

To deploy Business Process Framework documentation:
1. Insert the documentation CD into a CD reader.
2. For systems other than Windows, mount the CD device.

“Installing the Business Process Framework help documentation on WebSphere
Application Server”
To view help topics for Business Process Framework, you must install and
deploy the bpf_help.war file on WebSphere Application Server.
“Installing the Business Process Framework help documentation on Oracle
WebLogic Server 8.1.x” on page 81
To view help topics for Business Process Framework, you must install and
deploy the bpf_help.war file on Oracle WebLogic Server 8.1.x.
“Installing the Business Process Framework help documentation on Oracle
WebLogic Server 9.2.x or 10” on page 81
To view help topics for Business Process Framework, you must install and
deploy the bpf_help.war file on Oracle WebLogic Server 9.2.x. or 10
“Installing the Business Process Framework help documentation on JBoss
Application Server 4.0.x or 4.2.x” on page 82
To view help topics for Business Process Framework, you must install and
deploy the bpf_help.war file on JBoss Application Server 4.0.x or 4.2.x.

Installing the Business Process Framework help
documentation on WebSphere Application Server

To view help topics for Business Process Framework, you must install and deploy
the bpf_help.war file on WebSphere Application Server.

To install Business Process Framework help:
1. Install Business Process Framework Help from the WebSphere Application

Server administrative console:
a. Click Applications → Enterprise → Applications → Install.
b. Browse to bpf_help.war file on the documentation CD.
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c. Enter Context Root: web BPF help name

d. Click Next or Continue until Install New Application screen is reached.
e. Click Finish. A success message is displayed.
f. Click Save to Master Configuration.
g. Click Save.

2. Confirm that Business Process Framework Help is functional:
a. From the WebSphere Application Server administrative console, go to

Applications → Enterprise Applications.
b. Check web BPF help name.
c. Click Start.
d. Invoke help: http://web application server:9080/web BPF help name

Installing the Business Process Framework help
documentation on Oracle WebLogic Server 8.1.x

To view help topics for Business Process Framework, you must install and deploy
the bpf_help.war file on Oracle WebLogic Server 8.1.x.

To install Business Process Framework help:
1. Install Business Process Framework Help from the WebLogic Server

administrative console.
a. Click Deployments → Web Application Modules.
b. Click Deploy a new Web Application Module.
c. Click Upload your files.
d. Browse to bpf_help.war or the bpf_help folder on the documentation CD.
e. Click Upload.
f. Select the target bpf_help.war or bpf_help and click Target Module.
g. Enter Name: web BPF help name.
h. Click Deploy.

2. Confirm Business Process Framework Help is functional. Invoke help:
http://web application server:7001/web BPF help name.

Installing the Business Process Framework help
documentation on Oracle WebLogic Server 9.2.x or 10

To view help topics for Business Process Framework, you must install and deploy
the bpf_help.war file on Oracle WebLogic Server 9.2.x. or 10

To install Business Process Framework help:
1. Start the application server.
2. From theWebLogic Server Console, navigate to the domain to which you want

to deploy Business Process Framework Web application.
3. Click Deployments.
4. (Oracle WebLogic Server 9.2.x only) Under Change Center, click Lock & Edit.
5. From the right pane of the WebLogic Server Console, browse and select the

radio button for bpf_help.war or the bpf_help folder on the documentation CD.
6. Click Install. Accept the defaults for the deployment.
7. Click Finish. Business Process Framework Web application is deployed.
8. To verify that the deployment was successful, expand Web applications. The

Web application Business Process Framework help is listed.
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Installing the Business Process Framework help
documentation on JBoss Application Server 4.0.x or 4.2.x

To view help topics for Business Process Framework, you must install and deploy
the bpf_help.war file on JBoss Application Server 4.0.x or 4.2.x.

To install Business Process Framework help:
1. Copy the bpf_help.war file or the bpf_help folder from the documentation CD

to JBOSS_HOME/server/server_name/deploy/.
2. If you copied the folder, rename the new folder to bpf_help.war.
3. Restart the JBoss Application Server.
4. Verify that the application deployed successfully, by browsing to the Business

Process Framework help URL: http://server_name:port/bpf_help
The default port number is 8080.

Setting tuning parameters (optional but highly recommended)
This optional but highly recommended step sets the Business Process Framework
Case ID and Microsoft Internet Explorer Cache Setting parameters.

Temporarily disable metadata cache. When you configure the system, disable
Metadata cache in Business Process Framework Explorer: Application Settings →
Enable Metadata cache = False.

Remember: When Metadata cache is enabled, Business Process Framework
Explorer changes take effect only after the Web application is restarted.

Set the following parameters:

Case ID
Reset the Case ID back to 1 with each release or set it to a particular
starting number. To make that change, locate the Settings object in the Root
Folder/BPF folder in the Content Engine repository and set the
Bp8LastCaseID to a desired number.

Microsoft Internet Explorer Cache Setting
Set the Microsoft Internet Explorer cache setting to automatic on user
desktops to achieve best performance. To verify or correct the browser
settings, open Tools → Internet Options → General tab → Settings and
ensure the Check for newer versions of stored pages is set to
Automatically.

Tip: This setting is not needed on JBoss Application Server.
“Setting the HTTP Connection Timeout parameter in WebSphere Application
Server”
You must set the HTTP Connection Timeout parameter on WebSphere
Application Server.
“Setting the JVM heap size on Oracle WebLogic Server” on page 83
You must set the JVM heap settings on Oracle WebLogic Server.

Setting the HTTP Connection Timeout parameter in
WebSphere Application Server

You must set the HTTP Connection Timeout parameter on WebSphere Application
Server.
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To set the HTTP Connection Timeout parameter:
1. Increase the HTTP connection timeout from the default 5 seconds to 10 seconds

or more.
2. Modify ConnectionIOTimeout and ConnectionKeepAliveTimeout parameters

in WebSphere Application Server.
Changing these parameters is required to resolve timeout and XML parsing
errors that might be observed on slow or busy network connections.

3. Follow the instructions for your version of WebSphere Application Server for
setting HTTP transport custom properties.

Related information

WebSphere Application Server 7.x HTTP transport custom properties

Setting WebSphere Application Server 6.x HTTP transport custom properties

Setting the JVM heap size on Oracle WebLogic Server
You must set the JVM heap settings on Oracle WebLogic Server.

To set the JVM heap settings:
1. Set JVM heap minimum and maximum settings to an equal number.

This step minimizes the negative performance effects of the garbage collection
in Java™.

2. Set the heap size to 256 MB or more on the production installation.

Adding database indexes in the Content Engine database
You must add database indexes to properties in the Content Engine object store.

You must index the following properties in the Content Engine object store:

Table 25. Object store properties

Object Index field name

Bp8Attachment Bp8ObjectGUID

Bp8Attachment Bp8Attachment_ Bp8Case

Bp8AuditLogItem Bp8AuditLogItem_ Bp8Case

Bp8Case Bp8CaseID

Do the following steps for each of the items previously listed by using Enterprise
Manager:
1. Navigate to Enterprise Manager → os display name → Other Classes → Custom

Object → Bp8Object.
2. Right click the appropriate object.
3. Select Properties.
4. Select Property Definitions tab.
5. Check the Inherited Properties check box.
6. Select the appropriate field name.
7. Click Edit.
8. Verify that the Indexed text box has value of single indexed. If not:

a. Click the Set/Remove button.
b. Click Set radio button.
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c. Check the Single Indexed check box.
d. Click OK.

9. Click OK to close Properties page.

Configuring Business Process Framework SSL security (optional)
You can optionally configure Business Process Framework to direct sign-ins
through a Secure Socket Layer (SSL) HTTPS connection.

The Business Process Framework Web application must be installed.

Business Process Framework Web application supports the following methods of
configuring an SSL environment:

Full SSL support
A single Business Process Framework Web application server, where all of
the software is running under SSL.

One server SSL redirect
One Business Process Framework Web application server set up to redirect
logon attempts on the non-SSL port to the SSL port.

Two server SSL redirect
Two Business Process Framework Web application servers, where one is
SSL-enabled, and the other redirects users to the SSL-enabled Business
Process Framework Web application server to log on.

“Setting up full SSL support on a single Business Process Framework Web
application server”
You can set up full SSL support on a single Business Process Framework Web
application server.
“Setting up SSL redirect on a single Business Process Framework Web
application server” on page 85
You can set up SSL redirect on a single Business Process Framework Web
application server.
“Setting up SSL redirect on two Business Process Framework Web application
servers” on page 85
You can set up SSL redirect on two Business Process Framework Web
application servers.

Setting up full SSL support on a single Business Process
Framework Web application server

You can set up full SSL support on a single Business Process Framework Web
application server.

To set up full SSL support:
1. Enable SSL on the application server that runs Business Process Framework

Web application (see your SSL documentation).
2. Test the SSL connection by signing into Business Process Framework Web

application by using the following URL: https://
BPF_Web_Application_server_name:SSL port/Context_Root
The entire sign-in process is handled by the SSL-enabled host.
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Setting up SSL redirect on a single Business Process
Framework Web application server

You can set up SSL redirect on a single Business Process Framework Web
application server.

To set up SSL redirect:
1. Enable SSL on the application server that runs Business Process Framework

Web application (see your SSL documentation).
2. Change the sslInfo attribute in bootstrap preferences file (SERVER:HTTPSPORT)

format. Save the file.

Tip: The first time you log on to Business Process Framework Web Application,
you get a bootstrap page to set Business Process Framework bootstrap
information. You can set sslinfo attribute from bootstrap page. For subsequent
logons you manually edit the bootstrap preference file to set sslinfo attribute.

3. Sign out of Business Process Framework Web Application, and close your
browser.

4. Test the SSL connection by signing into Business Process Framework Web
Application by using the following URL: http://
BPF_Web_Application_server_name:non-SSL port/Context_Root
You are redirected to the SSL-enabled port for sign in, then back to the non-SSL
enabled port after sign-in is complete.

Setting up SSL redirect on two Business Process Framework
Web application servers

You can set up SSL redirect on two Business Process Framework Web application
servers.

To set up SSL redirect:
1. Install Business Process Framework Web application on both computers so that

both Business Process Framework Web applications use the same
bootstrap.properties and UTCryptokeyFile.properties files. (The Setup
program prompts you to configure both locations. For SSL redirect to work,
each Business Process Framework Web application must use the same User
Token cryptographic key file).

2. Change the sslInfo attribute in bootstrap preferences file (SERVER:HTTPSPORT)
format. Save the file.

3. Sign out of both Business Process Framework Web application and close your
browser.

4. Test the SSL connection by signing into first Business Process Framework Web
application by using the following URL: http://
BPF_Web_Application_server_name:non-SSL port/Context_Root
You are redirected to the SSL-enabled port for sign in to the second Business
Process Framework Web application instance, and then back to the non-SSL
enabled port after sign-in is complete.

Modifying Business Process Framework operations logging (optional)
You can change the default Business Process Framework logging operations.

Logging in the Business Process Framework operations component is enabled by
default by using the ERROR level. The following levels are supported:
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error Log errors only (default).

warning
Log errors and warnings.

info Log all above and information type messages.

debug Log information on the detailed level (this option might generate large
file).

By default, logging is directed to the Bp8Operations file located in the BPF\bpfops
folder. A new empty log is created at the end of each day.

To modify Business Process Framework operations logging:
1. Extract log4j.xml from the install.home/bpfops/bp8ciops.jar package by

using WinZip or another tool.
2. Modify the following sections of the log4j.xml file:

v Log File Name: param name="File" value="bp8operations.log"/ where
value = the name and the location of the log file.

Tip: The default location of log files is the \bin directory of the running
JVM. Be aware that usage of absolute path (including drive letter) is
impossible, but any relative path from bin directory of JVM directory can be
used. For example: /../../../logs/bp8ciops.log.

v Logging Level: level value ="error"/ where value = error, warning, info, or
debug

3. Add the log4j.xml file back to bp8ciops.jar. Create production and debug
level copies of bp8ciops.jar to simplify management.

4. Restart the Component Manager for the changes to take effect.

Creating workflow subscription on the Content Engine Case
Management Documents document class (optional)

You can create and configure workflow subscription on Content Engine Case
Management Documents document class.

Bypass this step if you are not using the standard process map (Case Management
Sample Application).

If you are using the Case Management Sample Application, you must create and
configure this Workflow Subscription so that the creation event for new Case
Management Documents objects triggers the launch of new workflows that either
creates new Business Process Framework Cases (with the new document attached)
or attaches the new document to an existing Case (depending on values configured
below).

The sample process map has different behavior depending on how the subscription
is configured and on the values of DocumentType and AccountNumber in the new
document:
v If the DocumentType is set to 1, regardless of whether you map DocumentType

in the Property Map, then when the subscription is launched, it will create a
case in the Index Inbasket, and attach the document to it.

v If the DocumentType is set to 2 and DocumentType is not mapped in the
Property Map, then when the subscription is launched, it will attach a document
to the existing case with the same value in the AccountNumber field, in the
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Index inbasket. You must provide a value for AccountNumber or the workflow
will not be able to find the existing case. If there are multiple existing cases with
that AccountNumber value, the workflow will attach the document to a single
arbitrary case.

v If the DocumentType is set to 2 and DocumentType is mapped in the Property
Map, then when the subscription is launched, it will create a new case in the
Matching Inbasket, and attach the document to it.

Regardless of the behavior that you want, you must change DocEntryStatus from
None to DocEntry (interval value is 1) for the sample workflow to operate
correctly.

“Creating subscriptions from Enterprise Manager or Workplace”
Follow this procedure to create a subscription from the FileNetEnterprise
Manager. You can also create the workflow subscription from Workplace.
“Testing the workflow subscription on the Content Engine Case Management
Documents document class” on page 88
You can test workflow subscriptions on Content Engine Case Management
Documents document class by creating a new instance of the Case Management
Documents class or by launching the workflow manually.
“Troubleshooting the workflow subscription” on page 90
If you launch a workflow subscription and you see no new Case or no new
Attachment on an existing Case, ensure that BPF_Operations is running in
Component Manager. If BPF_Operations is stopped, restart it and see whether
your results now appear as expected.

Creating subscriptions from Enterprise Manager or Workplace
Follow this procedure to create a subscription from the FileNetEnterprise Manager.
You can also create the workflow subscription from Workplace.

To create the subscription:
1. Log on to Enterprise Manager and open the Case Management Documents

Class Properties screen by navigating through Object Stores → os display
name → Document Classes → Case Management Documents.

2. Click the Subscriptions tab and then click Create.
3. Follow the steps indicated by the Content Engine Create a Subscription

Wizard. Begin by using Case Management Workflow for the Name and
Description on the Name and Describe the Subscription screen. Then, click
Next.

4. On the Specify the Type of Object screen, click the Applies to all instances of
class Case Management Documents radio button and ensure to check the
Workflow checkbox. Then, click Next.

5. On the Specify Triggers screen, select and highlight Creation Event in the list
of Available Events on the left-hand side of the dialog, then click the >>
button to move it over to the list of Subscribed Events on the right-hand side
of the dialog. Then, click Next.

6. On the Specify Workflow Information screen that follows, leave Workflow
Event Action selected in the first dropdown list (Select a Workflow Event
Action) and then select Case Management Workflow in the second dropdown
(Select a Workflow Definition). Doing this automatically populates the third
dropdown (Select a Version) with the number of the latest (current) version of
your Case Management Workflow.

7. Select Enable Manual Launch before you click Next.
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Remember: Your Case Management Workflow must be saved as a Workflow
Definition document object in your Object Store for it to appear here in the list
of available Workflows. Transferring a Workflow Map to the Isolated Region
in Process Engine without also saving it in Content Engine does not work.
The number in the Isolated Region field defaults to whatever is actually in use
on your machine.

8. On the Specify Additional Properties screen, enter DocEntryStatus=1 for Filter
Expression and click Next.

9. On the Complete the Create a Subscription Wizard screen, confirm your
settings and click Finish.

10. Reopen the properties for your new subscription and configure its Property
Map. To do this, while still on the Subscriptions tab of the property page for
your Case Management Documents Class Properties screen, highlight the new
Case Management Workflow subscription and click Properties.

11. Click the Workflow tab of the Case Management Workflow Properties screen
and enter the following Property Map settings:

Table 26. Property map settings

Process Engine property Content Engine property

AccountNumber AccountNumber

Bp8CaseID Bp8CaseID

CompanyName CompanyName

ContractAmount ContractAmount

DocumentType DocumentType

EffectiveDate EffectiveDate

Priority CasePriority

ReceivedDate ReceivedDate

Tip: The Workflow Property and Document Property names for the Case
Management Sample Application are all the same except for CasePriority
(Content Engine) and Priority (Process Engine).

12. When you finish adding the last mapping, click Cancel. Then, click Apply
and OK.

Testing the workflow subscription on the Content Engine Case
Management Documents document class

You can test workflow subscriptions on Content Engine Case Management
Documents document class by creating a new instance of the Case Management
Documents class or by launching the workflow manually.

“Starting the workflow subscription by creating a new document instance” on
page 89
Creating a document in the Content Engine launches a workflow. The behavior
of that workflow varies depending on how the workflow subscription is
configured.
“Manually starting the workflow subscription” on page 89
You can manually create the Workflow Subscription in two ways. You can
create a new Case Management Documents document and leave
DocEntryStatus set to None (0), so that the Workflow Subscription does not run
through the Creation Event, and then browse to the new document. You can
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also browse to an existing Case Management Documents document in
Workplace and open its Information page.

Starting the workflow subscription by creating a new document
instance
Creating a document in the Content Engine launches a workflow. The behavior of
that workflow varies depending on how the workflow subscription is configured.

To test the Workflow Subscription by creating a new instance of the Case
Management Documents class, log on to Workplace and browse to a folder in your
Object Store where you want to place your new documents.

To start the workflow subscription by creating a new document instance:
1. You might have to create this folder yourself. Once there, click the Add

Document link to launch the Add Document Wizard. Then click the Change
Class link and select Case Management Documents.

2. Enter document property values in the resulting screen, making sure to change
DocEntryStatus from None to DocEntry (1). (This is because of the Filter
Expression you set when configuring the Workflow Subscription itself.)
Otherwise the Workflow Subscription you created is not launched.

3. Enter values for DocumentType and AccountNumber depending on the
behavior you want, as explained above.

4. Once you have finished entering the document property values, click the Next
button, adjust the security settings (on the resulting Set Security screen) as
needed (or take the defaults), then click Next again and. On the Select File
screen, browse to a local file to upload as the content of this new document
object. When you are done, click Finish. The Workflow Subscription launches a
new Workflow.

5. To check the results, log on to the Business Process Framework Web application
and look at the case in the Index or Matching Inbasket.

Manually starting the workflow subscription
You can manually create the Workflow Subscription in two ways. You can create a
new Case Management Documents document and leave DocEntryStatus set to
None (0), so that the Workflow Subscription does not run through the Creation
Event, and then browse to the new document. You can also browse to an existing
Case Management Documents document in Workplace and open its Information
page.

When you have browsed to the document, make sure to change the value of the
DocEntryStatus property to DocEntry (1) if it is already set to any other value.
Otherwise, you cannot start the Workflow Subscription. This is because of the
Filter Expression you set when configuring the Workflow Subscription itself.

To start the workflow subscription manually:
1. Click the Launch link to see the Workplace Launch Processor’s Launch Step

General screen.
2. Click each of the four links under Information to review the values configured

(noting that your current document is set as the Initiating Attachment) and
then click the Launch button.

3. On the Attachments screen, click the Assign link and browse.
4.
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Troubleshooting the workflow subscription
If you launch a workflow subscription and you see no new Case or no new
Attachment on an existing Case, ensure that BPF_Operations is running in
Component Manager. If BPF_Operations is stopped, restart it and see whether your
results now appear as expected.

Try the following tasks to troubleshoot problems with workflow subscriptions on
Content Engine Case Management Documents document class.
v If BPF_Operations is running and you still see no effects from launching your

Workflow Subscription, open Process Administrator and search for new Work
Items to see if any Work Item was launched.

v If a Work Item was launched, open it in Process Tracker to see what went
wrong. Click the Workflow History tab, highlight the line where the Exception
occurred, right click and select View Information Stack.... Then highlight the
line in the upper pane and then hover your mouse pointer above the Error
Message text to see full information about the error.

v Alternatively, if a search in Process Administrator indicates that no Work Item
was launched at all, open the Windows Application Event Log on the Content
Engine server to see if any error occurred during launch.

Configuring for multiple object store support
You can configure Business Process Framework to support multiple object stores.

Business Process Framework 4.1 adds multiple object store support. A single
Business Process Framework application can use different object stores for its
attachments, audit logs and case object data. If an existing application uses this
feature, some changes to the previous 4.1 configuration are required.

Many of these changes are made to queries that could be customized in an existing
installation. Ensure that you retain your customizations when you apply these
updates.

Remember: There is no automated way to migrate existing data from one object
store to another. After you enable multiple object store support, all preexisting case
objects, audit logs, attachments, and so on are located in the same object store.

“Roles of object stores in a multiple object store configuration” on page 91
You can configure different object stores for a Business Process Framework
environment that uses multiple object stores.
“Configuring object stores for multiple object store support” on page 91
The Bootstrap Object Store setting, Default Object Store setting, Case Object
Store settings (one per case type), and Audit Log Object Store settings (one per
case type) in the Business Process Framework Metastore can all point to the
same object store, or each can point to a different object store, or some mixture
in between.
“Configuring additional case types to use multiple object stores” on page 93
The case object store and audit log object store are configured on the case type.
If you want to store case objects or audit log entries in multiple object stores,
you will have to define multiple case types, and configure each case type to
specify the desired Case Object Store and Audit Log Object Store.
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Roles of object stores in a multiple object store configuration
You can configure different object stores for a Business Process Framework
environment that uses multiple object stores.

You can prepare the following types of object stores:

Bootstrap object store
The bootstrap object store is used for resolving Workplace site preference,
Access Roles, Bp8Settings object for CaseId generation, and site preference.
The object store filling this role is configured as a System-Wide setting.

Default object store

The default object store is used to store Case Object, Audit logs, and
Attachment objects for any Case Type if there is no specific Object Store
mentioned under the Case Type configuration.

If the case type is not known, Business Process Framework looks for the
case first in the default object store. All cases created in previous releases
of Business Process Framework are assumed to reside in the default object
store. The object store filling this role is configured as a System-Wide
setting.

Case object store
The case object store is used to store the Bp8Case and Bp8Attachment
custom objects for Business Process Framework cases of a given case type.
Each Case Type configuration has a setting for the object store which will
fill this role for cases of that type.

Audit log object store
The audit log object store is used to store the audit log entries for Business
Process Framework cases of a given case type. Each Case Type
configuration has a setting for the object store which will fill this role for
cases of that type.

Configuring object stores for multiple object store support
The Bootstrap Object Store setting, Default Object Store setting, Case Object Store
settings (one per case type), and Audit Log Object Store settings (one per case
type) in the Business Process Framework Metastore can all point to the same object
store, or each can point to a different object store, or some mixture in between.

The Business Process Framework application installer will initially specify a single
Object Store to fill all of these roles throughout the Metastore. Any other object
store configuration must be configured manually after installation. In addition to
changing the setting in the Metastore, object stores must be prepared for use by
Business Process Framework.

The remainder of this section assumes that ce_ CaseType.xml is the Content Engine
data model for the case type, including the data model for:
v CaseType subclass under the Bp8Case class.
v CaseType Document subclass under the Document class.

“Preparing an object store to be the bootstrap object store” on page 92
You must manually prepare an object store to be the bootstrap object store.
“Preparing an object store to hold Business Process Framework case objects of a
given case type” on page 92
You must prepare an object store to hold Business Process Framework case
objects from selected case types.
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“Preparing an object store to hold Business Process Framework audit log entries
for cases of a given case type”
You can prepare an object store to hold Business Process Framework audit log
entries for selected case types.
“Preparing an object store to hold Business Process Framework documents tied
to cases of a given case type” on page 93
You can prepare an object store to hold Business Process Framework documents
that are tied to case of selected case types.
“Preparing an object store to hold Business Process Framework attachments” on
page 93
Attachments to Business Process Framework cases can reside in any object store
in the IBM FileNet P8 domain, without restriction. (This refers to the actual
attached document, folder or custom object.

Preparing an object store to be the bootstrap object store
You must manually prepare an object store to be the bootstrap object store.

The System-wide setting → Bootstrap Content Engine Object Store Name setting
specifies the display name of the Bootstrap Object Store. This object store contains
Workplace access roles, the CaseId generation object (Bp8Settings), Business
Process Framework stored searches and the Business Process Framework site
preferences.

To manually configure the bootstrap object store:
1. Identify the object store that has Workplace site preference stored.
2. In Enterprise Manager, import the file ce_base.xml to the object store.

Importing the file generates a Bp8Settings object called Settings in the
Operating system → Root Folder → Business Process Framework folder in the
object store.

If the Business Process Framework system is already running and you must import
the ce_base.xml file again to the bootstrap Object Store, do the following tasks:
v Record the last case ID. Right-click the Bp8Settings object and select Properties.

Click the Properties tab. Record the Bp8LastCaseID property value.
v Import the ce_base.xml file.
v Manually update Bp8LastCaseID property value to the recorded case ID.

Preparing an object store to hold Business Process Framework
case objects of a given case type
You must prepare an object store to hold Business Process Framework case objects
from selected case types.

To prepare an object store:
1. Import the file ce_base.xml into the Object Store, if this was not done

previously.
2. Import the data model from the file ce_CaseType.xml, including:

v The CaseType subclass under the Bp8Case class.
v The CaseType Documents subclass under the Document class.

Preparing an object store to hold Business Process Framework
audit log entries for cases of a given case type
You can prepare an object store to hold Business Process Framework audit log
entries for selected case types.
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To prepare an object store:
1. Import the file ce_base.xml into the Object Store if this was not done

previously.
2. Import the data model from the file ce_CaseType.xml, including:

v The CaseType subclass under the Bp8Case class.
v It is not necessary to create the CaseType Documents subclass under the

Document class.

Preparing an object store to hold Business Process Framework
documents tied to cases of a given case type
You can prepare an object store to hold Business Process Framework documents
that are tied to case of selected case types.

To prepare an object store:
1. Import the file ce_base.xml into the Object Store, if this was not done

previously.
2. Import the data model from the file ce_CaseType.xml, including:

v The CaseType subclass under the Bp8Case class.
v The CaseType Documents subclass under the Document class.

Preparing an object store to hold Business Process Framework
attachments
Attachments to Business Process Framework cases can reside in any object store in
the IBM FileNet P8 domain, without restriction. (This refers to the actual attached
document, folder or custom object.

Each such attachment is referenced by a Business Process Framework Attachment
object, which always resides in the same object store with the Business Process
Framework case object.)

Because no Business Process Framework data is stored with the attachment, no
special preparation of the object store is required.

Configuring additional case types to use multiple object
stores

The case object store and audit log object store are configured on the case type. If
you want to store case objects or audit log entries in multiple object stores, you
will have to define multiple case types, and configure each case type to specify the
desired Case Object Store and Audit Log Object Store.

When you define additional case types, also create a search template for the new
case type.

Legacy cases in a multiple object store environment
The original cases that were created in Business Process Framework 4.0 are stored
in the DefaultOS in Business Process Framework 4.1. Likewise, any cases that were
created in Business Process Framework 4.1 before you configure the system for
multiple object stores will have all their data stored in the DefaultOS. These cases
are referred to as legacy cases.

In general, legacy cases (cases created in previous releases of Business Process
Framework software) will function without issue in a multiple object store
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environment. There are consequences to changing case type settings to use a
different object store when you have existing legacy cases of that type.

“Impact on existing legacy cases when changing case object store”
When changing the Case Object Store on a case type configuration to a different
object store than the default, you are responsible for moving the existing legacy
cases to the new object store. If the cases are not moved, they will not be visible
to the Business Process Framework application, since Business Process
Framework will expect to find them in the new object store.
“Impact on existing legacy cases when changing audit log object store”
When you change the audit object store on a case type configuration to a
different object store than the default, you are responsible for moving the
existing audit log objects to the new object store. If the audit entries are not
moved, they will not be visible in the Business Process Framework Web
application, because Business Process Framework will expect to find them in
the new object store.
“Impact on existing legacy cases when changing document object store”
You can change the document object store to reference a different object store
without impacting the existing legacy cases.
“Example: impact on existing legacy cases when changing object store settings”
on page 95
This example describes the impact on existing legacy cases when you change
the Case Management case type object store setting.
“Multiple object store capabilities in workflows” on page 95
To make full use of the multiple object store support capabilities, you must use
a workflow that is enabled for multiple object store support.

Impact on existing legacy cases when changing case object
store

When changing the Case Object Store on a case type configuration to a different
object store than the default, you are responsible for moving the existing legacy
cases to the new object store. If the cases are not moved, they will not be visible to
the Business Process Framework application, since Business Process Framework
will expect to find them in the new object store.

If the cases are not moved, they will not be visible to the Business Process
Framework application, since Business Process Framework will expect to find them
in the new object store.

Impact on existing legacy cases when changing audit log
object store

When you change the audit object store on a case type configuration to a different
object store than the default, you are responsible for moving the existing audit log
objects to the new object store. If the audit entries are not moved, they will not be
visible in the Business Process Framework Web application, because Business
Process Framework will expect to find them in the new object store.

Impact on existing legacy cases when changing document
object store

You can change the document object store to reference a different object store
without impacting the existing legacy cases.
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Changing the document object store to reference a different object store does not
impact existing legacy cases.

For example, if you changed the Case Management case type setting to use
multiple object stores as follows:
v Case object store: Defaultobject store
v AuditLog object store: object store 2
v Document object store: object store 3

In this situation, you could:
v View and update legacy cases. However, the legacy audit logs might be missing

unless you moved them to object store 2.
v Attach a document from any object store to legacy cases. In this situation,

Business Process Framework saves the audit logs to object store 2.
v Create, view, and update new cases. In this situation, Business Process

Framework saves the cases to the Default Object Store and the audit logs to
object store 2.

v Attach a document from any object store to a case without restriction. Attached
documents, folders or custom objects can reside in any object store regardless of
settings on the case type.

Example: impact on existing legacy cases when changing
object store settings

This example describes the impact on existing legacy cases when you change the
Case Management case type object store setting.

For example, if you changed the Case Management case type setting to use
multiple object stores as follows:
v Case object store: Defaultobject store
v AuditLog object store: object store 2
v Document object store: object store 3

In this situation, you could:
v View and update legacy cases. However, the legacy audit logs might be missing

unless you moved them to object store 2.
v Attach a document from any object store to legacy cases. In this situation,

Business Process Framework saves the audit logs to object store 2.
v Create, view, and update new cases. In this situation, Business Process

Framework saves the cases to the Default Object Store and the audit logs to
object store 2.

v Attach a document from any object store to a case without restriction. Attached
documents, folders or custom objects can reside in any object store regardless of
settings on the case type.

Multiple object store capabilities in workflows
To make full use of the multiple object store support capabilities, you must use a
workflow that is enabled for multiple object store support.

The staging folder contains sample workflows for use with both single object store
and multiple object store configurations, for cases with and without eForms:
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Table 27. Multiple object support

Folder or file Description

misc/solutions/case management/config/ Case Management sample configuration

CaseManagement.pep

Sample workflow map for single operating system,
non-eForms

CaseManagementMOSS.pep

Sample workflow map for multiple operating system,
non-eForms

eFormsCaseManagement.pep

Sample workflow map for single operating system with
eForms

eFormsCaseManagementMOSS.pep

Sample workflow map for multiple operating system
with eForms

To switch workflows, check out the old workflow and check in the new one, then
transfer the workflow to the Process Engine. If you are using eForms, reconfigure
eForms integration to use the new version of workflow following the eForms
Integration Guide. If there is a Content Engine event subscription associated with
the workflow, remember to update it to use the new version of the workflow.

CaseManagementMoss.pep uses new Business Process Framework Operations
methods that are compatible with multiple object store support. You must modify
the object store names for the UpdateCase method.

“Differences between 4.0 and multiple object store support case management
sample workflows”
The 4.0 Case Management Sample Workflow cases save their artifacts in a
default object store that is specified in the workflow definition. Cases created
by using the new sample workflow enabled for Multiple Object Store Support
store their artifacts in the object stores specified in the case type definition.

Differences between 4.0 and multiple object store support case
management sample workflows
The 4.0 Case Management Sample Workflow cases save their artifacts in a default
object store that is specified in the workflow definition. Cases created by using the
new sample workflow enabled for Multiple Object Store Support store their
artifacts in the object stores specified in the case type definition.

If you launch the original 4.0 Case Management Sample Workflow to create a case,
then the case objects, audit logs and initiating object will all be saved to the default
object store specified in the workflow definition, replicating the single object store
behavior of Business Process Framework 4.0.

If you instead launch the new sample workflow that is enabled for Multiple Object
Store Support to create a case, then the case objects, audit logs and initiating object
will be saved to the corresponding object stores specified in the case type
definition in Business Process Framework Explorer.
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There is also a new sample workflow for use with eForms in a multiple object
store environment. The differences are basically the same as for the non-eForms
workflows.
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Manually editing installation settings

You can manually edit the configuration settings after the installation is complete.
This is useful if the error logs for your installation indicate a problem with the
automatic configuration. You can also choose to do some parts of the installation
manually.

“Integrating Business Process Framework with Workplace” on page 100
If a redeploy of the Workplace Web application overwrites settings specific to
Business Process Framework, you might have to manually recreate these
settings.
“Importing Content Engine base objects” on page 103
You can use Enterprise Manager to import base Content Engine objects.
“Importing Content Engine solution specific objects” on page 103
You can use Enterprise Manager to import solution specific objects.
“Creating base or solution specific workflow objects” on page 104
If certain base and solution specific workflow objects were not created during
the Business Process Framework automatic installation, you can create them by
editing XML files and importing them in the Process Configuration Console.
“Updating the process map” on page 105
Updating the process map is an automated process in the Business Process
Framework installation program. If an error occurs during this part of the
installation, you can manually update the process map using the Workplace
application.
“Configuring Business Process Framework operations” on page 105
You can manually configure the Business Process Framework operations by
editing Application Engine and Business Process Framework configuration files.
“Configuring user tokens” on page 109
User token configuration across Workplace and Business Process Framework
(and possibly other IBM FileNet P8 applications such as IBM InfoSphere™

Enterprise Records) allows those applications to share credentials. Allowing
applications to share credentials avoids the need for multiple login prompts
when the user moves between these applications
“Editing the Business Process Framework Web application web.xml file” on
page 110
Business Process Framework Installer updates Metastore data source name meta
datasource and Process data source name pe datasource in web.xml during
installation time.
“Loading the Business Process Framework Metastore” on page 110
You can choose to manually load data into the Business Process Framework
Metastore database.
“Importing the Metastore manifest” on page 112
You can use the Business Process Framework Explorer application to import the
Metastore manifest.
“Editing the Metastore settings” on page 113
You can edit the Metastore settings by using the Business Process Framework
Explorer application.
“Creating the JDBC data source for the Business Process Framework Metastore”
on page 115
The Business Process Framework Web application requires a connection to the
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data source for the Business Process Framework Metastore. You can create the
JDBC data source according to your Web application server and database type.
“Creating the JDBC data source for the Process Engine” on page 127
The Business Process Framework Web application requires a connection to the
data source for the Process Engine. You can create the JDBC data source
according to your Web application server and database type.
“Deploying the Business Process Framework Web application” on page 139
After you have installed and configured the Business Process Framework
server, you can manually deploy the Web application on the application server.
“Applying IBM FileNet P8 Platform changes to the Business Process
Framework installation” on page 144
You can apply IBM FileNet P8 Platform changes to the Business Process
Framework installation. Verify your installation and component versions.
“Updating the contents of the Business Process Framework WAR file” on page
146
Various procedures involve updating the contents of the Business Process
Framework WAR file in the installation location.
“Updating the contents of the Business Process Framework EAR file” on page
146
Various procedures involve updating the contents of the Business Process
Framework EAR file in the installation location.

Integrating Business Process Framework with Workplace
If a redeploy of the Workplace Web application overwrites settings specific to
Business Process Framework, you might have to manually recreate these settings.

“Editing Workplace settings”
This step applies to new installations or in cases where Workplace
redeployment overwrites Business Process Framework integration settings.
“Workplace integration” on page 101
In addition to creating settings in the Workplace application, you can also edit
settings in the configuration files that are part of the Workplace installation.

Editing Workplace settings
This step applies to new installations or in cases where Workplace redeployment
overwrites Business Process Framework integration settings.

It is possible to deploy Workplace again without overwriting the Business Process
Framework integration settings, avoiding the need to repeat the integration tasks
in this section. To avoid repeating the integration tasks, recreate the Workplace.war
and Workplace.ear files by running /opt/FileNet/AE/deploy/
create_app_engine_war.sh and /opt/Filenet/AE/deploy/
create_app_engine_ear.sh.
1. Under Workplace → Admin → Site Preferences → General, ensure that these

preferences are set:
v Enable custom objects: Yes

v Add as major version: Yes

v Check in as major version: Yes

2. Run Workplace Integration.
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Workplace integration
In addition to creating settings in the Workplace application, you can also edit
settings in the configuration files that are part of the Workplace installation.
v GUID (Example: 5309C5AF-6D24-4BDB-BB6C-71C61E7EFC53)

The object GUIDs shown later in this section are examples for referencing the
Case Management class from the Case Management Sample Configuration. You
have to add one or more Bp8 Case Object GUIDs representing classes in your
solution. These classes are Bp8 Case child classes. Use Enterprise Manager to
determine the GUIDS.

v URL (Example: http://p8demo30:7001/BPF/Bp8Main.jsp)
The URLs shown later in this section are examples and might have to be
changed. Consult the IBM FileNet P8 Platform documentation.

v Folder References: All the Workplace folder references are to the deployed
instance of Workplace (the instance used by the Web server).

v This procedure assumes that you have imported the following Content Engine
manifests (in previous steps):
– The base Business Process Framework manifest
– The Case Management manifest or some other custom manifest

v You have only imported the base Workplace manifest if Enterprise Manager
does not show any child classes under Bp8 → Case os display name → Other
Classes → Custom Object → Bp8 → Object → Bp8.

Editing infopages.xml

Do not use lowercase alpha hex digit characters for the id (GUID) parameters in
Actions.xml and InfoPages.xml. Due to a limitation in Workplace, specifying
92689f34-9f53-44ce-85ef-2d561e50d139 instead of 92689F34-9F53-44CE-85EF-
2D561E50D139, for example, as a GUID value in the InfoPages.xml and
Actions.xml files (for the Bp8Case custom object class) fails to work. Workplace
does not pick up the value. Use only uppercase alpha hex digit characters.

See the procedure introduction for background information. The items in italics are
not entered. They are shown in the example later in this section for context only.
Edit InfoPages.xml in AE_install_path/FileNet/Config/AE. Add this section:
<object key="objectInfoPages" version="3.0">
<list key="pages">
<object key="infoPage">
<array key="objectTypes">
<value>customobject</value>
</array>
<array key="classes">
<value>{92689F34-9F53-44CE-85EF-2D561E50D139}</value>
</array>
<setting key="url">http://web app server:web port/web BPF name

/Bp8IntegrationServlet?_commandId=9000</setting>
<setting key="isPopup">true</setting>
<setting key="popupHeight">550</setting>
<setting key="popupWidth">650</setting>
<setting key="useToken">true</setting>
</object>
</list>
</object>

Remember: The object key="infoPage" subsection can go at the end of the <list
key="pages"> section. Search for </list>.
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Editing actions.xml

Do not use lowercase alpha hex digit characters for the ID (GUID) parameters in
Actions.xml and InfoPages.xml.

Due to a limitation in Workplace, specifying 92689f34-9f53-44ce-85ef-2d561e50d139
instead of 92689F34-9F53-44CE-85EF-2D561E50D139, for example, as a GUID value
in the InfoPages.xml and Actions.xml files (for the Bp8Case custom object class)
fails to work. Workplace does not pick up the value. Use only uppercase alpha hex
digit characters.

See the procedure introduction for background information. The items in italics are
not entered. They are shown in the example later in this section for context only.
Edit Actions.xml in AE_install_path/FileNet/Config/AE. Add the following
sections.

Add the following section to the <array key=″topLevelActions″> section:
<!-- top levelactions -->
<array key="topLevelActions">
<value>openCase</value>
</array>

Add the following section to the <list key=″actionDefinitions″> section:
<list key="actionDefinitions">
<object key="actionDefinition">
<setting key="id">openCase</setting>
<setting key="title" localizationKey="server.Actions_xml.openInCaseQuery">Open Case

</setting>
<setting key="url">http://web app server:web port

/web BPF name/Bp8IntegrationServlet?_commandId=9000&amp;id=
{OBJECT_ID}&amp;objectType={OBJECT_TYPE}</setting>

<setting key="img">images/action/Launch16.gif</setting>
<setting key="hiddenForGuests">true</setting>
<array key="objectTypes">
<value>customobject</value></array>
<array key="classes">
<value>{92689F34-9F53-44CE-85EF-2D561E50D139}</value>
</array>
<setting key="isPopup">true</setting>
<setting key="useToken">true</setting>
<setting key="popupHeight">550</setting>
<setting key="popupWidth">650</setting>
</object>
</list>

v The items earlier in this section in braces (such as OBJECT_TYPE) are to be left
alone in the XML. Do not substitute actual values.

v If Business Process Framework is deployed on a Web farm or in a load
balancing environment, Web app server must point to the name or address of the
load balancer.

Editing integration.xml

See the procedure introduction for background information. The items in italics are
not entered; they are shown in the example later in this section for context only.
Edit Integration.xml in Workplace...\WEB-INF. Add the following section:
<object key = "propertyPageConfiguration" version = "3.0">
<list key = "commands">
<object key = "command">
<setting key = "id">4030</setting>
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<setting key = "url">Bp8ViewActions.jsp</setting>
<setting key = "description">View by external request</setting>
</object>
<object key = "command">
<setting key = "id">4040</setting>
<setting key = "url">operations/WcmCheckoutObject.jsp</setting>
<setting key = "description">Check Out Document</setting>
</object>
<object key = "command">
<setting key = "id">4050</setting>
<setting key = "url">operations/WcmCancelCheckout.jsp</setting>
<setting key = "description">Cancel Checkout From CheckoutList</setting>
</object>
<object key = "command">
<setting key = "id">4060</setting>
<setting key = "url">wizards/WcmCheckinDocument.jsp</setting>
<setting key = "description">Quick Check In Document</setting>
</object>
</list>
</object>

Copying files

Copy this file to the main folder of the deployed Workplace instance (the parent
folder of WEB-INF): Bp8 ViewActions.jsp. This file can be found in the staging
folder/misc/components/Workplace folder.

Tip: For more information about Workplace integration, see BPF Advanced
Configuration → BPF Integration Servlet in the Business Process Framework Help
documentation.

Reloading XML files

To reload the XML files in Workplace:
1. Click Admin → Site Preferences → Refresh.
2. Click Reload configuration files.

Tip: See the IBM FileNet P8 Platform documentation for further details on
modifying the Actions.xml and InfoPages.xml files.

Importing Content Engine base objects
You can use Enterprise Manager to import base Content Engine objects.

If any error occurs during the import of the base Content Engine objects, the
installation program shows an error message at the end of installation.

In such a condition use Enterprise Manager to import it manually.

See the IBM FileNet P8 Platform documentation for the import procedure details.
v Base Business Process Framework Objects: staging folder/misc/base/config/

ce_base.xml

Importing Content Engine solution specific objects
You can use Enterprise Manager to import solution specific objects.
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If any error occurs during the import of the solution specific Content Engine
objects, the installation program shows an error message at the end of installation.

If this occurs, you can use Enterprise Manager to import the solution specific
objects manually.
v Case Management Sample Configuration: staging folder/misc/solutions/

case_management/config/ce_cm.xml

See the IBM FileNet P8 Platform documentation for the import procedure details.

Creating base or solution specific workflow objects
If certain base and solution specific workflow objects were not created during the
Business Process Framework automatic installation, you can create them by editing
XML files and importing them in the Process Configuration Console.

To create base or solution-specific workflow objects manually, set the following
parameter values in Workplace:
1. Point your browser to: http://web application server:port/Workplace

Tip: Consult your Web application service for the correct port number.
2. From the Workplace menu, select Author → Advanced Tools → Process

Configuration Console.
3. Locate the connection point that is configured with the isolated region where

you want your base or solution-specific objects to be created. Right click the
connection point and click Import from XML file. navigate to base or solution
specific object creation XML file.

4. Browse to the base or solution specific object creation XML file. The XML files
are located in staging folder/misc/wfutil/

v For base workflow objects, use qcreate_base.xml.
v For solution-specific workflow objects, use qcreate_cm.xml.

Important:

v Do NOT modify the qcreate_base.xml file in the staging
folder/misc/base/config folder or the qcreate_cm.xml file in the staging
folder/misc/solutions/case_management/config folder. The files in those
folders are used by the Business Process Framework installer only.

v Choose, but do NOT modify the qcreate_base.xml and qcreate_cm.xml files
in the staging folder/misc/wfutil/. Use the files in those folders for
manual import through Process Configuration Console. They have the same
names but different content from the files in the config folders.

5. Click Yes on the Caution screen. The import progress and success status are
displayed.
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Related concepts

“Environment conditions that require additional manual configuration after
installation” on page 25
The Business Process Framework installation program automatically configures the
P8 Platform environment to work with Business Process Framework. However,
some component versions require additional manual configuration after the
installation is complete.

Updating the process map
Updating the process map is an automated process in the Business Process
Framework installation program. If an error occurs during this part of the
installation, you can manually update the process map using the Workplace
application.

Determine which process map to use:
v Custom Process Map: You have your own process map.
v Case Management Sample Configuration: You are using the Case Management

Sample process map, located at staging folder\misc\solutions\
case_management\config\CaseManagement.pep

To update the process map:
1. Start your Web browser and log in to Workplace.
2. Select Author → Advanced Tools → Process Designer from the Workplace menu.
3. Select File → Open... and navigate to the pep file.
4. If you are using the Case Management Sample process map, the object store

names must be updated from the default value Bp8ObjectStore to the name of
your actual object store in these three operations: Create Case, Attach
Document and Update Case.

5. Click File → Validate. (Verify that there are no errors.)
6. Select File → Transfer. (Save the workflow to a wanted folder location such as

ObjectStore → BPF → Workflow folder. (Verify that the transfer is successful.)
7. Select File → Exit. (Check in the workflow.)
Related concepts

“Environment conditions that require additional manual configuration after
installation” on page 25
The Business Process Framework installation program automatically configures the
P8 Platform environment to work with Business Process Framework. However,
some component versions require additional manual configuration after the
installation is complete.

Configuring Business Process Framework operations
You can manually configure the Business Process Framework operations by editing
Application Engine and Business Process Framework configuration files.

“Editing the taskman policy” on page 106
The taskman.policy configuration file contains a privilege setting for the
bp8ciops.jar file.
“Editing the taskman.properties file” on page 106
You can edit the taskman.properties located in the Router folder in the
Application Engine installation folder.
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“Adding taskman libraries (vwtaskman.xml)”
The Task Manager uses a set of libraries that must be added to vwtaskman.xml
during Business Process Framework installation.
“Editing taskman login configuration” on page 108
You can edit the taskman.login.config file to match your environment settings.
“Editing Business Process Framework operations component queue” on page
108
You can use the Process Configuration Console to edit the operations
component queue.

Editing the taskman policy
The taskman.policy configuration file contains a privilege setting for the
bp8ciops.jar file.

To edit the taskman policy:
1. Edit taskman.policy. (By default, it is found in the Router folder in the

Application Engine installation folder.)
2. If bp8ciops.jar file is not listed, create a new section to grant the required

privileges.
Example:

grant codeBase "file: {install.home} /bpfops/bp8ciops.jar "
{

permission java.security.AllPermission;
};

3. Save and close taskman.policy.

Editing the taskman.properties file
You can edit the taskman.properties located in the Router folder in the
Application Engine installation folder.

To edit the taskman.properties file:
1. Edit taskman.properties. (By default, it is found in the Router folder in the

Application Engine installation folder.)
2. Add path for install.home/bpfops/bp8ciops.jar to

TaskManager.ComponentManager.ClassPath.

Adding taskman libraries (vwtaskman.xml)
The Task Manager uses a set of libraries that must be added to vwtaskman.xml
during Business Process Framework installation.

The Task Manager uses the following libraries:

Table 28. Task Manager libraries

Expected path Library short name

install.home/bpfops/bp8ciops.jar bp8ciops.jar

install.home/bpfops/lib/oracleJDBCDriver_stub.jar oracleJDBCDriver_stub.jar

install.home/bpfops/lib/sqlJDBCDriver_stub.jar sqlJDBCDriver_stub.jar

install.home/bpfops/lib/db2JDBCDriver_stub.jar db2JDBCDriver_stub.jar
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The JDBC Data Source configuration and roster configuration file, bp8_config.xml,
is distributed in the install.home/bpfops/bp8ciops.jarfile. Extract bp8_config.xml
from the bp8ciops.jar package by using WinZip or another tool.

Set the following XML elements as indicated:
v User: meta user

v Password: meta password

v Database: meta database

v Server: metadata server

Put the updated bp8_config.xml file into the bp8ciops.jar package.

Tip:

v You might have to uncomment the JDBC section for your database.
v XML parser errors can occur when BPF_Operations is used with Oracle if the

JDBC node for MSSQL is commented out. You must delete the node for MSSQL
from the bp8_config.xml file to prevent such errors.

To add taskman libraries:

Option Description

DB2 Add the required files to the vwtaskman.xml
file as follows:

1. Start the Application Engine Process Task
Manager (using routercmd).

2. Stop the Component Manager (in the
Application Engine).

3. Go to the Required Libraries tab.

4. Add the following files from the
/opt/FileNet/BPF/bpfops/lib folder:

v db2jcc.jar

v db2jcc_license_cu.jar

v oracleJDBCDriver_stub.jar

v sqlJDBCDriver_stub.jar

5. Add the bp8ciops.jar file from the
/opt/FileNet/BPF folder.

Microsoft SQL Server Add the required files to the vwtaskman.xml
file as follows:

1. Set the DBType to MSSQL.

2. Start the Application Engine Process Task
Manager (by using routercmd ).

3. Stop the Component Manager (in the
Application Engine).

4. Go to the Required Libraries tab.

5. Add the following files from the
/opt/FileNet/BPF/bpfops/lib folder:

v jtds-1.x.y.jar

v db2JDBCDriver_stub.jar

v oracleJDBCDriver_stub.jar

6. Add the bp8ciops.jar file from the
/opt/FileNet/BPF folder.
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Option Description

Oracle Add the required files to the vwtaskman.xml
file as follows:

1. Set the DBType to Oracle.

2. Start the Application Engine Process Task
Manager (by using routercmd).

3. Stop the Component Manager in the
Application Engine.

4. Go to the Required Libraries tab.

5. Add the following files from the
/opt/FileNet/BPF/bpfops/lib folder:

v db2JDBCDriver_stub.jar

v ojdbc14.jar

v db2JDBCDriver_stub.jar

v sqlJDBCDriver_stub.jar

6. Add the bp8ciops.jar file from the
/opt/FileNet/BPF folder.

Editing taskman login configuration
You can edit the taskman.login.config file to match your environment settings.

To edit taskman login configuration:
1. Open taskman.login.config for editing.

By default, taskman.login.config is in the Router subdirectory in the
Application Engine installation directory.

2. Edit the routername setting under CELogin, if necessary to match your
environment settings.

Tip: Do not use localhost as a system name.
For example:
CELogin
{

filenet.vw.server.VWLoginModule required
routerurl="{pe connection point name}";

com.filenet.wcm.toolkit.server.operations.util.CELoginModule
required credTag=Clear;

};

3. Save and close taskman.login.config file.

Editing Business Process Framework operations component
queue

You can use the Process Configuration Console to edit the operations component
queue.

To edit Business Process Framework operations component queue:
1. Navigate to P8 Workplace → Admin → Process Configuration Console,

right-click the connection point icon for your Isolated Region, and choose
Connect.

2. Open the Server node for your Process Engine Server, right-click the
Component Queues node, and select Register Additional Classes.

3. On the Jar File Locations tab of the Component Registration dialog:
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a. Navigate to and add the JAR files used by BPF_Operations for your meta
database type as follows:

DB2

Add db2 drivers and Oracle stub and Microsoft SQL Server stub:
v db2jcc.jar

v db2jcc_license_cu.jar

v oracleJDBCDriver_stub.jar

v sqlJDBCDriver_stub.jar

Oracle

Add Oracle drivers and DB2 stub and Microsoft SQL Server stub:
v ojdbc14.jar

v sqlJDBCDriver_stub.jar

v db2JDBCDriver_stub.jar

Microsoft SQL Server

Add Microsoft SQL Server drivers and DB2 stub and Oracle stub:
v jtds-1.x.y.jar

v oracleJDBCDriver_stub.jar

v db2JDBCDriver_stub.jar

b. Click OK.
4. Right-click the BPF_Operations component queue node and select Properties.

Make sure to select the correct Java class: ″/com/filenet/Operations/
Bp8Operations.class″.

5. On the Adaptor tab of the property page dialog box, ensure that Java
Component is selected in the Adaptor drop-down, and then click Configure.
Ignore any error regarding introspection class.

6. Navigate to and select the bp8ciops.jar file that BPF_Operations is using.
Make sure to select the correct Java class /com/filenet/Operations/
Bp8Operations.class.

7. Click OK.
8. To configure an exposed operation, navigate to the Operations tab, make the

wanted changes, and then click OK. Configuring an exposed operation is only
necessary to expose your own custom methods as operations. If the normal
installation of Business Process Framework operations fails, the fix is to
manually import qcreate_base.xml or qcreate_cm.xml as explained in section
“Creating base or solution specific workflow objects” on page 104.

9. Right-click your Connection Point node and select Commit Changes to
commit your changes to isolated region.

10. Start Process Task Manager → Component Manager → BPF_Operations.

Configuring user tokens
User token configuration across Workplace and Business Process Framework (and
possibly other IBM FileNet P8 applications such as IBM InfoSphere Enterprise
Records) allows those applications to share credentials. Allowing applications to
share credentials avoids the need for multiple login prompts when the user moves
between these applications

Manually editing installation settings 109



For detailed information about how to configure user tokens, please see the IBM
FileNet P8 Platform documentation: IBM FileNet P8 Documentation → Developer
Help → Workplace Integration and Customization → User Tokens → Configuring
Applications to Use Tokens.

Editing the Business Process Framework Web application web.xml file
Business Process Framework Installer updates Metastore data source name meta
datasource and Process data source name pe datasource in web.xml during installation
time.

These web.xml settings were added during the manual configuration process after
installation. Business Process Framework installer does not perform data source
name validation. In case any of these data source names have been entered wrong
during installation, you might want to edit web.xml file to correct these entries.
These entries can be manually edited in web.xml by browsing install.home/web/
web application name/WEB-INF location.

WAR or EAR installation requires extracting contents in temporary folder and
bundling it again after making correction in web.xml .

Modify bold italic text to correct data source names:
v init-param

v param-name MetaStoreDSName/param-name

v param-value Bp8MetadataDS/param-value

v /init-param

v init-param

v param-name ProcessStoreDSName/param-name

v param-value Bp8ProcessDS/param-value

v /init-param

Loading the Business Process Framework Metastore
You can choose to manually load data into the Business Process Framework
Metastore database.

“Loading the Business Process Framework Metastore data on DB2” on page 111
You can use the Command Editor to load the Business Process Framework
Metastore data on DB2®.
“Loading the Business Process Framework Metastore data on Microsoft SQL
Server” on page 111
You can use the Query Analyzer to load the Business Process Framework
Metastore on Microsoft SQL Server.
“Loading the Business Process Framework Metastore data on Oracle” on page
112
You can use the SQL scripts to load the Business Process Framework Metastore
on Oracle.
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Related concepts

“Environment conditions that require additional manual configuration after
installation” on page 25
The Business Process Framework installation program automatically configures the
P8 Platform environment to work with Business Process Framework. However,
some component versions require additional manual configuration after the
installation is complete.

Loading the Business Process Framework Metastore data on
DB2

You can use the Command Editor to load the Business Process Framework
Metastore data on DB2.
1. Open the Command Editor.

Option Description

Windows Start menu → Programs → DB2 → Command
Line Tools → Command Editor

UNIX

2. Change the Statement Termination Character to @. You can change this
character at the bottom of the Command Editor Window.

3. Click Add button and select the database.
4. Clear User implicit credentials and enter meta user and meta password and

click Ok. Now you have logged on to meta user with meta password.
5. Perform this step only if you are doing a new install. Do not run the

Step1.Microsoft SQL Server script if you are performing an upgrade. Open
Step1.DB2.Bp8.Metabase.1.0.sql in Command Editor: Selected → Open , then
start the script: Selected → Execute .
This step loads all necessary data. The following errors are benign and can be
ignored if seen:
v SQL0100W No row was found for FETCH, UPDATE, or DELETE; or the

result of a query is an empty table. SQLSTATE=02000
v SQL0204N IDENTIFIER is an undefined name. SQLSTATE=42704 SQL0458N

In a reference to routine IDENTIFIER by signature, a matching routine could
not be found. SQLSTATE=42883 IDENTIFIER here is a placeholder for the
names of various stored procedures.

6. Open Step1.DB2.Bp8.Metabase.1.0.sql in Command Editor: Selected → Open .
7. Run the script: Selected → Execute

Loading the Business Process Framework Metastore data on
Microsoft SQL Server

You can use the Query Analyzer to load the Business Process Framework
Metastore on Microsoft SQL Server.
1. Start the Microsoft SQL Server Query Analyzer:

a. Click Start menu → Programs → Microsoft SQL Server → Query Analyzer.
a. Log on by using the meta admin user.
b. Select the meta database if not already selected (in combination box on

toolbar).
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c. Perform this step only if you are doing a new installation. Do not run the
Step1 SQL Server script if you are performing an upgrade. Select File ... →
Open → staging folder\SQL\SQL\Step1.mssql.Bp8.Metabase.1.0.SQL.
Select Query ... → Execute.

d. Run the Step2 and Step3 scripts.
1) Select File ... → Open ... → staging folder\SQL\SQL\

Step2.mssql.Bp8.Metabase.1.0.SQL

2) Select Query ... → Execute.
2. Assign a password.

The scripts create user Bp8 with a Bp8 password. Record this name on your
worksheet as meta user and meta password.
You can assign a new password in this manner:
a. Open Enterprise Manager: Start menu → Programs → Microsoft SQL Server

→ SQL Server Enterprise Manager.
b. Right-click SQL Server Group → Security → Logins → bp8.
c. Select Properties.
d. Determine the meta password and record on your worksheet.
e. Enter password: meta password.
f. Click Ok and confirm the new password.

Loading the Business Process Framework Metastore data on
Oracle

You can use the SQL scripts to load the Business Process Framework Metastore on
Oracle.
1. Connect as meta user.
2. Run these scripts:

Important: Run this set of scripts only if you are doing a new installation. Do
not run the Step1 SQL Server script if you are performing an upgrade.
v staging folder\SQL\Oracle\Step1.oracle.Bp8.Metabase.1.0.SQL

v staging folder\SQL\Oracle\Step2.oracle.Bp8.Metabase.1.0.SQL

v staging folder\SQL\Oracle\Step3.oracle.Bp8.Metabase.1.0.SQL

Importing the Metastore manifest
You can use the Business Process Framework Explorer application to import the
Metastore manifest.

To import the Metastore manifest:
1. Determine which manifest to use:

Option Description

Base staging folder\misc\base\config\
bpf_base_[dbtype].xml

Case management sample configuration Use staging folder\misc\solutions\
case_management\config\
bpf_cm_[dbtype].xml

Custom Use your own custom manifest XML file.

2. Log in to Business Process Framework Explorer.
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3. Select Export and Import Management.
4. Right-click for pop up menu: All Tasks → Import XML Manifest.
5. Click Yes: Confirm loss of current configuration.
6. Select your manifest.
7. Click No: User information is not to be preserved.
8. If you are importing a manifest from a Business Process Framework system

where the Workflow user ID values in Process Engine are different from the
values in the environment where the Business Process Framework system was
created, you can update the WF_USER_ID column in the USERS table in the
Metastore by setting all rows to NULL. In this way, Business Process
Framework automatically interrogates Process Engine for the correct values for
these users in your environment. Otherwise, Business Process Framework
assumes that existing values are correct, causing problems in the Web
Application whereby a user who has opened a Case receives warnings that the
Case is locked by another user even though the Case is not locked at all. To
reset the WF_USER_ID column, run the following SQL Server statement against
the Metastore:
update users set wf_user_id=null

If you are importing a manifest that was created in the same environment (a
backup, for example), then you can skip this step, as the Workflow user ID
values in Process Engine are still be the same.

Editing the Metastore settings
You can edit the Metastore settings by using the Business Process Framework
Explorer application.

To edit the Metastore settings:
1. Start the application by selecting Start Menu → Programs → Business Process

Framework → BPF Explorer.
2. Log in by using meta user and meta password.
3. Edit the following settings:

Table 29. Metastore settings and values

Setting Value

Application Settings → System-wide Settings → Process
EngineConnection Point

pe connection point
Tip: The connection point is case sensitive.

Application Settings → System-wide Settings → Bootstrap
Content Engine Object Store Name

bootstrap os display name

This is the display name of the bootstrap object store.

The bootstrap object store stores Workplace access roles
and Case ID generation object (Bp8Settings), as well as
Business Process Framework site preferences and stored
searches.

You must enter the exact spelling of the display name of
the object store as defined in Enterprise Manager.
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Table 29. Metastore settings and values (continued)

Setting Value

Application Settings → System-wide Settings → Default
Content Engine Object Store Name

default os symbolic name

This is the symbolic name of the default object store.

This object store is used by default when no alternate
entry exists in the case type map.

You must enter the exact spelling of the symbolic name of
the object store as defined in Enterprise Manager.

Application Settings → Web Application → Workplace
Integration Servlet URL

workplace url

Language references: *| http://p8demo30:7001/
Workplace/

This example indicates that the URL:
http://p8demo30:7001/Workplace/ is to be used for all
languages. Different URLs might be specified for
particular languages; for example: en-us|http://
p8demo30:7001/WorkplaceEn/

The language designations are the industry-standard
designations used in Web browsers.

Workflow Configuration → Queues Change the object names for queues listed in this section
to correspond to the isolated region in use (as determined
by the Process Engine Connection Point specified in the
Application Settings → System-wide Settings →
Processing Engine Connection Point.

For example, if 26 is the isolated region, the object name
for the Case Management queue is pe runtime
user.VWVQ26_CaseManagement.

Also, if the value of pe runtime user is different from f_sw,
change the alias prefix of the object name of each queue
in Workflow Configuration → Queues to match the actual
value.

For example, if the user alias is dbo, the object name for
the Case Management queue is
dbo.VWVQ1_CaseManagement.

Change or view the queue object name by right clicking
the queue in question and selecting Properties.

Workflow Configuration → Queue Filters (for Process
Engine implementations by using SQL Server only)

Verify that the NOLOCK option is used in all queue filter
SQL queries.

For example: SELECT COUNT(UserID) FROM Users
WITH (NOLOCK) WHERE user name LIKE ’smith’

This option is necessary to reduce or eliminate deadlock
contention.

Change or view a queue filter SQL query by right
clicking the queue filter in question and selecting
Properties.
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Table 29. Metastore settings and values (continued)

Setting Value

Workflow Configuration → Queue Filters (for Process
Engine implementations by using Oracle and DB2.

Verify that the NOLOCK option is not used in all queue
filter SQL queries. This syntax is not valid for Oracle.

Change or view a queue filter SQL query by right
clicking the queue filter in question and selecting
Properties.

Miscellaneous → Inbasket Filters → Company Name (for
Oracle and DB2 implementations by using the Case
Management Sample Application manifest only)

Change the Company Name regular template to be:
UPPER(CompanyName) LIKE UPPER(’%PARAM1%’)

Change or view the Company Name regular template by
right-clicking Company Name, selecting Properties, and
clicking Expression within the Regular area.

Miscellaneous → Inbasket Filters → Account Number (for
Oracle and DB2 implementations by using the Case
Management Sample Application manifest only)

Change the Account Number regular template to be:
UPPER(AccountNumber) LIKE UPPER(’%PARAM1%’)

Change or view the Account Number regular template by
right-clicking Account Number, selecting Properties, and
clicking Expression within the Regular area.

Creating the JDBC data source for the Business Process Framework
Metastore

The Business Process Framework Web application requires a connection to the data
source for the Business Process Framework Metastore. You can create the JDBC
data source according to your Web application server and database type.

The XA driver type is not supported.
“Creating the Metastore data source on WebSphere Application Server for DB2”
on page 116
You can manually configure the JDBC data source connection for the Metastore
on WebSphere Application Server for DB2.
“Creating the Metastore data source on WebSphere Application Server for
Oracle” on page 118
You can manually configure the JDBC data source connection for the Metastore
on WebSphere Application Server for Oracle.
“Creating the Metastore data source on WebSphere Application Server for
Microsoft SQL Server” on page 119
You can manually configure the JDBC data source connection for the Metastore
on WebSphere Application Server for Microsoft SQL Server.
“Creating the Metastore data source on Oracle WebLogic Server 8.1.x for DB2”
on page 121
Before you configure the JDBC data source connection for the Metastore on
Oracle WebLogic Server 8.1.x for DB2, you must first create a JDBC connection
pool.
“Creating the Metastore data source on Oracle WebLogic Server 9.2.x or 10 for
DB2” on page 122
You can manually configure the JDBC data source connection for the Metastore
on Oracle WebLogic Server 9.2.x or 10 for DB2.
“Creating the Metastore data source on Oracle WebLogic Server 8.1.x for
Oracle” on page 122
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Before you configure the JDBC data source connection for the Metastore on
Oracle WebLogic Server 8.1.x for Oracle, you must first create a JDBC
connection pool.
“Creating the Metastore data source on Oracle WebLogic Server 9.2.x or 10 for
Oracle” on page 123
You can manually configure the JDBC data source connection for the Metastore
on Oracle WebLogic Server 9.2.x or 10 for Oracle.
“Creating the Metastore data source on Oracle WebLogic Server 8.1.x for
Microsoft SQL Server” on page 124
Before you configure the JDBC data source connection for the Metastore on
Oracle WebLogic Server 8.1.x for Microsoft SQL Server, you must first create a
JDBC connection pool.
“Creating the Metastore data source on Oracle WebLogic Server 9.2.x or 10 for
Microsoft SQL Server” on page 125
You can manually configure the JDBC data source connection for the Metastore
on Oracle WebLogic Server 9.2.x or 10 for Microsoft SQL Server.
“Creating the Metastore data source on JBoss Application Server for DB2” on
page 126
You can manually configure the JDBC data source connection for the Metastore
on JBoss Application Server for DB2.
“Creating the Metastore data source on JBoss Application Server for Oracle” on
page 126
You can manually configure the JDBC data source connection for the Metastore
on JBoss Application Server for Oracle.
“Creating the Metastore data source on JBoss Application Server for Microsoft
SQL Server” on page 127
You can manually configure the JDBC data source connection for the Metastore
on JBoss Application Server for Microsoft SQL Server.

Creating the Metastore data source on WebSphere Application
Server for DB2

You can manually configure the JDBC data source connection for the Metastore on
WebSphere Application Server for DB2.
1. Log on to WebSphere Application Server Administrative Console: http://web

application server}:9060/ibm/console
2. To create the JDBC Provider:

a. Click Resources → JDBC Providers.
Skip this sub step if pe connection pool exists. Otherwise, do the following:

b. Click New.
c. Select the database type: DB2

d. Select the provider type: DB2 Universal JDBC Driver Provider

e. Select the implementation type: Connection pool DataSource

f. Click Next.
g. Click Apply.
h. Save changes to master configuration.

3. To create the Initial JDBC Data Source:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider.
c. Click DataSources under Additional Properties.
d. Click New.
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e. Enter the Name for the Data Source. Record this name on your worksheet
as meta datasource.

f. Enter JNDI name: meta datasource.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Enter Description: meta datasource

h. Enter Database name: meta database

i. Enter Server name: meta data server

j. Click Apply.
k. Save changes to master configuration.

4. To create the Authentication Entry:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Click J2EE Connector Architecture (J2C) authentication data entries under

Related Items.
f. Click New.
g. Enter Alias name meta authentication name. Suggested name:

Bp8MetatdataAlias
h. Enter user ID: meta user

i. Enter Password: meta password

j. Click Apply.
k. Save changes to master configuration.

5. To set the JDBC Data Source Authentication:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Select Component-managed authentication alias: meta authentication name

f. Click Apply.
g. Save changes to master configuration.

6. To set the JDBC Data Source Additional Properties:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Select Custom properties under Additional Properties.
f. Add property Name: resultSetHoldability Value: 1 Type: java.lang.Integer

g. Add property Name: webSphereDefaultIsolationLevel Value: 2 Type:
java.lang.Integer

h. Save changes to master configuration.
7. To test the connection:

a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider
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c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Click Test Connection.

A success message is displayed.

Creating the Metastore data source on WebSphere Application
Server for Oracle

You can manually configure the JDBC data source connection for the Metastore on
WebSphere Application Server for Oracle.
1. Log on to WebSphere Application Server Administrative Console: http://web

application server:9060/ibm/console
2. To create the JDBC Provider:

a. Record Oracle JDBC Driver as meta connection pool on worksheet.
b. Click Resources → JDBC Providers.
Skip these sub steps if meta connection pool exists. Otherwise, do this procedure:
a. Click New.
b. Select the database type: Oracle

c. Select the provider type: Oracle JDBC Driver

d. Select the implementation type: Connection pool Data Source

e. Click Next.
f. Enter meta connection pool in the Name field.
g. Keep the default class path value of

oracle.jdbc.pool.OracleConnectionPoolDataSource. Record it as the meta class
path on the worksheet.

h. Click Apply.
i. Save changes to master configuration.
j. Click Environment → WebSphere Variables.
k. Verify that any environment variables that are used in meta class path is set

correctly.
3. To create the Initial JDBC Data Source:

a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool.
c. Click DataSources under Additional Properties.
d. Click New.
e. Enter the Name for the Data Source. Record this name on your worksheet

as meta datasource.
f. Enter JNDI name: meta datasource.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Enter Description: meta datasource

h. Enter URL: jdbc:oracle:thin:@{meta data server}:1521:meta database
sid

Tip: If URL does not work for any reason try: jdbc:oracle:thin@TNS
Descriptor
For example:
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jdbc:oracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)
(HOST=p8demo35)(PORT=1521)))(CONNECT_DATA=(SERVER=DEDICATED)
(SERVICE_NAME=Bp8.Metastore)))

i. Click Apply.
j. Save changes to master configuration.

4. To create the Authentication Entry:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool

c. Click DataSources under Additional Properties.

Tip: Do not select Data Sources (Version 4).
d. Click meta datasource.
e. Click J2EE Connector Architecture (J2C) authentication data entries under

Related Items.
f. Click New.
g. Enter Alias name. Enter on your worksheet as meta authentication name.
h. Enter user ID: meta user

i. Enter Password: meta password

j. Click Apply.
k. Save changes to master configuration.

5. To set the JDBC Data Source Authentication:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Select Component-managed authentication alias: meta authentication name

f. Click Apply.
g. Save changes to master configuration.

6. To test the connection:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Click Test Connection.

A success message is displayed.

Creating the Metastore data source on WebSphere Application
Server for Microsoft SQL Server

You can manually configure the JDBC data source connection for the Metastore on
WebSphere Application Server for Microsoft SQL Server.
1. Log on to the WebSphere Application Server Administrative Console:

http://web application server:9060/ibm/console
2. To create the JDBC Provider:

a. Click Resources → JDBC Providers.
Skip these sub steps if meta connection pool exists. Otherwise, do these steps:
a. Click New.
b. Select the database type: SQL Server
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c. Select the provider type: WebSphere embedded ConnectJDBC driver for
MS SQL Server

d. Select the implementation type: Connection pool data source.
e. Click Next.
f. Click Apply.
g. Save changes to master configuration.

3. To create the Initial JDBC Data Source:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool.
c. Click DataSources under Additional Properties. Do not select Data Sources

(Version 4).
d. Click New.
e. Enter the name for the Data Source. Suggested name: Bp8MetadataDS.
f. Enter JNDI name: meta datasource

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Enter Description: meta datasource

h. Enter Database name: meta database

i. Enter Server name: meta data server

j. Click Apply.
k. Save changes to master configuration.

4. To create the Authentication Entry:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Click J2EE Connector Architecture (J2C) authentication data entries under

Related Items.
f. Click New.
g. Enter Alias name. meta authentication name

h. Enter user ID: meta user

i. Enter Password: meta password.
j. Click Apply.
k. Save changes to master configuration.

5. To set the JDBC Data Source Authentication:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Select Component-managed authentication alias: meta authentication name

f. Click Apply.
g. Save changes to master configuration.

6. To test the connection:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: meta connection pool
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c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Click Test Connection.

A success message is displayed.

Creating the Metastore data source on Oracle WebLogic
Server 8.1.x for DB2

Before you configure the JDBC data source connection for the Metastore on Oracle
WebLogic Server 8.1.x for DB2, you must first create a JDBC connection pool.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To configure a connection pool, select Services → JDBC → Connection pools.

a. Click Configure a new JDBC Connection Pool.....
b. Select Database Type: DB2.
c. Select Database Driver: DB2 Driver (Type 4) Versions: 7.x, 8.x

d. Click Continue.
e. Determine the meta connection pool name and record on your worksheet.

Suggested name: Bp8MetadataPool
f. Select Name: meta connection pool

g. Enter Database name: meta database

h. Enter Host name: meta data server

i. Enter Port: 50000 (default).
j. Enter Database user name: meta user

k. Enter Database password: meta password

l. Click Continue.
m. Select Create → Deploy.
n. Select Services → JDBC → Connection pools → Bp8MetadataPool.
o. Click the Configuration Connections tab.
p. Click Show under Advanced Options.
q. Check Test Reserved Connections and Test Release Connections and click

Apply.
r. Click the Testing Tab.
s. Click Test Pool. You receive the Connection Successful message.

3. To create JDBC Data Source:
a. Select Services → JDBC → DataSources.
b. Select Configure a new JDBC DataSource....

c. Determine the meta datasource name and record on your worksheet.
Suggested name: Bp8MetadataDS

d. Enter name: meta datasource

e. Enter JNDI name: meta datasource

Restriction: The Data Source name and the Data Source JNDI name must
be the same.

f. Enter Honor Global Transactions: selected
g. Enter Emulate Two-Phase commit: unselected
h. Click Continue.

Manually editing installation settings 121



i. Select meta connection pool.
j. Select Continue.
k. Select Create.

Creating the Metastore data source on Oracle WebLogic
Server 9.2.x or 10 for DB2

You can manually configure the JDBC data source connection for the Metastore on
Oracle WebLogic Server 9.2.x or 10 for DB2.
1. Log into Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To create JDBC Data Source:

a. Select Services → JDBC → DataSources.
b. (Oracle WebLogic Server 9.2.x only) Click Lock & Edit button under

Change Center.
c. Click New....

d. Determine the meta datasource name and record on your worksheet.
Suggested name: Bp8MetadataDS

e. Enter name: meta datasource

f. Enter JNDI name: meta datasource

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Select Database Type: DB2

h. Select Database Driver: DB2 Driver (Type 4) Versions: 7.X 8.X

i. Click Next.
j. Enter Support Global Transactions: selected
k. Enter Emulate Two-Phase commit: unselected
l. Click Next.
m. Enter Database name: meta database

n. Enter Host name: meta data server

o. Enter Port: 50000
p. Enter Database user name: meta user

q. Enter Password: meta password

r. Click Next.
s. Select Test Configuration. The Connection Test succeeded message displays.
t. Click Next.
u. Select Server under Select Targets (default is AdminServer).
v. Click Finish.
w. Click Activate Changes button under Change Center.

Creating the Metastore data source on Oracle WebLogic
Server 8.1.x for Oracle

Before you configure the JDBC data source connection for the Metastore on Oracle
WebLogic Server 8.1.x for Oracle, you must first create a JDBC connection pool.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To configure Connection Pool:
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a. Select Services → JDBC → Connection pools.
b. Click Configure a new JDBC Connection Pool....

c. Select Database Type: Oracle.
d. Select Database Driver: Oracle Driver (Type 4)

e. Click Continue.
f. Determine the meta connection pool name and record it on your worksheet.

Suggested name: Bp8MetadataPool
g. Select Name: meta connection pool.
h. Enter Database name: meta database.
i. Enter host name: meta data server.
j. Enter Port: 1521 (default)
k. Enter Database user name: meta user

l. Enter Database password: meta password

m. Click Continue.
n. Modify Properties → SID if necessary.
o. Select the Test Driver Configuration. You receive the Connection Successful

message.
p. Select Create → Deploy.

3. To create JDBC Data Source:
a. Select Services → JDBC → DataSources.
b. Select Configure a new JDBC DataSource....

c. Determine the meta datasource name and record on your worksheet.
Suggested name: Bp8MetadataDS

d. Enter name: meta datasource.
e. Enter JNDI name: meta datasource.

Restriction: The Data Source name and the Data Source JNDI name must
be the same.

f. Enter Honor Global Transactions: selected
g. Enter Emulate Two-Phase commit: unselected.
h. Click Continue.
i. Select meta connection pool.
j. Select Continue.
k. Select Create.

Creating the Metastore data source on Oracle WebLogic
Server 9.2.x or 10 for Oracle

You can manually configure the JDBC data source connection for the Metastore on
Oracle WebLogic Server 9.2.x or 10 for Oracle.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To create the JDBC Data Source:

a. Select Services → JDBC → DataSources.
b. (Oracle WebLogic Server 9.2.x) Click Lock & Edit button under Change

Center.
c. Click New....
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d. Determine the meta datasource name and record on your worksheet.
Suggested name: Bp8MetadataDS

e. Enter name: meta datasource

f. Enter JNDI name: meta datasource

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Select Database Type: Oracle

h. Select Database Driver: Oracle Driver (Type 4)

i. Click Next.
j. Enter Support Global Transactions: selected
k. Enter Emulate Two-Phase commit: unselected
l. Click Next.
m. Enter Database name: meta database.
n. Enter host name: meta data server

o. Enter Port: 1521 (default).
p. Enter Database user name: meta user

q. Enter Password: meta password

r. Click Next.
s. Modify Properties → SID if necessary.
t. Click Test Configuration. You receive the Connection Test succeeded

message.
u. Click Next.
v. Select Server under Select Targets (default is AdminServer).
w. Click Finish.
x. Click Activate Changes button under Change Center.

Creating the Metastore data source on Oracle WebLogic
Server 8.1.x for Microsoft SQL Server

Before you configure the JDBC data source connection for the Metastore on Oracle
WebLogic Server 8.1.x for Microsoft SQL Server, you must first create a JDBC
connection pool.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To configure connection pool, select Services → JDBC → Connection pools.

a. Click Configure a new JDBC Connection Pool.....
b. Select Database Type: MS SQL Server.
c. Select Database Driver: MS SQL Server Driver (Type 4) Versions: 7.0,2000

d. Click Continue.
e. Determine the meta connection pool name and record on your worksheet.

Suggested name: Bp8MetadataPool
f. Select Name: meta connection pool

g. Enter Database name: meta database

h. Enter Host name: meta data server

i. Enter Port: 1433.
j. Enter Database user name: meta user

k. Enter Database password: meta password
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l. Click Continue.
m. Select the Test Driver Configuration. You receive the Connection successful

message.
n. Select Create → Deploy.

3. To create JDBC Data Source:
a. Select Services → JDBC → DataSources.
b. Select Configure a new JDBC DataSource....

c. Determine the meta datasource name and record on your worksheet.
Suggested name: Bp8MetadataDS

d. Enter name: meta datasource

e. Enter JNDI name: meta datasource

Restriction: The Data Source name and the Data Source JNDI name must
be the same.

f. Enter Honor Global Transactions: selected
g. Enter Emulate Two-Phase commit: unselected
h. Click Continue.
i. Select meta connection pool.
j. Select Continue.
k. Select Create.

Creating the Metastore data source on Oracle WebLogic
Server 9.2.x or 10 for Microsoft SQL Server

You can manually configure the JDBC data source connection for the Metastore on
Oracle WebLogic Server 9.2.x or 10 for Microsoft SQL Server.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To create JDBC Data Source:

a. Select Services → JDBC → DataSources.
b. (Oracle WebLogic Server 9.2.x) Click Lock & Edit under Change Center.
c. Click New....

d. Determine the meta datasource name and record on your worksheet.
Suggested name: Bp8MetadataDS

e. Enter name: meta datasource

f. Enter JNDI name: meta datasource

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Select Database Type: MS SQL Server

h. Select Database Driver: MS SQL Server Driver (Type 4) Versions: 7.0,2000

i. Click Next.
j. Enter Support Global Transactions : selected
k. Enter Emulate Two-Phase commit : unselected
l. Click Next.
m. Enter Database name: meta database

n. Enter Host name: meta data server

o. Enter Port: 1433
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p. Enter Database user name: meta user

q. Enter Password: meta password

r. Click Next.
s. Select the Test Configuration. You receive the Connection Test succeeded

message.
t. Click Next.
u. Select Server under Select Targets (default is AdminServer).
v. Click Finish.
w. Click Activate Changes button under Change Center.

Creating the Metastore data source on JBoss Application
Server for DB2

You can manually configure the JDBC data source connection for the Metastore on
JBoss Application Server for DB2.
1. Create a file named ms-ds.xml with this content:

<datasources>
<local-tx-datasource>

<jndi-name> {meta datasource} </jndi-name>
<use-java-context>false</use-java-context>
<connection-url> jdbc:db2:// {meta data server} :

{meta data port} / {meta database} </connection-url>
<driver-class>com.ibm.db2.jcc.DB2Driver</driver-class>
<user-name> {meta user} </user-name>
<password> {meta password} </password>

</local-tx-datasource>
</datasources>

2. Edit the contents of this file, replacing these parameters with the values from
the prerequisite worksheet:

meta datasource
meta data server
meta data port
meta database
meta user
meta password

3. Copy the file to directory JBOSS_HOME/server/server_name/deploy.

Creating the Metastore data source on JBoss Application
Server for Oracle

You can manually configure the JDBC data source connection for the Metastore on
JBoss Application Server for Oracle.
1. Create a file named ms-ds.xml with this content:

<datasources>
<local-tx-datasource>

<jndi-name> {meta datasource} </jndi-name>
<use-java-context>false</use-java-context>
<connection-url> jdbc:oracle:thin:@ {meta data server} :

{meta data port} : {meta database} </connection-url>
<driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
<user-name> {meta user} </user-name>
<password> {meta password} </password>

</local-tx-datasource>
</datasources>
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2. Edit the contents of this file, replacing these parameters with the values from
the prerequisite worksheet:

meta datasource
meta data server
meta data port
meta database
meta user
meta password

3. Copy the file to directory JBOSS_HOME/server/server_name/deploy.

Creating the Metastore data source on JBoss Application
Server for Microsoft SQL Server

You can manually configure the JDBC data source connection for the Metastore on
JBoss Application Server for Microsoft SQL Server.
1. Create a file named ms-ds.xml with this content:

<datasources>
<local-tx-datasource>

<jndi-name> {meta datasource} </jndi-name>
<use-java-context>false</use-java-context>
<connection-url> jdbc:jtds:sqlserver:// {meta data server} :

{meta data port} / {meta database} </connection-url>
<driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class>
<user-name> {meta user} </user-name>
<password> {meta password} </password>

</local-tx-datasource>
</datasources>

2. Edit the contents of this file, replacing these parameters with the values from
the prerequisite worksheet:

meta datasource
meta data server
meta data port
meta database
meta user
meta password

3. Copy the file to directory JBOSS_HOME/server/server_name/deploy.

Creating the JDBC data source for the Process Engine
The Business Process Framework Web application requires a connection to the data
source for the Process Engine. You can create the JDBC data source according to
your Web application server and database type.

“Creating the Process Engine data source on WebSphere Application Server for
DB2” on page 128
You can manually configure the JDBC data source connection for the Process
Engine on WebSphere Application Server for DB2.
“Creating the Process Engine data source on WebSphere Application Server for
Oracle” on page 130
You can manually configure the JDBC data source connection for the Process
Engine on WebSphere Application Server for Oracle.
“Creating the Process Engine data source on WebSphere Application Server for
Microsoft SQL Server” on page 131
You can manually configure the JDBC data source connection for the Process
Engine on WebSphere Application Server for Microsoft SQL Server.
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“Creating the Process Engine data source on Oracle WebLogic Server 8.1.x for
DB2” on page 133
Before you configure the JDBC data source connection for the Process Engine
on Oracle WebLogic Server 8.1.x for DB2, you must first create a JDBC
connection pool.
“Creating the Process Engine data source on Oracle WebLogic Server 9.2.x or 10
for DB2” on page 134
You can manually configure the JDBC data source connection for the Process
Engine on Oracle WebLogic Server 9.2.x or 10 for DB2.
“Creating the Process Engine data source on Oracle WebLogic Server 8.1.x for
Oracle” on page 134
Before you configure the JDBC data source connection for the Process Engine
on Oracle WebLogic Server 8.1.x for Oracle , you must first create a JDBC
connection pool.
“Creating the Process Engine data source on Oracle WebLogic Server 9.2.x or 10
for Oracle” on page 135
You can manually configure the JDBC data source connection for the Process
Engine on Oracle WebLogic Server 9.2.x or 10 for Oracle.
“Creating the Process Engine data source on Oracle WebLogic Server 8.1.x for
Microsoft SQL Server” on page 136
Before you configure the JDBC data source connection for the Process Engine
on Oracle WebLogic Server 8.1.x for Microsoft SQL Server , you must first
create a JDBC connection pool.
“Creating the Process Engine data source on Oracle WebLogic Server 9.2.x or 10
for Microsoft SQL Server” on page 137
You can manually configure the JDBC data source connection for the Process
Engine on Oracle WebLogic Server 9.2.x or 10 for Microsoft SQL Server.
“Creating the Process Engine data source on JBoss Application Server for DB2”
on page 138
You can manually configure the JDBC data source connection for the Process
Engine on JBoss Application Server for DB2.
“Creating the Process Engine data source on JBoss Application Server for
Oracle” on page 138
You can manually configure the JDBC data source connection for the Process
Engine on JBoss Application Server for Oracle.
“Creating the Process Engine data source on JBoss Application Server for
Microsoft SQL Server” on page 139
You can manually configure the JDBC data source connection for the Process
Engine on JBoss Application Server for Microsoft SQL Server.

Creating the Process Engine data source on WebSphere
Application Server for DB2

You can manually configure the JDBC data source connection for the Process
Engine on WebSphere Application Server for DB2.
1. Log on to WebSphere Application Server Administrative Console: http://web

application server}:9060/ibm/console
2. To create the JDBC Provider:

a. Click Resources → JDBC Providers.
Skip this sub step if pe connection pool exists. Otherwise, do the following:

b. Click New.
c. Select the database type: DB2
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d. Select the provider type: DB2 Universal JDBC Driver Provider

e. Select the implementation type: Connection pool DataSource

f. Click Next.
g. Click Apply.
h. Save changes to master configuration.

3. To create the Initial JDBC Data Source:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider.
c. Click DataSources under Additional Properties.
d. Click New.
e. Enter the Name for the Data Source. Record this name on your worksheet

as pe datasource.
f. Enter JNDI name: pe datasource.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Enter Description: pe datasource

h. Enter Database name: pe database

i. Enter Server name: pe data server

j. Click Apply.
k. Save changes to master configuration.

4. To create the Authentication Entry:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider

c. Click DataSources under Additional Properties.
d. Click meta datasource.
e. Click J2EE Connector Architecture (J2C) authentication data entries under

Related Items.
f. Click New.
g. Enter Alias name pe authentication name. Suggested name:

Bp8MetatdataAlias
h. Enter user ID: pe user

i. Enter Password: pe password

j. Click Apply.
k. Save changes to master configuration.

5. To set the JDBC Data Source Authentication:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider

c. Click DataSources under Additional Properties.
d. Click pe datasource.
e. Select Component-managed authentication alias: pe authentication name

f. Click Apply.
g. Save changes to master configuration.

6. To test the connection:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider
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c. Click DataSources under Additional Properties.
d. Click pe datasource.
e. Click Test Connection.

A success message is displayed.

Creating the Process Engine data source on WebSphere
Application Server for Oracle

You can manually configure the JDBC data source connection for the Process
Engine on WebSphere Application Server for Oracle.
1. Log on to WebSphere Application Server Administrative Console: http://web

application server}:9060/ibm/console
2. To create the JDBC Provider:

a. Click Resources → JDBC Providers.
Skip this sub step if pe connection pool exists. Otherwise, do the following:

b. Click New.
c. Select the database type: Oracle

d. Select the provider type: Oracle JDBC Driver Provider

e. Select the implementation type: Connection pool DataSource

f. Click Next.
g. Enter pe connection pool in the Name field.
h. Keep the default class path value of

oracle.jdbc.pool.OracleConnectionPoolDataSource. Record it as the Class
path as the pe class path on the worksheet.

i. Click Apply.
j. Save changes to master configuration.
k. Click Environment → WebSphere Application Server Variables.
l. Verify that any environment variables used in meta class path is set correctly.

3. To create the Initial JDBC Data Source:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: pe connection pool

c. Click DataSources under Additional Properties.
d. Click New.
e. Enter the Name for the Data Source. Record this name on your worksheet

as pe datasource.
f. Enter JNDI name: pe datasource.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Enter Description: pe datasource

h. Enter Database name: pe database

i. Enter URL: JDBC:oracle:thin:@pe data server:1521:pe database sid.

Tip: If URL does not work for any reason try: JDBC:oracle:thin@TNS
Descriptor
For example:
JDBC:oracle:thin:@(DESCRIPTION=(ADDRESS_LIST=(ADDRESS=(PROTOCOL=TCP)
(HOST=p8demo35)(PORT=1521)))(CONNECT_DATA=(SERVER=DEDICATED)
(SERVICE_NAME=Bp8.Metastore)))
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j. Click Apply.
k. Save changes to master configuration.

4. To create the Authentication Entry:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: pe datasource

c. Click DataSources under Additional Properties.
d. Click pe datasource.
e. Click J2EE Connector Architecture (J2C) authentication data entries under

Related Items.
f. Click New.
g. Enter Alias name pe authentication name. Suggested name:

Bp8MetatdataAlias
h. Enter user ID: pe user

i. Enter Password: pe password

j. Click Apply.
k. Save changes to master configuration.

5. To set the JDBC Data Source Authentication:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: DB2 Universal JDBC Driver Provider

c. Click DataSources under Additional Properties.
d. Click pe datasource.
e. Select Component-managed authentication alias: pe authentication name

f. Click Apply.
g. Save changes to master configuration.

6. To test the connection:
a. Click Resources → JDBC Providers.
b. Click the appropriate provider: pe authentication name

c. Click DataSources under Additional Properties.
d. Click pe datasource.
e. Click Test Connection.

A success message is displayed.

Creating the Process Engine data source on WebSphere
Application Server for Microsoft SQL Server

You can manually configure the JDBC data source connection for the Process
Engine on WebSphere Application Server for Microsoft SQL Server.
1. Log on to the WebSphere Application Server Administrative Console:

http://web application server}:9060/ibm/console
2. To create the JDBC Provider:

a. Click Resources → JDBC Providers.
Skip this sub step if pe connection pool exists. Otherwise, do this procedure:
a. Click New.
b. Select the database type: SQL Server

c. Select the provider type: WebSphere embedded ConnectJDBC driver for
MS SQL Server

d. Select the implementation type: Connection pool data source.
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e. Click Next.
f. Click Apply.
g. Save changes to master configuration.

3. To create the Initial JDBC Data Source:
a. Select Services → JDBC → DataSources.
b. Click the appropriate provider: pe connection pool.
c. Click DataSources under Additional Properties.
d. Click New.
e. Enter the name for the Data Source pe connection pool. Suggested name:

Bp8ProcessDS
f. Enter JNDI name: pe connection pool.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Enter Description: pe datasource

h. Enter Database name: pe datasource

i. Enter Server name: pe data server

j. Click Apply.
k. Save changes to master configuration.

4. To create the Authentication Entry:
a. Click Resources > JDBC Providers.
b. Click the appropriate provider: {pe connection pool}.
c. Click Data Sources under Additional Properties.
d. Click {pe datasource}.
e. Click J2EE Connector Architecture (J2C) authentication data entries under

Related Items.
f. Click New.
g. Enter Alias name {pe authentication name}. Suggested name:

Bp8ProcessAlias. Record this name on your worksheet as {pe authentication
name}.

h. Enter user ID: {pe end-user}.
i. Enter Password: {pe password}.
j. Click Apply.
k. Save changes to master configuration.

5. To set the JDBC Data Source Authentication:
a. Click Resources > JDBC Providers.
b. Click the appropriate provider: {pe connection pool}.
c. Click Data Sources under Additional Properties.
d. Click {pe datasource}.
e. Select Component-managed authentication alias: {pe authentication name}.
f. Click Apply.
g. Save changes to master configuration.

6. To test the connection:
a. Click Resources > JDBC Providers.
b. Click the appropriate provider: {pe connection pool}.
c. Click Data Sources under Additional Properties.

132 Installation Guide



d. Select the check box for {pe datasource}.
e. Click Test Connection.
f. A success message is displayed.

Creating the Process Engine data source on Oracle WebLogic
Server 8.1.x for DB2

Before you configure the JDBC data source connection for the Process Engine on
Oracle WebLogic Server 8.1.x for DB2, you must first create a JDBC connection
pool.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To configure the Connection Pool:

a. Select Services → JDBC → Connection pools.
b. Click Configure a new JDBC Connection Pool.
c. Select Database Type: DB2

d. Select Database Driver: DB2 Driver (Type 4) Version: 7.x 8.x

e. Click Continue.
f. Determine the pe connection pool name and record on your worksheet.

Suggested name: Bp8ProcessPool
g. Enter Name: pe connection pool

h. Enter Database name: pe database.
i. Enter host name: pe data server

j. Enter Port: 50000 (default).
k. Enter Database user name: pe user

l. Enter Password: pe password

m. Click Continue.
n. Select Create → Deploy.
o. Select Services → JDBC → Connection pools → Bp8ProcessPool.
p. Click the Configuration Connections tab.
q. Click Show under Advanced Options.
r. Check Test Reserved Connections and Test Release Connections and click

Apply.
s. Click the Testing Tab.
t. Click Test Pool.

You receive the Connection Successful message.
3. To create the JDBC Data Source:

a. Select Services → JDBC → DataSources.
b. Select Configure a new JDBC DataSource.....
c. Determine the pe datasource name and record on your worksheet. Suggested

name: Bp8ProcessDS
d. Enter name: pe datasource

e. Enter JNDI name: pe datasource

Restriction: The Data Source name and the Data Source JNDI name must
be the same.

f. Enter Support Global Transactions: selected
g. Enter Emulate Two-Phase commit: unselected
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h. Click Continue.
i. Select pe connection pool

j. Select Continue.
k. Select Create.

Creating the Process Engine data source on Oracle WebLogic
Server 9.2.x or 10 for DB2

You can manually configure the JDBC data source connection for the Process
Engine on Oracle WebLogic Server 9.2.x or 10 for DB2.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To create the JDBC Data Source:

a. Select Services → JDBC → DataSources.
b. (Oracle WebLogic Server 9.2.x only) Click the Lock & Edit button under

Change Center.
c. Click New....

d. Determine the pe datasource name and record on your worksheet. Suggested
name: Bp8ProcessDS

e. Enter name: pe datasource

f. Enter JNDI name: pe datasource.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Select Database Type: DB2.
h. Select Database Driver: DB2 Driver (Type 4) Versions: 7.x, 8.x

i. Click Next.
j. Enter Honor Global Transactions: selected
k. Enter Emulate Two-Phase commit: unselected
l. Click Next.
m. Enter Database name: pe database

n. Enter Host name: pe data server

o. Enter Port: 50000 (default).
p. Enter Database user name: pe user

q. Enter Database password: pe password

r. Click Next.
s. Select Test Configuration. You receive the Connection Test succeeded

message.
t. Click Next.
u. Select Server under Select Targets (default is AdminServer).
v. Click Finish.
w. Click Activate Changes button under Change Center.

Creating the Process Engine data source on Oracle WebLogic
Server 8.1.x for Oracle

Before you configure the JDBC data source connection for the Process Engine on
Oracle WebLogic Server 8.1.x for Oracle , you must first create a JDBC connection
pool.
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1. Log in to Oracle WebLogic Server console from a Web browser: http://web
application server:7001/console

2. To configure the Connection Pool:
a. Select Services → JDBC → Connection pools.
b. Click Configure a new JDBC Connection Pool.
c. Select Database Type: Oracle

d. Select Database Driver: Oracle Driver (Type 4)

e. Click Continue.
f. Determine the pe connection pool name and record on your worksheet.

Suggested name: Bp8ProcessPool
g. Enter Name: pe connection pool

h. Enter Database name: pe database.
i. Enter host name: pe data server

j. Enter Port: 1521 (default).
k. Enter Database user name: pe user

l. Enter Password: pe password

m. Click Continue.
n. Modify Properties → SID if necessary.
o. Click Test Configuration. You receive the Connection Test succeeded

message.
p. Select Create → Deploy.

3. To create the JDBC Data Source:
a. Select Services → JDBC → DataSources.
b. Select Configure a new JDBC DataSource.....
c. Determine the pe datasource name and record on your worksheet. Suggested

name: Bp8ProcessDS
d. Enter name: pe datasource

e. Enter JNDI name: pe datasource

Restriction: The Data Source name and the Data Source JNDI name must
be the same.

f. Enter Support Global Transactions: selected
g. Enter Emulate Two-Phase commit: unselected
h. Click Continue.
i. Select pe connection pool

j. Select Continue.
k. Select Create.

Creating the Process Engine data source on Oracle WebLogic
Server 9.2.x or 10 for Oracle

You can manually configure the JDBC data source connection for the Process
Engine on Oracle WebLogic Server 9.2.x or 10 for Oracle.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To create the JDBC Data Source:

a. Select Services → JDBC → DataSources.
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b. (Oracle WebLogic Server 9.2.x only) Click the Lock & Edit button under
Change Center.

c. Click New....

d. Determine the pe datasource name and record on your worksheet. Suggested
name: Bp8ProcessDS

e. Enter name: pe datasource

f. Enter JNDI name: pe datasource.

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Select Database Type: Oracle.
h. Select Database Driver: Oracle Driver (Type 4)

i. Click Next.
j. Enter Honor Global Transactions: selected
k. Enter Emulate Two-Phase commit: unselected
l. Click Next.
m. Enter Database name: pe database

n. Enter Host name: pe data server

o. Enter Port: 1521 (default).
p. Enter Database user name: pe user

q. Enter Database password: pe password

r. Click Next.
s. Modify Properties → SID if necessary.
t. Select Test Configuration. You receive the Connection Test succeeded

message.
u. Click Next.
v. Select Server under Select Targets (default is AdminServer).
w. Click Finish.
x. Click Activate Changes button under Change Center.

Creating the Process Engine data source on Oracle WebLogic
Server 8.1.x for Microsoft SQL Server

Before you configure the JDBC data source connection for the Process Engine on
Oracle WebLogic Server 8.1.x for Microsoft SQL Server , you must first create a
JDBC connection pool.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To configure the Connection Pool:

a. Select Services → JDBC → Connection pools.
b. Click Configure a new JDBC Connection Pool.
c. Select Database Type: MS SQL Server

d. Select Database Driver: MS SQL Server Driver (Type 4) Versions: 7.0,2000

e. Click Continue.
f. Determine the pe connection pool name and record on your worksheet.

Suggested name: Bp8ProcessPool
g. Enter Name: pe connection pool

h. Enter Database name: pe database.
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i. Enter host name: pe data server

j. Enter Port: 1433
k. Enter Database user name: pe user

l. Enter Password: pe password

m. Click Continue.
n. Click Test Configuration. You receive the Connection Test succeeded

message.
o. Select Create → Deploy.

3. Create JDBC Data Source:
a. Select Services → JDBC → DataSources.
b. Select Configure a new JDBC DataSource.....
c. Determine the pe datasource name and record on your worksheet. Suggested

name: Bp8ProcessDS
d. Enter name: pe datasource

e. Enter JNDI name: pe datasource

Restriction: The Data Source name and the Data Source JNDI name must
be the same.

f. Enter Support Global Transactions: selected
g. Enter Emulate Two-Phase commit: unselected
h. Click Continue.
i. Select pe connection pool

j. Select Continue.
k. Select Create.

Creating the Process Engine data source on Oracle WebLogic
Server 9.2.x or 10 for Microsoft SQL Server

You can manually configure the JDBC data source connection for the Process
Engine on Oracle WebLogic Server 9.2.x or 10 for Microsoft SQL Server.
1. Log in to Oracle WebLogic Server console from a Web browser: http://web

application server:7001/console
2. To create the JDBC Data Source:

a. Select Services → JDBC → DataSources.
b. (Oracle WebLogic Server 9.2.x only) Click Lock & Edit button under

Change Center.
c. Click New....

d. Determine the pe datasource name and record on your worksheet. Suggested
name: Bp8MetadataDS

e. Enter name: pe datasource

f. Enter JNDI name: pe datasource

Restriction: The Data Source name and the Data Source JNDI name must be
the same.

g. Select Database Type: MS SQL Server

h. Select Database Driver: MS SQL Server Driver (Type 4) Versions: 7.0,2000

i. Click Next.
j. Enter Support Global Transactions: selected.
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k. Enter Emulate Two-Phase commit: unselected.
l. Click Next.
m. Enter Database name: pe database

n. Enter Host name: pe server

o. Enter Port: 1433
p. Enter Database user name: pe user

q. Enter Password: pe password

r. Click Next.
s. Select the Test Configuration. You receive the Connection Test succeeded

message.
t. Click Next.
u. Select Server under Select Targets (default is AdminServer).
v. Click Finish.
w. Click Activate Changes button under Change Center.

Creating the Process Engine data source on JBoss
Application Server for DB2

You can manually configure the JDBC data source connection for the Process
Engine on JBoss Application Server for DB2.
1. Create a file named , with the following content:

<datasources>
<local-tx-datasource>

<jndi-name> {meta datasource} </jndi-name>
<use-java-context>false</use-java-context>
<connection-url> jdbc:db2:// {pe data server} :

{pe data port} / {pe database} </connection-url>
<driver-class>com.ibm.db2.jcc.DB2Driver</driver-class>
<user-name> {meta user} </user-name>
<password> {pe password} </password>

</local-tx-datasource>
</datasources>

2. Edit the contents of this file, replacing these parameters with the values from
the prerequisite worksheet

meta datasource
pe data server
pe data port
pe database
meta user
pe password

3. Copy the file to directory JBOSS_HOME/server/server_name/deploy.

Creating the Process Engine data source on JBoss
Application Server for Oracle

You can manually configure the JDBC data source connection for the Process
Engine on JBoss Application Server for Oracle.
1. Create a file named ps-ds.xml, with the following content:

<datasources>
<local-tx-datasource>

<jndi-name> {meta datasource} </jndi-name>
<use-java-context>false</use-java-context>
<connection-url> jdbc:oracle:thin:@ {pe data server} :
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{pe data port} : {pe database} </connection-url>
<driver-class>oracle.jdbc.driver.OracleDriver</driver-class>
<user-name> {meta user} </user-name>
<password> {pe password} </password>

</local-tx-datasource>
</datasources>

2. Edit the contents of this file, replacing these parameters with the values from
the prerequisite worksheet:
meta datasource
pe data server
pe data port
pe database
meta user
pe password

3. Copy the file to directory JBOSS_HOME/server/server_name/deploy.

Creating the Process Engine data source on JBoss
Application Server for Microsoft SQL Server

You can manually configure the JDBC data source connection for the Process
Engine on JBoss Application Server for Microsoft SQL Server.
1. Create a file named ps-ds.xml, with the following content:

<datasources>
<local-tx-datasource>

<jndi-name> {meta datasource} </jndi-name>
<use-java-context>false</use-java-context>
<connection-url> jdbc:jtds:sqlserver:// {pe data server} :

{pe data port} / {pe database} </connection-url>
<driver-class>net.sourceforge.jtds.jdbc.Driver</driver-class>
<user-name> {meta user} </user-name>
<password> {pe password} </password>

</local-tx-datasource>
</datasources>

2. Edit the contents of this file, replacing these parameters with the values from
the prerequisite worksheet:
meta datasource
pe data server
pe data port
pe database
meta user
pe password

3. Copy the file to directory JBOSS_HOME/server/server_name/deploy.

Deploying the Business Process Framework Web application
After you have installed and configured the Business Process Framework server,
you can manually deploy the Web application on the application server.

“Deploying the Web application on IBM WebSphere Application Server 6.x” on
page 140
You can use the WebSphere Application Server Administrative Console to
deploy the Business Process Framework Web Application.
“Deploying the Web application on IBM WebSphere Application Server 7.x” on
page 141
You can use the WebSphere Application Server 7.x Administrative Console to
manually deploy the Business Process Framework Web Application.
“Deploying the Web application on Oracle WebLogic Server 8.1.X” on page 142
You can use the Oracle WebLogic Server console to manually deploy the
Business Process Framework Web application.
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“Deploying the Web application on Oracle WebLogic Server 9.2.x or 10” on
page 143
You can use the Oracle WebLogic Server Console to manually deploy the
Business Process Framework Web Application.
“Deploying the Web application on JBoss Application Server 4.0.x or 4.2.x” on
page 143
You can manually deploy the Business Process Framework Web application on
JBoss Application Server 4.0.x or 4.2.x.

Deploying the Web application on IBM WebSphere Application
Server 6.x

You can use the WebSphere Application Server Administrative Console to deploy
the Business Process Framework Web Application.
1. To install the Business Process Framework Web Application (WAR or EAR):

a. Verify that the app_name.war or app_name.ear file was created.
b. From the WebSphere Application Server Administrative Console, expand

Applications.
c. Click Install New Application .

The Preparing for the application installation dialog opens.
v If the Administrative Console is running locally, select Local Path and

browse to the location of the app_name.war or app_name.ear file that was
created by the setup program. The default path is:
– Windows: C:\Program Files\FileNet\BPF\web\

– UNIX: /opt/FileNet/BPF/web/

Remember: Do not enter the machine name.
v If the Administrative Console is remote, select Remote File System and

enter the fully qualified path to the app_name.war or app_name.ear file.

Remember: Do not enter the machine name.
2. Enter BPF and click Next to deploy a new application.

a. Enter the context root.

Tip: The context root is the name of the application you log in to for using
the Web interface, for example: http://WebAApplicationServerName:port#/
Context Root

b. On the Preparing for the application installation screen, leave the defaults,
and click Next.

c. On the Application Security Warningscreen, click Continue.
d. At Install New Application, Step 1, specify the application name. Enter BPF,

or the name you chose to call the application, click Next.
e. At Install New Application, Step 2, Map modules to servers, specify the

Web server you are planning to use. Check BPF and click Next.
f. At Install New Applicatio″, Step 3, Map Virtual Hosts for Web Modules,

check BPF, keep the default virtual host (default_host), and click Next.
g. At Install New Application, Step 4, verify your configuration and click

Finish.
h. Once the configuration is saved, click Save to Master Configuration.

3. Stop and restart the application server.
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4. To set the Classloader to Parent_First: Do not set the Classloader to Parent_Last
as is done for Workplace and IBM InfoSphere Enterprise Records. Because this
setting differs across IBM FileNet P8 applications, ensure that you apply this
setting only to the Business Process Framework application, and not to the
application server as a whole.
a. From the WebSphere Application Server Administrative Console, expand

Applications, click Enterprise Applications, and then click your application.
(The default application is bpf.)

b. From the Configuration tab, set the Classloader Mode to PARENT_FIRST
(default).

c. Verify that the WAR Classloader Policy is set to Module.
d. Under Related Items, click Web Modules, and then click bpf.war.
e. From the Configuration tab, set the Classloader Mode to PARENT_FIRST

(Default). Click Apply → Save and Save changes to the Master
Configuration.

5. To start the Enterprise Application:
a. From the Administrative Console, expand Applications.
b. Click Enterprise Application to the left of the Business Process Framework

application, and click Start.

Deploying the Web application on IBM WebSphere Application
Server 7.x

You can use the WebSphere Application Server 7.x Administrative Console to
manually deploy the Business Process Framework Web Application.
1. To install the Business Process Framework Web Application (WAR or EAR):

a. Verify that the app_name.war or app_name.ear file was created.
b. From the WebSphere Application Server Administrative Console, navigate

to Applications → WebSphere Enterprise Applications → New Enterprise
Applications → Install.

c. Select the file to deploy.
v If the Administrative Console is running locally, select Local File System

and browse to the location of the app_name.war or app_name.ear file that
was created by the setup program. The default path is:
– Windows: C:\Program Files\FileNet\BPF\web\

– UNIX: /opt/FileNet/BPF/web/

Remember: Do not enter the machine name.
v If the Administrative Console is remote, select Remote File System and

enter the fully qualified path to the app_name.war or app_name.ear file.

Remember: Do not enter the machine name.
d.

2. If you are deploying as a WAR file, enter BPF as the Context Root and click
Next to deploy the new application.

Tip: The context root is the name of the application you log in to for using the
Web interface, for example: http://WebAApplicationServerName:port#/Context
Root

a. On the Preparing for the application installation screen, leave the defaults,
and click Next.
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b. On the Application Security Warningscreen, click Continue.
c. At Install New Application, Step 1, specify the application name. Enter BPF,

or the name you chose to call the application, click Next.
d. At Install New Application, Step 2, Map modules to servers, specify the

Web server you are planning to use. Check BPF and click Next.
e. At Install New Application, Step 3, Map Virtual Hosts for Web Modules,

check BPF, keep the default virtual host (default_host), and click Next.
f. At Install New Application, Step 4, verify your configuration and click

Finish.
g. Once the configuration is saved, click Save to Master Configuration.

3. Stop and restart the application server.
4. To set the Classloader to Parent_First: Do not set the Classloader to Parent_Last

as is done for Workplace and IBM InfoSphere Enterprise Records. Because this
setting differs across IBM FileNet P8 applications, ensure that you apply this
setting only to the Business Process Framework application, and not to the
application server as a whole.
a. From the WebSphere Application Server Administrative Console, navigate

toApplications → Enterprise Applications → BPF → Class loading and
update detection.

b. Set the Classloader order to Classes loaded with parent class loader first
(parent first) (default).

c. Verify that the WAR Classloader Policy is set to Module.
d. Under Related Items, click Web Modules, and then click bpf.war.
e. From the Configuration tab, set the Classloader Mode to PARENT_FIRST

(Default). Click Apply → Save and Save changes to the Master
Configuration.

5. To start the Enterprise Application:
a. From the Administrative Console, expand Applications.
b. Click Enterprise Application to the left of the Business Process Framework

application, and click Start.

Deploying the Web application on Oracle WebLogic Server
8.1.X

You can use the Oracle WebLogic Server console to manually deploy the Business
Process Framework Web application.

To deploy the application:
1. Start the application server.
2. From the Oracle WebLogic Server Console, mydomain, expand Deployments,

and click Web Application Modules.
3. Click Deploy a new Web Application Module.
4. In the right pane of the Oracle WebLogic Server Console, browse to and select

the radio button for the Business Process Framework folder in the path to folder
location. The default path is:

Option Description

Windows C:\Program Files\FileNet\BPF\web\

UNIX: /opt/FileNet/BPF/web/

5. Click Target Module and select BPF. Verify that the Name field.
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6. Click Deploy. To verify that the deployment was successful, expand Web
Applications.

Deploying the Web application on Oracle WebLogic Server
9.2.x or 10

You can use the Oracle WebLogic Server Console to manually deploy the Business
Process Framework Web Application.

To deploy the application:
1. Start the application server.
2. From the Oracle WebLogic Server Console, navigate to the domain to which

you want to deploy Business Process Framework Web Application.
3. Click Deployments.
4. Click Lock & Edit button under Change Center.
5. From the right pane of the Oracle WebLogic Server Console, browse to and

select the radio button for the Business Process Framework folder:

Option Description

Windows C:\Program Files\FileNet\BPF\web\

UNIX /opt/FileNet/BPF/web/

6. Click Install.
7. Accept the defaults for the deployment.
8. Click Finish. Business Process Framework Web Application is deployed. To

verify that the deployment was successful, expand Web Applications. The web
application Business Process Framework is listed.

Deploying the Web application on JBoss Application Server
4.0.x or 4.2.x

You can manually deploy the Business Process Framework Web application on
JBoss Application Server 4.0.x or 4.2.x.

To deploy Business Process Framework:
1. Copy Web application files in the Business Process Framework Web Folder to

JBOSS_HOME/server/server_name/deploy/. The default path of Business Process
Framework Web Folder is:

Option Description

Windows C:\Program Files\FileNet\BPF\web\

UNIX /opt/FileNet/BPF/web/

If you are deploying Business Process Framework as a folder, you will be
copying the folder (by default, this folder is named bpf) and everything
beneath it. The copied Business Process Framework folder must be renamed to
bpf.war in the JBoss Application Server deploy directory.
If you are deploying Business Process Framework as a .war file, you will be
copying the .war file (by default, this file is named bpf.war). In this case, no
rename is required.

2. Restart the JBoss Application Server.
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Related concepts

“Environment conditions that require additional manual configuration after
installation” on page 25
The Business Process Framework installation program automatically configures the
P8 Platform environment to work with Business Process Framework. However,
some component versions require additional manual configuration after the
installation is complete.

Applying IBM FileNet P8 Platform changes to the Business Process
Framework installation

You can apply IBM FileNet P8 Platform changes to the Business Process
Framework installation. Verify your installation and component versions.

Apply IBM FileNet P8 Platform changes.
The Business Process Framework 4.1 installation is packaged with JAR files from
these IBM FileNet P8 software levels:
v IBM FileNet P8 Content Engine: P8CE-4.0.1
v IBM FileNet P8 Process Engine: P8PE-4.0.2
v IBM FileNet P8 Application Engine: P8AE-4.0.1-000.001
v IBM FileNet P8 eForms: P8eForms-4.0.1

These IBM FileNet P8 software levels are the software versions required in order to
run Business Process Framework 4.1. If you have installed a later fix pack for the
Content Engine, Process Engine, Application Engine or (optionally) eForms, you
must replace certain JAR files in the Business Process Framework install and
deploy locations to ensure your Business Process Framework software functions
correctly. The following table identifies the JAR files that you must replace for each
component:

Component JAR Files

Content Engine Jace.jar javaapi.jar

Process Engine pe.jar peResources.jar

Application Engine v aeeforms.jar

v listener.jar mailapi.jar

v p8ciops.jar p8toolkit.jar

v soap.jar

v p8webappLogging.jar

v commons-fileupload-1.*.jar

eForms v eforms-resources.jar

v eforms.jar

v itext-1.5.2.jar

v jai_codec.jar

v commons-httpclient-2.0.2.jar

You can find the new versions of these files in the Workplace WEB-INF\lib folder.
By default the WEB-INF folder on the Application Engine is in the following
location:
v Windows: C:\Program Files\FileNet\Workplace\WEB-INF\lib

v UNIX: /opt/FileNet/Workplace/WEB-INF/lib
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1. “Copying the updated JAR files to the Business Process Framework installation
location”
You must copy the updated JAR files to the Business Process Framework
installation location to ensure the installation is complete.

2. “Deploying the application” on page 146
You can deploy Business Process Framework again if Business Process
Framework is deployed as an exploded folder, or if you are using WebSphere
Application Server.

Related concepts

“Environment conditions that require additional manual configuration after
installation” on page 25
The Business Process Framework installation program automatically configures the
P8 Platform environment to work with Business Process Framework. However,
some component versions require additional manual configuration after the
installation is complete.

Copying the updated JAR files to the Business Process
Framework installation location

You must copy the updated JAR files to the Business Process Framework
installation location to ensure the installation is complete.

By default, the Business Process Framework installation location is:
v Windows: C:\Program Files\FileNet\BPF

v UNIX: /opt/FileNet/BPF

To copy the updated JAR files:
v Ignore the existing IBM FileNet P8 jar files in bpfops/lib. The IBM FileNet P8

jar files in bpfops/lib are not used at runtime. You do not have to update these
jar files when applying IBM FileNet P8 Platform fix pack changes; however,
updating the files does no harm.

v (Optional) Update the existing IBM FileNet P8 jar files in BPFAssembly/CE_API.
Other IBM FileNet P8 components update the IBM FileNet P8 jar files beneath
the CE_API in their installation. Although these files are not used by Business
Process Framework, we recommend for consistency that you update the jar files
beneath BPFAssembly/CE_API when you apply IBM FileNet P8 Platform fix pack
changes.

v If Business Process Framework is installed as an EAR file: Follow the
instructions in “Updating the contents of the Business Process Framework EAR
file” on page 146. In that procedure, delete the existing commons-fileupload-
1.*.jar file and copy the JAR files in the table earlier in this section from
Workplace deploy folder/WEB-INF/lib to the C:\temp_war\WEB-INF\lib folder.

v If Business Process Framework is installed as a WAR File: Follow the
instructions in “Updating the contents of the Business Process Framework WAR
file” on page 146. In that procedure, delete the existing commons-fileupload-
1.*.jar file and copy the JAR files in the table earlier in this section from
Workplace deploy folder/WEB-INF/lib to the C:\temp_war\WEB-INF\lib folder.

v If Business Process Framework is installed in a folder structure: Copy the JAR
files from Workplace deploy folder/WEB-INF/lib to the BPF WEB-INF/lib folder,
overwriting the existing files.
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Deploying the application
You can deploy Business Process Framework again if Business Process Framework
is deployed as an exploded folder, or if you are using WebSphere Application
Server.

To deploy the application:
1. 1. Copy the JAR files from Workplace deploy folder/WEB-INF/lib to BPF

deploy folder/WEB-INF/lib folder, overwriting the existing files. The BPF
deploy folder is:
v WebSphere Application Server: WAS_Home/profiles/profile-name/

installedApps/node_name/bpf/WEB-INF/lib

v Oracle WebLogic Server: No copy is required as the install and deployment
locations are identical.

v JBoss Application Server: JBoss_install_path/server/server_name/deploy/
bpf.war/WEB-INF/lib

2. Restart the application server.

If your installation directory contains a packaged .war or .ear file and you are not
using WebSphere Application Server, redeploy the newly packaged .war or .ear
file

Updating the contents of the Business Process Framework WAR file
Various procedures involve updating the contents of the Business Process
Framework WAR file in the installation location.

To update the contents of the Business Process Framework WAR file:
1. Copy the WAR file to a temporary folder. In this procedure, the temporary

folder is assumed to be c:\temp_war.
2. Open a command window.
3. Navigate to C:\temp_war and then run the following command to extract the

WAR file contents: jar -xvf bpf.war

4. Delete the WAR file from the c:\temp_war folder.
5. Change the contents of the exploded WAR file in the C:\temp_war\WEB-INF\lib

folder.
6. Rebundle the WAR file by running the following command: jar -cvf bpf.war

*

7. Copy the WAR file into the Business Process Framework installation location.

Updating the contents of the Business Process Framework EAR file
Various procedures involve updating the contents of the Business Process
Framework EAR file in the installation location.

To update the contents of the Business Process Framework EAR file:
1. Copy the EAR file to a temporary folder. In this procedure, the temporary

folder is assumed to be c:\temp_ear.
2. Open a command window.
3. Navigate to the C:\temp_ear folder and then run the following command to

extract the WAR file and META-INF folder contents to the temporary folder: jar
-xvf bpf.ear
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4. Delete the EAR file from the C:\temp_ear folder.
5. Copy the WAR file from the C:\temp_ear folder to another temporary folder.

In this procedure, the second temporary folder is assumed to be C:\temp_war.
6. Navigate to C:\temp_war and then run the following command to extract the

WAR file contents:jar -xvf bpf.war

7. Delete the WAR file from the c:\temp_war folder.
8. Change the contents of the exploded EAR file in the C:\temp_war\WEB-INF\lib

folder.
9. Rebundle the WAR file by running the following command: jar -cvf bpf.war

*

10. Copy the WAR file generated in the previous step from the c:\temp_war folder
to the c:\temp_ear folder.

11. Rebundle the EAR file by running this command: jar -cvf bpf.ear *

12. Copy the EAR file into the Business Process Framework installation location.
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Uninstalling Business Process Framework

The Business Process Framework 4.1 uninstallation program can automatically
undeploy the Web application, which makes the 4.1 uninstallation procedures
different than previous Business Process Framework releases.

The uninstallation program can automatically undeploy the Business Process
Framework Web application, remove data sources from application server, and
remove the J2C user in WebSphere Application Server.

Some folders and files (the Business Process Framework Deployment Home folder
and BPFAssembly) might not be deleted during the uninstallation because a running
process prevents its deletion. You might need to remove these folders manually.

The uninstallation program does not revert the Workplace files or Application
Engine router files (under ..AE/Router folder) that the Business Process
Framework installer updated.

The uninstallation program does not uninstall Business Process Framework
operations.

The uninstallation program does not remove the Business Process Framework
Metastore database or configurations in the Content Engine or Process Engine.
1. “Uninstalling Business Process Framework Web application and Business

Process Framework operations” on page 150
You can undeploy Business Process Framework Web application and its
operations with the uninstallation program or undeploy the Web application
manually.

2. “Uninstalling Business Process Framework Explorer” on page 151
You can use the Microsoft Windows Add or Remove Programs program to
remove Business Process Framework Explorer from your server.

3. “Manually uninstalling the Business Process Framework Web application” on
page 151
You can bypass the automatic uninstallation and manually uninstall the
Business Process Framework Web application.

4. “Manually deleting data sources” on page 153
The uninstallation program automatically deletes the data sources in the Web
application server. If you choose to manually remove Business Process
Framework, you must also manually delete the data sources from your Web
application server.

5. “Removing the deployment file from WebSphere Application Server” on page
155
For WebSphere Application Server installations only, whether you chose
automatic or manual removal of Business Process Framework, after
uninstallation you must remove additional deployment information from the
WebSphere Application Server administration console.

6. “Removing Business Process Framework components from the FileNet P8
Platform environment” on page 155
After you uninstall the Business Process Framework applications, you have the
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option to completely remove the Business Process Framework from your
environment by deleting all data and configuration from the other FileNet P8
Platform components.

Uninstalling Business Process Framework Web application and
Business Process Framework operations

You can undeploy Business Process Framework Web application and its operations
with the uninstallation program or undeploy the Web application manually.

It does not matter whether the Component Manager or Process Task Manager on
the Application Engine is running or not.

To uninstall Business Process Framework Web application and Business Process
Framework operations:
1. Start or stop the Web application server:

Option Description

For JBoss Application Server on Windows
only

Shut down the Web application server.

For all other application server and
operating system combinations

Ensure that the Web application server is
running.

2. Start the uninstallation program:

Option Description

UNIX bpf_uninstall.bin

Windows bpf_uninstall.exe

Tip: For Windows, you can also start the uninstallation program from the
Windows Add or Remove Programs window.

3. Select to automatically undeploy the Business Process Framework Web
application and automatically remove the data sources and have the uninstaller
automatically perform these tasks, or manually undeploy the Business Process
Framework Web application and remove the data sources from the application
server.

4. Stop application server if it is running.
5. Delete all the cache folders for the Business Process Framework Web

Application. The location of the default cache folders for the Business Process
Framework Web Application are as follows:

Option Description

Oracle WebLogic Server bea_home/user_projects/domains/
app_domain/servers/server_name/tmp/
_WL_user

WebSphere Application Server 5.x WAS_Home\temp\node_name\servers\server1\
bpf

WebSphere Application Server 6.x WAS_Home\profiles\profile-name\temp\
node_name\server1\bpf

6. Delete the deployed Business Process Framework application directory. The
default location depends on which version of the application server you are on:
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Tip: These folders might not be deleted when the Web Application is deleted.

Option Description

WebSphere Application Server 5.x WAS_Home\installedApps\node_name\bpf

WebSphere Application Server 6.x WAS_Home\profiles\profile-name\
installedApps\node_name\bpf

Oracle WebLogic Server 8.1.x v .../.wlnotdelete/extract/
...application name

v .../upload/application name

These folders might reside under
C:/bea/user_projects/domains/mydomain/
myserver :

v .../.wlnotdelete/extract/
myserver_BPF_BPF

v .../upload/BPF

Oracle WebLogic Server 9.2.x /tmp/_WL_user/application name

These folders might reside under
C:/bea/user_projects/domains/mydomain/
servers/AdminServer: /tmp/_WL_user/BPF

7. On the Application Engine server, stop the Component Manager
BPF_Operations component by using the FileNet Process Task Manager.

8. Exit FileNet Process Task Manager.
9. Delete the BPF_install_path/FileNet/BPF and BPF_install_path/FileNet/BPF/

BPFAssembly directories.

Uninstalling Business Process Framework Explorer
You can use the Microsoft Windows Add or Remove Programs program to remove
Business Process Framework Explorer from your server.

Run this procedure on the server where Business Process Framework Explorer is
installed:
1. Open Start Menu → Settings → Control Panel → Add/Remove Programs.
2. Select FileNet Business Process Framework Explorer.
3. Select Change/Remove.

Manually uninstalling the Business Process Framework Web
application

You can bypass the automatic uninstallation and manually uninstall the Business
Process Framework Web application.

The Business Process Framework installation program removes the Web
Application automatically. Perform the manual uninstallation only if you do not
want to use the uninstallation program or the uninstallation program failed.

“Manually uninstalling the Business Process Framework Web application from
WebSphere Application Server” on page 152
You can remove the Business Process Framework on WebSphere Application
Server by uninstalling the Web application.
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“Manually uninstalling the Business Process Framework Web application from
Oracle WebLogic Server 8.1.x”
You can remove Business Process Framework by deleting the BPF module on
Oracle WebLogic Server 8.1.x.
“Manually uninstalling the Business Process Framework Web application from
Oracle WebLogic Server 9.2.x or 10”
You can remove Business Process Framework by deleting the Business Process
Framework module on Oracle WebLogic Server 9.2.x or 10.
“Manually uninstalling the Business Process Framework Web application from
JBoss Application Server” on page 153
You can remove Business Process Framework by removing the bpf.war file on
JBoss Application Server

Manually uninstalling the Business Process Framework Web
application from WebSphere Application Server

You can remove the Business Process Framework on WebSphere Application Server
by uninstalling the Web application.

To uninstall Business Process Framework:
1. Use Internet Explorer to go to the WebSphere Application Server

Administration page: http://web application server:9060/ibm/console
2. Enter your name.
3. Navigate to Applications/Enterprise Applications.
4. Select the Business Process Framework application name.
5. Click Stop.
6. Reselect Business Process Framework (or other application name you have

Business Process Framework deployed under).
7. Click Uninstall and then Save.

Manually uninstalling the Business Process Framework Web
application from Oracle WebLogic Server 8.1.x

You can remove Business Process Framework by deleting the BPF module on
Oracle WebLogic Server 8.1.x.

To delete the module:
1. Log in to WebLogic Server console from a Web browser: http://web application

server:7001/console
2. Delete module by doing the following:

a. Expand mydomain → Deployments → Web Application Modules (in
navigation tree pane).

b. Right-click BPF.
c. Select Delete BPF.
d. Click Yes.
e. Click Continue.

Manually uninstalling the Business Process Framework Web
application from Oracle WebLogic Server 9.2.x or 10

You can remove Business Process Framework by deleting the Business Process
Framework module on Oracle WebLogic Server 9.2.x or 10.

152 Installation Guide



To delete the module:
1. Log in to WebLogic Server console from a Web browser: http://web application

server:7001/console
2. (Oracle WebLogic Server 9.2.x only) Click Lock & Edit button under Change →

Center.
3. Delete the module. Click mydomain → Deployments.

a. Select BPF.
b. Click Delete.
c. Click Yes on Delete Deployments screen.
d. Click Activate Changes button under Change → Center.

Manually uninstalling the Business Process Framework Web
application from JBoss Application Server

You can remove Business Process Framework by removing the bpf.war file on
JBoss Application Server

To remove the bpf.war file:
1. Shut down JBoss Application Server.
2. Remove bpf.war from the JBOSS_HOME/server/server_name/deploy directory.
3. Remove the bpf.war cache folder JBOSS_HOME>server/server_name/work/

jboss.web/localhost/bpf.

Manually deleting data sources
The uninstallation program automatically deletes the data sources in the Web
application server. If you choose to manually remove Business Process Framework,
you must also manually delete the data sources from your Web application server.

“Manually deleting data sources from WebSphere Application Server”
You can manually delete data sources from WebSphere Application Server by
deleting the appropriate JDBC provider.
“Manually deleting data sources from Oracle WebLogic Server 8.1” on page 154
If you chose to do a manual removal of Business Process Framework, you must
also manually delete data sources in the Oracle WebLogic Server 8.1.
Administrative Console. Delete both the Metastore datasource and the Process
Engine datasource, as well as related connection pools.
“Manually deleting data sources from Oracle WebLogic Server 9.2 or 10” on
page 154
If you chose to do a manual removal of Business Process Framework, you must
also manually delete data sources in the Oracle WebLogic Server 9.2.x or 10
Administrative Console. Delete both the Metastore datasource and the Process
Engine datasource.
“Manually deleting data sources from JBoss Application Server” on page 155
You can manually delete data sources from JBoss Application Server by
removing the ms-ds.xml and ps-ds.xml files.

Manually deleting data sources from WebSphere Application
Server

You can manually delete data sources from WebSphere Application Server by
deleting the appropriate JDBC provider.

To delete the JDBC Provider:
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1. Log onto the WebSphere Application Server administrative console:
http://web application server:9060/ibm/console

2. Create JDBC Provider:
a. Click Resources → JDBC Providers.

3. Click the appropriate JDBC provider.
4. Click the Data source link.
5. Choose the Data source used by Business Process Framework.
6. Click J2EE Connecter Architecture(J2C) authentication data entries in Related

Items.
7. Delete the J2C Alias that Business Process Framework used.
8. Go back to the data source page in step2.
9. Delete the meta datasource data source which is used by Business Process

Framework.
10. Go back to Resources → JDBC Provider.
11. Delete the JDBC Provider which is used by Business Process Framework.
12. Repeat these steps to delete the process datasource.

Manually deleting data sources from Oracle WebLogic Server
8.1

If you chose to do a manual removal of Business Process Framework, you must
also manually delete data sources in the Oracle WebLogic Server 8.1.
Administrative Console. Delete both the Metastore datasource and the Process
Engine datasource, as well as related connection pools.

To log in to WebLogic Server and delete data sources:
1. Log in toWebLogic Server console from a Web browser: http://web application

server:7001/console
2. Delete data sources:

a. Expand Services → JDBC → DataSources (in navigation tree pane).
b. Right-click meta datasource.
c. Select Delete meta datasource.
d. Click Yes.
e. Click Continue.
f. Repeat the same process for the pe datasource.

3. Delete connection pools as follows:
a. Expand Services → JDBC → Connection Pools.
b. Right click meta connection pool.
c. Select Delete meta connection pool.
d. Click Yes.
e. Click Continue.
f. Repeat the same process for the pe connection pool.

Manually deleting data sources from Oracle WebLogic Server
9.2 or 10

If you chose to do a manual removal of Business Process Framework, you must
also manually delete data sources in the Oracle WebLogic Server 9.2.x or 10
Administrative Console. Delete both the Metastore datasource and the Process
Engine datasource.
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To log in to WebLogic Server and delete data sources:
1. Log in toWebLogic Server console from a Web browser: http://web application

server:7001/console
2. Click Lock & Edit button under Change → Center.
3. Delete DataSources:

a. Expand Services → JDBC → DataSources (in tree-view pane).
b. Select meta datasource in right pane.
c. Click Delete meta datasource ...

d. Click Yes on Delete JDBC Data Sources screen.
e. Click Activate → Changes button under Change → Center.
f. Repeat the same process for the pe datasource.

Manually deleting data sources from JBoss Application Server
You can manually delete data sources from JBoss Application Server by removing
the ms-ds.xml and ps-ds.xml files.

To delete data sources from JBoss Application Server:
1. Shut down JBoss Application Server.
2. Remove the ms-ds.xml and ps-ds.xml files from JBOSS_HOME/server/

server_name/deploy.

Removing the deployment file from WebSphere Application Server
For WebSphere Application Server installations only, whether you chose automatic
or manual removal of Business Process Framework, after uninstallation you must
remove additional deployment information from the WebSphere Application Server
administration console.

To remove the deployment file automatically:

In the WebSphere Application Server Administration page, click Environment →
Update Web Server Plugin → OK. This procedure automates removal of the
deployment file after you uninstall the Web application. This step must be
performed after every uninstallation.

Removing Business Process Framework components from the FileNet
P8 Platform environment

After you uninstall the Business Process Framework applications, you have the
option to completely remove the Business Process Framework from your
environment by deleting all data and configuration from the other FileNet P8
Platform components.

This is an optional portion of the uninstallation process. It is useful if you want to
completely remove an installation of Business Process Framework.

“Deleting the object store in Content Engine” on page 156
You can delete the object store in Content Engine to remove all historical case
data. Removing the object store is not recommended for production systems or
for object stores that are used by other applications.
“Deleting the object store database” on page 156
You can delete the object store database remove all historical case data.

Uninstalling Business Process Framework 155



Removing the object store database is not recommended for production systems
or for object store databases that are used by other applications.
“Deleting the metastore database”
You can delete the metastore database to remove all historical data. Removing
the metastore database is not recommended for production systems or for
metastore databases that are used by other applications.
“Deleting the Process Engine database”
You can delete the Process Engine database to remove data. Removing the
Process Engine database is not recommended for production systems or for
Process Engine databases that are used by other applications or other isolated
regions.

Deleting the object store in Content Engine
You can delete the object store in Content Engine to remove all historical case data.
Removing the object store is not recommended for production systems or for object
stores that are used by other applications.

To delete the object store:
1. Click Start → Programs → IBM FileNet P8 Platform → Enterprise Manager

SnapIn.
2. Right-click Object Stores → os display name.
3. Select Delete.
4. Click Yes.
5. Click OK on other prompts.

Deleting the object store database
You can delete the object store database remove all historical case data. Removing
the object store database is not recommended for production systems or for object
store databases that are used by other applications.

Contact the database system administrator to delete object store database.

Deleting the metastore database
You can delete the metastore database to remove all historical data. Removing the
metastore database is not recommended for production systems or for metastore
databases that are used by other applications.

Contact the database system administrator to delete the metastore database.

Deleting the Process Engine database
You can delete the Process Engine database to remove data. Removing the Process
Engine database is not recommended for production systems or for Process Engine
databases that are used by other applications or other isolated regions.

Contact the database system administrator to delete the Process Engine database.
Alternatively, you can initialize the Process Engine isolated region again from the
Process Configuration Console and reuse it.

156 Installation Guide



Notices

This information was developed for products and services offered in the U.S.A.

IBM may not offer the products, services, or features discussed in this document in
other countries. Consult your local IBM representative for information on the
products and services currently available in your area. Any reference to an IBM
product, program, or service is not intended to state or imply that only that IBM
product, program, or service may be used. Any functionally equivalent product,
program, or service that does not infringe any IBM intellectual property right may
be used instead. However, it is the user’s responsibility to evaluate and verify the
operation of any non-IBM product, program, or service.

IBM may have patents or pending patent applications covering subject matter
described in this document. The furnishing of this document does not grant you
any license to these patents. You can send license inquiries, in writing, to:

IBM Director of Licensing
IBM Corporation
North Castle Drive
Armonk, NY 10504-1785
U.S.A.

For license inquiries regarding double-byte (DBCS) information, contact the IBM
Intellectual Property Department in your country or send inquiries, in writing, to:

Intellectual Property Licensing
Legal and Intellectual Property Law
IBM Japan, Ltd.
3-2-12, Roppongi, Minato-ku, Tokyo 106-8711 Japan

The following paragraph does not apply to the United Kingdom or any other
country where such provisions are inconsistent with local law: INTERNATIONAL
BUSINESS MACHINES CORPORATION PROVIDES THIS PUBLICATION ″AS IS″
WITHOUT WARRANTY OF ANY KIND, EITHER EXPRESS OR IMPLIED,
INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
NON-INFRINGEMENT, MERCHANTABILITY OR FITNESS FOR A PARTICULAR
PURPOSE. Some states do not allow disclaimer of express or implied warranties in
certain transactions, therefore, this statement may not apply to you.

This information could include technical inaccuracies or typographical errors.
Changes are periodically made to the information herein; these changes will be
incorporated in new editions of the publication. IBM may make improvements
and/or changes in the product(s) and/or the program(s) described in this
publication at any time without notice.

Any references in this information to non-IBM Web sites are provided for
convenience only and do not in any manner serve as an endorsement of those Web
sites. The materials at those Web sites are not part of the materials for this IBM
product and use of those Web sites is at your own risk.

IBM may use or distribute any of the information you supply in any way it
believes appropriate without incurring any obligation to you.
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Licensees of this program who wish to have information about it for the purpose
of enabling: (i) the exchange of information between independently created
programs and other programs (including this one) and (ii) the mutual use of the
information which has been exchanged, should contact:

IBM Corporation
J46A/G4
555 Bailey Avenue
San Jose, CA 95141-1003
U.S.A.

Such information may be available, subject to appropriate terms and conditions,
including in some cases, payment of a fee.

The licensed program described in this document and all licensed material
available for it are provided by IBM under terms of the IBM Customer Agreement,
IBM International Program License Agreement or any equivalent agreement
between us.

Any performance data contained herein was determined in a controlled
environment. Therefore, the results obtained in other operating environments may
vary significantly. Some measurements may have been made on development-level
systems and there is no guarantee that these measurements will be the same on
generally available systems. Furthermore, some measurements may have been
estimated through extrapolation. Actual results may vary. Users of this document
should verify the applicable data for their specific environment.

Information concerning non-IBM products was obtained from the suppliers of
those products, their published announcements or other publicly available sources.
IBM has not tested those products and cannot confirm the accuracy of
performance, compatibility or any other claims related to non-IBM products.
Questions on the capabilities of non-IBM products should be addressed to the
suppliers of those products.

All statements regarding IBM’s future direction or intent are subject to change or
withdrawal without notice, and represent goals and objectives only.

All IBM prices shown are IBM’s suggested retail prices, are current and are subject
to change without notice. Dealer prices may vary.

This information is for planning purposes only. The information herein is subject to
change before the products described become available.

This information contains examples of data and reports used in daily business
operations. To illustrate them as completely as possible, the examples include the
names of individuals, companies, brands, and products. All of these names are
fictitious and any similarity to the names and addresses used by an actual business
enterprise is entirely coincidental.

COPYRIGHT LICENSE:

This information contains sample application programs in source language, which
illustrate programming techniques on various operating platforms. You may copy,
modify, and distribute these sample programs in any form without payment to
IBM, for the purposes of developing, using, marketing or distributing application
programs conforming to the application programming interface for the operating
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platform for which the sample programs are written. These examples have not
been thoroughly tested under all conditions. IBM, therefore, cannot guarantee or
imply reliability, serviceability, or function of these programs. The sample
programs are provided ″AS IS″, without warranty of any kind. IBM shall not be
liable for any damages arising out of your use of the sample programs.

Trademarks
IBM, the IBM logo, and ibm.com are trademarks or registered trademarks of
International Business Machines Corporation in the United States, other countries,
or both. If these and other IBM trademarked terms are marked on their first
occurrence in this information with a trademark symbol (® or ™), these symbols
indicate U.S. registered or common law trademarks owned by IBM at the time this
information was published. Such trademarks may also be registered or common
law trademarks in other countries. A current list of IBM trademarks is available on
the Web at http://www.ibm.com/legal/copytrade.shtml (www.ibm.com/legal/
copytrade.shtml).

Java and all Java-based trademarks are trademarks of Sun Microsystems, Inc. in the
United States, other countries, or both.

Microsoft, Windows, and Windows NT are trademarks of Microsoft Corporation in
the United States, other countries, or both.

UNIX is a registered trademark of The Open Group in the United States and other
countries.

Linux is a registered trademark of Linus Torvalds in the United States, other
countries, or both. Other company, product, and service names may be trademarks
or service marks of others.
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